General Editing in the Score Editor

This section covers basic editing methods that are used in the Score Editor. For general MIDI editing information, see Introduction to MIDI Editing.

Using Shortcut Menus in the Score Editor

Many selection, editing, and other commands can be accessed by Control-clicking in the Score Editor. Make use of these shortcut menus to accelerate your workflow.

Note: Shortcut menus can also be accessed with a right-mouse click if the Right Mouse Button:  Opens Shortcut Menu option is chosen in the Logic Pro > Preferences > General > Editing pane.

The contents of a shortcut menu change when different objects are clicked. The Score Editor provides the following shortcut menu types:

  • Notes

  • Tablature

  • Clefs

  • Key signatures

  • Time signatures

  • Bar lines

  • Background

Changing Multiple Objects in the Score Editor

If several objects are selected, the Event Parameter box title line contains “X Notes/Symbols/Events/Texts/Chords selected.” “X” indicates the number of selected objects. The terms Notes, Texts, and Chords are only used if the current selection is limited to objects of that particular type.

If, as in most cases, parameter fields are visible while multiple events are selected, all corresponding values can be edited simultaneously. When the “*” value is shown, it indicates that the selected objects have different values for that particular parameter. There are different options for changing these values:

  • Relative change (preserving differences): Grab the “*” with the mouse, and use the mouse as a slider. The value shown during this process belongs to the first of the selected objects. The other objects are altered by the same amount (while retaining their relative values). You can also double-click the value, and insert the change (a number with a plus or minus in front of it) in the entry field.
  • Absolute Change (all values set to an equal value): Hold down Option while grabbing the “*” with the mouse, and use the mouse as a slider. As soon as you move the mouse, the parameter is set to the same value for all selected objects. This allows you to set all notes of a chord to the same length or velocity, or set all selected objects to the same height (Vertical Pos), for example.
To set the vertical and horizontal position of all selected objects to the same value
  • Use any of the following key commands:

    • Align Object Positions Vertically

    • Align Object Positions Horizontally

    • Align Object Positions (affects both parameters)

These key commands set all objects to the value of the first selected object. If only one object is selected when you use one of these key commands, a dialog asks if the parameters of all similar objects should be set to the same value.

All displayed regions and instruments are affected.

Tip: This technique is very useful for aligning lyrics and chord symbols.

Moving or Copying Objects in the Score Editor with the Mouse

You can move or copy notes and symbols with the mouse, just as you can in the Piano Roll Editor.

Note: It’s easy to unintentionally change a symbol’s bar position with the Pointer tool. Choose the Layout tool to limit changes to an event’s vertical and horizontal position. See Changing the Graphical Position of Objects in the Score Editor.

To move a note or symbol with the mouse
  • Select one or more notes or symbols, then drag it to the new position.

To copy a note or symbol with the mouse
  • Select one or more notes or symbols, hold down Option, then drag it to the new position.

    Watch the help tag during this process. It shows the operation (drag or copy), the current difference from the original position (transpose and time shift), and the current cursor position (bar position and—for notes—pitch).

You can simultaneously move or copy objects from different regions or staffs. Each event is moved or copied to its new position, within the original (source) MIDI region.

Note: You cannot use the Option-drag method to copy or move events between MIDI regions in the Score Editor. You can, however, copy and paste between regions and staffs. (See Copying Objects in the Score Editor via the Clipboard.)

To restrict movement to one direction (vertical or horizontal)
  • Hold down the Shift key while dragging.

There is also a general preference for this constraint:  Logic Pro > Preferences > General > Editing > Limit Dragging to One Direction In:  Piano Roll and Score.

The Impact of the Display Quantization Parameter

Movement along the time axis (horizontal) is affected by the display quantization grid (Quantize) setting.

If a hybrid quantize value is selected (16, 24 for example), the grid corresponds to the binary value (16, in this example).

  • If note positions are not aligned with this time grid (because they were recorded in real time), their relative offset is retained when they are moved or copied.

  • You can move or copy unquantized passages within the Score Editor, without losing the original feel of the performance.

Moving Global Symbols and Symbols Attached to Notes

You cannot copy or move the following symbols in the Score Editor:

  • Global symbols, such as repeat signs, time and key signature changes—except in the Signature List and Signature track—and global text elements (headers and so on). (For additional information, see Working with Time and Key Signatures.)

  • Symbols directly attached to notes, such as accents, fermatas, note heads, and so on.

Moving Objects in the Score Editor with Key Commands

A group of key commands is found in the Nudge Region/Event Position section of the Key Commands window. These functions move all selected objects (by various steps) along the time axis. The following Nudge commands are the most useful for score work:

  • Nudge Region/Event Position Left by Bar and Nudge Region/Event Position Right by Bar: Move the selected notes forward or back one bar.
  • Nudge Region/Event Position Left by Beat and Nudge Region/Event Position Right by Beat: Move the selected notes forward or back one beat.
  • Nudge Region/Event Position Left by Division and Nudge Region/Event Position Right by Division: Move the selected events forward or back one division step (as set in the Transport bar).

Copying Objects in the Score Editor via the Clipboard

When you copy objects via the Clipboard, the first object is pasted at the target bar position. The relative positioning of other copied objects (to the first object) is retained.

You can simultaneously paste the Clipboard contents into several regions, at the original position.

To paste the Clipboard contents into several regions
  1. Select all appropriate regions (either in the Arrange area or Score Editor) by Shift-clicking the staffs/regions, or dragging to select adjacent regions.

    The Display Parameter box title line always indicates the number of regions that are currently selected. (See Transcribing MIDI Recordings.)

  2. Choose Edit > Paste Multiple (or use the Paste Multiple key command.)

Automatic Insert Quantization

When you paste (or paste multiple) objects from the Clipboard, the position of the first inserted event is automatically quantized, in accordance with the current division value (set in the Transport bar). For example, if the current bar position is, and the division value is set to 1/16, the pasted object is inserted at position, whether it’s a note or a symbol. When the Clipboard contains more than one object, their relative positions from the first object are retained.

If you don’t want this behavior (because you want to preserve the unquantized timing of the original), you are better served by other copy methods.

Pasting Passages at the Same Time Position

You can use the Paste at Original Position and Paste Multiple at Original Position commands to quickly copy passages from one MIDI region to another, at the same time position. No insert position is required, and no automatic insert quantization takes place.

To copy an entire musical passage to the same time position in another region
  1. Select the notes and symbols of the passage.

  2. Select the staff you want to paste the passage to.

  3. Choose Edit > Paste at Original Position (or use the Paste at Original Position key command).

The notes and symbols are pasted at the position they were originally copied from, regardless of the current playhead position.

The Paste Multiple at Original key command works in a similar way, but allows you to paste a musical passage to the staffs of other instruments. All destination staffs need to be selected before the Paste Multiple command is executed.

Tip: You can use these commands in combination with the Select Similar function, to quickly copy all dynamic symbols from one staff into other staffs or instruments, for example.

Deleting Objects in the Score Editor

You can only delete events that are actually displayed in the Score Editor. For example, if you erase notes from a real-time recording in the Score Editor, MIDI controller events or pitch bend data that was recorded with these notes is not deleted.

To delete an object
Do one of the following:
  • Select the object, then choose Edit > Delete (or press the Delete key).

  • Click the object with the Eraser tool.

    Figure. Eraser tool over object in the Score Editor.

Note: Repeat signs and special bar lines cannot be selected. They can only be deleted with the Eraser tool.

Repeating Events in the Score Editor

The Repeat Events command is especially useful for copying complete bars (or multiple copies), without setting any bar positions.

To copy a bar that begins with a rest on one
  1. Select all notes and symbols.

  2. Choose Edit > Repeat Events (or use the Repeat Regions/Events key command).

  3. In the Repeat Regions/Events dialog, insert the number of copies, choose Bar from the Adjustment pop-up menu, then click OK.

For more information on the Repeat Events command, see Creating Multiple Copies of Regions.

Working with Aliases in the Score Editor

Alias is a term used for dependent MIDI regions and folders in the Arrange area. Alias regions mirror other MIDI regions and folders at different positions. Wherever an alias exists, it acts as a playback marker that points to the parent (original) MIDI region or folder. It is actually the parent region (or folder)—and not the alias—that is played back.

Displaying Aliases

Aliases are also displayed in the Score Editor, and can be printed. The display of aliases can be turned on in the Global pane of the Score project settings (File > Project Settings > Score > Global).

An alias can be assigned a staff style different from its parent region. (For information on staff styles, see Working with Staff Styles.) For example, imagine a melody that you want to be played in unison by several instruments:

  • You can set up a melody to be played in unison by several instruments by creating several aliases of a regular MIDI region (the melody).

  • Different staff styles can be used for each of the different instruments, including transposing staff styles (for example, Horn in Eb, Alto Sax, and so on).

  • If you decide to change something in the melody, you don’t need to edit all copies (aliases) of it. Just make the change in the parent MIDI region, and the change is reflected automatically in all aliases.

Editing Aliases

You can directly edit the notes and symbols in an alias if the Allow Alias Editing checkbox in File > Project Settings > Score > Global is selected.

Note: Changes to aliases alter the data of the original MIDI region (and all aliases created from it), because only the original region can actually contain MIDI data.

If Allow Alias Editing is turned off and you try to edit an alias, you will be asked to either enable alias editing or create a copy of the region. Choose the appropriate option, as follows:

  • Cancel: The aliases and original MIDI region are not changed.
  • Enable Alias Editing: Alias editing is allowed; remember that this actually edits the parent MIDI region.
  • Create a Copy: A copy of the original MIDI region replaces the selected alias. You can edit the notes independently of the original MIDI region, as the selected alias is now a real region.

Changing the Graphical Position of Objects in the Score Editor

You can change the graphical position of objects to improve the layout of your score (by creating space for a grace note, for example).

Using the Layout Tool

The Layout tool (located in the Score Editor’s Tool menu) is used to graphically move events in the Score Editor, in order to optimize the display without altering the timing of MIDI events.

Figure. Layout tool.
  • Symbols and text: When symbol or text objects are moved with the Layout tool, the bar position is retained. The Horizontal Position and Vertical Position parameters, however, are changed (as indicated in the help tag during the process).
  • Notes: The Layout tool can only edit the horizontal position of a note in relation to its bar position, not its vertical position. Dragging the note to the right or left changes the displayed distance from the adjacent notes or rests. The bar position (and playback) is unaltered.

Note: The bar position determines playback timing, as this is the actual MIDI event position. Remember that the Score Editor is primarily designed to deliver notation, and that most (but not all) editing functions are graphical, rather than physical, in nature.

Using the Event Parameter Box

You can change the graphical position of Score Editor symbols and text in the Event Parameter box by editing the Vertical Position and Horizontal Position parameters.

  • Vertical Pos.: Determines the vertical position (height) above or below the staff. Zero means a position exactly on the top line of the staff, in most cases. Positive values are above, negative values below it. In staff styles with more than one staff, the Staff parameter determines the staff that the Vertical Position parameter refers to.
  • Horizontal Pos.: Determines the horizontal offset of the object’s bar position. A value of zero corresponds to the left edge of a note, at that particular position.

    Tip: To adjust a number of selected symbols to the same height above (or below) the staff, use the Align Object Positions Vertically key command.

Using Key Commands

You can use the following key commands to move any score symbol that can be positioned independently of notes or staffs, as well as text events and chord symbols:

  • Nudge Position Up

  • Nudge Position Down

  • Nudge Position Left

  • Nudge Position Right

These functions do not alter the bar position of the affected symbols and text events. They alter the Horizontal Position and Vertical Position parameters by ±1.

Resizing Notes and Symbols in the Score Editor

You can change the size of any notes, and most symbols, with the Resize tool (located in the Score Editor’s Tool menu).

Figure. Resize tool.
To change an object’s size
  • Grab the object with the Resize tool, and move the mouse up or down.

To reset an object to its original size
  • Double-click it with the Resize tool (and click OK in the dialog).