Contents

Get started with MainStage
- Getting started overview
- MainStage window
- Patches in MainStage
- Channel strips in MainStage
- Assignments and mappings
- Layouts in MainStage
- Perform mode in MainStage
- Quick Help in MainStage

MainStage basics
- What is MainStage?
- MainStage workflow basics
- MainStage interface overview
- Manage MainStage content
- How to get help

Connect external devices
- Overview of connecting external devices
- Connect MIDI devices
- Connect audio devices

Work in Edit mode
- Overview of Edit mode
- Work with patches
- Work with channel strips
- Work with plug-ins
- Route audio via send effects
- Create keyboard layers and splits
- Work with articulations
- Edit screen control parameters
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map screen controls</td>
<td>99</td>
</tr>
<tr>
<td>Work with graphs</td>
<td>109</td>
</tr>
<tr>
<td>Create controller transforms</td>
<td>112</td>
</tr>
<tr>
<td>Work in the Assignments and Mappings tab</td>
<td>114</td>
</tr>
<tr>
<td>Work with sets</td>
<td>117</td>
</tr>
<tr>
<td>Share patches and sets between concerts</td>
<td>122</td>
</tr>
<tr>
<td>Record the audio output of a concert</td>
<td>123</td>
</tr>
<tr>
<td><strong>Work with concerts</strong></td>
<td>124</td>
</tr>
<tr>
<td>Overview of concerts</td>
<td>124</td>
</tr>
<tr>
<td>Create a concert</td>
<td>124</td>
</tr>
<tr>
<td>Open and close concerts</td>
<td>125</td>
</tr>
<tr>
<td>Save concerts</td>
<td>126</td>
</tr>
<tr>
<td>How saving affects parameter values</td>
<td>127</td>
</tr>
<tr>
<td>Clean up concerts</td>
<td>127</td>
</tr>
<tr>
<td>Consolidate assets in a concert</td>
<td>128</td>
</tr>
<tr>
<td>Rename the current concert</td>
<td>128</td>
</tr>
<tr>
<td>Work with concert settings</td>
<td>128</td>
</tr>
<tr>
<td>Tempo in MainStage concerts</td>
<td>132</td>
</tr>
<tr>
<td>Control the metronome</td>
<td>134</td>
</tr>
<tr>
<td>Silence MIDI notes</td>
<td>135</td>
</tr>
<tr>
<td>Mute audio output</td>
<td>136</td>
</tr>
<tr>
<td>Work at the concert level</td>
<td>137</td>
</tr>
<tr>
<td><strong>Work in Layout mode</strong></td>
<td>143</td>
</tr>
<tr>
<td>Layout mode overview</td>
<td>143</td>
</tr>
<tr>
<td>Work with screen controls</td>
<td>144</td>
</tr>
<tr>
<td>Assign hardware controls to screen controls</td>
<td>154</td>
</tr>
<tr>
<td>Edit screen control parameters</td>
<td>156</td>
</tr>
<tr>
<td>How MainStage passes through MIDI messages</td>
<td>162</td>
</tr>
<tr>
<td>Export and import layouts</td>
<td>162</td>
</tr>
<tr>
<td>Change the aspect ratio of a layout</td>
<td>163</td>
</tr>
<tr>
<td><strong>Perform live with MainStage</strong></td>
<td>164</td>
</tr>
<tr>
<td>Before performing live</td>
<td>164</td>
</tr>
<tr>
<td>Use Perform mode</td>
<td>165</td>
</tr>
<tr>
<td>Select patches in performance</td>
<td>166</td>
</tr>
<tr>
<td>Screen controls in performance</td>
<td>168</td>
</tr>
<tr>
<td>Tempo changes during performance</td>
<td>168</td>
</tr>
<tr>
<td>Tips for performing with keyboard controllers</td>
<td>168</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Tips for performing with guitars and other instruments</td>
<td>169</td>
</tr>
<tr>
<td>Tune guitars and other instruments with the Tuner</td>
<td>169</td>
</tr>
<tr>
<td>The Playback plug-in in performance</td>
<td>171</td>
</tr>
<tr>
<td>Record your performances</td>
<td>171</td>
</tr>
<tr>
<td>After the performance</td>
<td>172</td>
</tr>
<tr>
<td>Tips for complex hardware setups</td>
<td>172</td>
</tr>
<tr>
<td><strong>MainStage settings</strong></td>
<td>173</td>
</tr>
<tr>
<td>Overview of settings</td>
<td>173</td>
</tr>
<tr>
<td>General settings</td>
<td>173</td>
</tr>
<tr>
<td>Audio settings</td>
<td>175</td>
</tr>
<tr>
<td>MIDI settings</td>
<td>178</td>
</tr>
<tr>
<td>Display settings</td>
<td>179</td>
</tr>
<tr>
<td>Sampler settings</td>
<td>181</td>
</tr>
<tr>
<td><strong>Use the Touch Bar with MainStage</strong></td>
<td>185</td>
</tr>
<tr>
<td>Touch Bar shortcuts</td>
<td>185</td>
</tr>
<tr>
<td>Customize the Touch Bar</td>
<td>191</td>
</tr>
<tr>
<td><strong>Keyboard shortcuts and command sets</strong></td>
<td>193</td>
</tr>
<tr>
<td>Overview of keyboard shortcuts and command sets</td>
<td>193</td>
</tr>
<tr>
<td>Keyboard shortcuts</td>
<td>193</td>
</tr>
<tr>
<td>Customize keyboard shortcuts</td>
<td>198</td>
</tr>
<tr>
<td><strong>MainStage actions</strong></td>
<td>202</td>
</tr>
<tr>
<td>Overview of actions</td>
<td>202</td>
</tr>
<tr>
<td>Actions table</td>
<td>202</td>
</tr>
<tr>
<td><strong>Copyright</strong></td>
<td>205</td>
</tr>
</tbody>
</table>
Get started with MainStage

Overview of getting started with MainStage

Welcome to MainStage. For users new to MainStage, this chapter provides a brief guided "walkthrough" of the application and presents some basic tasks to help you get started. For more about the design and functionality of MainStage, see What is MainStage?.

Before you start working in MainStage, you should connect the hardware equipment you plan to use, such as a keyboard controller, an audio interface, and any instruments or microphones, to your computer. Any keyboard controllers or other MIDI devices should be capable of sending standard MIDI messages. In case you’re not sure about a particular device, consult the owner’s manual or the product website. See Overview of connecting MIDI devices and Overview of connecting audio devices to learn more.

You start by opening MainStage and creating a new concert from a template. After the concert opens, you can try out patch settings to find the ones you want to use.

MainStage includes templates for different musical instruments, including Keyboards, Guitar Rigs, Drums, Vocals, and more. You can choose a concert template in the Choose Template dialog, which appears the first time you open MainStage and when you create or close a concert.

Open MainStage

- Double-click the MainStage icon in your Applications folder, or click the MainStage icon in the Dock.
Choose a concert template

1. In MainStage, choose File > New (or press Command-N).
2. In the Choose Template dialog, choose the devices you want to use for audio input and output from the Audio Input and Audio Output pop-up menus.
3. Click the instrument category on the left you want to view templates for. You can also click Quick Start and choose a simple keyboard or guitar template to start playing immediately.

   A brief description below each template describes its features and intended use.
4. Scroll through the available templates to find the one you want to use, then select it.
5. Click Choose, or double-click the template.

Choosing one of the Quick Start templates opens a new concert in Perform mode, so you can start playing immediately. Choosing any other template opens a new concert in Edit mode.

For more information about opening concerts, see Open and close concerts.

Get started with the MainStage window

The MainStage window is where you work on your concerts. You can access all of the major working areas of MainStage in the main window.

![MainStage window diagram]

When you open a concert, the workspace appears in the center of the MainStage window, showing the screen controls in the concert. The Patch List, to the left of the workspace, shows the patches and sets in the concert. Channel strips for the selected patch appear in the Channel Strips area to the right of the workspace. Below the workspace, the Patch Library is open, so you can easily audition different patch settings to find the one you want to use.

To learn more about working in the MainStage window, see The MainStage window.
Get started with patches in MainStage

In a MainStage concert, individual sounds are stored as patches. You can customize patches by adding or replacing plug-ins, editing channel strip and plug-in parameters, and adding channel strips to get the sounds you want. You can mix channel strips of different types in a single patch.

When you open a concert or select a patch, the Patch Library opens in the Patch Inspector below the workspace, showing available patch settings. You can quickly audition patch settings in the Patch Library and choose a setting for the selected patch.

You can play the selected patch using a MIDI controller (for patches with a software instrument channel strip) or with a connected electric instrument or microphone (for patches with an audio channel strip).

To learn more about working with patches, see Overview of Edit mode.

Select a patch

- Click the patch in the MainStage Patch List.

You can start playing the patch right away.

Try moving some controls on your MIDI controller to see if the screen controls in the workspace respond. Some screen controls, including the keyboard, modulation and pitch bend wheels, respond to appropriate MIDI messages without needing to be assigned or mapped.

Add a new patch

1. Click the Add Patch button (+), located in the upper-right corner of the MainStage Patch List.

The new patch appears in the Patch List, and the Patch Library is open in the Patch Inspector.

2. Select the patch setting you want to use from the Patch Library.

Patches in the Instrument folder can be used with a MIDI controller. Patches in the Audio folder can be used with an electric instrument (such as electric guitar or bass) or a microphone.

3. If the patch uses an audio channel strip, make sure the channel strip is set to use the correct audio input, then gradually raise the volume fader on the channel strip until you hear sound on the channel.

You can start playing the patch immediately using the selected patch setting.
Get started with channel strips in MainStage

Channel strips are the building blocks of your patches. You can add channel strips to a patch to create layered sounds and keyboard splits. When you add a channel strip to a patch, you choose the type of channel strip, the output, and other settings. You can mix both types in a single patch.

You can adjust channel strip output using the Volume fader, adjust pan position using the Pan knob, and mute or solo the channel strip using the Mute and Solo buttons. For audio channel strips, you can switch between mono and stereo format using the Format button. For software instrument channel strips, you can choose a different instrument from the Input pop-up menu. You can choose new channel strip settings, add and edit effects, add sends to busses, and change the output using the controls on the channel strip.

You can also define the key range for a channel strip, create transform and velocity graphs, and filter various MIDI messages to a channel strip in the Channel Strip Inspector. For more information about using channel strips in MainStage, see Overview of channel strips.

You can quickly change the instrument, effects, and other parameters for a channel strip by selecting a new setting from the Channel Strip Library. The browser shows available settings for the currently selected channel strip.

Add a channel strip to a patch

1. Make sure the patch is selected in the MainStage Patch List.
2. Click the Add Channel Strip button (+) in the upper-right corner of the Channel Strips area.
   
   Note: You can also use key commands to add channel strips. See Key Commands Overview for more information.
3. In the New Channel Strip dialog, select the type of channel strip you want to create.
4. Choose the audio output for the channel strip from the Output pop-up menu.
5. For audio channel strips, choose mono or stereo format from the Format pop-up menu and choose the audio input from the Input pop-up menu. For external instrument channel strips, also choose the MIDI input, MIDI output, and MIDI channel from their respective pop-up menus.
   
   Important: Audio channel strips can produce feedback, particularly if you are using a microphone for audio input. When you add an audio channel strip, the volume of the channel strip is set to $-\infty$dB. Gradually raise the volume fader on the channel strip until you hear sound on the channel. You can also turn on Feedback Protection in MainStage > Settings > Audio.
6. Optionally, you can add multiple channel strips to a patch by entering a number in the Number field. You can add up to the maximum number for a channel strip type.
7. Click Create.

A new channel strip appears in the Channel Strips area, highlighted to indicate that it is selected. The Channel Strip Inspector appears below the workspace, showing different parameters for the new channel strip.
8. For audio and external instrument channel strips, gradually raise the volume fader until you hear sound on the channel.

Select a new channel strip setting

1. In MainStage, make sure that the channel strip you want to change is selected (highlighted).

2. In the Channel Strip Inspector, click the Channel Strip Library tab.

   In the Channel Strip Library, channel strip settings appear as a series of folders with different instrument and usage categories. If you have GarageBand or have one or more Jam Pack collections installed on your computer, those settings appear below the built-in settings.

3. Click a category from the column on the left, then click subcategories from the columns on the right until you see the settings you want.

You can also search for channel strip settings by name and perform other functions using the Channel Strip Library. For more information about the Channel Strip Inspector, see Choose channel strip settings.
Assignments and mappings

Learn a controller assignment in MainStage

You can assign hardware controls to screen controls in the Layout Inspector, or in the Assignments and Mappings tab. Learning controller assignments is a quick and easy method for assigning hardware controls to screen controls.

Note: To be able to assign a hardware control to a screen control, the hardware control must send standard MIDI messages. For more information, see Overview of connecting MIDI devices.

Learn a new controller assignment

1. In the MainStage workspace, select the screen control you want to learn.
   The selected control appears highlighted in blue.
2. Click the Assign & Map button at the top of the workspace.
   The button glows red to indicate that the assignment process is active.
3. On your MIDI device, move the control you want to assign. Move faders and knobs through their full range of motion, and press buttons exactly three times (not too quickly) to enable MainStage to correctly learn the MIDI message types sent by these controls.
   After the assignment process, the screen control responds when you move the corresponding hardware control. This shows that the screen control is receiving MIDI input and is correctly assigned.
4. While the Assign button is red, you can learn additional controller assignments by selecting another screen control and moving the hardware control you want to assign to it.
5. When you are finished assigning controls, click the Assign & Map button again to turn off the assignment process.

For information about working in the Assignments and Mappings pane, see Overview of assignments and mappings. For information about making controller assignments in Layout mode, see Controller assignments overview.
Map a screen control in MainStage

After you have learned controller assignments for the screen controls you want to use, you can map the screen controls to the parameters in the patches you want to control when you are performing. You can also map parameters at the concert level to control master volume, view master levels, or modify concert-wide effects.

Map a screen control to a parameter

1. In the MainStage workspace, click the screen control you want to map.
   
The screen control is highlighted in blue. The Screen Control Inspector appears below the workspace, showing the parameters for the selected screen control. The Screen Control Inspector includes Attributes and Mapping tabs as well as a tab labeled Unmapped (until you map the screen control).

2. Click the Map Parameter button (or press Command-L).
   
The Screen Control Inspector opens to the Unmapped tab, showing the Parameter Mapping browser. The Map Parameter button lights red to indicate that mapping is active.

3. Do one of the following:
   
   • *To map the screen control to a channel strip parameter:* Click the control for the parameter on the channel strip in the Channel Strips area.
   
   • *To map the screen control to a plug-in parameter:* Double-click the plug-in in the Inserts section of the channel strip to open the plug-in window, then click the parameter in the plug-in window.
4. You can continue mapping additional screen controls by clicking them in the workspace and then clicking the corresponding parameters in a channel strip or plug-in window.

5. When you are finished, click the Map Parameter button again (or press Command-L again) to turn off mapping.

You can map screen controls to parameters by visually selecting parameters on channel strips or plug-in windows, or by choosing parameters in the Parameter Mapping browser. To learn how to map a screen control to a channel strip or plug-in parameter, see Map to channel strip and plug-in parameters. To learn how to map a screen control to an action, see Map screen controls to actions.

Create assignments and mappings together in MainStage

You can view and edit assignments and mappings for the selected patch, set, or concert in the Assignments & Mappings table, and create and edit assignments and mappings without leaving Edit mode.

Show the Assignments & Mappings table

In MainStage, do one of the following:

- Click the Assignments & Mappings tab at the top of the workspace (or press Shift-Command-M).
- Choose View > Select Assignments & Mappings tab.
- Press Shift-Command-M.

Click the Workspace tab at the top of the window (or press Shift-Command-W) to return to the workspace.

Create a new assignment and mapping together

1. Choose New Assignment from the MainStage Action pop-up menu.
   A new, blank row appears in the table.
2. Click the Assign & Map button.
3. Manipulate the hardware control you want to assign.
   The row is updated to show the new assignment.
4. To create a mapping, do one of the following:
   • Select a mapping parameter or action in the Screen Control Inspector.
   • Click a parameter on a channel strip or a plug-in window.
   The table is updated to show the new mapping.

**Get started with layouts in MainStage**

Each MainStage concert includes a visual interface, called a *layout*, with screen controls that you use to modify your patches in live performance. You can customize the arrangement of screen controls, and make connections between your MIDI hardware and your concert.

To work with the layout of a concert, you switch to Layout mode. In Layout mode, you can add and arrange screen controls in the workspace, and make assignments between controls on your MIDI hardware and the screen controls in your concert. Below the workspace, the Screen Controls palette contains different types of screen controls you can add to your layout. The Screen Control Inspector appears to the left of the workspace, where you can learn controller assignments and edit layout parameters.

You can drag screen controls into the workspace in any order. If you plan to perform with a keyboard controller, you might want to first drag a keyboard screen control into the workspace, position it near the center, and then drag screen controls for the faders, knobs, wheels, buttons, and other physical controls on the keyboard controller.

For more information about working in Layout mode, see Layout mode overview.

**Switch to Layout mode**

• Click the Layout button at the upper-left corner of the MainStage window.

If you are using a macOS device with a Touch Bar, you can press the Layout button on the Touch Bar to switch to Layout mode.
Add a screen control

- In MainStage, drag the screen control from the Screen Controls palette to the workspace.

  As you drag the screen control to the workspace, a white outline appears, showing where it will be added. You can use the alignment guides to align the screen control with other items in the workspace.

Get started with Perform mode in MainStage

After learning controller assignments and mapping screen controls, you can try playing your patches as you would in a performance. You can have the workspace occupy the entire screen, presenting the screen controls as large as possible for easy viewing in concert environments, or view the workspace in a window, so you can use the toolbar buttons and access other applications.

For more information about using Perform mode, see the topics in the Perform Live with MainStage chapter.

Switch to Perform mode

In MainStage, do one of the following:

- Choose View > Perform in Full Screen (or press Command-4).

  Note: By default, the Perform button opens the workspace in full screen. For information about changing the default (in MainStage > Settings > Display), see Display settings.

- Click the Perform button in the toolbar.

If you are using a macOS device with a Touch Bar, you can press the Perform button on the Touch Bar to switch to Perform mode.

View the workspace in a window

- In MainStage, choose View > Perform in Window (or press Command-3).

  You can use either workspace view to play the patches you added or modified and use the controls on your MIDI controller to modify the parameters you have mapped to screen controls.
Get started with Quick Help in MainStage

You can view a brief description of windows, commands, controls, and other elements of the MainStage interface without leaving the application or interrupting your workflow. In both Edit mode and Layout mode, Quick Help is available in the lower-left corner of the MainStage window.

For more information about using Quick Help and other ways to access information about MainStage, see How to get help.

View Quick Help

- In MainStage, choose Help > Quick Help, or press Shift-Command-H.

  Some Quick Help topics include links to more detailed information. You can access the additional information by pressing Command-Slash (/) while the pointer is over the corresponding control or area.
MainStage basics

What is MainStage?

MainStage is a music application designed for use in live performance. MainStage turns your computer into a powerful multi-instrument and effects processor that you can use on stage when you perform. Whether you sing or play a keyboard, guitar, or another instrument, you can use MainStage when you perform live.

- Using a USB or MIDI keyboard controller, you can play a wide variety of software instruments, including pianos and other keyboards, synthesizers, strings, horns, percussion, and more.
- Using an iPad, you can also play software instruments, and control other aspects of MainStage, using the Logic Remote app.
- If you play electric guitar, you can play through virtual amps and use effects such as overdrive, reverb, and compression.
- Vocalists, drummers, and other musicians can sing and play with multi-effects setups using a microphone.
- If you’re using a Mac with a Touch Bar, you can use the Keyboard on the Touch Bar to play software instruments.

In MainStage, you organize and access your sounds in concerts. A concert can store all the sounds you’ll use in an entire performance or a series of performances. In a MainStage concert, individual sounds are stored as patches, and each patch can contain one or more channel strips, each with its own instruments and effects. You can add channel strips, choose channel strip settings, add instruments and effects, and edit their parameters to customize your sounds. You can even mix channel strips of different types in a single patch.

You organize patches for a concert in the Patch List, which includes grouping them into sets, which are folders where you can store patches you want to keep together.
Each concert includes a visual interface, called a layout, with screen controls that you use to modify your patches in live performance. Screen controls include keyboards, faders, knobs, buttons, pedals, drum pads, and other hardware controls and displays. You make connections between your MIDI devices and your MainStage concert by assigning hardware controls to the screen controls in the concert, then map the screen controls to channel strip and plug-in parameters, completing the connection so you can easily manipulate the parameters for each patch in the concert.

You can also map screen controls to actions, which provide the ability to select patches, control the Tuner or metronome, provide visual feedback, and perform other functions.

MainStage lets you quickly and easily make controller assignments and parameter mappings to speed your workflow. You can customize your layout to match the controls on your MIDI hardware, to optimize the use of available screen space, or in other ways that suit your needs.

### MainStage for keyboards

If you perform using a USB or MIDI keyboard controller, you can play and control MainStage patches with software instruments using your controller. You can assign faders, knobs, buttons, and other controls on the keyboard controller to screen controls in your concert, and then map those screen controls to parameters in your patches. You can choose exactly the parameters you want to have at your fingertips for each patch and access them from your controller as you perform.

You can use MainStage with other MIDI controllers, including sustain pedals, expression pedals, foot switches, MIDI guitars, and wind controllers that send standard MIDI messages. You can also control external hardware synthesizers, and other software instruments using external instrument channel strips.

Using an iPad, you can also play software instruments, and control other aspects of MainStage, using the Logic Remote app.

### MainStage for electric guitar and bass

If you play an electric guitar, you can use MainStage as a powerful, customizable multi-effects processor. After you connect your instrument to your computer using an audio interface, you send your guitar’s audio signal to audio channel strips in your patches, where you can add effects including the Amp Designer and Pedalboard plug-ins designed specifically for use with electric guitar. You can also use EQ, compression, reverb, overdrive, and other effects in your guitar patches. You can control volume, effect blend, or expression with an expression pedal, and use a foot switch to select patches hands-free when you perform.
MainStage for vocals, drums, and other instruments

Vocalists and acoustic musicians can use MainStage by sending the audio output from a microphone connected to their computer to audio channel strips in their patches. You can use MainStage with Core Audio-compatible audio devices, such as audio interfaces and digital mixers, for input from instruments and microphones, and for audio output to speakers, monitors, a mixing board, or a public address (PA) system. In MainStage, you can access a wide range of effects in your patches.

Drummers can also use MainStage by sending the audio output from microphones to audio channel strips in their patches or by using drum pads or a virtual drum kit to control the Sampler, Ultrabeat, and percussion-oriented plug-ins.

MainStage in live performance

After you have created your custom patches in a concert, you're ready to play. In Perform mode, you can select patches and start playing instantly. MainStage switches seamlessly between patches and sustains notes from the previous patch while you start playing the newly selected one. You can view patch names, parameter values, and audio output levels in real time, adjust concert-wide effects, and control other concert-wide settings.

By default, the workspace fills your computer screen, optimizing available screen space for your onscreen layout. You can also choose Perform in Window to have the workspace fill the MainStage window, while retaining access to the Finder and to other applications.

You can use MainStage with multiple MIDI controllers, microphones, musical instruments, and other music equipment. For time-based effects such as reverb and delay, you can set a predefined tempo, use MIDI input for tempo changes, or tap the tempo as you perform.

Using an iPad, you can also play software instruments, add patches, choose patch and channel strip settings, mute and solo channel strips, adjust Smart Controls, and control other aspects of MainStage, using the Logic Remote app.

For tips and more, see the topics in the Perform live with MainStage chapter.
MainStage workflow basics

The following list shows the main steps in a MainStage workflow.

Create a concert from a template

You start by creating a new concert from a template for keyboard, guitar, vocals, or another instrument. MainStage recognizes many popular MIDI controllers and automatically assigns hardware controls on the controller to corresponding screen controls in the workspace, simplifying hardware setup. For more information, see Create a concert.

Add and edit patches to customize your sounds

You add patches for the sounds you want to play and edit the patches by adding channel strips, instruments, and effects, and adjusting their parameters to “dial in” your custom sounds. In Edit mode, you can select and play patches, choose channel strip settings, and edit channel strip and plug-in parameters. You can quickly define key ranges for channel strips to create keyboard layers and splits, scale expression and other parameters using transforms, and filter incoming MIDI messages. Your patches are “live” so you can hear the results of your edits instantly. For more information, see Overview of Edit mode.

Organize patches for easy access

In Edit mode, you can order patches in the Patch List, organize patches in sets for added flexibility, and add channel strips at the set level, so they are available with every patch in the set. For information about organizing patches, see Reorder and move patches in the Patch List. For information about creating and editing sets, see Overview of working with sets.

Customize the visual layout of your concert

In Layout mode, you arrange screen controls to create the visual layout for the concert. Screen controls include keyboards, knobs, faders, and other hardware controls, as well as controls to display parameter and system information, text and images, and a patch selector. You can group controls and add grouped controls to your layout. For more information, see Screen controls overview.

Make connections between MainStage and your music hardware

In Layout mode, you connect hardware controls on your MIDI devices to screen controls in your layout by assigning the hardware controls to screen controls. You can move and resize screen controls in the workspace, and customize the visual display of parameter values and other information. You only need to make controller assignments once for an entire concert, minimizing the amount of work required to connect your hardware with your computer. For more information, see Controller assignments overview.
Map screen controls to the parameters you want to control

Edit mode is where you map screen controls to channel strip parameters. You can map the parameters you want to modify for each patch to easily control them from your hardware when you perform live. You can also map screen controls to MainStage actions, such as selecting the next patch to play. For more information, see Map to channel strip and plug-in parameters.

You don’t need to follow these steps in a strict order; however, in most cases you may want to create your layout before making hardware assignments and make hardware assignments before you map screen controls. If you use a concert template without significantly modifying its layout, you can concentrate on editing and organizing your custom patches and mapping their parameters to the screen controls in your layout.

MainStage interface overview

The basics of the MainStage window

You do all your work in MainStage in a single window. The MainStage window makes it easy to work with your patches and your concert’s layout. When you open MainStage, the workspace fills the center of the window, with inspectors and other editing areas on the sides and below. When you are ready to perform, you can choose Perform mode to maximize computer performance and display space for easy viewing on stage.

The main features of the MainStage window include:

- **Toolbar:** Includes buttons for quick access to common commands and tools.
- **Activity Monitor:** Shows your computer’s processor and memory usage, and shows the input from your MIDI devices as you edit and perform.
• **Workspace:** The “canvas” where you customize your onscreen layout, assign hardware controls to screen controls, and view your concerts while you perform. You can also view assignments and mappings for the concert.

• **Screen controls:** The onscreen objects that correspond to the controls on your hardware devices. You can add and arrange screen controls in the workspace, assign hardware controls to screen controls, and then map them to parameters you want to control for each patch in your concert.

• **Channel strips:** Channel strips are where you build and customize your sounds. MainStage channel strips feature Insert, Sends, and I/O menus as well as level meters, faders, pan knobs, and other controls.

• **Inspectors:** Inspectors appear below (in Edit mode) or along the left side of the MainStage window (in Layout mode) when you select different items onscreen. The inspectors allow you to edit parameters and attributes for patches, sets, screen controls, channel strips, and the concert. Most inspectors feature tabs that make it easy to quickly access the parameters you want to edit.

To make working easier, MainStage features three different modes, each suited to a different task. Some features are common to all modes, while others are exclusive to a particular mode.

• You audition, edit, and organize your sounds and map screen controls in **Edit mode**.

• You customize the visual arrangement of controls onscreen and make controller assignments in **Layout mode**.

• You use **Perform mode** when you perform live.

**The basics of Layout mode in MainStage**

Layout mode is where you customize your onscreen layout. You drag screen controls into the workspace and arrange them onscreen to customize your layout. You can also make connections between your MIDI hardware and your concert in Layout mode, by creating **controller assignments** between your MIDI hardware and the screen controls.
• **Screen Control Inspector**: View and edit parameters for screen controls in the workspace, including hardware input, appearance, and certain types of MIDI output parameters.

• **Screen Controls Palette**: Drag screen controls from the palette into the workspace to add them to your onscreen layout. The palette has four tabs so that you can view all screen controls or only one type of screen control. Panel controls appear as two-dimensional objects in the workspace, while shelf controls appear on an adjustable three-dimensional shelf. The Smart Controls screen control adapts the controls available depending on what patch you select.

In Layout mode, unlike the other modes in MainStage, you cannot select or edit individual patches.

For information about working in Layout mode, see [Layout mode overview](#).

### The basics of Edit mode in MainStage

Edit mode is where you create, edit, and organize your sounds. You can add patches, add and edit channel strips, create keyboard layers and splits, and edit channel strip and plug-in parameters. You also map screen controls to channel strip parameters and actions and edit patch, set, and concert-level parameters in Edit mode.

- **Patch List**: Shows the patches and sets in the concert. You can add patches and sets to the Patch List, name them, and organize them. The Patch List includes an Action pop-up menu with commands to create patches and sets, reset program change numbers, skip items, and import and export patches and sets to use in other concerts.

- **Inspector**: View and edit parameters for the currently selected patch, channel strip, screen control, set, or for the concert. The name of the inspector indicates the type of item you are currently inspecting.
• **Channel Strips area:** View and edit the channel strips in your patches or at the concert or set level. Channel strips appear in a vertical format with volume, pan, and other mixer controls. You can also add channel strips and save channel strip settings.

• **Assignments & Mappings tab:** Shows the assignments and mappings for the selected patch, set, or concert. You can create new assignments and mappings, edit existing ones, and edit the hardware input settings for an assignment.

For information about working in Edit mode, see *Overview of Edit mode.*

**The basics of Perform mode in MainStage**

By default, Perform mode opens in full screen. The workspace fills your entire computer display so that your screen controls are as large as possible for maximum readability. Perform in Full Screen optimizes your display for live performance when you want to use MainStage exclusively while you play.
You can choose to have Perform mode open in a window rather than full screen. The toolbar remains visible so that you can switch modes using the Mode buttons, use the Panic or Master Mute button and the Tuner, and view CPU and system memory levels and MIDI input in the Activity Monitor. The browsers and inspectors are hidden to maximize the size of the workspace, making screen controls larger and easier to read in onstage situations. You can still access the Finder and switch to other applications but cannot open plug-in windows.

Perform mode disables OS-level Auto Save, Spotlight, and Time Machine.

To learn about performing live with MainStage, see *Before performing live* and the following sections in the Perform live with MainStage chapter.

**Customize the MainStage window**

**Customize the toolbar in MainStage**

By default, the toolbar includes a selection of buttons and a display meter chosen to be universally useful. However, you can customize the toolbar for your own personal workflow. Also, though the toolbar is also configured to show only icons, you can configure the toolbar to show both icons and text. You can customize the toolbar in any mode (Layout, Edit, or Perform in Window) in which the toolbar is displayed.

**Configure the toolbar to show icons and text**

- In MainStage, Control-click anywhere in the toolbar, then choose Icon and Text from the shortcut menu.

  Descriptive text appears under each button.

  ![Toolbar Icons and Text Example](image)

**Configure the toolbar to show icons only**

- In MainStage, Control-click anywhere in the toolbar, then choose Icon Only.
Customize the toolbar

1. In MainStage, Control-click anywhere in the toolbar, then choose Customize Toolbar.

   A window containing all the available toolbar buttons appears under the toolbar.

   ![Customize Toolbar window](image)

2. Drag each button that you want to appear in your toolbar from the customize toolbar window onto the toolbar in the location that you want the button to appear.

   Note: You can also use the customize toolbar window to rearrange the buttons that are already on the toolbar, or to revert to the default set of buttons.

3. If you want to change whether the toolbar shows the icon only or icon and text, you can select one or the other in the Show pop-up menu of the Customize Toolbar window. If you don’t want to change the current display setting, you can skip this step.

Resize the workspace in MainStage

You can adjust both the size of the workspace to give more room to the Patch List, the inspector, and the Channel Strips area.

**Resize the workspace horizontally**

1. In MainStage, move the pointer to the space between the workspace and the inspector.

   The pointer becomes a resize pointer.

2. Drag up or down to resize the workspace.

**Resize the workspace vertically**

1. In MainStage, move the pointer to the space between the workspace and the Channel Strips area.

   The pointer becomes a resize pointer.

2. Drag left or right to resize the workspace.

Show or hide working areas in MainStage

You can customize the MainStage window to suit your way of working. In Edit mode, you can show or hide the inspectors, the Channel Strips area, or the workspace. You can also show or hide all open plug-in windows.
Hide the inspectors
In MainStage, do one of the following:
• Choose View > Hide Inspectors (or press Command-5).
• Click the Inspectors button on the toolbar.

Show the inspectors
In MainStage, do one of the following:
• Choose View > Show Inspectors (or press Command-5 again).
• Click the Inspectors button on the toolbar.

Hide the Channel Strips area
In MainStage, do one of the following:
• Choose View > Hide Channel Strips (or press Command-6).
• Click the Channel Strips button on the toolbar.

Show the Channel Strips area
In MainStage, do one of the following:
• Choose View > Show Channel Strips (or press Command-6 again).
• Click the Channel Strips button on the toolbar.

Hide the workspace
• In MainStage, choose View > Hide Workspace (or press Command-7).
  To show the workspace when it is hidden, choose View > Show Workspace (or press Command-7 again).

Hide all open plug-in windows
• In MainStage, choose View > Hide Plug-ins (or press V).
  To show the plug-in windows when they are hidden, choose View > Show Plug-ins (or press V again).

Switch between the Assign & Map and Workspace tabs
In MainStage:
• To switch to the Assign & Map tab: choose View > Select Assign & Map tab.
• To switch to the Workspace tab: choose View > Select Workspace tab.
Manage MainStage content

MainStage features an extensive Sound Library of Apple Loops, patches, drum kits, and other content that you can use in your projects. When you install MainStage, essential sounds and instruments are included as part of the installation. Additional content is available to download after the installation is complete.

You can view available content and select content to download in the Sound Library Manager. Some items in the Sound Library Manager have a disclosure arrow, which you can click to show and select individual content types to download. You can also download updated sounds and reinstall the complete Sound Library using the Sound Library Manager. Updated sounds are indicated in the Sound Library Manager and can be downloaded.

Additionally, in the Patch Library, items requiring additional content are indicated by an icon 📦. You can download the content needed for the item by clicking its icon.

Additional content is required to use some sounds and other features. When you select an item that needs additional content, a dialog appears, asking if you want to download it. In the Drum Kit Designer plug-in, drum kits not yet installed include a Download button that opens the Additional Content window.

Content types

The Sound Library includes the following types of content:

- Apple Loops
- Drum kits
- Patches
- Plug-in settings
- Sampler instruments and their associated samples
- Impulse responses
- Legacy and compatibility content, including Jam Packs, sounds, and instruments

Content locations

MainStage installs Sound Library content in several different locations on your computer:

<table>
<thead>
<tr>
<th>Content type</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apple Loops</td>
<td>/Library/Audio/Apple Loops/Apple/</td>
</tr>
<tr>
<td>Impulse responses</td>
<td>/Library/Audio/Impulse Responses/Apple/</td>
</tr>
<tr>
<td>Patches</td>
<td>Patches are stored inside MainStage. They may be added, updated, or removed when a new version is installed.</td>
</tr>
<tr>
<td>Plug-in settings</td>
<td>Plug-in settings are stored inside MainStage and in /Library/Application Support/Logic/Plug-In Settings.</td>
</tr>
<tr>
<td>Sampler instruments</td>
<td>/Library/Application Support/Logic/Sampler Instruments</td>
</tr>
<tr>
<td>Samples</td>
<td>• /Library/Application Support/Logic/Alchemy Samples</td>
</tr>
<tr>
<td></td>
<td>• /Library/Application Support/Logic/EXS Factory Samples</td>
</tr>
<tr>
<td></td>
<td>• /Library/Application Support/Logic/Ultrabeat Samples</td>
</tr>
</tbody>
</table>
Relocating the Sound Library

You can relocate the Sound Library to another compatible volume or partition, provided enough free space exists for the Sound Library. When you relocate the Sound Library, all Sound Library content except for Apple Loops and Impulse Responses are moved to the new location. User-created content is not affected.

Relocating the Sound Library to an external drive can free up a large amount of disk space on your system drive. If you change your mind or decide you no longer want to keep the content in another location, you can relocate the Sound Library back to its original location. When you install additional content after relocation, it is installed in the new location. For detailed information on relocating content and possible issues, see the Support article Move Logic Pro and MainStage content on the Web.

Note: Other Apple music creation apps such as Logic Pro and GarageBand share the same Sound Library location. When you relocate the Sound Library, it is also relocated for these apps if they are installed on your computer.

Reinstalling the Sound Library

You can reinstall the Sound Library. This can be useful to make sure you have the latest version of all available content, and also in case the drive containing the Sound Library is no longer available.

If the Sound Library is available in its current location when you reinstall it, it is reinstalled in the same location. If the Sound Library is not available (for example, if it is installed on an external drive that is lost, or not connected to your computer), it is reinstalled in the default location on your system drive.

Deleting MainStage content

You can view and delete MainStage content by choosing About This Mac from the Apple menu, clicking Storage, then clicking the Manage button for your system storage drive. Content for MainStage (as well as other music creation applications, including Logic Pro and GarageBand) is listed in the Music Creation section. You can view the capacity of the Instrument Library and Apple Loops library and delete each of these items.

If you delete MainStage content that is required for a patch or software instrument, MainStage prompts you to re-download that content the next time you try to use the patch or instrument.

Open the Sound Library Manager

• Choose MainStage > Sound Library > Open Sound Library Manager.

Select and download additional content

1. In MainStage, do one of the following:
   • In the Additional Content window, select the checkbox for each content package you want to download.
   • To download all installed content, click the Select All Uninstalled button.
2. Click Install.
Download all available sounds
- Choose MainStage > Sound Library > Download All Available Sounds.

Relocate the Sound Library
1. Choose MainStage > Sound Library > Relocate Sound Library.
   The Relocate Sound Library window opens, showing available drives and the free space available on each. Unsuitable drives are greyed out, with the reason for their unsuitability shown in the Comments column.
2. Select the new Sound Library location, then click Relocate.
   The Sound Library is relocated to the selected location. If other music creation apps such as Logic Pro or GarageBand are open, you are asked to close them before relocation can proceed.
   When relocation is complete, the Relocate Sound Library window closes.

Reinstall the Sound Library
- Choose MainStage > Sound Library > Reinstall Sound Library.
While additional content is downloading, a progress bar appears in the right side of the toolbar. You can view more detailed information about the progress of the download by clicking the progress bar.

How to get help for MainStage
MainStage provides several ways for you to get answers to questions, learn about controls and functions while you're working, and view detailed information about all aspects of the application. You can also view information directly in the application using the Quick Help feature.

In addition to being available from the MainStage Help menu, the full suite of help documents is available online in HTML and ePub formats.

Quick Help
You can view a brief description of windows, commands, controls, and other elements of the MainStage interface without leaving the application or interrupting your workflow.
- To view Quick Help in the main window, do one of the following:
  - Click the Quick Help button in the control bar.
  - Choose Help > Quick Help (or press Shift-Command-H).

MainStage Help
Describes the MainStage interface, commands, and menus and gives step-by-step instructions for creating MainStage concerts and for accomplishing specific tasks.
- To view MainStage Help from within MainStage, choose Help > MainStage Help.
- To view MainStage Help online, browse to https://support.apple.com/guide/mainstage.
- To view MainStage Help in other available formats, use the links at the bottom of the page, or search for MainStage User Guide in the store in Apple Books.
MainStage Instruments
Provides comprehensive instructions for using the powerful collection of instruments included with MainStage.

- To view the MainStage Instruments guide in MainStage, choose Help > MainStage Instruments.
- To view the MainStage Instruments guide in other available formats, use the links at the bottom of the page, or search for MainStage Instruments in the store in Apple Books.

MainStage Effects
Provides comprehensive instructions for using the powerful collection of effects included with MainStage.

- To view the MainStage Effects guide in MainStage, choose Help > MainStage Effects.
- To download the MainStage Effects guide in other available formats, use the links at the bottom of the page, or search for MainStage Effects in the store in Apple Books.

View Smart Help on Logic Remote
You can use the Logic Remote app to view detailed Help information on your iPad while you work in MainStage, as well as control many aspects of MainStage. The Logic Remote app is available on the App Store, or you can download it directly from within MainStage by choosing MainStage > Download Logic Remote.

When you open Smart Help in Logic Remote, you can access Help information about the MainStage interface, commands, and menus, including step-by-step instructions for using MainStage on your Mac, while you are working, simply by placing the pointer over different parts of the interface.
Connect external devices

Overview of connecting external devices to MainStage

You can use MainStage with a wide variety of MIDI controllers and Core Audio-compliant audio devices. The following sections provide basic setup information for using MIDI and audio devices with MainStage.

MainStage is a 64-bit application. Real-time generation and processing of digital audio requires intensive processing by your computer. If you plan to work on large or complex projects, using a computer with a faster processor and extra random-access memory (RAM) installed can facilitate your productivity. Additional RAM is useful particularly when using a large number of effects plug-ins and when playing sample-based software instruments. It is recommended that you do not run other processor- or RAM-intensive applications simultaneously with MainStage, particularly when performing live.

In Perform mode (both Perform in Window and Perform in Full Screen), Time Machine backups are disabled automatically. This avoids any impact on your performance.

Connect MIDI devices

Overview of connecting MIDI devices to MainStage

MainStage works with many USB and MIDI keyboard controllers and with MIDI devices such as foot pedals and switches. MIDI devices must send standard MIDI control messages. MainStage receives standard MIDI messages, and can be used to control external MIDI devices using external MIDI instrument channel strips.

Controller presets

Some keyboard controllers allow you to choose different presets or “scenes” that reconfigure the messages sent by the controls on the device. In most cases, you should choose a generic preset that sends standard MIDI messages rather than system exclusive messages or messages intended for a particular application. After you have assigned hardware controls to screen controls in MainStage, do not change the preset on the MIDI device, or your assignments might be lost.
In some cases, you can change the message type the controller sends by choosing a different preset or by reprogramming the device. Some devices may include software that you can use to reprogram knobs, buttons, and other controls. For information about reprogramming a MIDI device, see the documentation that came with the device.

**MIDI devices that support automatic configuration**

MainStage can automatically configure the screen controls in a concert to support many popular MIDI controllers. If you are using a device that supports automatic configuration, MainStage alerts you to select the appropriate preset on your device when you open a new concert. After you select the preset on your MIDI device, the screen controls in the concert are assigned to the corresponding controls on your hardware device so you can use them in MainStage with no further configuration.

**MIDI devices that send special MIDI message types**

Certain types of hardware controls such as knobs (rotary controls) and buttons are capable of sending several types of MIDI messages. When you assign these controls to MainStage screen controls using the Learn process, MainStage analyzes the incoming MIDI data to determine which type of message the hardware control is sending. In order for MainStage to learn these controls correctly, be sure to turn knobs through their full range of motion and to press buttons exactly three times during the Learn process.

Some MIDI controllers can send nonstandard or proprietary MIDI messages. MainStage cannot process or respond to nonstandard MIDI messages, to “registered” or “non-registered” parameter messages, or to system exclusive (SysEx) messages. MainStage can process some system real-time messages and MIDI Machine Control (MMC) messages when you assign a hardware control that sends these messages to a screen control.

Some devices have buttons that send program change messages. You can use these buttons to send program change messages to MainStage, but you cannot assign them to control other parameters using MainStage screen controls.

**Connect a USB music keyboard to MainStage**

You can connect a USB music keyboard to your computer to play software instrument patches or to use with external MIDI devices such as synthesizers or sound modules.

**Connect a USB music keyboard to your computer**

*If the keyboard has a USB port:* Connect the USB cable from the keyboard to your computer.

Be sure to follow the instructions that came with the keyboard, which may include installing the correct driver on your computer. Check the manufacturer’s website for the latest driver software. If you are using a MIDI interface, be sure to follow the instructions that came with the interface.
Connect MIDI keyboards and modules to MainStage

You can connect a MIDI keyboard to your computer to play software instrument patches or to use with external MIDI devices such as synthesizers or sound modules.

When you connect a device with MIDI In and MIDI Out ports, be sure to connect the MIDI Out port to a MIDI In port on a MIDI interface, and connect the MIDI In port on the keyboard to a MIDI Out port on the MIDI interface using MIDI cables.

Connect a MIDI keyboard

Do one of the following:

• For keyboard controllers without tone generators: You only need to connect the MIDI Out port of the keyboard to a MIDI In port on your MIDI interface, using a MIDI cable.

• For keyboards with tone generators: You should also connect the MIDI Out port of the MIDI interface to the keyboard MIDI In port. If your MIDI interface offers more than one MIDI output, connect any other tone generators (or other MIDI devices, such as control surfaces that require bidirectional MIDI communication) to these.
• If your MIDI interface has a single MIDI output: You need to connect the MIDI In of the second tone generator to the keyboard MIDI Thru port. A third device can be connected to the MIDI Thru port of the second unit, and so on.

The MIDI Thru port replicates the signals coming into the MIDI In port of the device. It is preferable to use a direct connection from the computer MIDI Out port to a device, rather than chaining too many units, one after the other. Doing so can cause timing problems in the chain, if numerous MIDI commands are sent quickly. This is due to the slight delays introduced by each MIDI In to MIDI Thru transaction. As such, a multi input/output MIDI interface is recommended in studios with several MIDI tone generators and controllers.

Connect Multichannel MIDI devices to MainStage

Multi-timbral MIDI devices can simultaneously receive MIDI data on multiple MIDI channels. Each MIDI channel can be assigned a tone or sound, such as piano, strings, bass, and so on.

To take full advantage of the capabilities of such multi-timbral devices, you should use separate MIDI Out ports (from the computer MIDI interface to the MIDI In ports) for each device.

MainStage is capable of channelizing MIDI data (routing it to MIDI channels 1 to 16) and sending the channelized data to specific MIDI Out ports.

In effect, having a multi-output MIDI interface is something like having more MIDI channels. In this scenario, it would be like having 64 independent MIDI channels—with 16 channels per port (A, B, C, and D).

Not only does this allow you to play up to 64 different sounds simultaneously through your tone generators, it also allows full MIDI control for each channel of each device. This becomes increasingly important when arranging and orchestrating such a large number of instrument parts.

If your computer offers several MIDI inputs, you can connect the MIDI outputs of other MIDI expanders and controllers to it.
Turn off internally generated sounds in MainStage

If your MIDI keyboard is also a sound generator, you may want to stop the device from generating its own sounds while you use it with MainStage, to avoid doubling notes between the device and the MainStage patch you’re playing.

Most MIDI synthesizers and other MIDI controllers with tone generation capabilities include a function known as Local Control. By turning off this function, the device’s internal tone generation is suppressed.

Suppress a device’s internally generated sounds

On the device, turn on the Local Off function.

If you can’t find the Local Off function in the MIDI menu of your keyboard, consult its manual on sequencer use. Some keyboards allow you to select from Local, MIDI, or Both for each of their Parts (individual MIDI channels/sounds in multi-timbral MIDI devices). The MIDI setting, if applicable to your keyboard, is the equivalent of Local Off.

Connect audio devices

Overview of connecting audio devices to MainStage

MainStage works with Core Audio-compliant audio devices, including USB, Thunderbolt, FireWire, and PCI audio interfaces. You can connect microphones, electronic musical instruments, and other musical equipment to your computer, or to an audio interface, and use them with MainStage. For information about choosing audio drivers (in MainStage > Settings > Audio), see Audio settings.

MainStage can require a large amount of available RAM to play sample-based software instruments or when you are using complex effects setups. It is recommended that you test your system and the concerts you plan to use before you perform with MainStage to make sure there is enough available memory to select and play the patches you want to use without causing audio drop-outs or distortion.

Connect a microphone to MainStage

You can connect a microphone to your computer to capture your voice, an instrument, or any other sound to use as audio input when you perform. You can connect a microphone to your computer’s audio input port, a USB port, or to an audio interface connected to your computer. You can also use the built-in microphone in your computer.

Connect a microphone to your computer

Do one of the following:

• Connect the microphone to an input on the audio interface using a standard XLR cable.
• Connect a USB microphone to a USB port on your computer. Choose the USB microphone as the audio input source in MainStage > Settings > Audio, then choose the input from the Input pop-up menu on audio channel strips in your concert.

• Connect an audio interface to your computer’s Thunderbolt or USB port, then connect a microphone to the audio interface.

• Connect an audio mixer or console to an audio interface, then connect the interface to your computer.

• If your computer has an audio input port, connect the microphone to the audio input port, then choose Built-in Input as the audio input source in MainStage > Settings > Audio.

• If you are using your computer’s built-in microphone, choose Built-in Microphone as the audio input source in MainStage > Settings > Audio. No additional steps are necessary to connect the microphone.

If you connect a microphone using an audio interface, choose the port to which it is connected as the audio input source in MainStage > Settings > Audio.

Also, if you connect an audio interface to your computer, check the manufacturer’s specifications to make sure the interface is compatible with macOS and Core Audio. Also make sure the audio interface uses a format supported by your computer. Follow the manufacturer’s instructions, which might include installing the correct driver on your computer.
Connect an electric instrument to MainStage

You can connect an electric instrument, such as an electric guitar or a bass, to your computer to use with MainStage. You can set the guitar as the audio input for patches with an audio channel strip and use the amps and pedalboard effects to shape your guitar sound. There are several ways to connect an electric instrument to your computer.

Connect an electric instrument to your computer

Do one of the following:

- Connect an audio interface to your computer’s Thunderbolt or USB port, then connect an electric instrument to the audio interface.

- Connect the electric instrument to a channel on the audio interface or the adapter cable, using a standard 1/4-inch instrument cable.

- If your computer has an audio input port, connect an electric instrument to the audio input port using an adapter cable. Choose Built-in Input as the input source.

After you connect an electric instrument, you choose the port to which it is connected as the audio input source in MainStage > Settings > Audio.

Also, if you connect an audio interface to your computer, check the manufacturer’s specifications to make sure the interface is compatible with macOS and Core Audio. Also make sure the audio interface uses a format supported by your computer. Follow the manufacturer’s instructions, which might include installing the correct driver on your computer.

Connecting some electric instruments, such as electric guitars, to your computer’s audio input port may result in a low-level input signal. To increase the input signal, you can connect the guitar to a preamplifier and connect the preamplifier to your computer.

Connect an audio interface to MainStage

Using an audio interface, you can connect microphones, instruments, and other music equipment to your computer for use with MainStage. You can also connect a mixer, speakers or monitors, headphones, and other equipment to hear the audio output from your concert.
MainStage supports plug-and-play for audio interfaces, making it possible to connect and turn on a new audio interface while MainStage is open. An alert appears when you connect a new device and prompts you to select and confirm the audio interface and driver that you want to use.

When considering an audio interface for your computer, check the manufacturer’s specifications to make sure the interface is compatible with macOS and Core Audio. Also make sure the audio interface uses a format supported by your computer.

All digital audio interfaces can be susceptible to **latency**—a noticeable delay between the time the audio signal is produced and when you hear it. Always attach your audio interface directly to the computer, rather than through a hub or daisy-chaining it through another device. Doing so can cause an unacceptable amount of latency, particularly with slower USB 1.1 devices.

**Connect an audio interface to your computer**

Do one of the following:

- Connect an audio interface to your computer’s Thunderbolt or USB port.

  ![Thunderbolt connector](image1)

  ![USB connector](image2)

  ![USB-C connector](image3)

- Connect an audio interface to a PCIe (Peripheral Component Interconnect Express) card installed in your computer. PCIe provides extremely high bandwidth and fast data transfer rates, allowing audio input and output at the highest possible sample rates and bit depths.

Follow the manufacturer’s instructions, which might include installing the correct driver on your computer. After connecting an audio interface to your computer, be sure to choose the audio interface as the audio input source in MainStage > Settings > Audio. After choosing the audio interface as the input device, you can set the individual inputs on the audio interface as the input source for the audio channel strips in your concert.

**Connect speakers and other audio devices to MainStage**

You can connect speakers or monitors to your computer to hear your projects with better audio quality. A variety of speakers is available that you can connect to your computer or to your audio interface. How you connect them depends on your system and the type of speakers you use.

After connecting speakers or monitors to your computer, be sure to set them as your audio output in MainStage > Settings > Audio. For details, see Audio settings.
Work in Edit mode

Overview of Edit mode in MainStage

Edit mode is where you add, edit, and manage patches to create your custom sounds and organize them in your concert. Tasks you can perform in Edit mode include the following:

- Choose patch settings in the Patch Library
- Add, select, and organize patches in the Patch List
- Edit patch attributes, including time signature, tempo, tuning, and others
- Map screen controls to parameters and actions

Patches are the individual sounds you play using your MIDI controller and the effects setups you use with your microphone, electric guitar, or other instrument. MainStage patches can contain one or more channel strips, each with a different instrument or effects setup.

If MainStage is in Layout or Perform mode, you first switch to Edit mode to begin working.

Switch to Edit mode

- Click the Edit button in the top-left corner of the MainStage window (or press Command-2).

While you are working in Edit mode, you can use the Activity Monitor in the toolbar to view the current CPU and system memory information, as well as received MIDI messages. You can show or hide the CPU and memory meters in MainStage > Settings > Display. For information, see Display settings.
Work with patches

Select patches and sets in the MainStage Patch List

You access patches in a concert by selecting them in the Patch List. You can play the selected patch using a MIDI controller (for patches with a software instrument channel strip) or with a connected electric instrument or microphone (for patches with an audio channel strip).

All of the patches and sets in a concert appear in the Patch List. The patch number appears to the left of the patch icon in the Patch List. In Patch Selection mode, you can easily search for patches by typing the patch number or the first few letters of the patch name.

You can also skip patches or sets in the Patch List. When you skip a patch or set, using the Command key together with the arrow keys to select items passes over the patch or set and the next (non-skipped) item is selected. However, you can still select the item by clicking it or using just the arrow keys. Skipped items are also skipped when you use the patch selector in Perform mode.

Select a patch in the Patch List

1. In the MainStage Patch List to the left of the workspace, click the patch.

2. With the patch selected, you can start playing instantly.

Select multiple patches in the patch list

In MainStage, do either of the following:

- To select consecutive patches: Click the first patch you want to select in the Patch List, then Shift-click the last patch in the patch list you want to select. All patches between the two patches will be selected.

- To select multiple, nonconsecutive patches: Command-Click the patches you wish to select.

You can play only one of the selected patches at a time (the first patch you have selected in the Patch List).
Select a patch using key commands

In MainStage, do any of the following:

- **To select the previous (higher) patch:** Press the Up Arrow key.
- **To select the next (lower) patch:** Press the Down Arrow key.
- **To select the previous patch:** Press Command–Up Arrow.
- **To select the next patch:** Press Command–Down Arrow.
- **To select the first patch in the previous set:** Press Command–Left Arrow.
- **To select the first patch in the next set:** Press Command–Right Arrow.

*Note:* When you use the Command–Arrow key commands listed above to select different patches, the selected screen control remains selected in the workspace. This makes it easy to see how a screen control is configured in different patches.

Select a patch by typing its patch number

1. In MainStage, click the border of the Patch List to select it.
2. Press F to enter Patch Selection mode.
3. With the Patch List selected, type the patch number.

*Note:* If you select another part of the interface after selecting a patch, you'll need to follow all three steps to select another patch by typing its number. However, if the Patch List is still selected, you can skip step one.

Select a patch or set by name

1. In MainStage, click the border of the Patch List to select it.
2. Press F to enter Patch Selection mode.
3. With the Patch List selected, start typing the name of the patch or set. After you type enough letters to uniquely identify it, the patch or set is selected.

*Note:* If you select another part of the interface after selecting a patch, you'll need to follow all three steps to select another patch by typing its name. However, if the Patch List is still selected, you can skip Step One.

You can also select a patch by typing its name in Perform mode. For information, see [Select patches by typing](#).

Select a patch while keeping workspace focus

Normally when you select a patch, the screen controls in the workspace change to reflect the new patch selection and the window focus changes to the Patch List. However, sometimes when working with screen controls in the workspace you may want to hear how your changes affect other patches and keep the window focus on the workspace and screen control you have selected. This keyboard shortcut lets you change patches without losing your current screen control selection and workplace focus.

- **Option-select a patch in the MainStage Patch List.**
Skip a patch or set
1. In MainStage, select the patch or set in the Patch List.
2. Choose Skip from the Action pop-up menu 🗑️ in the Patch List.
   
   The item appears as a thin line in the Patch List.

Set a skipped patch or set to no longer be skipped
1. In MainStage, select the item (patch or set) in the MainStage Patch List.
2. Choose Don’t Skip from the Action pop-up menu 🗑️ in the Patch List.
   
   The item returns to full size in the Patch List.

Note: You can select multiple patches in the Patch List, and edit the parameters common to all the selected patches. The heading “Multiple Selection” appears in the header of the Patch List, and only parameters shared by all the selected patches are available.

Copy, paste, and delete patches in MainStage
You can copy, paste, and duplicate patches in the Patch List using the standard macOS menu and key commands, or by Option-dragging. When you paste or duplicate a patch, it includes any mappings made to parameters in the original patch. You can also delete a patch if you no longer want to use it in the concert.

Copy a patch
1. In MainStage, select the patch in the Patch List.
2. Choose Edit > Copy (or press Command-C).

Paste a patch
• In MainStage, after copying a patch, choose Edit > Paste (or press Command-V).

Delete a patch
1. In MainStage, select the patch in the Patch List.
2. Choose Edit > Delete (or press the Delete key).

Reorder and move patches in the MainStage Patch List
When you add a patch to a concert, the new patch appears below the currently selected patch in the Patch List. You can drag patches in the Patch List to reorder them.

MainStage includes a Move Again command that lets you move selected patches multiple times. You can use Move Again when you drag, paste, create, or delete patches in the Patch List.

Reorder patches in the Patch List
• In MainStage, drag patches up or down in the Patch List until they appear in the order you want.

Move patches repeatedly
• In MainStage, after moving the patch once, choose Move again from the Action pop-up menu 🗑️ in the Patch List (or press Option-Shift-M) for each additional move.
Add and rename patches in MainStage

You can add patches to the concert and organize them in the Patch List. The number of patches is limited only by the amount of available memory in your system. When you add a patch to a concert, the patch is selected so you can easily audition and select a patch setting from the Patch Library.

When you add a patch, by default it takes the name of the channel strip added with it. You can give each patch a custom name to make it easier to identify and distinguish between them.

Add a new patch

1. In MainStage, click the Add Patch button (+), located in the upper-right corner of the Patch List.

   The Patch Library opens in the Patch Inspector as shown, and the new patch appears in the Patch List.

   ![Patch List](image)

2. Select the patch setting you want to use from the Patch Library.

   If you are using a keyboard controller, select a Keyboard patch. If you are playing an electric guitar, select a Guitar Rig patch. For other instruments or vocals, you can choose a template from the appropriate category or modify a keyboard or guitar template to suit your needs.

3. If the patch uses an audio channel strip, make sure the channel strip is set to use the correct audio input, then gradually raise the volume fader on the channel strip until you hear sound on the channel.
Rename a patch
1. In MainStage, click the patch name in the Patch List.
   
   A field appears with the patch name, which is selected.

2. Enter a new name in the patch name field.

Create a patch from several patches in MainStage
You can create a patch by combining several existing patches. The new patch contains all of the channel strips of the selected patches.

Create a patch from several existing patches
1. In MainStage, select the patches in the Patch List you want to use to create the new patch.

2. Choose New Patch from Selected Patches from the Action pop-up menu in the Patch List.
   
   The new combined patch appears in the Patch List, labeled “Untitled Patch.”

3. Double-click the name, then type a name for the combined patch.

   Note: Creating a patch with more than three channel strips can affect performance, particularly if the channel strips use a large number of plug-ins or processor-intensive plug-ins.
Work with patch settings

Overview of the MainStage Patch Settings Inspector

You can select patch settings in the Patch Library and edit settings for individual patches in the Patch Settings Inspector, which appears below the workspace when a patch is selected in the Patch List. Patch settings you can edit include:

- Setting the time signature for patches
- Setting the tempo to change when you select a patch
- Setting program change and bank numbers
- Changing patch icons
- Transposing the pitch of incoming notes for a patch
- Add text notes to a patch

The four tabs of the Patch Settings Inspector provide the following functions:

- Patch Library: The library of all your patches.
- Attributes: You can set attributes such as the time signature, tempo, bank and program change values, pitch transposition values, and more.
- Tuning: You can set the tuning method for the patch.
- Notes: Add text notes to the patch.

Open the Patch Settings Inspector

1. Enter Edit mode in MainStage, either by clicking the Edit button on the toolbar, choosing Edit from the View menu, or via a key command.

2. Choose Show Inspectors from the View menu.

   If the Inspector is already displayed, you can skip this step.

3. Select a patch in the Patch List.
Select patch settings in the MainStage Patch Library

When you open a concert or select a patch, the Patch Library opens in the Patch Settings Inspector below the workspace. The Patch Library contains a variety of patches optimized for the instrument the concert is designed for. You can quickly audition patches in the Patch Library. You can also search for patch settings by name.

Open the Patch Library

- In MainStage, select a patch in the Patch List.

The Patch Settings Inspector opens to the Patch Library tab.

Select a patch in the Patch Library

1. In MainStage, look through the settings in the Patch Library to find the one you want to use.
2. Click the patch setting.

You can start playing the patch immediately using the selected patch setting.

Search for patch settings by name

1. In MainStage, press Command-F to open the Find a Patch search field.
2. Enter the name of the patch setting you want to find.
3. Click Find.
   - The first patch setting with the text you entered appears selected in the Patch Library.
4. To find subsequent patch settings with the same name, choose Find Next in Library from the Action pop-up menu.

Note: If you have saved multiple patches using the Save as Set command (previously called Export as Set in MainStage 1.0) in the Patch List Action pop-up menu, the saved file appears as a patch in the Patch Library unless you have selected a different location for saving the file. Clicking the saved file in the Patch Library causes an alert to appear when the individual patches are opened from the patch file.

Set the time signature for patches in MainStage

You can set the time signature for a patch. Time signatures can be used with the Playback plug-in and also control the beats for the metronome. When you set the time signature for a patch, it overrides any concert- or set-level time signature.

Set the time signature for a patch

1. In the MainStage Patch Settings Inspector, select the Attributes tab.
2. In the Attributes tab, select the Has Time Signature checkbox.
3. Double-click the number in the field at the right, and enter the number of beats for one measure of the time signature.
4. Choose the beat value from the pop-up menu at the right.
Change the tempo when you select a patch in MainStage

You can give a patch its own tempo setting so that when you select the patch, the tempo changes to the patch tempo setting. MainStage uses the new tempo until you select another patch or set with its own tempo setting, until you tap a new tempo, or until MainStage receives tempo information from incoming MIDI messages. For more information about using and changing tempo in MainStage, see Overview of tempo.

Change the tempo using a patch

1. In the Attributes tab of the MainStage Patch Settings Inspector, select the Change Tempo To checkbox.
2. Set the patch tempo using the Change Tempo To value slider.

Set program change and bank numbers in MainStage

When you add a patch to a concert, the patch is given a MIDI program change number (the lowest available number) until all available program change numbers are taken. You can select patches using program change numbers in performance by assigning buttons on a MIDI device to send program change messages. The program change number can be edited in the Patch Inspector.

To select more than 128 patches, you can also set the bank number for a patch.

You can reset program change numbers for all active (non-skipped) patches in a concert. When you reset program change numbers, patches are assigned program change numbers based on their order in the Patch List, starting from the top. The program change numbers for skipped (inactive) patches are not reset.

To select patches by bank, first send the bank select message, then the program change message.

Note: Some devices send program change numbers in the range of 0–127, while other devices use the range of 1–128. You can set which range of program change numbers MainStage uses in MainStage > Settings > MIDI.

Edit the program change number for the selected patch

1. In the Attributes tab of the MainStage Patch Settings Inspector, select the Program Change checkbox.
2. Using the value slider, set the program change number.
Set the bank number for the selected patch

1. In the Attributes tab of the MainStage Patch Settings Inspector, select the Bank Select checkbox.
2. Using the value slider, set the bank number.

Reset program change numbers for active patches in a concert

- In MainStage, choose Reset Program Change Numbers from the Action pop-up menu for the Patch List (or press Option-Shift-Command-R).

Reset program change and bank select numbers in the Patch List

- In MainStage, choose Reset Bank and Program Numbers from the Patch List Action pop-up menu.

Show bank and program change numbers in the Patch List

- In MainStage, choose Show Bank and Program Numbers from the Patch List Action pop-up menu.

The MIDI standard allows program change numbers with values from 0 to 127. If all available program change numbers in a concert are already in use, any new patches added to the concert are given program change number zero (0), but the number is inactive (the checkbox is not selected). Bank changes are not supported.

If you edit a program change number to be the same as an existing program change number, the word “Duplicate” appears in red next to the Program Change value slider. If two or more patches have the same program change number, and the numbers are active, the patch that appears first (highest) in the Patch List or patch selector is selected when you send the program change message with the corresponding value.

Using Reset Bank and Program Numbers sets the bank automatically, based on sets. This lets you browse sets using bank select numbers, and browse patches using program change numbers, to access a large number of patches.

You can assign buttons and other controls to send program change messages and use them to select patches in the concert. For information about assigning buttons, see Button assignments.

Defer patch changes in MainStage

By default, when you switch patches, the new patch is ready to play immediately. You can “defer” a patch change so that the patch change occurs after the last note of the previous patch has been released or sustained.

Defer a patch change

- In the Attributes tab of the MainStage Patch Settings Inspector, select the Defer Patch Change checkbox.

Note: Deferring a patch change works in Perform mode but does not work when you are editing patches in Edit mode. You can defer incoming MIDI program changes and buttons mapped to actions, but not defer patch changes made by clicking the Selector object or using the arrow keys.
**Instantly silence the previous patch in MainStage**

Sometimes you may want the sound of the previous patch to continue after you select a new patch, such as when you want to sustain a chord pad while soloing over it. At other times, you may want to silence the sound of the previous patch instantly when you select a new patch.

**Instantly silence the previous patch when you select a patch**

- In the Attributes tab of the MainStage Patch Settings Inspector, select the Instantly Silence Previous Patch checkbox.

**Change patch icons in MainStage**

Each patch has an icon that appears in the Patch List next to the patch name. By default, the patch icon shows the type of channel strip created when the patch was added. You can choose a new icon for a patch and use icons to visually distinguish patches in the Patch List.

**Change the icon for a patch**

- In the Attributes tab of the MainStage Patch Settings Inspector, choose an icon from the Icon pop-up menu.

**Transpose the pitch of incoming notes for a patch in MainStage**

You can set the transposition for a patch, so that all the channel strips in the patch are transposed by the same number of semitones when the patch is selected. You can raise or lower the pitch of incoming MIDI notes in semitone increments, to a maximum of 8 octaves higher or lower.

**Transpose the pitch of incoming notes for the selected patch**

- In the Attributes tab of the MainStage Patch Settings Inspector, click the Transpose Patch control and do one of the following:
  - Drag the value up or down.
  - Click the up arrow or down arrow.
  - Press the up arrow key or down arrow key on your keyboard to raise or lower the value.
  - Type the number of semitones higher or lower you want to transpose the patch.

*Note: The total amount of pitch transposition applied to incoming notes is the sum total of all transpose settings. For example, if you have set the Transpose Concert setting to +12, the Transpose Set setting to +12, and the Transpose Patch setting to +12, your incoming notes are raised in pitch by 36 semitones.*
Change the tuning for a patch in MainStage

By default, patches use the same tuning method as the concert (or the set, if they are in a set with its own tuning method). You can change the tuning for a patch so that it uses a different tuning. When you change the tuning for a patch, it overrides any concert- or set-level tuning method. Available tuning methods include:

- **Use parent tuning**: The patch uses the same tuning as the set (if it is in a set with its own tuning method) or the concert.
- **Equal tempered tuning**: The standard tuning for most Western music, with an equal distance between all semitone intervals.
- **Fixed**: Lets you choose from a number of fixed tuning scales and keys. Fixed Tuning mode tunes musical keys (to different degrees) for scaled tuning systems, and delivers a key signature character. When playing mostly white keys (in the Pure setting, and with C as the root key), C major is the main focus, and tuning is scaled to that chord. An A major chord that is played immediately after a C major (and is therefore subject to C major scaled tuning) is affected somewhat by the scaled tuning effect, but does not sound completely tempered. If you normally play polyphonic music, this mode (when using the Pure setting) sounds most pleasing to your ears. The Fixed Tuning scales are ideal for a number of baroque and medieval instruments and styles of music.
- **User**: Lets you detune (set the deviation from equal tempered tuning) each semitone in steps.

- **Hermode Tuning**: Dynamically adjusts the tuning of an electronic instrument to create clear frequencies for every fifth and third interval in all possible chord and interval progressions. Because all tuning requirements cannot be satisfied simultaneously with any one Hermode Tuning setting, you can set different Hermode Tuning modes and degrees of effect.

When you choose Fixed, Hermode, or User as the tuning method, additional tuning controls appear in the Tuning tab. You can edit these controls to adjust the chosen tuning.

Change the tuning method for a patch

- In the Tuning tab of the MainStage Patch Settings Inspector, choose the tuning you want the patch to use from the Method pop-up menu.

Edit Fixed Tuning parameters

If you choose Fixed Tuning from the Method pop-up menu in MainStage, additional parameters become available:

- **Type pop-up menu**: Choose from the most important historic tuning scales, as well as a few others.
- **Root Key pop-up menu**: Choose a global key (C-B) for the chosen scale. This provides an easy way to reference the chosen scale to any root note.
- **Copy to User button**: Copies the chosen scale to use as a basis for a User tuning.
Edit Hermode Tuning parameters
If you choose Hermode Tuning from the Method pop-up menu in MainStage, additional parameters become available:

- **Type pop-up menu:** Choose any of the three modes:
  - **Classic (3/5-all):** This mode provides a broad and regular tuning of pure 5ths and 3rds. In cases of conflict, the degree of purity is temporarily reduced. This mode can be used for all types of music. The value of the Depth parameter indicates the degree of the 5th and 3rd purity. A setting of 100% determines maximum purity. A 10% value is the lowest purity setting. Off sets the tuning to an equal tempered scale.
  - **Pop/Jazz (3/5/7-all):** 5ths, 3rds, and 7ths are changed in this mode. It is great for Pop and Jazz styles, especially when using sustained chords. It is less suitable for polyphonic music because the detuning of the natural 7th is significant. This mode should always be used with a Depth of 90% or 100% because other values render the natural 7th acoustically ineffective.
  - **Baroque (3/5-adaptive):** This mode tunes pure 5ths and 3rds (with changing characteristics). In tonal music, with a clear harmonic center, the middle chords are tuned very purely, whereas more distant chords are tuned with less purity. If the harmonic center becomes unclear, all chords are tuned with equal purity. As with the other mode parameters, a Depth value of 100% determines the highest purity, and a value of 10%, the lowest purity.
- **Depth slider:** Drag to set the degree of effect between 0% and 100%.

Edit User Tuning parameters
If you choose User Tuning from the Method pop-up menu in MainStage, additional parameters become available:

- **Semitone boxes:** Detune each semitone in steps, by dragging vertically in each semitone box until you reach the value you want. Or, you can double-click in each semitone box and enter a value. Press Return or click in another box to exit text entry mode.
- **Reset button:** Resets all of your tuning adjustments to their default values.
- **Stretch Upper slider:** Determines the deviation (from the equal tempered scale) in the treble end of the sound. The higher the value, the farther down the low notes are tuned. A setting of 0 results in an equal tempered scale tuning.
- **Stretch Lower slider:** Determines the deviation (from the equal tempered scale) in the bass end of the sound. The higher the value, the further down the low notes are tuned. A setting of 0 results in an equal tempered scale tuning.
- **Root Key pop-up menu:** Lets you choose a global key (C-B) for the chosen scale. This provides an easy way to reference the chosen scale to any root note.

Add text notes to a patch in MainStage
You can use the Notes tab of the Patch Settings Inspector to add text notes and other information about your patch.
In the Notes tab of the Patch Settings Inspector in MainStage, click the text field and enter your notes.

The Notes field lets you use special ASCII characters and any installed languages, font symbols, and emoji. You cannot style text or change the font.

You can display your text notes in your layout by choosing a Parameter Text screen control and mapping the Current Notes action to it. See Add common screen controls and Map screen controls to actions for more information.

Work with channel strips

Overview of channel strips in MainStage

Channel strips are the building blocks of your patches. They contain the instruments and effects for the sounds you use in performance. MainStage channel strips use the channel strip interface common to many DAW and mixing applications. These are the main features of MainStage channel strips:
• **Badge:** These icons indicate the type of channel strip for easy identification. The various badges MainStage uses to identify channel strips are:
  
  - **Metronome:** ‪ollections ‪eton badge. ‪on the metronome channel strip.
  - **Tuner:** ‪an on jazz the tuner is focused.
  - **Alias:** ‪an audio or software instrument channel strip that is an alias to another channel strip. The audio channel strip alias badge is blue; the software instrument channel strip alias is green. See Create an alias of a channel strip for more information on aliases.
  - **Parent of Alias:** ‪onstrains that the channel strip is the parent channel strip of one or more alias channel strips.
  - **Concert:** ‪onstrains that this channel strip is a concert-level signal flow channel strip available to multiple patches.
  - **MIDI Output menus:** These pop-up menus let you choose the MIDI output port and channel on which to send MIDI data to your external instrument.
  - **Expression control:** Lets you quickly adjust the expression value of the channel strip.
  - **Settings menu:** Lets you load and save the entire routing configuration of a single channel strip, including all loaded plug-ins and settings.
  - **EQ Thumbnail:** Lets you add an EQ effect to sculpt the sound of the channel strip signal before applying other effects.
  - **MIDI plug-in slots:** Lets you insert MIDI plug-ins into instrument channel strips.
  - **Input slot:** Sets the channel strip’s input source. Depending on the channel strip type, it can be a physical input, a bus, or a software instrument plug-in—in this case it is also known as an Instrument slot.
  - **Effect slots:** Lets you insert plug-ins into audio, instrument, aux, and output channel strips.
  - **Send slots:** Lets you route a channel strip’s signal to an aux channel strip. Sends are commonly used to apply the same effect or effects to several signals.
  - **Send level knob:** Controls the amount of signal sent to an aux channel strip. This knob appears when a Send slot is activated.
  - **Output slot:** Sets the channel strip’s output path. It can be a physical output or a bus.
  - **Icon:** Every channel strip comes with a default icon, but you can choose a unique icon to distinguish each channel strip. See Change channel strip icons for more information.
  - **Pan/Balance knob:** On a mono channel strip, the Pan/Balance knob controls the position of the signal in the stereo image. On a stereo channel strip, it controls the relative level of the left and right signals at their outputs.
  - **Volume fader:** Sets a channel strip’s playback volume.
  - **Peak level display:** Updates during playback to show the highest peak level reached.
  - **Level meter:** Shows a channel strip’s playback level.
  - **Mute button:** Mutes and unmutes the channel strip.
  - **Solo button:** Solos and unsolos the channel strip.
  - **Latency display:** Shows how much time it takes to process the channel strip.
  - **Memory Usage display:** Shows how much RAM is used by each channel strip.
• **Channel Name:** Displays the name that you assign the channel strip.

• **Channel Notes:** If selected, a blank text field appears at the bottom of each channel strip. Double-click in this text field to write notes. Space is limited, so keep your notes short. If you need more room for notes, use the Notes tab in the Channel Strip Inspector. See notes.

In MainStage, you can use audio, software instrument, and auxiliary (aux) channel strips in your patches and sets, and also at the concert level. You can also use external instrument patches to play external hardware devices. You can adjust the volume level using the Volume fader, adjust the pan position using the Pan knob, and mute or solo the channel strip using the Mute and Solo buttons.

A MainStage concert can have a maximum of 1,023 software instrument channel strips, 267 audio channel strips, 256 external instrument channel strips, and 256 auxiliary (aux) channel strips.

You can add effects using the Insert slots, send the signal to an auxiliary channel (aux) using the Sends slots, and choose a different output from the Output slot. For audio channel strips, you can change the format between mono and stereo using the Format button. For software instrument channel strips, you can change the instrument using the Instrument slot. You can also choose, copy, and save channel strip settings, choose a different channel strip type, or reset the channel strip from the Settings menu.

Aux channel strips can be used to route a signal to multiple destinations, and as additional destination channels for multi-output instruments. Typically, you create aux channel strips as you need them. There are three ways to do this:

• An aux channel strip is created automatically when a send assignment is made from a channel strip, except when the chosen bus is already in use.

• When a multi-output instrument such as the Sampler is inserted into an instrument channel strip, several aux channel strip assignments are made “behind the scenes.” You then must create the required number of aux channel strips by clicking the Add button (+) at the bottom of the instrument channel strip. Each time you click it, a new aux channel strip is created (and automatically assigned to particular instrument outputs).

• You can also create aux channel strips by choosing Actions > Create Aux channel strip from the Mixer menu bar.

To learn how to add a channel strip, see Add a channel strip. To learn how to change a channel strip setting, see Change a channel strip setting. For information about the included instrument and effects plug-ins, see the MainStage Instruments and MainStage Effects manuals.
Add a channel strip in MainStage

You can add channel strips to a patch to create layered sounds and keyboard splits. When you add a channel strip to a patch, you choose the type of channel strip, the output, and other settings. You can mix both types in a single patch.

Add a channel strip to a patch

1. In MainStage, make sure the patch is selected in the Patch List.
2. Click the Add Channel Strip button (+) in the upper-right corner of the Channel Strips area.
3. In the New Channel Strip dialog, select the type of channel strip you want to create.
4. Choose the audio output for the channel strip from the Output pop-up menu.
5. For audio channel strips, choose mono or stereo format from the Format pop-up menu and choose the audio input from the Input pop-up menu. For external instrument channel strips, also choose the MIDI input, MIDI output, and MIDI channel from their respective pop-up menus.

   **Important:** Audio channel strips can produce feedback, particularly if you are using a microphone for audio input. When you add an audio channel strip, the volume of the channel strip is set to 0dB. Gradually raise the volume fader on the channel strip until you hear sound on the channel. You can also turn on Feedback Protection in MainStage > Settings > Audio.

6. Optionally, you can add multiple channel strips to a patch by entering a number in the Number field. You can add up to the maximum number for a channel strip type, depending on how many you already have in your project.
7. Click Create.

   A new channel strip appears in the Channel Strips area, highlighted to indicate that it is selected. The Channel Strip Inspector appears below the workspace, showing different parameters for the new channel strip.
8. For audio and external instrument channel strips, gradually raise the volume fader until you hear sound on the channel.

You can adjust channel strip output using the Volume fader, adjust pan position using the Pan knob, and mute or solo the channel strip using the Mute and Solo buttons. For audio channel strips, you can switch between mono and stereo format using the Format button. For software instrument channel strips, you can choose a different instrument from the Input pop-up menu. You can choose new channel strip settings, add and edit effects, add sends to busses, and change the output using the controls on the channel strip.

You can also define the key range for a channel strip, create transform and velocity graphs, and filter various MIDI messages to a channel strip in the Channel Strip Inspector. For more information about using channel strips in MainStage, see **Overview of channel strips**.
Change a channel strip setting in MainStage

You can quickly change the instrument, effects, and other parameters for a channel strip by selecting a new setting from the Channel Strip Library. The browser shows available settings for the currently selected channel strip.

Select a new channel strip setting
1. In MainStage, make sure that the channel strip you want to change is selected.
2. In the Channel Strip Inspector, click the Channel Strip Library tab.
3. Click a category from the column on the left, then click subcategories from the columns on the right until you see the settings you want.

You can also search for channel strip settings by name and perform other functions using the Channel Strip Library. For more information about the Channel Strip Inspector, see Choose channel strip settings.
Configure channel strip components in MainStage

You can customize how your channel strips appear in the Channel Strip area. The Channel Strip Configuration pop-up menu lets you select or deselect individual channel strip components, including components that are not activated by default.

The channel strip components not shown in the Overview of channel strips are:

- **Audio Device Controls**: When selected, direct hardware device controls such as mic preamp gain knobs, phantom power buttons, and so on. appear on the channel strip. The controls available depend on the audio device. Only audio devices specifically integrated with Logic, such as Apogee audio devices, offer direct audio device controls.

- **Type and Number Label**: Displays the type of channel strip (audio, software instrument, external instrument, or auxiliary) and number.

- **Channel Color**: When selected, the channel name and the channel notes fields will display the channel color.

- **Channel Number**: When selected, the internally determined channel number of each track is displayed.

**Choose channel strip components**

1. In MainStage, Control-click on any empty part of a channel strip.
2. Do one of the following:
   - To select or deselect a single channel strip component, choose Channel Strip Components then choose a component from the sub-menu.
   - To select or deselect multiple channel strip components, choose Configure Channel Strip Components, then choose one or more components from the Channel Strip Configuration pop-up menu.
Choose the number of lines for track names
1. In MainStage, Control-click on any empty part of a channel strip.
2. Choose Configure Channel Strip Components.
3. Choose 1 Line, 2 Lines, or 3 Lines from the pop-up menu to the right of the Track Name checkbox.

Show signal flow channel strips in MainStage
In addition to the channel strips in a patch, you can view and edit signal flow channel strips in the Channel Strips area. Signal flow channel strips include the Output and Master channel strips for the concert, auxes that are receiving signal from a channel strip in the patch, and any set- or concert-level channel strips that are available when the patch is selected. You can also view signal flow channel strips at the set level.

When you show signal flow channel strips, channel strips at the concert level, including Output and Aux channel strips, include a small concert icon near the top of the channel strip to make it easy to distinguish them from patch-level channel strips. Channel strips at the set level include a small folder icon so they can also be easily distinguished.

You can edit signal flow channel strips in the Channel Strips area. For example, you can adjust the volume fader or pan slider of a signal flow channel strip or add effects to an aux channel strip.

Show signal flow channel strips for the selected patch
• In MainStage, click the Action pop-up menu in the Channel Strips area and choose Show Signal Flow Channel Strips (if it’s not already enabled with a checkmark).

Hide the metronome channel strip in MainStage
You can hide the metronome channel strip in the Channel Strips area, where you can change its volume or change the metronome sound.

Hide the channel strip for the metronome
• In MainStage, click the Action pop-up menu in the Channel Strips area and deselect the Show Metronome Channel Strip checkbox (if it’s selected).
  To show the metronome channel strip, select the Show Metronome Channel Strip checkbox.
Create an alias of a channel strip in MainStage

You can create an alias of a channel strip and use the alias in different patches or sets. Aliases allow you to share highly memory-intensive plug-ins, such as third-party multichannel instruments and samplers, between different patches, rather than creating multiple instances of these plug-ins. In some cases, creating an alias can be more efficient (use fewer resources) than adding a concert- or set-level channel strip.

**Create a channel strip alias**

1. In the MainStage Channel Strips area, select the channel strip.
2. Choose Edit > Copy, or press Command-C (default).
3. In the Patch List, select the patch in which you want to use the alias.

   The alias is pasted after the last channel strip in the patch (but before any signal flow channel strips, if they are visible). An alias icon appears near the top of the alias to distinguish it from the channel strips in the patch.

You can use an alias in multiple patches or sets. When you change settings on the original channel strip (with the exception of volume, pan, and expression), those changes are reflected in the aliases of the channel strip. You may want to audition each patch that uses an alias after changing the settings of the original channel strip, to make sure it sounds the way you want.

You can create an alias of a multi-output instrument, such as the Sampler, to use in another patch or set in the concert. When you copy a multi-output instrument to create an alias, be sure to select all of the aux channel strips for the instrument so that the complete multi-output instrument is pasted as an alias. For information, see [Use multiple instrument outputs](#).

Add a patch bus in MainStage

In addition to the 64 global busses available for concert-wide routing, you can add patch-specific busses for routing inside a patch—using patch busses does not contribute to the global maximum. They can be used for a variety of purposes, such as a local volume control for layered patches.

A patch bus is available only for the patch you add it to. Patch busses for each patch are numbered sequentially starting from 1. Two different patches may each have a patch bus named “Patch Bus 1,” but each one is unique to the patch it was added to. The signal flows of the two patch busses are completely independent.
Add a patch-specific bus

- In MainStage, click a Send slot, then choose Patch Bus > Insert Patch Bus from the shortcut menu.

A new patch bus appears in the Send menu for the patch.

Set channel strip pan or balance positions in MainStage

You can separate sounds by positioning audio and instruments in the stereo mix from left to right. The Pan (short for panorama) knob defines whether an instrument is placed on the left, right, or center of the stereo field. You can set the pan position for each track in a project. MainStage includes several different pan modes. Which options are available depends on the type of channel strip:

- **Pan**: This is the default pan mode for mono channel strips. The Panner determines the position of a signal in the stereo image. At the center pan position, the channel strip sends equal amounts of the signal to both sides of the stereo image. If you were to increase the pan position on the left side and decrease it on the right, the sound would move to the left.

- **Stereo Pan**: The Stereo Pan knob is only available on stereo channel strips. It is similar to having two pan knobs, allowing you to place the position of the left and right signals individually in the stereo field.

- **Balance**: This is the default pan mode for stereo channel strips. It differs from Stereo Pan in that it controls the relative levels of two signals (Left and Right) at their outputs.

Mono channel strips have a Pan knob by default. Stereo channel strips have a Balance knob by default.
Select a channel strip's pan mode

• In MainStage, Control-click on the Pan knob, then choose a panner from the shortcut menu.

Set a channel strip’s pan or balance position

In MainStage, do one of the following:

• Drag the channel strip's Pan or Balance knob horizontally or vertically.
• Option-click the Pan knob to return it to the center position.
• Hold down Shift while you drag the knob to change the pan position in finer increments.

Adjust a channel strip’s Stereo Pan settings

In MainStage:

• To adjust the stereo spread of one channel of the stereo field without affecting the other channel, drag that channel's white handle. For example, if you want to narrow the stereo field of the left channel without affecting the right channel, drag the white handle of the left channel vertically closer to the center position.
• To invert the right and left channels, Command-click anywhere inside the Stereo Pan knob or ring. The signal ring changes color from green to orange (or back again).
• To widen or narrow the stereo spread range, drag the green or orange ring vertically.
• To adjust the center position of the stereo field, drag the center of the Stereo Pan knob vertically.
• To reset the stereo spread and center position to their initial values, Option-click anywhere inside the Stereo Pan knob or ring.

Set channel strip volume levels in MainStage

You can set the volume level of each channel strip independently.

Set a channel strip’s volume level

In MainStage, do one of the following:

• Drag the Volume fader up or down.
• Option-click the Volume fader to return it to a neutral level (0 dB gain).
• Hold down Shift while dragging the Volume fader to change the volume level in finer increments.

The level meter, located to the right of the Volume fader, shows the channel strip output volume as the project plays. When you play, watch the level meter to make sure the channel strip volume is not too high.
Mute and solo channel strips in MainStage

You can silence (mute) a channel strip so that you don’t hear it when you play the patch. Muting channel strips is useful when you want to compare how the patch sounds with and without the target instrument.

You can also listen to a channel strip signal alone (solo), silencing all other channel strips.

**Mute a channel strip**

- In MainStage, click the channel strip’s Mute button.

The Mute button turns blue. Click the button a second time to restore the channel strip to its previous level.

**Solo a channel strip**

- In MainStage, click the channel strip’s Solo button.

The Solo button turns yellow. The Mute buttons of all unsoloed channel strips flash blue, with the exception of external MIDI channel strips.

**Solo a channel strip when another channel strip is already soloed**

- In MainStage, option-click an unsoloed channel strip.

This action solos the selected channel strip and unsolos any other channel strip.
Use multiple instrument outputs in MainStage

MainStage supports the multiple outputs of all instruments that provide a multi-output configuration (including Drum Kit Designer, Sampler, Studio Horns, Studio Strings, Ultrabeat, and some Audio Unit instruments). You can insert multi-output instruments and use them to route different outputs to different physical outputs, to apply different plug-ins or processing to different outputs, or for other uses.

If an instrument supports multiple outputs, one or more multi-output versions are available in the Instrument Plug-in pop-up menu for the instrument.

The Plug-in menu shows specific information about output configurations—for example, Sampler: Multi-Output (5xStereo, 6xMono).

*Note: Not all instruments support multiple outputs. If no multi-output version is available in the Plug-in menu, the instrument does not support multiple outputs.*

Insert a multi-output instrument

1. In MainStage, on the channel strip in which you want to use the multi-output instrument, click the Instrument slot.

2. Choose the instrument from the Plug-in menu, and choose the multi-output version from the submenu.

The instrument name appears in the Instrument slot, and a small Add button (+) appears below the Solo button on the channel strip. The Output for the instrument is set to Output 1-2.
3. Double-click the Instrument slot to open the instrument (plug-in) window.
   You need to set up the output routing for individual sounds or samples in the instrument (plug-in window). You set up output routing for Sampler in the Instrument Editor, and set up output routing for Ultrabeat in the Output menu of the Assignment section of the Ultrabeat window.

4. On the channel strip, click the Add button (+) to add additional outputs.
   Each time you add an output, a new section of the channel strip is added, with the next available pair of outputs.
   Each output uses the same instrument, but each can have its own inserts, volume, pan, and expressions settings and its own effect sends as well as its own outputs.

For more information about using multiple instrument outputs, see the MainStage Instruments manual. Information about specific instruments (for example, Ultrabeat) can be found in the chapters covering those instruments.

Use external MIDI instruments in MainStage

You can add an external MIDI instrument channel strip to a patch and use it to play an external instrument, such as a hardware synthesizer.

When you use an external MIDI instrument channel strip, you choose the MIDI channel to send MIDI output from MainStage to the instrument, and choose the audio inputs to receive audio from the instrument. The audio output from the instrument is routed to the input of the channel strip, where you can process it using MainStage effects.

When you play your keyboard controller with the patch containing the external MIDI instrument selected, MainStage sends note and other MIDI messages to the chosen MIDI Output and MIDI Channel, receives audio from the chosen Input, and sends the audio output to the chosen Output. You can also send a program change message to the external instrument when you select the patch to control which program the external instrument uses.

You can also send MIDI messages, including SysEx and continuous control messages, to your connected MIDI hardware devices using an external instrument channel strip. You can send SysEx data to your external instrument in real time or as a MIDI file. The Channel Strip Inspector includes a Send MIDI File control where you can select a standard MIDI file with the information you want to send.

Add an external instrument channel strip

1. In MainStage, click the Add Channel Strip button (+) in the upper-right corner of the Channel Strips area.
2. In the New Channel Strip dialog, select External Instrument.
   You can also choose the MIDI input and output, the format, and the audio input and output for the channel strip. You can choose an audio channel for the input, but you cannot choose a bus. The MIDI input pop-up menu shows the Keyboard or MIDI Activity screen controls (which receive MIDI note input) currently in the workspace.
Send a program change to an external instrument when you select a patch
1. In the MainStage Channel Strip Inspector, click the MIDI Out tab.
2. In the MIDI Out tab, select the Send Program Change checkbox.
   The Program Change value is set to –1 by default, so that no program change is sent when you select the Send Program Change checkbox until you change the value.
3. Set the program change number you want to send using the Send Program Change value slider.
4. If you want to send a Bank Change message, select the Send Program Change checkbox, then set the most-significant byte (MSB) and least-significant byte (LSB) of the bank change number using the Bank MSB and Bank LSB value sliders.
   When you select the patch, the program change and bank change messages are sent to the external instrument. Also note that program and bank changes are sent when you edit the program change and bank change value sliders in the Channel Strip Inspector (so you can be sure that the values you enter send the correct program and bank change messages).
   If you want the external instrument to respond to the program change, but do not want it to receive note or other MIDI information from your controller, click the MIDI Input tab and choose None from the Keyboard pop-up menu.

Send program changes to an external instrument using a screen control
1. In the MainStage workspace, click the screen control you want to use to send program change messages.
2. In the Screen Control Inspector, click the Unmapped tab.
3. In the Mapping browser, select the external instrument, then select the MIDI Controller folder from the submenu.
4. In the third column from the left, select Program Change.
   The screen control is mapped to the Program Change parameter. By moving the hardware control assigned to the screen control, you can send program changes to the external instrument.
   \textbf{Note:} If the MIDI Out parameter of the external instrument channel strip is set to the external instrument when you map the screen control to the Program change parameter, a program change (Program 0) is sent when you create the mapping. If you are editing the program on the external instrument, your changes may be lost. To map the screen control without sending an immediate program change to the external instrument, choose None from the MIDI Out slot of the external instrument before you create the mapping, then choose the external instrument in the MIDI Out slot. No program change is sent until you move the knob or fader.

Pass SysEx data through to an external instrument
1. In the MainStage External Instrument Channel Strip Inspector, click the MIDI Input tab.
2. In the Input column of the Inspector window, deselect the SysEx checkbox.
   The external instrument channel strip now passes SysEx data through to the instrument.
Send a MIDI file using an external instrument

1. In the MainStage External Instrument Channel Strip Inspector, click the MIDI Output tab.
2. Select the Send MIDI File checkbox, then click the Select button.
3. Browse to the location of the MIDI file you want to add, select the file, then click Send.

The MIDI file is sent immediately to the port selected on the external instrument channel strip. The MIDI file is re-sent when you change patches, just like the other options in the Channel Strip Inspector (such as Program Change or MIDI Clock messages).

Only SMF (standard MIDI file) types 0 and 1 are supported. MIDI files are sent sequentially, one at a time, per concert. If you switch rapidly through several patches that send long MIDI files, the MIDI files are queued and sent in succession. MIDI messages are sent at the tempo stored in the MIDI file.

Reorganize channel strips in MainStage

If a patch has multiple channel strips, you can reorganize them in the Channel Strips area by moving individual channel strips to the right or left of other channel strips. You can only move audio, software instrument, and external MIDI channel strips, not the Metronome or signal flow channel strips.

Move a channel strip in the Channel Strips area

- Drag an audio, software instrument, or External MIDI channel strip to the right or left in the MainStage Channel Strips area.

  Note: Be sure to drag from a portion of the channel strip without any controls or text fields.

Delete channel strips in MainStage

You can delete a channel strip if you decide you no longer want it in a patch.

Delete a channel strip

1. In MainStage, select the channel strip in the Channel Strips area.
2. Choose Edit > Delete (or press the Delete key).
Work with channel strip settings

Overview of the MainStage Channel Strip Inspector

You edit channel strip parameters in the Channel Strip Inspector, which appears below the workspace when the channel strip is selected in the Channel Strips area. With these parameters you can:

- Rename channel strips
- Change channel strip colors
- Change channel strip icons
- Configure key ranges and articulations for instruments
- Create controller transforms
- Add text notes to a channel strip in the Channel Strip Inspector

The five tabs of the Channel Strip Inspector provide the following functions:

- **Channel Strip Library**: A library of all your channel strip settings.
- **Attributes**: You can change the name, color, and icon of the channel strip.
- **Layer Editor**: In this tab you can create keyboard layers and splits. For more information on keyboard layers and splits, see [Overview of layers and splits](#). You can also choose Articulation Sets and access the Articulation Set Editor. For more information on Articulation Sets see [Manage articulations with the Articulation Set Editor](#).
- **MIDI Input**: You can choose and transform data from your MIDI input keyboard using graphs and the controller transform area.
- **Notes**: You can add additional plain text notes that didn’t fit into the Notes area under the channel strip.

You can access any available channel strip using the Channel Strip Library. Some channel strips, however, include plug-ins (particularly Space Designer) not suited for live performance because of their intensive CPU usage. Using these channel strips can affect the performance of your concert, resulting in audio dropouts and other issues.

Surround effect plug-ins cannot be used with MainStage. If you choose a channel strip setting containing a surround effect, the unused effects are shown disabled (gray, with a diagonal line running through the effect name).
Open the Channel Strip Inspector

1. In MainStage, enter Edit mode, either by clicking the Edit button on the toolbar, choosing Edit from the View menu, or via key command.

2. Choose Show Inspectors from the View menu. If the Inspector is already displayed, you can skip this step.

3. Select a channel strip in the Channel Strips area.

Choose channel strip settings in MainStage

You can quickly change the instrument, effects, and other parameters for a channel strip by choosing a new channel strip setting. You can choose a new channel strip setting from the Channel Strip Library or from the Settings menu at the top of the channel strip.

You can also search for channel strip settings by name.

Choose a channel strip setting from the Channel Strip Library

1. In the MainStage Channel Strips area, select the channel strip you want to change.

   The selected channel strip is highlighted with a blue outline.

2. In the Channel Strip Inspector, click the Channel Strip Library tab.

   Available settings for the channel strip appear in the Channel Strip Library. MainStage built-in channel strip settings appear in a series of folders with different instrument categories. If you have GarageBand installed, or have one or more Jam Packs installed on your computer, those settings appear below the built-in settings.

3. Click a category from the column on the left, then click subcategories from the columns on the right until you see the settings you want.

   ![Channel Strip Library Screenshot]

   You can select a recent channel strip setting by clicking Recent in the column on the left and then selecting a recent setting from the second column.

Choose a channel strip setting from the Settings pop-up menu

In MainStage, click the Settings button at the top of the channel strip, then choose a new setting from the pop-up menu that appears.

When you choose new channel strip settings from the Settings pop-up menu, the selected channel strip setting does not appear selected in the Channel Strip Library.
Search for channel strip settings in the Channel Strip Library

1. In the MainStage Channel Strip Inspector, click the Channel Strip Library tab.
2. Click the Action pop-up menu in the upper-right corner of the Channel Strip Inspector, then choose Find in Library.
3. In the dialog that appears, enter the text you want to search for.
   The channel strip with the text in its name appears selected in the library.
4. Choose Find Next in Library from the Action pop-up menu to see additional instances of the search term in the channel strips.
5. To change the channel strip setting, click the name of the new setting in the Channel Strip Inspector.

The Channel Strip Library shows all available channel strip settings, including settings that may not be useful in MainStage. If you choose a channel strip setting containing plug-ins not usable in MainStage, the plug-ins appear with a bold diagonal line in the Channel Strips area.

Rename channel strips in MainStage

When you add a channel strip to a patch, the channel strip has a default name. You can rename channel strips to distinguish your custom settings from the default ones.

Rename a channel strip

• In the Attributes tab of the MainStage Channel Strip Inspector, select the name in the Name field and enter a new name.

![Instrument Channel Strip Inspector](image)

Change channel strip colors in MainStage

Each channel strip has a color, which appears at the bottom of the channel strip and as a layer above the keyboard screen control in the workspace and the Layer Editor. You can change the color to make it easier to visually distinguish channel strips.
Change the color of a Software Instrument channel strip

- In the Attributes tab of the MainStage Channel Strip Inspector, choose a color from the Color pop-up menu.

![Image of Instrument Channel Strip Inspector]

Choose a color from the pop-up menu.

Change channel strip icons in MainStage

When you add a channel strip, the channel strip has a default icon, which appears above the Pan knob. You can change the icon to help visually distinguish channel strips with different instrument types or uses.

Change the icon for a channel strip

- In the Attributes tab of the MainStage Channel Strip Inspector, choose an icon from the Icon menu.

![Image of Instrument Channel Strip Inspector]

Choose an icon from the menu.

Use feedback protection with channel strips in MainStage

You can use feedback protection on audio and external instrument channel strips in MainStage. Feedback protection is turned off by default. You can turn feedback protection on or off for individual channel strips in the Channel Strip Inspector, and enable feedback protection globally in MainStage > Settings > Audio. For more information on the Channel Strip Inspector, see Overview of the Channel Strip Inspector.

Turn feedback protection on or off

1. In MainStage, select the audio or external instrument strip you want to apply feedback protection to.

2. In the Attributes tab of the MainStage Channel Strip Inspector, select the Feedback Protection checkbox to turn feedback protection on. Deselect the checkbox to turn it off.
When feedback protection is turned on for a channel strip, MainStage alerts you when it detects feedback on the channel. When the feedback alert appears, the channel is temporarily silenced. You can then choose to mute the channel while you find and eliminate the source of the feedback, disable feedback protection for all audio and external channel strips in all concerts, or continue to use the channel and receive alerts when feedback occurs.

For more information about enabling feedback protection globally (in MainStage > Settings > Audio), see Audio settings.

Set keyboard input for a software instrument channel strip in MainStage

In the Channel Strip Inspector, you can choose the keyboard controller from which the channel strip receives MIDI input. For multi-timbral instruments, you can also choose the input for each MIDI channel. For example, when using the EVB3 instrument as a multi-timbral instrument, you can send input to the upper and lower register and the foot pedal using three separate MIDI channels.

For information about using keyboard controllers in performance, including using multiple controllers, see Tips for performing with keyboard controllers.

Set the keyboard input for a software instrument channel strip

1. In the MainStage Channel Strip Inspector, click the MIDI Input tab.
2. Choose the MIDI input device from the Keyboard pop-up menu in the Input section.
   The names in the Keyboard pop-up menu correspond to keyboard screen controls in the workspace.

Set multi-timbral input for different MIDI channels

1. In the MainStage Channel Strip Inspector, click the MIDI Input tab.
2. Choose Multi-timbral from the Keyboard pop-up menu in the Input section.
3. In the Multi-timbral Settings dialog, choose the input device for each MIDI channel you want to receive MIDI input.

Transpose individual software instruments in MainStage

In the Channel Strip Inspector, you can transpose (change the pitch of) the MIDI notes being received by a software instrument. When you transpose MIDI notes, the pitch of every MIDI note received by the software instrument assigned to the channel strip is transposed by the number of semitones set in the Transpose value slider. If a software instrument is unpitched—such as a sound effect or a percussion sound that doesn’t change in pitch regardless of the MIDI note received—you can also set the instrument assigned to the channel strip as unpitched even if all the other instruments in the patch are being transposed.

Transpose the MIDI input of a software instrument

1. In MainStage, select the channel strip in the Channel Strips area.
2. In the MIDI Input tab of the Channel Strip Inspector, set the value using the Transpose value slider. You can drag the value up or down to set the value, click the Up Arrow or Down Arrow, or double-click the value and type a new value.
Set a software instrument as unpitched
1. In MainStage, select the channel strip in the Channel Strips area.
2. In the MIDI Input tab of the Channel Strip Inspector, select the Unpitched checkbox.
   The software instrument's output remains unpitched even if the rest of the patch receives transposed MIDI notes.

Filter MIDI messages in MainStage
You can filter some MIDI messages for a channel strip in the Channel Strip Inspector. When you select one or more MIDI message types in the Filter section of the Channel Strip Inspector, the corresponding MIDI message types are filtered out of any incoming MIDI data and are not sent to the channel strip.

You can filter the following types of MIDI messages:
- Pitch Bend
- Channel Aftertouch
- SysEx
- Continuous Controller (CC) messages 0-127

Filter incoming MIDI messages
1. In the MainStage Channel Strip Inspector, click the MIDI Input tab.
2. In the Input Controller section of the MIDI Input tab, select the checkbox for the MIDI messages you want to filter.
   If you have created a controller transform, you can filter the input message type, and the controller transform still sends its output message type. It is also possible to filter the output message type, but in this case the output of the controller transform is filtered. See Create controller transforms for more information.

Scale channel strip velocity in MainStage
You can scale the output velocity of a channel strip using the Velocity Scaling graphs. You can scale output velocity based on note input or input velocity.

When you perform velocity scaling, each input velocity (regardless of the note being played) is scaled to the output velocity.

When you perform note scaling, output velocity is scaled depending on the note in the key range. This is useful when you want to have a parameter change in different parts of the key range; for example, when a filter or attack parameter opens for higher note values to give a brighter, sharper sound.

Open a velocity scaling graph
1. In the MainStage Channel Strips area, select the channel strip on which you want to perform velocity scaling.
2. In the Channel Strip Inspector, click the MIDI Input tab.
3. In the MIDI Input tab, do one of the following:
   - To open the velocity input graph: Select the Velocity Input button.
   - To open the note input graph: Select the Note Input button.

For information about editing the graph, see Work with graphs.

Set channel strips to ignore Hermode tuning in MainStage

If a patch (or the concert or set containing the patch) is set to use Hermode tuning, but the patch contains a channel strip (for example, one with a drum or percussion instrument) that you do not want to use Hermode tuning, you can set the individual channel strip to ignore Hermode tuning.

Set a channel strip to ignore Hermode tuning
   - In the MIDI Input tab of the MainStage Channel Strip Inspector, select the Ignore Hermode Tuning checkbox.

Override concert- and set-level key ranges in MainStage

If a software instrument channel strip exists at the concert level, the concert-level channel strip takes precedence over any patch-level software instrument channel strips within its key range. This means that when you play any notes in the key range of the concert-level channel strip on a keyboard controller, you hear only the concert-level channel strip, even when a patch is selected.

Similarly, if a software instrument channel strip exists at the set level, the same condition applies for all patches in the set. That is, the set-level channel strip takes precedence over any patch-level channel strips within its key range.

You can override concert- or set-level channel strips for a channel strip on an individual patch, so that the patch-level channel strip takes precedence over the concert-level or set-level channel strips.

Override concert- or set-level key ranges

1. In MainStage, select the patch in the Patch List with the channel strip that you want to override the concert- or set-level channel strip.
2. In the Channel Strips area, select the channel strip with the key range that you want to override the concert- or set-level key range.
3. In the Channel Strip Inspector, select the Layer Editor.
4. In the “Override parent ranges” pop-up menu choose one of the following options:
   - Off: The key ranges of the concert- or set-level instrument is used for the patch.
   - Replace: The key ranges of the patch-level instrument replaces the key ranges of the concert- or set-level instrument.
   - Add: The key ranges of the patch instrument are layered on top of the key ranges of the concert- or set-level instrument.

The “Override parent ranges” pop-up menu is available only if there is a concert- or set-level instrument or external instrument channel strip.
Add text notes to a channel strip in the MainStage Channel Strip Inspector

In addition to the Channel Notes area of a channel strip, you can use the Notes tab of the Channel Settings Inspector to add text notes and other information about a channel strip.

1. In MainStage, click on the Notes tab of the Channel Strip Settings Inspector.
2. Enter your text note in the Notes field.

The Notes field lets you use special ASCII characters and any installed languages, font symbols, and emoji. You cannot style text or change the font.

Work with plug-ins

Overview of working with plug-ins in MainStage

MainStage includes a full collection of professional-quality instrument and effect plug-ins, as well as utility plug-ins such as the Tuner. For more information about the included effects plug-ins, refer to the MainStage Instruments and MainStage Effects manuals. You can use plug-ins in MainStage channel strips in patches and also at the concert and set level. You use instrument plug-ins in software instrument channel strips, and you can use effect plug-ins in audio, software instrument, external instrument, and auxiliary channel strips.

You can add and remove plug-ins from channel strips, and move and copy plug-ins between slots on the same channel strip or between two channel strips. You can also use plug-in settings, adjust plug-in parameters, and use the other controls in the plug-in window header.

Many effects plug-ins can be inserted on channel strips used in real-time performances without any problems. Some effects, such as Space Designer, require intensive real-time processing of the audio signal. Using Space Designer and other processor-intensive plug-ins in individual patches can affect the performance of your concert, and in some cases can cause audio dropouts or glitches, particularly if the audio buffer is set to a smaller size. It's recommended that you use Space Designer and other, similarly processor-intensive plug-ins sparingly in your concerts. Rather than inserting processor-intensive plug-ins in individual channel strips, you can use a few instances in auxiliary channel strips shared between multiple patches.

MIDI plug-ins

MainStage also includes a set of MIDI plug-ins that you can use in software instrument and external MIDI instrument channel strips for real-time MIDI processing. In a channel strip, MIDI plug-ins appear below the EQ display and above the instrument slot. You can also use third-party Audio Units MIDI plug-ins with MainStage. For more information, see the MainStage Effects manual.

Audio Units plug-ins

In addition to the built-in factory plug-ins, you can use Audio Units plug-ins for both instruments and effects in MainStage.
Some Audio Units plug-ins can introduce latency. Using effects that introduce latency, such as compressors and limiters, can produce undesirable or unpredictable results during live performance. Other Audio Units plug-ins, particularly instrument and amp modeling plug-ins, require high levels of real-time processing and can affect the performance of your concert.

Add and remove plug-ins in MainStage

You can add plug-ins, replace a plug-in with a different one, and remove plug-ins from the plug-in slots of a channel strip.

Add an instrument plug-in

• In a MainStage channel strip, click an empty Input slot or the right side of an occupied Input slot, then choose a plug-in from the pop-up menu.

Note: To see legacy instrument plug-ins in the pop-up menu, Option-click an Input slot.

Add an audio effect plug-in

• In a MainStage channel strip, click an empty Audio Effect slot or the right side of an occupied Audio Effect Slot, then choose a plug-in from the pop-up menu.
The last visible empty Audio Effect slot in a channel strip is shown at half its height; use it in the same way.

Note: To see legacy audio effect plug-ins in the pop-up menu, Option-click an Audio Effect slot.

Add a MIDI effect plug-in
In a MainStage channel strip, do one of the following:

- Click the MIDI Effect slot, then choose a plug-in from the pop-up menu.

Replace a plug-in

- In a MainStage channel strip, place the pointer over a plug-in slot, click the arrows that appear to the right, then choose a plug-in to replace the existing one.
Remove a plug-in

- In a MainStage channel strip, place the pointer over the plug-in slot, click the arrows that appear to the right, then choose No Plug-in from the pop-up menu.

Move and copy plug-ins in MainStage

You can move, reorder, and copy plug-ins in a channel strip.

Move a plug-in

- In MainStage, press and hold the Command key while dragging the plug-in to an empty slot, either in the same channel strip or to another channel strip.

Reorder plug-ins

- In MainStage, press and hold the Command key while dragging the plug-in to an occupied slot, either in the same channel strip or to another channel strip.

Copy a plug-in

- In MainStage, press and hold the Option key while dragging the plug-in to another slot, either in the same channel strip or to another channel strip.

Use Channel EQ in MainStage

The Channel EQ plug-in allows you to sculpt the sound of the channel strip. It is usually, but not always, the first audio effect. The graphic controls make it easy to view and change the audio signal in real time. For full details about the Channel EQ, along with some usage tips, see the MainStage Effects documentation.

Use the Channel EQ plug-in

1. In MainStage, click the EQ area at the top of the channel strip.

   The Channel EQ plug-in is added to the first available Insert slot and the plug-in window opens.

   Note: Shift-click the EQ area to insert the Linear Phase EQ in the first available Insert slot. Be aware, however, that the Linear Phase EQ takes more time to process your signal than the Channel EQ, which makes it less suited to real-time performance.

2. Do one of the following:

   - Choose a Channel EQ setting from the Settings pop-up menu at the top of the plug-in window.
   - To graphically edit an EQ band, drag vertically to change the level or drag horizontally to change the center frequency.
   - To numerically edit an EQ band, drag the number to raise or lower the value; or double-click, then type a new value.

To learn more about using the Channel EQ effect, see the Channel EQ documentation in the MainStage Effects Users Guide.
Use plug-in settings in MainStage

MainStage plug-ins include a variety of settings, each optimized for a specific result. For an instrument plug-in, a setting may re-create the characteristic sound of a particular instrument, while for an effect plug-in, it may be tailored for use with a specific instrument or to create a particular sound. You can choose settings, copy and paste settings, save settings, and perform other functions in the Settings pop-up menu for each plug-in.

Choose a plug-in setting

1. In MainStage, to open the plug-in window, double-click the plug-in slot.
2. Click the Settings pop-up menu (at the top of the plug-in window), browse to the setting you want, then choose it.

Tip: You can also select the plug-in slot, then choose a plug-in setting in the Channel Strip Inspector.

Choose the previous or next plug-in setting

In MainStage, do one of the following:

- To choose the previous plug-in setting: Click the left arrow next to the Settings pop-up menu (or choose Previous Setting from the Settings pop-up menu).
- To choose the next plug-in setting: Click the right arrow next to the Settings pop-up menu (or choose Next Setting from the Settings pop-up menu).

Copy and paste plug-in settings

1. In MainStage, click the Copy button in the plug-in window header (or choose Copy Setting from the Settings pop-up menu).

All parameter setting are copied to a plug-in settings Clipboard, which is independent of the macOS Clipboard.
2. Click the Paste button in the plug-in window header (or choose Paste Setting from the Settings pop-up menu).

Save changes to a plug-in setting

In MainStage, do one of the following:

- To save the current plug-in parameter values as the setting: Choose Save Setting. This overwrites the existing setting.
- To name and save a setting, including its folder location: Choose Save Setting As. You can create a new folder in the Save As dialog, if you want.

Note: Subfolders must be located in the folder for the corresponding plug-in. For example, you could save a setting called “Euro Lead” in the Lead Synths subfolder of the ES2 folder.

Revert to a plug-in's default settings

- In MainStage, choose Reset Setting from the Settings pop-up menu.

Create a default setting

- In MainStage, save a setting called “#default” in the Settings folder for the plug-in.
Delete a plug-in setting

- In MainStage, choose Delete Setting from the Settings pop-up menu.

Adjust plug-in parameters in MainStage

Each plug-in window contains controls to adjust the values of the parameters for that plug-in. Some controls, such as buttons, knobs, and sliders, are shared by different plug-ins, while others are unique to a particular plug-in. Most controls are labeled to show the parameter they affect. For details about each plug-in, see the MainStage Instruments and MainStage Effects manuals.

Adjust plug-in parameters

In MainStage, do any of the following:

- Click buttons to switch them on or off.
- Drag knobs vertically to adjust their value.
- Drag sliders horizontally or vertically, depending on their orientation.
- Enter a value in a numbered field.
- Select a control, then move your mouse wheel or swipe your trackpad to adjust the value.

Reset a parameter to its default value

- In MainStage, option-click the parameter.

Adjust a parameter in finer increments

- In MainStage, hold down the Shift key before manipulating a control.

Use other plug-in window controls in MainStage

All MainStage plug-ins share a common set of controls in their headers for choosing, loading, and saving settings, copying and pasting plug-in parameters, switching between views, bypassing the plug-in, and comparing plug-in settings before and after adjustments. For some plug-ins that offer additional parameters not shown in the Editor view, you can also find extended plug-in parameters at the bottom of their plug-in windows.

You can view plug-in parameters in Editor view, which shows a graphical interface for the plug-in, or in Controls view, which shows parameters arranged in a row of value sliders where appropriate.
Bypass a plug-in
• In MainStage, click the Bypass button in the header at the top of the plug-in window.

When a plug-in that is mapped to a screen control is bypassed, the screen control appears dimmed in the workspace.

Compare the plug-in before and after adjustments
1. In MainStage, click Compare in the plug-in window header to hear the plug-in with its saved settings.
2. Click Compare again to hear the plug-in with your latest changes (since saving).

Adjust the size of a plug-in window
In MainStage, do one of the following:
• Drag the lower-right corner of the plug-in window.
• Choose the window size from the View pop-up menu in the header of the plug-in window.

Link or unlink plug-in windows
When linked, a single plug-in window is used to either display all open plug-ins or all plug-ins in the same insert slot row across all channel strips.
1. In MainStage, control-Click the Link button to the right of the plug-in window header.

2. Choose one of the following options from the Link shortcut menu:
   Off: Plug-in windows are not linked. Clicking in the center of any plug-in opens it in a new plug-in window.
   Single: A single plug-in window is used to display all open plug-ins. Each time you open a new plug-in, the window updates to reflect the newly chosen plug-in. In Single mode, the Link button turns purple.
   Multi: A single plug-in window is used to display all open plug-ins of the same insert slot row. (For example, all of the plug-ins from the first row of insert slots would share a single plug-in window, but plug-ins in other slots would open in their own window). In Multi mode, the Link button turns yellow.

   Note: You can simply click on the Link button to toggle between Off and Single mode.

The Link mode affects the entire concert—it is not possible to have the Link mode set differently in different plug-in windows of the same concert. The Link mode can either be set to Single for the entire concert or for Multi mode for one or more rows of plug-ins. This means that if Multi mode is selected, clicking the Link button on additional plug-ins from any not currently linked rows engages Multi mode for that row of plug-ins, and if Single mode is selected in any open plug-in, Multi mode is turned off.
Choose a source for a side chain signal into a plug-in

For plug-ins with a Side Chain Source pop-up menu, you can use audio from an audio or software instrument track, hardware input, or bus to trigger the plug-in. For example, the dynamics of a drum groove can be used to rhythmically change the compression, and therefore dynamics, of a guitar, synthesizer, or bass part. The side chain signal is used to control the plug-in, but it is not processed by the plug-in.

- In MainStage, click the Side Chain Source pop-up menu in the plug-in header area, then choose one of the available sources.

The audio signal from the selected side chain source now serves to control the plug-in. You can change external side chain sources, select an internal side chain source if one is available, or select None to disable the side chain if an internal side chain source is not available, at any time.

Show extended plug-in parameters

- In MainStage, click the disclosure arrow at the bottom of the plug-in window.

Switch between Editor and Controls view

- In MainStage, choose the Controls or Editor item from the plug-in window header’s View pop-up menu.

Route audio via send effects in MainStage

You use send effects when you want to isolate effect plug-ins from a channel strip’s signal flow, or when you want to use the same effect on more than one channel strip. By creating a send, you split the channel strip’s signal. The channel strip’s main signal continues its route to the chosen output. The other part of the signal is routed down a parallel path, via a bus to an aux channel strip. You use the Send Level knob to control the amount of signal that is sent via the bus.

You use the Send pop-up menu to configure where in the channel strip’s signal the send occurs, and to set the destination for the send’s parallel routing.

Open the Send pop-up menu

Use the Send pop-up menu to configure where the send occurs, and to set the destination for the send.

- In MainStage, long-click the Send knob to open the Send pop-up menu.
Choose a destination for a send

- In MainStage, select a Bus from the submenu of the Send pop-up menu.

If you have named the aux channel strip that a bus is sending to, the name appears beside the bus number. If the Bus you choose is not already assigned to an aux channel strip, a new aux channel strip is created. After a send has a destination, you can double-click the send to jump to the destination aux channel strip.

Set the location of the send in the signal flow

- In the MainStage Send pop-up menu, choose one of the three signal flow options for the send.

- **Post Pan**: The signal is sent after the fader and the Pan knob; the send signal is affected by both channel strip volume and pan adjustments. When a send is Post Pan, the Send knob ring is green.

- **Post Fader**: The signal is sent after the fader but before the Pan knob; the send signal is affected by volume adjustments but not pan adjustments. When a send is Post Fader, the Send knob ring is blue.

- **Pre Fader**: The signal is sent before the fader and Pan knob; the send signal is not affected by volume or pan adjustments. When a send is Pre Fader, the Send knob moves to the left of the Send pop-up menu, and the Send knob ring is blue.
Create keyboard layers and splits

Overview of layers and splits in MainStage

If you play a keyboard controller, you can easily create keyboard layers and splits in your MainStage patches. You create layers and splits by adding two or more channel strips to a patch and setting the Low Key and High Key for each channel strip to define its key range. The key range defines the range of notes on a keyboard controller that trigger sound from a software instrument or external instrument in the channel strip. You can define key ranges so that they overlap (for layered sounds) or are contiguous (for splits).

Define the key range in MainStage

The Layer Editor tab in the Channel Strip Inspector shows the key range for each channel strip in a patch and in the concert or set containing the patch (if either includes a channel strip with a key range). You can define the key range for a channel strip using the layers, the Learn buttons, or the Low Key and High Key value sliders.

Define a key range using the layers

1. In the MainStage Channel Strip Inspector, click the Layer Editor tab.
2. In the Layer Editor, move the pointer over the left edge of the layer you want to change or define.
   The pointer changes to a resize pointer.
3. Drag the left edge of the layer to the note you want to use as the low key (the lowest note in the key range).
4. Move the pointer over the right edge of the layer.
5. Drag the right edge of the layer to the note you want to use as the high key (the highest note in the key range).

Define a key range using the Learn buttons

1. In the MainStage Channel Strips area, select the channel strip.
2. In the Channel Strip Inspector, click the Layer Editor tab.
3. Click the Learn button next to the Low Key value slider.

4. On your keyboard controller, press the key you want to set as the lowest key in the key range.

5. To turn off Learn mode for the Low Key, click the Learn button again.

6. Click the Learn button next to the High Key value slider.

7. On your keyboard controller, press the key you want to set as the highest key in the key range.

8. To turn off Learn mode for the High Key, click the Learn button again.

When you play the patch, you hear the channel strip when you play notes inside the key range. When you play notes outside the key range, no sound is generated from the channel strip.

Define a key range using the value sliders

1. In the MainStage Channel Strips area, select the channel strip.

2. In the Channel Strip Inspector, click the Layer Editor tab.

3. Change the value in the Low Key value slider.

You can drag vertically, click the up arrow or down arrow, or double-click the value and enter a new value.
4. Change the value in the High Key value slider.
   You can drag vertically, click the up arrow or down arrow, or double-click the value and enter a new value.

Set floating split points in MainStage

When a key range has a floating split point, the notes that define the boundaries of the key range change depending on the keys you play as you approach the boundary of the key range. You set floating split points in the Layer Editor tab of the Channel Strip Inspector.

Floating split points can be explained using an example. If you set the Low Key of a key range to C1, set a floating split point value of 3, then play notes immediately above C1 (for example, the notes F1-Eb1-D1), and continue playing downward past C1 (for example, the notes C1-Bb0-A0), the split point moves down to include those notes, up to the floating split point value (3 semitones). If, however, you start by playing notes immediately below the Low Key (for example, the notes G0-A0-B0) and continue playing upward past C1 (for example, the notes C1-D1-E1), the split point moves up to include those notes, up to the floating split point value. (In this example, C1 and D1 would be included, but not E1, which is four semitones above the Low Key.)

Set floating split points for a layer/key range

1. In the Layer Editor tab, click the Low Key Floating value slider and drag vertically to change the value, or double-click the current value and type a new value (the value is the number of semitones used for the split).
2. Click the High Key Floating value slider and drag vertically to change the value, or double-click the current value and enter a new value.

You can also create a keyboard split by adding a channel strip at the set level and adjusting the key range of the channel strips in the patches in the set. The channel strip at the set level takes precedence over any channel strips in patches in the set for the notes in its key range. For information about adding a channel strip at the set level, see Add a channel strip at the set level.

Set the velocity range in MainStage

By default, the velocity of a channel strip extends from 1 to 127. You can limit the velocity range so that the channel strip only responds when the notes you play on your controller fall between the Min and Max values.

Set the velocity range for a channel strip

1. In the MainStage Channel Strips area, select the channel strip.
2. In the Channel Strip Inspector, click the Layer Editor tab.
3. In the Layer Editor, set the minimum velocity that triggers the channel strip using the Velocity Min value slider. (Drag vertically to change the value, or double-click the value and enter a new value.)
4. Set the maximum velocity that triggers the channel strip using the Velocity Max value slider.
Bypass a layer in MainStage

If you want to mute one of the layers in your patch, you can bypass it in the Channel Strips Inspector.

1. In the MainStage Channel Strips area, select the channel strip.
2. In the Channel Strip inspector, click the Layer Editor tab.
3. Click the Layer MIDI Input Bypassed checkbox.

The layer darkens in the Layer Editor tab, and the channel strip instrument is bypassed.

Copy and paste layer properties in MainStage

You can copy and paste layer properties in the Instrument Channel Strip Inspector. When you copy or paste layer properties, the following values are copied from (or pasted to) the current layer:

- High Key and Low Key
- Floating Range Up and Floating Range Down
- Velocity Min and Velocity Max

Copying and pasting layer properties can greatly simplify creating multiple layers with the same key ranges or velocity values. After pasting, values can be edited as with any layer.

Copy properties from the current layer

- In MainStage, click the Action pop-up menu in the Instrument Channel Strip Inspector, then choose Copy Layer Properties.

Paste properties to the current layer

- In MainStage, click the Action pop-up menu in the Instrument Channel Strip Inspector, then choose Paste Layer Properties.
Work with articulations

Overview of managing articulations in MainStage

Sampled instruments that emulate real instruments often allow you to switch between the unique playing techniques that the real instrument is capable of. For example, a sampled violin instrument might offer articulations to switch between tremolo, pizzicato, and sustained notes, while a sampled horn instrument might include articulations for sustained and staccato notes, trills, and falls. These playing techniques are called *articulations*. Each articulation is identified with a unique *Articulation ID*. All the information regarding the available articulations is stored in *Articulation Sets*. Articulation Sets are saved both within saved patches and saved projects.

MainStage offers various ways to choose which articulations to use for the notes that you play:

- For instruments that load with pre-configured Articulation Sets, you can **choose an articulation from the plug-in window header**.
- For instruments with multiple Articulation Sets, you can **Manage articulations with the Articulation Set menu**.
- You can create, view, and change parameters for existing Articulation Sets using the **Articulation Set Editor**.

Choose an articulation from the plug-in header in MainStage

If a software instrument includes articulations, you can choose between articulations using the Articulations pop-up menu in the plug-in window header. Some software instruments let you view the most recently played articulation in the plug-in interface as well.

*Choose an articulation from the plug-in window header*

- In MainStage, click the Articulation pop-up menu in the plug-in header and choose from the available articulations.
Manage articulations with the MainStage Articulation Set menu

You can select Articulation Sets, as well as edit, delete, and create new Articulation Sets, from the Articulation Set pop-up menu in the Layer Editor of the Channel Strip Inspector.

Choose an Articulation Set
1. In the MainStage Channel Strips area, select the channel strip.
2. In the Channel Strip Inspector, click the Layer Editor tab.
3. In the Articulation Set pop-up menu, choose the Articulation Set you want to use.

Create a new Articulation Set
1. In the MainStage Channel Strips area, select the channel strip.
2. In the Channel Strip Inspector, click the Layer Editor tab.
3. In the Articulation Set pop-up menu, choose New.

The Articulation Set Editor opens with an empty Articulation Set. See Manage articulations with the Articulation Set Editor for more information.

Edit an Articulation Set
1. In the MainStage Channel Strips area, select the channel strip.
2. In the Channel Strip Inspector, click the Layer Editor tab.
3. In the Articulation Set pop-up menu, choose the Articulation Set you want to edit.
4. In the Articulation Set pop-up menu, choose Edit.

The Articulation Set Editor opens with the articulations from the loaded Articulation Set. See Manage articulations with the Articulation Set Editor for more information.

Save an Articulation Set
1. In the MainStage Channel Strips area, select the channel strip.
2. In the Channel Strip Inspector, click the Layer Editor tab.
3. In the Articulation Set pop-up menu, choose an Articulation Set.
4. In the Articulation Set pop-up menu, choose Save As.

This opens a Save As window where you can name your Articulation Set and set the location. It is recommended that you do not change the location from the default Articulation Set folder.
5. Click Save. Your new Articulation Set now appears in the Articulation Set pop-up menu.
Managing Articulations with the MainStage Articulation Set Editor

The Articulation Set Editor can be used to create sophisticated key switch and controller switch definitions, and define output transformations, which enables compatibility with third party sample libraries. You can also use the Articulation Set Editor to create Articulation Sets for instruments that have assigned Articulation IDs to sample groups, but do not have pre-configured articulations. For example, some Sampler instruments come pre-configured with specific sample groups identified by an Articulation ID but do not have pre-configured Articulation Sets.

The Articulation Set Editor consists of three panes: Articulations, Switches, and Output.

The Articulations pane

The Articulations pane is where you can define specific articulations, including their names and IDs. The articulations defined here populate the articulation menus in the plug-in header and the various editors.

You can set articulations to be triggered by MIDI channel rather than an articulation ID. This can be useful for instruments whose MIDI channels are used to control additional properties.

The Articulations pane contains a table showing the following parameters:

- **Name field**: Type a name for your articulation in this field.
- **Articulation ID field**: Type a number to be the Articulation ID for your articulation. For Sampler based instruments that use the articulation ID for group selection, choose the corresponding articulation ID. For any other instruments, an output transformation needs to be defined on the output page (converting the articulations back into keyswitches), and the IDs can be arbitrary.
- **Channel pop-up menu**: Choose a MIDI channel for the articulation, or choose “-“ for all MIDI channels.
• **Symbol pop-up menu:** Choose a notation symbol to represent the articulation in the Score Editor.

• **Revert button:** Reverts any changes done to the articulations to their saved state.

• **Plus and minus buttons:** Use these buttons to create and remove articulations.

**The Switches pane**

The *Switches pane* is where you create and customize keyswitches and controller switch assignments for each articulation. You can determine the type of MIDI message to use for switches, what values within that MIDI message to use, and you can specify the articulation behavior when the switch is triggered.

It includes the following controls:

• **MIDI Remote button:** This button has to be active for your articulation switches to respond to the defined MIDI messages. If MIDI Remote is off, you cannot control your articulation switches remotely with your attached MIDI device. For example, you might want to turn off MIDI Remote if you want to play an instrument live using the full keyboard range without risking an accidental switch between articulations.

• **MIDI Channel pop-up menu:** Sets a specific MIDI channel for all your keyswitches. This is useful if you have a dedicated keyboard for keyswitches or you want to limit your keyswitches to a particular MIDI channel.

• **Octave Offset pop-up menu:** Sets an offset for the octave used for keyswitches. You can set an offset of up to plus or minus ten octaves. This can be useful in particular for bass instruments; keyswitches are often set to very low octaves, with bass instruments you may want to move the keyswitches to higher octaves and leave the lower octaves free for playing.

These three controls can be set locally in the Switches pane, or globally to affect how all instruments with articulations behave. To determine if these settings are local or global, see **MIDI settings**.
Below the controls is a table showing each articulation, along with the following parameters:

- **Type pop-up menu**: Chooses the specific type of MIDI message used to activate the articulation. Note On is the standard MIDI message used to trigger articulations, but Note Off, Poly Aftertouch (polyphonic aftertouch), Controller, Program (program change), Aftertouch (monophonic aftertouch), and Pitch Bend are also supported.

- **Selector pop-up menu**: Determines which specific value of the MIDI message chosen in the Type column triggers the articulation. For example, if you chose Note On in the Type column, here is where you would choose the specific note for the keyswitch. If you chose Controller in the Type column, you would choose the specific controller number. If you choose Program, Aftertouch, or Pitch Bend in the Type column, there will be no Selector value.

- **Value Start slider**: Defines the low end of the range for the controller switches. For Note On/Off messages, this relates to velocity values.

- **Value End slider**: Defines the high end of the range for the controller switches. For Note On/Off messages, this relates to velocity values.

- **Mode pop-up menu**: Selects between different switch modes. These different switch modes exist in order to support both variations in your playing style and special articulation features.
  - **Permanent**: Switches to the selected articulation, which then is used for all subsequent notes until another articulation is selected. This is useful for the main (standard) articulations such as Sustain, Staccato, and other common playing techniques.
  - **Permanent (Retrigger)**: Stops the currently sounding note and retriggers it immediately with the newly selected articulation. The new articulation is used for all the following notes until another articulation is selected.
  - **Permanent (Trigger)**: Immediately applies the newly selected articulation to the currently playing note. As soon as the switch is disengaged, all notes are stopped. This is useful to trigger falls, doits, and so on, at the end of a musical phrase.
  - **Momentary**: Activates the keyswitch only while the switch is within its defined Value range. For Note On or Note Off articulations this means the articulation switches only while the key is depressed or released respectively; for controllers the articulation is selected as long as the value is within the value start and end range. This is useful for articulations you only want to use for one note or a very short passage such as growls, trills, and so on.
  - **Momentary (Retrigger)**: Stops the current note and retriggers it immediately with the selected articulation while the switch is within its defined Value range. For Note On or Note Off articulations this means the articulation switches only while the key is depressed or released respectively; for controllers the articulation is selected as long as the value is within the value start and end range.
  - **Momentary (Trigger)**: Immediately applies the newly selected articulation to the currently playing note while the switch is within its defined Value range. As soon as the switch is disengaged all notes are stopped. This is useful to trigger falls, doits, and so on, at the end of a musical phrase.
• **Toggle**: Activates the selected articulation when the switch is engaged. When the switch is engaged again it reactivates the previous articulation. This is useful when you want to toggle between two articulations, such as sustained notes and palm muting.

• **Toggle (Retrigger)**: Stops the currently sounding note and retriggers it immediately with the newly selected articulation. When the switch is engaged again it reactivates the previous articulation.

• **Toggle (Trigger)**: Immediately applies the newly selected articulation to the currently playing note. As soon as the switch is disengaged all notes are stopped. This is useful to trigger falls, doits, and so on, at the end of a musical phrase.

• **Articulation pop-up menu**: Choose the articulation for the switch. You can use the same articulation multiple times, each triggered by a different type or selector, and with different value ranges.

• **Revert button**: Reverts any changes made to the switches to their saved state.

• **Plus and minus buttons**: Use these buttons to create and remove the selected switch.

**The Output pane**

For instruments that don’t support the use of articulation IDs directly, you can use the Output pane to define how articulations are accessed in your particular instrument. Output articulations are mostly keyswitches. Some third-party sampler instruments also use controllers as switches.

Working in the Output pane, you can define output triggers for articulations, which means that you can use triggers with third-party libraries for which pre-configured Articulation Sets do not already exist. Because the output triggers are independent of the switches, they can be used to create setups with consistent switches across different libraries.
The Output pane consists of a table showing each articulation, along with the following parameters:

- **Name field**: Displays the name of the articulation.
- **Type pop-up menu**: Choose the specific type of MIDI message that is used to activate the articulation. Note On is the standard MIDI message used to trigger articulations, but Note Off, Poly Aftertouch (polyphonic aftertouch), Controller, Program (program change), Aftertouch (monophonic aftertouch), and Pitch Bend are also supported.
- **Channel pop-up menu**: Choose a MIDI channel for the articulation, or choose “-” for all MIDI channels. This is useful when third-party sample libraries use specific MIDI channels for articulations.
- **Selector pop-up menu**: Determines which specific value of the MIDI message chosen in the Type column triggers the articulation. For example, if you chose Note On in the Type column, here is where you would choose the specific note for the keyswitch. If you chose Controller in the Type column, you would choose the specific controller number.
- **Value Start slider**: Defines the low end of the range for the controller switches.
- **Value End slider**: Defines the high end of the range for the controller switches.
- **Activate Multiple Outputs checkbox**: Define up to three MIDI messages that can be sent to an instrument in order to activate an articulation. This may be necessary for instruments that require, for example, one MIDI message to chose a category and another MIDI message to choose an articulation within that category.
- **Revert button**: Reverts any changes made to the output assignments to their saved state.

**Choose an Articulation Set**
- In the Layer Editor tab of the MainStage Instrument Channel Strip Inspector, choose an Articulation Set from the Articulation Set pop-up menu.

**Open the Articulation Set Editor**
- In the Layer Editor tab of the MainStage Instrument Channel Strip Inspector, choose Edit from the Articulation Set pop-up menu.

**Create a new articulation**
- In the MainStage Articulations pane, click the “+” button at the bottom left of the Articulation Set Editor window.

**Remove an articulation**
- In the MainStage Articulations pane, select an articulation and click the “-“ button at the bottom left of the Articulation Set Editor window.

**Revert to a previously saved version of articulations**
- Click the Revert button at the bottom left of the MainStage Articulation Set Editor window.
Turn all articulations on or off in MainStage

You can turn on or off all articulations using the Articulation MIDI Remote command, available either in the Action menu or via a key command.

Turn articulations on or off
In MainStage, do one of the following:

• Press the key command for Articulation MIDI Remote.
  
  *Note:* First, you need to assign Articulation MIDI Remote to a key command in the Key Command Editor; see *Edit keyboard shortcuts* for more information.

• In the Action menu, choose Articulation MIDI Remote.

• If you have added the Articulation MIDI Remote button to the toolbar, click the button. For more information on adding buttons to the toolbar, see *Customize the toolbar*.

Edit screen control parameters

Overview of the Screen Control Inspector in MainStage

In Layout mode, you edit basic screen control parameters that are constant throughout the entire concert. The Screen Control Inspector is where you edit screen control parameters for a specific patch or set. In the Screen Control Inspector you can:

• Replace parameter labels

• Choose custom colors for screen controls

• Change the appearance of grouped screen controls

• Set the behavior of screen controls

• Override concert- and set-level mappings

The Screen Control Inspector consists of three tabs:

• *Attributes:* You can change the behavior and appearance of screen controls.

• *Mapping:* You can see and edit the mappings of screen controls to hardware or software parameters. For more information on mapping screen controls, see *Overview of mapping screen controls*.

• *Unmapped:* If a screen control is unmapped, you can map it to a hardware or software parameter. For more information on mapping screen controls, see *Overview of mapping screen controls*.

Open the Screen Control Inspector

1. In MainStage, enter Edit mode, either by clicking the Edit button on the toolbar, choosing Edit from the View menu, or via a key command.

2. Choose Show Inspectors from the View menu. If the Inspector is already showing, you can skip this step.

3. Select a screen control in the Workspace.
Replace parameter labels in MainStage

You can replace the parameter label for a screen control (for an individual patch or a set) to make the label easier to identify.

Replace the parameter label for a screen control
1. In MainStage, select the screen control in the workspace.
2. In the Screen Control Inspector, select the Attributes tab, then select the Replace Parameter Label checkbox (or press Control-Option-L).
3. Enter the new label text in the field.

Choose custom colors for screen controls in MainStage

You can change the color of the active area of a screen control (for an individual patch or a set) and also change the color of the text for a screen control.

Choose a custom color for a screen control
1. In MainStage, select the screen control in the workspace.
2. In the Screen Control Inspector, click the Attributes tab.
3. Select the Custom Color checkbox, then choose a new color from the Custom Color pop-up menu.
4. Select the Custom Label Color checkbox, then choose a new color from the Custom Label Color menu.

Change background or grouped screen control appearance in MainStage

You can change the appearance of a background screen control or grouped set of screen controls by choosing a different panel or adding a custom image.

Change the panel for a background or grouped screen control
1. In MainStage Edit mode, Option-click the screen control in the workspace.
2. In the Screen Control Inspector, make sure that the Custom Background checkbox is selected.
3. Click the Panel button.
4. Click the Panel well, then choose a new panel from the pop-up menu.

Add a custom image for a background or grouped screen control
1. In MainStage Edit mode, Option-click the screen control in the workspace.
2. In the Screen Control Inspector, make sure that the Custom Background checkbox is selected.
3. Click the Image button, then click Select.
4. In the dialog that appears, browse to the image you want to use, select the image, then click Choose Image.
Set MainStage screen controls to show the hardware value

By default, screen controls show the value of the parameter the control is mapped to. Alternatively, they can show the value of the hardware control assigned to the screen control; for example, when the screen control is assigned to a foot pedal or when the screen control is mapped to multiple parameters.

Set a screen control to show the hardware value
1. In MainStage, select the screen control in the workspace.
2. In the Screen Control Inspector, click the Attributes tab.
3. Select the Show Input Value checkbox.

Set parameter change behavior for MainStage screen controls

You can set the behavior for saving parameter values for screen controls in individual patches. This is useful, for example, when the default for saving parameter values is set to Reset, but you want certain screen controls (for example, concert- and set-level screen controls) to keep their current value when switching patches.

Set the behavior for saving parameter values in a patch
1. In MainStage, select the patch.
2. Select the screen control for which you want to set the parameter change behavior.
3. In the Attributes tab of the Screen Control Inspector, choose the parameter change behavior for the screen control from the On Patch Change pop-up menu:
   • To have the screen control use the default behavior set in MainStage Settings: Choose Setting.
   • To preserve changes to parameter values when you change patches: Choose Keep.
   • To return values to the last saved value: Choose Reset. When this value is chosen, you should save the concert after making any changes you want to keep to the patch, before selecting another patch.
   • To have the screen control use the last received value from the physical control assigned to it: Choose Match.

When you choose an item from the pop-up menu, a brief description of its function appears below the menu.

Important: If you set the behavior for saving parameter values in a patch to Reset, parameter values are also reset when you switch to Layout mode.
Set hardware matching behavior for MainStage screen controls

Some hardware synthesizers and music workstations let users control what happens when you move a physical control that is set to a different value than the parameter it modifies. The parameter value can instantly change to the position of the physical control (sometimes called jump), it can change by the same amount (called relative), or it can not change at all until the physical control matches its current value (called snap).

You can set the behavior for screen controls in MainStage to any of these behaviors when you move the physical control assigned to the screen control.

Set the behavior for screen controls when you move a hardware control

1. In MainStage, select the patch.
2. Select the screen control for which you want to set the hardware matching behavior.
3. In the Attributes tab of the Screen Control Inspector, choose the parameter change behavior for the screen control from the “When hardware value differs from screen value” pop-up menu:
   - To have the screen control use the default behavior set in MainStage Settings: Choose Setting.
   - To have the screen control instantly change to match the hardware value: Choose Jump.
   - To have the screen control change when the hardware control matches its current value: Choose Pickup.
   - To have the screen control move relative to the hardware control: Choose Relative.

   Note: When you choose an item from the menu, a brief description of its function appears below the pop-up menu.

Reset and compare changes to a patch in MainStage

You can reset changes to all parameters in a patch that are mapped to screen controls to their last saved value, letting you hear the patch in its last saved (original) state, and toggle between the original and modified states of the patch.

Reset and compare changes using the Reset/Compare action

1. In MainStage Layout mode, add a button screen control to your layout.
2. Assign a button on your hardware controller to the new button screen control.
3. In Edit mode, click the concert icon in the Patch List.
4. Select the new button screen control in the workspace.
5. In the Parameter Mapping browser, select the Actions folder, and then select the Reset/Compare Patch action in the second column.

For more information about mapping a screen control at the concert level, see Map a screen control at the concert level.
Override concert- and set-level mappings in MainStage

By default, mappings you make at the concert level (to parameters and actions) take precedence over mappings to individual patches or sets in the concert. If you map a screen control to a parameter at the concert level (for example, to Master Volume), that screen control can’t be mapped to a parameter or action in a patch or set unless you override the concert-level mapping.

Similarly, mappings you make at the set level take precedence over mappings for any patches in the set. If you map a screen control to a parameter at the set level (for example, to an effect on a set-level channel strip), that screen control cannot be mapped to a parameter or action in a patch in the set unless you override the set-level mapping.

If you try to map a screen control that is mapped at the concert or set level, text appears in the Screen Control Inspector informing you that the screen control is mapped at another level, and the parameters in the Screen Control Inspector are dimmed. You can override the concert- and set-level mappings for an individual patch, and then map the screen control at the patch level.

Override concert-level mappings
• In the MainStage Screen Control Inspector, select the Override Concert Mapping checkbox.

   ![Screen Control Inspector](image)

   Select the checkbox to override mappings at the concert level.

   The parameters in the Screen Control Inspector become active.

Override set-level mappings and other parameters for a patch
• In the MainStage Screen Control Inspector, select the Override Set Mapping checkbox.

   The Parameter Mapping section becomes active so that you can map the parameter.

Mapping tabs for concert-level mappings are available only at the concert level, and mapping tabs for set-level mappings are available only at the set level. When you override a concert- or set-level mapping, the mapping tabs become available at the level of the override.
Map screen controls

Overview of mapping MainStage screen controls

After you have created your patches and learned controller assignments for the screen controls you want to use, you can map MainStage screen controls to channel strip and plug-in parameters to modify the sound of your patches while you perform or map them to MainStage actions to control other functions. You may want to map screen controls to parameters in each patch in a concert, so that you can easily access and modify the parameters you want for each patch when you perform live.

You map screen controls to parameters in Edit mode. After you learn controller assignments (in Layout mode), the screen controls in the workspace do not respond to movements of physical controls on your MIDI hardware until you map them to channel strip parameters (in Edit mode). You can map screen controls to parameters by visually selecting the parameters or by choosing parameters in the Parameter Mapping browser. You can also create mappings in the Assignments & Mappings table. For information, see Overview of assignments and mappings. You can also move, resize, align and distribute, group, and delete screen controls.

Map MainStage screen controls to channel strip and plug-in parameters

After you have made controller assignments, you can map screen controls to the parameters in your patches you want to control while you are performing. You may want to map screen controls to parameters for each patch in a concert, so that you can easily access and modify the parameters you want for each patch when you are performing live. You can also map parameters at the concert level to control master volume, view master levels, or modify concert-wide effects.

You can map screen controls to channel strip and plug-in parameters in one of two ways: by mapping screen controls visually to parameters on the channel strip or in a plug-in window or by using the Parameter Mapping browser.

You map screen controls to parameters in Edit mode. The screen controls in the workspace do not respond to movements of physical controls on your MIDI hardware until you map them to channel strip parameters.

Map a screen control to a channel strip or plug-in parameter

1. In the MainStage workspace, click the screen control you want to map.
   
   The screen control is highlighted in blue. The Screen Control Inspector appears below the workspace, showing the parameters for the selected screen control. The Screen Control Inspector includes Attributes and Mapping tabs as well as a tab labeled “Unmapped.”

2. Click the Map Parameter button (or press Command-L).
   
   The Screen Control Inspector opens to the Unmapped tab, showing the Parameter Mapping browser. The Map Parameter button lights red to indicate that mapping is active.
3. To map the screen control to a channel strip parameter, click the control for the parameter on the channel strip in the Channel Strips area.

4. To map the screen control to a plug-in parameter, double-click the plug-in in the Inserts section of the channel strip to open the plug-in window, then click the parameter in the plug-in window.

The screen control is mapped to the selected parameter, and the Unmapped tab takes the name of the parameter. If you hover the pointer over the Unmapped tab label the entire mapped parameter path is temporarily displayed.

You can continue mapping additional screen controls by clicking them in the workspace and then clicking the corresponding parameters in a channel strip or plug-in window.

5. When you finish, press Command-L (or click the Map Parameter button) to turn off mapping.
Map a screen control using the Parameter Mapping browser

1. In the MainStage workspace, click the screen control you want to map.

   The screen control is highlighted in blue. The Screen Control Inspector appears below the workspace, showing the parameters for the selected screen control. The Screen Control Inspector includes General and Mapping tabs as well as a tab labeled “Unmapped.”

2. In the Screen Control Inspector, click the Unmapped tab.

   The Parameter Mapping browser appears, showing the channel strips and plug-ins available for mapping as well as the Actions folder.

3. In the column on the left of the Parameter Mapping browser, select the channel strip with the parameter to which you want to map the screen control.

   Parameters for the selected channel strip appear in the columns on the right. Additional folders for the instruments and effects in the channel strip may appear in these columns. Click a folder to see the parameters for that instrument or effect.

4. Select the parameter you want to map.

   The screen control is mapped to the selected parameter, and the Unmapped tab takes the name of the parameter. You can continue mapping additional screen controls by clicking them in the workspace and then choosing parameters in the Parameter Mapping browser. Using the Parameter Mapping browser, you can map parameters that are not visible in plug-in windows.

   You can also map screen controls to MainStage actions and to AppleScript scripts. For more information, see Map screen controls to actions.

   Note: If you change the channel strip setting for a channel strip to which you have mapped screen controls, you lose any parameter mappings.

   You can also edit velocity sensitivity for a channel strip, create controller transforms, and filter various MIDI messages. For information about editing channel strips, see Overview of the Channel Strip Inspector.
Map MainStage screen controls to actions

In addition to mapping screen controls to channel strip and plug-in parameters, you can map them to MainStage actions. Actions let you select patches and sets; silence MIDI notes; control the Tuner and the metronome; tap a new tempo; display information about patches, MIDI messages, and other information; and perform other functions.

For a complete table of actions, including descriptions and usage notes, see Overview of actions.

The Actions folder, which appears in the Parameter Mapping browser along with available parameters, contains actions for selecting patches and sets, showing the Tuner, activating tap tempo, Master Mute, Panic, and other functions. The Actions folder also contains an AppleScript subfolder with useful scripts.

You can map button screen controls to actions for selecting different patches and use physical buttons on your MIDI device to select patches when you perform. You can also map buttons to actions for selecting different sets or selecting the concert. For information about assigning buttons, see Button assignments.

Map a screen control to an action

1. In the MainStage workspace, click the screen control you want to map.

   The Screen Control Inspector appears below the workspace, showing the settings for the selected screen control. If the screen control is currently mapped, a tab with the name of the mapping is visible in addition to the General and Mapping tabs. If the control is unmapped, the tab is labeled “Unmapped.”

2. Click the Unmapped (or name of mapping) tab.

   The Parameter Mapping browser appears below the workspace. The Actions folder is available in the Parameter Mapping browser.

3. In the column on the left of the Parameter Mapping browser, click the Actions folder.

   The available actions appear in the second column of the browser.

4. Select the action you want to map.

   Note: If you map a knob screen control to an action to select a patch (such as the −10 Patches, Previous Patch, Next Patch, or +10 Patches action), the screen control jumps to the value of the hardware control, regardless of the setting of the Respond to Hardware Move parameter in the Screen Control Inspector.
Map a MainStage screen control to multiple parameters

You can map a single screen control to multiple parameters and control how the screen control modifies each mapped parameter. Mapping a screen control to multiple parameters is also referred to as multimapping. You map a screen control to up to eight parameters by adding mappings in the Screen Control Inspector.

If you create multiple mappings for a screen control, you can define the relationships between the first mapping and subsequent mappings. This can be especially useful when, for example, you are mapping the same control to filter cutoff and filter resonance, and you want to ensure that resonance doesn't exceed a certain maximum value as you increase the cutoff value. The default relationship affects all future mappings (for the same and other screen controls), but does not affect existing mappings. The default is set to Scale the first time you open MainStage.

Add a mapping

1. In MainStage, map the screen control to a parameter or action, as described in Map to channel strip and plug-in parameters and Map screen controls to actions.
2. With the screen control selected, click the Add Mapping (+) button at the upper-right corner of the Screen Control Inspector.
   A new Unmapped tab appears in the Inspector, showing the Parameter Mapping browser.
3. In the Parameter Mapping browser, choose the parameter to which you want to map the screen control.

If you add a mapping while the Learn process is active (the Assign & Map button is red), you can immediately learn the new mapping. There are key commands for selecting the previous and next tab to make mapping to multiple parameters easier. For more information, see Parameter mapping (Edit mode) keyboard shortcuts.

View all mappings for a screen control

• In the MainStage Screen Control Inspector, click the Mappings tab.
   The mappings appear in a list view that shows the minimum and maximum range values and patch change behavior for each mapping and includes buttons to open the Parameter graph and Invert graph values for each mapping.

Define the default relationship between the first mapping and subsequent mappings

1. In MainStage, select a screen control you want to map to multiple parameters.
2. In the Screen Control Inspector, click the Action pop-up menu ☐, then choose Default Relation to First Mapping.
3. Do one of the following:
   • To set subsequent mappings to be offset by a fixed value from the first mapping: Choose Offset.
   • To set subsequent mappings to scale by a constant ratio, starting from the same minimum value: Choose Scale.
   • To set subsequent mappings to scale by a constant ratio to the point defined for the mapping, starting from both the same minimum value and maximum value: Choose Pivot.
Use screen controls to display PDF document pages in MainStage

You can import a multipage PDF document into your layout and then use screen controls to select a page or turn the pages. This is useful if, for example, you want to add a PDF of sheet music or lyrics to your layout and then advance the pages as you perform. In MainStage, you import the PDF into a Background screen control.

Add multi-page PDF documents

In order to map screen controls to turn the pages of a multipage PDF, your layout must contain at least one Background screen control with a multipage PDF selected as the image, and one Patch List screen control to act as a table of contents for your PDF. If your layout does not already contain these items, follow the steps below:

1. In MainStage, click the Layout button at the upper-left corner of the MainStage window (or press Command-1).
2. Drag one of the Patch List screen controls from the Screen Controls palette to the workspace.
3. In the Patch List screen control, click the list.
4. In the Screen Control Inspector for the Patch List screen control, select the Patch Names or Markers checkbox.

5. Drag a Background screen control from the Screen Controls palette to the workspace.

6. In the Screen Control Inspector for the Background screen control, click the Image button.

7. Drag your multipage PDF into the image well, or click the Select button, browse to the location of the PDF, and select it.

If you have multiple PDFs—for example, to add both a PDF of sheet music and a PDF of lyrics—repeat the steps above to add both a Patch List and Background screen control to your layout for each PDF.

Map screen controls to turn pages of a multi-page PDF

With a multipage PDF as a Background image and a dedicated Patch List screen control for that PDF, you can then map the Next Patch and Previous Patch buttons at the bottom of the Patch List to navigate from one page to the next.

1. In MainStage, click the Edit button at the upper-left corner of the MainStage window (or press Command-2).

2. Select the Patch List screen control you wish to assign to the multipage PDF.

3. In the Attributes tab of the Screen Control Inspector, choose Image/PDF Object 1.

All the page numbers in your multipage PDF appear in the Patch List.

4. Click the Next Patch button at the bottom of the Patch List screen control.

5. In the Attributes tab of the Screen Control Inspector, select Override Concert Mapping.


The name of the parameter tab changes to PDF Page.

7. In the Range Mode pop-up menu, choose Increase Value.

8. Repeat steps 5 and 6 for the Previous Patch button at the bottom of the Patch List screen control.


You can now click the Next Patch and Previous Patch buttons to move forward or backward one page at a time in your multipage PDF.
If you have multiple PDFs, follow the steps above for each Patch List screen control associated with each additional PDF, incrementing the numbering—so if you have two PDFs, in your second Patch List screen control in step 3 you would choose Image/PDF object 2, and so on.

You are not limited to only turning pages using the Next Patch and Previous Patch buttons below the Patch List screen control. Using the Assignments & Mappings tab, you can assign any assignable screen control to increase and decrease value. For example, if you wanted larger screen buttons to turn pages, you could use Drum Pad screen controls. Or if you wanted to turn pages using your MIDI keyboard, you could assign one key on your MIDI keyboard to increase and another key to decrease page numbers. See Overview of assignments and mappings in MainStage and Map screen controls to actions for comprehensive instructions on how to assign screen controls to parameters.

**Map screen controls to select a page of a multipage PDF**

With a multipage PDF as a Background image and a dedicated Patch List screen control for that PDF, you can then map any screen control to select a page of the PDF by changing the patch number in the Patch List.

1. In MainStage, if you haven’t already associated a Patch List screen control with the multipage PDF you want to use, follow steps 1 through 3 in the previous task.
2. Select the screen control you want to select a page in your PDF.
3. In the Unmapped tab of the Screen Control Inspector, choose Actions > Image/PDF Objects > Image/PDF Object 1.
   - If you have multiple PDFs in your layout, use the PDF Object number for the PDF with the page you wish to select.
   - The name of the parameter tab changes to PDF Page.
4. In the Range Mode pop-up menu, choose Standard.
5. In the Button On and Button Off pop-up menus, choose the number of the page you wish to select.
   - Triggering the screen control now selects the specific numbered page in your PDF you chose in step 5.

You can assign multiple screen controls to select individual page numbers in the same PDF. You can also assign multiple screen controls to select individual page numbers in separate PDFs. Using the Assignments & Mappings tab, you can assign any screen control capable of being assigned to select a patch number to select a page in a multipage PDF. See Overview of assignments and mappings in MainStage and Map screen controls to actions for comprehensive instructions on how to assign screen controls to parameters.
Edit the saved value for a mapped parameter in MainStage

Each mapped parameter has a saved value. You can view and edit the saved value for each parameter mapping in the Mappings tab of the Screen Control Inspector. If you change the value of a parameter in performance by manipulating screen controls, those changes are saved only for the selected patch. Editing the saved value in the Screen Control Inspector ensures that the value is saved, regardless of whether the patch is selected.

Adjust the minimum range value for a mapped parameter

1. In the MainStage Screen Control Inspector, click the Mappings tab.
   
   The current saved minimum range value appears in the Range Min column for the mapped parameter.

2. Drag the slider to raise or lower the value.

Adjust the maximum range value for a mapped parameter

1. In the MainStage Screen Control Inspector, click the Mappings tab.
   
   The current saved maximum range value appears in the Range Max column for the mapped parameter.

2. Drag the slider to raise or lower the value.

Switch the minimum and maximum range values for a mapped parameter

1. In the MainStage Screen Control Inspector, click the Mappings tab.

2. Select the Invert checkbox in the Invert column for the mapped parameter.

Open the Parameter graph for a mapping

1. In the MainStage Screen Control Inspector, click the Mappings tab

2. Click the Graph button for the mapping you want to edit.

   See Work with graphs for more information on how to use the graphs.

Set how a mapped parameter behaves when changing patches

The On Patch Change pop-up menu in the General settings pane determines how saved mapped parameters behave when changing patches. However, you can choose to set a custom behavior for a mapped parameter in the Mappings tab of the Screen Control Inspector.

1. In the MainStage Screen Control Inspector, click the Mappings tab.

2. Select the On Patch Change pop-up menu in the On Patch column for the mapped parameter, and choose from the following options:

   • Setting: The parameter value behavior when changing patches is determined by the On Patch Change pop-up menu in the General settings pane.
• *Keep current value*: The current value of the parameter is retained when changing patches.

• *Reset to saved value*: The parameter value resets to the saved value when changing patches.

• *Match hardware value*: The parameter value is set to the current hardware value when changing patches.

*Note:* When you save a concert, the current value of each screen control in the currently selected patch is saved in the concert. You can see the values update in the Screen Control Inspector. When you export a patch, the current parameter values become the saved values in the exported patch.

**Set drum pads or buttons to use note velocity in MainStage**

When you map a drum pad or button to a non-binary parameter (for example, to Volume or Expression), you can set the screen control to use note velocity. This can make help make performing with these controls more dynamic and expressive.

**Set a drum pad or button screen control to use note velocity**

1. In MainStage, map the screen control to a non-binary parameter, such as Volume.
2. In the Screen Control Inspector, click the tab for the mapping.
3. Select the “Use note velocity” checkbox.

**Map MainStage screen controls to all channel strips in a patch**

When you map a screen control to a channel strip parameter such as volume or pan, you can map it to control the same parameter in all of the channel strips in the patch. This is particularly useful when you want to control the overall volume of a layered sound, even if the different layers are played across multiple keyboards.

**Map a screen control to all channel strips in a patch**

1. In MainStage, map the screen control to a common screen control parameter, such as volume or pan.
2. In the column on the left of the Parameter Mapping browser, select the Send to All folder.
3. Select the destination from the second column.
4. Select the parameter to map the screen control to from the third column.

You can map the screen control to actions for transposing software instrument channel strips, channel strip parameters, and MIDI control message types from the Destinations folder. When you map a screen control to all channel strips in a patch, the parameter to which the screen control is mapped changes to the same value for all channel strips in the patch when you move the screen control.

*Note:* When you map a drum map using Send to All, the Send to All folder contains MIDI notes, not controllers.
Undo MainStage screen control parameter mappings

You can undo parameter mapping if you decide you do not want to keep the mapping. When you undo parameter mapping, all mappings created in the current Learn mode (either by pressing Command-L or clicking the Map Parameter button) session are undone.

**Undo parameter mappings**

- In MainStage, choose Edit > Undo (or press Command-Z).

Remove screen control mappings in MainStage

If you want a screen control to be free of any mappings, you can remove its existing mapping. This can be useful with controls that pass through MIDI messages (for example, for pitch bend and modulation wheels, or expression pedals) when you do not want them to send MIDI messages for their pass-through control type. You do not need to remove the mapping for a screen control when you remap it.

**Reset the mapping for a screen control**

1. In the MainStage workspace, click the screen control you want to map.
2. In the column on the left of the Parameter Mapping browser, click None.

Work with graphs in MainStage

Each parameter mapping has a Parameter graph. You can edit the graph to remap input values to different output values for the parameter. Using graphs, you can graphically remap the values for some MIDI control messages so that input values from your controller produce different output values for the channel strip or plug-in parameter. Graphs make it easier to see and modify a range of values for a parameter, such as velocity or filter cutoff.

You can use graphs for the following types of parameters:

- Controller transforms
- Velocity scaling (both input velocity and note input)
- Parameters to which a screen control is mapped

You open a graph window by clicking the button for that type of graph in the appropriate Inspector. The Transform and Velocity Scaling graphs for the selected channel strip are available in the MIDI Input tab of the Channel Strip Inspector. The Parameter graph for the selected screen control is available in the tab for the individual mapping, as well as in the Mappings tab in the (Edit mode) Screen Control Inspector.

The graph shows the range of input values on the horizontal (x) axis, moving from left to right, and shows the range of output values on the vertical (y) axis, moving from bottom to top.

In the graph window, you have several ways of working. You can edit the graph curve directly, edit values numerically using the Precision Editor, or use the Curve buttons to set the graph to one of the predefined curves.
Edit a graph

1. In MainStage, select the channel strip or screen control you want the graph to apply to.

2. Select the MIDI Input tab (for transform and velocity scaling graphs) or the Mapping tab (for parameter mapping graphs).

3. Click the graph button for the type of graph you want to edit.

4. In the graph window, do one of the following:
   - To set the graph to one of the preset curves, click one of the Curve buttons.
   - Click the curve at the point where you want to add a node, then drag the node to the desired value. Drag horizontally to change the input value, or vertically to change the output value.
     As you drag, the current values of the node appear next to the pointer.

   • Double-click the curve at the point where you want to add a node, then edit the values for the node in the Precision Editor.

   • To delete a node, click to select it, then press Delete.

   • Option-click any part of the curve (except a node), then drag the dotted part of the curve to make the curve nonlinear.

5. Continue adding and adjusting points on the curve until you achieve the result you want.

6. When you finish, click the close button at the upper-left corner of the graph window, or press the Escape (Esc) key.

After you have edited a graph, the button for the graph in the Inspector shows the edited shape of the graph in a dark blue color to make it easier to identify which graphs you have edited and how.
Create a stepped graph
1. In the MainStage graph window, select the Stepped checkbox.
   The graph window shows two steps, with input and output values.
2. To add steps, click the Add (+) button.
3. To change the input or output values for a step, click the value, then drag vertically.

Copy and paste values
1. In the MainStage graph window, click the Copy button.
2. Open the graph you want to paste the values into, and click the Paste button.

Invert the values of the graph
In MainStage, do one of the following:
• In the graph window, click the Invert button.
• In the tab for the mapping, select the Invert Parameter Range checkbox.

Reset the graph to its default values
• In MainStage, click the Revert to Default button at the top of the graph window.

Close the graph window
• In MainStage, click the close button at the upper-left corner of the graph window, or press the Escape (Esc) key.

Most of the ways you edit graphs are the same regardless of the type of graph, although there are a few features specific to one or another type. For Parameter graphs, you can change the minimum and maximum range values for the graph using the Range Min and Range Max value sliders. For more information, see Create controller transforms and Scale channel strip velocity.
Create controller transforms in MainStage

Using a transform graph, you can remap the values for some MIDI control messages so that input values from your controller produce different output values for the channel strip. A common use of the transform is for expression scaling, where input MIDI expression values are mapped to different output values on a graphic curve.

In addition, you can transform input values for one message type to output values for another message type. For example, you can transform MIDI volume values from your controller to send expression values to the channel strip or transform input breath values to send modulation values. The transform graph provides a very flexible way of remapping both the values and the output destination for these MIDI control messages. In MainStage, you can transform values for pitch bend, channel aftertouch, and MIDI Continuous Controller messages.

You choose the input and output message types and graphically create transform curves in the MIDI Input tab of the Channel Strip Inspector. In a transform graph, the horizontal axis represents input values from your controller, and the vertical axis represents output values sent to the channel strip.

Add a new controller transform

1. In the MainStage Channel Strips area, select the channel strip for which you want to create a controller transform.
2. In the Channel Strip Inspector, select the MIDI Input tab.
3. Click the “+” button at the bottom left of the controller transform area.

Set the input and output message types for a controller transform

1. In the MainStage Channel Strips area, select the channel strip for which you want to create a controller transform.
2. In the Channel Strip Inspector, select the MIDI Input tab.
3. Choose the input message type from the Input Controller pop-up menu.
4. Choose the output message type from the Output Controller pop-up menu.

Open the Transform graph

- In the MIDI Input tab of the MainStage Channel Strip Inspector, double-click the Transform button.

Note: If the output controller is set to Filter, the Transform button is unavailable.

If a patch contains more than one channel strip with a transform graph, the transform curves for the other channel strips in the patch appear in the controller Transform graph window behind the current curve. Each channel strip in the patch can have its own controller transform.

Remove a controller transform

1. In the MainStage Channel Strips area, select the channel strip for which you want to create a controller transform.
2. In the Channel Strip Inspector, select the MIDI Input tab.
3. Click the “-” button at the bottom left of the controller transform area.

For information about editing the graph, see Work with graphs.
Work in the Assignments and Mappings tab

Overview of assignments and mappings in MainStage

You can view and edit assignments and mappings for the selected patch, set, or concert in the Assignments & Mappings table, and create and edit assignments and mappings without leaving Edit mode.

The Assignments & Mappings table shows the following for the selected item:

- **Assignment column**: Lists the assignments in the patch, set, or concert by device and MIDI channel.
- **Screen Control column**: Shows the screen control to which each hardware control is assigned. For detailed information, see Controller assignments overview.
- **Mapping column**: Shows the mapping for each control, following the same order as the Screen Control Inspector.

You can quickly see whether a hardware control is assigned and see the parameter or action to which it is mapped. When you manipulate a hardware control, a yellow dot appears in the row showing its assignment and mapping.

The Assignments & Mappings tab also includes an Action pop-up menu, with items for creating assignments and for selecting a mapping row when it receives MIDI input.

**Show the Assignments & Mappings table**

Do one of the following:

- Click the MainStage Assignments & Mappings tab at the top of the workspace (or press Shift-Command-M).
- Choose View > Select Assignments & Mappings tab.
- Press Shift-Command-M.

Click the Workspace tab at the top of the window (or press Shift-Command-W) to return to the workspace.
Create and delete assignments and mappings in MainStage

The Assignments & Mappings tab includes an Assign & Map button so you can quickly create new assignments and mappings. You can also create assignments and mappings independent of any screen control, allowing you to use a hardware control to adjust the value of a parameter or action for which there is no screen control in the workspace.

You can also delete assignments and mappings in the Assignments & Mappings table. When you select a row in the table with both an assignment and a mapping, only the mapping is deleted. When you select a row containing only an assignment, an alert appears. If the assignment has a screen control, the assignment is deleted but the screen control remains in the table. If the assignment has no screen control, the entire row is deleted.

Create a new assignment and mapping together
1. In the MainStage Assignments and Mappings tab, choose New Assignment from the Action pop-up menu.
   A new, blank row appears in the table.
2. Click the Assign & Map button.
3. Manipulate the hardware control you want to assign.
   The row is updated to show the new assignment.
4. To create a mapping, do one of the following:
   • Select a mapping parameter or action in the Screen Control Inspector.
   • Click a parameter on a channel strip or a plug-in window.
   The table is updated to show the new mapping.

Delete an assignment
1. In MainStage, select the table row with the assignment, then press the Delete key.
2. In the alert that appears, click Delete.

Delete a mapping
In MainStage, select the table row with the mapping, then press the Delete key.

Edit assignments and mappings in MainStage
Using the Assign & Map button, you can also edit existing assignments and mappings in the Assignments & Mappings table.

Edit an existing assignment or mapping
1. In the MainStage Assignments & Mappings table, select the assignment you want to edit.
2. Click the Assign & Map button.
3. To change the assignment, manipulate the hardware control you want to assign.
   The table is updated to show the new assignment.
4. To change the mapping, do one of the following:
   • Select a new mapping parameter or action in the Screen Control Inspector.
   • Click a parameter on a channel strip or a plug-in window.
   The table is updated to show the new mapping.

Edit Hardware Input parameters in MainStage
You can view and edit the Hardware Input parameters for an assignment in the Assignments & Mappings table, allowing you to quickly modify the assignment without leaving Edit mode. For detailed information about particular Hardware Input parameters, see Screen controls overview.

Edit Hardware Input parameters for an assignment
1. In MainStage, click the assignment you want to edit.
2. In the dialog that appears, choose new Hardware Input parameters for the assignment from the pop-up menus.
3. When you finish, click Done, or click anywhere outside the dialog.

Block incoming controller messages in MainStage
You can block incoming controller messages that you do not want MainStage to process. To block incoming controller messages, the controller must not be assigned to any screen control.

Block unassigned controller messages
1. In the MainStage Assignments & Mappings table, select the text “Unassigned” in the Assignment column.
2. In the Screen Control Inspector, deselect the Send all unassigned MIDI to Channel Strips checkbox.
Work with sets

Overview of working with sets in MainStage

Sets are like folders that let you organize patches you want to keep together. Using sets, you can organize patches in any manner. For example, you can put all the patches you want to use in the first part of a performance together or keep all your lead synth patches together. Sets are flexible, so you can use them in whatever way suits your method of working.

Here are some different ways you can use sets:

- To group similar or related sounds into “banks”
- To keep multiple patches you use in a single song together
- To share a set-level instrument or channel strip between a group of songs

Note: As with patches, you can select multiple sets in the Patch List, and edit the parameters common to all the selected sets. The heading “Multiple Selection” appears in the header of the Patch List, and only parameters shared by all the selected sets are available.

Create sets in MainStage

You can create a new, empty set or create a set from a group of selected patches.

Create a new, empty set

- In MainStage, choose New Set from the Action pop-up menu in the upper-right corner of the Patch List.
  
  A new set appears in the Patch List.

Create a set from a group of patches

1. In the MainStage Patch List, select the patches you want to include in the new set.
2. Choose New Set From Selection from the Action pop-up menu in the upper-right corner of the Patch List.

The new set appears in the Patch List containing the selected patches. You can add new patches to the set or drag existing patches into the set.

Rename sets in MainStage

When you create a set, it is given a default name. You can rename a set in the same way you rename a patch in the Patch List.

Rename a set

1. In MainStage, click the set name in the Patch List.
   A text field appears with the set name, which is selected.
2. Type a new name in the set name field.

Collapse sets in the MainStage Patch List

When you collapse a set, you can select the set and use any channel strips or busses at the set level, but you can’t select or play patches in the set while in Edit mode.

Collapse a set

1. In the MainStage Patch List, click the disclosure arrow for the set.

   You can uncollapse the set by clicking its disclosure arrow again. Collapsing a set has no effect on whether you can select patches in the set in Perform mode.

For information about creating and using sets, see Overview of working with sets.
Override concert-level key ranges for a set in MainStage

If a software instrument channel strip exists at the concert level, the concert-level channel strip takes precedence over any set-level software instrument channel strips within its key range. This means that when you play any notes in the key range of the concert-level channel strip on a keyboard controller, you hear only the concert-level channel strip, even when a patch is selected in a set with a set-level channel strip.

You can override the concert-level channel strip for a channel strip at the set level so that the set-level channel strip takes precedence over the concert-level one.

Override concert- or set-level key ranges
1. In the MainStage Patch List, select the set with the channel strip that you want to override the concert-level channel strip.
2. In the Channel Strips area, select the channel strip with the key range that you want to override the concert-level key range.
3. Select the “Override parent ranges” checkbox.

Delete sets in MainStage

You can delete a set if you decide you no longer want it in the concert.

Delete a set
1. Select the set in the MainStage Patch List.
2. Choose Edit > Delete (or press the Delete key).

When you delete a set, the patches in the set are also deleted. To delete the set without deleting the patches, move the patches outside the set before you delete it.

Add a channel strip at the MainStage set level

You can add channel strips at the set level and play the set-level channel strips together with every patch in the set. This can be useful, for example, if you want to use the same bass instrument in a single song or group of songs. You can place the patches for all of the songs in a set, add a channel strip at the set level, and then add a bass instrument to the set-level channel strip. You can set the key range of the bass instrument to play only notes in the lower octaves so that you can play it together with your patches.

Important: If you add a channel strip at the set level, it takes precedence over all of the channel strips in all of the patches in the set. For example, if you add a software instrument channel strip at the set level, the software instrument for the set takes precedence over all of the software instruments in all of the patches in the set that fall within the same key range as the set-wide software instrument.

Add a set-level channel strip
1. In the MainStage Patch List, select the set.
2. Click the Add Channel Strip button (+) at the top of the Channel Strips area.
3. In the New Channel Strip dialog, select the type of channel strip you want to create.
4. Choose the audio output for the channel strip from the Output pop-up menu.
5. For audio channel strips, choose mono or stereo format from the Format pop-up menu and choose the audio input from the Input pop-up menu.

6. Click Create.

Work with set settings

Overview of the MainStage Set Settings Inspector

You edit set parameters in the Set Settings Inspector, which appears below the workspace when the set is selected in the Patch List. With these parameters you can:

• Set the time signature for sets
• Set the tempo to change when you select a set
• Choose a color for the set folder in the Patch List
• Transpose the pitch of incoming notes for a set
• Change the tuning for a set
• Add text notes to a set

The three tabs of the Set Settings Inspector provide the following functions:

• **Attributes**: You can set the time signature, tempo, folder color, and transposition for the set.
• **Tuning**: You can set the tuning method for the set.
• **Notes**: You can add text notes to the set.

Open the Set Settings Inspector

1. Enter MainStage Edit mode, either by clicking the Edit button on the toolbar, choosing Edit from the View menu, or via a key command.

2. Choose Show Inspectors from the View menu. If the Inspector is already displayed, you can skip this step.

3. Select a set (the folder icons under the concert folder) in the Patch List.

Set the time signature for sets in MainStage

You can set the time signature for a set. Time signatures can be used with the Playback plug-in and also affect the beats of the metronome. When you set the time signature for a set, it overrides the concert-level time signature (if one is set).
Set the time signature for a set
1. In the Attributes tab of the MainStage Set Inspector, select the Has Time Signature checkbox.
2. Double-click the number in the field, and enter the number of beats for the time signature.
3. Choose the beat value from the pop-up menu at the right.

Change the tempo when selecting MainStage sets
You can give a set its own tempo setting so that when you select the set, the tempo changes to the set tempo setting. MainStage uses the new tempo until you select another patch or set with its own tempo setting, tap a new tempo, or until MainStage receives tempo information from incoming MIDI messages. For more information about using and changing tempo in MainStage, see Overview of tempo.

Change the tempo using a set
1. In the Attributes tab of the MainStage Set Inspector, select the “Change Tempo to” checkbox.
2. Drag the “Change Tempo to” value slider up and down to set the tempo.

Choose a color for the set folder in the MainStage Patch List
Each set folder can be assigned a separate color in order to help you visually distinguish sets in a concert.
1. In the Attributes tab of the MainStage Set Settings Inspector, select the Color checkbox.
2. Choose a color from the pop-up menu.

Transpose the pitch of incoming notes for a MainStage set
You can transpose the pitch of incoming MIDI notes for every patch in a set at once by using the Transpose Set setting. You can raise or lower the pitch of incoming MIDI notes in semitone increments, to a maximum of 8 octaves higher or lower.

Transpose the pitch of incoming notes
- In the Attributes tab of the MainStage Set Settings Inspector click the Transpose Set slider and do one of the following:
  - Drag the value up or down.
  - Use the arrow keys to raise or lower the value.
  - Type the number of semitones higher or lower you want to transpose the set.

Note: The total amount of pitch transposition applied to incoming notes is the sum total of all transpose settings. For example, if you have set the Transpose Concert setting to +12, the Transpose Set setting to +12, and the Transpose Patch setting to +12, your incoming notes are raised in pitch by 36 semitones.
Change the tuning for sets in MainStage

By default, new sets (and most existing ones) use the same tuning method as the concert. You can change the tuning for a set so that it uses a different tuning. When you change the tuning method for a set, the patches in the set use the set-level tuning unless you change the tuning at the patch level.

Change the tuning for a set
1. Select the Tuning tab in the MainStage Set Settings Inspector.
2. Choose the tuning you want the set to use from the Method pop-up menu.

Add text notes to a set in MainStage

You can use the Notes tab of the Set Settings Inspector to add text notes and other information about a set.

1. In MainStage, click on the Notes tab of the Set Settings Inspector.
2. Enter your text in the Notes field.
   The Notes field lets you use special ASCII characters and any installed languages, font symbols, and emoji. You cannot style text or change the font.

You can display your text notes in your layout by choosing a Parameter Text screen control and mapping the Current Notes action to it. See Add common screen controls and Map screen controls to actions for more information.

Share patches and sets between MainStage concerts

You can export patches and sets from a concert and import them into another concert. When you import a set, all the patches in the set are imported.

Export a patch
In MainStage, do one of the following:

• Drag the patch from the Patch List to the Finder.
  The patch appears as a patch file in the Finder.

• Select the patch, choose Save as Patch from the Action pop-up menu in the Patch List, then click Save.
  The patch is exported to the ~/Music/Patches folder.

Export a set
In MainStage, do one of the following:

• Drag the set from the Patch List to the Finder.
  The set appears as a patch file in the Finder.

• Select the set, choose Save as Set from the Action pop-up menu in the Patch List, then click Save.
  The set is exported to the MainStage Patches folder.
Note: You can also export an entire concert as a set by selecting the concert and choosing Export Set from the Action pop-up menu.

You can export multiple patches or sets. When you export multiple patches by dragging them to the Finder, each patch is exported as a patch file. When you select multiple patches and export them using the Export Patch command, the patches are grouped into a single exported set. You can import patches or sets from the Finder to another open concert.

**Import a patch or set**

In MainStage, do one of the following:

- In Edit mode, drag the patch or set from the Finder to the Patch List.
- Choose Load Patch/Set from the Action pop-up menu in the Patch List, select the patch or set you want to import, then click Import.

**Record the audio output of a MainStage concert**

You can record the audio output of a MainStage concert. When you record audio output, all audio on the output you choose is recorded (including the metronome, and so on).

Before you record audio output, make sure the correct output, recording location, and file format are set in MainStage > Settings > Audio. For information about changing recording settings (in MainStage > Settings > Audio), see Audio settings.

**Record audio in Edit mode**

- In MainStage, click the Record button in the toolbar.

  To stop recording, click the Record button again.

You can also map a screen control to the Record action to record audio in Perform mode and assign a key command to the action to turn recording on or off using a hardware control.
Work with concerts

Overview of concerts in MainStage

Concerts are where you create and organize the sounds you use in your performances, customize your onscreen layout, and make connections between your MIDI hardware and MainStage.

A concert holds all the sounds you’ll use for an entire performance or a series of performances. In a concert, you add, edit, and organize patches, and select patches while you are performing. You can reorder patches in the Patch List and also organize them into sets.

Concerts also contain layouts, where you visually arrange screen controls in the workspace and make connections between your hardware devices and MainStage. You can add and arrange screen controls and assign physical controls on your hardware MIDI devices to screen controls in Layout mode. For information about customizing your layout, see Layout mode overview.

You can also control the volume for an entire concert, add concert-wide effects, and make other changes at the concert level.

Create a concert in MainStage

You start by creating a concert from a template. You can also open an existing concert to play the patches in the concert or continue editing them.

Create a new concert from a template

1. In MainStage, choose File > New.
2. In the Choose Template dialog, choose the devices you want to use for audio input and output from the Audio Input and Audio Output pop-up menus.

3. Click an instrument category on the left to view templates for that category. You can also click Quick Start and choose a simple keyboard or guitar template to start playing immediately.

   A brief description below each template describes its features and intended use.

4. Scroll to find the template you want to use, then select it.

5. Click Choose, or double-click the template.

Choosing one of the Quick Start templates opens a new concert in Perform mode, so you can start playing immediately. Choosing any other template opens a new concert in Edit mode.

Open and close concerts in MainStage

You can open an existing concert to continue working, and close and save concerts. You can add patches to a concert and organize them in the Patch List. The number of patches is limited only by the amount of available memory. You can add channel strips to an existing patch or to new ones you create and can organize patches into sets. For information about patches and sets, see **Overview of Edit mode**.

**Open an existing concert**

In MainStage, do one of the following:

- Choose File > Open, select the concert you want to open, then click Open.
- Choose File > New. In the Choose Template dialog, click Open an Existing Concert, then choose the concert in the Open dialog.
- In the Finder, double-click the concert.
- In the Finder, drag the concert over the MainStage icon in the Dock.

The first time you open a concert, the first patch is selected and the Patch Library is open so you can easily choose a patch setting. When you reopen a concert, the patch that was selected when you last saved the concert is selected.
If any audio files or other assets are not found when you open a concert, a dialog appears showing which assets are missing, and asking if you want to search for the assets, locate them manually, or skip them.

By default, when you open a concert, it opens in Edit mode. You can change the default behavior in MainStage > Settings > General. For more information, see General settings.

Note: When you open a concert created with an earlier version of MainStage, it opens as an untitled concert, and MainStage prompts you to save the concert in the current version.

Reopen a recently open concert
In MainStage, do one of the following:

- Choose File > Open Recent Concert, then choose a concert from the submenu.
- Open the Choose Template dialog, click Recent Concert, then choose the concert you want to open.

Close a concert
- In MainStage, choose File > Close Concert.
  If you have edited the concert since the last time you saved it, you are prompted to save your changes.

Save concerts in MainStage
When you save a concert, changes to mapped parameter values are saved for the selected patch or set, but not for other patches or sets.

Some patches or plug-ins may use assets such as audio files, virtual instruments, Ultrabeat samples, and Space Designer impulse response files. You can save the assets used in a concert with the concert, so they are available if you copy or move the concert file.

Save a concert
1. In MainStage, choose File > Save.
2. The first time you save a concert, the Save dialog appears. Enter a name for the concert, browse to the location where you want to save it, then click Save.
   You can save a copy of a concert with a new name by choosing File > Save Concert As.

Save a concert including its assets
1. In MainStage, choose File > Save As.
2. In the Save As dialog, select the checkboxes for the asset types you want to save in the concert.
3. Click Save.

For information about how to set the behavior for saving parameter values for screen controls in individual patches, see How saving affects parameter values and Edit the saved value for a mapped parameter.
How saving affects parameter values in MainStage

In MainStage settings, you can set whether changes to mapped parameters are kept when you change patches or when they are reset to their saved value. By default, when you select a patch, the mapped parameters in the previously selected patch return to their saved value (as defined in the Screen Control Inspector). When you save the concert, changes to mapped parameters for the currently selected patch are saved (but mapped parameters for other patches keep their saved value).

If you set the On Patch Change preference to “Keep current value,” when you select a patch, the mapped parameters in the previously selected patch retain their current value. When you save the concert, the changes are saved (and the previous saved values are lost).

However, if you close the concert without saving, mapped parameters return to their previously saved values when you reopen the concert.

If you decide not to keep your latest changes, you can revert a concert to its previously saved state.

**Revert a concert to its last saved state**

- In MainStage, choose File > Revert to Saved.
  
  All the changes you have made since the last time you saved the concert are lost when you revert the concert to its last saved state.

**Set the default behavior for saved values**

1. Choose MainStage > Settings > General.

2. In the Parameter Values section of the General settings pane, choose the default behavior from the On Patch Change pop-up menu.
   
   - To preserve changes to parameter values when you change patches, choose “Keep current value.”
   - To return parameters to their last-saved value when you change patches, choose “Revert to saved value.”

You can also set the behavior for saving parameter values for screen controls in individual patches. For information, see Set parameter change behavior for screen controls.

Clean up concerts in MainStage

You can clean up a project to delete unused or unneeded media files using the Clean Up command.

**Clean up a concert**

1. In MainStage, choose File > Concert > Clean Up.

   A dialog appears, showing the number of files to be deleted.

2. Click OK.
Consolidate assets in a MainStage concert

Using the Consolidate command, you can create a “consolidated” copy of a concert that includes selected assets. You can select which types of assets are copied into the consolidated concert.

**Consolidate concert assets**

1. In MainStage, choose File > Concert > Consolidate.
2. Select the checkboxes for the file types you want to copy into the concert, then click OK.

Rename the current concert in MainStage

You can rename the currently open concert without leaving MainStage.

**Rename the currently open concert**

1. In MainStage, choose File > Concert > Rename.
2. In the dialog that appears, enter a new name for the concert, then click OK.

Work with concert settings

Overview of the MainStage Concert Settings Inspector

You edit concert parameters in the Concert Settings Inspector, which appears below the workspace when the concert is selected in the Patch List. With these parameters you can:

- Set MIDI Routing to channel strips
- Set the time signature for a concert
- Change the tuning for a concert
- Set channel strips pan law
- Transpose the pitch of incoming notes
- Add text notes to a concert

The six tabs of the Concert Settings Inspector provide the following functions:

- **MIDI**: You can set MIDI destinations for the concert, as well as determine which devices program changes are received.
**Timing:** You can set timing preferences, the tempo, and the time signature for the concert. For information on working with tempo, see [Overview of tempo](#).

**Tuning:** Change the tuning for the concert.

**Channel Strips:** You can set the pan law, level meter scale, and other channel strip parameters for the concert.

**Metronome:** You can adjust the metronome for the concert. For more information about the metronome, see [Control the metronome](#).

**Notes:** add text notes to the concert.

---

**Open the Concert Settings Inspector**

In MainStage, choose File > Concert Settings, or:

1. Enter Edit mode, either by clicking the Edit button on the toolbar, choosing Edit from the View menu, or via a key command.
2. Choose Show Inspectors from the View menu. If the Inspector is already displayed, you can skip this step.
3. Select the concert (the leftmost folder) in the Patch List.

---

**Set MIDI Routing to channel strips in MainStage**

Using checkboxes in the MIDI tab of the Concert Settings Inspector, you can choose whether or not you want MIDI Control Change message #7 to control channel strip volume and MIDI Control Change message #10 to control channel strip pan. You can also choose whether or not to send unassigned MIDI messages to all channel strips.

**Set MIDI Control Change behavior**

- In the MIDI tab of the MainStage Concert Settings Inspector, select the “Control Change 7/10 controls Volume/Pan of channel strips” checkbox.

**Send unassigned MIDI messages to all channel strips**

- In the MIDI tab of the MainStage Concert Settings Inspector, select the “Send unassigned MIDI to all channel strips” checkbox.

---

**Transpose incoming note pitch for a concert in MainStage**

You can transpose the pitch of incoming MIDI notes for every set and patch in a concert at once by using the Transpose Concert setting. You can raise or lower the pitch of incoming MIDI notes in semitone increments, to a maximum of 8 octaves higher or lower.

**Transpose the pitch of incoming notes**

- In the MIDI tab of the MainStage Concert Settings Inspector, click the Transpose Concert slider and do one of the following:
  - Drag the value up or down.
  - Use the arrow keys to raise or lower the value.
  - Type the number of semitones higher or lower you want to transpose the concert.
Note: The total amount of pitch transposition applied to incoming notes is the sum total of all transpose settings. For example, if you have set the Transpose Concert setting to +12, the Transpose Set setting to +12, and the Transpose Patch setting to +12, your incoming notes are raised in pitch by 36 semitones.

Define the program change message source in MainStage

By default, MainStage receives and responds to program change messages from all connected MIDI controllers. However, some MIDI controllers send program change messages while performing other operations. You can define the source for program change messages for a concert, so the concert responds to messages for only one MIDI device, port, or channel.

Choose the source for program change messages

1. In the MIDI tab of the MainStage Concert Settings Inspector, choose the source device or port for program change messages from the Device pop-up menu.
2. If you want to limit messages to a single MIDI channel on the device, choose the MIDI channel from the Channel pop-up menu.

Send unused program changes to channel strips in MainStage

In a MainStage concert, you can send program change messages that are not used for switching patches to channel strips for changing plug-in presets and other functions.

Send unused program change messages to channel strips

• In the MIDI tab of the MainStage Concert Settings Inspector, select the Send unused Program Changes to Channel Strips checkbox.

For information about setting program change numbers for patches, see Set program change and bank numbers.

Set the time signature for a concert in MainStage

You can set the time signature for a concert. Time signatures can be used with the Playback plug-in, and they also affect the operation of the metronome. When you set the time signature for a patch or set, it overrides the concert-level time signature while the patch or set is selected. When you select a patch or set without a time signature, it uses the concert time signature.

Set the time signature

1. In the Timing tab of the MainStage Concert Settings Inspector, select the Has Time Signature checkbox.
2. Double-click the number in the field at the right, and enter the number of beats for one measure of the time signature.
3. Choose the beat value from the pop-up menu on the right.

You can also set the tempo in the Timing tab. See Overview of tempo for more information on working with tempo in MainStage.
Change the tuning for a concert in MainStage

By default, concerts use equal tempered tuning. You can change the tuning for a concert so that it uses a different tuning.

Change the concert tuning

1. In the MainStage Concert Settings Inspector, click the Tuning tab.
2. Choose the tuning you want the concert to use from the Method pop-up menu.

When you change the tuning of a concert, the tuning of the patches and sets in the concert changes if their Tuning Method is set to “Use parent tuning.” Patches and sets with a different tuning method are not affected.

Set the pan law for a concert in MainStage

Audio signals panned to the center position may sound louder than signals panned hard left or right. The Pan Law value determines the amount of volume reduction applied to audio that is panned to the center position.

Set the pan law

- In the Channel Strips tab of the MainStage Concert Settings Inspector, choose one of the following pan law settings:
  - 0 dB: With no change to the volume level, signals seem louder when panned to the center position, compared to extreme left or right pan positions.
  - −3 dB: A full-scale signal (0 dBfs) has a level of −3 dB when panned to the center position.
  - −3 dB compensated: A full-scale signal (0 dBfs) has a level of 0 dB when panned to the center position (or +3 dB when panned to extreme left or right positions).
  - −4.5 dB: A full scale signal (0 dBfs) has a level of −4.5 dB when panned to the center position.
  - −4.5 dB compensated: A full scale signal (0 dBfs) has a level of 0 dB when panned to the center position (or +4.5 dB when panned to the extreme left or right positions).
  - −6 dB: A full scale signal (0 dBfs) has a level of −6 dB when panned to the center position.
  - −6 dB compensated: A full scale signal (0 dBfs) has a level of 0 dB when panned to the center position (or +6 dB when panned to the extreme left or right positions).
Add text notes to a concert in MainStage

You can use the Notes tab of the Concert Settings Inspector to add text notes and other information about your patch.

1. In MainStage, click on the Notes tab of the Concert Settings Inspector.
2. Enter your text in the Notes field.

The Notes field lets you use special ASCII characters and any installed languages, font symbols, and emoji. You cannot style text or change the font.

You can display your text notes in your layout by choosing a Parameter Text screen control and mapping the “Current Notes” action to it. See Add common screen controls and Map screen controls to actions for more information.

Tempo in MainStage concerts

Overview of tempo in MainStage

Each concert has a tempo, which you can change while you are performing. You can change the tempo by selecting a patch or a set with its own tempo setting, change the tempo in real time by Tapping a new tempo, or have MainStage Get the tempo from MIDI input.

When you open a MainStage concert, the tempo setting in the Concert Settings Inspector is used until you change the tempo. When you change the tempo, MainStage uses the new tempo until you change it again or close the concert.

You set the tempo for a concert in the Concert Settings Inspector, which appears in the lower-left corner of the MainStage window when the concert icon is selected in the Patch List. By default, the tempo for new concerts is 120 beats per minute (bpm).

Some plug-ins available in MainStage, including delay and tremolo effects, synthesizer LFOs, and the metronome, can require a specific tempo.

Set the tempo for a concert

1. In the MainStage Patch List, select the concert icon.
2. In the Timing tab of the Concert Settings Inspector, set the tempo using the Tempo slider or value slider.
You can use patches and sets to change the tempo when you select the patch or set while performing. For information about patch tempo settings, see Change the tempo when you select a patch. For information about set-level tempo settings, see Change the tempo when selecting sets.

**Tap the tempo in MainStage**

MainStage includes a “tap tempo” feature that allows you to set the tempo in real time while you perform.

**Tap the tempo on your computer keyboard**

- In MainStage, press Control-T several times at the desired tempo.

You can also tap the tempo using a screen control mapped to the Tap Tempo action. For information about mapping screen controls to actions, see Map screen controls to actions.

**Get the tempo from MIDI input in MainStage**

MainStage can receive tempo changes from incoming MIDI messages. If you select the “Get tempo from MIDI input” checkbox, MainStage listens to incoming MIDI clock messages for tempo information. If it receives tempo information, the concert tempo changes to the new tempo value.

**Get the tempo from incoming MIDI clock messages**

1. In the Timing tab of the Concert settings Inspector, select the Get tempo from MIDI input checkbox.
2. Choose the MIDI clock source from the Device pop-up menu.

When the “Get tempo from MIDI input” checkbox is selected, the Tempo slider is dimmed and cannot be edited. If MIDI messages MainStage receives do not include MIDI clock information, MainStage uses the concert tempo setting and changes the tempo when you select a patch or a set with its own tempo setting. If MainStage stops receiving MIDI clock messages, it continues to use the last received value for the tempo until you select a patch or set with its own tempo setting or tap a new tempo.
Control the metronome in MainStage

MainStage features a metronome that you can use to play in time with the concert tempo. The metronome always plays at the current concert tempo.

You can have the metronome play different notes for different bars, beats, groups, or divisions. You can also choose a different sound for the metronome, change the audio output for the metronome sound, and change the volume of the metronome relative to the overall audio output.

Start the metronome

In MainStage, do one of the following:

- Click the Metronome button in the toolbar.
- Click a button mapped to the Metronome action.
- If you are using a Playback plug-in, click the Metronome button in the Playback window (or click a button mapped to the Metronome button).

To stop the metronome, click any of the listed buttons again.

Note: Starting the metronome also starts the MainStage clock if it is not already running.

At the concert level, you can also map a button or other screen control to the Metronome action (located in the Actions folder) and use it to start and stop the metronome.

If you are using a Mac with a Touch Bar, you can also press the Metronome button in the Touch Bar to start the metronome.

By default, the metronome sound is routed to the main outputs (Output 1-2). You can route the metronome to another output pair, which can be useful in performance when you want to hear the metronome sound through a separate audio output (for example, a headphone mix) and not through the main outputs.

Change the output of the metronome sound

1. In MainStage, click Channel Strips Action pop-up menu, choose Show Metronome Channel Strip.
2. Choose a different output from the Output pop-up menu on the Metronome channel strip.

Change the sound of the metronome

1. In MainStage, click the Channel Strips Action pop-up menu, then choose Show Metronome Channel Strip.
2. Open the Klopfgeist plug-in from the Instrument menu on the Metronome channel strip.
3. Choose a different metronome sound.

Play multiple metronome sounds simultaneously

1. In the MainStage Concert Settings Inspector, click the Metronome tab.
2. Select the “Polyphonic click” checkbox.
3. Select one or more of the Bar, Beat, Group, or Division checkboxes.
The metronome sends notes as defined for bars, beats, groups, and divisions. When multiple selections occur at the same musical division, the defined notes play simultaneously. For example, if you selected Bar, Beat, and Division, three notes would play simultaneously at the beginning of each measure.

**Change note and velocity settings for the metronome**
1. In the MainStage Concert Settings Inspector, click the Metronome tab.
2. Do any of the following:
   - To change the note value for bars, beats, groups, or divisions, drag the value vertically.
   - To change the velocity value for bars, beats, groups, or divisions, drag the value vertically.

**Open the Metronome plug-in window**
In MainStage, do one of the following:
- In MainStage, do one of the following:
  - In the Metronome tab of the Concert Settings Inspector, click the Metronome button.
  - In the Channel Strips area, select the Metronome channel strip, and click the Klopfgeist instrument.

**Silence MIDI notes in MainStage**
MainStage also includes a Panic function. The Panic function immediately silences any hanging MIDI notes.

**Silence all MIDI notes**
In MainStage, do one of the following:
- Press Control-P.
- Double-click the MIDI Monitor in the toolbar.
- If you have mapped the Panic function to a screen control, press or move the corresponding controller.

If you are using a Mac with a Touch Bar, you can press the Panic button on the Touch Bar to silence any hanging MIDI notes.
Mute audio output in MainStage

Sometimes you may want to quickly mute (silence) all audio output for the concert. MainStage includes a Master Mute button that silences the output from all patches in the concert.

**Quickly mute all sound**

In MainStage, do one of the following:

- Press Control-M.
- In the toolbar, click the Master Mute button.
- If you have mapped the Master Mute function to a screen control, press or move the corresponding controller.

  The Master Mute button changes to show that the output is muted (a red diagonal line covers the speaker icon). All output remains muted until you unmute it.

If you are using a Mac with a Touch Bar, you can press the Master Mute button on the Touch Bar to mute all sound.

**Unmute all sound**

In MainStage, do one of the following:

- Press Control-M again.
- In the toolbar, click the Master Mute button again.
- If you have mapped the Master Mute function to a screen control, press or move the corresponding controller.

  Master Mute is also a mappable parameter in the Parameter Mapping browser. You can map Master Mute to a button or other controller in your concerts so that you can quickly mute all output when you are playing live in Perform mode.

  If you are using a Mac with a Touch Bar, you can press the Master Mute button on the Touch Bar to unmute all sound.

  You can also mute audio output for a single channel strip by clicking its Mute (M) button.
Work at the concert level

Overview of working at the concert-level in MainStage

You can control the overall volume for a concert and make other changes at the concert level. You can use busses at the concert level to control concert-wide effects or to control the output of multiple channel strips assigned to the bus. You can also add channel strips at the concert level and have the concert-level channel strips available with every patch in the concert.

You can map screen controls to busses and to concert-level channel strips only at the concert level, not at the patch or set level.

Make changes at the concert level

- In Edit mode, click the concert icon in the MainStage Patch List.

Control the overall volume of a MainStage concert

A MainStage concert contains Output and Master channel strips that you can use to control the overall volume of the concert. The Master channel strip always controls the output volume of the entire concert. If the concert has multiple Output channel strips, each Output channel strip controls the volume level for a particular (mono or stereo) physical output. You can use the Output and Master channel strips to control the overall volume of a concert.
To see all of the channel strips, you may need to resize the Channel Strips area.

You can map a screen control to a channel strip parameter or an action at the concert level. For example, you can map the Output 1-2 Volume fader to a fader screen control and use the hardware control assigned to that screen control to adjust the overall volume of the concert.

**Control the overall concert volume level**

- MainStage, drag either the Output 1-2 volume fader or the Master volume fader.

**Map a screen control at the concert level**

1. Make sure the concert icon is selected in the MainStage Patch List.
2. Click the screen control you want to map.
3. In the Parameter Mapping browser, click the parameter to which you want to map the screen control.

   In the example above, you would click the fader screen control, click Out 1-2 in the left column of the Parameter Mapping browser, and then click Volume in the second column of the browser.

   Screen controls can also display visual feedback about parameter values, including volume level. For example, you can map the Output 1-2 Volume fader to a level meter screen control and have the level meter display the overall volume level while you are performing live. In this case, you would map the level meter to Level in the second column of the browser, rather than to Volume.

When you map a screen control at the concert level, you cannot map the same screen control at the patch or set level unless you override the concert-level mapping. For information about overriding concert-level mappings, see Override concert- and set-level mappings.
Add concert-wide effects in MainStage

You can add concert-wide effects such as reverb and delay using auxiliary (aux) channels. When you choose a bus from the Send slot on a channel strip, a corresponding aux appears at the concert level. You can insert effects on the aux and have those effects apply to every channel strip sending its signal to the aux.

Send a channel strip signal to an aux
1. In the MainStage Patch List, select the patch you want to use with a concert-wide effect.
2. On the channel strip, click one of the Send slots and choose a bus from the pop-up menu.
3. Drag the Send knob next to the slot to set the amount of the signal sent to the aux.

Add a concert-wide effect to an aux
1. In the MainStage Patch List, click the concert icon. The auxes in the concert appear in the Channel Strips area along with the concert-level channel strips.
2. On an aux, click one of the Insert slots and choose an effect from the pop-up menu.

After you add an effect to an aux, you can edit the effect as you would any channel strip effect, by clicking it to open the plug-in window and then adjusting parameters in the plug-in window. You can add multiple effects to an aux, and adjust the level and pan of the aux using the channel strip controls on the aux.

You can also add concert-wide effects to an aux at the patch level, if Show Signal Flow Channel Strips is turned on. For information about showing signal flow channel strips in the Channel Strips area, see Show signal flow channel strips.
Use auxes to control channel strip output in MainStage

You can send the output of multiple channel strips to an aux (auxiliary channel strip) and use the aux to control the volume level and pan position of the channel strips. Sending the output to an aux is also useful for adding EQ or compression to a group of patches.

When you send channel strip output to an aux, the volume fader of the channel strip controls how much of the signal is sent to the aux.

When you control the output of multiple channel strips using an aux, their relative volume levels and pan positions are preserved, but the overall volume level and pan position are modified by the aux Volume fader and Pan knob.

Send the output of a channel strip to an aux
1. In the MainStage Patch List, select the patch you want to control using an aux.
2. In the channel strip, click the Output slot and choose a bus from the pop-up menu.

Control the output of channel strips using an aux
1. In the MainStage Patch List, click the concert icon.
   - The concert is selected. The busses added to the concert appear in the Channel Strips area along with the concert-level channel strips.
2. Drag the Volume fader on the aux to adjust the volume level of the overall aux output.
3. Drag the Pan knob on the aux to adjust the pan position of the overall aux output.

Add channel strips at the MainStage concert level

You can add a channel strip at the concert level and use the concert-level channel strip for a software instrument or audio input you want to use in every patch in the concert.

Important: When you add a channel strip at the concert level, it takes precedence over the channel strips in the patches and sets in the concert. For example, if you add a concert-level channel strip containing a software instrument, the software instrument takes precedence over all of the software instruments in all of the patches and sets in the concert, for the notes in its key range. This means that you hear only the sound of the concert-level software instrument, and can't play any software instruments in a patch or set that fall in the same key range.
Add a concert-level channel strip

1. In the MainStage Patch List, select the concert icon.
2. Click the Add Channel Strip button (+) at the top of the Channel Strips area.
3. In the New Channel Strip dialog, select the type of channel strip you want to create.
4. Choose the audio output for the channel strip from the Output pop-up menu.
5. For audio channel strips, choose mono or stereo format from the Format pop-up menu.
   Important: Audio channel strips can produce feedback, particularly if you are using a microphone for audio input. When you add an audio channel strip, the volume of the channel strip is set to 0dB. Gradually raise the volume fader on the channel strip until you hear sound on the channel. You can also turn on Feedback Protection in MainStage > Settings > Audio.
6. Click Create.
7. For software instrument channel strips, you can define the key range for the channel strip in the Channel Strip Inspector so that the concert-level channel strip does not overlap software instruments you plan to use in your patches and sets.
   For information about defining the key range of a channel strip, see Overview of layers and splits.
   When you add a channel strip at the concert level, you can map screen controls to the channel strip only at the concert level, not for individual patches or sets.

The MainStage clock

Some plug-ins, including the Playback and Ultrabeat plug-ins, require a time source, and use beat and tempo information in order to play in time.

Additionally, some third-party applications and plug-ins using their own sequencer or playback engine may behave differently than the included plug-ins. These applications (which include Reason and Reaktor) require a play message from the host application to begin playback and require a stop message to end playback. They may also require a continue (also sometimes called “resume”) message to continue playback from their current time position.

MainStage includes an internal beat clock or “time base” that you can use to control the playback of these plug-ins. The MainStage clock generates beat, time position, and tempo information so sequencer-oriented plug-ins can start, stop, and play in time. The MainStage clock operates similarly to the song position in Logic Pro or other DAW applications.

You can send play and stop messages in the following ways:

- Using the Play/Stop button in the toolbar, if it is visible
- Using the Metronome button in the toolbar, if it is visible (turning on the metronome also starts the MainStage clock, if it is not already running)
- Using a screen control mapped to the Play/Stop, Play, or Stop action
- Using a screen control mapped to the Continue action, to resume playback of a third-party plug-in (but not a Playback plug-in)
Different plug-ins can make use of the MainStage clock in different ways, depending on what information they require and what mode they are set to. Some plug-ins may only make use of the beat information, while others may only make use of tempo information. For example:

- The Playback plug-in can start immediately (if Snap To is set to Off), at the beginning of the next bar (if Snap To is set to Bar), or at the next beat (if Snap To is set to Beat). It can also start when you start the MainStage clock (if you choose Start with Play Action from the Action pop-up menu).
- UltraBeat starts when you start the MainStage clock if its sequencer is turned on, except when Ultrabeat is in Pattern mode.
- For plug-ins with synchronizable LFOs, the LFO can oscillate at the tempo set by the MainStage clock. You can also send MIDI beat clock to synchronize external MIDI devices.

You can view the beat information of the MainStage clock using a Parameter Text screen control mapped to the Beat Count action. When the MainStage clock is running, the current bar and beat are displayed in the screen control.

**Important:** When you start the MainStage clock, the audio engine is reset, causing a brief interruption in the audio output from MainStage. You may want to start the MainStage clock at the beginning of a song or performance and use screen controls mapped to individual plug-in parameters to start and stop those plug-ins to avoid an interruption in the audio output while you are performing.
Work in Layout mode

Overview of Layout mode in MainStage

You cannot change the position of physical faders, knobs, and other controls on your instruments and other music hardware, but you can arrange the screen controls in your MainStage concert in any order you like by editing the layout. You can modify an existing layout or create one from a template, and you can export a layout and import it into another concert.

Each concert template included with MainStage includes a built-in layout, optimized for a type of musical instrument you use with MainStage.

You modify the layout of a concert in Layout mode. You can add and arrange screen controls in the MainStage workspace to match your music hardware, optimize your display size, and make assignments between controls on your MIDI hardware and the screen controls in your concert. Below the workspace, the Screen Controls palette contains different types of screen controls you can add to your layout. The Screen Control Inspector appears to the left of the workspace, where you can learn controller assignments and edit layout parameters.

To work with the layout of a concert, you switch to Layout mode.

Switch to Layout mode

• In MainStage, click the Layout button at the upper-left corner of the MainStage window (or press Command-1).

If you’re using a Mac with a Touch Bar, you can press the Layout button on the Touch Bar to switch to Layout mode.
Work with screen controls

Overview of screen controls in MainStage

Screen controls are objects in a MainStage concert that correspond to the physical controls on your music hardware. Screen controls can also display patch numbers, parameter values, and other information and update the displayed information in real time. You can add screen controls to the workspace of your concert, where you can move and resize them, group them together, and edit their appearance in different ways.

There are three types of screen controls you can use in a MainStage layout:

- Panel controls
- Shelf controls
- Grouped controls

In the Screen Controls palette, located below the workspace in Layout mode, each type has its own tab; in addition, there is a tab for all controls. You can add Screen Controls to the workspace by dragging them from the palette to the workspace.

Additionally, if you create and add a grouped control to the Screen Controls palette, a tab for My Grouped Controls appears in the palette. You can add your custom grouped controls to the palette, so they are available in every concert.

After you arrange the screen controls for your concert, you make connections between your MIDI hardware and the concert by assigning physical controls on your hardware to the screen controls in the workspace. You only need to make hardware assignments for a concert once, as long as you are using the same music hardware.

After you make controller assignments, you can map screen controls to channel strip parameters in your patches or to actions. You can map parameters in Edit mode. For information about mapping parameters, see Map to channel strip and plug-in parameters and Map screen controls to actions.
Screen control types

Panel screen controls in MainStage
Panel controls appear on a two-dimensional plane (or panel) in the workspace. You can move a panel control to any position in the workspace, except onto the shelf of a shelf control. Panel controls include:

- MIDI Activity light (displays MIDI note activity, and can be used as a substitute "keyboard")
- Round and directional knobs
- Vertical and horizontal faders
- Button
- Drum pad
- Vertical and horizontal level meters (used to visually display volume level or another parameter)
- VU meter (used to visually display volume level or another parameter)
- Parameter text (used to dynamically display parameter names and values)
- Organ drawbar
- Progress indicator (used with the Playback plug-in)
- Waveform (used with the Playback plug-in)
- Selector (used to select patches while you are performing or to select markers for use with the Playback plug-in)
- Text (used to display song lyrics, performance notes, and other static information)
- Background (used to group a series of controls, or to import an image or PDF)
- Smart Controls (used with patches that have a Smart Controls layout)

Shelf screen controls in MainStage
When you add a shelf control, it appears on a three-dimensional shelf. You can move the shelf, adjust the angle of the shelf, and place multiple shelf controls on the same shelf. For example, if you have a keyboard screen control in your layout, you can add pitch bend wheel and modulation wheel screen controls to the same shelf as the keyboard screen control. Shelf controls include:

- Keyboard
- Modulation or pitch bend wheel
- Sustain pedal
- Foot pedal
- Foot switch
Grouped screen controls in MainStage

Grouped controls consist of individual controls that are grouped together to make them easier to work with as a single unit. Grouped controls include:

- Selector grouped with increment and decrement buttons
- Keyboard grouped with mod wheel, pitch bend wheel, and sustain pedal
- Sustain and expression pedals
- Organ drawbars
- Guitar amp controls
- Guitar pedal controls
- Arrays of knobs and faders with uniform size and spacing
- Effects and tone control knobs
- Arrays of level meters and VU meters
- Arrays of parameter text displays
- Master output fader grouped with stereo level meter
- Arrays of drum pads
- Transport controls for use with Playback plug-in
- Channel strip controls
- XY pad

The first time you add a custom grouped control to the Screen Controls palette, the My Grouped Controls tab appears in the palette. You can add custom grouped controls and name them so they are accessible from every concert. For information about adding custom grouped controls to the Screen Controls palette, see Group screen controls.

Add screen controls to a layout

Add common screen controls in MainStage

In Layout mode you can quickly add screen controls to your layout and arrange them in the workspace.

You can drag screen controls into the workspace in any order. If you plan to perform with a keyboard controller, you might want to first drag a keyboard screen control into the workspace, position it near the center, and then drag screen controls for the faders, knobs, wheels, buttons, and other physical controls on the keyboard controller.

Add a screen control

- In MainStage, drag the screen control from the Screen Controls palette to the workspace.

As you drag the screen control to the workspace, a white outline appears, showing where it will be added. You can use the alignment guides to align the screen control with other items in the workspace.
When you drag a screen control into the workspace, the control is selected, and the available hardware assignments and other parameters for the screen control appear in the Screen Control Inspector to the left of the workspace. Different types of screen controls have different parameters; for more information, see Screen control parameter editing overview.

Mod/pitch wheel screen controls in MainStage

When you add mod/pitch wheels to a layout, by default they are configured to receive the following MIDI message types:

- The first mod/pitch wheel is configured to receive pitch bend messages.
- The second mod/pitch wheel is configured to receive modulation messages.
- The third mod/pitch wheel is configured to receive aftertouch messages.

By default, modulation and pitch bend screen controls pass through the MIDI messages for their common use—that is, mod wheels pass through MIDI modulation messages, and pitch bend wheels pass through MIDI pitch bend messages. In most cases this is desirable so that you can use them for their standard functions without any additional setup. If you want to use these screen controls to control other parameters, choose “Do not pass thru” from the MIDI Thru pop-up menu in the Screen Control Inspector.

Foot pedal screen controls in MainStage

When you add a foot pedal to a layout, by default the first foot pedal you add is configured to receive expression messages, and the second foot pedal you add is configured to receive volume messages.

By default, expression pedal screen controls pass through the MIDI messages for their common functions (expression or volume). If you want to use an expression pedal screen control to control another parameter, choose “Don’t pass thru” from the MIDI thru pop-up menu in the Screen Control Inspector.

Copy and paste screen controls in MainStage

You can copy and paste screen controls using the standard OS X menu items and key commands.

Note: You cannot copy a panel control and a shelf control at the same time.

Paste a copy of a screen control

In MainStage, do one of the following:

- Press Command-C to copy the selected screen control, then press Command-V to paste a copy.
- Option-drag the screen control to a new location in the workspace.
Add multiple instances of the same screen control in a row or column

In MainStage:

1. To create the first copy, Option-drag the screen control.
2. To create additional copies of the screen control, choose Edit > Duplicate.

The duplicated screen controls appear offset by the same amount as the first copy.

Move screen controls in MainStage

You can move screen controls to a new position whenever you are in Layout mode. You can use the alignment guides to help align and position screen controls in an orderly arrangement.

Move a screen control

In MainStage, do one of the following:

- Drag the screen control to a new position in the workspace.
- Select the screen control, then press the arrow keys to move it in the workspace.

You can constrain the movement of screen controls to either horizontal or vertical by pressing Shift while dragging them.

If a screen control overlaps another screen control in the workspace when you switch from Layout mode to another mode, an alert appears, asking if you want the overlapped controls to be highlighted so you can adjust them before leaving Layout mode.

Move multiple screen controls

In MainStage, do one of the following:

- Shift-click the screen controls, then drag them to a new position.
- Hold down the Shift key as you drag around the controls, then drag them to a new position.

If the panels for the screen controls are merged, rubber-banding selects the entire panel. You can constrain the movement of screen controls to either horizontal or vertical by pressing Shift while dragging them.

If a screen control overlaps another screen control in the workspace when you switch from Layout mode to another mode, an alert appears, asking if you want the overlapped controls to be highlighted so you can adjust them before leaving Layout mode.
Resize screen controls in MainStage

You can resize screen controls to make them more easily visible or to fit them into a smaller area.

### Resize a screen control

1. In MainStage, click the screen control in the workspace.
   - Blue resize guides appear over the screen control.
2. Drag the resize guides to resize the screen control.

### Resize the text display area of a screen control

1. In MainStage, select the screen control in the workspace.
2. Drag the inner resize guide to increase the area of the text display.
3. Drag the outer resize guide to increase the overall size of the control.

Notice that when you resize the text display area, the rest of the screen control becomes smaller. You can first resize the overall control, and then resize the text display area using the inner resize guide.

### Align and distribute MainStage screen controls

MainStage includes controls for centering, aligning, and distributing screen controls in the workspace.

### Align screen controls

1. In MainStage, select the screen controls in the workspace.
2. Do one of the following:
   - **To align the left edges of the screen controls:** From the Layout Action pop-up menu, choose Align > Align Left.
   - **To horizontally align the centers of the screen controls:** From the Layout Action pop-up menu, choose Align > Align Horizontal Centers.
   - **To align the right edges of the screen controls:** From the Layout Action pop-up menu, choose Align > Align Right.
• To align the top edges of the screen controls: From the Layout Action pop-up menu, choose Align > Align Top.

• To align the bottom edges of the screen controls: From the Layout Action pop-up menu, choose Align > Align Bottom.

• To vertically align the centers of the screen controls: From the Layout Action pop-up menu, choose Align > Align Vertical Centers.

If you’re using a Mac with a Touch Bar, you can align screen controls by pressing the Align Left, Align Right, Align Horizontal Centers, Align Vertical Centers, Align Top, and Align Bottom buttons on the Touch Bar.

You can also align and distribute screen controls by Control-clicking the selected screen controls and choosing commands from the Align and Distribute submenus in the shortcut menu. The Distribute shortcut menu contains additional controls for distributing the space between screen controls.

**Distribute screen controls evenly**

1. In MainStage, select the screen controls in the workspace.

2. Do one of the following:
   • To vertically distribute the screen controls: From the Layout Action pop-up menu, choose Distribute > Distribute Centers Vertically.
   • To horizontally distribute the screen controls: From the Layout Action pop-up menu, choose Distribute > Distribute Centers Horizontally.

You can also align and distribute screen controls by Control-clicking the selected screen controls and choosing commands from the Align and Distribute submenus in the shortcut menu. The Distribute shortcut menu contains additional controls for distributing the space between screen controls.

**Adjust the shelf for a shelf screen control in MainStage**

When you add a shelf control such as a keyboard to the workspace, it appears at a default angle, creating a three-dimensional appearance. You can adjust the angle of the shelf control so that it appears more or less three-dimensional. This can be useful, for example, if you want to see more of the keys on the keyboard or minimize the amount of space it occupies onscreen.

You can also move the shelf vertically to change its position in the workspace. When you move the shelf vertically, all screen controls on the shelf (for example, a modulation or pitch bend wheel and a keyboard) move with the shelf.

**Adjust the angle of the shelf for a shelf control**

1. In the MainStage workspace, select the shelf control.
White alignment guides for the control’s shelf appear.

2. Drag the lower alignment guide (the one aligned with the front of the shelf control).
   - To make the angle steeper (as though you are looking down from above): Drag the lower alignment guide down.
   - To make the angle less steep (as though you are looking from the front): Drag the alignment guide up.

Move a shelf vertically
1. In MainStage, select one of the screen controls on the shelf.
   The alignment guides for the shelf appear.

2. Place the pointer over the upper alignment guide (the one aligned with the rear of the shelf control).
   The pointer becomes a move pointer (a horizontal bar with up and down arrows).
3. Drag the upper alignment guide to move the shelf to a new position.
Group screen controls in MainStage

You can group screen controls together, creating a grouped control, and then move and resize the grouped control as a single unit. Grouping screen controls has no effect on how they work in performance, but makes it easier to quickly create a layout. You can group screen controls using the Group button, using the shortcut menu, or using a background screen control.

You can quickly add one or more screen controls to a group and move or resize individual controls in a group without ungrouping them.

You can add a panel or an image to the background of a grouped control to re-create the look of a hardware panel and visually distinguish the grouped control in the workspace.

Group a set of screen controls

1. In MainStage, select the screen controls you want to group together.
2. Do one of the following:
   - From the Layout Action pop-up menu, choose Group.
   - Control-click the selected controls, then choose Group from the shortcut menu.

The screen controls are grouped into a single, grouped control. If there is no background around the screen controls, one is added to encompass them. Selecting any member of the group selects the entire group so you can move and resize them together.

When you group screen controls, the edges of the background appear “dotted” to indicate that the controls are grouped.

If you’re using a Mac with a Touch Bar, you can press the Group button on the Touch Bar to group screen controls.

Group screen controls using a background screen control

1. In MainStage, drag a background screen control to the workspace.
2. Size and position the background screen control.
3. Drag the screen controls you want to include in the grouped control so they are within the borders of the background screen control.
**Ungroup screen controls**

1. In MainStage, select the grouped control.

2. Do one of the following:
   - From the Layout Action pop-up menu, choose Ungroup.
   - Control-click the selected controls, then choose Ungroup from the shortcut menu.

If you’re using a Mac with a Touch Bar, you can press the Ungroup button on the Touch Bar to ungroup screen controls.

**Add a screen control to a group**

- In MainStage, drag the screen control into the group.

**Move or resize a screen control in a group**

1. In MainStage, select the individual screen control you want to move or resize.

   The handles of the screen control appear so you can move or resize it independently from the group.

2. Hold down the Command key as you move or resize the screen control.

**Change the look of the background**

1. In MainStage, select the background.

   The Screen Control Inspector appears to the left of the workspace.

2. In the Appearance section of the Screen Control Inspector, do one of the following:
   - **To add a panel**: Click the Panel well, and choose a panel from the menu.
     
     If the background currently uses an image, select the Panel button before choosing a panel.
   - **To add an image or PDF**: Select the Image button, then do one of the following:
     
     - Drag an image or PDF to the Image well.
     - Click the Select button, browse to the location of the image or PDF, then select it.

   *Note*: If you add a multi-page PDF to your layout, you can map screen controls to turn the pages. See [Use screen controls to display PDF document pages](#).

**Add a grouped control to the Screen Controls palette**

In MainStage, do one of the following:

- Control-click the grouped control, then choose Add to Palette from the shortcut menu.
- Select the grouped control, then choose Add to Palette from the Layout Action pop-up menu 📖.

After you add the first grouped control to the Screen Controls palette, the My Grouped Controls tab appears. Select this tab (or the All tab) to see the custom grouped controls you have added to the Screen Controls palette.
Delete screen controls in MainStage

If you decide you no longer want a screen control in your layout, you can delete it from the workspace.

Delete a screen control

1. In MainStage, select the screen control you want to delete.
2. Choose Edit > Delete (or press the Delete key).

When you delete a screen control, any assignments or mappings for the screen control are deleted as well.

Assign hardware controls to screen controls

Overview of controller assignments in MainStage

To use MainStage with a MIDI controller, you assign hardware controls on the controller (such as faders, knobs, buttons, drum pads, and pedals) to screen controls such as knobs and buttons in the workspace. After you assign a hardware control to a screen control, the screen control receives the MIDI messages from the hardware control. You only need to make controller assignments once for a concert as long as you use it with the same hardware.

You assign hardware controls to screen controls using the Learn process, which is described in Learn a controller assignment. You can also assign hardware controls in the Assignments & Mappings table. For information, see Overview of assignments and mappings.

When you assign a hardware control using the Assign button, MainStage determines the type of MIDI message the control sends when you move it and the range of values the control is capable of sending. When you map the screen control to a channel strip parameter or an action, MainStage converts (or “maps”) the range of values sent by the hardware control to the optimal range of values usable by the parameter.

For example, many faders, knobs, and other MIDI controls send a range of numeric values between 0 and 127. You could map a hardware knob with this range of values to control the frequency parameter of an EQ effect, which has a range of usable values between 20 Hz and 20 kHz. When you map the screen control for the knob to the EQ frequency parameter, MainStage converts the values sent by the hardware knob to be distributed between the minimum (20 Hz) and maximum (20 kHz) values for the parameter.
Knob assignments in MainStage

MIDI controllers can have different types of knobs or rotary controllers. Knobs can be either absolute controllers, which send a fixed value determined by the knob's position or can be relative controllers, which increment or decrement the previous value regardless of their exact position. Knobs can either have a fixed range of movement or be continuous (sometimes called endless rotary encoders).

When you assign a knob screen control using the Assign button, MainStage attempts to determine which type of knob or rotary control on your hardware is sending the MIDI message and sets the value in the Type pop-up menu in the Screen Control Inspector to the correct value. For absolute controllers, the correct value is Absolute; for relative controllers, the correct value can be either Relative (2's complement) or Relative (Sign magnitude), depending on the type of relative controller. In most cases, there is no need to change the default values unless you intend to use the knob for a specific, non-standard purpose.

When you assign a knob screen control, be sure Absolute is chosen from the Type pop-up menu if the hardware controller is an absolute rotary controller, or one of the Relative values is chosen if the hardware controller is a continuous rotary encoder. Moving the knob through its full range of motion helps ensure that MainStage correctly determines the type of knob you are assigning.

Button assignments in MainStage

MIDI controllers can have different types of buttons. Some buttons send a single value each time you press them, while others alternate between two values when pressed. Other buttons can send separate values when they are pressed and released (this type of button is called a momentary or temporary button).

When you assign a button screen control using the Assign button, MainStage attempts to determine which type of button on your hardware is sending the MIDI message and sets the value in the Type pop-up menu in the Screen Control Inspector to the correct value for that button type. To enable MainStage to determine the correct value, press the button exactly three times during the Learn process. Pressing the button three times helps ensure that MainStage determines if the button is a single value, an alternating value (binary), or a momentary button. In most cases, there is no need to change the default values unless you intend to use the button for a specific, non-standard purpose.

You can change the function of a momentary button to match the function of a single value or alternating value button in MainStage.

Change the function of a momentary button

1. In the MainStage Layout mode, be sure the button screen control is selected.
2. In the Screen Control Inspector, choose either Single Value or Alternating Value from the Type pop-up menu.

Choose Single Value if you want the button to function as a single value button, or choose Alternating Value if you want the button to function as an alternating value button. You cannot change the function of a single value or alternating value button to match the function of a momentary button.
Edit screen control parameters

Editing screen control parameters in MainStage

When you select a screen control in Layout mode, the parameters for the screen control appear in the Screen Control Inspector where you can edit them. Most screen controls share the same common parameters, but some types have different parameters according to their function. The parameters for each type are described in the following sections.

For most Hardware Input parameters, there is no need to change the default values MainStage sets when you learn a controller assignment unless you intend to use the screen control for a specific, non-standard purpose.

Edit parameters for a screen control

1. In the MainStage Layout mode, select the screen control. (When you drag a screen control to the workspace, it is selected.)

2. In the Screen Control Inspector, edit the parameters for the selected screen control (for example, by choosing a menu item, typing text, clicking the button, or selecting a checkbox).

Lift and stamp screen control parameters in MainStage

You can “lift,” or copy, certain parameters from a screen control and “stamp” them onto other screen controls. This makes it easy to give multiple screen controls the same size, appearance, and text attributes to create a uniform look in your layout. Parameters affected by lift and stamp include the parameters in the Appearance and Text Labels headings in the Screen Control Inspector (except the control type) as well as the size of the screen control.

Lift parameters from a screen control

• In MainStage, Control-click the screen control in the workspace, then choose Lift from the shortcut menu.

If you’re using a Mac with a Touch Bar, you can press the Lift button to lift parameters from a screen control.

Stamp parameters onto another screen control

• In MainStage, Control-click the screen control in the workspace, then choose Stamp from the shortcut menu.

You can Shift-click to select multiple screen controls, then Control-click the selection.

If you’re using a Mac with a Touch Bar, you can press the Stamp button to stamp parameters onto another screen control.
Reset screen control parameters in MainStage

You can reset a screen control to its saved value (as stored in the Screen Control Inspector).

Reset a screen control to its saved value

- In Edit or Perform mode in the MainStage workspace, Option-click the screen control.

Common screen control parameters in MainStage

You can edit the following common parameters for button, fader, knob, pedal, footswitch, mod/pitch wheel, meter, VU meter, organ drawbar, progress indicator, and parameter text screen controls.

Hardware Input

- MIDI Port pop-up menu: Shows the name of the device containing the assigned control. The device name may correspond to the name of a keyboard controller, or to a port on the controller, if it has multiple ports. You can choose another device, All, or Unassigned.
- Channel pop-up menu: Choose the MIDI channel on which MainStage receives input from the controller.

If you plan to use more than one keyboard when you perform, be sure that screen controls such as faders and knobs are assigned to receive input from the correct controller using the Device and Channel pop-up menus.

- Type pop-up menu: Choose the type of control messages to which the control responds. Control types include the following three categories:
  - Continuous Control: Includes knobs, rotary encoders, faders, and most pedals that send values in the range of 0–127. In most cases, these controls are set to Absolute. Some rotary encoders can be set to Relative after you program the hardware device to send relative controller messages. The different types of Relative control messages represent different encoding types used by different vendors (who may refer to them by proprietary names).
  - Button Control—Toggle Only: Includes buttons that send either one (Single) or two (Alternating) values.
  - Button Control—Toggle or Momentary: Includes drum pads and other buttons that send a value when the button is released as well as when it is pressed.
- Number pop-up menu: Choose the MIDI control number that the control sends. For common MIDI controls, such as volume, the control name appears in the menu along with the number.
- MIDI Thru pop-up menu: Choose whether the control automatically passes MIDI through or does not pass MIDI through.
- Send Value to pop-up menu: Sends the current value of the screen control to supported devices to display using an LED ring around a rotary encoder or to move a motorized fader.
Settings
- **Name field**: Enter a name for the screen control.

Appearance
- **Color selector**: Choose the color for the active part of the screen control, which visually displays its current value in performance. (This parameter is not available for text or meter screen controls.)
- **Control pop-up menu**: Choose the type for the screen control. If you change the control to a different type, you may need to resize it in the workspace.

Text Labels
- **Color selector**: Choose the color for the text labels.
- **Display pop-up menu**: Choose what information is displayed in the text display area for the control and how many lines are used to display it.
- **Add hardware label checkbox and field**: Select the checkbox, then type a hardware label in the field to display it on the top line of the control’s text display.

Keyboard screen control parameters in MainStage
If you are using a keyboard controller or another MIDI device that sends MIDI note messages, your layout should include a keyboard (or MIDI activity) screen control. You can edit the following parameters for keyboard screen controls.

Hardware Assignment
- **Device pop-up menu**: Shows the name of the learned keyboard. The device name may correspond to the name of the keyboard controller, or to a port on the controller, if it has multiple ports. You can choose another device or choose All.
- **Channel pop-up menu**: Shows the MIDI channel on which MainStage receives input from the keyboard. You can choose another channel or choose All.
- **Velocity Sensitivity slider**: Sets the velocity sensitivity for the keyboard. **Less** means that higher velocities are required to trigger the maximum value, while **More** means that lower velocities trigger the maximum value.

Settings
- **Name field**: Enter a name for the keyboard. The name appears in the Input pop-up menu in the Channel Strip Inspector, where you can select the device the channel strip responds to.
- **Number of Keys value slider**: Enter the number of keys to display on the keyboard screen control.
- **Lowest Key value slider**: Enter the note name for the lowest key.
- **Lowest Key Learn button**: Click the Learn button, then press the lowest key to have MainStage learn it.

The Number of Keys and Low Key affect only the visual appearance of the screen control. They do not affect what notes are received from your keyboard controller.
Layer Display
- *Display keyboard layers checkbox:* When active, a layer is displayed above the keyboard in the workspace for each software instrument channel strip in a patch. The layers show the name and color of the channel strip and respond when you play the keyboard.
- *Height value slider:* Sets the height of the layer display that appears above the keyboard.

MIDI activity screen control parameters in MainStage
MIDI activity screen controls can indicate when MIDI note messages are received and can also be used as smaller, “noteless” keyboard screen controls. You can edit the following parameters for MIDI activity screen controls.

Hardware Input
- *Device pop-up menu:* Shows the name of the device to show MIDI activity for. You can choose another device, All, or Unassigned.
- *Channel pop-up menu:* Choose the MIDI channel on which MainStage receives input from the controller.
- *Velocity Sensitivity slider:* Set the amount of sensitivity for incoming MIDI data.

Settings
- *Name field:* Type a name for the screen control.

Appearance
- *Color selector:* Choose the color for the MIDI activity light.

Drum pad screen control parameters in MainStage
You can use drum pad screen controls with hardware drum pads. You can edit the following parameters for drum pad screen controls.

Hardware Input
- *Device pop-up menu:* Shows the name of the hardware device with the drum pad control. You can choose another device, All, or Unassigned.

  *Note:* If the Device parameter for a drum pad screen control is set to All, the MIDI note that triggers the drum pad (set in the Note value slider) is not sent to any keyboard screen controls in the patch, and so does not produce sound from any software instrument plug-ins “played” using those keyboard screen controls.
- *Channel pop-up menu:* Choose the MIDI channel on which MainStage receives input from the controller.
- *Note value slider:* Change the MIDI note for the drum pad to a different value than the learned value.
Appearance

- **Color selector**: Choose the color for the active part of the screen control, so that you can easily see when the drum pad is pressed.

Text Labels

- **Color selector**: Choose the color for the active part of the text label.
- **Justification buttons**: Click to set the text justification (left, center, or right).
- **Display pop-up menu**: Choose what information is displayed in the text display area and how many lines are used to display text.
- **Add hardware label checkbox and field**: Select the checkbox, then enter hardware label text in the field to display it on the top line of the control’s text display.

Waveform screen control parameters in MainStage

You can use waveform screen controls to display the waveform of the audio file for a Playback plug-in. You can edit the Color and Hide Ruler parameters for waveform screen controls.

Appearance

- **Color selector**: Choose the color for the waveform display.
- **Hide Ruler checkbox**: When selected, the ruler at the top of the waveform display is not visible.

Selector screen control parameters in MainStage

You can use selector screen controls to display and select patches and sets, or to display and select markers in audio files used by a Playback plug-in. You can edit the following parameters for selector (patch or marker selector) screen controls.

Appearance

- **View Patches and Sets button**: When active, both patches and sets are shown in the selector.
- **Dual Column Display checkbox**: When selected, sets are displayed in the left column and patches are displayed in the right column.
- **Patches or markers button**: When active, only patches are shown in the selector.
- **Items to Display value slider**: Set the number of items (lines) visible in the selector.
- **Color selector**: Choose the color for selected items in the selector.
- **Set Justification buttons**: Click to set whether sets are left, center, or right justified in the selector.
- **Patch Justification buttons**: Click to set whether patches are left, center, or right justified in the selector.
Text screen control parameters in MainStage

You can edit the following parameters for text screen controls after adding text to the text field.

Text Parameters

- **Font button**: Select text, click the Font button to show the Font menu, then choose the font, style, color, and size.
- **Alignment buttons**: Select whether the selected text is left, right, or center aligned, or justified.
- **Text field**: Enter the text you want to display onscreen.
- **Show frame around text checkbox**: When selected, a darker frame appears around the text, showing the borders of the screen control.

Background screen control parameters in MainStage

You can use backgrounds for grouped controls. You can edit the following parameters for background screen controls.

General

- **Name field**: Enter a name for the grouped control in the Name field.
- **Description field**: Enter a description for the grouped control in the Description field.
- **Panel button and well**: Click the Panel button, then choose a panel or texture for the background from the menu that appears.
- **Image button and well**: Click the Image button, then drag an image into the well to use it for the background.
- **Select button**: Click to open an Open File dialog to browse and select an image.
- **Stretch to Fit checkbox**: When selected, the image stretches to fill the area of the background as completely as possible.
How MainStage passes through MIDI messages

Some MIDI messages sent by your keyboard controller (or other MIDI device) are "passed through" to any channel strips in the MainStage concert that are mapped to the same controller (or device). Whether or not MIDI messages are passed through depends on the following conditions:

• If there is no screen control in your layout assigned to receive the message type sent by the controller, the messages are passed through.

• If a screen control for that MIDI message type exists, and the MIDI Thru parameter for the screen control is set to Automatic or to the input device, the messages are passed through. This is the default for screen controls set to receive volume, pan, expression, sustain, modulation, pitch bend, and aftertouch messages.

• If a screen control for that MIDI message type exists, and the MIDI Thru parameter for the screen control is set to “Do not pass through,” the data is not passed through. This is the default for most other screen controls.

The reason for these exceptions is so that when you add a screen control for a modulation wheel or a sustain pedal, for example, it “automatically” responds to the appropriate MIDI message type, without your having to configure it further. If you want to have the screen control respond to a different type of MIDI message, you can choose another MIDI message type from the Number pop-up menu in the Screen Control Inspector.

Incoming MIDI messages that are passed through are passed to any channel strips mapped to the same device sending those messages (that is, to the keyboard controller you are using to “play” those channel strips). If there is no matching device, the MIDI messages are sent to all channel strips.

You can also filter incoming MIDI messages for individual channel strips. For information on filtering MIDI messages, see Filter MIDI messages.

Export and import layouts in MainStage

You can export a layout so that you can save it independently from the concert and import it into other concerts. You can also import an exported layout into another concert and then adjust it to work with the mappings in the concert.

When you import a layout into a concert, MainStage analyzes the layout and attempts to convert the assignments and mappings in the layout to work with the concert. It uses the following rules to convert imported assignments and mappings:

• Screen controls are assigned and mapped to screen controls of the same type if they exist in the imported layout.

• Keyboard screen controls are assigned only to keyboard screen controls.

• If the arrangement of screen controls in the concert is similar to their arrangement in the imported layout, screen controls are assigned and mapped to screen controls in the same positions in the workspace.

• If the arrangement of screen controls in the concert is different, MainStage tries to assign and map screen controls starting from the top-left corner of the workspace to the bottom-right corner.
**Export a layout**

1. In Layout mode, choose Export Layout from the Action pop-up menu in the upper-right corner of the workspace (or press Control-Shift-Command-S).
2. In the Save As dialog, type a name for the layout.
3. Browse to the location where you want to save the layout and select it (or use the default location).
4. Click Export.

**Import a layout into a concert**

1. In Layout mode, choose Import Layout from the Action pop-up menu in the upper-right corner of the workspace (or press Control-Command-O).
2. In the Open dialog, select the layout you want to import.
3. Click Open.
   
   The layout for the concert changes to the imported layout.

Because of the wide variety of possible layouts, not all assignments and mappings may be converted as you intended, depending on the differences between the layouts. After you import a layout into a concert, be sure to try the screen controls in the concert to see if they work as expected. After importing the layout, you may need to manually reassign some controls and then manually remap screen controls in your patches for the concert to work with the new layout. If the imported layout has fewer screen controls than the old layout, or has different types of screen controls, you may have to add new screen controls after importing and then assign physical controls to the screen controls to maintain the same level of functionality.

**Change the aspect ratio of a layout in MainStage**

You can change the aspect ratio of a concert layout. Changing the aspect ratio lets you use the concert with different monitor types: 16:10 (widescreen), 4:3 (standard), and 10:16 (portrait).

**Change the aspect ratio for a layout**

- Choose Aspect Ratio from the workspace Action pop-up menu, then choose an option from the submenu.
Perform live with MainStage

Before performing live with MainStage

Now that you’ve created and organized your sounds and set up your layout, it’s time to play! MainStage features Perform mode that optimizes your display for live performance. Here are a few things to check before you begin performing:

- **Check hardware connections and settings**, making sure your MIDI controllers, instruments, microphones, and other music equipment are connected to your computer and are working.

- **Test the audio output** from MainStage using the audio interface and speakers or monitors you plan to use in performance.

- **Select a patch** with a software instrument channel strip and play your keyboard controller. Watch the Activity Monitor to make sure MainStage is receiving MIDI input from the controller, and make sure you can hear the audio output.

- **Make sure any instruments or microphones** you plan to play through audio channel strips are connected to the correct audio inputs on your audio interface. Select a patch with an audio channel strip and play or sing to make sure you can hear audio output.

- **For the best results**, close any applications that you do not need while performing, particularly applications with high processor or RAM requirements.

- **Disconnect the computer** that is running MainStage from any network connections.

- **If you are using Logic Remote with MainStage**, be sure both your computer and iPad are connected to the same wireless network, and connect Logic Remote to MainStage.

For more information about using Logic Remote with MainStage, see Logic Remote Help.
Use Perform mode in MainStage

When you perform live, you can use either Perform in Full Screen or Perform in Window, depending on which you prefer. Each offers some advantages for different performance situations. If you want to view the workspace at maximum size on your display and do not need to access the Finder or the toolbar, use Perform in Full Screen. If you need to access other applications or access buttons in the toolbar, use Perform in Window.

Switch to Perform mode

In MainStage, do one of the following:

- Choose View > Perform in Full Screen (or press Command-4).
- Click the Perform button in the toolbar.

  Note: By default, the Perform button opens the workspace in full screen. For information about changing this preference (in MainStage > Settings > Display), see Display settings.

If you are using a macOS device with a Touch Bar, you can press the Perform button on the Touch Bar to switch to Perform mode.

Close Perform in Full Screen

In MainStage, do one of the following:

- Press the Escape (Esc) key.
- Click the circled “X” in the upper-left corner of the screen.
- Use the key command for one of the other modes (Command-1 through Command-3).

Switch to Perform in Window

- In MainStage, choose View > Perform in Window (or press Command-3).

In Perform mode (both Perform in Window and Perform in Full Screen), Time Machine backups are disabled automatically. This avoids any impact on your performance.
Select patches in performance

Overview of selecting patches while performing in MainStage

In Perform mode, you can view and select patches using the patch selector screen control in your layout. If you are using a macOS device with a Touch Bar, you can also select patches and sets using the Previous Patch, Next Patch, and Set buttons on the Touch Bar. Patches and sets appear in the patch selector in the same order as in the Patch List in Edit mode. Skipped items do not appear in the patch selector and cannot be selected, but patches in collapsed sets do appear and can be selected. For information about skipping items, see Select patches and sets in the Patch List.

When you select a patch, you can start playing it instantly. If you sustain notes from the previous patch, they continue until you release the notes or the sustain pedal. If the previous patch contains effects (such as a reverb or delay effect) with a release “tail,” the effect tail continues sounding for the amount of time set in the Silence Previous Patch pop-up menu in MainStage > Settings > General. For more information, see General settings.

When performing, keep in mind the difference between patch-level mapped parameters and those mapped at the concert level. When you select a patch, its mapped parameters are set to the values at which you last saved the patch (if On Patch Change is set to “Reset to saved value” in MainStage > Settings > General), or the values set the last time you played the patch (if On Patch Change is set to “Keep current value”). Parameters mapped at the concert level keep their current value when you select new patches, regardless of the On Patch Change setting.

Also keep in mind that when you select a patch, the screen controls for knobs, faders, and other controls in the workspace show the parameter values for the patch, which may be different than the positions of the physical controls on your controller. When you move the physical controls, the screen controls instantly update to show the current value.

Select patches in MainStage using keyboard shortcuts

You can select patches in the patch selector using key commands.

Select patches in the patch selector

In MainStage, do any of the following:

- To select the previous patch: Press the Up Arrow.
- To select the next patch: Press the Down Arrow.
- To select the first patch in the previous set: Press the Left Arrow.
- To select the first patch in the next set: Press the Right Arrow.
Select patches in MainStage by typing

You can select a patch in the Patch List by typing the first few letters of its name.

Select a patch by typing its name

- In MainStage, type the letter “f,” then begin typing the name of the patch. To cancel typing, press Enter.

  Once you type enough letters to uniquely identify the patch name, the patch is selected.

Select patches in MainStage using actions

If you have mapped screen controls to actions for selecting patches, such as selecting the previous or next patch, you can select the patches using the physical controls assigned to those screen controls as you perform. You can also select sets or the concert using actions. Buttons are particularly useful for selecting patches, sets, or the concert using actions.

When selecting patches using actions, skipped patches are also skipped. For example, if you use a screen control mapped to select +10 patches, any skipped patches would not be counted in the +10.

Select a patch using an action

- In MainStage, manipulate the control assigned to the screen control that is mapped to the action.

For more information, see Actions table.

Select patches in MainStage using program change messages

If your MIDI device has buttons or other controls that send program change messages, you can select patches in your concert by program change number. You can use program change messages to select patches, but not sets.

For information about how your MIDI device sends program change messages, consult the documentation that came with the device or the manufacturer’s website. For information about changing the program change number for a patch, see Set program change and bank numbers.
MainStage screen controls in performance

In performance, you use the controls on your MIDI hardware devices that are assigned to screen controls to manipulate the parameters mapped to those screen controls. When you select a new patch, the parameters you mapped for that patch are instantly available for editing.

When you move a physical control, the screen control updates based on the Respond to Hardware Move parameter in the Screen Control Inspector. If the parameter is set to Jump, the screen control instantly moves to the position of the hardware control. If the parameter is set to Pickup, the screen control starts moving when the hardware control reaches its current position. If the parameter is set to Relative, the screen control moves in sync with the hardware control, starting from its current position.

Tempo changes in MainStage during performance

When you open the concert you plan to use in your performance, MainStage uses the tempo you set for the concert in the Concert Inspector. If the “Get tempo from MIDI input” checkbox is selected, MainStage uses incoming MIDI beat clock to set the tempo. For information about setting and changing the tempo in a concert, see Overview of concerts.

If you select a patch or set with its own tempo setting, the tempo changes to the new setting. You can also change the tempo in real time while you perform using the Tap Tempo feature, either by pressing Control-T repeatedly at the tempo you want to use, by clicking the Tap Tempo button in the toolbar repeatedly, or by using a screen control mapped to the Tap Tempo action.

MainStage tips for performing with keyboard controllers

If you are using one of the Keyboards templates designed for use with a MIDI-compatible keyboard controller, you can play your keyboard and use MainStage as a sophisticated sound module and multi-effects processor. The patches in the template make extensive use of the software instrument plug-ins included with MainStage as well as a wide range of effects plug-ins.

If you plan to use multiple keyboard controllers when you perform, you can choose whether screen controls respond to MIDI messages from all controllers or only a specific controller and whether channel strips receive input from all controllers or only a single controller.

In Layout mode, screen controls can be set to respond to MIDI input on all MIDI ports and channels or to only a specific device or channel. To have a screen control respond to MIDI input from all controllers, choose All from both the Device and Channel pop-up menus in the Layout Inspector. To have a screen control respond to a specific controller or to the same channel as the keyboard screen control, choose that controller from the Device pop-up menu.

In Edit mode, you set the device from which a channel strip receives MIDI input in the Input tab of the (software instrument) Channel Strip Inspector. By default, channel strips receive input from the first controller in the layout. You can set a channel strip to receive input from another device in the Input pop-up menu.
MainStage tips for performing with guitars and other instruments

If you are using one of the Guitar Rigs templates designed for use with electric guitar, you can play your electric guitar and use MainStage as a multi-effects processor. The patches in the template make extensive use of the Amp Designer amp simulation plug-in and the Pedalboard effects plug-ins as well as other effects commonly used with guitars.

Guitar patches with Pedalboard-style screen controls can be assigned to a foot switch, allowing you to bypass different effects in the channel strip. Some patches also allow you to switch between channel strips with different effects using an expression pedal.

When playing guitars and other low-impedance instruments, be sure they are connected to an audio input that matches the impedance of the instrument. Connecting a guitar to a standard line-level audio input may produce a lower volume level for the guitar’s output than intended.

You can also use MainStage with vocals, or any sound captured with a microphone, using an audio interface connected to your computer and choosing the audio input channel in audio channel strips in your patches.

For guitar patches that use multiple channel strips, you can control the overall volume of the patch using a foot pedal. Using the following procedure, you can set the overall volume for the patch (that is, for all channel strips) so it starts playing at the set volume level but still control subsequent volume changes using the foot pedal.

Tune guitars and other instruments with the MainStage Tuner

MainStage includes a Tuner that you can use to tune guitars and other instruments you play through an audio channel strip. The Tuner shows pitch on a circular scale with the note name and octave displayed in the center of the scale. When you play a single note on your instrument, the pitch is shown in relation to the correct pitch for the note displayed.

You can use the Tuner on an instrument connected to the first audio channel strip in a patch. To use a different channel strip, you can reorder channel strips in the patch. Channel strips that can use the Tuner are indicated by a tuning fork icon near the top of the channel strip.
Tune an instrument using the Tuner

1. In MainStage, click the Tuner icon in the toolbar (or press Command-T).

   The Tuner appears in the workspace.

   *Note:* If you have a macOS device with a Touch Bar, you can press the Tuner button on the Touch Bar to activate the Tuner.

2. Play a single note on your instrument, and watch the Tuner display.

   As you play, the Tuner shows the note name of the closest note. If the note is not in tune, red vertical bars appear, showing whether the note is sharp or flat. The bars appear to the right of the note name if the note is sharp, and to the left if the note is flat.

3. Adjust the tuning peg for the string you are tuning.

   When the note is in tune, a blue vertical bar appears in the center, above the note name. Be sure to play only a single note at a time while tuning. The Tuner can't tune to a chord or interval or if you play different notes rapidly.

   When using the Tuner with a patch containing multiple channel strips, only audio from the first audio channel strip is sent to the Tuner, even if other channel strips in the patch have the same input source. Before using the Tuner, make sure that the first audio channel strip is active and not muted.

   In the Channel Strips area, the channel strip that sends audio to the Tuner is indicated by a tuning fork icon at the top of the channel strip. To use a different channel strip, reorder the channel strips in the patch.

   If other channel strips in the patch have the same audio input source as the first channel strip, the sound from those channel strips is still audible (unlike the output from the Tuner). For example, if you are using a twin-amp patch from the Rock guitar concert template, the output for the second amp is audible while you tune the guitar, unless you mute its output (by setting the Expression pedal screen control to zero).
The MainStage Playback plug-in in performance

You can use the Playback plug-in to play backing tracks or other audio files while you are performing. Playback can be triggered either when you select a patch or set or by using a button or other screen control. You can control other Playback parameters to which you have mapped screen controls, including fading out the sound and looping playback. For files containing marker information, you can also use markers to switch playback to different sections of the audio file. You can start and stop playback of multiple Playback plug-in instances using the Group menu.

Where you add an instance of the Playback plug-in depends on how you want to use it. If you want to play back an audio file while you play a single patch, you can add it to the patch. If you add a Playback plug-in at the set level, you can select different patches in the set and have the audio file continue playing. This can be useful, for example, if the set includes all the patches you use in a song, and the Playback plug-in plays an audio file with a backing track for the song. If you add a Playback plug-in at the concert level, you can select different patches in the concert and have the audio file continue playing. The ability to use the plug-in at any level gives you a great deal of creative freedom in how you use it.

You can use the Playback plug-in in software instrument channel strips in a patch or at the set or concert level.

The Playback plug-in is designed so that it can be used in a variety of ways. Following are a few ideas for how to use the Playback plug-in in different situations. You can try them out or use them as a starting point for your own creative uses.

- Add a Playback plug-in to a patch and use it to play a backing track while you play an instrument on another channel strip in the patch.
- Add a Playback plug-in at the set level and use it to play a backing track that continues while you select and play different patches in the set.
- Add a Playback plug-in at the concert level and use it to play a backing track or sound effect while you select and play different patches in the concert.
- Add multiple instances of the Playback plug-in at the set or concert level, and use them to play and remix different backing tracks.

Record your performances in MainStage

You can record a performance to an audio file. Before you record a performance, you can choose the file format of the recorded audio file.

If you choose AIFF as the file format for recording, the maximum file size for the recorded file is 2 gigabytes. If you choose WAVE as the file format, the maximum file size is 4 gigabytes. If you choose CAF as the file format, there is no practical limit to the file size. You can choose the file format in MainStage > Settings > Audio, and also set the location of the recorded file and choose which audio outputs are recorded (if you are using multiple sets of outputs in your concert). For information about recording settings, see Audio settings.

You can record in Perform mode by mapping a screen control to the Record action. You can also assign a key command to the Record action and use it to record in Perform mode (but not in Perform in Full Screen).
Start recording to an audio file

- In MainStage, move the screen control mapped to the Record action (or press Option-R).

Stop recording

- In MainStage, move the screen control mapped to the Record action (or press Option-R again).

After the performance with MainStage

Before closing your concert after your performance, remember that, for any screen controls for which the On Patch Change parameter is set to “Reset to saved value,” changes to channel strip or plug-in parameters you made while performing revert to their previously saved state if you close the concert without saving. If you save the concert before closing, the new values are saved only for the patch currently selected in the Patch List, not for the other patches (or sets) in the concert.

MainStage tips for complex hardware setups

It is highly recommended that you test your concert thoroughly using the same setup you plan to use in live performance prior to performing, at the performance venue if possible. This is especially important for more complex hardware setups.

If you use MainStage with a complex hardware setup, such as with multiple MIDI controllers or MIDI interfaces or with multiple audio inputs, you can achieve the best results when you use exactly the same hardware setup you used when you created your concert.

If you plan to use MainStage with different controllers, interfaces, or other devices than the ones you used to create your concert, you need to relearn your hardware assignments using your performance hardware setup. To facilitate working in this situation, you can create two separate layouts, one for your studio setup and another for your performance setup, with corresponding screen controls in each layout. Before you perform, import the performance layout into your concert. The hardware assignments for your performance setup are imported with the layout, and your mappings are maintained.
MainStage settings

Overview of settings in MainStage

You can set a variety of settings by choosing MainStage > Settings. The settings window includes tabs for general, audio, MIDI, and display settings, which are described in the following sections.

General settings in MainStage

These settings let you set the tuning of software instruments, choose what happens when you open MainStage, reset alerts, and set whether screen controls highlight when their parameter values change.

Tuning

- **Tuning slider and field**: Sets the tuning for all software instruments in MainStage. Tuning is centered around A440 Hz, in the range of 100 cents.
Startup

- **Startup Action pop-up menu:** Choose the startup action when you open MainStage. The choices are:
  - *Do Nothing:* Does nothing. You can open the Choose Template dialog by choosing File > New.
  - *Create New Concert from Template:* Opens the Choose Template dialog.
  - *Open Most Recent Concert:* Opens the last open concert in the same mode it was in when you closed it.
  - *Open Most Recent Concert in Perform Mode:* Opens the last open concert in Perform mode.

Accessibility

- **Open plug-ins in controls view by default checkbox:** When this option is selected, plug-in windows open in controls view, making plug-in parameters available for use with VoiceOver.

Alerts

- **Reset Warnings button:** Click to reset the behavior of alerts for which you have selected the “Do not show again” checkbox, so that they appear in the future when appropriate conditions occur.

Parameter Values

- **On Patch Change pop-up menu:** Choose whether parameter values change or remain the same when you change patches. By default, the On Patch Change parameter for individual screen controls is set to Preference, in which case they follow the preference behavior. If this parameter is set to another value for a screen control, the control follows the value of its individual setting. The choices are:
  - To preserve changes to parameter values when you change patches, choose “Keep current value.”
  - To return values to the last saved value, choose “Reset to saved value.”

- **Respond to Hardware Move pop-up menu:** Choose how screen controls respond when you move the hardware controls assigned to them. By default, the Respond to Hardware Move parameter for individual screen controls is set to Preference, in which case they follow the preference behavior. If this parameter is set to another value for a screen control, the control follows the value of its individual setting. The choices are:
  - To have screen controls instantly change to match the hardware value, choose Jump.
  - To have screen controls change when the hardware control matches its current value, choose Pickup.
  - To have screen controls move relative to the hardware control, choose Relative.
Autosaving

- **Autosave modified concerts pop-up menu:** Choose the time interval for autosaving modified concerts, or choose Never to turn off autosaving.

  *Note:* For performance reasons, autosaving does not occur in Perform mode. However, the concert is autosaved when you switch to Perform mode.

Audio settings in MainStage

These settings let you set the audio output and input drivers, set the size of the I/O buffer, set the audio sample rate, and choose which note is displayed as middle C.

Audio

- **Audio Output pop-up menu:** Choose the device you want to use to hear the audio output from MainStage.

- **Audio Input pop-up menu:** Choose the device you want to use as the source for audio input. Choose Automatic to use the system setting for audio input (except when the only available input device is the built-in microphone, in which case no input device is selected).

- **Setup buttons:** Click one of the Setup buttons to open the Audio/MIDI Setup window and configure audio output or input.

- **Sample Rate pop-up menu:** Choose the sample rate for audio input. If you are using an audio interface or other audio device with MainStage, the Sample Rate value should be set to the sample rate of your audio device.

- **Advanced Settings button:** Open the Advanced Settings window so you can set the I/O buffer size and driver latency, and view an estimate of the resulting latency.

- **Hot-Plug Behavior pop-up menu:** Choose what action MainStage takes when you hot-plug an audio device while MainStage is open. The choices are:
• **Alert me**: Displays an alert when a device is hot-plugged. The alert includes buttons that let you use or ignore the device.

• **Automatically Use Device**: Switches the audio drivers to allow immediate use of the hot-plugged device for audio input and output.

• **Do Nothing**: Does not switch the audio drivers.

### Recording

• **Output pop-up menu**: Choose the audio output to record.

• **Recordings Folder field**: Click the field, then browse to choose the location where recordings are saved. The file path of the chosen location appears in the field.

• **File Format pop-up menu**: Choose the file format for audio recordings. The choices are:
  - AIFF
  - CAF
  - WAVE

• **24-Bit Recording checkbox**: When selected (default), MainStage can record 24-bit files. Otherwise, audio recordings use a resolution of 16-bit.

### Channel Strips

• **Silence Previous Patch pop-up menu**: Choose the amount of time sustaining notes and effects tails continue to sound before falling silent when you select a new patch.

  The Silence Previous Patch preference applies only to audio and external instrument channel strips, not software instrument channel strips.

• **Globally Disable Feedback Protection checkbox**: When selected, feedback protection is disabled for all audio and external instrument channel strips in all concerts. The Feedback Protection checkbox is also removed from the Attributes tab in the Channel Strip Inspector.

• **Voice Limiter Active checkbox**: When selected, the voice limiter is enabled. The voice limiter avoids audio dropouts at high CPU loads by stopping voices from MainStage software instruments based on the order in which those voices were played. When the CPU load increases to the point that audio dropouts may occur, the voice limiter activates and stops a few of the oldest voices still sounding; if that doesn’t lower the CPU load enough to avoid dropouts, the voice limiter stops all older voices still sounding. In general, the voice limiter should remain enabled.
Advanced Settings

Clicking the Advanced Settings button in the Audio settings pane opens a new window with the following additional settings:

- **I/O Buffer Size pop-up menu**: Choose the size of the buffer for audio input and output in samples. Smaller buffer sizes reduce the amount of latency, but also require more work from the CPU and may result in playback artifacts. You may want to try different settings to find the lowest setting that does not produce any artifacts.

- **I/O Safety Buffer checkbox**: If selected, MainStage uses an additional buffer to process audio output streams, providing a safeguard against crackling noises that may occur when using very low I/O Buffer Size settings. If turning on this preference does not improve things on your system, disable the checkbox and select a larger I/O buffer size setting.

  *Note*: Use of the I/O Safety Buffer preference increases the output latency and therefore the round trip (input plus output) latency.

- **Driver Latency slider**: Drag the slider to set the amount of latency. Drag left to decrease the amount of latency, or drag right to increase the amount of safety (may increase latency).

  The latency for the current buffer size is displayed below the Driver Latency slider.

- **CPU Usage slider**: Drag the slider to set the amount of processor power devoted to audio processing. For multi-core processors, this controls the number of cores devoted to audio processing.

- **Draw pop-up menu**: The MainStage interface is drawn using either the open source OpenGL standard, or the Apple-developed Metal standard. Metal can offer performance benefits for the latest generation of Macs, but can cause performance issues with older or less powerful computers. However, Metal also allows offloading drawing to discreet (external) GPUs. Therefore, you can choose whether the interface is drawn using OpenGL, using Metal on discreet GPUs, or Metal (on the built-in GPU), based on your specific equipment.
MIDI settings in MainStage

These settings let you view the current status of MIDI inputs and choose which note appears as middle C.

![MIDI settings interface]

### MIDI

- **MIDI Status field:** Displays the number of detected MIDI inputs.
- **Setup button:** Click to open the Audio Devices pane of Audio/MIDI Setup Utility.
- **Warn if no MIDI device is connected checkbox:** When selected, a warning is displayed in no MIDI device is connected to your computer.

### Display

- **Display Middle C as pop-up menu:** Choose whether middle C is displayed as C3 or C4.
- **Program Change Range pop-up menu:** Choose whether program changes use the range of 0–127 or 1–128.
- **Bank Select as individual MSB/LSB controllers checkbox:** When selected, Bank Select messages are displayed as two independent controllers.
Display settings in MainStage

These settings let you choose the default size for plug-in windows and the view in which the workspace opens in Perform mode.

Inspectors

- **Show Icons in File Browsers checkbox**: If selected, mini icons are displayed next to folders and patches in the Inspector when browsing.

Toolbar

- **Show Toolbar CPU and Memory meters checkbox**: When selected, the CPU and Memory meters appear in the center of the toolbar, along with the MIDI Status display. The checkbox is deselected by default.
- **Show warning if computer is running too hot checkbox**: When selected, MainStage alerts you if your computer’s temperature is too high and needs to cool down to ensure continued safe operation.
- **Show memory usage in patch list checkbox**: When selected, the Patch List displays each patch with its memory requirement to the right of the patch name.
- **Show warning if power supply is disconnected checkbox**: When selected, MainStage alerts you if no power supply is connected to your computer.
Mixer and Plug-in Window

- **Open the plug-in window when adding a plug-in checkbox:** When selected, adding a new plug-in to a channel strip automatically opens the plug-in window.

- **Show recent plug-in list in plug-in menu checkbox:** When selected, a “Show Recent” section of recently opened plug-ins appears at the top of plug-in menus.

- **Show bus names in the mixer checkbox:** Select this if you want the mixer to display the bus name, if one exists, along with the bus number.

- **Wide Channel Strips in the mixer checkbox:** Select this if you want the mixer to display channel strips wider than the default.

- **Pre-Fader Metering checkbox:** When selected, meters display the signal level before the signal is processed through the channel strip.

- **Level Meter Scale pop-up menu:** Use this pop-up menu to select the level meter scale to use in the mixer:
  - **Exponential:** Provides higher display resolution in the upper level meter range.
  - **Sectional dB-linear:** Provides the best possible display resolution across the entire level meter range.

Performance

- **Perform in Full Screen checkbox:** If selected, Perform mode opens in a full screen view, rather than a window.

- **Disable screen saver in Perform mode:** If selected, the macOS screen saver is disabled when MainStage is in Perform mode.

- **Large Selection Handles in Layout Mode:** If selected, screen controls have large selection handles in Layout mode.
Sampler settings in MainStage

You can configure the way in which the Sampler instrument searches for audio samples, stores audio samples, uses virtual memory, and more, using these settings. The Sampler settings window contains two tabs with configuration options: The Misc tab for miscellaneous settings, and the Virtual Memory tab for virtual memory settings.

Misc

The Misc tab contains the following settings:

- **Sample Storage pop-up menu**: Determines how Sampler handles the bit depth of samples. Choose one of the following:
  - **Original**: Loads samples into RAM at their original bit depth. These are converted to the internal 32-bit floating point format of the host application on playback.
  - **32 Bit Float**: Samples are stored and loaded as 32-bit float files, which removes the need for real-time format conversions. Sampler handles 32 bit float samples more efficiently and can play back more voices simultaneously.
    
    *Note*: This requires twice as much RAM for 16-bit samples and a third more RAM for 24-bit samples.

- **Search samples on pop-up menu**: Determines the locations that Sampler searches for instrument samples. Choose one of the following:
  - **Local Volumes**: Sampler searches storage media attached to or installed in the computer for samples.
  - **External Volumes**: Sampler searches storage media accessible over a network for samples.
  - **All Volumes**: Sampler searches both internal and network media for samples.

  *Note*: Choosing External Volumes or All Volumes may increase the time it takes Sampler to find and load sampler instruments and files.
• **Read root key from pop-up menu**: Sets the method Sampler and Quick Sampler use to determine the root key of audio files when loaded using Optimized mode. Choose one of the following menu options:

  • **File/Analysis**: Sampler and Quick Sampler first attempt to read the root key from the header of the AIFF, WAV, or CAF file when loading the sample into a zone. If no root key information exists in the header, then the audio samples are analyzed to determine the root key from the longest note detected. If no pitch is detected, C3 is automatically assigned to the zone as the root key.

  • **Filename/Analysis**: Sampler and Quick Sampler first attempt to read the root key from the filename when loading the sample into a zone. If the filename does not contain that information, then the audio samples are analyzed to determined the root key from the longest note detected. If this doesn’t provide useful results, Sampler uses C3 as the default root key in the zone.

  • **Filename only**: Sampler and Quick Sampler attempt to read the root key from the filename only when loading the sample into a zone. If no root key information can be read from the filename, C3 is automatically assigned to the zone as the root key.

  • **File only**: Sampler and Quick Sampler read from the AIFF, WAV, or CAF file header only in an attempt to detect the root key when loading the sample into a zone. If no root key information can be read from the file header, C3 is automatically assigned to the zone as the root key.

  • **Analysis only**: Sampler and Quick Sampler analyze the audio samples in an attempt to determine the root key from the longest note detected when loading the sample into a zone. If no pitch is detected, C3 is automatically assigned to the zone as the root key.

• **Root Key at File Name Position pop-up menu**: Determine how Sampler derives the root key from the audio file header. Choose one of the following:

  • **Auto**: Provides a smart analysis of numbers and keys from the filename. Sampler can recognize a number in the filename regardless of its format—60 and 060 are both valid. Other valid numbers range between 21 and 127. Numerical values outside of these are generally just version numbers. A key number is also a valid possibility for this use—C3, C 3, C_3, A-1, #C3, or C#3, for example. The possible range is C-2 up to G8.

  • **Numeric value**: You can set a numeric position in the filename which Sampler uses to find the root key. This is useful when a filename uses multiple numbers, such as a loop that uses multiple numbers to indicate both tempo and root key. For example, a loop might be named “loop100-60.wav” to represent that it has a tempo of 100 beats per minute and the root is the 60th position (E6). When you know the position of the number representing the root key, you can set a numerical value to read the root key at position eight of the filename.

• **Previous Instrument pop-up menu and field**: Determines which MIDI event type and data value are used for selection of the previous instrument. Choices include Note, Poly Aftertouch, Control Change, Program Change, Channel Aftertouch, and Pitch Bend. In the field next to each pop-up menu, you can enter either the note number or the value of the first data byte. If you choose Control Change, the number field determines the MIDI controller number.
Note: The Sampler Previous Instrument setting is separate from the global Previous/Next Plug-in Setting or Sampler Instrument command. Be careful not to assign the same MIDI event for both, otherwise both commands are executed, which can result in unexpected behavior.

- **Next Instrument pop-up menu and field:** Determine which MIDI event type and data value are used for selection of the next instrument. Choices include Note, Poly Aftertouch, Control Change, Program Change, Channel Aftertouch, and Pitch Bend. In the field next to each pop-up menu, you can enter the note number or the value of the first data byte. If you choose Control Change, the number field determines the MIDI controller number.

Note: The Sampler Previous Instrument setting is separate from the global Previous/Next Plug-in Setting or Sampler Instrument command. Be careful not to assign the same MIDI event for both, otherwise both commands are executed, which can result in unexpected behavior.

- **Keep common samples in memory when switching projects checkbox:** Determines whether the samples commonly used, or shared, by two open project files are reloaded when you switch between projects.

**Virtual Memory**

Clicking the Virtual Memory tab opens a window with the following additional settings:

- **Active checkbox:** Turns on or off the virtual memory feature in Sampler. With virtual memory on only the initial attacks of samples are loaded into RAM; the rest of the sample streams in real-time from the hard drive. If you have enough physical RAM to hold all samples for a project, you can improve performance by deselecting the Active checkbox. In projects with lots of audio tracks playing and relatively few Sampler instances, this may affect performance. If the Active checkbox is deselected and there is insufficient RAM to hold all samples, Sampler swaps data to and from the disk, which degrades performance. Deselecting the Active checkbox also increases project load times.
• **Buffer Range pop-up menu**: Determines the size of the buffer used for processing audio samples. You can choose between Small, Medium, and Large buffer sizes.

• **Host Disk Activity pop-up menu**: Optimizes Sampler by indicating how much recording and streaming of non-sampler-related audio is occurring. Choose one of the following:
  - **Less**: If your projects consist mostly of software instrument playback, with perhaps a recorded instrument or vocal or two, set your Host Disk Activity to Less.
  - **Average**: If your projects involve recording a small number of tracks at a time, and possibly playing back a dozen or so audio tracks and some software instruments, set your Host Disk Activity to Average.
  - **Extensive**: If you are recording an entire drum kit using over a dozen microphones, streaming live guitars and bass, recording choirs, and so on, set your Host Disk Activity to Extensive.

• **Requires Constant RAM Allocation Of field**: Shows memory requirements of the parameter settings above. The slower your hard drive and the higher your hard disk recording activity, the more RAM you may need to allocate to virtual memory. If you need to apply more, change the amount and click the Apply button.

• **Disk I/O Traffic field**: Shows Sampler read/write disk load. If read/write traffic exceeds your hard drive's throughput capacity, you may hear audio glitches.

• **Not Read From Disk in Time field**: Shows the number of audio files Sampler is unable to read in time. If audio cannot be read from disk in time, you may hear audio glitches.
Use the Touch Bar with MainStage

Touch Bar shortcuts in MainStage

If your Mac has a Touch Bar, you can use gestures to select and play patches, turn on and off the Tuner or the metronome, switch between modes, activate key commands, and quickly perform other tasks. The controls in the main area of the Touch Bar (to the left of the Control Strip) change depending on what mode you are using and what is selected in the app. In addition, most of the Touch Bar controls can be customized using the Customize Touch Bar window.

For more information about the Control Strip, see MacBook Pro Essentials. To learn more about the Touch Bar, see the macOS User Guide Use the Touch Bar on Mac.

Primary Touch Bar shortcuts

These shortcuts appear in the Touch Bar when you open MainStage.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar</td>
<td>Toolbar</td>
<td>Switches to the Toolbar screen.</td>
</tr>
<tr>
<td>Layout</td>
<td>Layout</td>
<td>Switches MainStage to Layout mode.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit</td>
<td>Switches MainStage to Edit mode.</td>
</tr>
<tr>
<td>Perform</td>
<td>Perform</td>
<td>Switches MainStage to Perform in Window.</td>
</tr>
<tr>
<td>Icon</td>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>🎤</td>
<td>Tuner</td>
<td>Turns the Tuner on or off, if there is an audio channel strip with an assigned input in the current patch.</td>
</tr>
<tr>
<td>⚠️</td>
<td>Panic</td>
<td>Immediately silences any hanging MIDI notes.</td>
</tr>
<tr>
<td>⏯️</td>
<td>Play/Stop</td>
<td>Starts or stops playback at the current transport position.</td>
</tr>
<tr>
<td>⏯️</td>
<td>Metronome</td>
<td>Starts or stops the metronome.</td>
</tr>
<tr>
<td>🎤</td>
<td>Master Mute</td>
<td>Mutes or unmutes all sound.</td>
</tr>
</tbody>
</table>

**Toolbar shortcuts**

When you tap the Toolbar button [ ], the following controls appear in the Touch Bar:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✗</td>
<td>Close</td>
<td>Returns you to the Primary screen.</td>
</tr>
<tr>
<td>🎵️</td>
<td>Toolbar</td>
<td>Returns you to the Primary screen.</td>
</tr>
<tr>
<td>♂️</td>
<td>Select Screen</td>
<td>Shows additional Touch Bar commands for the selected MainStage mode.</td>
</tr>
<tr>
<td>🔥</td>
<td>Key Commands</td>
<td>Switches to the Key Commands screen.</td>
</tr>
<tr>
<td>🖥️</td>
<td>Keyboard</td>
<td>Switches to the Keyboard screen.</td>
</tr>
</tbody>
</table>
Layout mode shortcuts

When MainStage is in Layout mode, if you tap the Select Screen button, the following dynamic controls appear in the Touch Bar.

*Note:* To switch between buttons in the same position of the Touch Bar, press Control.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Select Screen</td>
<td>Returns you to the Toolbar screen.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Group/Ungroup</td>
<td>Groups and ungroups selected screen controls.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Lift/Stamp</td>
<td>Lifts or stamps parameters from the selected screen controls.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Align Left</td>
<td>Aligns the left edges of selected screen controls.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Align Horizontal Center/Distribute Centers Horizontally</td>
<td>Aligns the horizontal centers or distributes the centers horizontally of selected screen controls.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Align Right/Distribute Spacing Horizontally</td>
<td>Aligns the right edges or distributes the spacing horizontally of selected screen controls.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Align Top/Distribute Centers Vertically</td>
<td>Aligns the top edges or distributes the centers vertically of selected screen controls.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Align Vertical Centers/Distribute Spacing Vertically</td>
<td>Aligns the vertical centers or distributes the spacing vertically of selected screen controls.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Align Bottom</td>
<td>Aligns the bottom edges of selected screen controls.</td>
</tr>
</tbody>
</table>
For information on how to customize the buttons on this bar, see Customize the Touch Bar.

**Edit mode shortcuts**

When MainStage is in Edit mode, if you tap the Select Screen button, the following controls appear in the Touch Bar:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Select Screen</td>
<td>Returns you to the Toolbar screen.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Show/Hide Workspace</td>
<td>Shows or hides the Workspace area.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Show/Hide Plug-ins</td>
<td>Shows or hides any open or previously opened plug-in windows.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Workspace/Assignments &amp; Mappings</td>
<td>Toggles the Workspace between the Workspace and Assignments &amp; Mappings tabs.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Tap Tempo</td>
<td>Tap this button rhythmically to set MainStage's clock.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Panic</td>
<td>Immediately silences any hanging MIDI notes.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Master Mute</td>
<td>Mutes or unmutes all sound.</td>
</tr>
</tbody>
</table>

For information on how to customize the buttons on this bar, see Customize the Touch Bar.
Perform mode shortcuts

When MainStage is in Perform mode, if you tap the Select Screen button, the following controls appear in the Touch Bar:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Select Screen</td>
<td>Returns you to the Toolbar screen.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Previous Set</td>
<td>Selects the previous set.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Next Set</td>
<td>Selects the next set.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Previous Patch</td>
<td>Selects the previous patch.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Next Patch</td>
<td>Selects the next patch.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Tuner</td>
<td>Turns the Tuner on or off, if there is an audio channel strip with an assigned input in the current patch.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Metronome</td>
<td>Starts or stops the metronome.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Panic</td>
<td>Immediately silences any hanging MIDI notes.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Master Mute</td>
<td>Mutes or unmutes all sound.</td>
</tr>
</tbody>
</table>

For information on how to customize the buttons on this bar, see Customize the Touch Bar.
Key Commands shortcuts

When you tap the Key Commands button, the following controls appear in the Touch Bar:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Key Commands</td>
<td>Returns you to the Primary screen.</td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>Saves current concert.</td>
</tr>
<tr>
<td></td>
<td>Previous Patch</td>
<td>Selects the previous patch.</td>
</tr>
<tr>
<td></td>
<td>Next Patch</td>
<td>Selects the next patch.</td>
</tr>
<tr>
<td></td>
<td>Previous Set</td>
<td>Selects the previous set.</td>
</tr>
<tr>
<td></td>
<td>Next Set</td>
<td>Selects the next set.</td>
</tr>
<tr>
<td></td>
<td>Play/Stop</td>
<td>Starts or stops playback at the current transport position.</td>
</tr>
<tr>
<td></td>
<td>Panic</td>
<td>Immediately silences any hanging MIDI notes.</td>
</tr>
<tr>
<td></td>
<td>Master Mute</td>
<td>Mutes or unmutes all sound.</td>
</tr>
</tbody>
</table>

For information on how to customize the buttons on this bar, see Customize the Touch Bar.

Keyboard controls

When you tap the Keyboard button, you can use the Touch Bar to play a software instrument on the selected software instrument track.

- Tap the keys on the Touch Bar keyboard to play notes.
- To adjust the octave range of the Touch Bar keyboard, tap one of the Keyboard Octave buttons to the left of the Touch Bar keyboard.
- To limit notes to a musical scale: Tap the Scale button, then tap to select the root note and the mode.
- Tap the Close button to return to the previous Touch Bar screen.
Customize the Touch Bar in MainStage

You can customize most screens of the Touch Bar using the Customize Touch Bar window.

You can customize the buttons on the Key Commands screen in the Key Commands Editor.

Open the Customize Touch Bar window

- In MainStage, select View > Customize Touch Bar.

Add, remove, or rearrange items

In MainStage:

- Add buttons: Use the trackpad or mouse to drag a button from the screen to the Touch Bar; buttons in the Touch Bar jiggle slightly.

- Remove buttons: Use the trackpad or mouse to drag a button from the Touch Bar to the screen.

- Rearrange buttons: Use your finger on the Touch Bar to drag a button.

When you have finished customizing the Touch Bar, click Done in the Customize Touch Bar window.
Customize buttons on the Key Commands screen

- In MainStage, select MainStage > Key Commands > Customize (or press Option-K) to open the Key Commands Editor.

The Key Commands Editor opens with a virtual Touch Bar showing the currently assigned key commands on the Key Commands screen.

The Touch Bar also shows the Key Commands screen.

- **Add buttons**: Drag a key command from the Command List in the Key Commands Editor to one of the buttons on the virtual Touch Bar.

- **Remove buttons**: Drag a key command button off the virtual Touch Bar.
Keyboard shortcuts and command sets

Overview of MainStage keyboard shortcuts and command sets

Standard keyboard shortcuts: Many common tasks, from switching modes and showing inspectors to working with tools, can be accomplished quickly by pressing one or more keys on your computer keyboard. These are called keyboard shortcuts. For a list of default keyboard shortcuts, see the subtopics in the Keyboard shortcuts topic.

Custom keyboard shortcuts: You can create your own custom keyboard shortcuts for tasks you perform frequently, and use the Key Commands Editor to substitute your custom keyboard shortcuts for the default set in MainStage. See View keyboard shortcuts in the Key Commands Editor and Edit keyboard shortcuts.

Keyboard shortcuts

A table of MainStage concerts and layouts keyboard shortcuts

Includes keyboard shortcuts for creating, opening, and saving concerts and for exporting and importing layouts.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command-N</td>
<td>New concert</td>
</tr>
<tr>
<td>Command-O</td>
<td>Open concert</td>
</tr>
<tr>
<td>Command-W</td>
<td>Close concert, or close the active plug-in window</td>
</tr>
<tr>
<td>Command-S</td>
<td>Save concert</td>
</tr>
<tr>
<td>Shift-Command-S</td>
<td>Save concert as</td>
</tr>
<tr>
<td>Control-Command-O</td>
<td>Import layout</td>
</tr>
<tr>
<td>Control-Shift-Command-S</td>
<td>Export layout</td>
</tr>
</tbody>
</table>
A table of MainStage patches and sets (Edit mode) keyboard shortcuts

Includes keyboard shortcuts for adding, selecting, exporting, and importing patches and sets.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option-Command-N</td>
<td>Add a new patch</td>
</tr>
<tr>
<td>Option-Command-S</td>
<td>Add a new set</td>
</tr>
<tr>
<td>Command-I</td>
<td>Import patches or sets</td>
</tr>
<tr>
<td>Command-E</td>
<td>Export patch, export set, or export as set</td>
</tr>
<tr>
<td></td>
<td>(depending on what is selected)</td>
</tr>
<tr>
<td>Command-Up Arrow</td>
<td>Select the previous patch</td>
</tr>
<tr>
<td>Command-Down Arrow</td>
<td>Select the next patch</td>
</tr>
<tr>
<td>Command-Left Arrow</td>
<td>Select the first patch in the previous set</td>
</tr>
<tr>
<td>Command-Right Arrow</td>
<td>Select the first patch in the next set</td>
</tr>
<tr>
<td>Option-Shift-Command-S</td>
<td>Create a new set from selected patches</td>
</tr>
<tr>
<td>Option-Shift-M</td>
<td>Move the selected patch again</td>
</tr>
<tr>
<td>Option-Shift-Command-R</td>
<td>Reset program change numbers</td>
</tr>
</tbody>
</table>

A table of MainStage editing keyboard shortcuts

Includes keyboard shortcuts for cutting, copying, pasting, and other common editing functions.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command-Z</td>
<td>Undo the last command</td>
</tr>
<tr>
<td>Shift-Command-Z</td>
<td>Redo the last undone command</td>
</tr>
<tr>
<td>Command-X</td>
<td>Cut</td>
</tr>
<tr>
<td>Command-C</td>
<td>Copy</td>
</tr>
<tr>
<td>Command-V</td>
<td>Paste</td>
</tr>
<tr>
<td>Command-D</td>
<td>Duplicate</td>
</tr>
<tr>
<td>Command-A</td>
<td>Select all</td>
</tr>
</tbody>
</table>
### A table of MainStage actions keyboard shortcuts

Includes keyboard shortcuts for some MainStage actions.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control-P</td>
<td>Panic</td>
</tr>
<tr>
<td>Control-T</td>
<td>Tap Tempo</td>
</tr>
<tr>
<td>Control-M</td>
<td>Master Mute</td>
</tr>
<tr>
<td>Control-R</td>
<td>Toggle Recording</td>
</tr>
<tr>
<td>Space bar</td>
<td>Toggle Play/Stop</td>
</tr>
</tbody>
</table>

### A table of MainStage parameter mapping (Edit mode) keyboard shortcuts

Includes keyboard shortcuts for learning mappings and locating mappings in the Parameter Mapping browser, and setting the range of mappings in the Mappings tab.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command-L</td>
<td>Map Parameter (turn on mapping for selected parameter)</td>
</tr>
</tbody>
</table>

### A table of MainStage channel strips (Edit mode) keyboard shortcuts

Includes keyboard shortcuts for adding channel strips.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option-Command-A</td>
<td>Add audio channel strip</td>
</tr>
<tr>
<td>Option-Command-I</td>
<td>Add software instrument channel strip</td>
</tr>
<tr>
<td>Option-Command-F</td>
<td>Show/Hide signal flow channel strips</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Select the channel strip to the left of the currently selected one</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Select the channel strip to the right of the currently selected one</td>
</tr>
</tbody>
</table>
A table of MainStage screen controls (Layout mode) keyboard shortcuts

Includes keyboard shortcuts for learning controller assignments and for grouping and ungrouping screen controls.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command-L</td>
<td>Learn controller assignment (turn on the Learn process)</td>
</tr>
<tr>
<td>Shift-Command-G</td>
<td>Group screen controls</td>
</tr>
<tr>
<td>Option-Shift-Command-G</td>
<td>Ungroup screen controls</td>
</tr>
<tr>
<td>Control-H</td>
<td>Add Hardware Label to Next Object</td>
</tr>
</tbody>
</table>

A table of MainStage Perform in Full Screen keyboard shortcuts

Includes keyboard shortcuts for selecting patches and sets, sending MIDI panic, muting/unmuting audio, and exiting Perform in Full Screen.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up Arrow</td>
<td>Select the previous patch</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>Select the next patch</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Select the first patch of the previous set</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Select the first patch of the next set</td>
</tr>
<tr>
<td>P</td>
<td>Send MIDI panic</td>
</tr>
<tr>
<td>M</td>
<td>Mute/unmute all audio</td>
</tr>
<tr>
<td>Esc</td>
<td>Exit Perform in Full Screen</td>
</tr>
</tbody>
</table>
A table of MainStage window and view keyboard shortcuts

Includes keyboard shortcuts for switching modes and for showing inspectors and other areas of the interface.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command-1</td>
<td>Layout mode</td>
</tr>
<tr>
<td>Command-2</td>
<td>Edit mode</td>
</tr>
<tr>
<td>Command-3</td>
<td>Perform in Window</td>
</tr>
<tr>
<td>Command-4</td>
<td>Perform in Full Screen</td>
</tr>
<tr>
<td>Command-5</td>
<td>Show/Hide Inspectors</td>
</tr>
<tr>
<td>Command-6</td>
<td>Show/Hide the Channel Strips area</td>
</tr>
<tr>
<td>Command-7</td>
<td>Show/Hide the workspace</td>
</tr>
<tr>
<td>Command-T</td>
<td>Show/Hide the Tuner</td>
</tr>
<tr>
<td>Command-M</td>
<td>Minimize the MainStage window</td>
</tr>
<tr>
<td>Command-Comma (,)</td>
<td>Open MainStage settings</td>
</tr>
<tr>
<td>V</td>
<td>Show/Hide the active plug-in window</td>
</tr>
<tr>
<td>Shift-Command-M</td>
<td>Show the MIDI Message Monitor window</td>
</tr>
</tbody>
</table>

A table of MainStage Help and support keyboard shortcuts

Includes the keyboard shortcuts to open MainStage Help.

<table>
<thead>
<tr>
<th>Default keyboard shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift-Command-H</td>
<td>Shows or hides Quick Help.</td>
</tr>
<tr>
<td>Command-Backslash (/)</td>
<td>View detailed Help for a Quick Help topic.</td>
</tr>
</tbody>
</table>
Customize keyboard shortcuts

View keyboard shortcuts in the MainStage Key Commands Editor

You can use the Key Commands Editor to view and modify keyboard shortcuts, create new keyboard shortcuts, and save command sets that you can export for others to use. You can also import a command set from another computer. If you are used to using keyboard shortcuts from other applications, you can use the Key Commands Editor to substitute those keyboard shortcuts in place of the default set for MainStage.

The Key Commands Editor provides a set of keyboard shortcuts for MainStage in several languages. Your Mac’s system language is used as the default language. To learn how to change the system language, see macOS Help, available from the Help menu when the Finder is active.

View the current command set

1. Choose MainStage > Key Commands > Customize (or press Option-K).
2. To find key commands in the Key Commands Editor, do any of the following:
   - Click keys on the virtual keyboard, or click one of the four modifier buttons at the top of the Key Commands Editor.
     The Command groups associated with the selected key or keys appear in the lower-left corner of the window, and a list of all the keyboard shortcuts associated with the key you selected appears in the lower-right area of the window.
     When you hold down one or more modifier keys on your keyboard, the key colors update. Key colors correspond with command groups; for example, playback commands, such as Play/Pause (Space bar), are blue. The Command Groups window in the lower-left corner of the window shows a list of command groups.
Enter a command name, description keywords, or a key name in the search field at the upper-right corner of the window. Commands that match the search term are listed in the Command List at the bottom of the window.

Tip: To show the keys that correspond with the items in the Command List, click the Keyboard Highlight button to the left of the search field.

- Click any command in the list to view its details in the Command Detail area in the lower-right corner of the window.
- Click a Command group to quickly filter the Command List to display only the commands and keyboard shortcuts in that group.

Choose a different command set

- Do one of the following:
  - Choose MainStage > Key Commands, then choose a command set from the Command Sets submenu.
  - If the Key Commands Editor is already open, choose a command set from the Command Set pop-up menu in the upper-left corner of the window.

Edit keyboard shortcuts in MainStage

You can quickly and easily customize keyboard shortcuts in the Key Commands Editor. If you want to add a few custom commands to the default set, you can duplicate the default set and assign keyboard shortcuts to some of the unassigned commands. You can also create a new set that contains only your keyboard shortcuts.

Duplicate a command set

1. Choose MainStage > Key Commands > Customize (or press Option-K).
2. If the command set that you want to duplicate is not shown, choose a different command set from the Command Set pop-up menu in the upper-left corner of the Key Commands Editor.
3. Choose Duplicate from the pop-up menu.
4. In the dialog that appears, type a name for the command set, then click OK.

Edit a command set

You can add keyboard shortcuts to a command set or reassign keyboard shortcuts.

1. Choose MainStage > Key Commands > Customize (or press Option-K).
2. If the command set that you want to modify is not shown, choose a different command set from the Command Set pop-up menu at the top of the Key Commands Editor.
3. Select the command to which you want to assign a new key command by doing one of the following:
   • Type a command name in the search field in the upper-right corner of the Key Commands Editor window.
   • Browse the command list to find the command you want.
4. Press the combination of keys you want to use for the command.
   Note: Keys on the Key Commands Editor virtual keyboard that are shaded with diagonal lines are reserved for system use and cannot be assigned.
   If the key combination is not already assigned to a command, the virtual keyboard updates to show the new key command. A gray dot appears on a newly assigned key (or keys), and a color is applied if the command belongs to a color-coded Command group.
   If the key combination is already assigned to a command, MainStage displays the current setting, and prompts you to confirm the change.
5. To save your changes to the command set, click the Save button in the lower-right corner of the Key Commands Editor.
   If you close the Key Commands Editor with unsaved changes, a dialog appears, prompting you to save your changes.

Delete a command set
1. Choose MainStage > Key Commands > Customize (or press Option-K).
2. If the command set that you want to delete is not shown, choose a different command set from the Command Set pop-up menu at the top of the Key Commands Editor.
3. Choose Delete from the Command Set pop-up menu in the upper-left corner of the Key Commands Editor.
4. In the dialog that appears, click Delete.
   The command set is removed.

Import and export command sets in MainStage
After you save a command set, you may want to export it to create a backup or to share the new set with another user.

Export a command set
1. Choose MainStage > Key Commands > Customize (or press Option-K).
2. If the command set that you want to export is not shown, choose a different command set from the Command Set pop-up menu at the top of the Key Commands Editor.
3. Do one of the following:
   • Choose MainStage > Commands > Export.
   • Choose Export from the pop-up menu in the upper-left corner of the Key Commands Editor.
4. Type a name for the exported command set in the Save As field, browse to the location where you want to save the exported set, then click Save As.
Import a command set

1. Do one of the following:
   - Choose MainStage > Commands > Import.
   - Choose Import from the Command Set pop-up menu in the upper-left corner of the Key Commands Editor.

2. In the window that appears, navigate to the location where you've stored a command set file, select it, and click Open.

   If you're already using a command set with the same name, a window appears and prompts you to rename the command set.

   The new command set is added to the list of command sets.
MainStage actions

Overview of actions in MainStage

In addition to mapping screen controls to channel strip and plug-in parameters, you can map them to MainStage actions. Actions let you select patches and sets, silence MIDI notes, control the Tuner and the metronome, tap a new tempo, display information about patches, MIDI messages and other information, and perform other functions using screen controls.

The Actions folder, which appears in the Parameter Mapping browser along with available parameters, contains actions for a variety of MainStage functions. The Actions folder also contains an AppleScript subfolder with useful scripts. The following table describes each action and the type of screen control to map it to.

To learn more about mapping screen controls to actions, see Map screen controls to actions.

A table of MainStage actions

For each action in the Actions folder, the Description column describes the function of the action, and the Usage column tells which screen controls it is intended to be used with.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>−10 Patches</td>
<td>Selects the patch 10 patches above the current patch in the Patch List.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Prev Patch</td>
<td>Selects the patch above the current patch in the Patch List.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Current Patch</td>
<td>Displays the name of the current patch and can also be used to change patches.</td>
<td>Parameter Text screen control (to display); Knob screen control (to select)</td>
</tr>
<tr>
<td>Jump to Patch</td>
<td>Switches to a different patch.</td>
<td>Parameter Text screen control (to display); Knob screen control (to select)</td>
</tr>
<tr>
<td>Current Patch Number</td>
<td>Displays the patch number of the selected patch and can also be used to change patches.</td>
<td>Parameter Text screen control (to display); Knob screen control (to select)</td>
</tr>
<tr>
<td>Action</td>
<td>Description</td>
<td>Usage</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>Current Program Number</td>
<td>Displays the program change number of the selected patch and can be used to change to a specific program.</td>
<td>Parameter Text screen control (to display); Button screen control (to change)</td>
</tr>
<tr>
<td>Next Patch</td>
<td>Selects the patch below the current patch in the Patch List.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>+10 Patches</td>
<td>Selects the patch 10 patches below the current patch in the Patch List.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Prev Set</td>
<td>Selects the set above the current patch in the Patch List.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Current Set</td>
<td>Displays the name of the current set.</td>
<td>Parameter Text screen control</td>
</tr>
<tr>
<td>Next Set</td>
<td>Selects the set below the current patch in the Patch List.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Concert</td>
<td>Displays the name of the concert.</td>
<td>Parameter Text screen control</td>
</tr>
<tr>
<td>Tuner</td>
<td>Shows or hides the Tuner.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Master Tuning</td>
<td>Adjusts the overall tuning for the concert, from −100 cents to +100 cents.</td>
<td>Knob or fader screen control</td>
</tr>
<tr>
<td>Master Mute</td>
<td>Mutes or unmutes all audio (toggle).</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Tap Tempo</td>
<td>Use to tap a new tempo.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Metronome</td>
<td>Turns the metronome on or off and starts the “transport” (toggle).</td>
<td>Button screen control</td>
</tr>
<tr>
<td>MIDI Beat Clock</td>
<td>Displays incoming MIDI beat clock messages.</td>
<td>Parameter Text screen control</td>
</tr>
<tr>
<td>Beat Count</td>
<td>Displays the current bar and beat count from the “transport” if it is running.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>MIDI Display</td>
<td>Displays incoming MIDI messages, the same as the MIDI Activity display in the toolbar.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Panic</td>
<td>Silences all MIDI notes and resets the audio engine.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>CPU Load</td>
<td>Displays the current CPU usage, the same as the CPU Activity display in the toolbar.</td>
<td>Parameter Text screen control</td>
</tr>
<tr>
<td>Record</td>
<td>Turns audio recording on or off (toggle).</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Play/Stop</td>
<td>Starts or stops playback at the current transport position.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Play</td>
<td>Starts playback at the beginning of the song or file (bar 1, beat 1).</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Stop</td>
<td>Pauses playback at the current transport position.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Action</td>
<td>Description</td>
<td>Usage</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------------------------------------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>Continue</td>
<td>Resumes playback at the current transport position.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Reset/Compare Patch</td>
<td>Toggles the selected patch between its edited and last saved state (toggle).</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Current Time</td>
<td>Displays the current time in hours, minutes, and seconds.</td>
<td>Parameter Text screen control</td>
</tr>
<tr>
<td>Smart Controls Tab Index</td>
<td>For tabbed Smart Controls, lets you set which tab is visible.</td>
<td>Knob or fader screen control</td>
</tr>
</tbody>
</table>

In addition to the actions in the Actions folder, there are two actions in the Send to All > Destinations > Actions folder.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transpose Octave Up</td>
<td>Transposes the software instrument played by the keyboard up one octave.</td>
<td>Button screen control</td>
</tr>
<tr>
<td>Transpose Octave Down</td>
<td>Transposes the software instrument played by the keyboard down one octave.</td>
<td>Button screen control</td>
</tr>
</tbody>
</table>