<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit your project</strong></td>
<td>108</td>
</tr>
<tr>
<td>Intro to editing</td>
<td>108</td>
</tr>
<tr>
<td>Create and manage projects</td>
<td>109</td>
</tr>
<tr>
<td>Select clips and ranges</td>
<td>117</td>
</tr>
<tr>
<td>Add and remove clips</td>
<td>125</td>
</tr>
<tr>
<td>Make three-point edits</td>
<td>146</td>
</tr>
<tr>
<td>Arrange clips in the timeline</td>
<td>153</td>
</tr>
<tr>
<td>Cut and trim clips</td>
<td>159</td>
</tr>
<tr>
<td>View and navigate</td>
<td>179</td>
</tr>
<tr>
<td>Work with markers</td>
<td>195</td>
</tr>
<tr>
<td>Correct shaky video</td>
<td>201</td>
</tr>
<tr>
<td><strong>Edit audio</strong></td>
<td>205</td>
</tr>
<tr>
<td>Intro to audio</td>
<td>205</td>
</tr>
<tr>
<td>Audio editing basics</td>
<td>207</td>
</tr>
<tr>
<td>Add audio</td>
<td>216</td>
</tr>
<tr>
<td>Edit audio clips or audio components</td>
<td>223</td>
</tr>
<tr>
<td>Add and adjust audio effects</td>
<td>248</td>
</tr>
<tr>
<td>Audio tools and techniques</td>
<td>264</td>
</tr>
<tr>
<td><strong>Add titles</strong></td>
<td>275</td>
</tr>
<tr>
<td>Add and adjust titles</td>
<td>275</td>
</tr>
<tr>
<td>Add and adjust 3D titles</td>
<td>294</td>
</tr>
<tr>
<td><strong>Add effects</strong></td>
<td>347</td>
</tr>
<tr>
<td>Intro to effects</td>
<td>347</td>
</tr>
<tr>
<td>Add and adjust transitions</td>
<td>348</td>
</tr>
<tr>
<td>Adjust built-in effects</td>
<td>361</td>
</tr>
<tr>
<td>Add and adjust clip effects</td>
<td>378</td>
</tr>
<tr>
<td>Add generators</td>
<td>404</td>
</tr>
<tr>
<td>Use onscreen controls</td>
<td>414</td>
</tr>
<tr>
<td>Animate video effects</td>
<td>422</td>
</tr>
<tr>
<td><strong>Advanced editing</strong></td>
<td>434</td>
</tr>
<tr>
<td>Use roles to manage clips and organize the timeline</td>
<td>434</td>
</tr>
<tr>
<td>Add, adjust, and share captions</td>
<td>462</td>
</tr>
<tr>
<td>Group clips with compound clips</td>
<td>490</td>
</tr>
<tr>
<td>Edit with multicam clips</td>
<td>498</td>
</tr>
<tr>
<td>Add storylines</td>
<td>528</td>
</tr>
<tr>
<td>Use the precision editor</td>
<td>532</td>
</tr>
<tr>
<td>Feature</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Try out clips using auditions</td>
<td>536</td>
</tr>
<tr>
<td>Retime clips to create speed effects</td>
<td>543</td>
</tr>
<tr>
<td>Conform frame sizes and rates</td>
<td>558</td>
</tr>
<tr>
<td>Use XML to transfer projects</td>
<td>563</td>
</tr>
<tr>
<td>Edit 360-degree video</td>
<td>564</td>
</tr>
<tr>
<td>Change the focus in Cinematic mode video</td>
<td>586</td>
</tr>
<tr>
<td>Keying, masking, compositing, and tracking</td>
<td>594</td>
</tr>
<tr>
<td>Keying</td>
<td>594</td>
</tr>
<tr>
<td>Masking</td>
<td>614</td>
</tr>
<tr>
<td>Compositing</td>
<td>640</td>
</tr>
<tr>
<td>Tracking</td>
<td>644</td>
</tr>
<tr>
<td>Color correction</td>
<td>660</td>
</tr>
<tr>
<td>Intro to color correction</td>
<td>660</td>
</tr>
<tr>
<td>Quickly balance and match color</td>
<td>661</td>
</tr>
<tr>
<td>Make advanced color corrections with color correction effects</td>
<td>667</td>
</tr>
<tr>
<td>Add color masks and shape masks</td>
<td>701</td>
</tr>
<tr>
<td>Wide color gamut and HDR</td>
<td>714</td>
</tr>
<tr>
<td>Apply LUTs</td>
<td>736</td>
</tr>
<tr>
<td>Measure video levels</td>
<td>744</td>
</tr>
<tr>
<td>Color correction tools and techniques</td>
<td>754</td>
</tr>
<tr>
<td>Share your project</td>
<td>758</td>
</tr>
<tr>
<td>Intro to sharing projects</td>
<td>758</td>
</tr>
<tr>
<td>Share to Apple devices</td>
<td>759</td>
</tr>
<tr>
<td>Export files</td>
<td>763</td>
</tr>
<tr>
<td>Share on the web</td>
<td>780</td>
</tr>
<tr>
<td>Create optical discs and disk images</td>
<td>781</td>
</tr>
<tr>
<td>Share in email</td>
<td>787</td>
</tr>
<tr>
<td>Batch sharing</td>
<td>788</td>
</tr>
<tr>
<td>Share using Compressor</td>
<td>790</td>
</tr>
<tr>
<td>Create share destinations</td>
<td>793</td>
</tr>
<tr>
<td>Change metadata for shared items</td>
<td>799</td>
</tr>
<tr>
<td>View the status of shared items</td>
<td>802</td>
</tr>
<tr>
<td>Speed up exports with simultaneous processing</td>
<td>804</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Manage media, libraries, and archives</td>
<td>805</td>
</tr>
<tr>
<td>Intro to media management</td>
<td>805</td>
</tr>
<tr>
<td>Manage your media files</td>
<td>806</td>
</tr>
<tr>
<td>Manage libraries</td>
<td>824</td>
</tr>
<tr>
<td>Create camera archives</td>
<td>834</td>
</tr>
<tr>
<td>Common media management issues</td>
<td>837</td>
</tr>
<tr>
<td><strong>Work smarter</strong></td>
<td></td>
</tr>
<tr>
<td>Final Cut Pro settings</td>
<td>842</td>
</tr>
<tr>
<td>Keyboard shortcuts and gestures</td>
<td>857</td>
</tr>
<tr>
<td>Customize the Final Cut Pro interface</td>
<td>891</td>
</tr>
<tr>
<td>Work with metadata</td>
<td>898</td>
</tr>
<tr>
<td>Use color and gradient controls</td>
<td>905</td>
</tr>
<tr>
<td>Download sound effects and Pro Video Formats</td>
<td>915</td>
</tr>
<tr>
<td><strong>Glossary</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Copyright</strong></td>
<td></td>
</tr>
</tbody>
</table>
What’s new in Final Cut Pro for Mac

Final Cut Pro 10.7 introduces new features and enhancements, detailed below.

**Automatic timeline scrolling**
Stay focused on your edit by keeping your clips in view under the playhead during playback. See Scroll in the timeline.

**Video role colors**
View both video and audio role colors to easily see the organization of the timeline at a glance. See Show video role colors.

**Collapse to Connected Storyline**
Increase efficiency by combining a group of connected clips or storylines into a connected storyline. See Collapse connected clips or storylines into a single storyline.

**Accelerated H.264 and HEVC exports**
Speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing. See Speed up exports with simultaneous processing.

**Enhanced Object Tracker**
See improved results when using the Object Tracker’s all-new machine-learning model to analyze the movement of faces and other objects on Mac computers with Apple silicon. See Change the tracking analysis method.

**System requirements**
The minimum system requirement is macOS Ventura 13.5. For more information, go to the Final Cut Pro Tech Specs webpage.
Final Cut Pro basics

What is Final Cut Pro for Mac?

Final Cut Pro is a revolutionary app for creating, editing, and producing the highest-quality video.

Edit everything

- Import and edit everything from standard-definition to 8K video—including ProRes, ProRes RAW, and all major professional camera formats.
- Import and edit immersive 360° video with 360° titles, graphics, and effects, as well as VR headset playback.
- Play and skim high-definition media in up to 8K resolution (and beyond), in full screen or on a second display.
- Edit and color correct vibrant high-dynamic-range (HDR) video using your Pro Display XDR as a professional HDR reference monitor. Or apply Final Cut Pro tone mapping to see your HDR content on a Mac display. Use high-resolution video scopes to gauge HDR brightness levels as you edit.
Work faster, smarter
- Assemble clips in the Magnetic Timeline, which fluidly adjusts adjacent clips to eliminate gaps, collisions, and sync problems.
- Ripple, roll, slip, and slide your edits using state-of-the-art trimming tools, then fine-tune your cuts with the inline precision editor.
- Connect clips to lock cutaway shots, superimposed titles, and sound effects to your main storyline, or nest clips within other clips.
- Edit multicamera footage, automatically syncing up to 64 angles of video with different formats, frame sizes, and frame rates. View up to 16 angles at once, then use the angle editor to move, sync, trim, add effects, or color grade individual clips in the timeline.

Get organized
- Declutter your workflow by organizing your media clips: Rate them, add keywords, or bundle them into Smart Collections.
- Let Final Cut Pro detect people and shot types and then automatically assign keywords like “One Person” or “Wide Shot.”
- With a single click, arrange sound clips into separate audio lanes in the timeline for dialogue, voiceover tracks, music, and more.

Make every effect special
- Add stunning visual effects using any of more than 300 built-in special effects, transitions, and generators, then adjust them with precision keyframes and onscreen controls.
- Retime clips to create cinematic fast-motion, slow-motion, and variable-speed effects.
- Reduce or eliminate grain and video noise with easy-to-use noise-reduction tools.
- Create studio-quality 2D and 3D titles and set them in motion, without leaving Final Cut Pro.
- Track moving objects in clips to match their movement with an effect, graphic, or title.
- Import clips recorded in Cinematic mode on iPhone into Final Cut Pro, then use onscreen controls to adjust the focus.
- Add closed captions in a variety of formats, without the need for expensive third-party software or services.
- Create stunning effects and sweeping graphics in Motion—Apple’s professional imaging effects app—then open and adjust them in Final Cut Pro.
- Add pro audio effects with dozens of plug-ins for audio compression, EQ, and more—or send your soundscape to a professional audio application like Apple’s Logic Pro for advanced mixing.
- Let Final Cut Pro analyze your video and nondestructively fix common problems like excess hum or loudness. Correct shaky video using the Final Cut Pro stabilization feature.
Perfect your pixels with advanced color grading

- Automatically balance colors, match colors, and white-balance clips...
- ...Or go manual and use the professional color-grading tools built into Final Cut Pro, including a dedicated color inspector with color wheels, color curves, hue/saturation curves, and keyframes to adjust corrections over time.

Export and share everywhere

- Send your finished project to Compressor for streamlined delivery to the iTunes Store. And because Final Cut Pro, Motion, and Compressor all share the same Metal architecture, you’ll experience blazing performance and consistent rendering across applications.
- Optimize your project for viewing on Apple devices such as iPad, iPhone, and Apple TV.
- Export files in a variety of professional formats, including industry-standard MXF.
- Use batch sharing to export multiple projects, clips, or clip ranges at the same time.

Note: For a complete list of topics covered in this user guide, click Table of Contents at the top of the page.

What are libraries in Final Cut Pro for Mac?

In Final Cut Pro 10.1 or later, you organize your work in libraries. A library can contain multiple events and projects in the same location. The first time you open Final Cut Pro, it creates a library file in the Movies folder. When you create a new project or event, it’s automatically included in the active library. The library tracks all your media files, your editing decisions, and the associated metadata.

You can have multiple libraries open at the same time, and you can easily copy events and projects between libraries. This makes it simple and quick to move media, metadata, and creative work to another system for mobile work, work with multiple editors, or archiving. You can open and close libraries as needed.

The following concepts are important to understand when you work with libraries.
Managed and external media

Media that you import into a specific library is stored inside the library and is referred to as managed media. Media can also be imported or copied to any location on a connected storage device and linked to the library as external media. Multiple users can access this external media instantly on shared storage.

Managed media can be made external at any time if you want to share access, and external media can be collected as managed media inside the library for easy transport or archiving. See Consolidate projects and libraries.

Generated media

Render files, optimized files, proxy files, and analysis files are all considered generated media because the system creates them in the background after the original media has been imported. You can store generated media inside your Final Cut Pro library or in an external location you define. For example, to organize media in a large facility more efficiently, you can put generated media on a SAN or on a storage device outside the library. See Set storage locations.

To reduce a library’s size, and to move, copy, or archive a library more quickly, you can delete all the generated media (proxy, optimized, or render files) in one step. See Create optimized and proxy files and Manage render files.

Note: By default, copying a project between libraries does not copy the associated proxy, optimized, or render files because these files can be quickly regenerated. However, you can choose to include proxy or optimized media when you copy a project to another library.

Final Cut Pro for Mac workflow

The overall process for putting together a movie with Final Cut Pro is described below. You don’t have to do every step, and you might do others that aren’t listed. The workflow isn’t necessarily linear. You could, for example, go all the way through editing and adding effects, and then import more new media for your project.

Step 1: Import your media into Final Cut Pro

To use Final Cut Pro, you need to transfer your media (video, audio, and still images) from your recording device to your Mac or an external storage device. You can import media from many kinds of cameras and other devices, or from other apps such as Photos or iMovie.

Step 2: Organize your media

Final Cut Pro automatically organizes your imported media into events. An event is similar to a folder that can hold dozens, hundreds, or even thousands of video clips, audio clips, and still images, as well as projects. In Final Cut Pro, your media appears as clips, which link to the media files on your Mac or storage device. You can reorganize your clips by creating or renaming events and moving clips between events. For example, you could create an event for all the media shot for a specific client.
As you review your footage, you can easily rate clips as favorite or rejected. These ratings make it easier to focus on your best footage. Final Cut Pro also offers other useful organizing tools, such as Keyword Collections, Smart Collections, and roles.

**Step 3: Create a project and add clips to it**

Your project is the movie you create using clips from your events and from the collections of media (such as titles and sound effects) that come with Final Cut Pro. Start creating your movie by adding clips to the timeline. You make all your edits in the project; your original media files remain untouched (this is known as *nondestructive editing*).

**Step 4: Arrange and edit your clips**

Now your movie can really begin to take shape. To assemble a rough cut, rearrange and trim clips in the timeline. You can also try out different clips using auditions. Use connected clips and storylines to add cutaway shots, titles, background music, and sound effects to your project. Create compound clips to group any combination of clips and nest clips within other clips. For example, you can simplify a complicated project by creating a separate compound clip for each major section.

**Step 5: Add effects and transitions**

Add special effects from the ample collection of video and audio effects in Final Cut Pro. Give your movie titles and credits, and apply video or audio transitions. Adjust clip speed settings to create fast-motion or slow-motion effects.

To further polish your project, you can fine-tune cuts and transitions with the precision editor, keyframe video and audio effects, correct color, and composite motion graphics.

**Step 6: Share your movie**

When your project is finished, you can publish your movie to the web right from Final Cut Pro, or send it to iPhone, iPad, iPod, or Apple TV. You can also burn a disc to give to others. For advanced projects, you can export separate video or audio files (also known as *media stems*) for broadcast delivery, audio mixing, or post-production.
Final Cut Pro for Mac interface

Here are the main areas of the Final Cut Pro window:

- **Sidebar**: Organize libraries and access photos, audio, titles, and generators.
- **Browser**: Skim and select clips to use in your projects.
- **Viewer**: Play back clips and projects.

Organize media in the Libraries sidebar and the browser

Your imported media is available in events in your library. (An event is like a folder that contains clips and projects.)

When you select an event in a library, its clips and projects appear in the browser on the right.
You can reorganize your media however you like, and you can use the Libraries sidebar and the browser to manage, rate, sort, and add keywords to your imported media. See Intro to libraries.

**Play back clips and projects in the viewer**

The viewer is where you play back your video, including clips and projects with 6K resolution and above. You can play back events, projects, or individual clips in full-screen view or on a second display. With the event viewer, a separate video display that can be shown next to the main viewer, you can display two clips at the same time: one from the browser and one from the timeline. For information about ways to play media, see Play media.

You can also use onscreen controls, superimposed over the video in the viewer, to adjust settings for a wide array of effects and transitions.

**Edit your project in the Magnetic Timeline**

The bottom portion of the Final Cut Pro window contains the timeline, where you create your movie by adding and arranging clips and making all your edits. The timeline “magnetically” adjusts clips to fit around clips that you drag into place. If you drag clips out of place, the surrounding clips close up to fill the space.
A project holds all of the information for your final movie, including your editing decisions and links to all the source clips and events. See Intro to adding clips and Arrange clips in the timeline.

With a click, you can arrange clips into audio lanes (separate, visually distinct layers in the timeline), based on their role assignments. Roles identify the type of clip, so each audio lane contains one type of audio. For example, one audio lane might contain music clips, and another might contain sound effects. This view organizes clips visually and provides reference points that make editing easier and more efficient. See Intro to roles and Organize the timeline with audio lanes.
Media files and clips in Final Cut Pro for Mac

After you import media into events in your Final Cut Pro library, clips representing the source media files appear in the browser. A large event may hold many clips.

Media files are the raw materials you use to create your project. A media file is a video, audio, still-image, or graphics file on your Mac or storage device that contains footage transferred from a camcorder or recording device or created on a computer. Media files can contain multiple video and audio components. Because media files—especially video files—tend to be quite large, projects that use a lot of footage require one or more high-capacity storage devices.

Clips represent your media, but they are not the media files themselves. The clips in a project simply point to (link to) the source media files on your Mac or storage device. When you modify a clip, you’re not modifying the media file, just the clip’s information in the project. This is known as nondestructive editing, because the changes you make to clips in Final Cut Pro never affect the media itself. Trimmed or deleted pieces of clips are removed from your project only, not from the clips in your library or the source media files on your Mac or storage device.
Import and analyze media

Intro to importing media in Final Cut Pro for Mac

Importing media into Final Cut Pro is the first step toward making your movie.

With Final Cut Pro, you can:

- Import from file-based cameras
- Import from iPhone, iPad, or iPod touch
- Import from a tape-based camcorder or device
- Import from iMovie
- Import from Photos
- Import from Music
- Import from your Mac or storage device
- Import from a camera archive
During import, you assign your media to an event. You can also transcode your media and analyze your media for a variety of issues, such as color balance, the presence of people and shot type, and audio problems.

When you import clips (video, audio, or still images), Final Cut Pro assigns one of five default roles to the video and audio components of each clip: Video, Titles, Dialogue, Music, and Effects. You can also override this automatic role assignment. See View and reassign roles and Assign audio roles during import.

If you want to quickly back up your media (instead of taking the time to import it), you can create an archive.

If it’s your first import into Final Cut Pro for Mac

The first time you open Final Cut Pro, it contains no media and one library containing a single event. You can import media into the event from your Mac, a storage device, or a connected camera.

1. In the Final Cut Pro main window, click Import Media.
2. Follow the instructions for importing files from a file-based camera, from your Mac or storage device, or from iPhone or iPad.
   For more ways to import media, see Intro to importing media.

To start editing, create a new project.
Import from connected cameras

Import into Final Cut Pro for Mac from file-based cameras

File-based camcorders and cameras can record video, audio, and still images. These kinds of devices, which record to flash-based storage media, hard drives, and so on, usually connect to your Mac through a Thunderbolt or USB cable. Some devices have removable memory cards that you can insert into your computer instead.

If your file-based device provides a clip-spanning feature (which allows a single clip to be recorded across multiple memory cards), you can import all of the media as one spanned clip.

To check whether your camera is compatible with Final Cut Pro, see the Apple Support article Cameras supported by Final Cut Pro.

Import from a file-based camcorder, camera, or device

1. Do one of the following:
   • Connect your camcorder, camera, or device to your Mac using the cable that came with the device, and turn on the device.
     If you’re using a camcorder, set it to PC Connect mode. (The name of this transfer mode may be different on your device.) Your camcorder may automatically go into “connect” mode if you turn it on in playback mode while it’s connected to your Mac. See the documentation that came with your camcorder.
     Note: Connecting a DVD camcorder to your Mac can cause the DVD Player app to open. If that happens, simply close DVD Player.
   • Remove the memory card from your camcorder or device and insert it into the card slot on your Mac (if it has one) or into an external card reader.
     See Memory cards and cables.
     Note: Some cameras require that you download and install an additional software plug-in. See the documentation that came with your camera.

2. In Final Cut Pro, do one of the following:
   • Choose File > Import > Media (or press Command-I).
   • Click the Import Media button on the left side of the toolbar.
3. If necessary, select your camcorder, camera, or device from the Cameras section on the left.

The Media Import window displays the media on your device. You can **play back your media** using the playback controls or **skim it** by moving the pointer forward or backward over a filmstrip.

![Media Import window](image)

**Note:** By default, the Media Import window is set to show only video clips. If you want to display just photos, or video clips and photos, use the pop-up menu in the middle-right area of the window.

4. Do any of the following:

   - **Change which device to import from:** Click the device in the Cameras section.
   - **Change the way the clips appear:** Click the Clip Appearance button in the bottom-right corner of the Media Import window.
   - **Switch between filmstrip view and list view:** Click the List View and Filmstrip View buttons at the bottom of the Media Import window (connected file-based cameras and camera archives only).

     **Note:** When you select a clip in list view, a filmstrip for the selected clip appears at the top of the browser. You can skim to any frame in the filmstrip and set start and end points.

   - **Sort clips in list view by data such as duration, creation date, rating, keyword, and file type:** Click the column headings at the top of list view. Control-click column headings to add additional columns. For more information about list view, see Import from your Mac or storage device.
   - **Add folders of frequently used media to the Favorites section:** Drag them from list view.

     To remove a folder from the Favorites section, Control-click the folder and choose Remove from Sidebar.
• **Automatically close the Media Import window when the import begins:** Select the “Close window after starting import” checkbox.

• **Add a folder to list view by dragging:** Drag the folder from the Finder to list view and browse its contents in list view.

5. Use the settings on the right side of the Media Import window to choose how you want to organize the imported media in your library:

• **Add the imported clips to an existing event:** Select “Add to existing event,” then choose the event from the pop-up menu.

• **Create a new event:** Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name (for example, “Chris and Kim Wedding”) in the text field.

To learn more about events, see Intro to libraries. If you want to import media into a new library, you must create the new library before importing your media.

*Note:* You can set storage locations for each of your libraries. See Set storage locations.

6. If you want to override automatic role assignment, create optimized or proxy media, analyze the video, or analyze the audio, select the relevant settings in the Audio Roles, Transcoding, and Analyze sections.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later in the browser.

*Note:* Some import options are available only when you import files from a storage device. See Organize files during import and Import from your Mac or storage device.

7. Do one of the following:

• **Import all clips:** Click Import All.

• **Import only some of the clips:** Select each clip you want to import by Command-clicking it, then click Import Selected (the Import button changes its name).

  **Tip:** To select several clips located together, drag a selection rectangle around the clips.

• **Import portions of clips:** Drag inside the filmstrip to select the range that you want, then click Import Selected. You can also select multiple ranges in each clip. See Select ranges.

  **Tip:** You can also select a clip, press the Space bar to play the clip, and then press either I (to set a start point) or O (to set an end point).

By default, the Media Import window closes when you click Import. You can begin working with your clips in the browser. The media is imported in the background.

If you selected any options in the previous step, the files are transcoded and optimized after the import is complete. You can view the progress of the import and other background tasks in the Background Tasks window.

8. When background tasks are completed, disconnect the camcorder, camera, or device.

You can create an archive from your file-based or tape-based camera or device. See Create camera archives.
Reimport a clip

Two situations warrant reimporting a clip:

- *If the clip was not completely imported:* If you cancel or quit Final Cut Pro before an import is finished, a camera icon appears on the bottom-left corner of the clip, indicating that the media on the camera is being used for playback (instead of the QuickTime file that was created during import).

  ![Camera icon](image)

  To play a clip with a camera icon, Final Cut Pro locates the media either on a connected camera or in a connected, available camera archive. (See Import from an archive or disk image.) If the media can’t be found in one of those locations, the clip becomes offline and displays the Missing Camera alert icon.

- *If the clip’s source media file is not available:* If a clip’s source media file is moved or deleted, or the volume it’s located on is disconnected from your Mac, a Missing File alert icon appears on the clip. To restore the clip, you can reimport it.

  See Alert icons.

When you reimport a clip, Final Cut Pro automatically connects to the camera or camera archive. You don’t need to manually mount a camera archive before reimporting.

1. Do one of the following:
   - Connect the camera that contains the clip to your Mac, and turn on the camera.
     The clip is now online but still displays the camera icon in the lower-left corner.
   - Insert the memory card that contains the clip into your Mac or a connected card reader.
     See Memory cards and cables.
   - Make sure the camera archive that contains the clip is located in one of the Final Cut Pro camera archives.
     See Create camera archives.

2. In Final Cut Pro, do one of the following:
   - *Reimport one clip:* Select the clip in the browser.
   - *Reimport all clips in an event:* Select the event in the Libraries sidebar.

3. Choose File > Import > Reimport from Camera/Archive.
Import spanned clips into Final Cut Pro for Mac

Some file-based camcorders or devices that have more than one memory card slot can record one shot over multiple memory cards. The resulting shot is called a spanned clip.

A good way to import a spanned clip is to connect your camera or card reader to your Mac and create a camera archive for each memory card. You can store the camera archives on your Mac or on an external storage device until you’re ready to import the spanned clip. (Even if you’re importing the spanned clip immediately, it’s useful to make a camera archive so that you have a backup of the spanned clip’s footage.) When you’re ready to import, you can mount all of the camera archives and import the spanned clip.

Create a camera archive for each memory card

1. Connect your camcorder or camera to your Mac and turn on the device, or connect your card reader and memory card to your Mac. If you’ll be saving the camera archives to an external storage device, connect that as well.

   Note: Some cameras require that you download and install an additional software plug-in. See the documentation that came with your camera.

2. In Final Cut Pro, do one of the following:
   • Choose File > Import > Media (or press Command-I).
   • Click the Import Media button on the left side of the toolbar.

3. In the Media Import window, select a memory card to archive from the list of cameras on the left.

4. Click the Create Archive button at the bottom-left corner of the window.

5. In the “Create Camera Archive as” field, type a name for the archive.

6. Click the Destination pop-up menu, choose a location to save the archive, then click OK.

   Note: To protect your media, it’s recommended that you save your archive to a storage device or partition different from the one where you store the media files used with Final Cut Pro.

7. To create camera archives for each of the memory cards that contain a portion of the spanned clip, repeat steps 3 through 6.
Import a spanned clip

1. If the media you want to import is on an external storage device or a memory card, connect the device to your Mac and turn on the device.

2. In Final Cut Pro, do one of the following:
   - Choose File > Import > Media (or press Command-I).
   - Click the Import Media button on the left side of the toolbar.

3. In the Devices section on the left side of the Media Import window, select the storage device (internal or external) or memory card that contains the spanned clip camera archives.

4. Use list view at the bottom of the window to navigate to and open the camera archives.

   **Important:** If the camera archives that make up the spanned clip are not all available, you can import each camera archive separately. Each portion of the spanned clip is imported as a separate clip.

   If all portions of the spanned clip are available, all the mounted camera archives show a clip with the same duration. An icon indicating that the spanned clip is complete appears on the spanned clip.

   If one or more camera archives are missing, an icon appears on the spanned clip to indicate which part of the spanned clip is available—the beginning, middle, or end. You can select each camera archive to see the different icons.

   - Indicates that all portions of the spanned clip are available.
   - Indicates that the beginning portion of the spanned clip is available.
   - Indicates that the middle portion of the spanned clip is available.
   - Indicates that the end portion of the spanned clip is available.
5. Use the settings on the right side of the Media Import window to choose how you want to organize the imported media in your library:

- **Add the imported media to an existing event**: Select “Add to existing event,” then choose the event from the pop-up menu.

- **Create a new event**: Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name (for example, “Chris and Kim Wedding”) in the text field.

To learn more about events, see Intro to libraries. If you want to import media into a new library, you must create the new library before importing your media.

**Note**: You can set storage locations for each of your libraries. See Set storage locations.

6. If you want to override automatic role assignment, create optimized or proxy media, analyze the video, or analyze the audio, select the relevant settings in the Audio Roles, Transcoding, and Analyze sections.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later in the browser.

**Note**: Some import options are available only when you import files from a storage device. See Organize files during import and Import from your Mac or storage device.

7. To import the spanned clip, click Import All.

   By default, the Media Import window closes when you click Import. You can begin working with your clips in the browser. The media is imported in the background.

   If you selected any options in the previous step, the files are transcoded and optimized after the import is complete. You can view the progress of the import and other background tasks in the Background Tasks window.

### Import into Final Cut Pro for Mac from iPhone, iPad, or iPod touch

Importing media from iPhone, iPad, or iPod touch is the same as importing media from a file-based camcorder, camera, or device.

**Note**: If you’re importing from an iOS or iPadOS device with iOS 11 or later and your footage was recorded with the High Efficiency camera setting, make sure you’re using macOS High Sierra 10.13 or later. See the Apple Support article Using HEIF or HEVC media on Apple devices.
1. Connect your iPhone, iPad, or iPod touch to your Mac using the cable that came with the device.
   
   If another app opens when you connect your device, close the app.

2. Turn on your device and unlock it.

3. In Final Cut Pro, do one of the following:
   
   • Choose File > Import > Media (or press Command-I).
   
   • Click the Import Media button on the left side of the toolbar.

4. In the Media Import window, select your iPhone, iPad, or iPod touch from the Cameras section on the left.

   You can **play back your media** using the playback controls or **skim it** by moving the pointer forward or backward over a filmstrip.

   You can also do any of the following:

   • **Change which device to import from**: Click the device in the Cameras section.
   
   • **Change the way the clips appear**: Click the Clip Appearance button in the bottom-right corner of the Media Import window.
   
   • **Switch between filmstrip view and list view**: Click the List View and Filmstrip View buttons at the bottom of the Media Import window (connected file-based cameras and camera archives only).
   
   **Note:** When you select a clip in list view, a filmstrip for the selected clip appears at the top of the Media Import window. You can skim to any frame in the filmstrip and set start and end points.

   • **Sort clips in list view by data such as duration, creation date, rating, keyword, and file type**: Click the column headings at the top of list view. Control-click column headings to add additional columns. For more information about list view, see Import from your Mac or storage device.
   
   • **Add folders of frequently used media to the Favorites section**: Drag them from list view.

   To remove a folder from the Favorites section, Control-click the folder and choose Remove from Sidebar.

   • **Automatically close the Media Import window when the import begins**: Select the “Close window after starting import” checkbox.

   • **Add a folder to list view by dragging**: Drag the folder from the Finder to list view and browse its contents in list view.
Note: By default, the Media Import window is set to show video clips only. If you want to display just photos, or video clips and photos, use the pop-up menu in the middle-right area of the window.

5. Use the settings on the right side of the Media Import window to choose how you want to organize the imported media in your library:

- **Add the imported clips to an existing event:** Select “Add to existing event,” then choose the event from the pop-up menu.

- **Create a new event:** Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name (for example, “Chris and Kim Wedding”) in the text field.

To learn more about events, see Intro to libraries. If you want to import media into a new library, you must create the new library before importing your media.

Note: You can set storage locations for each of your libraries. See Set storage locations.

6. If you want to override automatic role assignment, create optimized or proxy media, analyze the video, or analyze the audio, select the relevant settings in the Audio Roles, Transcoding, and Analyze sections.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later in the browser.

Note: Some import options are available only when you import files from a storage device. See Organize files during import and Import from your Mac or storage device.
7. Do one of the following:

• *Import all clips:* Click Import All.

• *Import only some of the clips:* Select each clip you want to import by Command-clicking it, then click Import Selected (the Import button changes its name).

   🔄 Tip: To select several clips located together, drag a selection rectangle around the clips.

• *Import portions of clips:* Drag inside the filmstrip to select the range that you want, then click Import Selected. You can also select multiple ranges in each clip. See Select ranges.

   🔄 Tip: You can also select a clip, press the Space bar to play the clip, and then press either I (to set a start point) or O (to set an end point).

By default, the Media Import window closes when you click Import. You can begin working with your clips in the browser. Your media is imported in the background.

If you selected any options in the previous step, the files are transcoded and optimized after the import is complete. You can view the progress of the import and other background tasks in the Background Tasks window.

8. When background tasks are completed, disconnect the iPhone, iPad, or iPod touch.

Import into Final Cut Pro for Mac from digital still cameras

You can import video and still images from digital still cameras. The steps below describe how to import video and still images directly into Final Cut Pro. You can also import your photos into a photos app and access them through the Photos, Videos, and Audio sidebar in Final Cut Pro.

To check whether your camera is compatible with Final Cut Pro, see the Apple Support article Cameras supported by Final Cut Pro.

1. Connect your camera to your Mac using the cable that came with the camera, and turn on the camera.

   If your camera doesn’t appear on the left side of the Media Import window (in either the Cameras section or the Devices section), remove the camera’s memory card and insert it into the card slot on your Mac (if it has one) or into an external card reader.

2. In the Finder, locate the DCIM folder inside the camera folder, then locate the still-image or video files.

   The files may be in the DCIM folder, or in a folder one or two levels down. Devices and file structures vary by model and manufacturer.

3. In Final Cut Pro, do one of the following:

   • Choose File > Import > Media (or press Command-I), then follow the instructions in Import from your Mac or storage device.

   • Drag the files from the Finder into an event or timeline in Final Cut Pro. The files are imported using the settings you selected in Import settings. See Import from your Mac or storage device.

After the import, you may have separate audio files that you want to use to replace the video’s audio track. To do this, you can automatically sync the video and audio clips.
Import into Final Cut Pro for Mac from tape-based cameras

You can import media from a tape-based camcorder or device. To determine which clips you want to import (rather than importing all of them), you can view them using Final Cut Pro before you import them.

Final Cut Pro supports tape-based import of the DV (including DVCAM, DVCPRO, and DVCPRO50), DVCPRO HD, and HDV formats.

To check whether your camera is compatible with Final Cut Pro, see the Apple Support article Cameras supported by Final Cut Pro.

1. Connect the camcorder to your Mac using the cable that came with the camcorder, and configure your device for remote control over FireWire, if necessary.

   If your computer does not have a FireWire port but does have a Thunderbolt port, you can connect the FireWire cable using an Apple Thunderbolt to FireWire Adapter or an Apple ThunderBolt Display (which also has a FireWire port).

   Note: For best results when importing from a tape-based camcorder, it’s recommended that you import the video using the same camcorder that you used to record it.

2. Turn on the camcorder and set it to VTR or VCR mode.

   This mode may have a different name on your camera. See the documentation that came with your camcorder.

3. In Final Cut Pro, do one of the following:
   - Choose File > Import > Media (or press Command-I).
   - Click the Import Media button on the left side of the toolbar.

4. If you have multiple devices connected to your computer, choose the device you want to import from in the list of cameras on the left side of the Media Import window.

   The Media Import window displays the image from the current position of the tape.
5. Use the settings on the right side of the Media Import window to choose how you want to organize the imported media in your library:

- **Add the imported clips to an existing event:** Select “Add to existing event,” then choose the event from the pop-up menu.

- **Create a new event:** Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name (for example, “Chris and Kim Wedding”) in the text field.

To learn more about events, see Intro to libraries. If you want to import media into a new library, you must create the new library before importing your media.

*Note:* You can set storage locations for each of your libraries. See Set storage locations.

6. If you want to override automatic role assignment, create optimized or proxy media, analyze the video, or analyze the audio, select the relevant settings in the Audio Roles, Transcoding, and Analyze sections.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later in the browser.

*Note:* Some import options are available only when you import files from a storage device. See Organize files during import and Import from your Mac or storage device.

7. Use the playback controls (or use the J, K, and L keys) to set your tape to the point where you want to begin importing, then click Import.

Importing begins immediately from the current location on the tape and continues until one of the following occurs:

- The end of the tape is reached.
- The storage device you’re importing to is full.
- You stop the import session by clicking Stop Import or Close (to close the Media Import window) or by pressing Escape.

The video plays as it’s being imported. It takes as long to import the video as it takes to watch it at normal speed.

8. When the section of video you want to import has been imported, click Stop Import (or press Escape).

If you selected any options in step 6, the files are transcoded and optimized after the import is complete. You can view the progress of the background tasks in the Background Tasks window.

9. If you want to import another section of video, use the import controls to go to the point on the tape where you want to begin importing, then repeat steps 5 through 8.

10. When you’re done importing, click Close to close the Media Import window.

You can also create an archive from your tape-based device, recording everything on the tape from beginning to end and saving the captured clips as an archive. See Create camera archives.
If your camera isn’t recognized in Final Cut Pro for Mac

If you’ve connected your camera or device to your computer but the Media Import window doesn’t open, or your device can’t be controlled from within Final Cut Pro, there are several things you can do to try to establish the connection.

Check your equipment and system

1. Before importing media into Final Cut Pro, make sure that you’re using the correct equipment configuration:
   - Your camcorder or camera must be compatible with Final Cut Pro. For a list of compatible devices, see the Apple Support article Cameras supported by Final Cut Pro.
   - Your device must be properly connected to your computer.
   - Your camcorder must be set to the correct output mode. On some camcorders, this is called VTR or VCR mode, but not all camcorders use the same terminology, so check the documentation that came with your device. On some camcorders you must set the output to DV mode or HDV mode, depending on whether the content is standard (DV) or high definition (HDV).
   - If you’re connecting a tape-based camcorder to your computer, you should be using a FireWire cable (also called IEEE 1394, or i.LINK), not a USB cable. See Memory cards and cables.
   - If you’re importing video clips from a still camera or other flash memory device, make sure the file format of your video is compatible with Final Cut Pro. See Supported media formats.
   - If your still camera is not supported by Final Cut Pro, try importing the media as files, using a card slot on your Mac or an external card reader. See Import from your Mac or storage device.
   - If you’ve enabled Fast User Switching, make sure no one else is trying to use the camcorder from a different account at the same time.

2. If you still can’t import media after checking the items above, try the following:
   - Turn the device off and on again.
   - Disconnect the cable from both the device and your Mac, then reconnect it.
   - Quit and then reopen Final Cut Pro.
   - Restart your Mac.
   - Try using a different cable.
   - Try using a different computer with Final Cut Pro installed.
   - If you’re using a file-based camcorder, use the Finder to copy the mounted volume to a local disk. Then open the files in Final Cut Pro in the same way that you open an archive.

Note: When you see red frames and a yellow alert triangle in the timeline or in an event, it means that part of your project or event is missing. See Alert icons.
Import from devices

Import into Final Cut Pro for Mac from your Mac or storage device

You can import media—video, audio, still images, and graphics files—from your Mac, a connected external storage device, a memory card inserted in the card slot on your Mac or a card reader, or a network-attached volume. You can import media using the Media Import window or by dragging files from the Finder.

When you drag media from the Finder into Final Cut Pro, the media is imported using the import settings in Final Cut Pro settings. Importing files by dragging them into Final Cut Pro is a good option if you always want to use the same file storage, transcoding, keyword, and analysis settings. See Import settings.

Note: Some file-based devices allow you to copy the recorded media (with its original directory structure) to a folder on your Mac using the Finder. To import media copied in this way, see Import from an archive or disk image.

Import media from your Mac or a storage device using the Media Import window

1. If the media you want to import is on an external storage device or a memory card, connect the device to your Mac and turn on the device.

2. In Final Cut Pro, do one of the following:
   • Choose File > Import > Media (or press Command-I).
   • Click the Import Media button on the left side of the toolbar.

3. In the Devices section on the left side of the Media Import window, select your Mac or the connected external storage device or memory card from which you want to import media.

4. Use list view at the bottom of the window to navigate to a file or folder and select it.
   When you import from your Mac or a storage device, filmstrips are visible for individual selected clips only.

Tip: Command-click to select multiple files or folders to import.
5. Do any of the following:

- **Preview the selected clip**: Play it using the playback controls or skim it by moving the pointer forward or backward over the filmstrip.
- **Change which device to import from**: Select the Mac or storage device in the Devices section, or select the location in the Favorites section.
- **Sort clips in list view by data such as duration, creation date, rating, and keyword**: Click the column headings at the top of list view. Control-click column headings to add additional columns.
- **Add folders of frequently used media to the Favorites section**: Drag a folder from the list on the right to the Favorites section on the left. To remove a folder from the Favorites section, Control-click the folder and choose Remove from Sidebar.
- **Automatically close the Media Import window when the import begins**: Select the “Close window after starting import” checkbox.
- **Add a folder to list view by dragging**: Drag the folder from the Finder to list view and browse its contents in list view.

6. Use the settings on the right side of the Media Import window to choose how you want to organize the imported media in your library:

- **Add the imported clips to an existing event**: Select “Add to existing event,” then choose the event from the pop-up menu.
- **Create a new event**: Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name for the event (for example, “Chris and Kim Wedding”) in the text field.

To learn more about events, see Intro to libraries.
7. Choose a storage location for the media files:

   • **Copy the files to the current library:** Select “Copy to library” to duplicate the files and place the copies in the current library storage location. For information about setting the storage location for a library, see Set storage locations.

     *Note:* The name of this option changes to “Copy to library storage location: location name” when the current library is set to an external storage location.

   • **Link to the files at their current location:** Select “Leave files in place.”

     *Note:* If you select this option, Final Cut Pro creates symbolic links (also known as symlinks), which are special files that point to the media files. If you later copy or move clips between events, only the symbolic links are copied or moved (not the source media files). To replace the symbolic links with the actual source media files, select the events and choose File > Consolidate Event Files. For more information about files and clips, see Media files and clips.

8. If you want to organize your media, override automatic role assignment, create optimized or proxy media, analyze the video, or analyze the audio, select the relevant checkboxes in the Keywords, Audio Roles, Transcoding, and Analyze sections.

   If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later in the browser.

9. When you’re ready to import, click Import Selected or Import All.

   The Import button changes its name based on your clip selection. By default, the Media Import window closes when you click Import. You can begin working with your clips in the browser. Your media is imported in the background.

   If you selected any options in the previous step, the files are transcoded and optimized when the import is complete. You can view the progress of the import and other background tasks in the Background Tasks window.

   If you imported media from an external device and you chose to have Final Cut Pro copy the media files to the library file (rather than just link to them in their original location), you can disconnect the device when the background tasks are completed.

**Import media by dragging from the Finder**

1. Open Final Cut Pro.

2. Do one of the following:

   • Select a file, Command-click to select multiple files, or select a folder of files, then drag the file or files from the Finder to the event.

   • Select a file, Command-click to select multiple files, or select a folder of files, then drag the file or files from the Finder to a Keyword Collection.

     The clip or clips appear in the event, and the keyword is automatically added to the clip or clips.

     *Important:* If you selected “From Finder tags” and “From folders” in the Keywords section of Final Cut Pro Import settings, a Keyword Collection is created for each folder name and each tag, and the corresponding files are assigned that keyword.

   • Select a file or Command-click to select multiple files, then drag the file or files to a project in the timeline.

     The clip or clips appear in the timeline and in the corresponding event.

   The file or files are imported using your default import settings. See Import settings.
Import into Final Cut Pro for Mac from an archive or disk image

If you’ve created a camera archive, you can use the media in the archive in two ways:

- You can connect to the camera archive, making the media available to Final Cut Pro.
- You can import the media from the archive, or import media from disk images previously archived with the Final Cut Pro Log and Transfer window in Final Cut Pro 7 or earlier. When you do this, copies of the media are created on your storage device.

Some file-based devices allow you to copy the recorded media (with its original directory structure) to a folder on your Mac using the Finder. To import media copied in this way (or to import from disk images previously archived with the Final Cut Pro Log and Transfer window in Final Cut Pro 7 or earlier), follow the instructions in Import media from a disk image, below.

Import media from a camera archive

1. In Final Cut Pro, do one of the following:
   - Choose File > Import > Media (or press Command-I).
   - Click the Import Media button on the left side of the toolbar.

2. In the Devices section on the left side of the Media Import window, select the storage device (internal or external) or memory card from which you want to import media, then use the list at the bottom of the window to navigate to the camera archive.

   The archive is connected to Final Cut Pro, and its media is displayed in the Media Import window.

3. Click the disclosure triangle to the left of the camera archive icon to reveal the list of clips in the archive, or double-click the camera archive to open it.

4. To import the media, see Import from file-based cameras.

Import media from a disk image

1. In the Finder, double-click the disk image (.dmg) file to open it.

2. In Final Cut Pro, do one of the following:
   - Choose File > Import > Media (or press Command-I).
   - Click the Import Media button on the left side of the toolbar.
3. Select the disk image in the Cameras section on the left side of the Media Import window.

   *Note:* If the disk image doesn’t have a file structure typical of a video camera, it appears in the Devices section instead.

   The open disk image is connected to Final Cut Pro, and its media is displayed in the Media Import window.

4. To import the media, see Import from file-based cameras.

**Organize files during import into Final Cut Pro for Mac**

You can choose how to organize your media when you import it into Final Cut Pro. You can copy the source files into the library or link to them at their current location. If your source files have Finder tags or the folders containing the files have meaningful names, you can choose to have the tags and folder names applied to the files as keywords during import.

If your source footage contains shots of people, you can have Final Cut Pro analyze the footage during import and apply keywords for the number of people in each shot and the shot type.

A Keyword Collection is created for each keyword added to your clips during import. Select a Keyword Collection in the Libraries sidebar to see all the clips with that keyword applied.

1. To import a file into Final Cut Pro, choose File > Import > Media, navigate to the file you want to import, select the file, then click Import.

2. Use the settings on the right side of the Media Import window to choose how you want to organize the imported media in your library:
   - *Add the imported media to an existing event:* Select “Add to existing event,” then choose the event from the pop-up menu.
   - *Create a new event:* Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name (for example, “Chris and Kim Wedding”) in the text field.

   To learn more about events, see Intro to libraries. If you want to import media into a new library, you must create the new library before importing your media.

3. In the Files section, select a file storage option:
   - *Copy to library:* This option duplicates the media files and places the copies in the current library storage location.

     *Note:* The name of this option changes to “Copy to library storage location: location name” when the current library is set to an external storage location.

   For information about setting the library storage location, see Set storage locations.
• **Leave files in place:** This option links to the source media files at their current location. If you import files with this option selected, Final Cut Pro creates symbolic links (also known as symlinks), which are special files that point to the media files without copying them. When you move, copy, or back up events and projects that use these files, only the symbolic links are moved or copied (not the source media files). If, after you move or copy your project or event, you want to replace the symbolic links with the actual source media files, select the events and choose File > Consolidate Event Files. For more information about files and clips, see Media files and clips.

4. In the Keywords section, select any of the following options:

• **From Finder tags:** Creates a keyword for each Finder tag in the files you’re importing. For each keyword, a Keyword Collection is also created. For more information about Finder tags, see macOS Help (click the desktop to make the Finder active, choose Help > macOS Help, then search for “tags”).

• **From folders:** Creates a keyword for each folder name and applies the keyword to all the files in the folder during import. Additionally, a Keyword Collection is created for each keyword.

![Image of Finder tags](image)

- After import, these clips will have "B-roll" and "AdventureTrips" keywords.
- After import, these clips will have "Interviews" and "AdventureTrips" keywords.

• **Find people:** Analyzes video clips and still images for the number of people present and shot types. After analysis, any of the following keywords are added to the clip: One Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot. For each keyword, a Keyword Collection is also created. The “Consolidate find people results” checkbox simplifies and summarizes all of the “find people” analysis keywords. If you’re analyzing to find people, it’s recommended that you also select the “Create Smart Collections after analysis” checkbox. See Intro to analyzing media.

5. If you want to override automatic role assignment, create optimized or proxy media, analyze the video, or analyze the audio, select the relevant checkboxes in the Audio Roles, Transcoding, and Analyze sections.

If you don’t specify that Final Cut Pro analyze your media during the import process, you can analyze it later in the browser.

6. Click Import Selected or Import All.

The Import button changes its name based on your clip selection. By default, the Media Import window closes when you click Import. You can begin working with your clips in the browser. Your media is imported in the background.

If you selected any options in the previous step, the files are transcoded and optimized after the import is complete. You can view the progress of the import and other background tasks in the Background Tasks window.
Import from other apps

Import into Final Cut Pro for Mac from iMovie for macOS

You can send an iMovie for macOS project to Final Cut Pro. You initiate the process from within iMovie. The project file and the media used in the project are copied to your Final Cut Pro library.

If you want to send an iMovie trailer project, you first need to convert it to a movie project.

For information about sending an iMovie project to Final Cut Pro or converting a trailer project to a movie project, see the iMovie User Guide.

Note: If you send a movie project from iMovie to Final Cut Pro and it contains a clip with the "Lower volume of other clips" audio adjustment, that adjustment appears in Final Cut Pro as the Gain filter. For information about adjusting audio effects in Final Cut Pro, see Adjust audio effects.

Import into Final Cut Pro for Mac from iMovie for iOS or iPadOS

You can import projects created in iMovie for iOS or iPadOS into Final Cut Pro.

1. Open iMovie on your iPhone or iPad.
2. Scroll projects in the Projects browser, then tap one to see project details.
3. Tap the Share button 📡, tap Options, tap Project, then tap Done (on iPhone) or tap the Back button (on iPad).
4. Tap one of the following options:
   • *AirDrop*: Share wirelessly to a nearby Mac using AirDrop.
   • *Save to Files*: Save the project to your iPhone, iPad, or iCloud Drive, and retrieve it with your Mac.

   For more information about these methods of sharing projects to other devices, see the iMovie User Guide for iPhone or the iMovie User Guide for iPad.
5. After the project file has finished copying, open Final Cut Pro and choose File > Import > iMovie iOS Projects.

   *Note*: This is the only way to import projects created in iMovie for iOS or iPadOS. You can’t open an iMovie for iOS or iPadOS project in Final Cut Pro by double-clicking the project icon or dragging it to Final Cut Pro.
6. In the window that appears, navigate to the location where you stored the project file you transferred from your iPhone or iPad.

   By default, AirDrop transfers appear in your Downloads folder. Projects sent to iCloud Drive appear in the iMovie folder in iCloud Drive.
7. Select the project file and click Import.

   The imported project appears in the current event in the browser.
When importing projects from iMovie for iOS or iPadOS, keep in mind the following:

- Some iMovie template elements may not be available in Final Cut Pro. You can re-create most of these effects in Final Cut Pro. See Intro to effects and Intro to titles. If you import a project that uses a Magic Movie or storyboard template that is not included with Final Cut Pro, the template elements in the imported project are replaced with the Standard Title element.

- Storyboard projects are automatically converted to movie projects for use in Final Cut Pro. Any empty placeholders in the storyboard project are replaced by placeholder clips in Final Cut Pro. See Add placeholders.

- If you import a project that contains a soundtrack included with iMovie for iOS or iPadOS, the soundtrack retains its clip name, clip composition, duration, and position in the timeline. However, the soundtrack is imported as a simple WAV audio file that no longer dynamically adjusts to fit the length of your project.

- If you’re using the most recent version of iMovie for iOS or iPadOS, you may get a message that the project can’t be imported.

### Import into Final Cut Pro for Mac from Final Cut Pro for iPad

You can use AirDrop or iCloud Drive to import a project created in Final Cut Pro for iPad.

1. Open Final Cut Pro on the iPad you want to transfer from, then do one of the following:
   - In the Projects screen, select a project in the list on the left, tap above the video preview, then tap Final Cut Pro for iPad Project.
   - With a project open, tap in the toolbar, then tap Final Cut Pro for iPad Project.

2. If you want to include all the video clips, audio clips, and photos you imported into your project (even if you haven’t added some of them to the timeline), make sure Include All Media is turned on; to export an offline project, turn off Include All Media.

3. Tap Export.

4. Tap one of the following options:
   - AirDrop: Share wirelessly to a nearby Mac using AirDrop.
   - Save to Files: Save the project to your iPad or iCloud Drive, and retrieve it with your Mac.

For more information, see the Final Cut Pro User Guide for iPad.

5. After the project file has finished copying, do one of the following:
   - Double-click the project file you transferred from your iPad.
   - Open Final Cut Pro on your Mac, then choose File > Import > Final Cut Pro for iPad Project. In the window that appears, navigate to the location where you stored the project file you transferred from your iPad, select the project file, and click Import.

   Note: By default, AirDrop transfers appear in your Downloads folder.

6. In the Save as Library window that appears, enter a name, then click Save.

   The project is converted to a Final Cut Pro library and appears in the Libraries sidebar.
Note: If you import a project that contains a soundtrack included with your Final Cut Pro for iPad subscription, the soundtrack retains its clip name, role, duration, and position in the timeline. However, the soundtrack is imported as a simple AAC audio file that no longer dynamically adjusts to fit the length of your project.

Import into Final Cut Pro for Mac from Photos

When you import photos and video clips from Photos or another photos app into Final Cut Pro, the media is always copied into the Final Cut Pro library, regardless of your import settings.

This is the only exception to the general rule that media is imported using the settings you define in the Import pane of Final Cut Pro settings. See Import from your Mac or storage device.

Tip: To streamline your importing workflow, organize your photos and video clips into albums in Photos before importing into Final Cut Pro. See Create albums in Photos on Mac.

Import by dragging from Photos

You can use the advanced search and organizing features in Photos and then drag your photos and video clips directly to the Final Cut Pro timeline or browser.

1. In Photos, organize your photos and video clips into albums and folders. (This speeds up the importing process.)
2. Click the disclosure triangle next to My Albums in the Photos sidebar, then click an album name to show its contents on the right.
3. Select one or more photos or video clips that you want to import, then drag them to an event in the Libraries sidebar in Final Cut Pro.
   The imported items appear in the event in Final Cut Pro.

This method of importing from Photos imports unmodified originals only. If you want to import photos that include edits made using the Photos app, see the Apple Support article If edits don’t appear in photos imported into Final Cut Pro 10.6.2.
Import from the sidebar in Final Cut Pro

1. In Final Cut Pro, open the Photos, Videos, and Audio sidebar by doing one of the following:
   - Choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).
   - Click the Photos, Videos, and Audio button in the top-left corner of the Final Cut Pro window.

2. In the sidebar, click Photos.

3. Use the pop-up menus at the top of the browser to choose a category and narrow your search.
   For example, choose My Albums to browse albums you created in Photos.

4. To use one or more photos or video clips in your project, drag the items from the browser to the timeline.
   To select multiple clips, Command-click them or drag a selection rectangle around them.

⚠️ Tip: If you want photos or video clips from a different photo library to appear in the sidebar, open the other photo library in the Photos app. Then, in the General pane of Photos settings, click “Use as System Photo Library.”
Import into Final Cut Pro for Mac from Music

You can import music and sound from your Music library into Final Cut Pro.

**Note:** To use a song you purchased from the iTunes Store in your project, you must be the copyright holder of the song or have express permission from the copyright holder. For more information, see the Final Cut Pro software license agreement (choose Final Cut Pro > About Final Cut Pro, then click License Agreement).

1. In Final Cut Pro, open the Photos, Videos, and Audio sidebar by doing one of the following:
   - Choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).
   - Click the Photos, Videos, and Audio button in the top-left corner of the Final Cut Pro window.

2. In the sidebar, click Music.
   
   A list of your Music content appears in the browser. If your Music library includes protected files, they are unavailable. (They do not appear in the browser.)

3. Use the controls in the upper-right corner of the browser to find the music or sound you want:
   - **Search for an item:** Click the search field and type.
   - **Choose which items to display:** Click the Music pop-up menu and choose a category, playlist, or folder.
     
     To show recently added content in the Music pop-up menu, choose Refresh Playlists.
   - **Preview an item:** Select the item and click the Play button ➤.
   - **Select more than one item:** Command-click each item.

4. Drag the clip or clips to the timeline.
   
   If you want to import just a portion of the clip, drag in the filmstrip at the top of the browser to select a range.

**Note:** For better import and playback performance, Final Cut Pro automatically transcodes all MP3 audio files to MOV audio files and retains the original MP3 files for future use. For information about where to find original and transcoded media files, see Locate source media files.
Import into Final Cut Pro for Mac from Apple TV

You can import videos from your Apple TV library into Final Cut Pro.

1. In Final Cut Pro, open the Photos, Videos, and Audio sidebar by doing one of the following:
   - Choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).
   - Click the Photos, Videos, and Audio button in the top-left corner of the Final Cut Pro window.

2. In the sidebar, click Apple TV.
   A list of your Apple TV content appears in the browser. If your Apple TV library includes protected files, they are unavailable. (They do not appear in the browser.)

3. Use the controls in the upper-right corner of the browser to find the media you want:
   - **Search for an item:** Click the search field and type.
   - **Choose which items to display:** Click the Apple TV pop-up menu and choose a category, playlist, or folder.
     To show recently added content in the Apple TV pop-up menu, choose Refresh Playlists.
   - **Preview an item:** Select the item and click the Play button ➤.
   - **Select more than one item:** Command-click each item.

4. Drag the clip or clips to the timeline.
   If you want to import just a portion of the clip, drag in the filmstrip at the top of the browser to select a range.

Import Motion content into Final Cut Pro for Mac

You can build and modify video effects, titles, transitions, and generators in Motion for use in Final Cut Pro. When you save a template in Motion, it is “published” and becomes available in its respective media browser in Final Cut Pro (the browser, Effects browser, or Transitions browser).

See the information about Final Cut Pro templates in the Motion User Guide.

For more information, see the following:

- Modify transitions in Motion
- Modify titles in Motion
- Modify effects in Motion
- Modify generators in Motion
Import into Final Cut Pro for Mac from GarageBand and Logic Pro

You can import music and sound from GarageBand and Logic Pro into Final Cut Pro.

1. Do one of the following:
   - In GarageBand: Choose Share > Song to Music.
   - In Logic Pro: Choose File > Share > Song to Music.

2. In Final Cut Pro, open the Photos, Videos, and Audio sidebar by doing one of the following:
   - Choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).
   - Click the Photos, Videos, and Audio button in the top-left corner of the Final Cut Pro window.

3. In the sidebar, select Music.

A list of your shared content appears in the browser.

4. To find the music or sound you want, do any of the following:
   - Search for an item: Type text in the search field at the top of the browser.
   - Choose which items to display: Click the pop-up menu at the top of the browser and choose a category, playlist, or folder.
   - Preview an item: Select the item and click the Play button ►.
   - Select more than one item: Command-click each item.
   - Select part of a clip: Drag in the filmstrip at the top of the browser to select the part of the clip you want to import. See Select a range.

Note: To use a song you purchased from the iTunes Store in your project, you must be the copyright holder of the song or have express permission from the copyright holder. For more information, see the Final Cut Pro software license agreement (choose Final Cut Pro > About Final Cut Pro, then click License Agreement).

5. Drag the clip or clips to the timeline.
*Note:* For better import and playback performance, Final Cut Pro automatically transcodes all MP3 audio files to MOV audio files and retains the original MP3 files for future use. For information about where to find original and transcoded media files, see [Locate source media files](#).

### Import into Final Cut Pro for Mac using workflow extensions

You can install workflow extensions to access features of third-party apps from within Final Cut Pro. For example, you can access and import from stock footage, media management, and review-and-approve apps without ever leaving Final Cut Pro.

1. To install an extension, follow the instructions that came with the extension app.
2. Open Final Cut Pro.
3. Click the Extensions button on the left side of the Final Cut Pro toolbar.
   - The Extensions button appears only when extensions are installed.
4. Use the extension interface to locate the media you want to import.
5. Drag items from the extension window to an event in the Libraries sidebar or to a project in the timeline.
6. To close the extension window, click the Extensions button.

To uninstall an extension, remove it from the Applications folder and reopen Final Cut Pro.

### Record video into Final Cut Pro for Mac

You can record video directly into Final Cut Pro using your computer’s built-in camera or an external camera.

#### Record live video and audio into Final Cut Pro

1. In Final Cut Pro, do one of the following:
   - *Record using the built-in camera:* Click the Import Media button in the toolbar.
   - *Record using an external camera:* Connect the camera to your Mac with a FireWire cable, then click the Import Media button in the toolbar.
2. In the Cameras list on the left side of the Media Import window, select the camera you want to import from.
A live video image from the camera appears in the Media Import window.

3. Click Import.

4. In the window that appears, choose how you want to organize the imported media in your library:
   - **Add the imported clips to an existing event**: Select “Add to existing event,” then choose the event from the pop-up menu.
   - **Create a new event**: Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name (for example, “Chris and Kim Wedding”) in the text field.

To learn more about events, see *Intro to libraries*. If you want to import media into a new library, you must create the new library before importing your media.

*Note*: You can set storage locations for each of your libraries. See *Set storage locations*.

5. If you want to override automatic role assignment, create optimized or proxy media, analyze the video, or analyze the audio, select the relevant settings in the Audio Roles, Transcoding, and Analyze sections.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later in the browser.

*Note*: Some import options are available only when you import files from a storage device. See *Organize files during import* and *Import from your Mac or storage device*.

6. When you’re ready to begin recording, click Import.

   The camera begins recording immediately.

7. When you want to stop recording, click Stop Import.

   A new video clip is created. You can click Import to begin recording again. You can repeat this process as many times as necessary.

*Tip*: You can also capture live video from some video camcorders over a FireWire cable using QuickTime X. See QuickTime Player Help (available from the Help menu when QuickTime Player is open).
Memory cards and cables used with Final Cut Pro for Mac

To import media from your recording device to your Mac, you need to remove the memory card from your device and insert it into either your Mac or a memory card reader. You can also connect your device directly to your Mac using the appropriate cable. Then you can import the media on the memory card or device using the Media Import window. See Import from your Mac or storage device and Import from file-based cameras.

- **Memory cards:** Many file-based camcorders and devices record media on a removable memory card. You can connect a card reader to your Mac and use that to transfer the contents of your memory card onto your Mac. Some Mac computers feature an SD (Secure Digital) or SDXC (SD extended capacity) card slot that allows data to be read from and written to SD media inserted in the slot. If your Mac has a card slot, you can remove the card from the camera, insert the card into your Mac, and then import the files.

  See About the SD and SDXC card slot.

  ![SD card](image)

You can also connect your device to your Mac using one of the cables listed below. The kind of cable you need depends on the kind of device you’re using:

- **Thunderbolt 3 device:** You can connect Thunderbolt 3 devices using a connector that plugs into the Thunderbolt 3 port on your Mac.

  ![Thunderbolt cable](image)

- **USB 2 or USB 3 device:** You use a USB cable for file-based camcorders, digital still cameras that record video, and iPhone, iPad, and iPod touch. The USB cable should have at least one connector that plugs into your Mac (at the top in the illustration below). The other end of the USB cable, which plugs into your recording device, might look different (on the bottom in the illustration below).

  ![USB cable](image)

- **USB-C device:** USB-C cables support both data and video transfer.

  ![USB-C cable](image)
• *Thunderbolt or Thunderbolt 2 device:* You can connect first- and second-generation Thunderbolt devices using a connector that plugs into the Mini DisplayPort on your Mac.

• *FireWire device:* For most camcorders that record to tape, you use a FireWire cable with a 6-pin connector on one end that plugs into your Mac (at the top in the illustration below) and a 4-pin connector on the other end that plugs into your camcorder (on the bottom in the illustration below).

Or you might have a FireWire 800 cable with a different end that plugs into your camcorder or Mac.

If your device didn’t come with a cable and you’re not sure what kind of device you have, you can check the logo near the cable ports on your device to see if it matches the USB or FireWire logo, both shown above. Otherwise, check the documentation that came with your device.

To check whether your camera is compatible with Final Cut Pro, see the Apple Support article [Cameras supported by Final Cut Pro](https://support.apple.com/en-us/HT204394).

### Media formats supported in Final Cut Pro for Mac

You can import and work with the following video, audio, and still-image formats in Final Cut Pro:

#### Video formats

- Apple Animation codec
- Apple Intermediate codec
- Apple ProRes (all versions)
- Apple ProRes RAW and Apple ProRes RAW HQ
- AVCHD (including AVCCAM, AVCHD Lite, and NXCAM)
- AVC-ULTRA (including AVC-LongG, AVC-Intra Class 50/100/200/4:4:4, and AVC-Intra LT)
- Canon Cinema RAW Light (requires the camera manufacturer’s plug-in software)
- DV (including DVCAM, DVCPRO, and DVCPRO50)
- DVCPRO HD
- H.264
- HDV
- HEVC
- iFrame
- Motion JPEG (OpenDML only)
- MPEG IMX (D-10)
- QuickTime formats
- REDCODE RAW (R3D) (requires the camera manufacturer’s plug-in software)
- Uncompressed 8-bit 4:2:2
- Uncompressed 10-bit 4:2:2
- XAVC (including XAVC-S)
- XDCAM HD/EX/HD422
- XF-AVC
- XF-HEVC

Audio formats
- AAC
- AIFF
- BWF
- CAF
- MP3
- MP4
- RF64
- WAV

Still-image formats
- BMP
- GIF
- HEIF
- JPEG
- PNG
- PSD (static and layered)
- RAW
- TGA
- TIFF
Container formats

- 3GP
- AVI
- MOV (QuickTime)
- MP4
- MTS/M2TS
- MXF

For information about formats you can export your movie to, see Supported export formats.

Adjust ProRes RAW camera settings in Final Cut Pro for Mac

Apple ProRes RAW brings to RAW video the same great performance, quality, and ease of use that Apple ProRes has brought to conventional video, in a format ideal for HDR content creation. ProRes RAW captures raw sensor data from compatible cameras. This wealth of data allows you to flexibly adjust camera settings in Final Cut Pro without losing quality.

With the standard RAW conversion built into Final Cut Pro for Mac, you can view and adjust the ISO setting, exposure offset, and color temperature of ProRes RAW media using controls in the inspector.

You can also install a software plug-in from a camera manufacturer to view and adjust ProRes RAW camera settings optimized specifically for that manufacturer’s camera sensors.

Adjust ProRes RAW camera settings for the standard conversion

1. Import ProRes RAW media into Final Cut Pro.

   **Important:** When you import the media, make sure to deselect the “Create optimized media” and “Create proxy media” options, because any transcoding work done during import will be discarded if you adjust the RAW settings in the next steps.

   For more information about importing media, see Import from file-based cameras and Import from your Mac or storage device.

2. In the Final Cut Pro browser or timeline, select the clip or clips you want to inspect or adjust.

   **Note:** Compound clips cannot be adjusted.

3. Do one of the following:

   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button in the toolbar.
4. Click the Info button at the top of the inspector.

5. At the bottom of the Info inspector, click Modify ProRes RAW Settings.

6. In the ProRes RAW Settings window, click the “Process using” pop-up menu and choose Standard Conversion (if it’s not already chosen).

7. In the ProRes RAW Settings window, view or adjust any of the following settings:

   Note: These settings appear only if the corresponding information is found in the clip metadata.
   - **Captured ISO**: Displays the as-shot ISO setting of ProRes RAW clips. (Not adjustable.)
   - **ISO**: Adjusts the ISO setting of ProRes RAW clips.
   - **Exposure Offset**: Adjusts the ISO setting of ProRes RAW clips up or down by as much as one stop.
   - **Captured Temp**: Displays the as-shot color temperature of ProRes RAW clips. (Not adjustable.)
   - **Color Temperature**: Adjusts the color temperature of ProRes RAW clips. This slider is available only for clips shot with supported cameras.
   - **RAW to Log**: Converts RAW to various log formats for use in LUT-based workflows. Choose the setting corresponding to your camera LUT. See Intro to color correcting ProRes RAW video.

8. As needed, generate optimized or proxy media from the ProRes RAW media.
Use a camera manufacturer’s ProRes RAW plug-in

1. Download the appropriate plug-in from the camera manufacturer’s website, and install it.

2. Import ProRes RAW media compatible with the plug-in.

   **Important:** When you import the media, make sure to deselect the “Create optimized media” and “Create proxy media” options, because any transcoding work done during import will be discarded if you adjust the RAW settings in the next steps.

   For more information about importing media, see Import from file-based cameras and Import from your Mac or storage device.

3. In the Final Cut Pro browser or timeline, select the clip or clips you want to inspect or adjust.

   **Note:** Compound clips cannot be adjusted.

4. Do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button in the toolbar.

5. Click the Info button at the top of the inspector.

6. At the bottom of the Info inspector, click Modify ProRes RAW Settings.

7. In the ProRes RAW Settings window, click the “Process using” pop-up menu and choose the plug-in you want to use.
8. View or adjust any of the plug-in settings.

The example below shows settings for a camera manufacturer plug-in.

9. As needed, generate optimized or proxy media from the ProRes RAW media.

For information about cameras that are compatible with Apple ProRes RAW, see the Apple Support article Cameras supported by Final Cut Pro.

**Import REDCODE RAW files into Final Cut Pro for Mac**

You can import and work with REDCODE RAW (R3D) files in Final Cut Pro.

RAW format video files require some additional steps before and after import.

After the R3D RAW files are imported, you can make nondestructive color correction adjustments directly within Final Cut Pro.

**Import REDCODE RAW (R3D) files**

1. Install the appropriate plug-in.

   In order for Final Cut Pro to recognize the R3D RAW files, you must download and install the RED Apple Workflow Installer.

2. Import the media into Final Cut Pro.

   **Important:** When you import the media, make sure to deselect the “Create optimized media” and “Create proxy media” options, because any transcoding work done during import will be discarded if you adjust the RAW settings in the next step.

   For more information about importing media, see Import from file-based cameras and Import from your Mac or storage device.
Note: If you’re importing files from the RED ONE camera, it's recommended that you import the R3D RAW files only. The RED ONE camera typically generates a set of up to four QuickTime reference movie (.mov) files for each R3D RAW file. If you select both the R3D file and the reference movies during the import process, only the R3D file is imported. If you need to import a reference movie, select only the reference movie, not the R3D file.

3. Adjust the RAW settings (with Final Cut Pro or with an external application such as REDCINE–X PRO).

You can apply a nondestructive “one-light” color correction to the R3D RAW clips immediately after import, to give your footage a more finished look for editing and review.

If you have a professional production with sophisticated color correction needs, you can revisit these RAW settings during the finishing stage. See Adjust RED RAW settings, below.

4. If you like, generate optimized or proxy media from the R3D RAW files.

See Create optimized and proxy files.

To control whether Final Cut Pro displays optimized, proxy, or original media in the viewer, and whether video playback is optimized for quality or performance, choose the corresponding options from the View pop-up menu in the upper-right corner of the viewer. See Control playback quality.

5. Add the R3D RAW clips to your project and edit them as you would any other clips.

**Adjust RED RAW settings**

You can adjust REDCODE RAW (R3D) files in Final Cut Pro using the RED RAW Settings window.

Metadata about REDCODE RAW (R3D) files can be stored in two locations:

- **Internal (embedded) settings**: This is information recorded by the camera and embedded in the R3D RAW file. It always remains with the file. These camera settings can be superseded by settings in the external RMD file, but they are never overwritten. You can revert to these camera settings by deleting any existing RMD file or by clicking the Revert To pop-up menu in the RED RAW Settings window and choosing Original Camera Settings.

- **External RMD file**: This is an external metadata file with the file extension .RMD. This file is created by Final Cut Pro, REDCINE-X PRO, or similar apps. If you adjust RED RAW settings in Final Cut Pro and an RMD file already exists, the existing file is overwritten when the changes are saved. The embedded camera settings remain intact.
1. Verify that the current versions of Final Cut Pro and Pro Video Formats software are installed:
   • *Final Cut Pro*: Choose Apple menu > App Store, then click Updates in the sidebar.
   • *Pro Video Formats*: Choose Apple menu > System Settings, click General in the sidebar, then click Software Update on the right.

2. Install the appropriate plug-in.

   In order for Final Cut Pro to recognize the R3D RAW files, you must download and install the corresponding plug-in. For more information, go to [http://www.red.com](http://www.red.com).

3. In the Final Cut Pro browser or timeline, select the clip or clips you want to adjust.

   **Note:** Compound clips cannot be adjusted.

4. Do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button in the toolbar.

5. Click the Info button at the top of the inspector.

6. In the Info inspector, click the Modify RED RAW Settings button.

7. In the RED RAW Settings window, adjust the settings.

   Your changes are saved nondestructively to an external metadata file with the file extension .RMD, overwriting any existing RMD metadata file. Unlike video effects that are applied to a clip, these adjustments are associated with the file (via the RMD metadata file). Any changes you make to these settings are applied to all copies of the selected clip or clips.

   To produce wide-gamut colors for HDR without the use of a LUT, set Color Space to Rec. 2020 and Gamma to HDR-2084. For information about wide-gamut HDR settings in Final Cut Pro, see [Use wide-gamut HDR color processing](#).

   **Note:** Final Cut Pro supports the RED ROCKET card, a PCI card that provides a significant boost in performance. For more information about REDCODE RAW (R3D) files and the RED ROCKET card, go to [http://www.red.com](http://www.red.com).
Import Canon Cinema RAW Light files into Final Cut Pro for Mac

You can import and work with Canon Cinema RAW Light files in Final Cut Pro when you install additional software from Canon.

Your camcorder or camera must be compatible with Final Cut Pro. For a list of compatible devices, see the Apple Support article Cameras supported by Final Cut Pro.

1. Verify that the current versions of Final Cut Pro and Pro Video Formats software are installed:
   - Final Cut Pro: Choose Apple menu > App Store, then click Updates in the sidebar.
   - Pro Video Formats: Choose Apple menu > System Settings, click General in the sidebar, then click Software Update on the right.

2. From the Canon website, download the Canon RAW Plugin for Final Cut Pro, then install the software on your Mac.

3. Import the media into Final Cut Pro.
   
   See Import from file-based cameras and Import from your Mac or storage device.

   Note: Canon Cinema RAW Light files have the filename extension .crm.

4. Optionally, confirm that Final Cut Pro applied the appropriate built-in Canon camera LUT (Canon Log 2/Cinema Gamut), or apply a custom LUT.
   
   See Apply LUTs.

5. If you like, generate optimized or proxy media from the Canon Cinema RAW Light media.

After you add the Canon Cinema RAW Light clips to your project, you can edit them as you would any other clips.

Analyze media

Intro to analyzing media in Final Cut Pro for Mac

You can have Final Cut Pro analyze your media (video, audio, and still images) and automatically correct common problems. For example, you can balance color and remove excess hum or loudness.

You can also analyze clips to identify their contents. Analysis can detect the number of people in a shot and identify whether the shot is a close-up, medium, or wide shot. This is helpful if you need to quickly find a certain type of clip while viewing footage or editing a project. For complete lists of the video and audio analysis options, see Video analysis options and Audio analysis options.

You can analyze media during import or after you import the media into Final Cut Pro. You can also set Final Cut Pro to automatically analyze clips you drag directly to the Final Cut Pro timeline from the Finder.
After certain types of analysis, keywords are automatically added to clips or clip ranges based on the results of the analysis. For example, a clip showing several people might have the Group and Medium Shot keywords assigned. In the browser, clips with analysis keywords have a purple line at the top. (Clips with keywords you add manually or keywords imported from Finder tags or folder names have a blue line at the top. See Add keywords.)

Note: This section covers analysis and automatic correction options for event clips only. For information about correcting shaky video and rolling shutter distortion in clips in the timeline, see Correct shaky video.

Video analysis options in Final Cut Pro for Mac

Final Cut Pro provides video and still-image analysis options that can automatically balance color in video and detect people and shot angles in video or still images. You can analyze video during import, or analyze video clips in the browser after import. Based on the results of the analysis, analysis keywords are added to clips or clip ranges.

Final Cut Pro provides these video and still-image analysis options:

- **Analyze for balance color**: Analyzes video clips to detect color balance and contrast. Color is automatically balanced when you add the clip to the timeline. You can turn automatic color adjustments on and off at any time.
- **Remove pulldown**: Analyzes video clips and removes pulldown patterns.
  Important: This option is available only when importing from a tape-based camera or device.
- **Find people**: Analyzes video clips and still images for the number of people present and shot types. After analysis, any of the following keywords are added to the clips or clip ranges: One Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot.
  Tip: To easily locate clips with “find people” analysis keywords, select the “Create Smart Collections after analysis” checkbox.
• **Consolidate find people results:** Consolidates all of the “find people” analysis keywords into one shot type keyword and one people keyword for every 2-minute segment of video. The shot type keyword chosen is the one for the widest shot type, and the people keyword chosen is the one representing the most people. For example, if a video segment contains Medium Shot, Wide Shot, One Person, and Group keywords, the segment’s analysis keywords are reduced to Wide Shot and Group during consolidation.

• **Create Smart Collections after analysis:** Creates a Smart Collection for each keyword applied when video clips and still images are analyzed for the presence of people. The Smart Collections are listed alphabetically in a People folder inside the event in the Libraries sidebar.

When you drag a media file from the Finder to a Final Cut Pro event or the timeline, the import begins automatically, without displaying a window of import options. You can set automatic import options in the Import pane of Final Cut Pro preferences.

### Audio analysis options in Final Cut Pro for Mac

Final Cut Pro provides automatic analysis options that can fix common audio problems, analyze and group audio channels, and remove silent channels. You can analyze audio during import, or analyze video clips with audio issues in the browser or in the timeline.

Final Cut Pro provides these audio analysis options:

• **Analyze and fix audio problems:** Analyzes the audio for hum, noise, and loudness. Final Cut Pro automatically fixes problems that are considered severe (marked in red) and flags problems that are considered moderate (marked in yellow). See [Enhance audio](#).

• **Separate mono and group stereo audio:** Audio channels are analyzed and grouped as dual mono or stereo, depending on the results of the analysis. Automatically corrected audio channels are marked as Autoselected. For more information about audio channels, see [Configure audio channels](#).

• **Remove silent channels:** Audio channels are analyzed, and silent channels are removed. Clips that have had channels removed are marked as Autoselected. For more information about audio channels, see [Configure audio channels](#).

When you drag a media file from the Finder to a Final Cut Pro event or the timeline, the import begins automatically, without displaying a window of import options. You can set automatic import options in the Import pane of Final Cut Pro preferences.
Analyze your media in Final Cut Pro for Mac

You can analyze clips during the import process, analyze clips in the browser after import, or set Final Cut Pro to analyze clips automatically when they're dragged to a Final Cut Pro event or the timeline.

Analyze clips during import

1. In Final Cut Pro, do one of the following:
   - **Import a file from a compatible camcorder or camera, iPad, iPhone, iPod, or other device:** Connect the device to your Mac and turn on the device, then choose File > Import > Media (or press Command-I). In the window that appears, select the file you want to import, then click the Import button.
   - **Import a file from a tape-based camcorder:** Connect the camcorder to your Mac, turn on the camcorder, and set it to VTR or VCR mode. Then choose File > Import > Media (or press Command-I) and click the Import button.
   - **Import a file from a memory card:** Insert the memory card into the card slot on your Mac or into a card reader that’s connected to your Mac, then choose File > Import > Media (or press Command-I). In the window that appears, select the file you want to import, then click the Import button.
   - **Import a file located on your Mac or a connected external storage device:** Choose File > Import > Media (or press Command-I). In the window that appears, select the file you want to import, then click the Import button.
   - **Import from an archive:** Choose File > Import > Media (or press Command-I). In the window that appears, select the archive you want to import from, select the files in the archive you want to import, then click the Import button.

2. In the window that appears, choose how you want to organize the imported media in your library:
   - **Add the imported media to an existing event:** Select “Add to existing Event,” then choose the event from the pop-up menu.
   - **Create a new event:** Select “Create new Event,” then type a name for the event (for example, “Chris and Kim Wedding”) in the text field. Use the “Save to” pop-up menu to choose the location where you want to store the event.

To learn more about events, see Intro to libraries.

3. Select the video and audio analysis options that you want to apply.
   - See Video analysis options and Audio analysis options. The files will be analyzed in the background after the import is complete.

4. Click Import.

The import may take a while, depending on the options you selected in step 3. You can view the progress of the import and other background tasks in the Background Tasks window.
Analyze clips after import

1. In Final Cut Pro, select a clip to analyze by doing one of the following:
   • Click the clip in the browser. To select multiple clips, Command-click them or drag a selection rectangle around them.
   • Control-click a clip in the timeline, then choose Reveal in Browser.

2. In the browser, Control-click the clip or clips, then choose “Analyze and Fix.”

3. In the window that appears, select the video and audio analysis options that you want to apply, then click OK.
   
   See Video analysis options and Audio analysis options.

Transcoding may take a while, depending on the analysis options you selected. You can see the status of transcoding and other background processes in the Background Tasks window.

Automatically analyze media files when they’re dragged to an event or the timeline

1. In Final Cut Pro, choose Final Cut Pro > Settings.

2. In the Settings window, click Import, then select the video and audio analysis options that you want to apply.
   
   See Import settings.

   When you’re finished, close the Settings window.

3. To import one or more files, select a file (or Command-click multiple files) in the Finder, then drag the selection to an event or the timeline.

View analysis keywords in Final Cut Pro for Mac

If you analyze media to find people, analysis keywords—such as One Person, Close Up Shot, and so on—are automatically added to clips or clip ranges. Clips or ranges with analysis keywords are marked with a purple line in the browser.

You can view a clip’s analysis keywords in several locations in Final Cut Pro.
View keywords in the Skimmer Info window
1. In Final Cut Pro, choose View > Browser > Skimmer Info (or press Control-Y).
2. Skim the clip in the browser.
   Keywords, including analysis keywords, are displayed in the Skimmer Info window when you hold the pointer over the clip.

   To turn off Skimmer Info, choose View > Browser > Skimmer Info (or press Control-Y).

View keywords in list view in the browser
1. In Final Cut Pro, click the List View button in the top-right corner of the browser.

2. To see a clip's keywords, click the disclosure triangle next to the clip.
View the contents of a Smart Collection

If you chose to create Smart Collections after analysis, clips that have analysis keywords are automatically grouped in Smart Collections within the event in the Libraries sidebar. A Smart Collection is created for each analysis keyword and placed in a People folder in the event.

• In the Libraries sidebar in Final Cut Pro, select an analysis keyword Smart Collection inside an event.

The clips with that analysis keyword appear in the browser. For example, if you select the Medium Shot Smart Collection, all the clips in the event that have the Medium Shot keyword appear in the browser.
Play back and organize media

Play back and skim media

Intro to playback in Final Cut Pro for Mac

Final Cut Pro makes it easy to view and listen to your media, whether it’s located in the timeline or the browser.

You use two tools to preview and play back media in Final Cut Pro:

- The **playhead** marks the current position in the timeline or the browser. You can move the playhead by dragging it (called **scrubbing**) or by clicking another area in the timeline or a clip. You can also play back a clip or project from the playhead’s current position.
  
  The playhead appears as a light gray vertical line that is fixed in place unless you move it or click elsewhere.

- The **skimmer** lets you preview clips in the timeline and the browser without affecting the playhead position. You use the skimmer to **skim**, or freely move over clips to play them back at the position and speed of the pointer.
  
  The skimmer appears as a red vertical line as you move the pointer over the area you’re skimming. If you have **snapping turned on**, the skimmer turns yellow when it snaps to a position.

When skimming is turned on, you can skim to see what’s in other clips but still keep your playhead position in the timeline. If both the playhead and skimmer are present in the same clip, the skimmer becomes the default position for playback or editing.

When skimming is turned off or the skimmer is not present in a clip, the playhead assumes the default position.
Play media in Final Cut Pro for Mac

Final Cut Pro provides many options for playing back projects and clips. You can play a project or clip from the beginning, play it from a certain point, play it at different speeds, and loop playback. You can also play video in full-screen view.

To control whether Final Cut Pro displays optimized, proxy, or original media in the viewer, and whether video playback is optimized for quality or performance, choose the corresponding options from the View pop-up menu in the upper-right corner of the viewer. See Control playback quality.

Play back video and audio clips

In Final Cut Pro, do any of the following:

- *Play a project or clip from the beginning:* Select the project or clip, then choose View > Playback > Play from Beginning (or press Control-Shift-I).

- *Play a section of a project, selected clips, or a frame range from the beginning:* In the timeline, select clips, or select a range, then choose View > Playback > Play Selection, or press the Slash (/) key.

  When you select a clip or a portion of a clip or project, the selected area is marked with a yellow border.

- *Play a project or clip from a specific point:* In the browser or the timeline, click a point in the project or clip where you want to begin (or move the playhead to a point in the timeline), then either press the Space bar or click the Play button ► in the viewer.
• **Play around the playhead or skimmer:** Choose View > Playback > Play Around, or press Shift-Question Mark (?)..

![](Skimmer.png)

• **Stop playback:** Press the Space bar.

• **Play clips in the browser without interruption:** Choose View > Browser > Continuous Playback.

  When this setting is chosen, all event clips play without interruption (rather than stopping at the end of each clip).

**Use the J, K, and L keys for playback**

You can use the J, K, and L keys on your keyboard to play a project or clip at up to 32x normal speed. Playback begins at the location of the playhead (for a project) or the skimmer (for a clip). You can also use the J, K, and L keys to control a video playback device.

![Keyboard.png](Keyboards.png)

In Final Cut Pro, you can use these keys to speed playback up to 32x normal speed.

1. In Final Cut Pro, position the playhead or the skimmer in the browser or the timeline.

2. Do any of the following:

   • **Begin forward playback at normal (1x) speed:** Press L.
   • **Begin reverse playback at normal (1x) speed:** Press J.
   • **Pause playback:** Press K.
   • **Double the current playback speed:** Press L or J twice.
   • **Immediately reverse the playback direction:** Press J to play in reverse, or press L to play forward.
   • **Move the playhead one frame at a time:** Hold down the K key, and press J or L.
   • **Move the playhead at 1/2x speed:** Hold down the K key while holding down J or L.

When you use keyboard shortcuts to control a device (like a camcorder or camera), the speed of forward (L) and reverse (J) playback may vary depending on your video equipment.
Play back media in a loop

You can turn on looping so that a project or a clip (or any portion of either) plays in a continuous loop.

1. To turn on looping in Final Cut Pro, choose View > Playback > Loop Playback (or press Command-L).

2. Do any of the following:
   - **Loop your entire project**: Click the timeline to make it active, then press the Space bar.
   - **Loop a clip in the browser**: Select the clip, then press the Space bar.
   - **Loop a portion of a clip or project**: Select a range in a browser clip or the timeline (or select a timeline clip), then choose View > Playback > Selection, or press the Slash (/) key.

Play video in full-screen view

1. In Final Cut Pro, open a project in the timeline or select a clip in the browser, then position the playhead where you want the video to begin.

2. Do one of the following:
   - Choose View > Playback > Play Full Screen (or press Shift-Command-F).
   - Click the Play Full Screen button below the lower-right corner of the viewer.

The item plays in full-screen view starting at the playhead position.

💡 Tip: You can use all the playback shortcut keys during full-screen playback, including J, K, L, and others. For a full list of the available shortcuts, see **Playback and navigation**.

To leave full-screen view, press the Esc (Escape) key.

When you play back clips, the frames under the playhead or skimmer play in the viewer. If you need to play two clips at once so that you can compare them, you can use the event viewer, a separate viewer for playing back event clips only. The event viewer appears to the left of the main viewer. See **Play media in the event viewer**.

Skim media in Final Cut Pro for Mac

You can quickly skim your video and audio to preview it, search for a particular shot, or make an edit. When skimming is turned on and you move the pointer forward or backward over a clip in the browser or the timeline, the content under the pointer plays in the viewer.

You can also use the Blade, Trim, and Range Selection editing tools to skim clips in the timeline or the precision editor. You can also turn on **clip skimming** to view or hear individual clips in isolation.

As you’re editing in Final Cut Pro, you may find skimming distracting when you move the pointer from one location to another. You can disable all skimming (or just audio skimming).
Skim clips

- In Final Cut Pro, move the pointer forward or backward over a clip in the browser or the timeline.

The skimmer (a vertical red line) indicates exactly where the pointer is as you skim, and the corresponding frames are displayed in the viewer.

Tip: You can also press the Space bar at any time to play forward from the skimmer position.

Skim clips with editing tools

The Blade, Trim, and Range Selection tools behave as skimmers as you move the pointer over a clip.

1. In Final Cut Pro, select a clip in the timeline or open the precision editor.
2. Click the Tools pop-up menu above the timeline, then choose the Blade, Trim, or Range Selection tool.
3. Move the tool forward or backward over a clip.

When using an editing tool as a skimmer, you can skim and add markers to clips below connected clips in the timeline.

Note: When you skim clips with editing tools, Final Cut Pro displays the source timecode for those clips. See View source and project timecode.
**Turn skimming on and off**

In Final Cut Pro, do any of the following:

- **Turn all skimming on or off:** Click the Skimming button.
  You can also choose View > Skimming (or press S).

- **Turn audio skimming on or off:** Click the Audio Skimming button.
  You can also choose View > Audio Skimming (or press Shift-S).

When skimming is turned on, the skimming buttons appear highlighted.

Note: When skimming is turned off, you can still skim with the Blade, Trim, and Range Selection editing tools.

**Skim audio for individual clips or audio components**

You can turn on clip skimming to limit audio skimming to an individual clip. This is useful if you have a connected clip in the timeline and want to skim it without also hearing audio from the clip in the primary storyline. When clip skimming is turned on, Final Cut Pro displays the source timecode for clips as you skim.

**Important:** You must turn on audio skimming to use this feature.

- In Final Cut Pro, choose View > Clip Skimming (or press Option-Command-S).
  A checkmark appears next to the menu item to indicate that clip skimming is turned on.

You can also use clip skimming to skim and listen to an individual audio component when editing clips that show expanded audio components. If clip skimming is turned off, you hear combined audio for all components in the clip as you skim.

⚠️ **Tip:** To view expanded audio components, select the clip in the timeline and choose Clip > Expand Audio Components (or press Control-Option-S).

With clip skimming enabled, you can view source timecode as you skim clips in the timeline. See View source and project timecode.
Play media in the event viewer in Final Cut Pro for Mac

Sometimes, you may need two viewers so that you can play back and skim event clips separately from timeline clips. The event viewer is a separate video display that appears next to the main viewer. With the event viewer and the viewer open, you can display two clips at the same time: one from the browser and one from the timeline.

You use the event viewer to play clips in the browser only. As you do with the main viewer, you can show video scopes, color channels, title and action safe zones, and multicam angles (with the event viewer set to show angles). Playback and adjustment controls are identical in the viewer and the event viewer. Other viewer-related operations (including onscreen controls and built-in effects) are done with the main viewer.

Open or close the event viewer

- In Final Cut Pro, choose Window > Show in Workspace > Event Viewer (or press Control-Command-3).

Note: If you’re using video scopes with the event viewer, you may find it convenient to display the scopes below the video image rather than on the left side (the default). To display scopes below the video image, click the View pop-up menu at the top of the video scopes display and choose Vertical Layout. See Display video scopes.

Compare two video frames in Final Cut Pro for Mac

In Final Cut Pro, you can show the comparison viewer next to the main viewer to compare any two frames of video side by side. For example, you can compare frames to look for differences or similarities in color correction, cropping, titles, video effects such as blurs or masks, and so on.

You can use the comparison viewer in two modes in Final Cut Pro:

- **Saved**: Save frames to the comparison viewer so you can compare them to any frame in the timeline or the browser. In Saved mode, you can use the comparison viewer with a frame browser that shows thumbnails of your saved frames. You can save up to 30 frames from anywhere in your project or library, and you can display saved frames in the comparison viewer with just a click.

- **Timeline**: Quickly compare a frame in your project with a frame from the previous or next clip in the timeline. As you move the playhead in the timeline, the comparison viewer updates automatically to show either the last frame of the previous clip or the first frame of the next clip.
Show the previous or next clip in the timeline.

Show the frame saved in the comparison viewer.

Show the comparison viewer

- In Final Cut Pro, choose Window > Show in Workspace > Comparison Viewer (or press Control-Command-6).

The comparison viewer appears next to the main viewer.

Note: You can’t show the comparison viewer and the event viewer at the same time.

Compare saved frames in the comparison viewer

1. In Final Cut Pro, show the comparison viewer next to the viewer by choosing Window > Show in Workspace > Comparison Viewer (or pressing Control-Command-6).

2. Click the Saved button at the top of the comparison viewer.

3. In the timeline or the browser, position the playhead on the frame you want to save to the comparison viewer, then click the Save Frame button in the lower-right corner of the comparison viewer.

The frame appears in the comparison viewer. A thumbnail of the saved frame also appears in the frame browser. See Store and review frames in the frame browser, below.

4. In the timeline or the browser, position the playhead on the frame you want to compare with, so that it appears in the viewer.

Store and review frames in the frame browser

When working with the comparison viewer in Saved mode, you can view, add, and remove saved video frames in the frame browser.

1. In Final Cut Pro, show the comparison viewer next to the viewer by choosing Window > Show in Workspace > Comparison Viewer (or pressing Control-Command-6).

2. To open the frame browser, click the Saved button at the top of the comparison viewer, then click the Frame Browser button in the lower-left corner.
3. To save a frame to the frame browser, position the playhead on a frame in the timeline or the browser, then do one of the following:
   • Click the Save Frame button in the lower-right corner of the comparison viewer.
   • Click the Save Frame button 🔄 in the lower-left corner of the frame browser.

   The saved frame appears in the comparison viewer, and its thumbnail is added to the frame browser.

   ![Click a thumbnail to show the image in the comparison viewer.](image)

   ![Save the frame at the playhead position.](image)

   When the frame browser reaches 30 saved frames, the oldest image will be deleted to make room for newly saved frames. You can access saved frames from any project in the current library, but they are not available across libraries.

4. In the frame browser, do any of the following:
   • *Display a saved frame in the comparison viewer*: Click its thumbnail.
   • *Quickly preview a saved frame in the comparison viewer*: Hold down the Option key as you move the pointer over a thumbnail.
   • *Remove a saved frame*: Select its thumbnail and press Delete.

### Compare the previous or next clip in the timeline

The Previous Edit and Next Edit buttons in the comparison viewer’s Timeline mode let you quickly compare a frame in the timeline with frames in adjacent clips. This is particularly useful for color correcting a series of shots in a scene that requires continuity in color and exposure.

1. In Final Cut Pro, show the comparison viewer next to the viewer by choosing Window > Show in Workspace > Comparison Viewer (or pressing Control-Command-6).
2. Click the Timeline button at the top of the comparison viewer.
3. In the timeline, position the playhead on the frame you want to compare to a frame in an adjacent clip.

   The video frame appears in the viewer.
4. To set the frame that appears in the comparison viewer, click one of the following buttons at the bottom of the comparison viewer:
   - Previous Edit: Shows the last frame of the previous clip in the timeline.
   - Next Edit: Shows the first frame of the next clip in the timeline.

For more information about color correction, see Manual color correction workflow.

Display video scopes in the comparison viewer

You can display video scopes in the comparison viewer, just as you can in the main viewer.

1. In Final Cut Pro, show the comparison viewer next to the viewer by choosing Window > Show in Workspace > Comparison Viewer (or pressing Control-Command-6).

2. In the upper-right corner of the comparison viewer, choose View > Video Scopes, or press Command-7 while the comparison viewer is active.

Tip: You can use the Command Editor to assign a keyboard shortcut to save a video frame to the comparison viewer (or to switch the active viewer between the comparison viewer and the viewer when working with an external display). In the Command Editor, search for “comparison viewer.” See Intro to the Command Editor.

Play media on an external display in Final Cut Pro for Mac

Final Cut Pro includes an A/V Output option to send video and audio from your Mac to an external video monitor. The A/V Output feature shows you how video and audio look and sound on a reference SDR or HDR video monitor. In addition, this feature allows you to test output with sophisticated external devices such as vectorscopes and waveform monitors.

A/V Output also lets you use the Pro Display XDR as a dedicated HDR color reference monitor for video editing and color correction.

Note: If you have a second computer display connected to your Mac, you can expand your workspace by showing the viewer, browser, or timeline on the second display. See Use a second display.
View playback on an external monitor using a third-party video interface
1. Install the video interface hardware and software according to the manufacturer’s instructions.
2. Connect an external video monitor to the video interface, and make sure the monitor and all other external devices are connected to power and turned on.
3. To select an A/V output device in Final Cut Pro, choose Final Cut Pro > Settings (or press Command-Comma), click Playback, then click the A/V Output pop-up menu and choose the external monitor.
4. In Final Cut Pro, choose Window > A/V Output.
   The viewer contents appear on the broadcast monitor. Viewer features (such as onscreen controls and the title-safe and action-safe overlays) appear only in Final Cut Pro.
   Note: Video and audio are synced at the video frame (not audio sample) level.

To turn off A/V Output, choose Window > A/V Output.

Use the Pro Display XDR as a dedicated HDR color reference monitor
On a system with a Pro Display XDR, Final Cut Pro provides the maximum color and brightness accuracy in HDR video playback. This makes the Pro Display XDR the ideal professional reference monitor for critical work such as HDR color correction.

You can enable A/V Output to set up an HDR color correction system with at least two displays: the Pro Display XDR as the external HDR reference monitor and a display for working with the Final Cut Pro interface.

For instructions, see Color correct HDR video with Pro Display XDR.
View playback on an external monitor using HDMI

If you’re using Final Cut Pro 10.1 or later on a 4K-capable Mac with an HDMI port or a Thunderbolt port and an HDMI adapter, you can play 4K or HD 1080 video on an external video monitor connected to the HDMI port.

1. Use an HDMI cable to connect the external HDMI video monitor to the HDMI port on your Mac, and make sure the monitor is connected to power and turned on.

2. To configure the HDMI monitor, choose Apple menu > System Settings, then click Displays.

3. In Displays settings, set the HDMI monitor to be a secondary display.

4. Select Scaled, and in the list that appears, select 4096 x 2160, 3840 x 2160, 1080i, or 1080p.

   Note: You may need to press the Option key while you click Scaled to see additional resolutions for the HDMI monitor.

5. To select the monitor in Final Cut Pro, choose Final Cut Pro > Settings (or press Command-Comma), click Playback, then click the A/V Output pop-up menu and choose the HDMI monitor.

6. In Final Cut Pro, choose Window > A/V Output.

   The viewer contents appear on the HDMI monitor. Viewer features (such as onscreen controls and the title-safe and action-safe overlays) appear only in Final Cut Pro.

   Note: If you’re viewing HDR video on a system with macOS Catalina 10.15 or later, you can have Final Cut Pro show the HDR image as tone mapped. Tone mapping compresses bright image content and reduces the apparent dynamic range of the video to fit the viewable range of the connected display. To turn on tone mapping, open the Playback pane of Final Cut Pro settings and select the Show HDR as Tone Mapped checkbox at the bottom of the pane.

   Video and audio are synced at the video frame (not audio sample) level.

   To turn off A/V Output, choose Window > A/V Output.

For more information about third-party devices and software, contact the device manufacturer or go to the Final Cut Pro Resources webpage.
Control playback quality in Final Cut Pro for Mac

You can adjust settings in the viewer to manage visual quality and playback performance. For example, you can increase playback performance by displaying video at reduced resolution or by using proxy media.

Set playback quality

• In Final Cut Pro, click the View pop-up menu in the upper-right corner of the viewer, then choose an option in the Quality section:
  • **Better Quality:** Choose this option to display full-resolution video frames in the viewer. This setting may decrease playback performance for high-quality, large-frame-size video.
  • **Better Performance:** Choose this option to display video in the viewer at reduced resolution. Decreasing the size of the media maintains playback performance even for very large media files.

Choose the type of playback media

• In Final Cut Pro, click the View pop-up menu in the upper-right corner of the viewer, then choose an option in the Media Playback section:
  • **Optimized/Original:** Choose this option to edit with optimized media (in the Apple ProRes 422 format) for playback. If optimized media is not available, Final Cut Pro uses the original media for playback.
  • **Proxy Preferred:** Choose this option to edit with proxy media for playback. If proxy representations aren’t available, Final Cut Pro uses optimized or original media for playback.
  • **Proxy Only:** Choose this option to edit with proxy media rather than full-resolution media for playback. Choosing this option increases playback performance but lowers the video quality. In Final Cut Pro, proxy media is in either the Apple ProRes 422 Proxy or H.264 format. For details about proxy media format and frame size options, see Import settings and Create optimized and proxy files.

You can use the Info inspector to determine whether optimized or proxy media files exist for a given clip. See View a clip’s information. If you choose Proxy Only in the View pop-up menu and no proxy media file exists, a Missing Proxy File alert icon appears in the viewer.

Important: If you use proxy media for playback, make sure to switch back to optimized/original media before sharing your project. This ensures the highest quality in the exported file. See Intro to sharing projects.
Use overlays in the viewer in Final Cut Pro for Mac

You can add video overlays to the viewer to guide you when placing text and graphics or cropping an image, or to make sure your video will look correct when it’s adapted to other screen resolutions and aspect ratios.

Final Cut Pro comes with title-safe and action-safe overlays that you can show or hide.

You can also create your own custom overlays tailored to the needs of your project. For example, you can use custom overlays to:

• Edit your video in an aspect ratio that differs from the aspect ratio of the original footage
• Hide unsightly “window burn-ins” (of timecode, filenames, and camera information)
• Reserve an area of the screen for a logo or graphic that hasn’t been produced yet

Note: Overlays are for your reference while editing and appear only in the viewer. Output (exported) media files are not affected.

Show or hide title-safe and action-safe overlays

The title-safe area is the inner 80 percent of the screen, guaranteed to be visible on all TVs. To prevent text in your video from being hidden by the edge of a TV, you should restrict any titles or text to the title-safe area. The action-safe area is 90 percent of the image area. Most of the time, anything in your video image that’s outside of this area won’t be displayed on a TV screen, so make sure important material is framed within the action-safe area.
In Final Cut Pro, click the View pop-up menu in the upper-right corner of the viewer, then choose Show Title/Action Zones.

Lines indicating title-safe and action-safe areas appear in the viewer.

Create a custom overlay
You can create custom overlays tailored to the needs of your project. See examples of custom overlays below.

1. Create a custom overlay image in an image editing app.
   It's best to create an image with an alpha channel (in which the reserved areas are opaque and the safe areas are transparent). The image pixel dimensions or aspect ratio should match that of your project settings.

2. Save the image in a format that supports alpha channels, such as PNG.

You can use custom overlays to do any of the following:

- Edit your video in an aspect ratio that differs from the aspect ratio of the original footage.

You can use a custom overlay to make sure your video will look correct when it's released in its final aspect ratio. For example, many film and TV productions are shot at a 16:9 aspect ratio, but then later released with other aspect ratios, such as 1.85:1 or 2.35:1.

The example below uses an image with a 16:9 aspect ratio, but the custom overlay adds opaque bars at the top and bottom to create a “letterbox” matte with a 2.35:1 aspect ratio.
Note: Using a custom overlay is the best way to change the aspect ratio because it allows you to reframe (reposition) or scale up (zoom in to) the image without affecting the aspect ratio (the edges of the video frame). If you’re not making editorial changes like those, you can also use the Letterbox effect to change the aspect ratio. See Add video effects.

- Hide unsightly “window burn-ins” (of timecode, filenames, and camera information) that might distract you from the editorial process.

- Reserve an area of the screen for a logo or graphic that hasn’t been produced yet. Custom overlays are particularly useful for the various vertical and square aspect ratios common in social media video projects.
Add a custom overlay

1. Create a custom overlay image.

2. In Final Cut Pro, create a new project or open an existing project.

3. To import the custom image and add it as an overlay, click the View pop-up menu in the upper-right corner of the viewer, choose Choose Custom Overlay > Add Custom Overlay, then navigate to the image file and click Open.

   Your custom overlay appears in the viewer.

4. Do any of the following:
   - Adjust the opacity (transparency) of the overlay: Click the View pop-up menu in the upper-right corner of the viewer and choose Show Custom Overlay, then choose a percentage from the Opacity submenu.
   - Turn off (disable) a custom overlay: Click the View pop-up menu in the upper-right corner of the viewer, then choose Show Custom Overlay (so there's no checkmark next to it).
   - Turn on a previously added custom overlay: Click the View pop-up menu in the upper-right corner of the viewer and choose Choose Custom Overlay, then choose the overlay from the submenu.

Background rendering in Final Cut Pro for Mac

Rendering is the process of creating temporary video and audio render files for segments of your project that Final Cut Pro can’t play in real time. When you add effects, transitions, generators, titles, and other items that require rendering for playback at high quality, the render indicator (a light gray dotted line) appears below the ruler at the top of the timeline.

By default, rendering begins in the background 0.3 seconds after you stop working and moving the pointer in Final Cut Pro. You can turn off background rendering or adjust this setting in Final Cut Pro settings (see Playback settings).

You can also manually control rendering for a project or a portion of a project, and you can delete render files for one or more projects, events, or libraries to free up storage space. See Manage render files.
Play back slow-motion clips in Final Cut Pro for Mac

To create high-quality slow-motion effects, you can use your video camera or iPhone to record video at high frame rates—those in excess of the standard 30 frames per second (fps). For example, iPhone can record video at up to 240 fps in Slo-mo mode. The resulting slow-motion clips appear in the Final Cut Pro browser with an icon to indicate that they were recorded at a high frame rate (95 fps or above).

Organize your library

Intro to libraries in Final Cut Pro for Mac

A library contains multiple events and projects in the same location. When you import video, audio, and still images, or record directly into Final Cut Pro, the source media files (your raw footage) appear as clips in one or more events in the library. An event is similar to a folder that can hold projects as well as dozens, hundreds, or even thousands of video clips, audio clips, and still images. Each event in the library refers to media on your Mac or storage device, and a database file keeps track of where everything is.

When you select an event in the library, the media it contains appears as clips in the browser. You select clips or portions of clips in the browser to work with them. You can sort clips in the browser by creation date, as well as by date imported, reel, scene, clip duration, and file type.
As your library grows, you can rename, copy, move, and delete your clips, events, and projects as necessary. You can have multiple libraries open at the same time, and you can easily copy events and projects between libraries. For more information about managing multiple libraries, see Intro to managing libraries.

Organize your projects, events, and media

Create a new event in Final Cut Pro for Mac

After importing your source media files into Final Cut Pro, you may find that you need to create additional events to organize your media. For example, after importing media shot for a production, you may decide to split the media into events defined by useful categories—shooting locations, scenes, episodes, and so on.

By giving your events descriptive names, such as “2017 Smith Wedding,” you can organize all of your media so that it’s readily accessible.

1. In the Libraries sidebar in Final Cut Pro, select the library in which you want to create a new event.
2. Choose File > New > Event (or press Option-N).
3. In the window that appears, type a name for the event, click the Library pop-up menu and choose a library to hold the event, then click OK (or press Return).
   
   If you want to include a new, untitled project, select the Create New Project checkbox. To customize settings for the new project, click Use Custom Settings. See Modify a project’s settings.

   The new event appears in the selected library.
4. Move clips from other events into the new event, as necessary.

Rename items in Final Cut Pro for Mac

You can rename clips, projects, and events.

Renaming a clip affects only that instance of the clip. For example, if you add a clip from the browser to the timeline, copy clips between events, or copy clips within the timeline, each of these clip instances (copies) is independent of the others and can have its own name.

Important: Renaming a clip in Final Cut Pro does not rename the clip’s source media file on your Mac or storage device.

Rename a clip or project in the browser

In the Final Cut Pro browser, do any of the following:

- Rename a clip or project in filmstrip view: Click the clip’s or project’s name, then type a new name.
- Rename a clip or project in list view: Click the clip’s or project’s name, press Return, then type a new name.

For more information about filmstrip view and list view, see Intro to browser views.

You can also rename a project in project settings. See Modify a project’s settings.
Rename a clip in the timeline
• In the Final Cut Pro timeline, Control-click the clip and choose Rename Clip, then type a new name.

Rename an event
1. In the Libraries sidebar in Final Cut Pro, select the event you want to rename.
2. Do one of the following:
   • Click the event’s name and type a new name.
   • Press Return and type a new name.

Rename a clip in the timeline index
1. To open the timeline index in Final Cut Pro, click Index in the top-left corner of the timeline (or press Shift-Command-2).
2. Click the Clips button at the top of the timeline index.
3. Select the Name field for a clip, click again (or press Return), then type a new name.

Rename a clip in the Info inspector
1. In Final Cut Pro, select a clip in the browser or the timeline.
2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button in the toolbar.
3. Click the Info button at the top of the inspector.

4. Click in the Name field and type a new name.

**Merge and split events in Final Cut Pro for Mac**

You can merge (combine) two or more events in a library (for example, if the media and projects they contain are very closely related). If you find an event is getting bulky and unmanageable, you can split it into multiple events.

You can also sort events in the Libraries sidebar by name or date.

**Merge multiple events**

1. In the Libraries sidebar in Final Cut Pro, do one of the following:
   - Drag one or more events to an event you want to combine them with.
   - Select the events you want to combine, then choose File > Merge Events.

   The events are merged into a single event in the library. The corresponding source media files remain in their original locations, either in the library file or linked from external folders.

2. Select the merged event and type a new name.

**Split an event into multiple events**

1. In Final Cut Pro, create the new events you need.

2. Drag the clips and projects you want to relocate from the original event to the new events.

   The corresponding source media files remain in their original locations, either in the library file or linked from external folders.
Sort events by name or date
1. In Final Cut Pro, do one of the following:
   - Sort events by name: Choose View > Sort Library Events By > Name.
   - Sort events by date: Choose View > Sort Library Events By > Date.
2. To change the sort order, do one of the following:
   - Set an ascending sort order: Choose View > Sort Library Events By > Ascending. This option sorts the events in alphabetical or chronological order.
   - Set a descending sort order: Choose View > Sort Library Events By > Descending. This option sorts the events in reverse alphabetical or chronological order.

Move items between events in Final Cut Pro for Mac
You can copy and move clips and projects from one event to another.

For information about copying and moving clips, projects, and events to other libraries, see Copy or move items between libraries.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the clips or projects you want to copy or move.
2. In the browser, select the clips or projects you want to copy or move.
   Note: You can't select clips and projects at the same time.
3. Do one of the following:
   - Copy the items: Option-drag the items from one event to the other by first starting to drag and then holding down the Option key as you drag.
   - Move the items: Drag the items from one event to the other.

The event to which you copy or move the clips may be re-sorted in the library.

Duplicate projects and clips in Final Cut Pro for Mac
Duplicating projects and clips is a fundamental technique in your editing workflow. For example, you can duplicate a project to work on a new version of it. You can also duplicate a project and change its settings (such as the aspect ratio) at the same time.

If you work on projects that contain compound clips and multicam clips, you can use the Snapshot Project command to create a self-contained backup version of a project that includes referenced compound clips or multicam “parent” clips. Changes you make to other instances of the compound clips or multicam clips do not affect the versions in the duplicate, so your project is protected from accidental changes. For more information about compound clips and multicam clips, see Intro to compound clips and Intro to multicam editing.
**Duplicate projects and clips**

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the clips or projects you want to copy.
2. In the browser, select the clips or projects you want to copy.
   
   *Note:* You can't select clips and projects at the same time.
3. Choose Edit > Duplicate (or press Command-D).

   The duplicate items appear in the browser next to the originals.

**Duplicate projects as snapshots**

When you duplicate a project as a snapshot, Final Cut Pro embeds copies of compound or multicam “parent” clips in the duplicate, so any changes to other instances of those clips do not affect the duplicate.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the project you want to duplicate as a snapshot.
2. In the browser, select the project you want to copy.
3. Choose Edit > Snapshot Project (or press Shift-Command-D).

   The duplicate project appears in the browser with the word “Snapshot” and the date and time appended to the project name.

**Duplicate a project and change the project settings**

You can use the Duplicate As command to quickly and easily create a copy of a project with different project settings. This is useful for creating a new version of a project with a different aspect ratio. For example, you might want to create a square version of a horizontal project for social media delivery.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the project you want to duplicate.
2. In the browser, select the project you want to copy.
3. Do one of the following:
   - Choose Edit > Duplicate Project As.
   - Control-click the project in the browser, and choose Duplicate Project As.
4. In the window that appears, enter a project name and specify the settings for the duplicate project.

   If you change the aspect ratio, the Smart Conform checkbox appears. Smart Conform analyzes clips for faces and other areas of visual interest, and then uses the analysis to reframe clips that have a different aspect ratio from the project aspect ratio.
5. If you want Final Cut Pro to automatically reframe clips using Smart Conform, select the Smart Conform checkbox.

   See Adjust framing with Smart Conform.
6. Click OK.

   Final Cut Pro creates the new project. If you selected Smart Conform, Final Cut Pro enables overscan view for reframed clips, revealing areas of a clip that extend beyond the edge of the viewer. You can make further framing adjustments manually using the Transform effect. See Resize, move, and rotate clips.
Delete items from libraries in Final Cut Pro for Mac

You can delete unwanted clips and projects. You can also delete an entire event from your library to free up storage space. When you delete a clip or a project from an event, or delete an entire event, the source media files are moved to the Trash. There’s one exception: Media that is being used by other projects in your library always remains in the library.

Note: Libraries must contain at least one event.

1. In the Libraries sidebar in Final Cut Pro, select the event you want to delete or delete items from.
2. Do one of the following:
   - Delete items from the event: Select the clips or projects you want to remove, then choose File > Move to Trash (or press Command-Delete).
     Note: You can’t select clips and projects at the same time.
   - Delete the entire event: Choose File > Move Event to Trash (or press Command-Delete).

The selected items are deleted. To permanently delete the source media files from your Mac or storage device, empty the Trash.

WARNING: After the Trash is emptied, the deleted clips and their associated source media files can’t be restored.

View and sort items in the browser

Intro to browser views in Final Cut Pro for Mac

In Final Cut Pro, you can display your clips and projects in the browser in two views:

- Filmstrip view: Displays the clips in the selected event as a connected series of thumbnail images. Projects appear as thumbnail images with a superimposed clapboard design. Filmstrip view is useful when you want to visually locate your clips and projects.
• **List view:** Displays a list of your clips and projects with associated file and settings information. Use this view when you want to view or sort clips and projects by data such as duration, creation date, last modified date, rating, keywords, and so on. When you select a clip in list view, a filmstrip for the selected clip appears at the top of the browser. The clip filmstrip is fully interactive, allowing access to start and end points, markers, and keywords.

Customize browser views in Final Cut Pro for Mac

In the Final Cut Pro browser, you can switch between filmstrip view and list view, and customize the appearance and layout of each view.

To create and save custom arrangements of columns in list view, see [Create and share column sets](#).

**Switch between filmstrip view and list view**

• In Final Cut Pro, click the List View button ↓ or the Filmstrip View button ➡ in the top-right corner of the browser.
Customize filmstrip view

1. In Final Cut Pro, click the Clip Appearance button above the browser.

2. Do any of the following:

   • *Adjust the time represented by each thumbnail in a clip’s filmstrip:* Drag the Duration slider.

   Adjusting the Duration slider expands and contracts the amount of detail shown in each clip’s filmstrip. The longer each thumbnail’s duration, the fewer thumbnails each clip displays, and the more clips are displayed in the browser.
• Adjust the filmstrip height: Drag the Clip Height slider.

• Turn audio waveforms on or off: Click the Waveforms checkbox.

When audio waveforms are on, they appear at the bottom of each clip’s filmstrip, increasing the height of all clips in the browser.
• *Play clips in the browser without interruption:* Select the Continuous Playback checkbox. When this checkbox is selected, all clips in the browser play through without interruption (rather than stopping playback at the end of each clip). Alternatively, choose View > Browser > Continuous Playback.

**Customize list view**

With the Final Cut Pro browser in list view, do any of the following:

- *Choose what type of information is displayed:* Control-click a column heading in the browser, then choose a type of information to display.

- *Rearrange columns:* Drag a column heading to move the column to a new position.

- *Sort clips by a category:* Click a column heading to sort clips by that category.

- *View an item’s keywords, rating, or marker text:* Click the disclosure triangle to the left of the clip’s name.

![List View Example](image)

The disclosure triangle also appears if a portion of the clip is used in a project, and the browser is set to show used media. (To indicate used portions of clips in the browser with an orange line, choose View > Browser > Used Media Ranges.)

**Sort and group items in the browser in Final Cut Pro for Mac**

You can sort clips and projects in the browser so that it’s easier to locate them.

**Sort and group items in the browser**

1. In the Libraries sidebar in Final Cut Pro, select the event whose items you want to sort.
2. Click the Clip Appearance button above the browser, then do any of the following:
• **Group clips by category:** Click the Group By pop-up menu and choose a category. To set the sort order, click the pop-up menu again and choose either Ascending or Descending.

• **Choose how clips are sorted in filmstrip view:** Click the Sort By pop-up menu and choose an option. You can sort clips by date, name, take, or duration. To set the sort order, click the pop-up menu again and choose either Ascending or Descending.
  
  *Note:* In list view, click a column heading to sort clips by that category. See [Customize list view](#).

**Reset the sort order in the browser**
You can reset the browser sort order to its default state.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the items whose sort order you want to reset.
2. Click the Clip Appearance button ` Britt ` above the browser.
3. Click the Group By pop-up menu and choose Ascending, then click the pop-up menu again and choose None.
4. Click the Sort By pop-up menu and choose Content Created, then click the pop-up menu again and choose Ascending.

**Create and share column sets in Final Cut Pro for Mac**
With the browser in list view, you can save any combination of column settings as a new custom column set. The column settings include available columns, column order, column width, column visibility, and custom metadata fields.

You can easily copy column sets to another computer, or share them with friends and colleagues so that the same column sets are available in their browser.

**Save a column set in the browser**
1. In the Final Cut Pro browser in list view, arrange the columns the way you want them to appear in your column set.
   See [Customize list view](#).
2. Control-click any column heading in the browser, then choose Save Column Set As from the shortcut menu.
3. Enter a name for the column set, then click Save.
   The new column set is added to the shortcut menu, in alphabetical order.

**Switch between column sets**
After you create one or more column sets, you can easily switch between them.

• In the Final Cut Pro browser in list view, Control-click any column heading, then choose another column set from the shortcut menu.
Edit column sets

1. In the Final Cut Pro browser in list view, Control-click any column heading, then choose Edit Available Columns from the shortcut menu.

2. In the Column Set Editor window, do any of the following:
   - *Create a column set:* Click the Action pop-up menu in the lower-left corner and choose New Column Set, then enter a name for the new set.
   - *Edit a column set:* In the list on the left side of the window, select the set you want to edit, then select the properties you want to include in the set from the Property list. You can also use the Properties pop-up menu and the search field at the top of the window to filter and search for metadata to include in the Property list.
     You can add any metadata properties to a column set, including custom metadata fields. See View and change clip metadata and Modify metadata views.
     *Note:* The Default Column Set can't be modified. To make a new version of the Default Column Set, edit a duplicate set.
   - *Duplicate a column set:* In the list on the left side of the window, select the set you want to duplicate, then click the Action pop-up menu in the lower-left corner and choose Duplicate Column Set. Enter a name for the new set, then click OK.
   - *Delete a column set:* In the list on the left side of the window, select the set you want to delete, then click the Action pop-up menu in the lower-left corner and choose Delete Column Set.

Restore the default set of columns in the browser

- In the Final Cut Pro browser in list view, Control-click any column heading, then choose Default Column Set from the shortcut menu.

Share a column set

1. In the Final Cut Pro browser in list view, Control-click any column heading, then choose Reveal in Finder from the shortcut menu.
   The Column Sets folder, with all the custom column sets you created, opens in the Finder.

2. In the Finder, select the column set file, then choose File > Compress.
   *Note:* Compressing the file prevents any change to the column set during transit.

3. Transfer the resulting ZIP file to your friend or colleague using email or another convenient method.

4. On the receiving Mac, double-click the ZIP file to open it.

5. In the Finder, press and hold the Option key and choose Go > Library.

6. Drag the column set file to the following location in the Library folder:
   /Users/username/Library/Application Support/Final Cut Pro/Column Sets/
   The new column set appears in the shortcut menu when you Control-click any column heading in the browser.
Organize clips

Rate clips in Final Cut Pro for Mac

If your clips contain sections that you don’t like or might never want to use in a project—because they’re blurry, for example—you can mark them as rejected. You can easily rate the clips you like and don’t like as you review them. When you’re ready to edit your project, you can focus on your best footage by choosing to display only those clips you marked as favorite. You can also delete your rejected clips’ source media files to free up storage space.

Rate clips

1. In the browser in Final Cut Pro, select a range, a clip, or multiple clips you want to rate.
2. Do one of the following:
   - If you like the selection: Press the F key (or choose Mark > Favorite).
     In the browser, a green line appears at the top of frames you’ve marked as favorite.
   - If you don’t like the selection: Press the Delete key (or choose Mark > Reject).
     A red line appears at the top of frames you’ve marked as rejected.

Note: If you chose Hide Rejected from the Filter pop-up menu at the top of the browser, clips marked as rejected disappear from view. See Find clips and projects.
Remove ratings from clips
1. In Final Cut Pro, make sure the clips you want to work with appear in the browser.
   You might need to choose a new option, such as All Clips, from the Filter pop-up menu at the top of the browser so that all the clips you need to access are visible. See Find clips and projects.

2. In the browser, select the clips whose rating you want to remove, and press the U key (or choose Mark > Unrate).
   The green or red line at the top of the clips disappears.

   Note: An orange line along the bottom of an event clip indicates that the clip is being used in the current project (the project that is open in the timeline). To turn this view on or off, choose View > Browser > Used Media Ranges. For more information about these markings, see Lines marking event clips.

Add keywords to clips in Final Cut Pro for Mac
You can apply keywords to your clips to help you quickly locate the clips you need to compose your movie. After you apply a keyword to a clip or clip range, the clip or range is marked with a blue line in the browser. (Clips that have analysis keywords, which are automatically applied after certain types of analysis, are marked with a purple line. See Intro to analyzing media.)

Additionally, when a keyword is applied to a clip or clip range, a Keyword Collection appears in the Libraries sidebar. A Keyword Collection contains pointers (aliases) to clips tagged with a specific keyword. For example, if you apply the keyword “water” to all clips containing water, you can then select the “water” Keyword Collection in the Libraries sidebar to view all clips containing the “water” keyword in the browser.
You can apply one or more keywords to a range within a clip, a whole clip, or a group of clips in an event.

Note: If you used project folders in the Project Library in previous versions of Final Cut Pro and you updated those projects to Final Cut Pro 10.1 or later, the projects have keywords reflecting the names of the project folders.

Add keywords using the keyword editor
1. In the browser in Final Cut Pro, select a range or one or more clips to which you want to add keywords.
2. To open the keyword editor, click the Keywords button in the toolbar.
3. At the top of the keyword editor, type the keyword or keyword phrase you want to apply to the selection, then press Return.
4. Repeat step 3 for each keyword or keyword phrase you want to add to the selection.

   A blue line appears at the top of the selection in the browser, indicating that keywords have been applied to it.

5. When you're finished adding keywords, close the keyword editor.

Add keywords using keyboard shortcuts

To add keyword phrases to your clips using keyboard shortcuts, you must first assign keywords and keyword phrases to the keyboard shortcuts.

1. If the keyword editor isn't open in Final Cut Pro, click the Keywords button in the toolbar.

2. In the keyword editor, click the disclosure triangle to the left of Keyword Shortcuts to reveal the keyword shortcut fields.

3. Type a keyword or phrase in each shortcut field, then press Return.

   To reassign a keyboard shortcut, select the shortcut text in the field and type the new keyword.

4. To use a keyboard shortcut, select a range or one or more clips to which you want to add keywords, then press Control and the corresponding number key (1 through 9).
Add keywords by dragging clips to Keyword Collections

A quick and easy way to add keywords to one or more clips is to drag the clips from the browser to existing Keyword Collections.

To create a Keyword Collection, see Add keywords using the keyword editor, above.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the clips you want to add keywords to.

2. In the browser, select the clip or clips that you want to apply the keyword to.

3. Drag the selection to the Keyword Collection in the Libraries sidebar that corresponds to the keyword you created.

   The keyword is applied to the clips. Instances of the clips appear in the Keyword Collection.

View keywords applied to clips

In Final Cut Pro, do any of the following:

• Quickly identify clips that have keywords: Select an event in the Libraries sidebar.

   Clips that have one or more keywords appear in the browser marked with a blue line at the top.

   You can also create a Smart Collection for all clips that have keywords applied.

• View all keywords applied to a clip: Choose View > Browser > Skimmer Info (or press Control-Y), then skim the clip in the browser.
You can also view a clip’s keywords by selecting the clip in the browser and clicking the Keywords button in the toolbar (or pressing Command-K).

The keywords applied to the clip are shown in the keyword editor.

- *View all the clips that have a specific keyword:* Select a Keyword Collection in the Libraries sidebar. The clips with that keyword appear in the browser.

### Remove all keywords from a selection

1. In the browser in Final Cut Pro, select a range or one or more clips from which you want to remove keywords.

   A blue line at the top of the clips indicates the portions of the clips that have keywords applied.

2. Choose Mark > Remove All Keywords (or press Control-0).

### Remove a subset of keywords from a selection

1. In the browser in Final Cut Pro, select a range or one or more clips from which you want to remove specific keywords.

   A blue line at the top of the clips indicates the portions of the clips that have keywords applied. Each keyword assigned to a clip also appears in the browser in list view.

2. Click the Keywords button in the toolbar (or press Command-K) to open the keyword editor, then select the keyword or keywords you want to remove and press Delete.

**Tip:** To create a Keyword Collection for an entire library, create a library Smart Collection using one or more keywords as the search criteria.
Add clip and project notes in Final Cut Pro for Mac

As you review your clips and projects, you can add and edit notes about them in the browser (or, in the case of timeline clips, in the timeline index). You can quickly find these items later by entering the note text in the search field in the browser or the timeline index, or in the Text field in the Filter window. For information about text searches, see Find clips and projects.

Note: You can add notes to each instance of a clip or project. For example, if you copy clips or projects between events or libraries, add a clip from the browser to the timeline, or copy clips within the timeline, each of these clip or project instances (copies) is independent of the others.

Add or edit clip and project notes in the browser

1. If the browser isn’t already in list view in Final Cut Pro, click the List View button in the top-right corner of the browser.

2. Select the clip or project for which you want to add or edit notes.

   Note: Notes are applied to clips and projects as a whole, not to range selections.

3. Click the Notes field for the clip, then type or edit the notes for that clip.

<table>
<thead>
<tr>
<th>Start</th>
<th>End</th>
<th>Duration</th>
<th>Content Created</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>00:00:01:15</td>
<td>00:00:06:21</td>
<td>00:00:05:06</td>
<td>Jul 6, 2016, 6:18:47 PM</td>
<td></td>
</tr>
<tr>
<td>00:00:00:05</td>
<td>00:00:16:02</td>
<td>00:00:15:27</td>
<td>Jul 6, 2016, 6:18:33 PM</td>
<td>Good take</td>
</tr>
<tr>
<td>00:00:00:09</td>
<td>00:00:07:01</td>
<td>00:00:06:22</td>
<td>Jul 6, 2016, 6:17:53 PM</td>
<td></td>
</tr>
</tbody>
</table>

Add or edit clip notes in the timeline index

1. To open the timeline index in Final Cut Pro, click Index in the top-left corner of the timeline (or press Shift-Command-2).

2. To open the Clips pane, click the Clips button at the top of the timeline index.
3. If the Notes column isn’t visible in the Clips pane, Control-click a column heading and choose Notes.

4. Click the Notes field for the clip, then type or edit the notes for that clip.

Organize clips by roles in Final Cut Pro for Mac

You can organize clips by roles, which are metadata text and color labels assigned to clips.

When you import clips (video, audio, or still images), Final Cut Pro automatically assigns one of five default roles to the video and audio components of each clip: Video, Titles, Dialogue, Music, and Effects. You can also create custom roles and subroles, and assign them to clips.

You can use roles in Final Cut Pro to organize clips in your events and projects by function or category, control the arrangement of the timeline, and export separate video or audio files (also known as media stems) for distribution, broadcast, audio mixing, or post-production. Roles have distinct colors that let you instantly recognize clips from particular roles in the browser and the timeline.

You can view and reassign roles in the browser, the timeline, or the inspector. For example, you could easily identify all your dialogue clips and play them back in isolation from other audio clips. See View and reassign default roles.
Lines marking event clips in Final Cut Pro for Mac

In Final Cut Pro, lines appear on clips and ranges in the browser to help you see at a glance if they’re marked as favorite or rejected, have keywords applied, or are being used in the current project. The color of the line indicates the type of marker.

To turn marker lines on or off, choose View > Browser > Marked Ranges.

<table>
<thead>
<tr>
<th>Color</th>
<th>Description</th>
<th>More information</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Green Line]</td>
<td>A green line indicates that you’ve marked a clip as favorite.</td>
<td>See Rate clips.</td>
</tr>
<tr>
<td>![Red Line]</td>
<td>A red line indicates that you’ve marked a clip as rejected.</td>
<td>See Rate clips.</td>
</tr>
<tr>
<td>![Blue Line]</td>
<td>A blue line indicates that a clip has manually applied keywords or keywords imported with the media file.</td>
<td>See Add keywords.</td>
</tr>
<tr>
<td>![Purple Line]</td>
<td>A purple line indicates that a clip has one or more analysis keywords.</td>
<td>See View analysis keywords.</td>
</tr>
<tr>
<td>![Orange Line]</td>
<td>An orange line along the bottom of an event clip indicates that the clip is being used in the project currently open in the timeline.</td>
<td>See Intro to adding clips. To turn this view on or off, choose View &gt; Browser &gt; Used Media Ranges.</td>
</tr>
</tbody>
</table>

⚠️ Tip: To select a clip range marked with a line, click the line.
Find items using search, keywords, and Smart Collections

Find clips and projects in Final Cut Pro for Mac

In Final Cut Pro, you can search for media in the browser in several ways:

- **Quickly filter clips**: Use the Filter pop-up menu to locate clips by rating (for example, clips you’ve rated as favorite). You can also locate unused clips and clips with neither ratings nor keywords.
- **Search notes, names, or markers**: Use the browser search field to quickly find clips and projects by text in notes, names, or markers.
- **Search using a combination of criteria**: Use the Filter window to perform complex searches for clips and projects, also known as weighted searches. You can search by a wide variety of criteria, including clip or project name, rating, media type, used media, excessive shake, keywords, the presence of people, format information, date, roles, and item type (audition, synced clip, compound clip, multicam clip, layered graphic, or project).

Note: You can also use the timeline index to search and filter items in the timeline. See Search for items in the timeline index.

Filter clips quickly by rating

1. In the Libraries sidebar in Final Cut Pro, select a library or one or more events or folders you want to filter by rating.
2. Click the Filter pop-up menu at the top of the browser and choose an option.

- **All Clips**: Shows all clips in the event.
- **Hide Rejected**: Shows all clips or range selections except those you’ve rated as rejected.
- **No Ratings or Keywords**: Shows only the clips or range selections without ratings or keywords.
- **Favorites**: Shows only the clips or range selections you’ve rated as favorite.
- **Rejected**: Shows only the clips or range selections you’ve rated as rejected.
- **Unused**: Shows only the clips or range selections that are not used in a project, compound clip, multicam clip, or synced clip.
Search for clips or projects by text in notes, names, or markers

1. In the Libraries sidebar in Final Cut Pro, select a library or one or more events or folders you want to search.
2. Click the Search button at the top-right corner of the browser.
3. In the search field, enter the text you want to search for.

As you type, the search results update in the browser. By default, Final Cut Pro searches text in notes, clip and project names, and markers.
4. If you want to search only notes, names, or markers, click the Search button at the left side of the search field and choose an option.

Search for clips and projects by a combination of criteria

You can search for clips and projects by multiple search criteria. For example, you can search for video clips or projects that are rated as favorite and contain the text “exterior” or “wide shot” in their metadata.

1. In the Libraries sidebar in Final Cut Pro, select a library or events or folders you want to search.
2. Click the Search button at the top-right corner of the browser.
3. Click the Filter button to the right of the search field.
4. In the Filter window, click the Add Filter pop-up menu and choose search criteria.
• **Text:** Find clips or projects by their name or by text in notes and markers. You can add multiple Text filters to search using more than one word or phrase, as well as exclude specific words and phrases from the search.

• **Ratings:** Find clips based on the rating (favorite or rejected) assigned to them. See [Rate clips](#).

• **Markers:** Find clips by markers, including descriptive text and whether to-do markers are complete or incomplete. See [Edit and move markers](#).

• **Media Type:** Find clips by the type of source media file, such as video, audio, or still image.

• **Type:** Find items by their type, such as audition, synced clip, compound clip, multicam clip, layered graphic, or project.

• **Used Media:** Find clips based on whether they’re used in a project, compound clip, multicam clip, or synced clip.

• **Keywords:** Find clips by any of the keywords that you’ve assigned to them. You can select one or more keywords to search for. See [Add keywords](#).

• **People:** Find clips that Final Cut Pro has identified as having people in them. Options include One Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot. See [Video analysis options](#).

• **Format Info:** Find clips or projects using format information, such as video frame rate or scene number.

• **Media Representation:** Find clips by the available media representation: Original, Optimized, or Proxy.

• **Date:** Find clips or projects by either the date the item was created or the date the media was imported into Final Cut Pro.

• **Roles:** Find clips by their assigned roles. See [Intro to roles](#).

To remove a filter, click the Remove button to the right of the filter. To exclude a filter from your search without removing it, deselect its checkbox.

5. Further refine your search by choosing items from the pop-up menus for the filters you’ve added.

6. Do one of the following:

   • **Specify that an item must match at least one of the search criteria or keywords:** Click the pop-up menu in the upper-left corner of the Filter window, then choose Any.

   • **Specify that an item must match all the search criteria and keywords:** Click the pop-up menu in the upper-left corner, then choose All.

The items that match the search criteria are displayed in the browser.

If you wish, you can save your search results as a Smart Collection, which gathers items automatically based on the search criteria.

To clear the search criteria, click the Reset button in the browser search field.
Find clips using both searching and filtering
In Final Cut Pro, performing a search and then filtering the results in the browser by rating is a powerful way to quickly find clips. This is also the best way to find specific clips that you haven’t rated and compare them to clips you have rated.

1. In the Libraries sidebar in Final Cut Pro, select the library, events, or folders you want to search.
2. Search for clips using a combination of search criteria, as described above.
   However, don't apply a ratings filter using the Filter window.
3. Filter clips by rating, as described above.
4. Repeat step 3 until you find all the clips you’re looking for.

Create Smart Collections in Final Cut Pro for Mac
When you search for clips or projects in a library or an event using the Filter window, you can save your results by creating a new Smart Collection that gathers items matching the search criteria. Anytime a new item that matches the Smart Collection's search criteria is brought into the event or library, the new item is automatically added to the Smart Collection.

A Smart Collection created from a library appears in the library’s Smart Collections folder in the Libraries sidebar. A Smart Collection created from an event appears below the event.

Clips and projects that appear in Smart Collections are not duplicates. Smart Collections filter items in an event or library to help you focus on the items you need to use for a specific task.

Create a Smart Collection based on search criteria
1. In the Libraries sidebar in Final Cut Pro, select the library or one or more events or folders you want to search.
   Note: If you select multiple events or folders, Final Cut Pro creates a library Smart Collection in the Smart Collections folder for that library.
2. Do one of the following:
   - Use the Filter window to search for clips or projects based on specified criteria, then click the New Smart Collection (or New Library Smart Collection) button in the Filter window.
   - Choose File > New > Smart Collection or File > New > Library Smart Collection (or press Option-Command-N).
     If you create the Smart Collection using this method, you need to double-click the Smart Collection to open the Filter window and enter your search criteria.
     A new, untitled Smart Collection appears in the event or in the library Smart Collections folder.
3. Type a name for the Smart Collection, then press Return.
Change the contents of a Smart Collection

1. In Final Cut Pro, double-click the Smart Collection whose contents you want to change. The Filter window for the Smart Collection appears.

2. Revise the search criteria in the Filter window.

3. When you're finished specifying search criteria, close the Filter window.

Note: If you modify a clip's ratings or keywords in such a way that the clip no longer matches a Smart Collection's search criteria, the clip is removed from the Smart Collection.

Delete a Smart Collection

1. In the Libraries sidebar in Final Cut Pro, select the Smart Collection you want to delete.

2. Choose File > Delete Smart Collection (or press Command-Delete).

The Smart Collection is removed from the library, but its associated items (the clips and projects that appeared in it) are unaffected.

Tip: To create a Keyword Collection for an entire library, create a library Smart Collection using one or more keywords as the search criteria.

Organize Smart Collections in Final Cut Pro for Mac

You can organize Keyword Collections and Smart Collections in events using folders, and you can copy collections between folders and between events.

Additionally, every library you create comes with a Smart Collections folder containing a default set of Smart Collections:

- All Video
- Audio Only
- Favorites
- Projects
- Stills

You can rename any collection and adjust its search criteria. You can also add or delete collections from the library Smart Collections folder, or delete the entire folder.
Organize collections with folders

1. In the Libraries sidebar in Final Cut Pro, select the event containing the collections you want to organize, then choose File > New > Folder (or press Shift-Command-N).

2. Type a name for the new folder that appears within the event, then press Return.

3. Select the Smart Collections and Keyword Collections you want to organize, then drag them into the new folder.

You can show and hide the contents of the folder by clicking the disclosure triangle to the left of the folder’s name.

Copy or move collections between events, libraries, and folders

In Final Cut Pro, do any of the following:

- **Copy a Smart Collection or Keyword Collection to another event, library, or folder:** Drag the collection to the new location.
  
  A copy of the collection appears in the destination event, library, or folder, and the collection’s search criteria are applied to the items at that location.

- **Move a Smart Collection or Keyword Collection to another event, library, or folder:** Drag the collection to the new location to create a copy there. To delete the original collection, select it and choose File > Delete Keyword Collection (or press Command-Delete).
  
  The collection appears in the destination event, library, or folder, and the collection’s search criteria are applied to the items in the new location.
Restore a library in Final Cut Pro for Mac

Final Cut Pro makes automatic library backups at regular intervals. Backups include the database portion of libraries only, not the media files. Backups are saved with the time and date in the filename.

By default, Final Cut Pro saves backups to the Final Cut Pro Backups folder in the Movies folder, but you can change the backup location. See Set storage locations.

Final Cut Pro automatically deletes library backups that are more than several days old.

1. In the Libraries sidebar in Final Cut Pro, select the library you want to restore.
2. Choose File > Open Library > From Backup.
3. Click the “Restore from” pop-up menu and choose a backup from a specific time and date, or click Other and navigate to a different backup file to open.
4. Click Open.
   The backup is added as a library in the Libraries sidebar.

Note: The backups are standard Final Cut Pro library files, so you can also open them by double-clicking them in the Finder. See Intro to managing libraries.
Edit your project

Intro to editing in Final Cut Pro for Mac

The term video editing refers both to broader stages of a project workflow and to very specific manual tasks that you do with clips in a project timeline.

- **Create a project:** To create a movie in Final Cut Pro, you first create a project, which provides a record of your editing decisions and the media you use. See [Create a new project](#).

- **Make selections and add clips to the timeline:** Adding and arranging clips in your project is the fundamental step in creating a movie with Final Cut Pro. You move and reorder clips in the timeline. See [Intro to adding clips](#), [Arrange clips in the timeline](#), and [Intro to audio](#).

- **Cut and trim clips:** Final Cut Pro provides a wide variety of tools for adjusting the start and end points of clips in the timeline and for controlling pacing from one shot to the next. See [Intro to trimming](#).

- **Further refine and adjust your project:** Final Cut Pro provides many advanced editing tools that allow you to finish a highly polished movie with ease. See the topics in the advanced editing section.

- **Add effects and color correction:** Finishing touches include visual effects and color correction. See [Intro to effects](#) and [Intro to color correction](#).
Create and manage projects

Create a new project in Final Cut Pro for Mac

To create a movie in Final Cut Pro, you first create a project, which provides a record of your editing decisions and the media you use.

When you create a new Final Cut Pro project, you do the following:

- Name the project.
- Specify the event where the project is stored.
  
  Often, you store projects in events that contain the media used to create the project. When you drag media into the timeline from the Finder, or when you access media in the Photos, Videos, and Audio sidebar and drag it to the timeline, that media is automatically located in the same event as the project.

Optionally, you can also set the starting timecode and define the video, audio, and render properties for the project.

After creating your project, you add clips to it from an event in the library.

Note: If you’re creating a project and you haven’t yet imported media into Final Cut Pro, you should do so. See Intro to importing media.

1. In the Libraries sidebar in Final Cut Pro, select the event in which you want to create the project.
   
   Tip: You can automatically create a project that has the video properties of a specific clip, without having to enter the project settings manually. In the browser, Control-click a clip and choose New Project, then enter a project name and click OK.
3. In the window that appears, type a name for the project in the Name field.
4. If you want to store the project in an event other than the selected event, click the In Event pop-up menu and choose a different event.
5. If you want your project’s timecode to start at a value other than 00:00:00:00, type a starting timecode value in the Starting Timecode field.
   
   Note: If the automatic settings are shown, you can click OK to create a new project at this point. You can add a clip to the new (empty) project timeline, and, if the clip properties match a built-in preset, Final Cut Pro sets the project properties to match the properties of the clip.
6. If you want to further customize settings for your project, click Use Custom Settings.
   
   Note: Final Cut Pro shows the automatic settings by default, but it retains the settings you used last, so this step may be unnecessary.

7. If you want to make any changes to the project’s video or audio properties, use the pop-up menus in the custom settings view.

8. Click OK.
   
   The new project appears in the browser with the name you gave it in step 4.

You can now add clips from the browser and begin to edit your project in other ways, adding titles, special effects, background music, sound effects, and more.

You can change a project’s properties at any time. See Modify a project’s settings.

## Open and close projects in Final Cut Pro for Mac

### Open a project

1. In the Libraries sidebar in Final Cut Pro, select the event containing the project you want to open.

2. Locate the project you want to open and double-click it.
   
   Note: You may have to scroll up to the top of the event to see the project.
   
   The project appears in the timeline.

### Close a project

In Final Cut Pro, do one of the following:

- Choose File > Close [project].
- Click the down arrow at the top of the timeline, then choose Close [project].

### Close all projects in the timeline history

During the course of an editing session, you might open multiple projects and switch between them using the arrow buttons at the top of the timeline. Or you might navigate compound clip levels using the arrow buttons. You can close all projects in the timeline history other than the currently visible one.

In Final Cut Pro, do one of the following:

- Choose File > Close Other Timelines.
- Click the down arrow at the top of the timeline, then choose Close Other Timelines.
Modify a project’s settings in Final Cut Pro for Mac

As your project evolves, you may decide to change its settings.

In most cases, Final Cut Pro manages project settings automatically based on the properties of the first clip you add to a project, but you can change almost all settings of an existing project. If you must modify the project settings, choose video and audio project settings based on how you intend to share your final movie with your audience.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the project you want to modify, then select the project (or double-click it to open it in the timeline).

2. Do one of the following:
   - Choose Window > Project Properties (or press Command-J).
   - Click the Inspector button in the toolbar.

3. In the Project Properties inspector, click the Modify button in the top-right corner.

4. In the window that appears, change the settings as appropriate.
   
   For a detailed list of all project settings, see Final Cut Pro project settings.

5. Click OK.

Create square or vertical versions of a project in Final Cut Pro for Mac

Popular social media platforms and websites allow for (and sometimes require) video clips with a variety of aspect ratios—such as square or vertical—for playback in an app or on the web. A relatively new post-production task is creating multiple versions of a project with different aspect ratios.

With Final Cut Pro, you can repurpose projects that have standard horizontal aspect ratios, such as those for film or TV, to create deliverables in all shapes and sizes, including square or vertical.
In the past, reframing each clip in a project for a new aspect ratio was a manual and time-consuming process. Final Cut Pro now speeds up this process with the Smart Conform feature, which analyzes the content of each clip for faces or other areas of visual interest, and automatically reframes clips that have a different aspect ratio from the project aspect ratio. You can use Smart Conform to quickly create a square or vertical version of a horizontal or widescreen project, and then make manual framing adjustments later.

1. In Final Cut Pro, open an existing horizontal project.
2. Select the project in the browser, and do one of the following:
   - Choose Edit > Duplicate Project As.
   - Control-click the project in the browser, and choose Duplicate Project As.
3. In the window that appears, enter a project name and specify the settings for the duplicate project. (Choose Vertical or Square from the Video Format pop-up menu.)
   When you change the aspect ratio, the Smart Conform checkbox appears.
4. To have Final Cut Pro analyze clips in the project and automatically reframe the clips whose aspect ratio differs from the project aspect ratio, select the Smart Conform checkbox.
   See Adjust framing with Smart Conform.
5. Click OK.
   Final Cut Pro creates the new project.
   If you selected Smart Conform, Final Cut Pro enables overscan view for reframed clips, revealing areas of a clip that extend beyond the edge of the viewer. You can make further reframing adjustments manually using the Transform effect. See Resize, move, and rotate clips.

You can add a custom overlay as an onscreen guide when placing text and graphics in the frame. Custom overlays are similar to title-safe and action-safe overlays, except that they can be customized to the needs of your project. This makes them useful for the various vertical and square aspect ratios common in social media. See Use overlays in the viewer.

**Project settings in Final Cut Pro for Mac**

You can change almost all settings of an existing Final Cut Pro project. See Modify a project's settings.
Project Name

- **Project Name**: Type a name for the project.

Starting Timecode

- **Starting Timecode**: If you want your project’s timecode to start at a value other than 00:00:00:00, type a starting timecode value.

Video

- **Format**: Choose the video format (a specific method of encoding the video) or an aspect ratio.
  
  _Note:_ If you choose 360° from the Format pop-up menu, the Projection Type pop-up menu appears. See [Intro to 360-degree video](#).

- **Resolution**: Choose the frame size of the video. Available frame sizes are dependent on the format. To enter an arbitrary frame size, click the Format pop-up menu and choose Custom.

- **Rate**: Choose the frames per second (fps).
  
  _Note:_ Unless the timeline is completely empty, you can’t change the frame rate of an existing project.

Rendering

- **Codec**: Choose the codec to use for your project’s background rendering.

- **Color Space**: Choose the color space for your project, including the color space of the project’s render files. The color space you choose should be the color space in which you intend to export for final delivery. When the color-processing setting in the Library Properties inspector is set to Wide Gamut HDR, wide-gamut settings appear in this menu. For standard formats, the rendering color space is chosen for you based on other settings. For example, setting the video format to NTSC SD automatically sets the color space to Standard - Rec. 601 (NTSC).
  
  _Note:_ This setting also determines the color space of the images sent to video scopes, the color space used to detect out-of-gamut colors, the color space of files exported using the Export File share option, and the color space of images that appear on your computer display.

Audio

- **Channels**: Choose whether to present the audio as multichannel surround sound or as stereo.

- **Sample Rate**: Choose the audio sample rate for your project (the number of times a signal is measured—or sampled—per second). A higher sample rate produces higher-quality audio and larger file sizes, and a lower sample rate produces lower-quality audio and smaller file sizes. The sample rate you choose depends on the source material you’re working with and the final destination of your audio.
Save and back up projects in Final Cut Pro for Mac

Final Cut Pro automatically saves all the changes you make as you work on a project, which means you never have to save changes manually. Also, you can undo all of your changes up to the last time you quit and reopened Final Cut Pro by choosing Edit > Undo (or pressing Command-Z).

You can create multiple versions of a project by duplicating it. See Duplicate projects and clips.

Changes you make to a clip in a project do not affect the clip's source file. Thus, if you've made a lot of changes to a clip but want to start fresh, you can easily restore the clip to its original state by adding a new copy of the clip (located in an event in the library) to your project.

In addition, Final Cut Pro makes automatic backups of your library at regular intervals. Backups include the database portion of libraries only, not the media files. Backups are saved with the time and date in the filename. See Restore a library.

Copy a Final Cut Pro for Mac project to another Mac

You can copy or move a project to another Mac to continue editing the project or to make a backup.

To copy a project to another Mac, you must copy the library that contains the project. Final Cut Pro libraries combine your editing projects, video clips, and associated metadata into a single package that's easy to transfer to another Mac.

If your library contains multiple projects, you can isolate the project and its media files before copying. If you already have copies of the project's media on the other Mac, you can copy just the library file containing the project, without the media files.

⚠️ Tip: If the project you want to copy is the only project in the library, you can simply copy the library. See Transfer a library to another Mac.

Isolate a project and its media files, then copy them to another Mac

If the Final Cut Pro project you want to copy is in a library with multiple projects and events, you can separate the project and its media files (or the entire event that contains it) from the rest of the library. This simplifies and speeds up copying the project to another Mac.

1. Connect an external storage device to your Mac.
2. In the Libraries sidebar in Final Cut Pro, select the event that contains the project you want to copy.
3. Do one of the following:
   - Copy just the project and its media: Select the project.
   - Copy the project and any other projects or media in the same event: Select the event.
5. Enter a name for the new library, choose a location for it, and click Save.
6. If your selection contains optimized or proxy media, select settings for copying optimized or proxy media in the window that appears, then click OK.

7. In the Libraries sidebar, select the new library that you just created.

8. To open the Library Properties inspector, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button in the toolbar.

9. In the Media section, make sure the media storage location is set to In Library, then click Consolidate.
   See Set storage locations.

10. If your project contains effects, transitions, titles, and generators that were created or customized in Motion, make sure the Motion Content storage location is set to In Library, then click Consolidate.
    Note: As an alternative, you could manually back up and copy the Motion Templates folder located in your Movies folder. Regardless, you must manually track and move any third-party (FxPlug) content, because it’s not managed within the Final Cut Pro library.

11. Quit Final Cut Pro.
    Important: Always make sure that Final Cut Pro is not open when you copy or move libraries in the Finder.

12. In the Finder, drag the library file to the icon for the connected external storage device.
    If you can’t find the library file in the Finder, open Final Cut Pro, select the library in the Libraries sidebar, then choose File > Reveal in Finder (or press Shift-Command-R).
    The library is copied to the external storage device.

13. When copying is complete, eject the external storage device and disconnect it from your Mac.

14. Connect the external storage device to the new (destination) Mac.

15. Drag the library file to the folder on the new Mac where you want to store the file.

16. To open the library, double-click its icon.

**Copy a project to another Mac without duplicating its media files**

If there are identical copies of your project’s source media files (and any effects, transitions, titles, and generators that were created or customized in Motion) on both the original (source) Mac and the new (destination) Mac, you can copy the relatively small project file only.

1. Connect an external storage device to your Mac.

2. In the Libraries sidebar in Final Cut Pro, select the library that contains the project you want to copy.
3. To open the Library Properties inspector, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button in the toolbar.

4. In the Storage Locations section, click Modify Settings if either Media or Motion Content is set to In Library.

5. In the window that appears, click the Media pop-up menu and choose a folder outside the library in which to store the media, then click Choose.

6. Click the Motion Content pop-up menu and choose “In Motion Templates folder,” then click OK.
   See Set storage locations.

7. In the Media section of the Library Properties inspector, click Consolidate.
   Final Cut Pro moves the media files from the library file to the external storage location you chose.

8. In the Motion Content section of the Library Properties inspector, click Consolidate.
   Final Cut Pro moves the Motion Content files from the library file to the Motion Templates folder located in your Movies folder.

9. Quit Final Cut Pro.
   **Important:** Always make sure that Final Cut Pro is not open when you copy or move libraries in the Finder.

10. In the Finder, drag the library file (which no longer contains any media files) to the icon for the connected external storage device.
    If you can't find the library file in the Finder, open Final Cut Pro, select the library in the Libraries sidebar, then choose File > Reveal in Finder (or press Shift-Command-R).
    The library is copied to the external storage device.

11. When copying is complete, eject the external storage device and disconnect it from your Mac.

12. Connect the external storage device to the new (destination) Mac.

13. Drag the library file to the folder on the new Mac where you want to store the file.

14. To open the library, double-click its icon.

   **Note:** You may need to relink clips to media files or reset the library storage location on the new Mac. See Relink clips to media files and Set storage locations. If a missing media alert icon appears in the Libraries sidebar, but you can't locate any offline clips, click the Filter pop-up menu at the top of the browser and choose All Clips. All clips (including the offline ones) become visible in the browser. See Find clips and projects.

   To move a project to another Mac rather than copying it, follow the instructions for copying a project, then delete the project from the original Mac.
Select clips and ranges

Selections and filmstrips in Final Cut Pro for Mac

A fundamental step in editing a video project is choosing what you want to include in your final movie. In Final Cut Pro, you indicate what clips or portions of clips you want to act on by making a selection. Final Cut Pro provides a variety of powerful tools for making selections with both speed and precision, including filmstrips, which are a connected series of thumbnail images. Your video clips appear as filmstrips in the timeline (where you build projects) and in the browser (where your source media is displayed). A single video filmstrip might represent several seconds of video encompassing hundreds of video frames (individual images). Audio-only clips appear as audio waveforms, showing the change in the audio volume over time.

When you add clips from the browser to a project in the timeline, you can add one or more whole clips, or you can add a range within a clip. Then you can fine-tune the clips individually in the timeline, adding video effects to them, for example, or inserting transitions between them.

You can adjust the appearance of filmstrips in the browser and the timeline so that it’s easier to make selections. For example, expanding the width of a filmstrip (by showing shorter durations per thumbnail) helps you make more precise selections. See Customize filmstrip view.

You can also adjust the filmstrip appearance in the timeline to make it easier to view and select audio waveforms.
Select clips in Final Cut Pro for Mac

Clips represent your video, audio, and graphics files and allow you to work with your media in Final Cut Pro without changing the files themselves. To add clips to your project, rearrange them, or trim them, you first need to select them. You can select a single clip or multiple clips at a time.

Selecting multiple clips allows you to move them as a group within your project, or from one event to another. It’s also useful if you’ve made adjustments to a clip and you want to copy effects and attributes between clips.

Select an entire clip in the browser
1. In the Libraries sidebar in Final Cut Pro, select an event.
2. In the browser, do any of the following:
   • Click the clip once.
   • Move the skimmer (or the playhead) over the clip, then press X.
     Note: This results in a range selection that matches the boundaries of the clip.
   • Press the Up Arrow key or Down Arrow key to move the selection to a neighboring clip.
   • Option-drag from the start point to the end point of the clip.
     Note: All selections in the browser are technically range selections (with adjustable start and end points).

Select an entire clip in the timeline
1. In Final Cut Pro, open an existing project.
2. In the timeline, do any of the following:
   • Click the clip once.
   • Move the skimmer (or the playhead) over the clip, then press X.
     Note: This results in a range selection that matches the boundaries of the clip.
   • Move the skimmer (or the playhead if skimming is turned off) over the clip you want to select, then press C. This method selects the clip in the primary storyline.

Connected clips and storylines are attached to clips in the primary storyline, and they appear above and below the primary storyline. To select a connected clip or storyline with this keyboard shortcut method, position the pointer on the connected clip, then press C. See Connect clips and Add storylines.
A yellow border appears around the clip, indicating that it's selected.

Note: A timeline clip selection (shown above) is different from a timeline range selection, which has visibly distinct range handles for adjusting the selection start point and end point. See Select ranges.

Select multiple clips in the browser or the timeline
In Final Cut Pro, do any of the following:

- Select a number of individual clips: Hold down the Command key as you click the clips you want to select.
  
  Note: Command-clicking a browser clip with preexisting ranges selects the ranges rather than the whole clip.

- Select all clips and ranges in the browser or the timeline: Click the browser or timeline to make it active, then choose Edit > Select All (or press Command-A).

- Select multiple clips by dragging: Drag a selection rectangle over the timeline or event clips you want to select.

Deselect clips in the browser or the timeline
In Final Cut Pro, do any of the following:

- Deselect a single clip: Command-click the clip or click outside it (or select a different clip).

- Deselect multiple clips: Hold down the Command key and click the clips you don’t want selected.

- Deselect all clips and ranges: Choose Edit > Deselect All (or press Shift-Command-A).

- Deselect all clips and clear all selected ranges in the browser: Press Option-X.
Select ranges in Final Cut Pro for Mac

Instead of selecting whole clips, you can select a range within any clip in the timeline or the browser. In the timeline, you can also select a range that spans multiple clips. You can trim range selections, mark them with ratings and keywords, and modify them in other ways. You can adjust the range selection start and end points by dragging either side of the selection. You can also create multiple range selections in one or more clips in the browser.

Note: This illustration shows a timeline range selection. Browser range selections have straight range handles.

Select a range in the browser

1. In the Libraries sidebar in Final Cut Pro, select an event.

2. In the browser, do any of the following:
   - Drag across any clip’s filmstrip.
     A yellow border appears around the range you selected.
     If the filmstrip wraps onto two lines, you can select a range extending over the break simply by continuing to drag across the break. When you reach the edge, the pointer jumps to the next line.
     Tip: Option-drag across any clip’s filmstrip with existing ranges to replace those ranges with a new range.
   - Use the I and O keys to set the range selection start and end points. See Set a range start point or end point, below.
   - Move the skimmer (or the playhead) over a clip, then press X.
     Final Cut Pro sets the range selection start and end points at the clip start and end points.
   - Click a marker line at the top of a clip.
     These marker lines can indicate any of the following: clips marked as favorite (green) or rejected (red), manually applied keywords (blue), or analysis keywords (purple).
Select a range in the timeline

1. In Final Cut Pro, open an existing project.

2. In the timeline, do any of the following:
   - Click the Tools pop-up menu in the top-left corner of the timeline and choose Range Selection (or press R).

   ![Range Selection tool](image)

   The pointer changes to the Range Selection tool. Drag the Range Selection tool across one or more clips to select a range. To adjust the range selection start and end points, drag the range handles on either side of the range.

   ❗ Tip: To temporarily switch to the Range Selection tool, hold down the R key. When you release the R key, the tool reverts to the previously active tool.

   - Use the I and O keys to set the range selection start and end points. See Set a range start point or end point, below.

   - Move the skimmer (or the playhead) over a clip, then press X.
     Final Cut Pro sets the range selection start and end points at the clip start and end points.

     ❗ Tip: To use this keyboard shortcut with connected clips or clips in a connected storyline, position the pointer on the clip, then press X.

Set a range start point or end point

In the Final Cut Pro browser or timeline, do any of the following:

- **Set the start point:** Position the skimmer (or the playhead, if skimming is turned off) where you want the selection to start, then choose Mark > Set Range Start (or press I).
  
  To remove the range start point, press Option-I.

- **Set the end point:** Position the skimmer (or the playhead, if skimming is turned off) where you want the range to end, then choose Mark > Set Range End (or press O).
  
  To remove the range end point, press Option-O.

- **Set the range start point or end point while a clip or your project is playing:** Press the Space bar to start playback, then press the I or O key when you want to set the start or end point.

  ❗ Tip: In the browser, you can press Shift-Command-I and Shift-Command-O to set multiple ranges during playback.
If you’re using the Blade, Trim, and Range Selection tools in the timeline or in the precision editor, you can use the I and O keys to set selection start and end points in a connected clip or storyline, as well as in clips underneath connected clips and storylines. Move the pointer directly over a clip and press I to set a selection start point, or press O to set a selection end point. See Cut clips in two, Make roll edits, and Use the precision editor.

**Extend or shorten the range selection**

In the Final Cut Pro browser or timeline, do any of the following:

- **Adjust where the range starts or ends**: Drag the left or right edge of the yellow selection border.
- **Reset the start point or end point for a range within the same event clip or project**: Move the skimmer, then press I or O.
  
  If the skimmer is not present, you can **turn on skimming**.

  🔄 Tip: You can also press the I or O key while a clip is playing back.

- **Extend or shorten a range within an event clip**: Move the skimmer to any frame that you want the range to begin or end with, then hold down the Shift key and click (or drag).
- **Extend or shorten a range using timecode**: Choose Modify > Change Duration (or press Control-D), then enter a new duration using your keyboard. As you type, the duration value appears in the timecode display below the viewer. (This method works with single range selections only.)

**Set the range selection to match the boundaries of the clip**

- In the Final Cut Pro browser or timeline, move the skimmer (or the playhead) over a clip, then press X.

  Final Cut Pro sets a range selection from the start point to the end point of the clip. Any preexisting ranges are removed.

**Clear ranges**

You can remove one or more ranges from the browser or the timeline.

*Note:* This operation does not affect the clip media in either the browser or the timeline.

In the Final Cut Pro browser or timeline, do any of the following:

- **Remove an individual range in an event**: Option-click the range.
- **Remove a range in the timeline**: Click outside of the range, or select a different range.
- **Clear one or more ranges in the browser or the timeline**: Select the range or ranges, then choose Mark > Clear Selected Ranges (or press Option-X).
  
  Selected ranges have a thick yellow border. Unselected ranges (available only in the browser) have a thin orange border.

- **Remove all ranges in an event**: Choose Edit > Select All (or press Command-A) to select all ranges in the current event, then choose Mark > Clear Selected Ranges (or press Option-X).
Set multiple ranges in the browser in Final Cut Pro for Mac

In the browser, you can set multiple ranges within one or more clips, and you can select and deselect ranges after you set them. For example, you might set multiple ranges in a long event clip, and then deselect some of the ranges before adding all of the selected ranges to the timeline at once.

Note: Selected ranges have a thick yellow border. Unselected ranges have a thin orange border. Editing commands operate on yellow selections only.

Note: The commands described in this section require the browser to be the active portion of the Final Cut Pro main window. You can make the browser active by moving the pointer over it or clicking it. When the browser is active, a blue line appears at the top.

Set multiple ranges in an event clip

1. In the Final Cut Pro browser, select a range within a clip.

2. To set an additional range, do one of the following:
   - Command-drag in a different section of the clip.
   - Move the skimmer (or the playhead) to the frame where you want the additional range to start, then press Shift-Command-I. Move the skimmer or the playhead to the frame where you want the additional range to end, then press Shift-Command-O.
     Note: These keyboard shortcuts also work during playback, so you can set additional ranges on the fly.
   - Option-drag over or within existing ranges to replace them with a new range.
   - Command-click a marker line at the top of a clip.
     These marker lines can indicate any of the following: clips marked as favorite (green) or rejected (red), manually applied keywords (blue), or analysis keywords (purple).
The additional range selection appears in the clip.

To remove a range selection, Option-click it. For more ways to remove ranges from event clips, see Remove ranges from clips in an event, below.

Set multiple ranges in event clips during playback
You can set multiple ranges in clips in the browser during playback.

1. In Final Cut Pro, play back a clip in the browser.
2. While the clip is playing, do any of the following:
   • *Add a range start point:* Press Shift-Command-I.
   • *Add a range end point:* Press Shift-Command-O.

To set multiple ranges in the same clip, repeat these keyboard shortcuts while continuing playback.

Select and deselect ranges and clips in an event
You can set, select, or deselect multiple ranges within event clips or within events.

**Important:** Editing commands operate on yellow selections only. Editing commands ignore orange (unselected) ranges.

1. In Final Cut Pro, set multiple ranges in one or more event clips.
2. Do any of the following:
   • *Select an individual range:* Click the range.
   • *Select or deselect a range:* Command-click the range.
   • *Select all ranges in a clip:* Click an area of the clip that has no range.
   • *Select all ranges and clips in the current event:* Choose Edit > Select All (or press Command-A).
     The ranges (and all clips with no ranges) are selected with a yellow border.
   • *Deselect all ranges and clips in the current event:* Choose Edit > Deselect All (or press Shift-Command-A).
     The ranges turn orange.
Remove ranges from clips in an event
You can remove individual ranges, multiple ranges, or all ranges from the current event.

1. In Final Cut Pro, set multiple ranges in one or more event clips.
2. Do any of the following:
   - Remove an individual range in an event: Option-click the range.
   - Remove selected ranges in an event: Select the ranges you want to remove, then choose Mark > Clear Selected Ranges (or press Option-X).
   - Remove all ranges in an event: Choose Edit > Select All (or press Command-A) to select all ranges in the current event, then choose Mark > Clear Selected Ranges (or press Option-X).

Navigate between selections in an event
1. In Final Cut Pro, set multiple ranges in one or more event clips.
2. Do any of the following:
   - Go to the start of the range selection: Choose Mark > Go to > Range Start (or press Shift-I).
     Repeat this command to go to the start of the previous range selection, or to the start of the clip.
   - Go to the end of the range selection: Choose Mark > Go to > Range End (or press Shift-O).
     Repeat this command to go to the end of the next range selection, or to the end of the clip.
   - Select the previous clip (or its ranges): Press the Up Arrow key.
     To add to the selection, press Shift-Up Arrow.
   - Select the next clip (or its ranges): Press the Down Arrow key.
     To add to the selection, press Shift-Down Arrow.

Add and remove clips

Intro to adding clips in Final Cut Pro for Mac
You build a movie project by adding clips to the timeline in a chronological arrangement. To suit your particular editing style or need, you can choose from a wide variety of tools and techniques for adding clips. You can change the arrangement of the clips in the timeline at any time.

In Final Cut Pro, you can edit your projects without worrying about maintaining clip connection or sync. For example, when you drag a clip into the timeline, Final Cut Pro automatically rearranges the timeline to fit each new clip without disturbing your existing work. This is true for all kinds of clips: video, audio, titles, generators, still images, and so on.
You can use clips from multiple events in a single project. You can also add clips from your photo and music apps, the collections of media (such as titles and sound effects) that come with Final Cut Pro, and the Finder. Deleting clips from the timeline does not remove the source clips from your events, your other apps, the Final Cut Pro media collections, or the Finder.

Connected clips and storylines remain attached to, and synced with, clips in the primary storyline until you explicitly move or remove them.

In the browser, an orange line along the bottom of an event clip indicates that the clip is being used in the current project (the project open in the timeline). To turn this view on or off, choose View > Browser > Used Media Ranges.
Drag clips to the timeline in Final Cut Pro for Mac

You can add clips to the timeline by dragging them from the browser or from the Finder.

Drag clips from the browser

You can show media in the browser by selecting items in the sidebar.

1. In Final Cut Pro, open a project in the timeline.
2. To open the sidebar for the type of media you want to add, do one of the following:
   • Click one of the buttons in the top-left corner of the Final Cut Pro window.
   • Choose Window > Go To > Libraries (or press Command-1).
   • Choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).
   • Choose Window > Go To > Titles and Generators (or press Option-Command-1).
3. In the sidebar you opened, select the item containing the media you want to add to your project.
   The contents of the selected item appear in the browser.
4. Drag one or more clips from the browser to the timeline.

⚠️ Tip: You can add one clip to your project at a time, but it may be easier to add a number of clips to the project at once and then rearrange them in the timeline.
Drag files from the Finder

1. In Final Cut Pro, make sure to open the correct project in the timeline.

2. Arrange the windows onscreen so that you can see both the Final Cut Pro main window and the files in the Finder.

3. Drag the files from the Finder to the timeline.

💡 Tip: You can also copy one or more video files in the Finder and paste them into the timeline.

Depending on where you drag the clips in the timeline, your actions may result in an append edit, an insert edit, a connect edit, or a replace edit. Final Cut Pro automatically adjusts surrounding clips to fit in place around any clips you’ve dragged.

Note: If you add clips to the timeline from the Finder, the Libraries sidebar, or the Photos, Videos, and Audio sidebar, you’re effectively importing the media into the event that contains the current project. In this case, Final Cut Pro applies the default optimization and analysis settings to the new clips. You can change these settings in the Import pane of Final Cut Pro settings.

When you add still images to the timeline, they have a default duration of 4 seconds. You can change this duration in the Editing pane of Final Cut Pro settings.

Append clips to your project in Final Cut Pro for Mac

A simple way to add a clip to your project is an append edit, in which you add one or more clips to the end of a project or storyline.

1. In Final Cut Pro, select one or more clips in the browser.

2. To add the clips to the timeline, do one of the following:
   • Choose Edit > Append to Storyline (or press E).
   • Click the Append button in the top-left corner of the timeline.

If there’s no selection, the clip appears at the end of the primary storyline in the timeline. If a storyline is selected, the clip appears at the end of the selected storyline.
Insert clips in Final Cut Pro for Mac

An insert edit places the source clip so that all clips after the insertion point are moved later (or rippled) in the timeline to make room for the clip being added. No clips are removed from your project. An insert edit makes the project longer by the duration of the inserted clip.

You might use insert edits when you want to add a new shot in the beginning or the middle of your project. You can also use an insert edit to interrupt the action in an existing clip with the action in the newly inserted clip. The action in the original clip then resumes after the inserted clip.

Note: You can use three-point editing to make insert edits. See Intro to three-point editing.

Insert browser clips in the timeline

1. In Final Cut Pro, select one or more clips in the browser.
2. Move the playhead to the point in the primary storyline or in a selected storyline (or make a range selection) where you want to insert the clip.
3. Do one of the following:
   - Choose Edit > Insert (or press W).
     Note: If you use the keyboard shortcut and the skimmer is present in the timeline, the edit occurs at the skimmer position.
   - Click the Insert button in the top-left corner of the timeline.

The clip appears in the timeline, and all clips after the insertion point are rippled forward. If the skimmer is not present, the clips are inserted at the playhead position. If you perform an insert edit in the middle of an existing timeline clip, that clip is cut at the insertion point, and the second half is moved to the end of the newly inserted clip, along with the rest of the footage to the right of the insertion point.
Insert a gap or placeholder clip in the timeline

If you want to reserve space in the timeline for a clip that you don’t yet have, you can insert a generated placeholder clip or a blank and silent clip (called a gap clip). You can adjust a gap clip or placeholder clip to any duration.

1. In Final Cut Pro, move the playhead to the point in the primary storyline or a selected storyline (or make a range selection) where you want to insert the gap clip or placeholder clip.

2. Do any of the following:
   - *Insert a placeholder clip:* Choose Edit > Insert Generator > Placeholder (or press Option-Command-W).
     Final Cut Pro inserts a clip with gray placeholder imagery that you can customize. See Add placeholders.
   
   - *Insert a gap clip:* Choose Edit > Insert Generator > Gap (or press Option-W).
     Final Cut Pro inserts a blank clip (containing blank video and silent audio) that you can adjust to any duration. (The film industry term for this is *slug*.)

Note: Gap clip color is determined by the current background color in Final Cut Pro. To adjust the background color, choose a Player Background option in the Playback pane of Final Cut Pro settings. If you want a different color, consider using a solid generator. See Generators overview.

The clip appears in the timeline, and all clips after the insertion point are rippled forward (to the right).
Insert clips by dragging them from the browser or the Finder

In Final Cut Pro, you can drag clips to the timeline to insert them between other clips. Show clips in the browser from the Libraries sidebar, the Photos, Videos, and Audio sidebar, or the Titles and Generators sidebar, and then drag them to the timeline. You can also insert clips by dragging them directly to the timeline from the Finder.

- **Drag the clip you want to insert** to an edit point (between two clips) in the timeline.

The clip appears in the timeline, and all clips after the insertion point are rippled forward (to the right).

Connect clips in Final Cut Pro for Mac

In Final Cut Pro, you can attach clips to other clips in the timeline. Connected clips remain attached and synced until you explicitly move or remove them.

Some uses for connected clips include:

- **Cutaway shots**: Add a cutaway shot by connecting it to a video clip in the timeline.
- **Superimposed titles**: Add a title or a lower third to a video clip or range.
- **Spot sound effects and background music**: Sync audio clips to clips in the primary storyline. The clips remain synced even if you move the primary storyline clips.
When you connect clips using the Connect menu command, the keyboard shortcut, or the button above the timeline, video clips are connected above the primary storyline, and audio clips are connected below the primary storyline.

Note: You can also use three-point editing to make connect edits. See Intro to three-point editing.

**Connect clips in the timeline**

1. If your Final Cut Pro project is empty, add clips to the dark gray primary storyline area in the timeline to build your initial sequence.

   The clips in the primary storyline serve as a foundation on which you connect (attach) clips to further build your project. Connect edits are slightly different from the other edit types in that they never add clips to the primary storyline. If you perform a connect edit in an empty timeline, a gap clip is first added to the primary storyline, and then the new connected clip is attached to the gap clip.

2. Select one or more clips or a range in the browser.

3. To indicate where you want to connect the selected source clip, do one of the following:
   - Position the playhead over a frame of the clip in the primary storyline.
   - Select a range in the primary storyline.
4. To connect the selected clips to the clips in the primary storyline, do one of the following:

- Choose Edit > Connect to Primary Storyline (or press Q).
  
  *Note:* If you use the keyboard shortcut and the skimmer is present in the timeline, the clip is connected at the skimmer position.

- Click the Connect button in the top-left corner of the timeline.

- Drag the clips to the gray area above or below the primary storyline.

The first frame of the source selection is connected to the clip in the primary storyline at the playhead or skimmer position. If you dragged the selection to the timeline, the first frame of the source selection is connected to the primary storyline at the point where you released the mouse or trackpad button.

When you rearrange, move, ripple, or delete clips in the primary storyline, any clips connected to them are moved or deleted along with the primary storyline clips.
When you connect clips by dragging them, you have the option to put video clips either above or below the primary storyline.

**Note:** In Final Cut Pro, if you connect clips, the topmost video clips block out any video clips below them. Exceptions to this rule are clips with some type of transparency, keying, or compositing settings. See Intro to compositing. Audio clips never affect video output, even when they’re placed above video clips in the timeline.

**Adjust the connection point of a connected clip**

By default, connected clips and storylines are connected to the primary storyline at their first frame, but you can move the connection point. This is useful when you want to connect a specific frame or audio sample in the connected clip or storyline to a specific frame or audio sample in the primary storyline.

- In Final Cut Pro, hold down the Command and Option keys, then click the connected clip (or the gray border of the storyline) at the point where you want to position the connection point.

  The connection point is moved to the point where you clicked.
**Edit clips in the primary storyline without affecting connected clips**

If you need to move, trim, or delete clips in the primary storyline but want to keep any connected clips where they are, you can hold down the Grave Accent (´) key while editing to preserve the timing and position of connected clips.

In Final Cut Pro, do any of the following:

- **Move a clip without affecting connected clips**: While holding down the Grave Accent (´) key, drag the clip to another location in the timeline (using either the Select tool or the Position tool).

  ![Hold down the Grave Accent (´) key and drag the clip.](image)

- **Trim a clip without affecting connected clips**: While holding down the Grave Accent (´) key, trim the clip using any method, including ripple edits, roll edits, slip edits, and slide edits.

- **Delete a clip without affecting connected clips**: While holding down the Grave Accent (´) key, select the clip and press Delete (or press Option-Command-Delete).

  If you remove clips or ranges involved with connected clips and storylines *without* holding down the Grave Accent (´) key, special rules apply. See **Remove clips from projects**.

- **Switch to an alternate clip in an audition without affecting connected clips**: While holding down the Grave Accent (´) key, select the pick in the Audition window.

  ![The connected clip remains in place.](image)

  See **Review clips in auditions**.

In all of these cases, the connected clip (or clips) remains in exactly the same position, with its timing preserved.
Overwrite clips in Final Cut Pro for Mac

In an overwrite edit, one or more source clips overwrite any clips in the primary storyline or a selected storyline, starting at a range selection start point or the playhead or skimmer position. No clip items are rippled forward, so the duration of your project remains the same.

Overwriting media is different from replacing it. Overwriting works with range selections only, not entire clips, and is not constrained by clip boundaries. Use an overwrite edit when you want to replace media for a specific span of time, rather than replace specific shots.

Note: You can also use three-point editing to make overwrite edits. See Intro to three-point editing.

1. In Final Cut Pro, select one or more clips in the browser.
   If you select multiple clips, they appear in the timeline in the order in which they were selected.

2. To define where you want the overwrite clip to start in the timeline, do one of the following in the primary storyline or a selected storyline:
   • Position the playhead.
   • Select a range involving one or more clips in the timeline.

Note: The overwrite command ignores whole-clip selections in the timeline. If you don’t select a range in the timeline, the overwrite clip starts at the playhead or skimmer position.

3. Choose Edit > Overwrite (or press D).
   The source clip appears in the primary storyline and overwrites any clips for the duration of the source clip.

Note: If you use the keyboard shortcut and the skimmer is present in the timeline, the edit occurs at the skimmer position.

To overwrite from the playhead back, so that the overwrite clip’s end point (rather than its start point) is aligned at the target position, press Shift-D.
Replace clips in Final Cut Pro for Mac

You can replace clips in your project with clips from the browser or the Finder. In contrast to overwrite edits, replacing works on whole timeline clips only and can change the duration of your project.

Replace options include using the start or end of the source clip, retiming the source clip to fit the duration of the timeline clip, and automatically creating or adding to auditions.

Replace a clip in the timeline by dragging

1. In Final Cut Pro, make a source selection by doing one of the following:
   - Select a clip or range in the browser.
   - Select a media file in the Finder.

2. Drag the source selection over the clip in the timeline you want to replace.
   The target clip in the timeline is highlighted with a white outline.

3. Release the mouse or trackpad button and choose an option from the shortcut menu:

   - Replace: The target clip is replaced with the source clip selection. The duration is determined by the duration of the source clip selection. If the source clip selection and the target clip have different durations, the subsequent clips ripple.
   - Replace from Start: The target clip is replaced with the source clip selection, starting from the beginning of the source selection. The duration is determined by the duration of the target clip.
• **Replace from End**: The target clip is replaced with the source clip selection, starting from the end of the source selection. The duration is determined by the duration of the target clip.

• **Replace with Retime to Fit**: The target clip is replaced with the entire source clip selection, retimed to fit the duration of the target clip.

• **Replace and Add to Audition**: The target clip is replaced with an audition that has the source clip selection as the pick and the target clip as an alternate. The duration is determined by the source clip selection. If the source clip and the target clip have different durations, the subsequent clips ripple.

• **Add to Audition**: The target clip is replaced with an audition that has the target clip as the pick and the source clip selection as an alternate.

• **Cancel**: The replace edit is canceled.

The source clip selection appears in the timeline, in place of the original clip.

![The source clip selection appears in the timeline.](image)

**Note**: In the case of Replace from Start and Replace from End, if the source clip selection is a range selection with a duration shorter than that of the target clip and there's sufficient extra media, the source selection is extended to match the duration of the target clip. The resulting storyline duration doesn't change.

### Replace a clip in the timeline using keyboard shortcuts

1. In the browser in Final Cut Pro, select the source clip or range.

2. In the timeline, select the clip you want to replace.

   **Note**: The timeline selection must be a whole-clip selection, not a range selection.

3. Do one of the following:

   • **Perform a standard replace edit**: Press Shift-R.

     The target clip is replaced with the source clip selection. The duration is determined by the duration of the source clip selection. If the source clip selection and the target clip have different durations, the subsequent clips ripple.

   • **Perform a Replace from Start edit**: Press Option-R.

     The target clip is replaced with the source clip, starting from the beginning of the source clip. The duration is determined by the duration of the target clip.

   **Note**: In the case of Replace from Start, if the source clip selection is a range selection with a duration shorter than that of the target clip and there's sufficient extra media, the source selection is extended to match the duration of the target clip. The resulting storyline duration doesn't change.
Add still images in Final Cut Pro for Mac

In Final Cut Pro, you can add and edit a variety of still-image formats in your projects, including photos and graphics files.

Add a still image to the timeline

You can add still images to your Final Cut Pro project using the Libraries sidebar, the Photos, Videos, and Audio sidebar, or the Finder.

In Final Cut Pro, do any of the following:

- **Add a still image using the Libraries sidebar:** Import the still image into an event, select the event in the Libraries sidebar, then select all or part of the still-image clip in the browser and drag it to the timeline. For information about importing media, see Intro to importing media.

  Note: After a still image is imported, it functions like any other clip in Final Cut Pro. You can use any of the techniques described in this chapter to add still-image clips to the timeline.

- **Add a still image using the Photos, Videos, and Audio sidebar:** Open the Photos, Videos, and Audio sidebar, select a still image in the browser, and drag it directly into the timeline.

- **Add a still image from the Finder:** Select a still-image file in the Finder, then drag it directly into the timeline.

The default initial duration for still images is 4 seconds, but you can change this setting in the Editing pane of Final Cut Pro settings.

There’s no limit on the duration of a still-image clip. To adjust the duration of a still-image clip in the timeline, use any of the trimming techniques described in this chapter (see Intro to trimming). To adjust the duration of multiple still-image clips at once, select the clips, then choose Modify > Change Duration (or press Control-D).

Edit layered graphics files

You can edit layered graphics files, such as Adobe Photoshop (PSD) files, created with another image editing app.

1. Import the layered graphics files into Final Cut Pro.

   For information about importing media, see Intro to importing media.

   **Important:** If the layered graphics file has a transparent background, make sure your project’s rendering format is set to Apple ProRes 4444 to preserve the transparency when rendering. See Modify a project’s settings.

2. In the browser or the timeline, select the layered graphics image.
3. Choose Clip > Open Clip.

Each layer appears in the timeline as a connected clip that you can edit as you would any other clip. For example, you can animate layers by fading them in or out.

The default duration for a layered graphics file is one minute. To adjust the duration of one of the layers in the timeline, use any of the trimming techniques described in this chapter (see Intro to trimming). To adjust the duration of all the layers, select them, then choose Modify > Change Duration (or press Control-D).

For more information on creating layered graphics files for Final Cut Pro, see Best practices for creating layered graphics files.

Edit a still image with an external image editing app

You can modify a still image with an external image editing app, and the changes appear automatically in the clip in Final Cut Pro.

1. In Final Cut Pro, add a still image to the timeline.

2. To locate the clip’s source media file in the Finder, press Shift-Command-R.

   See Locate source media files.

3. Open the source media file in the external image editing app.

4. In the image editing app, modify the image and save the changes.

5. Switch back to Final Cut Pro.

   The changes appear automatically in the still-image clip in Final Cut Pro.

You can also create freeze frames from your video clips. See Create freeze frames.
Create freeze frames in Final Cut Pro for Mac

Freeze-frame clips hold a particular frame in place, temporarily stopping the action onscreen. You can create a freeze-frame clip from any video clip in the timeline or the browser. If you create a freeze-frame clip from the browser, it’s attached to the primary storyline at the playhead location as a connected clip.

If you don’t want to create a separate clip for a freeze frame, you can create a hold segment, which temporarily stops the action for part of a clip. Hold segments offer more precise control, especially when you’re creating variable speed effects. See Create hold segments.

You can also create a still-image file from a video frame in your project or from a clip in the browser. For example, you may want to email someone a JPEG image showing a specific moment in your project. See Export still images.

Create a freeze-frame clip

You can create freeze frames on the fly during playback or by navigating to a specific frame in a clip.

*Note:* Any attributes that you previously applied to the source clip, such as settings and effects, are rendered into the freeze-frame clip.

1. In the timeline or the browser in Final Cut Pro, do one of the following:
   - Move the skimmer or playhead to the frame you want to freeze.
   - Begin playback of the clip.

2. Choose Edit > Add Freeze Frame (or press Option-F).

How the freeze frame is added to the project depends on whether the freeze frame was created from the timeline or the browser.

*If you created the freeze frame from a clip in the timeline:* A new freeze-frame clip is inserted at the skimmer or playhead location in the timeline.

*If you created the freeze frame from a clip in the browser:* A new freeze-frame clip is attached as a connected clip at the playhead location in the timeline.
Change the default duration of freeze-frame clips

Freeze-frame clips have the same default duration as still-image clips: 4 seconds. You can change the default duration in the Editing pane of Final Cut Pro settings.

1. Choose Final Cut Pro > Settings (or press Command-Comma), then click the Editing button at the top of the window.
2. Adjust the Still Images value slider.

Add only a clip’s video or audio in Final Cut Pro for Mac

By default, whenever you add a clip from an event to the timeline, all of the video and audio components of the event clip are included in the edit. However, you can also add just the video or audio portion of an event clip to the timeline, even if the clip contains both video and audio.

1. To set the editing mode in Final Cut Pro, do one of the following:
   • Add just the video from your selection: Click the Edit pop-up menu in the top-left corner of the timeline and choose Video Only (or press Shift-2).
   • Add just the audio from your selection: Click the Edit pop-up menu and choose Audio Only (or press Shift-3).

The edit buttons (to the left of the Edit pop-up menu) change their appearance to indicate the mode you chose:

2. Add clips to the timeline as you normally would.
   See Intro to adding clips.

The video-only or audio-only clips appear in the timeline.

To return to the default editing mode (video and audio), click the Edit pop-up menu and choose All (or press Shift-1).
Remove clips from projects in Final Cut Pro for Mac

When you remove clips from a project in the timeline, the source media from the browser or the Finder is not affected.

Delete clips or ranges from the timeline

1. In the Final Cut Pro timeline, select the clips or the range you want to remove.
2. Choose Edit > Delete (or press the Delete key).

The selected clips or portions of clips are removed from the timeline, and any clips to the right of the selection ripple to close the resulting gap.

To undo the deletion immediately, choose Edit > Undo (or press Command-Z).

Note: Normally, if you select an entire timeline clip (for example, with the C key) or a range that consists of an entire clip (for example, with the X key) and delete it, any connected clips or storylines are also deleted. However, you can delete a clip without affecting its connected clips by holding down the Grave Accent (`) key while pressing the Delete key. See Edit clips in the primary storyline without affecting connected clips. Also, if you delete a partial range of a clip that includes a connected clip or storyline, the connected items are not deleted but are instead shifted to the closest primary storyline clip.

Delete clips or ranges without affecting the project duration

If you want to remove clips from the timeline but still maintain the total project duration and timing, you can replace clips with gap clips. This method prevents any ripple edits.

1. In the Final Cut Pro timeline, select the clips or the range you want to remove.
2. Choose Edit > Replace with Gap (or press Shift-Delete).

   The selection in the timeline is replaced with a gap clip.

Note: This method preserves connected clips. When you replace a clip with a gap clip, any connected clips are attached to the resulting gap clip.
Solo or disable clips in Final Cut Pro for Mac

Sometimes, it’s helpful to compare how a project plays with and without certain clips. In Final Cut Pro, you can quickly play one clip’s audio, excluding audio from other clips. This feature, called solo, works by disabling the audio in all unselected clips in the timeline. You can also disable (rather than delete) selected clips, making them invisible and silent during playback. Disabled clips don’t appear in any output. You can just as easily reenable them.

Solo selected items

1. In Final Cut Pro, select the clips in the timeline that you want to isolate.
2. Do one of the following:
   - Choose Clip > Solo (or press Option-S).
   - Click the Solo button in the top-right corner of the timeline.

When solo is turned on, the Solo button turns blue, and the soloed clips are outlined in yellow. Nonsoloed clips are shown in black and white.

3. To turn off solo, click the Solo button again.
Disable and reenable one or more clips

1. In Final Cut Pro, select one or more clips in the timeline.

2. Choose Clip > Disable (or press V).
   Disabled clips are dimmed in the timeline and are invisible and silent during playback.

3. To reenable the disabled clips, select them in the timeline, then choose Clip > Enable (or press V).

You can also solo, disable, or silence audio clips in Final Cut Pro. See Solo and mute audio clips.

Find a project clip’s source clip in Final Cut Pro for Mac

You can use the Reveal in Browser command to quickly find the source event clip for any clip in your project in the timeline. This command identifies the source clip in the browser and positions the playhead on the same frame as in the timeline. This is known as a match frame.

There are several reasons you might want to locate a timeline clip’s source clip in Final Cut Pro:

- You want to duplicate a clip in your project or add the same clip to a different project.
- You want to open the original source clip without any of the video or audio effects from the timeline clip—for example, to add a fresh copy of the clip to your project.
- You want to open the source event clip with all of its video and audio components, instead of the timeline clip, which may have only a single component. For example, your timeline clip may be a video clip item that no longer has its corresponding audio. You can open the video clip’s source clip in the browser, and then edit the audio components from the source clip back into the project using a replace or overwrite edit.
1. In the Final Cut Pro timeline, select the clip whose source event clip you want to locate.

2. Do one of the following:
   • Choose File > Reveal in Browser (or press Shift-F).
   • Control-click the clip and choose Reveal in Browser.

A selection border appears around the source clip or range in the browser, and the playhead position in the source clip matches the playhead position in the timeline clip. An orange line along the bottom of the source clip indicates that the clip is being used in the current project (the project open in the timeline).

When revealing the clip in the browser, Final Cut Pro maintains the current browser settings, such as clip filters and Keyword Collection or Smart Collection selections (when possible).

Make three-point edits

Intro to three-point editing in Final Cut Pro for Mac

Three-point editing allows you to use start and end points in the browser and the timeline to specify the duration of a clip and where it should be placed in the timeline. Three-point editing gets its name from the fact that only three edit points are necessary to determine the portion of the source clip to use and where to place that clip in the timeline. Final Cut Pro infers the fourth edit point automatically. The result of the edit depends on which three points are set in the browser and in the timeline: two start points and one end point or one start point and two end points.

You can use three-point editing with the following types of edits:

   • Insert
   • Connect
   • Overwrite
With each of these edit types, you can also perform *backtimed* three-point edits, in which the end point (rather than the start point) is aligned with the skimmer or playhead position in either the browser or the timeline. You can also make two-point edits in which start and end points are inferred from the skimmer position and the clip duration.

To make three-point edits, it’s important to know how to make selections and how to use the skimmer and the playhead. For information about making selections, see Select ranges and Select clips. For information about the skimmer and the playhead, see Intro to playback.

Basic three-point editing has three steps:

**Step 1: Set source selection edit points in the browser**

Specify which part of a clip you want to place in the timeline. You do this by setting the start and end points. If you want to set just a start point in the browser, position the skimmer (or playhead) at the point where you want the edit to begin. In this case, the end point is determined by the start and end points set in the timeline or by the end of the clip. You can also select multiple clips in the browser, and their aggregate source media duration determines the start and end points.

**Step 2: Set edit points in a storyline in the timeline**

Specify where you want the clip to appear in the timeline by setting start and end points in the primary storyline or in a connected storyline. If both start and end points are set in the timeline, these edit points determine the edit duration, regardless of the duration set in the browser. If no start or end points are set in the timeline, Final Cut Pro uses the skimmer position for the start point of the edit. If the skimmer is not present, Final Cut Pro uses the playhead position.

**Important:** With few exceptions, three-point editing requires range selections rather than clip selections.

**Step 3: Add the source clip or selection to the timeline**

Choose to either insert, connect, or overwrite.
## Three-point editing guidelines in Final Cut Pro for Mac

The result of a three-point edit in Final Cut Pro depends on which three points you set in the browser and the timeline.

<table>
<thead>
<tr>
<th>Edit points set</th>
<th>Results</th>
</tr>
</thead>
</table>
| • Source selection start and end points in the browser  
  • Destination start point in the timeline        | The start point of the source selection in the browser is aligned with the destination start point in the timeline, and the duration of the edit is determined by the source selection start and end points in the browser. |
| • Source selection start point in the browser     
  • Destination start and end points in the timeline | The start point of the source selection in the browser is aligned with the destination start point in the timeline, and the duration of the edit is determined by the destination start and end points in the timeline.  
  Note: This edit requires a range selection in the timeline. You can use the Range Selection tool or the I and O keys for this purpose. See Select ranges. |
| • Source selection start and end points in the browser  
  • Destination end point in the timeline          | The end point of the source selection in the browser is aligned with the destination end point in the timeline, and the duration of the edit is determined by the source selection start and end points in the browser.  
  This is known as “backtiming” an edit. Use this method when you want to make sure a clip ends at a specific point in the project. |
| • Source selection end point in the browser       
  • Destination start and end points in the timeline | The end point of the source selection in the browser is aligned with the destination end point in the timeline, and the duration of the edit is determined by the destination start and end points in the timeline.  
  This is known as “backtiming” an edit. Use this method when you want to make sure a clip ends at a specific point in the project.  
  Note: This edit requires a range selection in the timeline. You can use the Range Selection tool or the I and O keys for this purpose. See Select ranges. |
Three-point edit examples in Final Cut Pro for Mac

In Final Cut Pro, you can make precise edits using a combination of three (or sometimes two) edit points set in the browser and the timeline. See Intro to three-point editing.

Here are a few examples of ways to make three-point edits.

**Example: Make a three-point edit**

The simplest way to perform a three-point edit is to specify start and end points for the source selection in the browser, and then specify the destination start point in your project by positioning the skimmer (or the playhead) in the timeline.

1. In Final Cut Pro, set start and end points (or select a range) for the source selection in the browser.

   ![Start and end points](image)

2. In the timeline, position the skimmer (or the playhead, if the skimmer is not present) at the location in your project where you want the clip to start (the destination start point).

   ![Position the skimmer](image)

3. To add the source selection to the project using an overwrite edit, press D.

   ![The new clip](image)

The portion of your source selection between the start and end points appears in the timeline, starting at the skimmer position.

By defining only three points—the source selection start and end points in the browser and the destination start point in the timeline—you have total control of the edit.
Example: Make a backtimed three-point edit

You can make a three-point edit by defining source selection start and end points in the browser and a destination end point (instead of a destination start point) in the timeline. This is called backtiming a clip. You can use this method when you want to make sure a particular clip ends at a specific point in a project, on a musical beat. In the resulting edit, the end point of the media in the browser selection is aligned with the end point you set in the timeline, and the rest of the source selection appears to the left.

1. In Final Cut Pro, set start and end points (or select a range) for the source selection in the browser.

![Start point and End point](image)

2. In the timeline, position the skimmer (or the playhead, if the skimmer is not present) at the location in your project where you want the clip to end.

![Position the skimmer](image)

3. Do any of the following:
   - Backtime the selection using an overwrite edit: Press Shift-D. See Overwrite clips.

Your source selection is edited into the project so that the end point of the media in your source selection lines up with the end point you specified in the timeline.

![The new clip](image)
The rest of your clip overwrites any material to the left of the end point for the duration defined by the source selection start and end points set in the browser.

**Example: Make a three-point edit with multiple clips**

You can make three-point edits with multiple clips at a time.

1. In Final Cut Pro, select two or more clips in the browser (don’t select a range within a single clip).

   For information about selecting multiple clips, see [Select clips](#).

2. In the timeline, define a destination start point by positioning the skimmer at the location in your project where you want the clips to start.

3. To add the selected clips to the project using an **overwrite edit**, press D.

   The entire group of clips selected in the browser is edited into the project. The clips are added in the order in which you selected them.

   Because you used an overwrite edit, any clip items already in the project are overwritten by the clips selected in the browser, for the duration of the browser clips.
You can also make a three-point edit involving multiple clips in the timeline. To select a range across multiple clips in the timeline, you use the Range Selection tool or the I and O keys. See Select ranges.

**Example: Make a two-point edit**

You can make an edit without any selections in either the browser or the timeline. This is known as a *two-point edit*. In this case, Final Cut Pro acts on the current clip in the browser from the position of the skimmer or playhead to the end of the clip, and on the project in the timeline from the position of the skimmer or playhead forward.

You can also make backtimed two-point edits, in which Final Cut Pro acts on the current clip in the browser and the project in the timeline from the skimmer or playhead position back.

In either case, the duration of the edit is determined by the skimmer or playhead position and the end of the clip in the browser.

1. To specify a source selection start point in the Final Cut Pro browser, move the skimmer or playhead to the location where you want the edit to start (but don’t make any selections).

2. To specify a destination start point in the timeline, move the skimmer or playhead to the location where you want the edit to start (but don’t make any selections).

3. To add the clip to the project using an *overwrite edit*, press D.
Arrange clips in the timeline in Final Cut Pro for Mac

In Final Cut Pro, you can arrange and reorder the clips in your project however you want. If you add or move a clip in the timeline by dragging, Final Cut Pro moves other clips to make room for it. Other reordering techniques include moving clips numerically by entering a timecode value, nudging clips with keyboard shortcuts, overwriting with the Position tool, and moving clips vertically from and to the primary storyline.

Move clips by dragging horizontally
1. In the Final Cut Pro timeline, select one or more clips.
2. Drag the clips to a new location in the project.

As you drag your clips, you see an outline of your selection at the new position in the timeline. When you release the clip, the repositioned clip (or clips) appears at the new location. Final Cut Pro ripples clips (and any connected clips) in the timeline to make room for the repositioned clips and to close the gap left by the clips that were repositioned. You can also drag clips vertically in and out of the primary storyline.

Move clips by entering a timecode value
You can move selected clips in the timeline by entering an amount of time you want the clips to move.

Moving clips by entering a timecode value is similar to making a slide edit; the preceding clip and the following clip must have media handles (additional media available beyond the edit point). See Make slide edits.

1. In Final Cut Pro, select one or more clips in the timeline.
2. Do any of the following:
   • Move the clips forward: Press the Plus Sign (+) key, then type a timecode duration for the move.
   • Move the clips back: Press the Minus Sign (−) key, then type a timecode duration for the move.

Note: For more information and tips on entering timecode, see Navigate using timecode.
The timecode display below the viewer becomes an entry field and reflects your changes as you type.

3. Press Return.

The clips move forward or back by the duration you entered. The adjacent clips are trimmed to accommodate the change in the clip’s position. If you prefer to fill in the vacated parts of the storyline with a gap clip, select the Position tool by pressing P before entering a timecode value.
Nudge clips with keyboard shortcuts

You can "nudge" selected items to move them by very small amounts, such as frames. Nudging by subframes is also available for connected audio-only clips.

Nudging clips in the timeline is similar to making a slide edit; the preceding clip and the following clip must have media handles (additional media available beyond the edit point). See Make slide edits.

1. In Final Cut Pro, select one or more clips in the timeline.
2. To nudge the clips, do any of the following:
   - Move the selection left by one frame: Press Comma (,).
   - Move the selection left by 10 frames: Press Shift-Comma (,).
   - Move the selection right by one frame: Press Period (.).
   - Move the selection right by 10 frames: Press Shift-Period (.).
3. If you want to nudge connected audio clips by one or more subframes, do any of the following:
   - Move the selection left by one subframe: Press Option-Comma (,).
   - Move the selection left by 10 subframes: Press Option-Shift-Comma (,).
   - Move the selection right by one subframe: Press Option-Period (.).
   - Move the selection right by 10 subframes: Press Option-Shift-Period (.).

For more information about subframes, see Zoom in to audio waveforms.

The nudged clip appears at the new position in the timeline. The adjacent clips are trimmed to accommodate the change in the clip's position. If you prefer to fill in the vacated parts of the storyline with a gap clip, select the Position tool by pressing P before nudging clips.

Overwrite clips using the Position tool

You can move clips by dragging them in the timeline to overwrite other clips. This allows you to place clips precisely without causing other clips to move to make room.

1. In Final Cut Pro, click the Tools pop-up menu in the top-left corner of the timeline and choose Position (or press P).

![Position tool](image)

The pointer changes to the Position tool ►.

⚠️ Tip: To switch to the Position tool temporarily, hold down the P key. When you release the P key, the tool reverts to the previously active tool.
2. Select the clip you want to move.

3. Drag the clip to a new position in the timeline.

The moved clip overwrites any clips at the new position. A gap clip fills in the vacated part of the timeline.

*Note:* If you prefer to move clips left or right in the timeline *without* leaving a gap, you can perform a slide edit.

To return to the Select tool (the default), click the Tools pop-up menu in the top-left corner of the timeline and choose Select (or press A).

**Drag clips from and to the primary storyline**

Dragging clips from and to the primary storyline causes ripple edits, which affect the total duration of your project. When you move a clip out of the primary storyline, it becomes either an individual connected clip or part of a connected storyline.

1. In Final Cut Pro, if the Select tool is not the active tool, click the Tools pop-up menu in the top-left corner of the timeline and choose Select (or press A).

2. Select one or more clips (either clips in the primary storyline or connected clips).
3. Do any of the following:

- **Move clips out of the primary storyline:** Drag the clips from the primary storyline to their new position as connected clips (above or below the primary storyline).

  The subsequent clips in the primary storyline ripple left to close the gap created by the clips you moved.

- **Move clips to the primary storyline:** Drag the clips from their position as connected clips to an edit point between two clips in the primary storyline.

  The result is effectively an insert edit: The former connected clips are inserted in the primary storyline, and subsequent clips ripple right to make room for the new clips.
Note: You can drag clips from and to the primary storyline as long as there are no clips connected to them. If there’s a connected clip, you must first move or remove it, or use either the Lift from Storyline command (Option-Command-Up Arrow) or the Overwrite to Primary Storyline command (Option-Command-Down Arrow). See Move clips from and to the primary storyline without rippling the project, next.

Move clips from and to the primary storyline without rippling the project

You can move clips from and to the primary storyline without affecting the total duration of your project.

1. In Final Cut Pro, select the clips you want to move.

2. Do any of the following:
   - Move selected clips from the primary storyline to connected clips at the same timeline position: Choose Edit > Lift from Storyline (or press Option-Command-Up Arrow).

   ![New connected clip at the same timeline position]

   ![A gap clip fills in the vacated part of the primary storyline.]

Gap clips fill in the vacated parts of the primary storyline, as needed.
• Move selected connected clips to the primary storyline: Choose Edit > Overwrite to Primary Storyline (or press Option-Command-Down Arrow).

Depending on the amount of overlap on the connected clip, the Overwrite to Primary Storyline command either creates a split edit or overwrites any video clips at the new location and converts the audio portion of the overwritten clip to a connected clip. The Overwrite to Primary Storyline command is not available for audio-only clips.

Note: The Overwrite to Primary Storyline command works on individual connected clips only. To use this command on a clip in a connected storyline, first move the clip out of the storyline.

You can achieve the same results by dragging clips with the Position tool.

Cut and trim clips

Intro to trimming in Final Cut Pro for Mac

After you've roughly assembled your clips in chronological order in the timeline, you begin to fine-tune the cut point (or edit point) between each pair of contiguous clips. Any time you make a clip in a project longer or shorter, you're trimming that clip. However, trimming generally refers to precision adjustments of anywhere from one frame to several seconds. If you're adjusting clip durations by much larger amounts, you're still trimming, but you may not be in the fine-tuning phase of editing yet.

In Final Cut Pro, you can use a variety of techniques to trim timeline clips and edit points, including ripple edits, roll edits, slip edits, and slide edits.

No matter how you trim or make other edits in Final Cut Pro, the underlying media is never touched. Trimmed or deleted pieces of clips are removed from your project only, not from the source clips in your library or from the source media files on your Mac or storage device.

Tip: You can see a “two-up” display in the viewer as you trim edit points in the timeline. See Show trimming details in the viewer.

Cut clips in two in Final Cut Pro for Mac

After you add clips to the timeline, you can easily cut them to adjust their durations or remove unwanted sections.

The most basic edit is a straight cut. The term comes from the film editing process of cutting a filmstrip with a razor and attaching a new “clip” with glue.

Each time you cut a clip in your project, it's split into two clips. You can cut one clip at a time or multiple clips at a time.
Cut a clip in the timeline

1. In Final Cut Pro, click the Tools pop-up menu in the top-left corner of the timeline and choose Blade (or press B).

The pointer changes to the Blade tool.

Tip: To switch to the Blade tool temporarily, hold down the B key. When you release the B key, the tool reverts to the previously active tool.

2. Move the skimmer to the frame in the clip where you want to cut, then click.

Tip: You can also cut clips while playing back your project. To cut clips on the fly, press Command-B at any time while your project plays back.

An edit point appears as a dotted line where you clicked, and the clip is divided into two clips. The dotted line indicates a through edit, in which the media content on either side of the edit point is continuous.

To remove a through edit, do one of the following:

- Select either or both sides of the through edit point, then choose Trim > Join Clips (or press Delete).
- Select the clips on both sides of the through edit, then choose Trim > Join Clips.
**Cut all clips at once**

You can use the Blade All command to cut all primary storyline clips and connected clips at the skimmer or playhead location simultaneously.

1. In the Final Cut Pro timeline, move the skimmer to the frame where you want to cut.
2. Choose Trim > Blade All (or press Shift-Command-B).
   
   All clips at the skimmer position are cut.

**Cut multiple selected clips at once**

You can use the Blade command to cut selected primary storyline clips and connected clips simultaneously.

1. In the Final Cut Pro timeline, select the clips you want to cut.
2. Move the skimmer to the frame where you want to cut.
3. Choose Trim > Blade (or press Command-B).
   
   The selected clips are cut at the skimmer position.

*Note:* If you don’t make a selection, this command acts only on the clip in the primary storyline.
Extend or shorten clips in Final Cut Pro for Mac

You can trim a clip in your project by adjusting the start point or end point of the clip.

The default type of trim in Final Cut Pro is a ripple edit, which adjusts a clip’s start point or end point without leaving a gap in the timeline. The change in the clip’s duration ripples outward, moving all subsequent clips earlier or later in the timeline.

Before edit

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
</table>

After edit

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
</table>

Similarly, if you delete a clip from the timeline, subsequent clips ripple earlier to close the gap. Ripple edits affect the trimmed clip, the position of all subsequent clips in the timeline, and the total duration of your project.

You can see a “two-up” display in the viewer as you trim edit points in the timeline. This display shows a more detailed view of each side of an edit point. See Show trimming details in the viewer.

Drag edit points with the Select tool

1. In the Final Cut Pro timeline, move the pointer to the start point or the end point of the clip you want to trim.

   The pointer changes from an arrow icon to a trim icon. The look of the trim icon changes to indicate whether the trim will affect the end point of the left clip or the start point of the right clip.

2. Drag the start point or the end point in the direction you want to trim the clip.

   As you drag, the clip shortens or lengthens. Numerical timecode fields indicate the duration of the clip and the amount of time you’re moving the edit point.
Any clips to the right of the edit point are rippled accordingly.

When you extend a clip to its maximum length in either direction, the clip edge turns red.

![Timecode Display](image)

**Enter a new duration for a clip using timecode**

You can change the total duration of one or more selected clips by entering a timecode value.

1. In Final Cut Pro, select one or more clips in the timeline.
2. Do one of the following:
   - Choose Modify > Change Duration (or press Control-D).
   - Double-click the timecode display below the viewer.

   The timecode display changes to reflect the total duration of the clip or clips you selected in step 1.

![Timecode Display](image)

3. Enter a new duration for the selected clip.

   The end point of the clip is moved to the duration you entered, and any subsequent timeline clips ripple accordingly. If you enter a duration longer than the available media in the clip, the duration is extended to the maximum length of the clip.

   For more information about entering timecode values, see [Navigate using timecode](#).

**Trim to a selection**

1. In the Final Cut Pro timeline, select the part of a clip that you want to keep.

![Range Selection](image)

   For information about making range selections, see [Select ranges](#).
2. Choose Trim > Trim Selection.

Final Cut Pro trims the clip start and end points to match the range selection.

The unwanted sections are removed from the clip and the project, and the subsequent clips in the project ripple accordingly.

**Nudge edit points with keyboard shortcuts**

You can fine-tune the start or end point of a clip using keyboard shortcuts. You can move the edit point by one or more video frames. You can also move the edit points of connected audio clips (those not in the primary storyline) by subframes.

1. In the Final Cut Pro timeline, select the start or end point of the clip you want to trim.

2. To move the edit point, do any of the following:
   - *Move the edit point left by one frame*: Press Comma (,).
   - *Move the edit point left by 10 frames*: Press Shift-Comma (,).
   - *Move the edit point right by one frame*: Press Period (.).
   - *Move the edit point right by 10 frames*: Press Shift-Period (.).

3. If you want to move the edit point of connected audio clips by one or more subframes, do any of the following:
   - *Move the edit point left by one subframe*: Press Option-Comma (,).
   - *Move the edit point left by 10 subframes*: Press Option-Shift-Comma (,).
   - *Move the edit point right by one subframe*: Press Option-Period (.)
   - *Move the edit point right by 10 subframes*: Press Option-Shift-Period (.)

For more information about subframes, see [Zoom in to audio waveforms](#).
Move edit points to the playhead or skimmer position

You can adjust selected edit points in the timeline, either as a ripple edit or as a roll edit, using keyboard shortcuts.

1. In the Final Cut Pro timeline, select the edit point you want to adjust.

![Selected end point]

Note: For a roll edit, select both sides of the edit point with the Trim tool.

2. Position the playhead or the skimmer at the point in the timeline to which you want to move the edit point.

![Skimmer]

3. Choose Trim > Extend Edit (or press Shift-X).

The edit point is extended (or shortened) to the playhead or skimmer position.

![The clip's end point is extended to the skimmer position, and subsequent clips ripple right.]

In the example above, if you selected the end point of the clip, subsequent clips in the timeline are rippled accordingly. If you selected both sides of the edit point with the Trim tool, the right clip is shortened (with a roll edit) and no clips ripple.
Trim edit points using timecode

You can trim clips numerically by entering timecode values.

1. In Final Cut Pro, if the Select tool is not the active tool, click the Tools pop-up menu in the top-left corner of the timeline and choose Select (or press A).

2. In the timeline, select the start point or the end point of the clip you want to trim.

3. To trim the edit point, do one of the following:
   
   - Move the edit point forward: Press the Plus Sign (+) key, type a timecode duration for the trim, and press Enter.
   - Move the edit point back: Press the Minus Sign (–) key, type a timecode duration for the trim, and press Enter.

   The timecode display below the viewer shows the duration of the trim.

The clip is shortened or extended by the amount of time you entered, and subsequent clips in the timeline are rippled accordingly.

Note: You can’t extend a clip beyond its maximum duration.

For more information and tips on entering timecode, see Navigate using timecode.
Cut the start or end of a clip at the playhead

Some of your video clips may have sections at the beginning or the end that you don’t want to include in your project. You can easily trim off these ranges with a single command, even while playing back the project. No selections are required. This type of edit is sometimes called a *top and tail* edit.

1. In the Final Cut Pro timeline, position the playhead or the skimmer on the frame at which you want to trim the clip.

![Original clip and skimmer](image)

2. Do one of the following:
   - *Trim off the start of the clip:* Choose Trim > Trim Start, or press Option-Left Bracket ([).
   - *Trim off the end of the clip:* Choose Trim > Trim End, or press Option-Right Bracket (])
   - *Trim the edit point closest to the playhead:* Choose Trim > Trim to Playhead, or press Option-Backslash (\).

The clip is trimmed to the playhead (or skimmer) position, and the timeline is updated accordingly.

![New end point](image)

In the case of connected clips or storylines, the selected clip is trimmed. If there's no selection, the topmost clip is trimmed.
Align audio to video

At any time, you can align audio to video for clips or components in your project to make the video and audio start and end points match. This clears any split edits you made.

You can select multiple clips or components.

1. In the Final Cut Pro timeline, select the clips or components you want to align.
2. Choose Trim > Align Audio to Video.

Note: If you’re working on numerous split edits throughout your project, you might find it convenient to show expanded audio by displaying audio roles in separate lanes. See Organize the timeline with audio lanes.

Make roll edits in Final Cut Pro for Mac

A roll edit adjusts the start point and the end point of two adjacent clips simultaneously. If you like where two clips are placed in the timeline but want to change when the cut point happens, you can use the Trim tool to roll the edit point between the two clips. No clips move in the timeline as a result; only the edit point between the two clips moves. No other clips in the project are affected.

When you perform a roll edit, the overall duration of the project stays the same, but both clips change duration. One gets longer, and the other gets shorter to compensate.

![Before and After Roll Edit Example](image)

Before edit

![Before and After Roll Edit Example](image)

After edit

In the example above, clip B gets shorter while clip C becomes longer, but the combined duration of the two clips stays the same.

You can see a “two-up” display in the viewer as you trim edit points in the timeline. This display shows a more detailed view of each side of an edit point. See Show trimming details in the viewer.

1. In Final Cut Pro, click the Tools pop-up menu in the top-left corner of the timeline and choose Trim (or press T).

![Trim Tool Pointer](image)

The pointer changes to the Trim tool.

Tip: To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the tool reverts to the previously active tool.
2. In the timeline, click the center of the edit point you want to roll, so that both sides of the edit point are selected.

3. Do one of the following:
   - Drag the edit point left or right.
   - Press the Plus Sign (+) key or the Minus Sign (–) key followed by the timecode duration to add or subtract from the current edit, then press Return.
     
     The timecode display below the viewer shows the duration of the trim.
     
     For more information about entering timecode values, see Navigate using timecode.
   - Position the playhead or the skimmer at a point in the timeline to which you want to move the edit point, then choose Trim > Extend Edit (or press Shift-X).
     
     The edit point is rolled to the new location. The combined duration of the two clips stays the same.

If you can't roll the edit point any farther and one side of the edit point appears red, you've reached the end of the media for one of the two clips.
Make slip edits in Final Cut Pro for Mac

Performing a *slip edit* doesn’t change a clip’s position or duration in the timeline, but instead changes what portion of the clip’s media appears in the timeline. A slip edit allows you to change a clip’s start and end points simultaneously.

Whenever you arrange clips in the timeline so that edit points line up with musical beats or other fixed sync points in a movie, you want to keep your clips in position to maintain the alignment. These situations leave you with very little room to adjust a clip, because you can’t change its duration or move it elsewhere in the timeline. All you can do is move both the start and end points of the clip simultaneously, keeping the clip’s position and duration fixed. Surrounding clips are not affected, and the overall duration of your project doesn’t change.

![Diagram of slip edit example]

In the example above, the slip edit changes the start and end points of clip B, but not its duration or position in the timeline. When the project plays back, a different portion of clip B’s media is shown.

*Note:* To slip a clip, it must have media handles on both sides, meaning that there must be additional media available on both sides of the clip. If you’re having trouble slipping a clip, check that it has media handles on both sides. You can double-click any edit point to view or adjust media handles in the precision editor.

If there are no media handles available, consider using the Position tool instead. See [Overwrite clips using the Position tool](#).

For more accurate visual feedback on edits involving contiguous clips, you can see a “two-up” display in the viewer. For a slip edit, the two-up display shows the start and end points of the clip you’re slipping. See [Show trimming details in the viewer](#).

1. In Final Cut Pro, click the Tools pop-up menu in the top-left corner of the timeline and choose Trim (or press T).

![Trim tool menu]

The pointer changes to the Trim tool.

⚠️ **Tip:** To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the tool reverts to the previously active tool.
2. Drag a clip left or right.

As you drag, a timecode field indicates the amount of time you're moving the start point and the end point. Yellow edge selections on the start point and end point indicate a slip edit.

When you release the mouse or trackpad button, the slipped clip appears in the timeline with a new start point and a new end point.

Note: If either the start point or the end point turns red as you drag, you’ve reached the end of the available media for that side of the clip.

With the current selection, you can also slip the clip with keyboard shortcuts by doing one of the following:

- Press Comma (,) or Period (.) to nudge the start and end points one frame to the left or right. You can also press Shift-Comma or Shift-Period to nudge the start and end points 10 frames to the left or right.
- Press the Plus Sign (+) key or the Minus Sign (–) key followed by the timecode duration to slip the clip left or right, then press Return.
Make slide edits in Final Cut Pro for Mac

Performing a slide edit allows you to move a clip's position in the timeline between two other clips without creating a gap. The clip's content and duration remain the same; only its position in the timeline changes. When you slide a clip, the adjacent clips get longer and shorter to accommodate the change in the clip's position. The combined duration of these three clips stays the same, and the project's total duration remains unchanged as well.

Note: To slide a clip between two others, the preceding clip and the following clip must have media handles (additional media available beyond the edit point). You can double-click any edit point to view or adjust its media handles in the precision editor.

If there are no media handles available, consider using the Position tool instead. See Overwrite clips using the Position tool.

For more accurate visual feedback on edits involving contiguous clips, you can see a “two-up” display in the viewer. For a slide edit, the two-up display shows the two edit points you’re adjusting: the end point of the preceding clip and the start point of the subsequent clip. See Show trimming details in the viewer.

1. In Final Cut Pro, click the Tools pop-up menu in the top-left corner of the timeline and choose Trim (or press T).

The pointer changes to the Trim tool.

Tip: To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the tool reverts to the previously active tool.
2. Option-drag a clip to the left or right.

Yellow selections on the neighboring clips indicate a slide edit.

As you drag, a timecode field indicates the amount of time you're moving the clip in the timeline.

When you release the mouse or trackpad button, the slide clip appears at the new position in the timeline. The adjacent clips are trimmed to accommodate the change in the clip's position.

Note: If either edit point turns red as you drag, you've reached the end of the available media for that side of the clip.

With the current selection, you can also slide the clip with keyboard shortcuts by doing one of the following:

- Press Comma (,) or Period (.) to nudge the start and end points one frame to the left or right. You can also press Shift-Comma or Shift-Period to nudge the start and end points 10 frames to the left or right.
- Press the Plus Sign (+) key or the Minus Sign (–) key followed by the timecode duration to slide the clip left or right, then press Return.

See Arrange clips in the timeline.
Create split edits in Final Cut Pro for Mac

You can set separate video and audio start and end points in an individual clip, creating a *split edit*. You can use a split edit to introduce the sound of a new shot or scene before cutting to the video of that shot or scene, or to extend the audio of a shot over a subsequent shot. For example, you could cut from a clip of a person talking to video of a person listening, while the audio from the first clip continues.

You can use split edits in many different situations—in dialogue scenes, when cutting to illustrative B-roll footage during an interview, or when transitioning from one scene to another. Split edits help you create seamless edits from one shot to the next.

The split edit technique results in L-shaped and J-shaped clips with audio extending to the left or the right. These are known as *L-cuts* and *J-cuts*.

Create a split edit by dragging

To create the split edit, you extend the audio of one clip over a neighboring clip. In this example, the audio from the close-up shot is extended over the previous shot to create a J-cut.

1. In Final Cut Pro, add clips to the timeline in the order in which you want them to appear in your movie.

2. To show separate audio for the clip you want to edit, do one of the following:
   - Select the clip in the timeline, then choose Clip > Expand Audio (or press Control-S).
   - Double-click the clip’s audio waveform.
   - **Show audio lanes in the timeline** for the clips you want to edit.

The audio and video portions of the clip appear as discrete elements that you can change individually. The audio and video are still attached and will remain in sync.
3. Drag the start point (left edge) of the video portion of the clip to the right, effectively trimming it with a roll edit.

The example below shows the video start point of the close-up shot being dragged to the right.

This creates a J-shaped split edit, with the start point of the audio overlapping the preceding clip.

4. To complete the split edit, show separate audio for the preceding clip, then do one of the following:

• Drag the preceding clip’s end point to the left so that the two audio clips no longer overlap.

• Adjust the audio level of either clip (using keyframes or audio fade handles) so that the audio overlap sounds natural.
5. If you want to turn off the separate audio view to “clean up” the affected clips, do one of the following:
   • Select the clip in the timeline, then choose Clip > Collapse Audio (or press Control-S).
   • Double-click the clip’s audio waveform.

When you play back this section of the timeline, the person in the close-up shot begins to speak before the video cuts to the close-up.

**Create a split edit using keyboard shortcuts**

You can create split edits quickly using keyboard shortcuts. In this example, the audio from the close-up is extended over the medium shot to create a J-cut.

1. In Final Cut Pro, confirm that the two adjacent clips have sufficient media handles. If not, trim the clips (shorter) to create the media handles.

2. To show separate audio for the two adjacent clips, do one of the following:
   • In the timeline, select the clips whose audio you want to expand, then choose Clip > Expand Audio (or press Control-S).
   • Double-click the clip’s audio waveform.

3. Move the playhead to the edit point between the two clips.
To ensure accurate playhead placement, use keyboard shortcuts:

- **Move the playhead to the previous edit point**: Press Semicolon (;) or the Up Arrow key.
- **Move the playhead to the next edit point**: Press Apostrophe (’) or the Down Arrow key.

4. Do one of the following:
   - **Select both sides of the audio edit point**: Press Shift-Backslash (\).
   - **Select both sides of the video edit point**: Press Backslash (\).

5. To **roll** the audio edit point or the video edit point, do any of the following:
   - **Nudge the edit point left or right**: Press Comma (,) or Period (.), respectively.
   - **Nudge the edit point 10 frames left or right**: Press Shift-Comma (,) or Shift-Period (.), respectively.
   - **Add or subtract from the current edit using timecode**: Press the Plus Sign (+) or Minus Sign (–) key followed by the timecode duration, then press Return.

   The timecode entry field (with blue numbers) appears below the viewer as you type. For more information about entering timecode values, see Navigate using timecode.

When you play back this section of the timeline, the person in the close-up shot begins to speak before the video cuts to the close-up.
Align audio to video

If you perform a split edit that extends the audio portion of a clip beyond the video portion, you can quickly put the audio and video back into alignment so that the video and audio start and end points match.

1. In the Final Cut Pro timeline, select the clips or components you want to align.
2. Choose Trim > Align Audio to Video.

If you select a component, the audio is aligned on both edges of that component. If you select the edge of a component, only that edge is aligned.

Note: If you’re working on numerous split edits throughout your project, you might find it convenient to show expanded audio by displaying audio roles in separate lanes. See Organize the timeline with audio lanes.

Show trimming details in the viewer in Final Cut Pro for Mac

For more accurate visual feedback on edits involving contiguous or connected clips, you can see a “two-up” display in the viewer. For example, for a simple ripple edit, this two-up display shows the end point of the left clip and the start point of the right clip.

This display is available for ripple edits, roll edits, slip edits, and slide edits, as well as for trimming in the precision editor.

1. Choose Final Cut Pro > Settings, or press Command-Comma (,).
2. Click Editing.
3. In the Timeline section, select the “Show detailed trimming feedback” checkbox.

The two-up display appears in the viewer whenever you use a supported edit type or when trimming in the precision editor.

⚠️ Tip: You can use the Option key to change the detailed trimming feedback display on the fly. If detailed trimming feedback is enabled, press the Option key to disable it. If detailed trimming feedback is disabled, press the Option key to switch the view between the end point of the left clip and the start point of the right clip.
View and navigate

Scroll in the timeline in Final Cut Pro for Mac

You can set the timeline to scroll continuously during playback, so that the timeline always shows the section of the project playing in the viewer. When the timeline is zoomed in, you can also scroll manually to see other parts of your project.

Set the timeline to scroll automatically during playback

• In Final Cut Pro, choose Final Cut Pro > Settings (or press Command-Comma), click Playback, then select “Scroll timeline continuously during playback.”

When you play a project that extends beyond the visible timeline, the playhead moves to the center of the timeline and then remains there as the clips currently playing in the viewer pass beneath. During automatic scrolling, you can continue to make edits in the timeline and use the J, K, and L keys to control playback.

Manually scroll a zoomed-in timeline

1. In Final Cut Pro, zoom in to the timeline until you see a portion of the project only.
2. Do one of the following:
   • Drag the scroll bar at the bottom of the timeline left or right.
   • Drag the scroll bar at the right side of the timeline up or down.
   • Click the Tools pop-up menu in the top-left corner of the timeline and choose Hand (or press H), then drag in the timeline.

Tip: To switch to the Hand tool temporarily, hold down the H key. When you release the H key, the tool reverts to the previously active tool.

To change how scroll bars appear and behave, choose Apple menu > System Settings, click Appearance in the sidebar, then modify the scroll bar settings on the right.
Zoom in to and out of the timeline in Final Cut Pro for Mac

Being able to see and get to any point in your project is critical to efficient editing and storytelling. There are many ways to adjust the view of the timeline.

**Zoom in to and out of the timeline using commands**

In Final Cut Pro, do any of the following:

- **Zoom in to the timeline**: Choose View > Zoom In, or press Command-Plus Sign (+).
- **Zoom out of the timeline**: Choose View > Zoom Out, or press Command-Minus Sign (–).

**Zoom in to and out of the timeline using the Zoom tool**

1. In Final Cut Pro, click the Tools pop-up menu in the top-left corner of the timeline and choose Zoom (or press Z).

![Zoom tool](image)

The pointer changes to the Zoom tool.

️ **Tip**: To switch to the Zoom tool temporarily, hold down the Z key. When you release the Z key, the tool reverts to the previously active tool.

2. Do any of the following:

   - **Zoom in to the timeline**: Click the section of the timeline you want to zoom in to. (You can also drag over an area of the timeline to zoom in to just that area.)
     
     Click multiple times to continue zooming in.

   - **Zoom out of the timeline**: Option-click the section of the timeline you want to zoom out of.
     
     Option-click multiple times to continue zooming out.

**Fit the timeline contents into the available window size**

Whether you’re zoomed in to a single clip or zoomed out so far that all the clips in your project appear on the left side of the timeline, you can quickly change the view so that all the clips fill the visible part of the timeline and no scrolling is required.
- In Final Cut Pro, choose View > Zoom to Fit (or press Shift–Z).

Before choosing Zoom to Fit

After choosing Zoom to Fit

**Zoom in to and out of the timeline using the Zoom slider**

1. In Final Cut Pro, click the Clip Appearance button in the top-right corner of the timeline.

   ![Clip Appearance button](image)

   The clip appearance controls appear.

2. Do any of the following:
   - *Zoom in to the timeline*: Drag the Zoom slider to the right, or press Command-Plus Sign (+).
   - *Zoom out of the timeline*: Drag the Zoom slider to the left, or press Command-Minus Sign (–).

   ![Zoom slider](image)

   You can also use a variety of keyboard shortcuts and Multi-Touch gestures to zoom and scroll in the timeline. See [Keyboard shortcuts](#) and [Multi-Touch trackpad gestures](#).
Adjust timeline clip appearance in Final Cut Pro for Mac

In Final Cut Pro, you can change how clips are displayed in the timeline. For example, you can show clips with or without video filmstrips or audio waveforms. You can also change the vertical height of clips, and adjust the relative size of video filmstrips and audio waveforms in clip thumbnails. You can also show only the clip labels.

1. In Final Cut Pro, click the Clip Appearance button in the top-right corner of the timeline.

The clip appearance controls appear.

2. To adjust the display of filmstrips and waveforms in timeline clips, click a clip appearance button.

- **Display clips with large audio waveforms only**: Click the leftmost button (or press Control-Option-1).
- **Display clips with large audio waveforms and small filmstrips**: Click the second button from the left (or press Control-Option-2).
- **Display clips with audio waveforms and video filmstrips of equal size**: Click the third button from the left (or press Control-Option-3).
- **Display clips with small audio waveforms and large filmstrips**: Click the third button from the right (or press Control-Option-4).
- **Display clips with large filmstrips only**: Click the second button from the right (or press Control-Option-5).
- **Display clip labels only**: Click the rightmost button (or press Control-Option-6).
Tip: To increase the size of audio waveforms for timeline clips, press Control-Option-Up Arrow. To decrease the size of audio waveforms for timeline clips, press Control-Option-Down Arrow.

3. To adjust the vertical height of clips in the timeline, drag the Clip Height slider to the left to decrease the clip height, or to the right to increase the clip height.

4. To adjust the display of clip labels, do any of the following:
   - View clips by name: Select the Clip Names checkbox.
   - View multicam clips by the name of the active video angle and the active audio angle: Select the Angles checkbox.
   - View clips by role: Select the Clip Roles checkbox.
   - Always show lane names (so the names aren’t obscured by clips): Select the Lane Headers checkbox.
   - Show duplicate range indicators (diagonal lines) on clips with media that appears more than once in a project: Select the Duplicate Ranges checkbox.

Snap to items in the timeline in Final Cut Pro for Mac

The snapping feature in Final Cut Pro makes it easier and quicker to do things like line up a video clip with an audio clip or align the playhead to a particular marker. When snapping is turned on, items you move in the timeline appear to jump, or “snap,” directly to certain points. This can help you quickly line up edits with other items in the project.

Snapping affects the functions of many of the editing tools in Final Cut Pro, including the Select tool, the Trim tool, the Position tool, the Range Selection tool, and the Blade tool. Several elements trigger snapping in the timeline:
   - Clip boundaries (start and end points)
   - The playhead and the skimmer
   - Markers
   - Keyframes
   - Range selections

You can turn snapping on or off, even while you’re dragging a clip. For example, if you’re trying to move a clip only a few frames among a series of markers and clip boundaries, you can turn off snapping so that the clip doesn’t snap to any of these points.

Turn snapping on or off

In Final Cut Pro, do one of the following:
   - Choose View > Snapping (or press N).
     A checkmark next to the menu item indicates that snapping is on.
   - Click the Snapping button in the top-right corner of the timeline.

When snapping is on, the Snapping button is highlighted.
Tip: To turn snapping on or off temporarily, hold down the N key. When you release the N key, snapping reverts to its previous state.

Navigate your project in Final Cut Pro for Mac

The ability to jump to any point in the timeline instantly is one of the main benefits of a nonlinear editing environment. Final Cut Pro provides a variety of quick and easy ways to navigate your project.

You can also use a text-based view of the timeline to navigate and search your project. See View your project in the timeline index.

You can use the J, K, and L keys to play through a project with different speeds or directions. See Play media.

Navigate by skimming, clicking, or dragging

In Final Cut Pro, do any of the following:

- **Skim to a frame in your project**: Move the skimmer left and right over the clips in the timeline to quickly view them in the viewer.
- **Move the playhead to a frame in your project**: Move the playhead by clicking or dragging in the ruler at the top of the timeline, or by clicking the timeline background.

Tip: To prevent the playhead from moving while you select a clip in the timeline, press Option as you click.

Navigate frame by frame

To make it easier to find specific frames in a clip, you can step through the filmstrip frame by frame, rather than skimming it.

1. In the Final Cut Pro timeline or browser, move the pointer over a filmstrip, then click.
2. Do any of the following:
   - **Move backward in one-frame increments**: Choose Mark > Previous > Frame (or press the Left Arrow key).
   - **Move forward in one-frame increments**: Choose Mark > Next > Frame (or press the Right Arrow key).

Navigate subframe by subframe

You can navigate clips by subframes. A subframe has 1/80 the duration of a video frame and is a more precise unit of reference when viewing or editing audio waveforms that are zoomed in to the sample level.

Note: You can’t make edits to video at the subframe level.

1. In the Final Cut Pro timeline or browser, move the pointer over a clip, then click.
2. Do any of the following:
   - **Move backward in one-subframe increments**: Press Option-Left Arrow.
   - **Move forward in one-subframe increments**: Press Option-Right Arrow.

Note: You can change the timecode display below the viewer to show subframes. See Editing settings.
Navigate by jumping

You can move the playhead quickly from point to point in the timeline.

In Final Cut Pro, do any of the following:

• Go to the next edit point: Choose Mark > Next > Edit (or press the Down Arrow key).
• Go to the previous edit point: Choose Mark > Previous > Edit (or press the Up Arrow key).
• Go to the start of the project: Choose Mark > Go to > Beginning (or press the Home key).
• Go to the end of the project: Choose Mark > Go to > End (or press the End key).
• Go to the next marker: Choose Mark > Next > Marker, or press Control-Apostrophe (’).
• Go to the previous marker: Choose Mark > Previous > Marker, or press Control-Semicolon (;).

For more information about markers, see Intro to markers.

Navigate using timecode in Final Cut Pro for Mac

Timecode is a signal recorded with your video that uniquely identifies each video frame. When you play a clip from the browser, its timecode signal appears in a display below the viewer, using this format:

```
01:40:31:03
```

Timecode supports a variety of functions in Final Cut Pro, including timeline playback, syncing video and audio clip items, and adding, trimming, and moving clips. In addition, timecode allows you to navigate through projects in the timeline and see the duration of clips, range selections, and projects.
To move the playhead to a new timeline location in Final Cut Pro, do any of the following:

- **Move the playhead to a specific timeline location:** Click once in the center of the timecode display below the viewer (or press Control-P), enter the new timecode value, and press Return.

  For example, to move the playhead to 01:40:31:03, press Control-P, then enter “1403103” and press Return.

  ![Timecode Display](image)

- **Move the playhead by a timecode duration:** Make sure no clips are selected, then press the Plus Sign (+) or Minus Sign (–) key, enter the number of frames, seconds, or minutes you want to move the playhead, and press Return.

  For example, if you type “+1612” and press Return, the playhead moves ahead 16 seconds and 12 frames.

  ![Timecode Duration](image)

  The new timecode values appear in the timecode display as you enter them. When you press Return, the playhead moves to the new timeline location.

Here are some tips for entering timecode values:

- You don’t have to enter the separator characters (colons). Final Cut Pro adds them automatically after each set of two digits. For example, if you enter “01221419,” the timecode value is interpreted as 01:22:14:19 (1 hour, 22 minutes, 14 seconds, and 19 frames).

- If the leftmost fields are zeros, you don’t have to enter them. For example, if you enter “1419,” the timecode value is interpreted as 00:00:14:19. If you enter “253407,” the timecode value is interpreted as 00:25:34:07.

- If the rightmost fields are zeros, you can use periods instead. For example, to move to timecode 00:00:03:00, type “3.” (3 and a period). To move to 03:00:00:00, type “3...” (3 and three periods). Instead of a period, you can also use a comma, colon, or semicolon.

- You can copy and paste timecode (for example, to speed up timeline navigation or numerical entry from text documents, or to add timecode to notes). To copy timecode from the playhead position, choose Edit > Copy Timecode. To paste timecode into the timecode display, click once in the center of the timecode display below the viewer (or press Control-P), then press Control-V. For other ways to copy timecode, see Copy source or project timecode.

You can change the timecode display to show either timecode, timecode and subframes, just frames, or just seconds. See Editing settings.

💡 Tip: You can view source and project timecode in resizable, floating windows, or set Final Cut Pro to show clip source timecode (rather than the project timecode) when you skim clips in the timeline.
View source and project timecode in Final Cut Pro for Mac

You can view timecode in a resizable, floating window while you’re working on a project in the timeline. You can view either source timecode (the timecode originally embedded in the source clip) or project timecode (the time elapsed since the project’s starting timecode).

The source timecode window shows the names and source timecode of all the clips at the current playhead position in the timeline, starting with the topmost clip. Showing source timecode makes it easy to match or locate specific moments in a source clip.

The project timecode window shows the project timecode at the current playhead position in the timeline. You can place the project timecode window anywhere on your screen and enlarge it to make it more readable.

You can also set Final Cut Pro to show clip source timecode (rather than the project timecode) when you skim clips in the timeline.
Show source or project timecode in a floating window

1. In Final Cut Pro, do one of the following:
   - **Show source timecode**: Choose Window > Source Timecode, or Option-click in the center of the timecode display below the viewer.
     - **Tip**: Select a clip in the timeline to highlight the corresponding row in the source timecode window with a yellow box.
   - **Show project timecode**: Choose Window > Project Timecode, or Shift-click in the center of the timecode display below the viewer.

2. To adjust timecode window display settings, use the pop-up menu in the upper-right corner of the source timecode window or project timecode window.

   The following settings are available for the source timecode window:
   - **Project Timecode**: Show or hide the project timecode at the top of the source timecode window.
   - **Source Timecode**: Show or hide the source timecode for all the clips at the current playhead position.
   - **Clip Names**: Show or hide the clip names for all the clips at the current playhead position.
   - **Clip Roles**: Show or hide the assigned roles for all the clips at the current playhead position.

   The following setting is available for both timecode windows:
   - **Background**: Set the opacity of the timecode window background to 50%, 75%, or Solid.

3. To resize the timecode window, do any of the following:
   - **Resize the timecode and text**: Drag a corner of the source or project timecode window.
   - **Show more or fewer rows**: Drag the bottom edge of the source timecode window.
   - **Provide more or less space for the clip names**: Drag the right edge of the source timecode window.

Copy source or project timecode

When editing a project, you sometimes need to copy timecode from one app to another—for example, from clips in your project to a spreadsheet, an EDL, or an email.

1. In Final Cut Pro, show the source timecode window or the project timecode window.
   - See **Show source or project timecode in a floating window**, above.

2. Control-click a timecode item in the source timecode window or the project timecode window, then choose one of the following:
   - **Copy Timecode**: Copy the timecode for the item you clicked.
   - **Copy [item]**: Copy the timecode, clip name, and assigned roles for the item you clicked.
   - **Copy All**: Copy the timecode for all items in the window.

   The timecode information is copied to the Clipboard. You can now paste it into any app or document that accepts text.
Show source timecode when skimming clips in the timeline

By default, when you skim clips in the timeline, the timecode display shows the project timecode, but you can set Final Cut Pro to show source timecode instead.

1. To turn on video and audio skimming in Final Cut Pro, do one of the following:
   - Choose View > Skimming (or press S), so that a checkmark appears next to the menu item.
   - Click the Skimming button in the top-right corner of the timeline.

   When skimming is on, the Skimming button is highlighted.

2. Choose View > Clip Skimming, so that a checkmark appears next to the menu item.

3. In the timeline, position the pointer on a clip’s filmstrip, then skim.

   The clip’s source timecode appears in the timecode display as you skim. If you move the pointer above or below the clip’s filmstrip, the timecode display shows the project timecode.

   Note: When skimming is turned off, you can still view source timecode for timeline clips by skimming with the Blade, Trim, and Range Selection editing tools. See Skim clips with editing tools.

View your project in the timeline index in Final Cut Pro for Mac

The timeline index provides a list of the clips, tags (various kinds of markers and keywords), and roles used in your project in the timeline. You can easily filter items in the timeline index to show only the ones you want to see.

You can also use the timeline index to navigate in the timeline. The timeline index playhead appears in the list of items. When you play a project, the playhead moves down the list of items in the timeline index. When you select an item in the timeline index, the playhead automatically moves to the beginning of the item.
Show or hide the timeline index

- In Final Cut Pro, click Index in the top-left corner of the timeline (or press Shift-Command-2).

The timeline index appears to the left of the timeline.

View and manage clips in the timeline index

1. In Final Cut Pro, click Index in the top-left corner of the timeline to open the timeline index.

2. Click the Clips button at the top.

The timeline index displays a list of the clips used in the timeline, ordered chronologically.
3. To customize the display of clips in the timeline index, do any of the following:

   • *Change the type of clips shown:* Click a button at the bottom of the timeline index. You can show all clips, video clips, audio clips, or titles.
   
   ![Timeline index buttons](image)

   • *Change which columns are shown:* Control-click a column heading and choose an option. (Not all columns are shown by default.)

   ![Column selection](image)

4. To work with clips in your project, do any of the following:

   • *Rename clips:* Click a name in the Name column, press Return, then type a new name.

   • *View clips by timecode:* View a clip’s timecode in the Position column.

   • *Assign roles:* Edit and reassign subroles in the Video Roles and Audio Roles columns. See *Assign roles in the timeline index*.

   • *Add or edit notes for a clip:* Click the text field in the Notes column, then enter or change note text. See *Add or edit clip notes in the timeline index*.

   • *View the active angles of multicam clips:* View active angles in the Active Angle column. See *Intro to multicam editing*.
View all the tags on clips in the timeline
Tags include keywords and various kinds of markers—standard markers, chapter markers, and completed and incomplete to-do items. See Intro to markers.

1. In Final Cut Pro, click Index in the top-left corner of the timeline to open the timeline index.
2. Click the Tags button at the top.

   The timeline index displays a list of all the tags on clips in the timeline, ordered chronologically.

   ![Image of timeline index with tags]

   All of the tags are shown by default. You can specify which items are displayed by clicking a button at the bottom of the timeline index. You can show markers, keywords, analysis keywords, incomplete to-do items, completed to-do items, and chapter markers.

View and manage roles in the timeline index
You can view a list of roles in the timeline, and control the arrangement of the timeline.

1. In Final Cut Pro, click Index in the top-left corner of the timeline to open the timeline index.
2. Click the Roles button at the top.
3. Do any of the following:
   - *Highlight all the clips in the timeline with a particular role assigned:* Click a role name in the list.
   - *Turn a role on or off in the timeline:* Select or deselect the checkbox next to a role.
   
   When a role is turned off, you can't see or hear clips with that assigned role when you play back your project. For more information about roles, see *Intro to roles* and *Organize the timeline with audio lanes.*

**Search for items in the timeline index**

1. In Final Cut Pro, click Index in the top-left corner of the timeline to open the timeline index.

   ![Tip](icon.png) **Tip:** You can quickly open the timeline index with the search field active and ready for your search term. With the timeline active, choose Edit > Find (or press Command-F).

2. Click a button at the top of the timeline index to open the pane you want to search.

   Click Clips to search for clips, Tags to search for tags, or Roles to search for roles.

3. Enter a term in the search field at the top of the timeline index.

   You can search for clips, keywords, markers (including to-do items), captions, roles, notes, and custom metadata fields.

   You can also search using keywords that are added automatically by Final Cut Pro. For example, you can search for the following:
   - *Clips with the missing media alert icon:* Enter “missing.”
   - *Multicam clips:* Enter “multicam.”
   - *Compound clips:* Enter “compound.”
   - *Synced clips:* Enter “synchronized.”
   - *Auditions:* Enter “audition.”

**Show duplicate ranges in the timeline index**

1. In Final Cut Pro, click Index in the top-left corner of the timeline to open the timeline index.

2. Click the Clips button at the top.

3. Click the search field pop-up menu at the top of the timeline index, then choose *Show Clips with Duplicate Ranges.*

   The timeline index displays a chronological list of the clips with media that appears more than once in the project, and the duplicate ranges are highlighted with diagonal lines in the timeline.

   For more information, see *Show clips with duplicate ranges.*
Show clips with duplicate ranges in Final Cut Pro for Mac

You can quickly locate media that appears more than once in a Final Cut Pro project using highlighted clip ranges in the timeline or the timeline index.

View clips with duplicate ranges

1. In Final Cut Pro, open a project in the timeline.
2. Do one of the following:
   - Choose View > Show Duplicate Ranges.
   - Click the Clip Appearance button in the top-right corner of the timeline, then select the Duplicate Ranges checkbox. See Adjust timeline clip appearance.
   - Open the timeline index, click the search field pop-up menu at the top left, then choose Show Clips with Duplicate Ranges. See Show duplicate ranges in the timeline index.

Clips with duplicate ranges are highlighted with diagonal lines in the timeline and the timeline index.
Navigate between duplicate ranges

1. In the Final Cut Pro timeline or timeline index, select a clip that has a duplicate range.

2. To navigate to clips containing the same duplicate range, do any of the following:
   - Use keyboard shortcuts: Select the original clip, then press Option-Command-Right Arrow to move the playhead to the next instance, or press Option-Command-Left Arrow to move the playhead to the previous instance.
   - Use the timeline index: In the Clips pane of the timeline index, select the original clip, then select one of the other highlighted clips containing the same duplicate range.

![Image showing clips with duplicate ranges and timeline index]

Work with markers

Intro to markers in Final Cut Pro for Mac

Markers are reference points you can place within clips to locate, identify, annotate, and navigate to specific frames.

In Final Cut Pro, you can use markers to:

- Sync two or more clips at a specific point. For example, you can use a marker to label the frame where a door slams and then snap a sound effect to that marker.
- Flag a specific location in a clip with editing notes or other descriptive information.
- Add chapter markers to specific points in your project, so that viewers can jump to those points in the movie after it’s been exported or burned to a DVD or Blu-ray disc.
- Manage to-do items in your project.
Markers are classified as standard markers (blue), chapter markers (orange), to-do items (red), or completed to-do items (green).

You work with markers in the same way for clips in the browser and clips in the timeline.

Add and remove markers in Final Cut Pro for Mac

It's easy to add and remove markers. If you add markers to clips in the browser, the markers are visible in both filmstrip view and list view. When you add clips with markers to the timeline, the markers are visible in both the timeline and the timeline index.

Add a marker to a clip in the browser or the timeline

1. To specify where you want to add a marker in Final Cut Pro, do one of the following:
   - Skim to the location.
   - Play the clip, and when the playhead reaches the location where you want to add a marker, press the Space bar to stop playback.

   For more information about positioning the skimmer and the playhead, see Navigate your project.

2. Do one of the following:
   - Add a marker: Choose Mark > Markers > Add Marker (or press M).
     🔄 Tip: To add markers on the fly, just press M while playing a clip.
   - Add a marker and show the marker’s information: Choose Mark > Markers > Add Marker and Modify (or press Option-M). See Edit marker information and change marker types.
The marker appears at the top of the clip in the browser or the timeline.

Event clip markers also appear in the filmstrip and text list in the browser in list view.

Remove a marker

In Final Cut Pro, do one of the following:

- **Navigate to a marker**, then choose Mark > Markers > Delete Marker (or press Control-M).
- Select one or more clips, then choose Mark > Markers > Delete Markers in Selection.
- Double-click a marker to show the marker controls, then click the Delete button.
- Control-click the marker you want to remove, then choose Delete Marker.

Edit and move markers in Final Cut Pro for Mac

You can view and edit marker information, and you can move markers within a clip or to different clips.

**Edit marker information and change marker types**

By default, new markers are blue standard markers with placeholder text. You can change the text at any time, and you can change the marker to other marker types, including chapter markers, to-do items, and completed to-do items.
1. In Final Cut Pro, do one of the following:
   • Select the marker, then choose Mark > Markers > Modify Marker (or press Shift-M).
   • Control-click the marker and choose Modify Marker.
   • Double-click the marker.
   The marker controls appear above the marker.

2. To modify the marker, do any of the following:
   • Change the descriptive text for the marker: Type the new text in the text field. (The text is automatically selected when the marker controls appear, so you don’t need to select it.)
   • Make the marker a chapter marker: Click the Chapter Marker button.
   The marker turns into an orange chapter marker. See Add chapter markers.
   • Make the marker a to-do item: Click the To-Do Item button.
   The marker turns red.
   • Indicate that a to-do item is completed: Select the Completed checkbox.
   The marker turns green.

3. Click Done.
Move or copy a marker

You can move or copy markers using the familiar Cut, Copy, and Paste commands.

1. In Final Cut Pro, Control-click the marker you want to move or copy, then choose an option.
   - Move the marker: Choose Cut Marker.
   - Copy the marker: Choose Copy Marker.

2. Position the skimmer or the playhead where you want to move or copy the marker.


   The marker appears at the new location.

Nudge a marker one frame at a time

1. In Final Cut Pro, click a marker to select it.

2. Do one of the following:
   - Nudge the marker one frame to the right: Choose Mark > Markers > Nudge Marker Right, or press Control-Period (.).
   - Nudge the marker one frame to the left: Choose Mark > Markers > Nudge Marker Left, or press Control-Comma (,).

Navigate between markers

You can move quickly from marker to marker in the timeline or the browser.

In Final Cut Pro, do any of the following:

- Go to the next marker: Choose Mark > Next > Marker, or press Control-Apostrophe (').
- Go to the previous marker: Choose Mark > Previous > Marker, or press Control-Semicolon (;).

Add chapter markers in Final Cut Pro for Mac

Chapter markers are a standard feature in DVDs, Blu-ray discs, and podcasts. You can add chapter markers to your project so that when you share your finished movie, viewers can use the markers to quickly jump to those points in the movie. Apps and devices that recognize Final Cut Pro chapter markers during playback include iPod, iPhone, iPad, Apple TV, QuickTime Player, DVD Player, and most standard DVD and Blu-ray players.

Chapter markers make it easy for viewers to skip ahead to the section they want. They also allow Compressor, Apple’s professional transcoding app, and otherDVD and Blu-ray authoring apps to create a navigable chapter list or menu, such as a chapter index menu. But even in simple projects without menus (such as podcasts), chapter markers let viewers and listeners quickly skip through sections of a program using the Previous and Next buttons on their playback app or device.

A chapter marker thumbnail is a still image that represents a particular chapter. In Final Cut Pro, you can choose a specific video frame from the clip or storyline you’re marking as the chapter marker thumbnail image. In supported playback apps or devices, the chapter marker thumbnail images represent their corresponding chapters.
Create a chapter marker

1. In Final Cut Pro, add a marker to a clip in the timeline where you want the chapter to begin.

   By default, Final Cut Pro creates a blue standard marker.

2. To change the marker to a chapter marker, double-click it and, when the marker controls appear, click the Chapter Marker button.

   ![Image of marker controls]

   The marker changes to an orange chapter marker.

Set the chapter marker thumbnail image

After you set a chapter marker, you can choose an appropriate video frame to represent that particular chapter.

1. In Final Cut Pro, click the chapter marker once in the timeline to select it.

   The marker enlarges slightly to show that it’s selected, and a chapter marker thumbnail pin appears to the right of the selected chapter marker. By default, the chapter marker thumbnail pin appears 11 frames after the chapter marker.

   ![Image of chapter marker thumbnail pin]
2. To set the video frame for the chapter marker thumbnail image, drag the pin left or right in the timeline.

As you drag, the viewer displays the corresponding video frame.

![Drag the pin left or right in the timeline.]

*Note:* The chapter marker thumbnail image is the composited image from that location in the timeline and includes titles and any other superimposed imagery.

If the chapter marker is in the primary storyline, you can drag the chapter marker thumbnail pin as far as the beginning or the end of the primary storyline. If the chapter marker is in a connected storyline, you can drag the chapter marker thumbnail pin as far as the beginning or the end of the connected storyline.

For information about sharing your completed movie, see Intro to sharing projects.

**Correct shaky video in Final Cut Pro for Mac**

You can smooth a clip’s shaky footage by correcting the stabilization, rolling shutter, or both.

The stabilization feature in Final Cut Pro reduces the camera motion in your video so that shaky parts can be played back more smoothly. You can turn off stabilization for any clip so that it plays as originally recorded.

Many camcorders and still cameras include CMOS image sensors that expose the picture they’re recording progressively, instead of all at once. As a result, if the camera moves a lot during recording, or if the camera records fast motion, image distortion can occur. This causes the picture to appear wobbly or skewed. Final Cut Pro has a rolling shutter feature that can reduce this motion distortion.
Fix a clip with excessive shake or rolling shutter distortion

1. If the clip isn’t already in your Final Cut Pro project, add it to the timeline, then select it.

   Tip: Stabilization and rolling shutter corrections operate on whole-clip selections, not on range selections. To get the highest-quality and fastest results, isolate the problem section by cutting the clip with the Blade tool in the timeline. Then apply the correction to just the video footage that needs correcting.

2. If the Video inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Video button at the top of the inspector.

4. Scroll down to the Stabilization and Rolling Shutter sections.

   Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

5. In the Video inspector, do any of the following:
   - Reduce the shake: Select the Stabilization checkbox.
     
     If you turn on Stabilization, its checkbox turns blue and Final Cut Pro analyzes the clip for the best stabilization method. See Adjust stabilization settings, below.
   - Reduce rolling shutter distortion: Select the Rolling Shutter checkbox.

6. To view the fix, play the clip in the timeline.

   To turn off stabilization or rolling shutter corrections for a clip, deselect the Stabilization or Rolling Shutter checkbox.
Adjust stabilization settings
You can adjust how much of a correction is applied by the stabilization feature.

Stabilization has two independent phases:

• When you apply stabilization to a clip, Final Cut Pro analyzes the pixels in successive frames to determine the direction of camera movement.

• During playback and rendering, Final Cut Pro uses the motion analysis data to apply a transform effect to each frame, compensating for camera movement.

Use the available sliders in the Video inspector to control the steadiness of your shot. The higher you set the value of each parameter, the more camera motion is compensated for. A value of 0.0 turns off the parameter.

1. In Final Cut Pro, select a clip in the timeline, then open the Video inspector.

2. Select the checkbox for Stabilization or Rolling Shutter.

   If you turn on Stabilization, its checkbox turns blue and Final Cut Pro analyzes the clip for the best stabilization method. By default, the Method pop-up menu remains set to Automatic and the sliders for the appropriate stabilization method (either InertiaCam or SmoothCam) appear below it.

3. If you want to change the stabilization method, click the Method pop-up menu and choose an option:

   • **Automatic**: Allows Final Cut Pro to choose the most appropriate stabilization method (either InertiaCam or SmoothCam). This is the default setting.

   • **InertiaCam**: Applies stabilization optimized for video footage that has camera moves such as pans and zooms. Use the Smoothing slider to adjust the amount of the InertiaCam effect.

   *Note*: When you choose InertiaCam, Final Cut Pro analyzes your video footage and, depending on the results of the analysis, provides a Tripod Mode checkbox that creates the effect of a static camera that is mounted on a tripod.
• **SmoothCam**: Applies the default stabilization method described above, allowing you to adjust the translation, rotation, and scale parameters:
  
  • *Adjust left, right, up, and down movement of a shot (x and y axes)*: Drag the Translation Smooth slider.
  
  • *Adjust rotation around the center point of the image*: Drag the Rotation Smooth slider.
  
  • *Adjust forward or backward camera or lens movement (z axis)*: Drag the Scale Smooth slider.

For example, if you want to remove horizontal, vertical, and rotational shake, set the Translation Smooth and Rotation Smooth parameters to a value greater than 0. You may need to experiment to see which values steady your shot the best.

**Note**: When a clip has too much motion (excessive panning, for example), stabilizing the clip may result in black bars on the edges of the video.

To avoid the black bars, you can:

• Reduce the values for the Translation Smooth, Rotation Smooth, and Scale Smooth parameters.

• **Cut or trim** the clip in the timeline to remove the sections with the most shake. (You can locate the sections with excessive shake in the Tags pane of the timeline index. Click the individual Excessive Shake tags to select the corresponding ranges in the timeline.)

• **Crop the edges** of the stabilized video to remove the black bars.
Edit audio

Intro to audio in Final Cut Pro for Mac

Final Cut Pro has many features designed to make processing and editing audio easier. For example, you can analyze and automatically enhance audio to address problems such as noise or hum, add effects to your clips, sync video and audio clips automatically, and match audio between two clips.

You can make the following changes to clips or to audio components within a clip:

- **Edit multiple audio channels**: Expand the audio portion of clips to reveal and edit audio components down to the individual channel level. This allows you to apply different effects to different components or channels, and streamlines the process for making quick sound cutouts or other adjustments. See Intro to audio editing.
- **Adjust volume**: Quickly adjust a clip's volume directly in the timeline or in the Audio inspector. See Adjust volume.
- **Pan audio**: Take advantage of built-in pan presets for both stereo and surround sound. See Pan audio.
- **Add audio effects**: Add Audio Units effects, Logic effects, or custom effects included with Final Cut Pro, such as reverb, to clips. See Add audio effects.
- **Add keyframes to automate volume and effects**: Use keyframes to vary volume or effect settings as a clip plays. See Keyframe audio effects.
- **Fade audio in or out**: Fade audio in at the beginning or out at the end of a clip or an audio component with easy-to-use fade handles. See Fade audio in and out.
For the most part, you use the same tools to edit audio clips that you use to edit video in Final Cut Pro. The following editing features are covered elsewhere in the Final Cut Pro User Guide:

- **Use roles to manage clips**: Use roles and subroles in Final Cut Pro to organize clips in your events and projects by function or category, control the arrangement of the timeline, and export separate video or audio files (also known as *media stems*). See [Intro to roles](#).

- **Organize the timeline using audio lanes**: With a single click, arrange clips into audio lanes (separate, visually distinct layers) in the timeline. This view organizes clips visually and provides reference points that make editing easier and more efficient. See [Organize the timeline with audio lanes](#).

- **Change the edit mode**: Set the edit mode for a clip to video only or audio only. See [Add only a clip’s video or audio](#).

- **Add markers to clips**: Mark specific reference points within an audio clip. See [Intro to markers](#).

- **Trim audio**: Make precision edits to the audio waveform—for example, to take out an unwanted sound in the recording. See [Intro to trimming](#).

- **Add audio crossfades**: Create a smooth transition when connecting two separate audio waveforms. See [Add transitions and fades](#).

- **Use compound clips**: Combine any video or audio clips into a single compound clip. See [Intro to compound clips](#).

- **Export audio**: Export your project as an audio file in either mono, stereo, or surround sound. You can also export media by role. See [Intro to sharing projects](#).
Audio editing basics

Audio waveforms in Final Cut Pro for Mac

Audio waveforms are visual representations of the actual sound. Audio waveforms appear in clips in the following ways:

- As the bottom portion of a video clip
- As a detached or audio-only clip

An audio waveform’s amplitude and length change according to the underlying sound’s volume and duration. A short, loud sound such as a drum beat has a sharp, peaked waveform, whereas low-level crowd noise has a lower, more uniform waveform. These properties make it easier to find specific edit points when trimming clips or keyframing effects.

In Final Cut Pro, audio waveforms change according to a clip’s volume level or applied effects. The waveform appears larger when the volume is high and smaller when the volume is low.

Note: Clip colors are determined by role assignments. Each role has a default color. Video clips (including clips containing video and audio) are assigned the Dialogue role and are blue. Music clips are assigned the Music role and are green. Sound effects clips are assigned the Effects role and are teal. See View and reassign roles.
Audio channels and components in Final Cut Pro for Mac

Audio files can contain a single audio channel or multiple audio channels. Channels usually correspond to microphone inputs during recording or to speakers for multichannel output. For example, a stereo audio file usually contains left and right channels that match what you hear from the left and right speakers during playback.

Final Cut Pro automatically groups channels into *audio components* according to how the channels are configured for the clip. You can expand the audio portion of clips to view and edit audio components down to the individual channel level. You can then make separate volume or pan adjustments or apply and keyframe different audio effects for each component. See Intro to audio editing.

The number of audio components you see corresponds to the number of channels you've configured in your source clip.

*Note:* Many popular digital audio file formats, such as AAC and MP3, use *interleaved* stereo files, which do not contain separate left and right channels. A stereo clip with interleaved left and right channels appears as a single audio component in the Audio inspector and the timeline. If you change the clip’s channel configuration from Stereo to Dual Mono, the channels appear as two separate audio components.

![Audio components](image)

See Configure audio channels.

Ways to view audio clips in Final Cut Pro for Mac

When you work with audio waveforms in the timeline, you can zoom in or out or change the clip appearance to make the waveform taller or shorter.

Final Cut Pro also provides several ways to view and work with audio and video within clips. You can:

- Expand a clip to view and edit audio components down to the individual channel level
- Expand a clip to see separate audio and video
- Detach audio from a video clip to work on the audio and video as separate, independent clips
- Change the background appearance of a clip to show reference waveforms, which make it easier to see audio waveforms when the volume is diminished
Show expanded audio components
You can expand the audio portion of clips in Final Cut Pro to view and edit audio components.

In Final Cut Pro, do one of the following:

• Select the clip in the timeline, then choose Clip > Expand Audio Components (or press Control-Option-S).
• Double-click the audio portion of the clip in the timeline while holding down the Option key.

Note: You can also show audio components for all the clips in one or more roles. See Organize the timeline with audio lanes.

Collapse audio components
In Final Cut Pro, do one of the following:

• Select either the clip or one of its audio components in the timeline, then choose Clip > Collapse Audio Components (or press Control-Option-S).
• Double-click any of the audio components in the timeline while holding down the Option key.
Show expanded audio and video
You can view audio and video separately in the same clip in the timeline by expanding clips that have both audio and video. This can be useful if you need to zoom in to the audio portion to make edits or to create a split edit.

If you create a split edit so that audio portions overlap, you won’t clearly see the overlapped waveforms unless you choose to show expanded audio for split clips. For more information about split clips and split edits, see Create split edits.

In Final Cut Pro, do one of the following:

- **Expand a single clip:** Double-click the clip’s audio waveform.
- **Expand a clip or clips you’ve selected in the timeline:** Choose Clip > Expand Audio (or press Control-S).

When you show expanded audio, the audio and video portions of the clip remain attached to each other. To create a separate connected audio clip, detach the audio. You can also use the precision editor to see a detached view of the video and audio portions of the clip.

Note: You can also show expanded audio by displaying audio roles in separate lanes. See Organize the timeline with audio lanes.

Collapse audio and video
You can collapse the expanded audio/video view for a single clip or multiple clips.

In Final Cut Pro, do one of the following:

- **Collapse a single clip:** Double-click the clip’s audio waveform.
- **Collapse a clip or clips you’ve selected in the timeline:** Choose Clip > Collapse Audio (or press Control-S).
**Detach audio from video**

By default, Final Cut Pro imports audio and video from the same source into one clip. You can easily detach the audio from a video clip so that you can edit the audio clip separately in the timeline.

- In Final Cut Pro, select the clip in the timeline, then choose Clip > Detach Audio.

A new audio clip appears as a connected clip beneath the video clip.

![](image)

To reattach an audio clip to its original video clip, you need to **create a compound clip**.

**Show or hide reference waveforms**

A reference waveform shows the maximum visual resolution possible for the actual audio waveform. By factoring out loudness changes, reference waveforms let you see the details of the sound more clearly.

1. Choose Final Cut Pro > Settings, then click Editing.
2. Select the “Show reference waveforms” checkbox.

![](image)

When the actual waveform changes shape (for example, when it’s diminished because a clip’s volume level is low), its full reference waveform is still visible for easy reference when editing.
Zoom in to audio waveforms in Final Cut Pro for Mac

For even more precise editing, you can zoom in to audio clips at the audio sample level. Audio samples show the audio waveform at a fraction of a second (for example, 1/48,000 for audio recorded at a sample rate of 48 kHz).

**Zoom to audio samples**

1. In Final Cut Pro, choose View > Zoom to Samples (or press Control-Z), so that a checkmark appears next to the menu item.
   
   *Note:* The Zoom to Samples feature is enabled by default.

2. Position the playhead over a clip in the timeline.

3. **Zoom in** until the clip shows a gray overlay indicating the borders of a video frame.

![Frame borders](image)

You can continue to zoom in for a closer view of the waveform.

![Frame borders](image)

4. Make edits to the clip, or **make adjustments to audio effects using keyframes**.
   
   *Note:* Sample-accurate editing (such as cutting with the blade tool or trimming) is available only for connected audio clips (that is, audio clips not in the primary storyline) or compound clips that contain only audio.

To turn off zooming to audio samples, choose View > Zoom to Samples (or press Control-Z).

**Navigate by subframe**

You can navigate by subframes (which are 1/80 the duration of a video frame).

1. In the Final Cut Pro timeline or browser, position the playhead or skimmer over a clip.

2. Do any of the following:
   

**Tip:** For reference when working with video, you can view subframes in the timecode display below the viewer. In the **General pane** of Final Cut Pro settings, click the Time Display pop-up menu and choose the subframe option.
View and change audio levels in Final Cut Pro for Mac

The audio meters show the audio levels of clips in Final Cut Pro and warn you if a particular clip or section of a clip reaches peak levels, which may result in audible distortion.

When an audio clip is approaching peak levels during playback, the level color changes from green to yellow.

When an audio clip exceeds peak levels, the level color changes from yellow to red, and the peak indicator turns red for the respective audio channel or channels. The peak indicators are reset when you stop and start playback.

To avoid having clip volume exceed peak levels, adjust the volume. Although the proper level for a clip depends on the mix, it’s important to make sure that the combined level for all concurrent clips doesn’t exceed 0 dB during the loudest sections.

Show the audio meters

Final Cut Pro includes a small audio meters icon below the viewer and larger audio meters that can be shown to the right of the timeline.

In Final Cut Pro, do one of the following:

• Choose Window > Show in Workspace > Audio Meters, so there’s a checkmark next to the menu item.

• Click the audio meters icon below the viewer.

You can drag the edges of the meters to see an expanded view with additional information.

To hide the audio meters, choose Window > Show in Workspace > Audio Meters, or click the audio meters icon below the viewer.
Note: The number of audio meters you see depends on how many channels are configured for the clip you’re playing. For example, when you play back a surround clip in the browser, six surround audio meters are displayed, but if you drag that same clip into a stereo project in the timeline, Final Cut Pro automatically mixes down the surround audio into stereo, and only two audio meters are displayed. For information about changing a project from stereo to multichannel surround sound, see Modify a project’s settings. For information about channel configurations, see Configure audio channels.

**Reset and correct peak levels**

1. In Final Cut Pro, select the clip in the timeline.
2. Adjust the volume, and play back the clip again to test for peaks.

In the timeline and browser, the waveform section or sections of a clip turn yellow when a level is approaching peak levels, and red when a level exceeds 0 dB.

*Note:* If you add a clip with mono audio to a stereo project, Final Cut Pro plays the single mono audio in both left and right channels, visible in the stereo audio meters for the project.

**Solo and mute audio clips in Final Cut Pro for Mac**

The solo feature enables audio playback of only the selected clips in the timeline and temporarily disables audio playback for all other clips. It’s especially useful in audio editing if you have more than one audio clip layered in the timeline (dialogue and background music, for example) but need to listen and make edits to just certain clips.

Another way to mute clips is to disable them. Disabled clips are both invisible and silent and do not appear in any output.

**Solo clips in the timeline**

1. In Final Cut Pro, select one or more clips in the timeline that you want to listen to (in isolation from any other clips).
2. Do one of the following:
   - Choose Clip > Solo (or press Option-S).
   - Click the Solo button in the top-right corner of the timeline.
The soloed clip appears highlighted, and other clips appear dimmed.

To turn off solo, click the Solo button, or choose Clip > Solo (or press Option-S) again.

**Disable clips or ranges**

1. In Final Cut Pro, select one or more clips in the timeline.
   
   *Note:* If the selected clips contain both video and audio, and you want to mute the audio only, choose Clip > Expand Audio or Clip > Expand Audio Components, then select the audio portion only (or drag to select a range).

2. Choose Clip > Disable (or press V).

Disabled clips are both invisible and silent and do not appear in the viewer or in any output. The filmstrips of disabled clips appear dimmed in the timeline.

   To reenable the disabled clips, select them in the timeline and choose Clip > Enable (or press V).

**Silence clips or ranges**

You can silence a selected clip or range. This technique is simply a quick and easy way to adjust the volume.

1. In Final Cut Pro, select one or more clips in the timeline, or select a range.

2. Choose Modify > Adjust Volume > Silence (\(-\infty\)).

   The selection is silenced, and the volume control for the clip or range is set to \(-\infty\) dB.
   
   (You can confirm this level in the Audio inspector.)

   To restore the original audio level for the selected clip or range, choose Modify > Adjust Volume > Reset (0dB).

**Important:** If you import clips with unwanted audio that you will never use, you can ensure the best playback performance by deselecting the audio components of these clips in the Audio inspector. See Disable a clip’s audio.

You can also solo or disable video clips. See Solo or disable clips.
Add audio

Add music and sound in Final Cut Pro for Mac

You can add music and sound files directly to a project or an event from your Music library or other sources.

Final Cut Pro also includes a number of built-in Foley and other sound effects that you can insert as connected audio clips.

If you have a clip that contains both audio and video, you can choose to insert only the audio portion of the clip. See Add only a clip’s video or audio.

1. In Final Cut Pro, open the Photos, Videos, and Audio sidebar by doing one of the following:
   - Click the Photos, Videos, and Audio button in the top-left corner of the Final Cut Pro window.
   - Choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).

2. In the sidebar, select the sound category or app you want to browse.

   The audio clips in that category appear in a list in the browser.

   The Photos, Videos, and Audio sidebar includes a Sound Effects category as well as other media libraries, depending on which apps and which version of macOS you're using.
3. To find the music or sound you want to use, do any of the following:

- **Search and filter the collection:** Use the pop-up menu at the top of the browser to filter the items shown in the browser. For example, you could select Sound Effects, then choose Final Cut Pro Sound Effects > Impacts & Crashes.

- **Preview an item:** Select an item in the list, then click the Play button.

- **Select more than one item:** Command-click each item.

If your Music library includes protected files, they are unavailable. (They do not appear in the browser.)

*Note:* To use a song you purchased from the iTunes Store in your project, you must be the copyright holder of the song or have express permission from the copyright holder. For more information, see the Final Cut Pro software license agreement (choose Final Cut Pro > About Final Cut Pro, then click License Agreement).

4. When you've selected the clip or clips you want to use, do one of the following:

- Drag the sound clip or clips to the timeline.

- Drag the sound clip or clips to the sidebar.

  The Photos, Videos, and Audio sidebar changes to the Libraries sidebar, allowing you to add the files to an event or a Keyword Collection. After you drag the files, the Photos, Videos, and Audio sidebar reappears.

  For better import and playback performance, Final Cut Pro automatically transcodes all MP3 audio files to MOV audio files and retains the original MP3 files for future use. For information about where to find original and transcoded media files, see Locate source media files.

  *Note:* If you add a clip with mono audio to a stereo project, Final Cut Pro plays the single mono audio in both left and right channels, visible in the stereo audio meters for the project.

**Record voiceovers in Final Cut Pro for Mac**

You can record voiceover narration or other live audio directly in Final Cut Pro from input sources such as built-in and external microphones.

By default, Final Cut Pro includes an automatic countdown when you record, and also automatically groups multiple takes into auditions so that you can quickly preview recordings and choose the best one. The recorded audio files appear both in the browser and as connected clips in the timeline.
Record live audio

1. In Final Cut Pro, position the playhead where you want to start recording in the timeline.

2. Choose Window > Record Voiceover.

   🔄 Tip: To start recording immediately without adjusting settings, press Option-Shift-A and go to step 7.

3. To adjust the input level of the microphone, do one of the following:
   
   • Drag the Input Gain slider right to increase the input level, or left to decrease it.
   
   • Type a dB value in the Input Gain field.

   Use the audio meters to make sure the volume doesn’t exceed peak levels (shown in red), which may result in audible distortion.

   Note: If the Input Gain slider is dimmed for a selected input device, try adjusting the gain on the device itself or its software utility (if available).

4. To name your voiceover clip, click the Name field and type a name.

5. To specify other voiceover settings, click the Advanced disclosure triangle and do any of the following:

   • Change the input device or the number of input channels (mono or stereo): Click the Input pop-up menu and choose an option. The default choice of System Setting uses the first channel of the input device currently selected in Sound settings (in macOS System Settings).

   🔄 Tip: If you always want to record with a particular device or a particular channel on a multichannel audio device, choose that device/channel pair from the Input pop-up menu instead of System Setting. The setting is retained, and the Input pop-up menu indicates whether the device is available.
• **Listen to your microphone input as you record**: Set Monitor to On. The microphone audio plays from the output device currently selected in Sound settings (in macOS System Settings). There’s no input signal when monitoring is off.

  Tip: To listen to a live mix of both microphone and project audio, set Monitor to On and deselect the “Mute project while recording” checkbox below.

• **Adjust the monitoring level**: Drag the Gain slider right to increase the monitoring level, or left to decrease it (or type a dB value in the Gain field).

  Note: If the built-in microphone is selected, the Gain slider automatically resets to zero to prevent feedback from the built-in speakers when monitoring is turned on. To avoid feedback, use headphones or external speakers placed away from the microphone.

• **Turn off the automatic countdown before recording**: Deselect the “Countdown to record” checkbox.

• **Unmute project audio while recording**: Deselect the “Mute project while recording” checkbox.

• **Turn off automatic grouping of multiple voiceover takes into auditions**: Deselect the “Create Audition from takes” checkbox.

• **Change where the recording is saved**: Click the Event pop-up menu and choose an event in the current library.

• **Assign a role to the recording**: Click the Role pop-up menu and choose a role. To create a new role, choose Edit Roles. See Intro to roles.

6. To start recording, click the Record button (or press Option-Shift-A).

7. To stop recording, click the Record button (or press the Space bar or Option-Shift-A).

   When you stop recording, the playhead returns to the start point you set in step 1, ready for you to record additional takes. If you record additional takes with the “Create Audition from takes” checkbox selected, Final Cut Pro creates an audition. See Combine audio from multiple takes and Create auditions.

Your audio recordings are attached to the primary storyline at the playhead position.
**Record multiple voiceover takes**

You can record multiple versions, or “takes,” of voiceover recordings for the same section of your project. By default, Final Cut Pro creates an audition from all the takes you record. After you’ve finished recording, you can review the different takes in the audition and choose the one you want to use.

1. To record your first voiceover take in Final Cut Pro, follow the instructions in Record live audio, above.

2. Without moving the playhead, click the Record button (or press Option-Shift-A) to record another take for the same section of your project.

3. To stop recording, click the Record button again (or press the Space bar or Option-Shift-A).

By default, Final Cut Pro creates an audition containing both recordings.

To add another take to the audition, repeat steps 2 and 3. Each new take you record is added to the audition.

To learn more about auditions, see Add clips to auditions.

**Preview and select a voiceover take**

1. In the Final Cut Pro timeline, select the audition containing the voiceover takes you want to review, then open it by choosing Clip > Audition > Open (or pressing Y).
2. In the audition window, select the take and press the Space bar (or press Control-Command-Y) to play it.

3. When you decide on the take you want to use, make sure it’s selected, then click Done.

4. If you’re sure of your decision and want to finalize the audition, choose Clip > Audition > Finalize Audition (or press Option-Shift-Y).

   The audition is dissolved, leaving the voiceover clip in the timeline.

To learn more about previewing auditions, see Review clips in auditions.

**Combine audio from multiple takes**

By default, an audition lets you choose only one voiceover take to use in your project. If you want to combine portions of two separate takes into one “comp” take, you can break the audition into separate audio clips, which you can then edit and combine as needed.

1. In Final Cut Pro, select an audition in the timeline, then choose Clip > Break Apart Clip Items (or press Shift-Command-G).

   Final Cut Pro replaces the audition selected in the timeline with the individual recordings that made up the audition.

2. Edit the clips as needed.

   Tip: You can silence unwanted sections rather than edit them out. See Adjust volume automatically across a selected area.

**Access external audio files in Final Cut Pro for Mac**

Post-production professionals often download stock music and sound effects and maintain their own library of audio files (in addition to more than 1300 royalty-free sound effects available in Final Cut Pro).

You can create custom folders in the Sound Effects category of the Photos, Videos, and Audio sidebar that link to external collections of audio files, providing quick access to the files from any Final Cut Pro project. These custom folders can contain multiple levels of subfolders so that your audio files remain organized the way you like.

If you add or remove files in the external audio library, the changes appear in the Sound Effects category after you quit and reopen Final Cut Pro.
The following instructions assume that you have an existing set of audio files (such as sound effects or music) in a folder on your Mac.

1. In the Finder, select the top-level folder that contains the audio files you want to access from Final Cut Pro.
3. In the Finder, choose Go > Go to Folder, then enter the following in the “Go to the folder” field:
   /Library/Audio/Apple Loops/Apple/Final Cut Pro Sound Effects/
4. Click Go.
   The Final Cut Pro Sound Effects folder opens in the Finder.
5. In the Finder, drag the alias of your custom audio folder into the Final Cut Pro Sound Effects folder.
6. Delete the word “alias” from the end of the folder name.
7. In Final Cut Pro, if the Photos, Videos, and Audio sidebar isn’t already shown, do one of the following:
   • Click the Photos, Videos, and Audio button in the top-left corner of the Final Cut Pro window.
   • Choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).
8. In the sidebar, select the Sound Effects category.
9. Click the pop-up menu above the search field in the upper-right corner of the browser.

Your custom audio folder and any subfolders appear in the Final Cut Pro Sound Effects section of the menu.
10. To access the clips in your custom audio folder, do any of the following:
   - Choose your custom audio folder (or any of its subfolders) from the pop-up menu.
   - Type text in the search field to search for clips by name.

   The corresponding clips appear in the browser.

To add audio clips from your custom audio folder to your projects or libraries, see Add music and sound.

Note: By default, Final Cut Pro assigns the Effects role to every clip that is added from the Sound Effects category of the Photos, Videos, and Audio sidebar. To change the role assignment for a clip, see View and reassign roles.

Edit audio clips or audio components

Intro to audio editing in Final Cut Pro for Mac

Final Cut Pro includes tools for editing audio clips or multiple audio channels. You edit audio in two ways, detailed below.

Clip-level audio editing

You can make audio adjustments and edits to whole clips. At this level, audio adjustments and effects are applied to the entire clip, including any audio channels within the clip. Final Cut Pro preserves any adjustments you make to individual audio channels. This means that if you reduce the volume for a single channel but raise the volume for the whole clip, the volume of the single channel is raised but stays in proportion to the volume of other channels in the clip.

If your source media contains only one or two audio channels or you're editing an audio-only clip, you may only need to make adjustments and edits at this level.

Advanced multichannel audio editing

Final Cut Pro automatically groups channels into audio components according to how the channels are configured for the clip. You can expand the audio portion of clips to reveal and edit audio components down to the individual channel level. This allows you to apply different effects to different components and streamlines the process for making quick sound cutouts to a single microphone input or other fine adjustments.

Important: Many digital audio file formats, such as AAC and MP3, use interleaved stereo files, which do not contain separate left and right channels. These files appear as a single audio component unless you change the clip’s channel configuration.
Keep in mind the following when editing audio components in Final Cut Pro:

- You view and change the audio channel configuration of your clips in the Audio Configuration section of the Audio inspector. You can enable or disable audio components and configure channels in mono, stereo, and surround formats. See Configure audio channels.
- With the Range Selection tool, you can quickly select ranges within an audio component to target the audio you want to edit.
- When you show audio components for compound clips, multicam clips, and synced clips, Final Cut Pro presents role components, which you can edit in the same way you edit standard components. See Work with audio roles in compound clips.
- You edit audio components in the same way you edit whole clips. You can:
  - Skim individual components when clip skimming and audio skimming are turned on. See Skim media.
  - Adjust the volume of a component. See Adjust volume.
  - Mute a component’s audio by disabling or silencing all or a portion of the component. This is the fastest way to remove unwanted sounds from a component. See Solo and mute audio clips.
  - Trim a component’s start and end points. See Extend or shorten clips.
  - Perform a roll edit on adjacent audio components. See Make roll edits.
  - Apply fades or use fade handles to fade audio in at the beginning of an audio component, or fade audio out at the end. See Fade audio in and out.
  - Pan the sound for individual components. See Pan audio.
  - Assign a role (specifically, a subrole) to a component. See Intro to roles and View and reassign roles.
  - Add or adjust audio effects for individual components. See Add audio effects or Adjust audio effects.
  - Adjust audio effects for individual components using keyframes. See Keyframe audio effects.

For examples of multichannel audio editing workflows, see Multichannel audio editing examples.

Configure audio channels in Final Cut Pro for Mac

Final Cut Pro assigns a default channel configuration for audio clips when they’re imported or added to a project. You can change the channel configuration—for example, to convert a stereo dialogue clip to two mono channels.

Final Cut Pro automatically groups channels into audio components according to how the channels are configured for the clip. See Audio channels and components.

In addition to changing the channel configuration, you can view and listen to audio components and enable or disable audio components.
Change the channel configuration

The number of channel options you can configure depends upon how many channels are in your source clip or compound clip. You can configure channels in several formats, including:

- **Mono**: Single channel. In a surround sound setup, you can assign a mono channel to any surround channel.
- **Stereo**: Left and right channels.
- **5.1 surround**: Left, center, right, left surround, right surround, and low-frequency effects (subwoofer bass) channels.

If you configure more than six surround channels, Final Cut Pro automatically adjusts the channel mix down to 5.1 surround during playback.

**Important**: Changing the channel configuration resets all adjustments and edits made to audio components (including applied effects, disabled ranges, keyframe adjustments, and role assignments).

1. In Final Cut Pro, select the clip in the timeline.
2. In the Audio Configuration section of the Audio inspector, click the Channels pop-up menu and choose an option.

   The channels appear in the Audio inspector as separate audio components, each with its own waveform.

   ![Audio Configuration](image)

   To assign a mono channel to a specific surround channel, select the mono channel waveform, then click the Channels pop-up menu and choose an option.

View and listen to an audio component

1. In Final Cut Pro, select the clip in the timeline.
2. In the Audio Configuration section of the Audio inspector, **skim** over a component or play it back using the Space bar or the J, K, and L keys.

   ![Skim preview](image)
Enable or disable an audio component

You can enable or disable audio components in a clip. For example, you may want to disable unused components in a clip.

By default, all active audio components in a clip appear as selected in the Audio inspector and are arranged in the same order when the clip is expanded to show audio components in the timeline. To learn more about viewing audio components, see Ways to view audio clips.

When you disable an audio component, it appears dimmed in the Audio inspector and is removed from the clip's component arrangement in the timeline.

1. In Final Cut Pro, select the clip in the timeline.
2. In the Audio Configuration section of the Audio inspector, do one of the following:
   - **Disable a component**: Deselect the checkbox next to the component waveform.
   - **Enable a component**: Select the checkbox next to the component waveform.

   ![Click to enable or disable an audio component.](image)

**Note**: You can also disable an audio component in the timeline. **Expand the clip's audio components** in the timeline, then select the audio component you want to disable and press Delete.

You can also choose a channel configuration when exporting roles as audio stems for mixing or post-production. See **Share roles as files**. If you choose an export file channel configuration that is different from that of your source files, the channels are exported in the following ways:

   - **Stereo source exported as surround**: The left and right channels are exported to the left and right channels of the surround file.
   - **Surround source exported as stereo**: The surround source is exported as a stereo (left and right channel) mix.
   - **Stereo or surround source exported as mono**: The stereo or surround source is exported as a mono (one channel) mix.
Adjust volume in Final Cut Pro for Mac

You can adjust the volume levels of audio clips from the browser, the timeline, the Audio inspector, or the Modify menu. Volume adjustments you make from the Audio inspector or the Modify menu are applied to the entire selection. To make more precise adjustments, you can create keyframes in the clip, and then make adjustments to points between keyframes. See Keyframe audio effects.

You can use the audio meters to make sure the volume doesn’t exceed peak levels, which may result in audible distortion.

Adjust volume in the timeline

• In Final Cut Pro, drag the volume control (the horizontal line across the audio waveform) up or down.

As you drag, the volume level in dB appears, and the waveform changes shape to reflect your adjustments.

If you adjust the volume between two keyframes, the volume line slopes to show the change in volume between the keyframes.

Adjust volume from the Modify menu or the keyboard

1. In the Final Cut Pro timeline, select one or more audio clips or video clips with audio.

2. Do one of the following:

• Adjust the volume in +1 or −1 dB increments: Choose Modify > Adjust Volume, then choose Up or Down, or press Control-Plus Sign (+) or Control-Minus Sign (−).

• Adjust the volume using an absolute dB value: Choose Modify > Adjust Volume > Absolute (or press Control-Option-L).

The display below the viewer changes to show absolute dB values.

Type a positive or negative value to change the absolute volume. The volume across the entire selection is set to one dB level, and any keyframe adjustments are deleted.
• Adjust the volume using a relative dB value: Choose Modify > Adjust Volume > Relative (or press Control-L).

The display below the viewer changes to show relative dB values.

![Volume Display]

To change the volume, type a positive or negative dB value.

Type a positive or negative value to change the relative volume. The volume is adjusted by the same amount throughout the selection, preserving any fades or other keyframe adjustments.

• Silence the selected clip or range to 0 dB: Choose Modify > Adjust Volume > Silence (–∞).

The selection is silenced, and the volume control for the clip or range is set to –∞ dB.

• Restore the original audio level for the selected clip or range: Choose Modify > Adjust Volume > Reset (0dB).

The volume of the selection is reset to 0 dB.

If multiple clips are selected, the volume is adjusted for all clips.

Adjust volume in the Audio inspector

1. In the Final Cut Pro browser or timeline, select one or more audio clips or video clips with audio.
2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Audio button at the top of the inspector.

Tip: Double-click the top bar of the Audio inspector to switch between half-height view and full-height view.
4. In the Audio inspector, do one of the following:

- Enter a value in the Volume field.
  If multiple clips are selected, the volume for all clips is set to the value you entered.
- Drag the Volume slider right to increase the volume, or left to decrease it.
  If multiple clips are selected, the volume for all clips is adjusted relative to each clip’s original volume.

Adjust volume automatically across a selected area
To adjust the volume of a clip in the timeline, you can use the Range Selection tool to add keyframes automatically across a selected range. This is useful for ducking audio (temporarily lowering the volume). Ducking is usually applied to one type of audio (such as music or effects) to give prominence to other audio playing at the same time (such as dialogue or narration).

1. In Final Cut Pro, select the clip in the timeline.
2. Click the Tools pop-up menu above the timeline and choose Range Selection (or press R).

The pointer changes to the Range Selection tool 🕒.
3. Drag across the area where you want to adjust the volume.

4. To adjust the volume within the range, do one of the following:
   - Drag the horizontal control in the timeline up or down. (See Adjust volume in the timeline, above.)
   - Choose Modify > Adjust Volume > Silence (–∞) to silence the range.

Keyframes are automatically created along the adjustment points within the range.

**Reset all volume adjustments**

In Final Cut Pro, do one of the following:

- In the browser or the timeline, select an audio clip or a video clip with audio, then click the Reset button in the Volume and Pan section of the Audio inspector.
- Select a clip or a range in the timeline, then choose Modify > Adjust Volume > Reset (0dB).
Disable a clip’s audio

At times, you may import clips with unwanted audio that you will never use. You can disable the audio in these clips. To ensure the best playback performance, deselect the audio components of these clips in the Audio inspector.

1. In Final Cut Pro, select one or more clips in the timeline or the browser.
2. In the Audio Configuration section of the Audio inspector, deselect the checkboxes next to the component waveforms you want to silence.

Note: If you add a clip with mono audio to a stereo project, Final Cut Pro plays the single mono audio in both left and right channels, visible in the stereo audio meters for the project.

Fade audio in and out in Final Cut Pro for Mac

There are several ways to create audio fade-ins and fade-outs on the audio portions of clips or on audio components in Final Cut Pro:

- **Apply fades using the Modify menu:** You can quickly apply fade-ins and fade-outs to selected clips or audio components from the Modify menu. You can change the default fade duration in Final Cut Pro settings.

- **Create fades using fade handles:** You can use fade handles to create manual fade-ins and fade-outs on the audio portion of a clip or an audio component in the timeline. Fade handles appear in the top-left and top-right corners of the audio waveform when you place the pointer over the clip.

You can also change the fade’s shape by choosing one of several predefined options. Changing the fade shape changes the sound of the fade.

Note: Fades created using fade handles override crossfades created by a transition. For information about crossfades, see Crossfade audio.
Apply fades using the Modify menu
1. In the Final Cut Pro timeline, select one or more audio clips or video clips with audio.

2. Do one of the following:
   • Choose Modify > Adjust Audio Fades > Apply Fades.
     Fades appear at the beginning and end of the selected clip or clips.
     Note: If you select a clip that already has a fade, the Apply Fades command does not override it.
   • Choose Modify > Adjust Audio Fades > Fade In.
     If there are no preexisting fades at the beginning of the selected clip or clips, fades appear at the beginning of the clips. If there are already fades at the beginning of the selected clip or clips, they are removed.
   • Choose Modify > Adjust Audio Fades > Fade Out.
     If there are no preexisting fades at the end of the selected clip or clips, fades appear at the end of the clips. If there are already fades at the end of the selected clip or clips, they are removed.

3. To adjust the duration of a fade, drag the fade handle to the point where you want the fade to begin or end.

   The default duration for fades is one half-second. To change the default duration, see Editing settings.

   Tip: You can use the Command Editor to assign a keyboard shortcut to apply (or remove) only a fade-in or a fade-out. See Intro to the Command Editor.
Create a fade manually using fade handles

- In the Final Cut Pro timeline, drag the fade handle to the point in the clip where you want the fade to begin or end.

Fade handles from the beginning of a clip create a fade-in, and fade handles at the end of a clip create a fade-out.

Fades complement any volume adjustments you've already made to a clip. For example, if you previously adjusted the volume lower at the beginning of a clip, the fade-in increases the volume from silence (−∞ dB) to the level you've already specified.

Change the fade shape when using fade handles

- In the Final Cut Pro timeline, Control-click a fade handle and choose a fade option:

- **Linear**: Maintains a constant rate of change over the length of the fade.
- **S-curve**: Eases in and out of the fade with the midpoint at 0 dB.
- **+3dB**: Fade-ins start quickly and end slowly; fade-outs start slowly and end quickly. This is the default setting and is best for maintaining a natural volume when crossfading between two clips.
- **−3dB**: Fade-ins start slowly and end quickly; fade-outs start quickly and end slowly.
Remove fades

1. In the Final Cut Pro timeline, select one or more audio clips or video clips with audio.

2. Do one of the following:
   - Choose Modify > Adjust Audio Fades > Remove Fades.
     Fades are removed from the beginning and end of the selected clip or clips.
   - Choose Modify > Adjust Audio Fades > Fade In.
     If there are preexisting fades at the beginning of the selected clip or clips, they are removed. If there are no fades at the beginning of the selected clip or clips, fades appear at the beginning of the clips.
   - Choose Modify > Adjust Audio Fades > Fade Out.
     If there are preexisting fades at the end of the selected clip or clips, they are removed. If there are no fades at the end of the selected clip or clips, fades appear at the end of the clips.

Crossfade audio in Final Cut Pro for Mac

A crossfade is a common type of audio transition between two clips, in which the first clip's audio fades down while the second clip's audio simultaneously fades up. During the crossfade, audio from both clips is heard. Crossfades are similar to video transitions known as cross dissolves.

You can add audio crossfades in the following ways:

- **Create crossfades using the Modify menu:** You can quickly apply audio crossfades to any adjacent clips in the timeline.
- **Create a crossfade manually using fade handles:** You can apply a crossfade to the edit point when trimming the audio waveform in clips.
- **Apply crossfades automatically when transitions are added:** When you add a transition to a video clip with attached audio, a crossfade is automatically applied to the audio. If the audio is detached or expanded from the video, the crossfade is not applied. See Add transitions and fades.
Create an audio crossfade using the Modify menu

1. In the Final Cut Pro timeline, select two or more adjacent audio clips or video clips with audio.

2. Choose Modify > Adjust Audio Fades > Crossfade (or press Option-T).

   Final Cut Pro creates the crossfade at the edit point between the selected clips using media handles. To view the overlapping audio components, select the clips in the timeline and choose Clip > Expand Audio Components (or press Control-Option-S).

   If one or both of the clips do not have enough extra content (media handles) to support a crossfade of the default duration, you're given the option to overlap media in your project to create the crossfade. See How transitions are created.

   For information about applying crossfades to connected clips, see Create a crossfade manually using fade handles, below.

Set the default duration for audio crossfades

If you often change the length of your audio crossfades to last a specific number of seconds, you can set a default duration in Final Cut Pro settings.

⚠️ Tip: Adjust the default duration before applying a audio crossfades to many clips at once.

1. In Final Cut Pro, choose Final Cut Pro > Settings, or press Command-Comma (,), then click Editing.

2. Use the Crossfade value slider to set the duration, in seconds, of all audio crossfades that you create using the Modify menu.

   Note: Some transitions have a fixed audio crossfade duration and are not affected by this setting.
Create a crossfade manually using fade handles

1. In Final Cut Pro, select two adjacent clips in the timeline, then choose Clip > Expand Audio (or press Control-S).

   The clips appear expanded.

2. Drag the end point of the first clip and the start point of the second clip so that the audio portions of the clips overlap.

   Note: Make sure to adjust the audio overlap to the length you want.

3. Drag the fade handles of each clip to the points where you want the fade to begin and end.

   To change the fade shape for each clip, follow the instructions in Change the fade shape when using fade handles.
Change the fade shape of a transition crossfade

You can change the shape of the fade handles in a transition crossfade that Final Cut Pro created automatically.

1. In Final Cut Pro, select a video transition in the timeline, then do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

2. In the Audio Crossfade section of the Transition inspector, click the Fade In Type pop-up menu or the Fade Out Type pop-up menu and choose a fade option:
   - **Linear**: Maintains a constant rate of change over the length of the fade.
   - **S-curve**: Eases in and out of the fade with the midpoint at 0 dB.
   - **+3dB**: Starts slowly and then moves quickly toward the end. This is the default setting and is best for maintaining a natural volume when crossfading between two clips.
   - **–3dB**: Starts quickly and then slowly tapers off toward the end.

Remove a crossfade

In the Final Cut Pro timeline, do one of the following:

- Trim each clip to a point beyond the crossfade.
- Select both clips, align the audio to video, then choose Modify > Adjust Audio Fades > Remove Fades.

Pan audio in Final Cut Pro for Mac

Panning audio lets you distribute sound across the stereo or surround spectrum to create balance or a special effect. For example, you can place more sound in the right channel of a stereo clip or less sound in the center channel of a surround clip.

Final Cut Pro includes a built-in surround sound decoder that lets you choose among several stereo and surround preset pan modes that you can apply to clips from the Audio inspector. Using the pan mode presets, you can dynamically re-create surround sound fields from stereo source content.

*Note:* To display surround channels in the audio meters, make sure you set your project’s audio and rendering properties to surround before you decode stereo content to surround channels. For information about project properties, see Modify a project’s settings and Final Cut Pro project settings. For information about the audio meters, see View and change audio levels.

When you change the pan mode in the Audio inspector, the setting is applied to the entire selection. To make more precise adjustments, you can add keyframes using the Audio Animation editor or the Audio inspector, and then make adjustments to them in the Audio inspector.
Pan audio for stereo
1. In Final Cut Pro, select the audio clip.
2. In the Pan section of the Audio inspector, click the Mode pop-up menu and choose Stereo Left/Right.
3. Move the sound left or right by doing one of the following:
   • Type a value in the Pan Amount field.
   • Drag the Pan Amount slider left or right.

Pan audio for surround sound
1. In Final Cut Pro, select the audio clip.
2. In the Pan section of the Audio inspector, click the Mode pop-up menu and choose one of the following options:
   • Basic Surround: Positions the signal in its default channels, with a stereo signal in the right and left channels, and a mono signal in the center channel. The Pan Amount slider setting distributes portions of the signal to other channels and can be adjusted from –100 (left channels) to 100 (right channels).
   • Create Space: Distributes the signal across the surround spectrum, with more signal to the center and front left and right channels. This setting is useful for making a general-purpose surround mix from any stereo source. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (total surround field).
   • Dialogue: Pans more signal to the center channel of the surround spectrum so that the direct sound is in the center, while ambient sound is distributed to the other channels. This setting is best used for voiceover or other dialogue clips. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (all sound to the center channel).
   • Music: Distributes a stereo mix signal evenly across the surround spectrum. This setting is best used for converting stereo music to a surround mix. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (total surround field).
   • Ambience: Pans across the surround spectrum with more signal toward the surround channels and less signal to the front and center channels. This setting is useful for effects such as crowd noise or other outdoor environments. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (total surround field).
   • Circle: Pans the sound in a circle around the surround spectrum (like a bee buzzing around the listener’s head). The Pan Amount slider adjusts the direction to the listener in degrees (–180 to 180).
   • Rotate: Pans around the surround spectrum as if the listener is turning in a circle. The Pan Amount slider adjusts the listener rotation in degrees (–180 to 180).
   • Back to Front: Pans from back to front across the surround spectrum. The Pan Amount slider setting can be adjusted from –100 (back) to 100 (front).
   • Left Surround to Right Front: Pans from left surround to right front across the surround spectrum. The Pan Amount slider setting can be adjusted from –100 (left surround) to 100 (right front).
   • Right Surround to Left Front: Pans from right surround to left front across the surround spectrum. The Pan Amount slider setting can be adjusted from –100 (right surround) to 100 (left front).
3. If you want to adjust the pan amount, do one of the following:
   • Type a value in the Pan Amount field.
   • Drag the Pan Amount slider left or right.

   The Pan Amount settings vary according to the pan mode you choose.

**Adjust surround sound using the Surround Panner**

In the Audio inspector, you can use the Surround Panner to change the surround sound field or make advanced adjustments using sliders.

Using the Surround Panner, you can change the panning levels by moving a control that represents where the sound would appear to originate in an actual surround sound speaker setup.

1. In Final Cut Pro, select the audio clip.
2. In the Pan section of the Audio inspector, click the Mode pop-up menu and choose a surround preset.

   The Surround Panner appears in the Pan section.
3. Do any of the following:
   • **Make adjustments in the Surround Panner:** Drag the control within the surround field to pan toward or away from any of the surround channels (left, center, right, left surround, or right surround) represented by the speaker icons. Click a speaker icon to turn it on or off.

   ![Surround Panner](image)
   
   To move the control back to the center position, double-click it.
- **Make advanced adjustments:** Below the Surround Panner, click Show in the Advanced section, then drag the sliders to adjust any of the following parameters:

  - **Original/Decoded:** Adjusts the balance between the original and decoded signals. The slider can be adjusted from –100 (original signal only) to 100 (decoded center and surround signals only). At 0, the signal is balanced evenly between the original and decoded signals.

  - **Ambient/Direct:** Adjusts the balance between decoded surround and center signals. The slider can be adjusted from –100 (surround signal only) to 100 (center signal only). At 0, the signal is balanced evenly between the center and surround signals.

  - **Surround Width:** Specifies how much separation (in dB) is between the decoded surround signals. At 0 dB, there is complete separation between the center and surround signals, but each surround signal is mono. To increase the stereo effect in the left and right surround channels, you can increase the parameter value. This also results in some signal being diverted from the center channel to the surround channels.

  - **LFE Balance:** Adjusts the low-frequency effects (subwoofer) signal from –1 (no signal sent to the LFE channel) to 1 (all signal sent to the LFE channel). When the slider is centered at 0, the signal is distributed evenly among the five channels and the LFE channel.

  - **Rotation:** Rotates all surround signals to the left or right in a circular manner. When the slider is at the extreme left or right (–180 degrees or 180 degrees, respectively), the surround signal is rotated to the center channel and the center signal is rotated to the surround channels. At 0 degrees (the center of the slider), there is no rotation.

  - **Stereo Spread:** Adjusts the amount of stereo effect from the left and right channels to the center and surround speakers.

  - **Attenuate/Collapse:** Adjusts the way the panning effect is implemented. At 0, the source signals are attenuated (meaning that the original channel signals get louder and softer but are not actually diverted to other channels). At 100, the source signals are collapsed (meaning that the original channel signals aren’t changed in volume, but instead are moved to other channels in the panning direction).

  - **Center Balance:** Adjusts the balance between the center and surround signals. The slider can be adjusted from –100 (all center signal sent to the surround channels) to 100 (all surround signals sent to the center channel). At 0, the signal is balanced evenly between the center and surround channels.

When you make adjustments to advanced parameters, the Pan Mode setting indicates that it has been edited.
Reset pan adjustments

In Final Cut Pro, do any of the following:

- *Reset an edited pan mode:* Click the Pan Mode pop-up menu and choose another preset. The Pan Amount slider is not affected.

- *Reset adjustments to the Surround Panner only:* Move the pointer to the Surround Panner section in the Audio inspector, then click the Reset button that appears on the right.

- *Reset all adjustments:* Move the pointer to the Pan row in the Audio inspector, then click the Reset button that appears on the right.

You can monitor stereo and surround sound channel levels using the audio meters.

*Note:* If you add a clip with mono audio to a stereo project, Final Cut Pro plays the single mono audio in both left and right channels, visible in the stereo audio meters for the project.

Multichannel audio editing examples in Final Cut Pro for Mac

Below are examples of some multichannel audio editing workflows in Final Cut Pro.

**Example: Remove unwanted noise from an audio component**

*Note:* To skim audio for an individual audio component, make sure both clip skimming and audio skimming are turned on. See Skim media.

1. Select a clip in the Final Cut Pro timeline, then choose Clip > Expand Audio Components (or press Control-Option-S).

2. Skim or play back the audio component to find the specific place where the noise occurs.
3. Drag within the component to select the range where the noise occurs.

4. Do one of the following:
   - *Disable the portion of the component where the noise occurs:* Press the V key (or press the Delete key).
     Disabling a selected range mutes all sound within the range. To unmute (enable) the range, press the V key (or press Command-Z).
     Note: When you disable a range in an audio component, fade handles become available on either side of the disabled range. See **Fade audio in and out**.

   - *Adjust the volume within the range:* Drag the horizontal control up or down, or adjust volume from the **Modify menu** or the **keyboard**.

     Keyframes are automatically created along the adjustment points within the range.
5. Play back the clip to listen to your adjustments.

6. To collapse the audio components after you complete your adjustments, choose Clip > Collapse Audio Components (or press Control-Option-S).

**Example: Trim audio within an audio component**

1. Select a clip in the Final Cut Pro timeline, then choose Clip > Expand Audio Components (or press Control-Option-S).

![Audio components]

2. Position the pointer at the edge of the audio component you want to trim.
   
The pointer changes to the Trim tool \( \text{\textbullet} \).

3. Drag to trim that section.
   
   To undo your trim, press Command-Z.

![Trimmed audio component]

4. Play back the clip to listen to your adjustments.

5. To collapse the audio components after you complete your adjustments, choose Clip > Collapse Audio Components (or press Control-Option-S).
Example: Trim all audio components at the same time
1. Select a clip in the Final Cut Pro timeline, then choose Clip > Expand Audio Components (or press Control-Option-S).

2. Position the pointer at the edge of one of the expanded audio components.
3. Hold down the Shift key and drag left or right to trim the edit point for all of the audio components at once.
   The video portion of the clip is not affected.
   To undo your edit, press Command-Z.

4. Play back the clip to listen to your adjustments.
5. To collapse the audio components after you complete your adjustments, choose Clip > Collapse Audio Components (or press Control-Option-S).

Example: Enable or disable audio components in a multicam clip
When you create a multicam clip that contains multiple audio components, you can use the angle viewer or the Audio inspector to add audio components from inactive angles to the active angle. This makes it easy to add audio from different source clips in your multicam clip while maintaining the active video angle. You can also disable audio components from the active angle to eliminate unwanted or unused audio.

Before you start, you can make adjustments to the channel configuration of audio components in your source clips in the browser using the Audio inspector. See Configure audio channels.
1. In Final Cut Pro, drag a multicam clip from the browser to the timeline.

2. To open the angle viewer, do one of the following:
   - Choose View > Show in Viewer > Angles (or press Shift-Command-7).
   - Click the View pop-up menu in the top-right corner of the viewer and choose Angles from the Show section.
   The active angle appears highlighted in yellow.

3. To enable audio-only switching in the angle viewer, click the right switch mode button in the upper-left corner.

4. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button in the toolbar.

5. Click the Audio button at the top of the inspector.

The audio corresponding to the active angle in the angle viewer appears highlighted in the Audio Configuration section of the Audio inspector.
6. To add audio components from inactive angles, do one of the following:

   - **In the angle viewer:** Hold down the Command and Option keys and click an inactive angle or angles.
   - **In the Audio inspector:** Select the checkbox next to each audio component you want to add.

   In this example, the angle whose audio you added is highlighted in green in the angle viewer, and the audio components you added are highlighted in the Audio inspector.

   ![Audio components added to the active angle](image)

   The added audio components also appear in the multicam clip's component arrangement in the timeline. (To show expanded audio components, choose Clip > Expand Audio Components, or press Control-Option-S.)

   ![Audio components added to the timeline](image)

7. To remove an audio component from the active angle, do one of the following:

   - **In the angle viewer:** Hold down the Command and Option keys and click the angle (highlighted in green) whose audio you want to remove.
   - **In the Audio inspector:** Deselect the checkbox next to the audio component you want to remove.
   - **In the timeline:** With the clip's audio components expanded in the timeline, select the audio component and press Delete.
When a component is removed, it appears dimmed in the Audio inspector and the angle is no longer highlighted in green in the angle viewer. The component also disappears from the multicam clip’s component arrangement in the timeline.

**Example: Perform a roll edit on adjacent audio components**

1. Select adjacent clips in the Final Cut Pro timeline, then choose Clip > Expand Audio Components (or press Control-Option-S).

2. Click the Tools pop-up menu in the top-left corner of the timeline and choose Trim (or press T).

   ![Trim tool](image)

   The pointer changes to the Trim tool 🗺️.

   **Tip:** To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the tool reverts to the previously active tool.

3. In the timeline, click the center of the edit point between the adjacent audio components that you want to roll, so that both sides of the edit point are selected.

4. Drag left or right to **roll** the edit point.

   ![Roll edit](image)

   The edit point is rolled to the new location. The combined duration of the two components stays the same.

   **Note:** The adjacent audio components must have sufficient media handles (additional media available beyond the edit point). If you can’t roll the edit point any farther and one side of the edit point appears red, you’ve reached the end of the media for one of the two components.
Add and adjust audio effects

Add audio effects in Final Cut Pro for Mac

In addition to enhancing audio using the built-in audio enhancement features, you can take advantage of 64-bit macOS built-in and third-party Audio Units (AU) effects for your audio processing tasks.

Final Cut Pro also comes with an extensive range of custom audio effects and professional Logic effects, which are digital signal processing (DSP) effects and processors that are used to color or tonally shape existing audio recordings and audio sources—in real time.

Some of the most common processing options include noise reduction, pitch correction, EQs, dynamic processors, and reverbs. Further advanced features include delays, modulations, distortions, bass enhancement, and time-altering processors and utilities. Some custom effects included with Final Cut Pro combine multiple effects to create a particular sound environment, such as a cathedral.

You can add effects to individual audio clips and components or to a compound clip. After you add an effect, you can adjust its settings using the Audio inspector.

Add audio effects to a clip

1. Click the Effects button in the top-right corner of the Final Cut Pro timeline (or press Command-5).

2. In the Effects browser, select an audio effect.

   You can do any of the following to help make your selection:
   - Preview what an effect sounds like using the audio from the currently selected timeline clip: Move the pointer over the audio effect thumbnail.
   - Filter the list of effects that appear: Type text in the Effects browser search field.

3. Do one of the following:
   - Drag the effect to an audio clip (or a video clip with audio) in the timeline.
   - Double-click the effect icon to apply the effect to the selected clip.

The effect appears in the Effects section of the Audio inspector and in the Audio Animation editor. You can now adjust the effect.
Change the order of audio effects
You can apply multiple audio effects to a timeline clip.

The order in which you apply them affects the final output. For example, if you apply a reverb effect followed by the Noise Gate effect, the Noise Gate effect will interpret some of the reverb as noise and attempt to remove it.

After you apply audio effects to a clip, you can change the order in which they process the audio signal by reordering them in the Audio inspector or the Audio Animation editor. The first effect applied appears at the top of the list.

1. In the Final Cut Pro timeline, select a clip you’ve added effects to.
2. Do one of the following:
   • In the Effects section of the Audio inspector, drag an effect up or down.
   • In the Audio Animation editor, drag an effect up or down.

⚠️ Tip: Apply audio effects in this order: any noise reduction (if needed), then EQ or special effects, then compression or limiters.

Copy all of a clip’s effects to another clip
You can copy effects and their settings from one clip to another. This can be especially useful if you’ve made adjustments to effects in a clip that you want to preserve and use with other clips.

1. Select a clip in the Final Cut Pro timeline, then choose Edit > Copy (or press Command-C).
2. Select the clip or clips you want to apply the effects to, then choose Edit > Paste Effects (or press Option-Command-V).

If a clip has more than one effect applied to it, all of the effects and their settings are applied to the other clip.

Copy selected clip attributes to another clip
You can copy selected audio attributes, such as settings and effects, from one clip to another. For example, you can copy pan settings, or any effects you’ve added to a clip, including any keyframe adjustments.

1. Select a clip in the Final Cut Pro timeline, then choose Edit > Copy (or press Command-C).
2. Select the clip or clips you want to apply the attributes to, then choose Edit > Paste Attributes (or press Shift-Command-V).
3. In the Paste Attributes window, do any of the following:

- Apply all audio attributes from the source clip: Select the Audio Attributes checkbox.
- Apply individual attributes: Select the checkboxes for the attributes you want to apply.
- If you made any keyframe adjustments to the source clip: In the Keyframe Timing section, select either Maintain or Stretch to Fit. If you choose Stretch to Fit, Final Cut Pro adjusts the keyframes in time to match the duration of the destination clip.

4. Click Paste.

For more information about using the Logic effects that are included with Final Cut Pro, see Final Cut Pro Logic Effects for Mac.

Remove audio effects in Final Cut Pro for Mac

You can remove all effects from a clip selection, or you can use the Remove Attributes command to remove selected attributes and effects. The second method provides more control over individual effects and settings and is similar to copying selected effects to a clip selection using the Paste Attributes command.

If you’re not sure you want to remove an audio effect, you can turn it off but retain its settings.
Remove selected attributes and effects from one or more clips

1. Select one or more clips in the Final Cut Pro timeline.

2. Choose Edit > Remove Attributes (or press Shift-Command-X).

   The Remove Attributes window opens, with the clip’s current effects and attributes selected.

3. Deselect the checkboxes for the effects or attributes you want to retain, and select the checkboxes for the effects or attributes you want to remove.

4. Click Remove.

   Selected **clip effects** are removed from the clips entirely. Selected **built-in effects** (such as Volume and Pan) are reset to their default values.

   **Note:** You can also remove an individual effect from a clip in the timeline using the Audio inspector or the Audio Animation editor. Simply select the effect and press Delete.

Remove all clip effects from one or more clips

1. Select one or more clips in the Final Cut Pro timeline.

2. Choose Edit > Remove Effects (or press Option-Command-X).

   All **clip effects** are removed from the selected clips entirely. All **built-in effects** on the selected clips (such as Volume and Pan) are reset to their default values.

Turn off a clip effect

After you apply an audio effect to a clip, you can turn off the effect (but retain its settings) in the Audio inspector or the Audio Animation editor.

1. Select the clip with the effect in the Final Cut Pro timeline.

2. In the Audio Animation editor or the Effects section of the Audio inspector, deselect the effect’s checkbox.
Add the default audio effect in Final Cut Pro for Mac

You can set a default audio effect and quickly add it to your project clips using the Option-Command-E keyboard shortcut or a menu command.

Final Cut Pro comes with the default audio effect set to Channel EQ, but you can change the default effect to any audio effect in the Effects browser, including custom audio effects presets. For more information about audio effects presets, see Save audio effects presets.

Add the default audio effect to project clips
1. In the Final Cut Pro timeline, select one or more clips that contain audio components.
   
   Note: The name of the menu item changes depending on the current default audio effect.

Set the default audio effect
1. Click the Effects button in the top-right corner of the Final Cut Pro timeline (or press Command-5).
2. Control-click an audio effect or an audio effects preset in the Effects browser, then choose Make Default Audio Effect.

Adjust audio effects in Final Cut Pro for Mac

You can adjust an effect’s parameters using controls in the Audio inspector or the effect’s window.

If you’re using Audio Units effects or Logic effects, you can show an expanded interface by opening the effect’s window.

For more information about using the Logic effects that are included with Final Cut Pro, see Final Cut Pro Logic Effects for Mac.
Adjust an audio effect

1. In the Final Cut Pro timeline, select the clip with the effect you want to adjust.

2. Locate the effect in the Effects section of the Audio inspector.

3. To see an effect's parameters, do one of the following:
   - Click the Controls button (to the right of the effect's name) to show a larger window with advanced controls.
   - Move the pointer over the effect in the inspector and click the Show button at the right end of the effect bar.

   **Tip:** You can adjust effects over time using keyframes in the Audio inspector or the Audio Animation editor.

4. Select effect parameters and adjust their settings as needed.

   You can preview your adjustments by using the skimmer or playing the clip in the timeline.

   To return the effect's values to their default settings, click the effect's Reset button.
Use Audio Units and Logic effects presets

Many Audio Units and Logic effects include built-in presets that are tailored for specific settings or environments, such as reverb presets that simulate the acoustics of a small room or a large cathedral. Presets make it easy to preview and apply effects quickly.

1. In Final Cut Pro, locate the effect in the Effects section of the Audio inspector.
2. Click the Preset pop-up menu and choose a preset.

You can preview your presets by using the skimmer or playing the clip in the timeline. To return the effect to its default settings, click the Preset pop-up menu and choose Default.

Edit and save custom Audio Units and Logic effects presets

You can edit preset parameters by adjusting the effect’s controls. If you want to keep your changes, you can save them as a custom preset.

1. In Final Cut Pro, locate the effect in the Effects section of the Audio inspector.
2. Click the Preset pop-up menu and choose a preset.

3. To see an effect’s parameters, do one of the following:
   - Click the Controls button (to the right of the effect’s name) to show a larger window with advanced controls.
   - Click the Parameters disclosure triangle to show controls in the Audio inspector.
4. Select effect parameters and adjust their settings as needed.

You can preview your adjustments by using the skimmer or playing the clip in the timeline.

When you adjust a preset’s parameters, the Preset pop-up menu indicates that the preset has been edited.

5. To save an edited preset, click the Preset pop-up menu and choose Save Preset, then type a name for the new preset.

Saved presets appear in the Preset pop-up menu.

To return the effect to its default settings, click the Preset pop-up menu and choose Default.
Delete custom presets

1. In Final Cut Pro, locate the effect in the Effects section of the Audio inspector.

2. Click the Preset pop-up menu and choose Reveal User Presets in Finder.

3. In the Finder window, select the preset or presets you want to delete, then drag them to the Trash.

   After a custom preset has been deleted, it no longer appears in the Preset pop-up menu.

Save audio effects presets in Final Cut Pro for Mac

You can save any combination of audio effects and audio effect parameter settings as an audio effects preset, which appears in the Effects browser and functions like any other audio effect. You can create an effects preset from any combination of built-in effects and clip effects. After you create an effects preset, you can share it with friends and colleagues so that the same preset (with its specific combination of effects and parameter settings) is available in their Effects browser.

Save an audio effects preset

1. Apply any combination of built-in effects and clip effects to an audio clip (or a video clip with audio) in the Final Cut Pro timeline, then make any adjustments to the effects.

   See Add audio effects and Adjust audio effects.

2. Select the clip in the timeline.

3. Do one of the following:

   • Choose File > Save Audio Effects Preset.
   • Open the Audio inspector and click Save Effects Preset at the bottom of the inspector.

The Save Audio Effects Preset window appears, with any applied or adjusted effects selected in the Attributes list.
4. Enter a name for the new preset in the Name field.

5. Click the Category pop-up menu and choose an Effects browser category in which to store the new preset.

6. In the Attributes list, select the audio effects you want to include in the preset.
   
   If you made any keyframe adjustments to the source clip, select either Maintain or Stretch to Fit in the Keyframe Timing section. If you select Stretch to Fit, Final Cut Pro adjusts the keyframes in time to match the duration of any clip to which you apply the preset.

7. Click Save.

   The new audio effects preset appears in the Effects browser category you chose. To apply the preset to a clip, see Add audio effects.

**Share an audio effects preset**

1. In the Final Cut Pro Effects browser, Control-click the effects preset you want to share, then choose Reveal in Finder.

2. In the Finder, select the effects preset file and choose File > Compress.

   *Note:* Compressing the file prevents any change to the preset during transit.

3. Transfer the resulting .zip file to your friend or colleague using email or another convenient method.

4. On the receiving Mac, double-click the .zip file to decompress it.

5. In the Finder, hold down the Option key and choose Go > Library.

6. Drag the effects preset file to the following location in the Library folder:
   
   /Users/username/Library/Application Support/ProApps/Effects Presets/

7. If Final Cut Pro is open, quit and reopen it.

   The transferred audio effects preset appears in the Effects browser, in the same category as on the original Mac.
Keyframe audio effects in Final Cut Pro for Mac

With Final Cut Pro, you can use keyframes to create simple changes to audio over time, such as fading the volume or an effect in or out in the middle of a clip.

You place keyframes at specific points in a clip to change the parameter value of an audio enhancement or effect at those points. For example, you can keyframe specific points for volume or for an effect such as reverb or distortion.

You can set keyframes to adjust a clip’s volume directly in the timeline or the Audio inspector. To see keyframes in the timeline for all other effects, you need to display the Audio Animation editor.

For information about using keyframes with video clips, see Add video effect keyframes.

Add keyframes to a clip

1. In Final Cut Pro, do one of the following:
   - Select the clip in the timeline, then choose Clip > Show Audio Animation (or press Control-A).
   - Control-click the clip in the timeline and choose Show Audio Animation.

   If you’re adding keyframes for volume adjustment only, go to step 4.

   Each effect in the Audio Animation editor has a separate area for adding keyframes.

   Some effects have more than one parameter and allow you to add keyframes to individual parameters separately. They appear in the Audio Animation editor with a triangle next to the effect’s name or in the Audio inspector as additional parameter controls.

2. In either the Audio Animation editor or the Effects section of the Audio inspector, select the effect for which you want to add keyframes.

3. Do one of the following:
   - See expanded parameters in the Audio Animation editor: Click the triangle to choose an individual parameter from the pop-up menu, or choose All to see all keyframes.
   - See expanded parameters in the Audio inspector: Click the Parameters disclosure triangle for the effect.
4. For each parameter, do one of the following:

- *In the Audio Animation editor (or the audio clip for volume only):* Option-click (or press Option-K) at a point on the horizontal effect control where you want to add a keyframe.

  Keyframes for volume adjustment appear as white diamonds.

  ![Keyframe marking where a change in volume level occurred](image)

  For effects with more than one parameter, keyframes for the selected parameter appear as white diamonds, and keyframes for other parameters appear gray.

  ![Keyframes appear as white diamonds for all parameters when you choose All from the effect pop-up menu. Double diamonds indicate that you added a keyframe for more than one parameter at that point.](image)

- *In the Audio inspector:* Position the playhead in the timeline at the point where you want to add a keyframe, then click the Keyframe button (or press Option-K).

  ![Keyframe button](image)

  After you add a keyframe, the Keyframe button changes to solid white, indicating that the playhead is currently on this keyframe.
When you move the playhead in the timeline, arrows appear next to the Keyframe button in the Audio inspector to indicate which side of the playhead has keyframes. To go to the previous keyframe, click the left arrow or press Option-Semicolon (;). To go to the next keyframe, click the right arrow or press Option-Apostrophe (’).

5. Add keyframes as needed.

Tip: After you’ve added one keyframe, you can add another automatically by moving the playhead in the timeline and then adjusting the effect parameter (or the Volume slider when keyframing volume) in the Audio inspector.

Add keyframes automatically across a selected area

When making volume adjustments to a clip in the timeline, you can use the Range Selection tool to add keyframes automatically across a selected range.

If an effect appears in the Audio Animation editor with a disclosure button, you can use either the Select tool or the Range Selection tool to add keyframes across a selected area.

1. In Final Cut Pro, do one of the following:
   - Select the clip in the timeline, then choose Clip > Show Audio Animation (or press Control-A).
   - Control-click the clip in the timeline and choose Show Audio Animation.
   If you’re adding keyframes for volume adjustment only, go to step 3.

2. Select an effect, then click the disclosure button to expand it in the Audio Animation editor.
3. In the timeline, do one of the following:

- *If you’re adjusting volume only:* Click the Tools pop-up menu above the timeline and choose Range Selection (or press R).

![Range Selection tool](image)

The pointer changes to the Range Selection tool.

- *If you’re adjusting an effect in the Audio Animation editor:* Click the Tools pop-up menu above the timeline and choose either Select or Range Selection (or press A for Select, or R for Range Selection).

4. Drag across the area where you want to adjust the volume or effect.

![Audio Animation editor](image)

5. Adjust the volume or effect within the range by dragging the effect’s horizontal control up or down.

![Adjusting volume or effect](image)

Keyframes are automatically created along the adjustment points within the range.
Adjust keyframes in the Audio Animation editor

You can move keyframes left or right in the Audio Animation editor. If an effect appears with a disclosure button, you can expand the effect view and move keyframes up or down to change the parameter value.

1. In Final Cut Pro, select a keyframe.
2. Do one of the following:
   - To change the keyframe's position in time, drag it left or right.
     As you drag, the timecode value appears.
     ![Keyframe timecode](image1)
   - If an effect appears with a disclosure button, click the button (or double-click the effect) to expand the effect view.
     ![Disclosure button](image2)
     With the effect view expanded, you can drag the keyframe up or down to change the effect's parameter value.
     ![Expanded effect view](image3)

   To add another keyframe, Option-click (or press Option-K) at a point on the effect control where you want to add the keyframe. To add a keyframe and change the effect's parameter value at the same time, Option-click while dragging the effect control up or down.

Adjust keyframes in the Audio inspector

For many effects, you adjust the parameter value of individual keyframes using the Audio inspector.

1. In Final Cut Pro, select a keyframe or position the playhead on a keyframe, then adjust the parameter value in the Audio inspector.
2. To change the value at the next keyframe, go to the next keyframe and adjust the value again.
Adjust all keyframes at once in the Audio Animation editor

- In Final Cut Pro, hold down the Command and Option keys, then drag either a keyframe or the effect control up or down.

  All keyframes are adjusted by the same amount, preserving the original shape created by any keyframe adjustments.

  However, if you “flatten” the curve by dragging all the way to the top or bottom of the graph, the keyframe values remain in that flattened state, with all keyframes sharing the same value.

View one effect at a time in the Audio Animation editor

You can collapse the Audio Animation editor to view only one effect at a time. This can be useful if you have multiple effects applied to a clip and want to preserve screen space.

1. In Final Cut Pro, choose Clip > Solo Animation (or press Control-Shift-V).
2. In the Audio Animation editor, click the triangle next to the displayed effect’s name, then choose an effect from the pop-up menu.

Note: When Solo Animation is turned on, you can’t delete effects from the Audio Animation editor.

To turn off Solo Animation, choose Clip > Solo Animation (or press Control-Shift-V).

Delete keyframes

In Final Cut Pro, do one of the following:

- Select a keyframe in the Audio Animation editor, then press Option-Shift-Delete.
- Navigate to a keyframe in the Audio inspector, then click the Keyframe button.
Hide audio animation
In Final Cut Pro, do one of the following:

• Select the clip in the timeline, then choose Clip > Hide Audio Animation (or press Control-A).
• Click the close button ⌘ in the upper-left corner of the Audio Animation editor.
• Control-click the clip in the timeline and choose Hide Audio Animation.

You can also manipulate multiple keyframes simultaneously. This works the same way for audio keyframes as it does for video keyframes. See Modify groups of keyframes.

To copy specific keyframes between different attributes or between different clips, see Copy and paste keyframes.

⚠️ Tip: If you applied a reverb effect to a clip and you want the reverb to extend beyond the end of the clip, add a hold segment to the last frame. The hold segment duration is fully adjustable, and you can extend the reverb keyframing into the hold segment.

Audio tools and techniques

Enhance audio in Final Cut Pro for Mac
Final Cut Pro includes several powerful tools for analyzing and enhancing the audio in your projects, including:

• **Equalization**: Choose from a handy menu of equalization presets.
• **Voice Isolation**: Prioritizes human voices over other parts of the audio signal.
• **Loudness**: Improves the main audio signal and makes it more uniform.
• **Background Noise Removal**: Reduces background noise.
• **Hum Removal**: Reduces common electrical hum noise at either 50 or 60 Hz.

Equalization and Voice Isolation must be turned on manually in the Audio Enhancements section of the Audio inspector. The other enhancements are designed to correct common audio problems automatically or with minor manual adjustments.

You can also analyze and fix audio problems when you import a clip. (See Audio analysis options.)

*Note*: When you import a clip with the "Analyze Audio: Fix audio problems" import option selected, only severe audio problems are corrected. If the clip contains moderate problems, these appear in yellow next to Audio Analysis in the Audio Enhancements section of the Audio inspector after the clip is imported. To correct these problems, you need to automatically enhance audio in the Audio inspector.
Enhance audio automatically

1. In Final Cut Pro, select an audio clip or a video clip with audio in the timeline.
   
   **Important:** Audio enhancement works on the component level, not the clip level. If your audio clip has more than one audio component (for example, a dual mono clip), select an individual component, then proceed with the enhancements.

2. Do one of the following:
   
   • Choose Modify > Enhance Audio (or press Option-Command-A).
   
   • Click the Enhancements pop-up menu below the viewer and choose Enhance Audio.
   
   • In the Audio inspector, click the Enhance Audio button next to Audio Analysis in the Audio Enhancements section.

3. If it isn’t already open, open the inspector, then click the Audio button at the top.

   In the Audio Enhancements section of the inspector, a green checkmark to the right of an enhancement indicates that the clip was analyzed and, if necessary, adjusted for that enhancement. A blue checkbox appears next to each enhancement that was turned on to apply a correction. You can turn on additional enhancements by selecting their checkboxes (when an enhancement is turned on, its checkbox is blue).

   **Note:** If the enhancement controls aren’t shown, position the pointer over the right side of the Audio Analysis bar (or any individual enhancement bar), then click Show.

   To adjust any enhancement manually, see Enhance audio manually.

   To turn off an enhancement, deselect its checkbox. A yellow warning triangle may appear in the inspector, indicating potential problems.
Enhance audio manually

1. In Final Cut Pro, select an audio clip or a video clip with audio in the timeline.
   
   **Important**: Audio enhancement works on the component level, not the clip level. If your audio clip has more than one audio component (for example, a dual mono clip), **select an individual component**, then proceed with the enhancements.

2. If it isn’t already open, open the inspector, then click the Audio button at the top.

3. In the Audio Enhancements section of the Audio inspector, select the checkboxes for the enhancements you want to use, then do any of the following:
   
   - **Adjust equalization**: In the Equalization section, click the Equalization pop-up menu and choose an equalization preset, or click the Controls button to make manual adjustments.
   
   - **Change the percentage of voice isolation**: Drag the Amount slider in the Voice Isolation section. Voice Isolation prioritizes any detectable human voices over other parts of the audio signal. Voice Isolation requires macOS Monterey 12.3 or later. Turning on Voice Isolation for several audio components that are all playing at the same time may result in garbled audio. If this occurs, try turning off Voice Isolation for one or more audio components.
   
   - **Change loudness settings**: Drag the Amount and Uniformity sliders in the Loudness section. The Amount slider adjusts the overall loudness (compression) of the clip, and the Uniformity slider adjusts the dynamic range affected.
   
   - **Change the percentage of background noise removal**: Drag the Amount slider in the Noise Removal section.
   
   - **Remove hum**: Select either 50 Hz or 60 Hz in the Hum Removal section.
Note: If the enhancement controls aren’t shown, position the pointer over the right side of the Audio Analysis bar (or any individual enhancement bar), then click Show.

To turn off an enhancement, deselect its checkbox. A yellow warning triangle may appear in the inspector, indicating potential problems.

If you want a clip to sound like another clip, you can match the audio.

Sync audio and video in Final Cut Pro for Mac

Final Cut Pro can automatically analyze and sync the audio and video clips in your project.

A common production technique is double system sound, in which you record the video on one device (such as a DSLR camera) and the audio on a separate device (such as a digital audio recorder). In this workflow, you can use Final Cut Pro to sync the clips recorded on multiple devices.

For example, if you select two video clips and three audio clips from different sources that were all recorded during the same take, Final Cut Pro automatically analyzes the clips and syncs them together into a new clip in the browser. The original clips are not affected.

Final Cut Pro analyzes the clips for sync points such as markers you’ve added, timecode, file creation date, and audio content. If no sync points can be found, the clips are synced at their respective starting points.
For finer control of the syncing process, you can use custom settings to adjust several different parameters.

**Selected clips in the browser**

**New clip containing synced clips**

**Synced clip contents**

- Primary storyline for the synced clip
- Connected clips
Sync clips automatically

1. In the Final Cut Pro browser, select the audio or video clips you want to sync.

2. Do one of the following:
   • Choose Clip > Synchronize Clips (or press Option-Command-G).
   • Control-click the selection and choose Synchronize Clips.

3. In the window that appears, type a name for the synced clip in the Synchronized Clip Name field.

4. Click the In Event pop-up menu and choose the event in which you want to create the new synced clip.

5. If you want the synced clip’s timecode to start at a value other than the earliest timecode value in the selected clips (the default), type a timecode value in the Starting Timecode field.

6. To sync clips using audio waveform data, select “Use audio for synchronization.”
   This option makes precision sync adjustments using audio waveforms.

Note: Some audio recordings are not suited for use with this feature. Selecting this option may result in long processing times during which Final Cut Pro is not available for editing.

7. If you want Final Cut Pro to disable the audio in clips containing both video and audio, select “Disable audio components on AV clips.”
   For example, if you record dual-system sound (with a reference audio track on the video camera and a high-quality audio-only recording on a separate sound recorder), you can disable the reference track that was recorded on the camera after you finish syncing the video to the high-quality audio.

8. If the automatic settings aren’t shown, click Use Automatic Settings.
   The automatic settings appear.

Note: The automatic settings are shown by default, but if the last synced clip you created used custom settings, those settings are shown.

9. Click OK.
   Final Cut Pro creates a new synced clip in the event you specified.
Sync clips using custom settings

1. In the Final Cut Pro browser, select the audio or video clips you want to sync.

2. Do one of the following:
   - Choose Clip > Synchronize Clips (or press Option-Command-G).
   - Control-click the selection and choose Synchronize Clips.

3. In the window that appears, type a name for the synced clip in the Synchronized Clip Name field.

4. Click the In Event pop-up menu and choose the event in which you want to create the new synced clip.

5. If you want the synced clip's timecode to start at a value other than the earliest timecode value in the selected clips (the default), type a timecode value in the Starting Timecode field.

6. To sync clips using audio waveform data, select “Use audio for synchronization.” This option makes precision sync adjustments using audio waveforms.

   ![Sync point](image)

   **Note:** Some audio recordings are not suited for use with this feature. Selecting this option may result in long processing times during which Final Cut Pro is not available for editing.

7. If you want Final Cut Pro to disable the audio in clips containing both video and audio, select “Disable audio components on AV clips.”

   For example, if you record dual-system sound (with a reference audio track on the video camera and a high-quality audio-only recording on a separate sound recorder), you can disable the reference track that was recorded on the camera after you finish syncing the video to the high-quality audio.
8. To show the custom settings, click Use Custom Settings. The custom settings appear.

Note: The automatic settings are shown by default, but if the last synced clip you created used custom settings, those settings are shown.

9. Click the Synchronization pop-up menu and choose how the clips are synced:
   - **Automatic**: Final Cut Pro syncs the clips automatically.
   - **Timecode**: Final Cut Pro syncs the clips using timecode recorded in the clips. If you recorded timecode in your clips, choose this option. It’s the fastest and most frame-accurate method of syncing clips.
     
     Note: The Timecode option is not available when the drop frame patterns in the selected clips don’t match.

   - **Content Created**: Final Cut Pro syncs the clips using the date and time information recorded by your camcorder or video recording device.
The Content Created method can sync clips within 1-second accuracy (because in most camcorders the smallest unit in date and time information is 1 second). If you choose this syncing method, consider doing any of the following to make the sync frame-accurate:

- Select “Use audio for synchronization.” (See step 7.) Final Cut Pro uses the Content Created data as a starting point and then further refines the sync.

- Manually adjust the sync. (See Manually adjust or slip a synced clip, below.)

Note: At any time, you can change the Content Created date and time of your source clips in the browser. Just select one or more clips and choose Modify > Adjust Content Created Date and Time.

- **Start of First Clip:** Final Cut Pro uses the first frame in each clip as the sync point.

 Tip: The Start of First Clip method is useful if you want to use specific range selections of your source clips only. In the browser, add keywords to the ranges you want to use, or rate them as favorites, and then filter or search for the clips. When you create your synced clip, Final Cut Pro uses only the media showing in the filtered view.

- **First Marker on the Clip:** Final Cut Pro uses the first marker in each clip as the sync point.

 Tip: With this method, you can use the first marker to define a region that can be fine-tuned with the “Use audio for synchronization” option (described in step 6). In other words, you don’t need to place the marker exactly—just close enough so that the automatic audio sync feature can sync the clips the rest of the way.

10. If you want to change the video properties for the synced clip, click the Video pop-up menu and choose Custom, then change the settings as appropriate.

 Note: By default, Final Cut Pro analyzes the selected clips and configures these settings according to the most common clip properties among the clips.

11. If you want to change the rendering or audio settings for the synced clip, change the settings as appropriate in the Rendering and Audio sections.

12. Click OK.

 Final Cut Pro creates a new synced clip in the event you specified.
**Manually adjust or slip a synced clip**

You may need to adjust a synced clip (by slipping the sync, for example). You can do this by opening the contents of the synced clip in the timeline.

1. In Final Cut Pro, select the clip in the browser or the timeline.
2. Choose Clip > Open Clip.
   
   The timeline displays the contents of the clip.
3. Make adjustments to the contents of the synced clip.

   The contents of a synced clip include a clip in the primary storyline and one or more connected clips. You can adjust or slip the sync by dragging the connected clips left or right to change the points at which they connect to the clip in the primary storyline. See Connect clips.
4. When you’re done, click the left arrow in the upper-left corner of the timeline to save your changes and close the contents of the synced clip.

⚠️ **Tip:** To easily view all synced clips, you can create a Smart Collection that uses the Type search category set to Synchronized as one of the search criteria. See Create Smart Collections.

If your synced clip contains audio channels that aren’t being used, you can turn them off. See Configure audio channels.

**Match audio in Final Cut Pro for Mac**

The Match Audio function uses equalization (EQ) to let you match a selected clip’s sound to that of another clip. This is particularly useful when you have multiple audio clips recorded in different environments but want the clips to sound similar.

**Match audio**

1. In the Final Cut Pro timeline, select the clip or clips whose audio you want to match to that of another clip.

   Note: For clips with multiple components (such as dual mono clips, compound clips, multicam clips, and synced clips), make this selection at the component level. See Show expanded audio components.
2. Do one of the following:
   - Choose Modify > Match Audio (or press Shift-Command-M).
   - Click the Equalization pop-up menu in the Audio Enhancements section of the Audio inspector and choose Match.
   - Click the Enhancements pop-up menu below the viewer and choose Match Audio.

3. Click to select the clip whose sound you want to match.
4. Click Apply Match.

After you match a clip, you can adjust settings in the Audio Enhancements section of the Audio inspector.
Remove audio matching
1. In Final Cut Pro, select the clip in the timeline.
2. In the Audio Enhancements section of the Audio inspector, click the Equalization pop-up menu and choose a different equalization setting.
   To remove all equalization, choose the Flat setting.

Preserve pitch in retimed clips in Final Cut Pro for Mac
By default, Final Cut Pro preserves pitch when retiming clips so that the pitch doesn’t sound higher when the clip is faster or lower when the clip is slower. You can turn this feature on or off before or after a clip has been retimed.

1. In the Final Cut Pro timeline, select an entire clip, or a range within a clip, whose speed has been changed.
2. Click the Retime pop-up menu below the viewer and choose Preserve Pitch.

   A checkmark to the left of the command name indicates that Preserve Pitch is turned on. To turn it off, choose Preserve Pitch again.

Monitor mono or dual mono audio in Final Cut Pro for Mac
You can monitor audio from Final Cut Pro using a third-party audio interface. Some audio interfaces may require additional configuration using Audio MIDI Setup to properly monitor mono or dual mono audio from Final Cut Pro. See the Audio MIDI Setup User Guide.

1. Connect the audio output device to your Mac, and make sure it’s connected to power and turned on.
2. In the Finder, choose Go > Utilities (or press Shift-Command-U), then open Audio MIDI Setup.
3. In the Audio Devices window, select your audio output device in the list on the left.
   See Set up audio devices in Audio MIDI Setup on Mac.
4. Click Configure Speakers in the lower right.
5. Click the Configuration pop-up menu and choose Stereo, then click Done.

For more information about third-party devices and software, contact the device manufacturer.
Add titles

Add and adjust titles

Intro to titles in Final Cut Pro for Mac

Titles play a critical role in movies, providing important bookends (such as opening titles and closing credits) and conveying time and dates within the movie. Titles, especially in the lower third of the screen, are also used in documentaries and informational videos to convey details about subjects or products onscreen. You can also add notes and placeholders within your project while you edit.

You can create titles and credits within Final Cut Pro with title effects. Titles are synthesized clips (similar to generators) created by Final Cut Pro. Title clips don’t refer to any media on your Mac or storage device. When you add a title as a connected clip directly above another clip, the underlying clip appears as the title’s background, sparing you the need to perform any further compositing to create that effect.

For information about 3D titles, see Intro to 3D titles.

For information about creating subtitles and closed captions, see Intro to captions.
Add titles in Final Cut Pro for Mac

You add titles to clips in your project using the Titles and Generators sidebar. After you've added text, you can modify the title's text style.

Add a title to a project clip

1. Drag the playhead in the Final Cut Pro timeline to the point where you want to add the title.

2. If the Titles and Generators sidebar isn’t already shown, do one of the following:
   • Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.
   • Choose Window > Go To > Titles and Generators (or press Option-Command-1).

3. Do one of the following:
   • Browse all titles: Click Titles in the sidebar to display the titles in the browser.
   • Browse a single category of titles: Click a title category below Titles in the sidebar.
     To view the title categories, click the Titles disclosure triangle.

4. Do any of the following:
   • Add a title from the browser: Double-click the title.
     A title clip is added at the playhead location.
   • Add a basic title: Choose Edit > Connect Title > Basic Title (or press Control-T).
     A title clip named Basic Title (with no effects or animations) is added at the playhead location.
   • Add a lower-third title: Choose Edit > Connect Title > Basic Lower Third (or press Control-Shift-T).
     A lower-third title clip named Basic Lower Third (with no effects or animations) is added at the playhead location.

   Note: If you don’t see the title you’re looking for, you can use the Filter pop-up menu at the top of the browser to check for it in other locations. See Filter Motion content stored in a library.

The title clip is connected to the clip in the primary storyline at the position of the playhead. Visually, the title is superimposed over the clip in the primary storyline at the playhead position. If the playhead is not over a clip, the title is superimposed over the default background.
Add a title as a clip in the primary storyline

There are two ways to add a title as a clip in the primary storyline. You can either insert a title clip at the edit point between two clips or replace an existing clip in the primary storyline with a title clip.

1. To open the Titles and Generators sidebar in Final Cut Pro, do one of the following:
   • Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.
   • Choose Window > Go To > Titles and Generators (or press Option-Command-1).

2. Do one of the following:
   • Browse all titles: Click Titles in the sidebar to display the titles in the browser.
   • Browse a single category of titles: Click a title category below Titles in the sidebar.
     To view the title categories, click the Titles disclosure triangle.

3. Do one of the following:
   • Add a title between clips in the timeline: Drag the title from the browser to the edit point between the clips where you want the title clip to appear.
   • Replace an existing timeline clip with a title clip: Drag the title from the browser to the clip in the timeline that you want to replace, then choose Replace.

Enter text for your title

After you add a title clip to your project in the timeline, you can type text for your title in the viewer.

1. Select a title clip in the Final Cut Pro timeline.
2. Move the playhead over the selected title clip.
3. Do one of the following:
   • Select the text in the Text inspector.
   • In the viewer, double-click the title text.
4. Type text for your title.

5. To select a different text object, do one of the following:
   - Click the Previous Text Layer or Next Text Layer button in the viewer or the inspector.
   - Double-click a different text object.

6. Type new text as necessary.

7. To exit text editing, press Command-Return.

The Previous Text Layer and Next Text Layer buttons also support Motion text edit markers. See the Motion User Guide.

Note: If you have created or customized any titles in Motion, set the storage location for your Motion content to In Library before starting any copy or move operations between libraries or storage devices. Otherwise, the Motion content is not included in those operations. See Manage Motion content. Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.

**Add the default title in Final Cut Pro for Mac**

You can set a default title or a default lower third and then quickly add it to your project using a keyboard shortcut or a menu command.

Final Cut Pro comes with the default title set to Basic Title and the default lower third set to Basic Lower Third, but you can change the defaults to any title.
Add the default title or lower third

1. In the Final Cut Pro timeline, move the skimmer or the playhead to the frame where you want to add the default title or lower third.

2. Do one of the following:
   - Add the default title: Choose Edit > Connect Title > [title name] (or press Control-T).
   - Add the default lower third: Choose Edit > Connect Title > [lower third name] (or press Control-Shift-T).

   Note: The name of the menu item changes depending on the current default title or default lower third setting.

   The title or lower third is connected to the primary storyline at the skimmer or playhead position.

Set the default title or lower third

1. To open the Titles and Generators sidebar in Final Cut Pro, do one of the following:
   - Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.
   - Choose Window > Go To > Titles and Generators (or press Option-Command-1).

2. In the sidebar, select a titles category so that the appropriate titles appear in the browser.

3. Do one of the following:
   - Set the default title: Control-click a title in the browser and choose Make Default Title.
   - Set the default lower third: Control-click a title in the browser and choose Make Default Lower Third.
Adjust titles in Final Cut Pro for Mac

You can edit title text and change a title's style, color, and opacity.

You can edit text in the viewer or in the Text inspector, and you can adjust a title's appearance using the Title and Video inspectors.

**Edit title text**

1. In Final Cut Pro, do one of the following:
   - Select a title clip in the timeline, then move the playhead over the selected title clip.
   - Double-click a title clip in the timeline.
     
     The title appears in the viewer, and the text in the first text object in the title clip is selected. The playhead moves to the point in the timeline where the first text object is fully visible in the viewer. (For example, to make the animated text you’re editing visible in the viewer, you may need to move the playhead to a different point in the animation.)

2. Do one of the following:
   - Double-click a text object in the viewer.
   - Select the text in the Text inspector.

3. Edit the text.

4. To exit text editing, press Command-Return.

**Change a title’s color**

1. Double-click a title clip in the Final Cut Pro timeline.

   The title appears in the viewer, and the text in the first text object in the title clip is selected.

   *Note:* To modify a different text object in the same title, select it in the viewer.

2. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

   *Tip:* Double-click the top bar of the inspector to switch between half-height view and full-height view.
4. Click the color well in the Face section of the inspector and choose a color.

![Click the color well and choose a color.]

*Note:* To add a background color to your title, see *Add backgrounds.*

**Change a title’s text style**

You can change a title's text style—for example, the text's font, color, size, and alignment.

1. Double-click a title clip in the Final Cut Pro timeline.

   The title appears in the viewer, and the text in the first text object in the title clip is selected.

   *Note:* To modify a different text object in the same title, select it in the viewer.

2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

   ![Click the Text button at the top of the inspector.]

   🔄 *Tip:* Double-click the top bar of the inspector to switch between half-height view and full-height view.
4. Adjust the available settings as needed.

![Text settings interface](image)

**Note:** To reveal the controls in each of the sections, you may need to scroll down in the Text inspector and double-click each section name. For a complete list of available controls, see [Text inspector controls](#).

- **Basic:** Sets the basic text settings such as font, size, alignment, tracking, and line spacing.
- **3D Text:** Sets the depth, depth direction, weight, front edge type, front edge size, back edge type, and inside corner type for 3D text objects. See [Intro to 3D titles](#).
- **Face:** Sets the type of color fill, the fill color, opacity, and blur.
- **Outline:** Sets the type of color fill, the fill color, opacity, blur, and width.
- **Glow:** Sets the type of color fill, the fill color, opacity, blur, and radius.
- **Drop Shadow:** Sets the type of color fill, the fill color, opacity, distance, and angle.

5. To exit text editing, press Command-Return.

**Tip:** You can quickly add preset text styles to titles and save text appearance settings for future use. See [Apply preset text styles in Final Cut Pro](#).
Change the custom title settings
You can modify the title controls and parameters that are unique to a specific title.

Depending on the title, you may be able customize certain features or parameters such as the title's scale, position, color, or animation timing.

1. Select a title clip in the Final Cut Pro timeline.
2. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Title button at the top of the inspector.
   
   Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.
4. Adjust the available settings as needed.

You can design, build, and modify titles in Motion for use in Final Cut Pro. When you save a title template in Motion, you can choose which parameters to publish in the Title inspector in Final Cut Pro. See more information about Final Cut Pro templates in the Motion User Guide.

Note: You can also animate some titles by keyframing settings in the Title inspector. For more information about animating effects using keyframes, see Add video effect keyframes.
Change multiple text objects in a title at once

You can adjust the settings (such as the color, font, or size) of more than one text object at once.

1. Select a title clip in the Final Cut Pro timeline.
2. Move the playhead over the selected title clip.
3. In the viewer, do one of the following:
   - Holding down the Command key, select the text objects you want to modify.
   - Drag to select the text objects you want to modify.
4. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
5. In the Text inspector, adjust the available settings as needed.

Change a title’s opacity, blend mode, or HDR brightness

You can change a title’s opacity (to make the title more transparent) or how it blends with the clip beneath it in the timeline.

When you connect a title clip to an HDR video clip in the timeline, the superimposed text (and other title elements) in the viewer may seem dimmer than the video (because they were created in an SDR color space). You can increase the color intensity of title elements to HDR levels by adjusting the Graphics HDR Level slider.

1. Double-click a title clip in the Final Cut Pro timeline.
2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Video button at the top of the inspector.

Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. To exit text editing, press Command-Return.

5. In the Compositing section, do any of the following:
   - Change the title’s opacity: Drag the Opacity slider or use the value slider.
     Note: Some titles allow you to adjust the text opacity separately from the opacity of the rest of the title graphics. See Change a title's text style.

Note: You can also keyframe a title's opacity setting.

   - Change how the title blends with colors in the clip beneath it in the timeline: Click the Blend Mode pop-up menu, then choose an option (Darken or Multiply, for example).
     Note: The blend modes in Final Cut Pro for Mac are identical to those in Motion and in Final Cut Pro for iPad. For detailed information about blend modes, see the Motion User Guide.

6. If the title is in an HDR project, optionally change the title’s HDR intensity by clicking the Title button at the top of the inspector, then dragging the Graphics HDR Level slider.
Position and animate titles in Final Cut Pro for Mac

You can easily change the position and animation of titles.

Adjust a title’s position onscreen

1. Select a title clip in the Final Cut Pro timeline.
2. Move the playhead over the selected title clip.
3. Drag the text object to the new position.

Use the ruler to align paragraph text objects

Text created in Motion and some titles included with Final Cut Pro contain paragraph text. You can use a ruler and tabs to control the layout of paragraph text. See the Motion User Guide.

1. In Final Cut Pro, double-click a paragraph text object in the viewer.
2. In the viewer, click the Show Ruler button.

Note: The Show Ruler button appears only when you edit a paragraph text object.

A ruler appears above the paragraph text object in the viewer. Tabs in the ruler show how tabbed text will be aligned in the selected text.
3. Do any of the following:
   - **Add a tab**: Click in the ruler.
   - **Add a specific tab type when you click in the ruler**: Control-click in the ruler and choose a tab type.
     This also changes the type of tab added to the ruler when you click in it.
   - **Move a tab**: Drag it to another position on the ruler.
   - **Delete a tab**: Drag it out of the ruler.
   - **Change a tab to another tab type**: Control-click the tab and choose a tab type.

### Change the timing of an animated title

Many of the titles that come with Final Cut Pro include animations. Depending on the specific title, there are two main ways to adjust the speed of the animation.

In Final Cut Pro, do any of the following:

- **Change the duration of the clip**: The animation timing in some titles depends on the duration of the clip. For example, to slow down the Scrolling title, extend the duration of the title clip in the timeline.
- **Adjust the timing in Motion**: Open the Titles and Generators sidebar, select Titles in the sidebar, then Control-click a title in the browser and choose “Open a copy in Motion.”
  The title opens in Motion as a Motion project.
  For information about adjusting titles in Motion, see the [Motion User Guide](#).
Text inspector controls in Final Cut Pro for Mac

You can make common text adjustments using controls in the Text inspector.

To access these controls, select a title clip in the Final Cut Pro timeline, then open the Text inspector.

Preset pop-up menu

- **Preset**: An unlabeled pop-up menu at the top of the Text inspector, used to apply preset text styles to titles in the timeline. You can also use this pop-up menu to save text appearance and format settings. See Apply preset text styles.

Text editor

- **Text**: Many titles include a text field (the darker shaded area) to add and edit text in your title from the inspector.

Basic controls

- **Font**: A pop-up menu to choose a font for selected text.
- **Font Style**: An unlabeled pop-up menu (to the right of the Font pop-up menu) to choose a type style, such as Regular, Bold, Condensed, and so on. The available styles are specific to the font family selected in the Font pop-up menu.
- **Size**: A slider to set the point size of the text. The slider is constrained to a maximum of 288 points. To create larger text, drag to the right over the numeric value slider, or click the value, type a new number, and press Return.
- **Alignment**: Buttons to set the alignment and justification of text.
- **Vertical Alignment**: Buttons to set the vertical alignment of text.
- **Line Spacing**: A slider to set the distance between each line of text (leading) in point-size increments.

Tip: To modify the spacing for individual lines of text when hard returns are present, select text, then adjust the Line Spacing slider. Spacing is modified on the line that includes the selected text.
• **Tracking**: A slider to set the spacing between text characters; applies a uniform value between each character.

• **Kerning**: A slider to adjust spacing between text characters.

• **Baseline**: A slider to adjust the baseline of text characters: an invisible horizontal line defining the bottom alignment of characters.

• **All Caps**: A checkbox to make text characters uppercase.

• **All Caps Size**: A slider (available when the All Caps checkbox is selected) to set the size of uppercase characters based on a percentage of the font point size.

### Apply preset text styles in Final Cut Pro for Mac

Final Cut Pro comes with preset text styles (in 2D and 3D) that you can apply to text. A text style is a group of style settings. You can also create your own custom text styles and save them as presets. You apply preset text styles using the pop-up menu at the top of the Text inspector.

![Choose a preset text style from the pop-up menu.](image)

### Apply preset text styles to titles

1. In Final Cut Pro, do one of the following:
   - Double-click a title clip in the timeline.
     The title appears in the viewer, and the text in the first text object in the title clip is selected.
   - Select multiple title clips in the timeline.
     **Tip**: Use the timeline index to easily select multiple titles in your timeline. Click the Clips button at the top of the timeline index, then click the Titles button at the bottom. See View your project in the timeline index.

2. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Text button at the top of the inspector.

Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. Click the pop-up menu at the top of the Text inspector and choose 2D Styles or 3D Styles.

5. Choose a text style from the submenu that appears.

The text style is applied to the selected title clips.

**Save and apply custom text styles**

1. Double-click a title clip in the Final Cut Pro timeline.
   
   The title appears in the viewer, and the text in the first text object in the title clip is selected.

2. If the inspector isn't already shown, do one of the following:
   
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Text button at the top of the inspector.

Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. Make any custom changes to the font or style in the Text inspector. See [Change a title’s text style](#).

5. Click the pop-up menu at the top of the Text inspector and choose one of the following:
   - **Save Format Attributes**: Saves basic text attributes, including font, size, alignment, tracking, and line spacing.
   - **Save Appearance Attributes**: Saves effects such as text color, outline color, glow, drop shadow, and so on.
   - **Save All Format and Appearance Attributes**: Saves both format attributes and style attributes.

6. In the Save Preset to Library window, type a name for your new custom preset. The custom text style is saved and appears in alphabetical order in the pop-up menu at the top of the Text inspector.

7. To apply the new preset to another title, select the title in the timeline, then click the pop-up menu at the top of the Text inspector and choose the preset.

Organize your saved custom text styles

1. Quit Final Cut Pro.

2. In the Finder, hold down the Option key and choose Go > Library.

3. Navigate to `/Users/username/Library/Application Support/Motion/Library/Text Styles/`. The Text Styles folder contains the custom text styles you've created. Each text style has three files: a file with the extension .molo, a file with the extension .png that is the preview of the text style, and a file with ".menu" appended to the end of the style's name (also with a .png extension). The name of the text style appears in the preset menu with the style's attributes applied to the name.

4. Create one or more folders and drag the corresponding .molo files and .png files to those folders.
The next time you open Final Cut Pro, the folders appear as categories in the pop-up menu at the top of the Text inspector.

**Remove custom text styles**

1. Quit Final Cut Pro.
2. In the Finder, hold down the Option key and choose Go > Library.
3. Navigate to `/Users/username/Library/Application Support/Motion/Library/Text Styles/`. The Text Styles folder contains the custom text styles you've created. Each text style has three files: a file with the extension .molo, a file with the extension .png that is the preview of the text style, and a file with ".menu" appended to the end of the style's name (also with a .png extension). The name of the text style appears in the preset menu with the style's attributes applied to the name.
4. For each custom text style you want to remove, move the .molo file and the .png files to the Trash.
5. To reset Final Cut Pro settings, press Option-Command while opening Final Cut Pro. When Final Cut Pro opens, the custom text styles no longer appear in the pop-up menu at the top of the Text inspector.

**Modify Final Cut Pro for Mac titles in Motion**

Many of the titles included with Final Cut Pro were created using Motion, an Apple app designed to work with Final Cut Pro. You can open any of these titles in Motion, make modifications, and save the changes as a new title that you can access from the Titles and Generators sidebar.

**Important:** To modify a title in Motion, you must have Motion 5 installed on your computer.

1. To open the Titles and Generators sidebar, click the Titles and Generators button in the top-left corner of the Final Cut Pro window.

2. Do one of the following:
   - *Browse all titles:* Click Titles in the sidebar to display the titles in the browser.
   - *Browse a single category of titles:* Click a title category below Titles in the sidebar. To view the title categories, click the Titles disclosure triangle.

3. In the browser, Control-click the title you want to modify and choose "Open a copy in Motion."
   Motion opens, and the title's project appears.
4. Modify the title’s project.

See the Motion User Guide.

5. Choose File > Save As (or press Shift-Command-S), enter a name for the new title (referred to as a Template in Motion), assign it to a category (or create a new category), choose a theme (if needed), and click Publish.

If you choose File > Save, the effect is saved using the same name, with "copy" appended to its end.

Note: If you have created or customized any Final Cut Pro effects, transitions, titles, or generators in Motion, set the storage location for your Motion content to In Library before starting any copy or move operations between libraries or storage devices. Otherwise, the Motion content is not included in those operations. See Manage Motion content. Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.

Find and replace text in Final Cut Pro for Mac

If your project contains multiple instances of a particular word or phrase displayed in multiple title clips, such as names, company names, or job titles, you can find the specific word or phrase and quickly change each instance of it.

1. If you want to find and replace text in a selection, select a title clip in the Final Cut Pro timeline.

2. Choose Edit > Find and Replace Title Text.

3. In the window that appears, type the text you want to search for in the Find field.

4. In the Replace field, type the text you want to replace the text you’re looking for.

5. To choose where to search, do one of the following:
   - **Search for text in the selected title clip:** Click the “Search in” pop-up menu and choose Selected Title.
     This option is useful for searching in title clips that have a lot of text, such as credits.
     Note: If more than one title clip is selected, only the clip closest to the beginning of the timeline is searched. If selected clips are stacked vertically, the clip closest to the primary storyline is searched.
   - **Search for text across all the title clips in your project:** Click the “Search in” pop-up menu and choose All Titles In Project.
6. Do any of the following:
   • Match how letters are capitalized in your search text: Select the “Match case” checkbox.
   • Locate whole words rather than a group of letters within words: Select the “Whole words” checkbox.
   • Have the search start over from the beginning of the searched item after reaching the end: Select the “Loop search” checkbox.

7. Do one of the following:
   • Replace all instances of the text at once: Click the Replace All button.
   • Replace this single instance of the text only: Click the Replace button.
   • Replace this instance of the text and locate the next place the text appears: Click the Replace & Find button.
   • Cycle forward and backward through each instance of the text you’re looking for: Click the Previous and Next buttons.

To undo an operation performed in the Find and Replace window, click in the viewer to make it active, then choose Edit > Undo Text Replace (or press Command-Z).

Add and adjust 3D titles

Intro to 3D titles in Final Cut Pro for Mac

In addition to creating basic two-dimensional text, you can create text that appears to have depth—complete with sides, edges, and backs. 3D text in Final Cut Pro exhibits the same characteristics as real three-dimensional objects, simulating natural lighting, shading, and textures.

You can easily convert back and forth between 2D text and 3D text. When you reenable 3D text after switching to 2D text, the previous 3D settings are restored. See Convert text to 3D text. For information about creating basic 2D text, see Add titles.

As you can with 2D text, you can animate your 3D titles in Final Cut Pro. See Intro to video keyframing.
3D titles workflow in Final Cut Pro for Mac

Although 3D titles can be customized in unlimited ways, you can create impressive-looking 3D text in just a few steps with Final Cut Pro.

Step 1: Create a 3D title

In Final Cut Pro, you can either add a 3D title from the Titles and Generators sidebar or convert an existing 2D title to 3D. Either way, you’ll wind up with a 3D title that has basic settings.

Step 2: Apply a preset style

If you want to take advantage of the ready-made 3D text styles that come with Final Cut Pro, you can select the title and choose a preset 3D style in the Text inspector. This applies a combination of settings, including the font, weight, depth, and appearance. Each of these attributes can be further customized, but the preset styles are a great way to get started.
Step 3: Adjust 3D text settings

You can customize your 3D title by adjusting basic text settings (including font, size, tracking, line spacing, and capitalization). You can also modify 3D-specific text attributes such as depth, text weight, edge style, and corner style. All of these attributes can be modified in the Text inspector.

To get a good look at all sides of your title, you can use onscreen controls to rotate the title or move it in 3D space.
Step 4: Modify the materials

You can define the surface appearance of the 3D title by applying preset materials or by creating custom materials. Materials include substances (such as metal or plastic), paint layers, distress layers, and more. Each layer has many attributes, allowing you to create limitless variations in appearance. You can also apply different materials to different facets of 3D titles (front, back, side, and edges).

To learn more about materials, see Intro to materials.

Step 5: Add a lighting style

Another way to customize the appearance of your 3D title is to add a lighting style. You can choose from preset lighting styles in the Lighting section of the Text inspector.

You can customize the lighting in a variety of ways, but presets are a great way to quickly create a unique and realistic look.
Step 6: Integrate the text with your composition

Finally, you can combine your 3D title with backgrounds or other elements to create an organic, integrated scene. You can also apply glow or drop shadow effects in this final step.

Add 3D titles to a project

Add 3D titles in Final Cut Pro for Mac

Add a 3D title the same way you would add a 2D text title. For details (including alternative ways to add titles), see Add titles.

1. In the Final Cut Pro timeline, position the playhead where you want to add the title.
2. Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.
3. Select a 3D titles category in the Titles and Generators sidebar.
   The titles in that category appear in the browser.
4. Do any of the following:

- **Add a 3D title to a project clip:** Double-click the title in the browser.
  The title clip is connected to the clip in the primary storyline at the position of the playhead and appears superimposed over that clip. If the playhead isn’t over a clip, the title is superimposed over the default background.

- **Add a title between clips in the timeline:** Drag the title from the browser to the edit point between the clips where you want the title clip to appear.

- **Replace an existing timeline clip with a 3D title:** Drag a title from the browser to the clip in the timeline that you want to replace, then choose Replace.

The title appears in your project, showing the front of the text. For information on how to manipulate and examine all facets of your 3D titles, see [Rotate titles in 3D space](#) and [Move titles in 3D space](#).

![Image of 3D title](image)

*Note:* Some 3D titles come with their own built-in backgrounds. You can disable (or enable) the built-in background in the Title inspector.

**Convert text to 3D text in Final Cut Pro for Mac**

Any title can be converted back and forth between 2D and 3D. Converting a 2D text title to 3D (a process called *extruding*) replaces the Face and Outline settings with settings and parameters designed to simulate realistic three-dimensional objects.

Converting a 3D title to 2D text disables those settings and instead enables the Face and Outline settings.

**Convert 2D text to 3D**

1. Double-click a 2D title clip in the Final Cut Pro timeline.
   The title appears in the viewer, and the text in the first text object in the title clip is selected. To modify a different text object in the same title, select it in the viewer.

2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Text button at the top of the inspector.

Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. In the Text inspector, click the 3D Text checkbox so that it turns blue.
   The Face and Outline sections of the inspector are replaced by the Lighting and Material sections.

Convert 3D text to 2D
1. Double-click a 3D title clip in the Final Cut Pro timeline.
   The title appears in the viewer, and the text in the first text object in the title clip is selected. To modify a different text object in the same title, select it in the viewer.

2. If the inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. In the Text inspector, click the blue 3D Text checkbox to deselect it.
   The Lighting and Material sections of the inspector are replaced by the Face and Outline sections.
Rotate and move 3D titles

Rotate titles in 3D space in Final Cut Pro for Mac

When you add a 3D title to a project, you see a bit of the extruded sides in addition to the front of the text.

But 3D text actually has multiple facets (the front, sides, edges, and back), even though you can't see them by default. You can view these other facets by rotating the text object using the onscreen controls.

1. In Final Cut Pro, add a 3D title to your project and select it in the timeline.
2. Position the playhead in the timeline so that your 3D title appears in the viewer.
3. In the viewer, click the 3D title once.

   The onscreen controls for the 3D title appear in the viewer, with X, Y, and Z rotation handles.

   Note: Make sure to click the 3D title in the viewer only once. If you double-click the 3D title, the 3D onscreen controls do not appear. (Double-clicking selects the text for editing and formatting.)
4. Move the pointer over one of the rotation handles until a rotation ring appears, then
drag the ring.
   • The red ring rotates the object around its X axis.
   • The green ring rotates the object around its Y axis.
   • The blue ring rotates the object around its Z axis.
   As you drag, the active ring is highlighted, and the status bar above the viewer
displays the absolute rotation values as well as the amount of rotation change
(delta).

For more information about the three axes of the 3D coordinate system in Final Cut Pro,
see Move titles in 3D space.

Note: You can modify the appearance of each facet individually, and control the bevel and
style of the edges between facets. See Intro to materials and Modify depth and edges.

**Move titles in 3D space in Final Cut Pro for Mac**

Final Cut Pro uses a 3D coordinate system to precisely control the look of your 3D titles.
This system specifies the center of the viewer as 0, 0, 0. Moving a text object to the left
subtracts from the X value, moving to the right adds to the X value, and so on.

One of the main differences between 2D text and 3D text is that with 3D text you can
change your point of view, so that moving an object up doesn't always mean increasing its
Y position value.
1. In Final Cut Pro, **add a 3D title** to your project and select it in the timeline.

2. Position the playhead in the timeline so that your 3D title appears in the viewer.

3. In the viewer, click the 3D title once.
   
   The onscreen controls for the 3D title appear in the viewer, with position handles for the X, Y, and Z axes.

4. Do any of the following:
   
   - *Move the object horizontally along its X axis:* Drag the red arrow.
   - *Move the object vertically along its Y axis:* Drag the green arrow.
   - *Move the object forward or backward along its Z axis:* Drag the blue arrow.

   As you drag, the active arrow turns yellow, and the status bar above the viewer displays the current coordinates of the object as well as the distance the object has moved (the delta). Coordinates are given in the form of X, Y, and Z.
Modify basic 3D text attributes

Adjust basic 3D text settings in Final Cut Pro for Mac

In many ways, 3D text is just like 2D text, and you can modify most of the text attributes (including font, size, tracking, line spacing, and capitalization) exactly the same way you modify those attributes for 2D text.

Note: To modify the depth, texture, and lighting attributes of 3D text, use the controls in the 3D Text section of the Text inspector. See Modify depth and edges, Intro to materials, and Intro to 3D text lighting.

1. Double-click a 3D title clip in the Final Cut Pro timeline.
   The title appears in the viewer, and the text in the first text object in the title clip is selected. To modify a different text object in the same title, select it in the viewer.

2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

   ✽ Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. Adjust the basic text settings as needed.
   For a list of available controls, see Text inspector controls.
   For basic instructions on working with 2D or 3D titles, see Adjust titles.

   Note: To reveal the controls in each of the sections, you may need to scroll down in the Text inspector and double-click each section name.
Modify 3D text depth and edges in Final Cut Pro for Mac

One of the most obvious differences between 2D text and 3D text is that 3D text has depth.

This attribute, as well as a number of other basic aspects of a 3D title’s appearance (such as text weight, edge style, and corner style), can be set in the 3D Text section of the Text inspector.

Adjust 3D text depth

1. Select a 3D title in the Final Cut Pro timeline.
2. In the 3D Text section of the Text inspector, drag the Depth slider to the left to decrease depth, or to the right to increase depth.

⚠️ Tip: To create different letters at different depths, select the letters in the Text field at the top of the Text inspector. The 3D Text controls then affect only the selected letters. For more information about working with individual letters, see Text inspector controls.
Change text depth direction

3D text depth can be set to extrude in different directions: forward, backward, or centered on the original text plane.

1. Select a 3D title in the Final Cut Pro timeline.
2. In the 3D Text section of the Text inspector, click the Depth Direction pop-up menu and choose one of the following settings:
   - **Backward**: The text object is extruded backward from the plane where the text was initially added.
   - **Forward**: The text object is extruded forward from the plane where the text was initially added.
   - **Centered**: The text object is extruded equally both forward and backward from the plane where the text was initially added.

Change text weight

You can adjust 3D text to appear thicker or thinner. Whereas increasing the Size value makes text larger by substituting a larger version of the font, increasing the Weight value uniformly thickens all the lines and serifs that make up the letters in the text object.

1. Select a 3D title in the Final Cut Pro timeline.
2. In the 3D Text section of the Text inspector, drag the Weight slider to the left to make the text appear thinner, or to the right to make it appear thicker.
Set the style of 3D text edges

The places where the different facets of a 3D title meet are called edges. You can add bevels, ridges, rings, and other shapes to customize the appearance of these edges.

You can set the back edge (between the back of the text and its sides) to be identical to the front edge (between the front and the sides), or you can set each to a different edge shape.

1. Select a 3D title in the Final Cut Pro timeline.
2. In the 3D Text section of the Text inspector, click the Front Edge pop-up menu and choose an edge style.

3. Click the Back Edge pop-up menu and choose an edge style.
   
   If you choose Same As Front, the style you chose in step 2 is applied to the back edge of the 3D title.
Adjust the size of text edges

If you change the style of the front edge or back edge of a 3D title to anything other than square, you can also adjust the size of that edge. If the back edge is set to something other than Same As Front (or Square), you can adjust the size of the back edge independently from that of the front.

1. Select a 3D title in the Final Cut Pro timeline.
2. In the 3D Text section of the Text inspector, click the Front Edge pop-up menu and choose a setting other than Square.
   The Front Edge Size slider appears.
3. Drag the Front Edge Size slider to the left to make the edge smaller, or to the right to make the edge larger.
   To modify the width and depth of the edges independently, click the disclosure triangle to the left of the Front Edge Size slider, then drag the Width or Depth slider.
4. Click the Back Edge pop-up menu and choose a setting other than Same As Front or Square.
   The Back Edge Size slider appears.
5. Drag the Back Edge Size slider to the left to make the edge smaller, or to the right to make the edge larger.
   Note: You can’t see the back edge of the text object unless you rotate the title. See Rotate titles in 3D space.

Set the style of text inside corners

When the front edge or back edge of a 3D title is set to anything other than Square, you can customize text with inside corners (for example, the angles in the letter E).

1. Select a 3D title in the Final Cut Pro timeline.
2. In the 3D Text section of the Text inspector, click the Inside Corners pop-up menu and choose one of the following options:
   - *Straight*: Sets all corners to sharp angles.
   - *Round*: Softens the sharpness of corners by adding a round curve to each sharp angle.
   - *Miter*: Smoothes the sharpness of corners in a more subtle way, by adding an additional angle known as a *miter*.
3D Text controls in Final Cut Pro for Mac

In Final Cut Pro, adjust depth, weight, and edge attributes using the controls in the 3D Text section of the Text inspector.

To access these controls, select a 3D title clip in the timeline and choose Window > Show in Workspace > Inspector (or press Command-4).

- **3D Text**: A checkbox that, when selected, applies 3D attributes to selected text in your project and enables 3D controls. Deselecting this checkbox converts selected 3D text to 2D text and disables 3D controls.

  When this checkbox is selected, the following controls become available for adjustment:

  - **Depth**: A slider that sets the thickness of selected 3D text.
  - **Depth Direction**: A pop-up menu that sets whether selected 3D text is extruded backward, forward, or equally from front to back.
  - **Weight**: A slider that makes selected 3D text appear heavier or lighter.
  - **Front Edge**: A pop-up menu that sets the style of the front edge of selected 3D text.
  - **Front Edge Size**: A slider that adjusts the width and depth of the chosen edge style. Click the disclosure triangle to reveal separate Width and Depth sliders.
  - **Back Edge**: A pop-up menu that sets the style of the back edge of selected 3D text.
  - **Inside Corners**: A pop-up menu that sets the style of the inner corners of characters (such as angles in the letter **E**) in selected 3D text.
Modify surface appearance

Intro to 3D text materials in Final Cut Pro for Mac

3D titles in Final Cut Pro have properties designed to give them a natural and realistic appearance. They respond to lighting conditions and exhibit shading, reflectivity, and other attributes of real-world objects.

![3D text example]

Attributes that define an object’s surface appearance are called *materials*. After you create a 3D title, you can apply a preset material or create a custom material composed of one or more material layers—image overlays that combine to create a naturalistic 3D texture.
Think of material layers as the building blocks for creating an object in real life. For example, you might begin creating an object by deciding what substance it should be made of—wood, plastic, metal, and so on. Depending on what that basic substance is, the object will have some fundamental properties, such as color, texture, and reflectivity. Next, you apply paint or another finish to the object to change its color, sheen, and reflectivity. In Final Cut Pro, you can even apply a “distress” layer to add a bit of texture, aging, or other elements to make the object feel more organic and realistic.

Each material layer type has a variety of controls and settings to customize the specific look and feel of the material.

You can apply multiple material layers of differing types to compound their effects, and you can rearrange the order in which material layers are applied to create varied effects. You can also apply different materials to specific facets of a 3D title.
Add preset materials to 3D text in Final Cut Pro for Mac

The quickest way to give your 3D title a naturalistic texture is to apply one of the preset materials built into Final Cut Pro.

Below are some examples of the many preset 3D materials available in Final Cut Pro:

1. Add a 3D title to your Final Cut Pro project.
2. Double-click the 3D title clip in the timeline.
   
   The title appears in the viewer, and the text in the first text object in the title clip is selected. To modify a different text object in the same title, select it in the viewer.

3. If the inspector isn't already shown, do one of the following:
   
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   
   • Click the Inspector button on the right side of the toolbar.

4. Click the Text button at the top of the inspector.

Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.
5. In the Material section of the 3D Text section, click the preview thumbnail.

A pop-up menu showing the material presets categories appears.

6. Click the pop-up menu and choose a material category, then click the submenu and choose a preset.

The preset 3D material is applied to the text object.

You can modify any of the preset materials or add new material layers to create custom textures. See Modify materials and Work with material layers.

Modify 3D text materials in Final Cut Pro for Mac

When you add a new 3D title, it appears with a default 3D material preset applied: a matte white plastic texture (Basic). Most of the other preset materials in Final Cut Pro are more complex, composed of multiple material layers—combinations of substance, paint, finish, and distress overlays that create a naturalistic 3D texture. For example, the Brushed Metal preset combines an Aluminum substance layer with a Brushed finish layer. The Golf Ball preset combines a Plastic substance layer with a Polish finish layer, a Dirt distress layer, and a Bumps distress layer (set to –500% to create a dimple effect).

You adjust each of these material layers in the Material section of the Text inspector. As you modify these settings, your 3D title is updated instantly in the viewer, allowing you to fine-tune the look you want to achieve.
Modify material layers used in a 3D texture

You can create a custom material by applying a preset material and then modifying it.

This example shows how to modify the Substance layer of a simple 3D texture.

1. In the Final Cut Pro timeline, select a 3D title and apply a preset material to it.
   See Add preset materials.

   The preview thumbnail of the preset you applied appears in the Text inspector, in the Material section of the 3D Text section.

   ![Image showing material settings]

   The Basic material preset has a single material layer, Substance, which is set to Plastic.

   The material layers included in the preset appear below the preview thumbnail. For example, the Basic material preset has a single material layer, Substance, which is set to Plastic. Additional Substance settings specify the type of plastic (Shiny) as well as the color (White).

2. Click the Substance pop-up menu and choose a substance category.

   ![Image showing substance category options]

   Depending on the option you choose, additional controls may appear.

3. Click the Type pop-up menu (below the Substance pop-up menu) and choose a substance belonging to the category you chose above.

   Depending on the option you choose, additional controls may appear.

4. Adjust other available Substance settings, such as Color, Brightness, Roughness, and so on.

   As you make adjustments, the preview thumbnail is updated in the Material section, and the 3D title is updated in the viewer.

For more information about material layer controls, see Intro to Material controls.
**Rename a modified material**

When you modify material layers, the preview thumbnail in the Text inspector is updated to show the new texture. However, the preset name under the preview thumbnail remains the same ("Basic" for titles added from the 3D category). You can rename the material to better describe the modified material.

1. In the Final Cut Pro timeline, select a 3D title with a modified preset material.
2. In the Material section of the 3D Text section of the Text inspector, double-click the name of the material (beneath the preview thumbnail).

   The material is renamed for the selected 3D title. Other instances of the preset are not affected.
3. Type a new name, and press Return.

**Restore a preset material's original settings**

1. In the Final Cut Pro timeline, select a 3D title with a modified preset material.
2. In the Material section of the 3D Text section of the Text inspector, click the preview thumbnail and choose a preset from the pop-up menu.

   The original settings stored in the preset are applied to the selected facet. Other customized instances of the preset are not affected.

You can also save any changes you've made as a new custom material to be shared or reused. See Save modified materials.

**Work with 3D text material layers in Final Cut Pro for Mac**

You can add multiple material layers to create more complicated textures for your 3D titles. For example, if you combine an Aluminum substance layer with a Grey Granite substance layer, your 3D text takes on a metallic ore finish that may or may not exist in nature. Likewise, you can add paint layers, finish layers, distress layers, and emit layers to create highly realistic (or highly fanciful) textures that show signs of aging, dirtiness, radiance, and other real-world qualities.

The order in which material layers are applied affects the appearance of the object. For example, you might add a wood surface layer, a paint layer, and various distress layers to create a material that looks like painted wood that is aged and worn. Each layer affects the layers stacked beneath it in the Text inspector, and rearranging the layers creates different results.

You can also remove, rearrange, or temporarily disable material layers.
Add a material layer to a 3D texture

1. Select a 3D title in the Final Cut Pro timeline.

2. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

   Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. In the Material section of the 3D Text section, click the Add Layer pop-up menu, then choose a new material layer type (Substance, Paint, Finish, Distress, or Emit) and subtype.

   The new material layer and its adjustable controls appear in the Material section.

5. To add another material layer, repeat step 4.

6. Adjust the material layer controls in the Material section to achieve the look you want.

   For more information about material layer controls, see Intro to Material controls.
Enable or disable material layers

You can temporarily turn off or turn on any material layer to see how it's affecting the overall texture.

- In the Material section of the 3D Text section of the Final Cut Pro Text inspector, click the checkbox to the left of the material layer type (Substance, Paint, Distress, and so on).

When the checkbox is highlighted blue, the effect of the material layer is visible in the viewer. When the checkbox is not highlighted, the effect is turned off.

Rearrange the stacking order of material layers

The stacking order of material layers in the Material section of the Text inspector affects a 3D texture's appearance in the viewer. You can rearrange the stacking order to create different looks.

- In the Material section of the 3D Text section of the Final Cut Pro Text inspector, drag a material layer name (Substance, Paint, Distress, and so on) to a new position in the stack.

Remove a material layer

- In the Material section of the 3D Text section of the Final Cut Pro Text inspector, click a material layer name (Substance, Paint, Distress, and so on), then press Delete.

⚠️ Tip: To select and modify multiple material layers at once (for example, to delete or rearrange all the layers), Shift-click or Command-click the layers.
Add a light-emitting material to 3D text in Final Cut Pro for Mac

The Emit material layer type causes the selected 3D text layer to appear to be self-illuminating rather than just reflecting other light. The light emitted using this method does not illuminate other objects or cause shadows to be cast.

In fact, the Emit layer is a texture with a single color or gradient, which is superimposed on top of the 3D title. This makes the image appear brighter. Depending on which type of fill you choose, a different set of options appears.

1. Select a 3D title in the Final Cut Pro timeline.
2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

   Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. In the Material section of the 3D Text section, click the Add Layer pop-up menu and choose Emit.

   An Emit section is added to the Text inspector.

5. Click the Fill pop-up menu and choose a fill type (Color or Gradient).

   The fill type determines what additional parameters appear in the Emit section of the Text inspector. For a description of all Emit parameters, see Emit controls.
Save modified 3D text materials in Final Cut Pro for Mac

After you create your own materials, you can save those textures as custom presets. Saving a modified material as a custom preset includes all material layers shown in the Text inspector at the time of saving (including disabled material layers).

1. In the Material section of the 3D Text section of the Final Cut Pro Text inspector, click the preview thumbnail and choose Save Material from the pop-up menu.

2. In the Save Preset window, type a descriptive name for the preset, then click Save.

   The currently selected material is saved as a preset. Saved preset materials appear in alphabetical order at the bottom of the material presets pop-up menu. You can apply the preset as you would any other material preset.

   Note: You can organize saved custom preset materials using Motion, an Apple app designed to work with Final Cut Pro. See the information about organizing saved custom preset materials in the Motion User Guide.
Add materials to 3D text facets in Final Cut Pro for Mac

By default, applying a material to a 3D title causes all facets of the text to display the same material. But a 3D title can also display different materials on its different facets. For example, you can apply car paint to the front facet and a shiny metal appearance to the side facet. You can even apply a different material to the edges—facets that join a title's front (or back) with its sides.

If the same material is applied to more than one facet, you can modify the facets' settings simultaneously to ensure that the settings remain consistent. You can also link facets together so that they remain identical.

Apply a material to a specific facet of 3D text

1. Select a 3D title in the Final Cut Pro timeline.
2. If the inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Text button at the top of the inspector.

 Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.
4. In the Material section of the 3D Text section, click the Material pop-up menu and choose Multiple.

Five preview thumbnails appear, representing the five facets of 3D text: Front, Front Edge, Side, Back Edge, and Back.

5. Do any of the following:
   - Apply a preset material to a facet: Click the preview thumbnail for the facet, then choose a new preset material from the pop-up menu.
   - Apply a custom material to a facet: Click the name of the facet to show its material layers, then adjust those material layers or add new ones.

See Modify materials.

The facet is updated to display the new material—both in your 3D title in the viewer and in the preview thumbnail in the Material section of the Text inspector.

Apply a material to multiple facets simultaneously

1. Select a 3D title in the Final Cut Pro timeline.

2. In the Material section of the 3D Text section of the Text inspector, click the Material pop-up menu and choose Multiple.

Five preview thumbnails appear, representing the five facets of 3D text: Front, Front Edge, Side, Back Edge, and Back.

3. Do one of the following:
   - Click the broken link icon for each facet you want to modify.
   - Shift-click the names of the facets you want to modify.

The selected facets are highlighted in blue.
4. Click the preview thumbnail for any of the highlighted facets, then choose a new preset material from the pop-up menu.

The facets are updated to display the new material—both in your 3D title in the viewer and in the preview thumbnails in the inspector. The facets are also automatically linked together so that further changes to any of them affect all of them.

---

**Link facets together**

You can link two or more facets together so that changes made to one of them are automatically applied to the others.

1. Select a 3D title in the Final Cut Pro timeline.
2. In the Material section of the 3D Text section of the Text inspector, click the Material pop-up menu and choose Multiple.
3. Shift-click the names of two or more facets you want to link.
4. Click the broken link icon on one of the selected facets.

The selected facets are linked and display blue active link icons.

5. To add another facet to the group, click its broken link icon.

The additional facet is linked to the group. Now when you select any facet in the linked group, all linked facets are highlighted. Changes made to any of the highlighted facets are automatically made to all other facets in the linked group.

To remove a facet from a linked group, click the link icon for the facet you want to unlink. The facet is deselected and removed from the group.
Revert from multiple facets to a single facet

1. In the Final Cut Pro timeline, select a 3D title set to multiple facets.
   See Apply a material to multiple facets simultaneously.

2. In the Material section of the 3D Text section of the Text inspector, click the Material pop-up menu and choose Single.
   The five preview thumbnails are replaced by a single preview thumbnail, and all facets revert to the material that was applied to the selected facet. Any modifications you made to materials on other facets are permanently discarded.

Material controls

Intro to Material controls in Final Cut Pro for Mac

The preset or custom materials you apply to 3D text are made up of one or more material layers—Substance, Paint, Finish, Distress, and so on—that combine to create a complex texture. When you select a 3D title, its material layers appear in the Material section of the 3D Text section of the Text inspector, stacked under the Material preview thumbnail.

You can adjust the parameter controls in each of these material layers to modify the texture applied to your 3D title. For a complete list of controls in each type of material layer, see the following topics:

- Substance controls
- Paint controls
- Finish controls
- Distress controls
- Emit controls
- Placement controls
Substance controls in Final Cut Pro for Mac

Use the Substance controls, in the Material section of the 3D Text section of the Text inspector, to modify the basic surface texture of 3D text. Depending on the option you choose in the Substance pop-up menu, different parameter controls become available.

- **Substance**: A pop-up menu to set a substance type: Concrete, Fabric, Metal, Plastic, Stone, Wood, Flat, or Generic.

![Substance Controls](image)

**When Substance is set to Concrete**

- **Type**: A pop-up menu to choose a style of concrete (Aged, Smooth, and so on).
- **Depth**: A slider to adjust the depth of surface irregularities in the concrete substance.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the concrete pattern is applied to the text object. See Placement controls.

**When Substance is set to Fabric**

- **Type**: A pop-up menu to choose a style of fabric (Denim, Leather, Wool, and so on).
- **Roughness**: A slider to adjust how raised and uneven the fabric pattern appears.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the fabric pattern is applied to the text object. See Placement controls.
When Substance is set to Metal

- **Type:** A pop-up menu to choose a style of metal (Brass, Gold, Steel, and so on). There is also a Custom option that allows you to use a custom gradient for the metal's reflection. See Intro to the gradient editor.
- **Shininess:** A slider to adjust how reflective the surface appears.
- **Thickness:** A slider to adjust the apparent thickness of the metal surface when it's applied on top of another substance layer. You can control this effect more precisely by clicking the disclosure triangle and adjusting the Base and Highlight sliders.

When Substance is set to Plastic

- **Type:** A pop-up menu to choose any of three plastic styles: Shiny, Matte, or Textured.
- **Color Type:** A pop-up menu to choose whether the plastic surface is a solid color or a gradient.
- **Color:** A color control (available when Color Type is set to Color) to set the color of the plastic.
- **Gradient:** A gradient control (available when Color Type is set to Gradient) to determine how the gradient is applied to the text object.
- **Texture Depth:** A slider (available when Type is set to Textured) to adjust how visible the texture appears on the object.
- **Placement:** A group of controls (available when Type is set to Textured) to determine how the texture is applied to the text object. See Placement controls.
When Substance is set to Stone

- **Type:** A pop-up menu to choose a style of stone (Limestone, Granite, Slate, and so on).
- **Depth:** A slider to adjust the depth of surface irregularities in the stone substance.
- **Placement:** A group of controls (available when you click the disclosure triangle) to set how the stone pattern is applied to the text object. See Placement controls.

When Substance is set to Wood

- **Type:** A pop-up menu to choose a style of wood (Ash, Bamboo, Walnut, and so on).
- **Grain Depth:** A slider to adjust the depth of grain in the wood substance.
- **Placement:** A group of controls (available when you click the disclosure triangle) to set how the wood pattern is applied to the text object. See Placement controls.

When Substance is set to Flat

Use the Flat substance type to create an object that has depth but is unaffected by light or shadows. Flat creates a “2.5-dimensional” look popular in graffiti and pop-art styles.

- **Surface:** A pop-up menu to choose whether the surface displays a color or a gradient.
- **Color:** A color control (available when Surface is set to Color) to set the color of the text.
- **Gradient:** A gradient control (available when Surface is set to Gradient) to create a custom gradient. See Intro to the gradient editor.
- **Intensity:** A slider to adjust the vibrancy of the chosen Surface option (Color or Gradient).
- **Opacity:** A slider to adjust the transparency of the chosen Surface option (Color or Gradient). Drag to the left to make the surface appear more transparent, or drag to the right to make the surface appear more opaque.
• **Enable Edge**: A group of controls (available when you click the disclosure triangle) that creates a dynamic effect for how edges are rendered based on the relative position of the camera. As the text changes position (relative to the camera), the shading changes. You can enable or disable these controls by selecting or deselecting the checkbox to the left of the Enable Edge disclosure triangle.

• **Edge Amount**: A slider to adjust how visible the edges of the selected substance layer appear.

• **Invert**: A checkbox that, when selected, inverts the visible area of the edges for the selected substance layer.

• **Blend Mode**: A pop-up menu to control how flat substance layers interact with layers below them. Choose one of the following methods:
  - **Normal**: The visible areas of the topmost substance layer obscure the edges of the layers below.
  - **Multiply**: The visible areas of the substance layers are multiplied together so that the darker areas of each layer appear on the edges of the text object.
  - **Add**: The visible areas of the layers are added together so that the lighter areas of each layer appear on the edges of the text object.

**When Substance is set to Generic**

The Generic substance type is used by some of the preset materials available in Final Cut Pro. When Substance is set to Generic, a neutral surface is generated, to which a solid color or gradient can be applied. This substance type is usually used in conjunction with the Custom Specular or Custom Bump finish layer to create unique looks.

- **Surface**: A pop-up menu to choose whether the surface displays a color or a gradient.
- **Color**: A color control available when Surface is set to Color.
- **Gradient**: A gradient control (available when Surface is set to Gradient) to create a custom gradient. See *[Intro to the gradient editor]*.
- **Brightness**: A slider to adjust how much light is reflected by the surface of the text object.

You can control this effect more precisely by clicking the disclosure triangle and adjusting the following controls:

- **Lights**: A slider to adjust how much light from light sources reflects off the surface of the text object.
- **Environment**: A slider to adjust how much environmental light reflects off the surface of the text object. See *[Change the lighting environment]*.
- **Opacity**: A slider to adjust the transparency of the substance layer. Drag to the left to make the substance more transparent, or drag to the right to make it more opaque.
Paint controls in Final Cut Pro for Mac

Use the Paint controls, in the Material section of the 3D Text section of the Text inspector, to create the effect of a coat of paint added to the surface of the 3D title. Depending on the option you choose in the Paint pop-up menu, different parameter controls become available.

- **Paint**: A pop-up menu to set a paint type: Smooth Paint, Textured Paint, Watercolor, or Reflective Paint.

![Paint controls](image)

**When Paint is set to Smooth Paint**

- **Color Type**: A pop-up menu to choose whether the paint is a solid color or a gradient.
- **Paint Color**: A color control (available when Color Type is set to Color) to set the color of the paint.
- **Paint Gradient**: A gradient control (available when Color Type is set to Gradient) to create a custom gradient. See Intro to the gradient editor.
- **Sheen**: A slider to adjust the apparent shininess of the paint surface.
- **Opacity**: A slider to adjust the transparency of the paint. Drag to the left to make the paint more transparent, or drag to the right to make it more opaque.

**When Paint is set to Textured Paint**

- **Color Type**: A pop-up menu to choose whether the paint is a solid color or a gradient.
- **Paint Color**: A color control (available when Color Type is set to Color) to set the color of the paint.
- **Paint Gradient**: A gradient control (available when Color Type is set to Gradient) to create a custom gradient. See Intro to the gradient editor.
- **Sheen**: A slider to adjust the apparent shininess of the paint surface.
- **Surface Texture**: A pop-up menu to choose a texture to apply.
- **Texture Depth**: A slider to adjust the visibility of the texture on the surface of the 3D title.
- **Opacity**: A slider to adjust the transparency of the paint. Drag to the left to make the paint more transparent, or drag to the right to make it more opaque.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the paint texture is applied to the text object. See Placement controls.
When Paint is set to Watercolor

- **Paint Color**: A control to set the color of the paint.
- **Sheen**: A slider to adjust the apparent shininess of the paint surface.
- **Opacity**: A slider to adjust the visibility of the paint. Drag to the left to make the paint more transparent, or drag to the right to make it more opaque.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the watercolor pattern is applied to the text object. See Placement controls.

When Paint is set to Reflective Paint

- **Paint Job**: A pop-up menu to choose the type of reflective paint (Velvet, Pearl, Electric, and so on).
- **Paint Color**: A control to set the color of the reflective paint.
- **Second Color**: A color control to set a second paint color (available for some Paint Job types).
- **Sheen**: A slider to adjust the apparent shininess of the paint surface.
- **Opacity**: A slider to adjust the transparency of the paint. Drag to the left to make the paint more transparent, or drag to the right to make it more opaque.
- **Diffuse Brightness**: A slider (available when Paint Job is set to Custom) to set the amount of color reflected by the text object.
- **Specular Brightness**: A slider (available when Paint Job is set to Custom) to set the amount of light reflected by the text object.
- **Shininess**: A slider (available when Paint Job is set to Custom) to set how mirror-like the surface appears.
- **Face Opacity**: A slider (available when Paint Job is set to Custom) to set how transparent the paint effect is on surfaces that are more perpendicular to the camera.
- **Edge Opacity**: A slider (available when Paint Job is set to Custom) to set how transparent the paint effect appears on surfaces that are more parallel to the camera.
- **Fresnel**: A slider (available when Paint Job is set to Custom) to set how much the viewing angle affects the reflectivity of the object. A high Fresnel value means that there’s a strong change in reflectivity as the viewing angle changes; a low Fresnel value means that the reflectivity remains relatively consistent regardless of viewing angle.
Finish controls in Final Cut Pro for Mac

Use the Finish controls, in the Material section of the 3D Text section of the Text inspector, to create the effect of a layer of finish (such as polish, enamel, and so on) added to the surface of the 3D title. Depending on the option you choose in the Finish pop-up menu, different parameter controls become available.

- **Finish**: A pop-up menu to choose a finish type: Polish, Enamel, Brushed, Textured, or Custom Specular.

![Finish Controls](image)

**When Finish is set to Polish**

- **Reflectivity**: A slider to adjust the brightness of reflections that appear in the surface of the object. This value can be set above 100% to create a high dynamic range (HDR) type effect.
- **Glossiness**: A slider to adjust how dull or sharp reflections are. A setting of zero creates a blurry reflection, and a setting of 100 creates a sharp, mirror-like reflection.

**When Finish is set to Enamel**

- **Reflectivity**: A slider to adjust the brightness of reflections that appear in the surface of the object. This value can be set above 100% to create a high dynamic range (HDR) type effect.
- **Glossiness**: A slider to adjust how dull or sharp reflections are. A setting of zero creates a blurry reflection, and a setting of 100 creates a sharp, mirror-like reflection.
- **Highlight Color**: A color control to set a color to tint the highlights that appear in reflections on the text object's surface.

*Note*: The enamel setting effectively negates any bumpiness on layers beneath it (just like the effect of adding enamel to a rough surface in the real world). For example, if you place this layer over a wood layer, the grain depth of the wood is ignored no matter how high you set that parameter.

**When Finish is set to Brushed**

- **Type**: A pop-up menu to choose a brush pattern: Linear, Circular, or Overlapping Circular.
- **Reflectivity**: A slider to adjust the brightness of reflections that appear in the surface of the object. This value can be set above 100% to create a high dynamic range (HDR) type effect.
- **Glossiness**: A slider to adjust how dull or sharp reflections are. A setting of zero creates a blurry reflection, and a setting of 100 creates a sharp, mirror-like reflection.
- **Depth**: A slider to adjust the apparent depth of the brush pattern.
• **Reverse Depth**: A checkbox that, when selected, inverts the brush pattern, making dark areas appear raised and light areas appear sunken into the surface.

• **Placement**: A group of controls (available when you click the disclosure triangle) to set how the brush pattern is applied to the text object. See Placement controls.

**When Finish is set to Textured**

• **Type**: A pop-up menu to choose a texture: Combed, Cracked, Eggshell, and so on.

• **Reflectivity**: A slider to adjust the brightness of reflections that appear in the surface of the object. This value can be set above 100% to create a high dynamic range (HDR) type effect.

• **Glossiness**: A slider to adjust how dull or sharp reflections are. A setting of zero creates a blurry reflection, and a setting of 100 creates a sharp, mirror-like reflection.

• **Depth**: A slider to adjust the apparent depth of the texture pattern.

• **Reverse Depth**: A checkbox that, when selected, inverts the texture pattern, making dark areas appear raised and light areas appear sunken into the surface.

• **Placement**: A group of controls (available when you click the disclosure triangle) to set how the texture is applied to the text object. See Placement controls.

**When Finish is set to Custom Specular**

• **Intensity**: A slider to adjust the amount of light reflected in the text object's surface.

You can control the intensity of lights and environmental light separately by clicking the disclosure triangle and adjusting the following two sliders:

• **Lights**: A slider to adjust the amount of light reflected in the object's surface.

• **Environment**: A slider to adjust the amount of environmental light reflected in the object's surface.

  For more information about these lighting options, see Intro to 3D text lighting.

• **Intensity Image**: A checkbox selected by default for certain material presets (such as those in the Grunge category) that use a built-in image as an “intensity map” in a Custom Specular finish layer. An intensity map makes brighter areas of the image reflect more light, and darker areas reflect less light. An intensity map creates the effect of a pattern or smudge on the object's surface that dynamically modifies or limits the reflectivity of the object.

  **Note**: The Intensity Image controls in Final Cut Pro are available for a limited set of material presets only. However, you can assign a custom image as an intensity map in Motion, an Apple app designed to work with Final Cut Pro. See the Motion User Guide.

Apply a preset to your title, then click the disclosure triangle to reveal the following controls:

• **White Level**: A slider that sets the brightness point above which areas of the intensity map allow reflections to pass and be visible. Lowering the White Level value makes the intensity map more transparent, reducing reflectivity.

• **Black Level**: A slider that sets the brightness point below which areas of the intensity map prevent reflections from passing. Raising the Black Level value means more of the image appears opaque.
• **Wrap Mode:** A pop-up menu to choose what happens if the image is smaller than the text object. Choose one of the following options:
  - *None:* The image is applied once, and areas of the text object that exceed the scope of the image are not covered.
  - *Repeat:* The image is applied and reapplied as often as necessary, creating a pattern to fill the area beyond the scope of the original image.
  - *Mirror:* The image is applied to the text object, then applied again in an inverted, reversed orientation to cover the area beyond the scope of the original image.
• **Placement:** A group of controls (available when you click the disclosure triangle) to set how the intensity map is applied to the text object. See Placement controls.

• **Shininess:** A slider to adjust how mirror-like the object appears. You can control this effect more precisely by clicking the disclosure triangle and adjusting two additional sliders:
  - *Lights:* A slider to adjust how sharply lights are reflected in the surface of the object. A higher value makes light reflections more sharply defined, and a lower value creates blurrier light reflections.
  - *Environment:* A slider to adjust how sharply the environment image is reflected in the surface of the object. A higher value makes the environment more clearly visible in reflections, and a lower value creates blurrier reflections of the environment.

For more information about lighting options, see Intro to 3D text lighting.

• **Shininess Image:** A checkbox selected by default for certain material presets (such as those in the Grunge category) that use a built-in image as a "shininess map" in a Custom Specular finish layer. A shininess map controls how sharp or mirror-like the object appears.

*Note:* The Shininess Image controls in Final Cut Pro are available for a limited set of material presets only. However, you can assign a custom image as a shininess map in Motion, an Apple app designed to work with Final Cut Pro. See the Motion User Guide.

Apply a preset to your title, then click the disclosure triangle to reveal the following controls:

• **White Level:** A slider that sets the brightness point above which areas of the shininess map enable a clear, mirror-like reflection in the surface. Lowering the White Level value means more of the reflection appears clear and mirror-like.

• **Black Level:** A slider that sets the brightness point below which areas of the shininess map create a dulling or blurring effect on the object’s reflections. Raising the Black Level value means more of the reflection appears blurry.

• **Wrap Mode:** A pop-up menu to choose what happens if the image is smaller than the text object. Choose one of the following options:
  - *None:* The image is applied once, and areas of the text object that exceed the scope of the image are not covered.
  - *Repeat:* The image is applied and reapplied as often as necessary, creating a pattern to fill the area beyond the scope of the original image.
  - *Mirror:* The image is applied to the text object, then applied again in an inverted, reversed orientation to cover the area beyond the scope of the original image.

  - **Placement:** A group of controls (available when you click the disclosure triangle) to set how the shininess map is applied to the text object. See Placement controls.
• **Specular Color:** A pop-up menu to choose whether the specular color is based on the current surface or a solid color. Use this control to add a hue (or pattern) that colors the reflection as if the material were made of that color or pattern. For example, adding an orange specular color causes reflections to have an orange hue, as if the 3D title were made of copper.

• **Surface Blend:** A slider (available when Specular Color is set to From Surface) to adjust the amount of the underlying color blended into the highlights.

• **Color:** A control (available when Specular Color is set to Solid Color) to set the color of reflections to a color you choose (as opposed to the color of the current surface).

• **Anisotropic:** A checkbox that, when selected, activates a set of controls that limit the Custom Specular effect to a particular pattern or direction (as opposed to the default method, which disperses the specular effect in many directions at once). This allows you to distort the highlights created by lighting styles and scene lights. Click the disclosure triangle to reveal the following controls:
  - **Geometry:** A pop-up menu to choose whether the anisotropic effect is linear or cylindrical.
  - **Placement:** A pop-up menu to choose whether the anisotropic effect placement is independent or shared. See Placement controls.
  - **Place On:** A pop-up menu to choose whether the anisotropic effect is applied to individual glyphs (letters) in a text object or to the entire text object.
  - **Orientation:** Dials (available when Geometry is set to Linear) to set the direction of the linear anisotropic specular effect.
  - **Position:** Value sliders (available when Geometry is set to Cylindrical) to set the position where the cylindrical anisotropic specular effect is centered.
  - **Highlight Sharpness:** A slider to adjust the shape of the reflected highlight, making it narrow or wide.

*Note:* For details about anisotropic controls, see the Motion User Guide.

### Distress controls in Final Cut Pro for Mac

Use the Distress controls, in the Material section of the 3D Text section of the Text inspector, to create the effect of wear or degradation on the surface of the 3D title.

![Without distress layer](image1.png) ![With distress layer](image2.png)
Depending on the option you choose in the Distress pop-up menu, different parameter controls become available.

- **Distress**: A pop-up to choose a distress type: Scratches, Stains, Dirt, Dents, Wavy, Bumps, Perforated, Wrinkles, or Custom Bumps.

**When Distress is set to Scratches**
- **Type**: A pop-up menu to choose a scratch pattern.
- **Depth**: A slider to adjust the apparent depth of the scratches.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the scratch pattern is applied to the text object. See Placement controls.

**When Distress is set to Stains**
- **Type**: A pop-up menu to choose a stain pattern.
- **Opacity**: A slider to adjust the transparency of the stain pattern.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the stain pattern is applied to the text object. See Placement controls.

**When Distress is set to Dirt**
- **Type**: A pop-up menu to choose a dirt pattern.
- **Opacity**: A slider to adjust the transparency of the dirt pattern.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the dirt pattern is applied to the text object. See Placement controls.

**When Distress is set to Dents**
- **Type**: A pop-up menu to choose a dent pattern.
- **Depth**: A slider to adjust the apparent depth of the dents in the 3D title.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the dent pattern is applied to the text object. See Placement controls.

**When Distress is set to Wavy**
- **Depth**: A slider to adjust the apparent depth of the wave pattern.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the wave pattern is applied to the text object. See Placement controls.
When Distress is set to Bumps

- **Type**: A pop-up menu to choose a bump pattern.
- **Depth**: A slider to adjust the apparent depth of the bump pattern.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the bump pattern is applied to the text object. See Placement controls.

When Distress is set to Perforated

- **Type**: A pop-up menu to choose a perforation pattern.
- **Depth**: A slider to adjust the apparent depth of the perforation pattern.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the perforation pattern is applied to the text object. See Placement controls.

When Distress is set to Wrinkles

- **Type**: A pop-up menu to choose a wrinkle pattern.
- **Depth**: A slider to adjust the apparent depth of the wrinkles.
- **Placement**: A group of controls (available when you click the disclosure triangle) to set how the wrinkle pattern is applied to the text object. See Placement controls.

When Distress is set to Custom Bumps

*Note*: The Custom Bumps distress type is available in a limited set of preset materials that use a built-in image as a bump map. For example, the Scales preset in the Miscellaneous category uses the Custom Bumps distress type. For details about custom bump maps, see the Motion User Guide.

- **Bump Map Gain**: A slider to increase or decrease the contrast of the bump map image, giving the effect of larger or smaller bumps.
- **Blend Mode**: A pop-up menu to choose how multiple bump layers interact with each other. Choose one of two options:
  - **Add**: Uses a mathematical add operation, allowing the lighter areas of each layer to shine through.
  - **Replace**: Overrides the bump attributes of underlying layers.

**Emit controls in Final Cut Pro for Mac**

Use the Emit controls to apply a radiance effect to 3D text, as if the text were emitting its own light. When you add an emit layer to a 3D title, the following controls appear in the Material section of the 3D Text section of the Text inspector.
• **Fill**: A pop-up menu to choose whether the light emitted is based on a solid color or a gradient.

• **Color**: A color control (available when Fill is set to Color) to select the color to be emitted.

• **Gradient**: A gradient control (available when Fill is set to Gradient) to create a custom gradient for the colors to be emitted. See [Intro to the gradient editor](#).

• **Intensity**: A slider to adjust the strength of the light emitted from the text object.

• **Coverage**: A slider to adjust how visible the emit layer is, based on the opacity of the layer. A value of 100% (the default) causes the emit layer to be visible regardless of the opacity of the layers beneath it. A value of 0% means that the emit layer shines only where the material is opaque.

### Placement controls in Final Cut Pro for Mac

Many material layers include graphic images (with fixed dimensions) that are applied to the 3D title—for example, the pattern of a fabric or the wrinkles of a distress layer. In the Material section of the Text inspector, the controls for each of these layers include a set of Placement controls you can use to define the way the image is mapped onto the text object.

If you want to apply placement settings to more than one layer at once, you can designate the placement for those layers as Shared. In that case, Shared Placement controls appear in the Material section of the Text inspector and replace the Placement controls for the individual layers. Layers that have Placement set to Independent are not affected by the Shared Placement settings. As you add additional layers that include Placement controls, you can choose whether they use the shared settings or are controlled individually.

The Material section of the Text inspector also has a set of Global Placement controls you can use to randomize the placement of any textures applied in any material layer. These settings apply to all textures regardless of whether they are designated as Independent or Shared.

### Independent Placement controls

These controls appear in each material layer that includes a texture that is applied to the 3D title.
• **Placement:** A pop-up menu to choose whether the mapping of the image is *independent*, meaning that the controls below affect the placement of the image, or *shared* with the other images being placed on the selected 3D title.

When Placement is set to Shared, the rest of the placement parameters in the material layer are hidden, because the layer is now controlled by the Shared Placement settings in the Options section.

• **Place On:** A pop-up menu to choose whether to apply the image or texture once to the entire text object, or individually to each glyph (letter).

• **Side Placement:** A pop-up menu to choose how the mapped image or texture is applied to the sides of the text object. Choose one of the following options:
  - **Normal:** The image or texture is mapped onto the front and the sides of the text object in the same direction.
  - **Turn 90°:** The image or texture is mapped onto the front of the text object; the same image is mapped onto the sides of the text object, but is rotated by 90 degrees.
  - **Stretch From Edge:** The image or texture is mapped onto the front of the text object; on the sides, the pixels on the edge are repeated, so that the pattern appears to be stretched over the sides of the text object.

• **Position:** Value sliders to set the location where the image or texture is mapped onto the object.

• **Scale:** A slider to adjust the magnification (zoom) level of the image or texture being mapped. Click the disclosure triangle to reveal separate X and Y scale sliders and the Scale With Font Size checkbox (described below).

• **Scale With Font Size:** A checkbox (available when you click the Scale disclosure triangle) that, when selected, causes the size of the applied image or texture to change proportionally when you modify the font size of the text object.

• **Rotation:** A dial to rotate the mapped image or texture around the Z axis. Click the disclosure triangle to reveal separate dials for rotating around the X, Y, and Z axes.

**Shared Placement controls**

These controls appear in the Options section of the Text inspector when the Placement pop-up menu for a material layer is set to Shared. These controls are identical to the Independent Placement controls described above.

**Global Placement controls**

These settings apply to all images being affected by Placement controls, independent or shared. These controls appear in the Options section of the Text inspector.
You can create variations of the patterns Final Cut Pro uses to place textures, effects, and images onto text objects in your 3D titles. In some cases you may want the placement of the applied pattern to vary among the characters in your titles. The Random Seed feature is effectively a random-pattern generator for this purpose.

- *Randomize:* A pop-up menu to choose whether to apply the randomness to just the sides, just the front and back, or all facets.
- *Random Seed:* A control to choose a different random number to change the random-pattern placement. Click the Generate button to have Final Cut Pro select a random number, or enter your own number in the text field.

**Change lighting style**

**Intro to 3D text lighting in Final Cut Pro for Mac**

3D titles in Final Cut Pro are designed to simulate the shading and reflectivity of three-dimensional objects in the real world reacting to local lighting conditions and the surrounding environment. The built-in lighting and environment controls greatly simplify the process of creating natural-looking 3D titles.

Also, because reflectivity is a fundamental aspect of what makes three-dimensional objects appear realistic, Final Cut Pro allows you to control what's reflected in 3D titles. You can choose from a range of preset environments, or you can create your own custom environment.
Adjust 3D text lighting in Final Cut Pro for Mac

All 3D titles in Final Cut Pro have a set of built-in options that simulate basic lighting conditions, so you can create natural-looking scenes quickly and easily.

Modify the lighting style

1. Select a 3D title in the Final Cut Pro timeline.

2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

⚠️ Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.
4. In the Lighting section of the 3D Text section, click the Lighting Style pop-up menu and choose a lighting style.

![Lighting Styles]

Tip: In the case of the Backlit option, default environmental light will cause some illumination to fall on the front surface of the title. To create an effect where the front of the object appears entirely unlit (like the Backlit preview sphere), deselect the Environment checkbox.

5. Drag the Intensity slider to increase or decrease the amount of illumination.
The following examples illustrate a few selected lighting styles using the default Soft Box Above lighting environment set to 80% intensity. For information about lighting environments, see Change the lighting environment.

For a detailed list of all 3D text lighting controls, see Lighting controls.

**Control how 3D titles cast shadows**

In the real world, complex objects often cast shadows on parts of themselves. You can simulate this effect in Final Cut Pro using the Self Shadows controls. The following examples show what 3D text looks like with Self Shadows turned on and off. Both examples use the Diagonal Left lighting style.
1. Select a 3D title in the Final Cut Pro timeline.

2. In the Lighting section of the 3D Text section of the Text inspector, select the Self Shadows checkbox.

   *Note: If Lighting Style is set to Off, the Self Shadows checkbox is hidden.*

   With self-shadows enabled, one part of a 3D title casts a shadow on another part of the same title (depending on the light source position). Although this effect can add realism to a text object, in some cases it may add unwanted or distracting shadows.

3. Click the disclosure triangle next to the Self Shadows checkbox to reveal additional controls, then do any of the following:
   - *Decrease the visibility of self shadows:* Drag the Opacity slider to the left.
   - *Soften the edges of self shadows, making them more subtle:* Drag the Softness slider to the right.

**Change the 3D text lighting environment in Final Cut Pro for Mac**

Reflective objects such as 3D text need something to reflect. You can choose what's reflected in the surface of 3D titles by enabling environment lighting.

Environment lighting projects an image onto the 3D title to simulate a reflected world. Because environment lighting emulates the reflective properties of real-world objects, its effects are more noticeable on 3D text with shiny surfaces.

The following examples show different lighting environments. (In these examples, Lighting Style is set to Off. For information about lighting styles, see *Adjust 3D text lighting.*)
Set the lighting environment for a 3D title

1. Select a 3D title in the Final Cut Pro timeline.

2. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Text button at the top of the inspector.

   Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. In the Lighting section of the 3D Text section, click Show next to the Environment section to show the Environment controls.

5. Click the Type pop-up menu and choose one of the preset lighting environments.

   Tip: You may need to rotate the 3D title around the X or Y axis to see different parts of the reflected environment. See Rotate titles in 3D space.
Modify the appearance of a reflected environment

1. Select a 3D title in the Final Cut Pro timeline.
2. In the Lighting section of the Final Cut Pro Text inspector, click Show next to the Environment section to show the Environment controls.
3. Adjust the following controls:
   - **Intensity**: Adjust the brightness of the reflected image.
   - **Rotation**: Change the angle at which the environment image appears reflected in the 3D title.
     - **Tip**: By default, environments rotate around the Y axis. To rotate around the other axes, expand the Rotation controls and adjust the dials.
   - **Contrast**: Control the relative difference in brightness between the light and dark areas in the reflected image.
   - **Saturation**: Control the amount of color visible in the reflected image.

Turn off the environment reflection

Because the Environment controls effectively add a light source to your 3D title (even when Lighting Style is set to Off), you may want to turn off Environment entirely—for example, if you add scene lights to create a custom lighting environment.

1. Select a 3D title in the Final Cut Pro timeline.
2. In the Lighting section of the 3D Text section of the Text inspector, deselect the Environment checkbox.
   - **Tip**: For the most realistic results, make sure that all 3D titles in your project use the same reflection environment.

Lighting controls in Final Cut Pro for Mac

Adjust the controls in the Lighting section of the 3D Text section of the Text inspector to modify 3D text lighting.

Lighting controls

- **Lighting Style**: A pop-up menu to choose a preset lighting style for the selected 3D title.
  - **Off**: Disables the 3D text lighting controls. Choose this if you want to light your 3D title using environment lighting only.
    - **Note**: You may also want to disable environment lighting. See Change the lighting environment.
  - **Standard**: Illuminates the text object from the front, from the left, and from the right.
  - **Medium Center**: Creates a soft, flat light illuminating the text object from the center.
  - **Medium Left**: Creates a soft, flat light illuminating the text object from the left.
• **Medium Right**: Creates a soft, flat light illuminating the text object from the right.

• **Above**: Illuminates the text object from above.

• **Backlit**: Illuminates the text object from behind.

  *Note*: By default, environmental light causes additional illumination to fall on the front surface of the text object. To create a backlighting effect where the front of the text object appears entirely unlit, deselect the checkbox for the Environment controls to disable environment lighting. See [Change the lighting environment](#).

• **Below**: Illuminates the text object from the bottom.

• **Diagonal Left**: Illuminates the text object from the upper-left corner.

• **Diagonal Right**: Illuminates the text object from the upper-right corner.

• **Drama Top Left**: Illuminates the text object from the top and left sides, with no illumination at all on the right or bottom.

• **Drama Top Right**: Illuminates the text object from the top and right sides, with no illumination at all on the left or bottom.

• **Intensity**: A slider to adjust the strength of the light falling on the 3D title.

• **Self Shadows**: A group of controls (available when you click the disclosure triangle) to set whether and how the lighting causes text glyphs (individual characters) to cast shadows upon the other glyphs in the text object.

  When Self Shadows is enabled, two additional controls become available:

  • **Opacity**: A slider to adjust how visible the shadows are.

  • **Softness**: A slider to adjust how blurred the shadows appear.

**Environment controls**

• **Environment**: A checkbox that, when selected, enables a reflective lighting effect so that 3D text appears to reflect lighting from a surrounding environment. Click the disclosure triangle to reveal additional adjustment controls:

  • **Type**: A pop-up menu to choose one of the preset environments.

  • **Intensity**: A slider to adjust the strength of the environmental light.

  • **Rotation**: A dial that controls the angle at which the environment image is mapped onto the object.

  • **Contrast**: A slider that increases or decreases the contrast of the environment image. More contrast creates weaker midtones, brighter highlights, and darker shadows; less contrast creates stronger midtones, muted highlights, and muted shadows.

  • **Saturation**: A slider to adjust the visibility of the colors within the environment image. More saturation creates more visible color; less saturation creates a more monochromatic image.

  • **Anisotropic**: A checkbox that creates more realistic distortions in reflections for the Custom Specular or Brushed finish layers. Although this setting improves realism, it can impact performance.
Add 3D text glows or shadows in Final Cut Pro for Mac

You can apply standard glow and drop shadow effects to 3D titles just as you would to 2D titles. However, the results always appear in only two dimensions.

Add a glow effect to a 3D title
1. Select a 3D title in the Final Cut Pro timeline.
2. If the inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Text button at the top of the inspector.
   ❓ Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.
4. Select the checkbox to the left of the Glow heading (near the bottom of the Text inspector).
   The checkbox is highlighted blue, and a yellow glow is applied to the title.
5. Double-click the Glow heading to display parameter controls, then adjust Color, Opacity, and other settings to customize the glow effect.

Note: Adding a glow effect to a 3D title forces the title to be rasterized. When a title is rasterized, it's converted to a bitmap image.

Add a drop shadow effect to a 3D title
1. Select a 3D title in the Final Cut Pro timeline.
2. In the Text inspector, select the checkbox to the left of the Drop Shadow heading (near the bottom of the inspector).
   The checkbox is highlighted blue, and a default drop shadow is applied to the title.
3. Double-click the Drop Shadow heading to display parameter controls, then adjust Color, Opacity, and other settings to customize the drop shadow effect.
Add effects

Intro to effects in Final Cut Pro for Mac

You can easily add special effects to video, audio, and photos in your projects.

Final Cut Pro provides several kinds of effects and controls:

- **Transitions**: Add an effect between clips to control how they change from one to the next. See Intro to transitions.

- **Effects**: Add a wide variety of effects to your video and audio clips, from subtle (add film grain or a color effect to the video, or a graphic equalizer to the audio) to not so subtle (add droplet ripples or an insect-eye view to the video, or apply an exaggerated pitch shift to the audio). There are two main types of effects:
  - **Built-in effects**: Use these standard effects to resize, move, rotate, trim, skew, crop, or apply the Ken Burns zooming effect to a video clip. These effects are already part of each timeline clip—you just need to adjust them. See Intro to built-in effects.
  - **Clip effects**: Use these effects to correct issues in your video and audio clips or create stunning new looks or sounds. See Intro to clip effects.

- **Generators**: Add a special element like a placeholder clip, a timecode generator, or a countdown timer, or add colors, patterns, or animated backgrounds to your project. See Intro to generators.

- **Onscreen controls**: Customize many of your effects using onscreen controls. See Intro to onscreen controls.

- **Video animation**: Vary effect settings as a clip plays. See Intro to video keyframing.
You can add effects to any clips in the timeline. After the effects have been added (or in the case of built-in effects, adjusted), you can customize them using controls in an inspector, onscreen controls in the viewer, and controls in the Video Animation and Audio Animation editors. You can also try out multiple versions of an effect using auditions.

You can also open and customize most effects and generators in Motion, an Apple app designed to work with Final Cut Pro.

Note: If you’re using a transition, title, effect, or generator created in Motion that uses a third-party plug-in, and that plug-in is not installed on your Final Cut Pro system, the Final Cut Pro project may be rendered incorrectly or incompletely. To verify whether this is the cause, open the template in Motion; if there are offline elements, a warning dialog appears. See Modify transitions in Motion, Modify titles in Motion, Modify effects in Motion, or Modify generators in Motion.

Add and adjust transitions

Intro to transitions in Final Cut Pro for Mac

You can add cross dissolves and other transition effects between clips to make your program more interesting.

Transitions replace one shot with another over a specified period of time; when one shot ends, another one replaces it. Three very common video transitions are fades, cross dissolves, and wipes.

You can also add audio-only transitions. These transitions can be either a fade-in, a fade-out, or a crossfade. See Fade audio in and out.

Note: When a transition is added to a video clip with attached audio, a crossfade transition is automatically applied to the audio. If the audio is detached or expanded from the video, the crossfade is not added.

How transitions are created in Final Cut Pro for Mac

Transitions require overlapping video from the clips on each side of the edit point. A one-second transition requires one second of video from the end of the left clip and one second of video from the start of the right clip. When you apply a transition to an edit point, Final Cut Pro attempts to use additional video from each of the clips to create the overlap. These additional (unused) sections of clips are called media handles.
The example below shows range selections in a clip in the browser, and the portions of the clip that will become media handles when the range selections are edited into the timeline.

Clip selected in the browser

![Image showing media handles](image)

The media handle video may not be appropriate for use in a transition. For example, if the media handle includes unusable video such as a slate, it will be visible in the project.

The illustration below shows how transitions are created when the clips on either side of the edit point have media handles. The transition is placed so that it spans the clips; half of the transition overlaps each clip. Unused media from the end of each clip is added to fill out the transition, and the total duration of your project is unchanged.

![Image showing transition with media handles](image)

If one or both of the clips do not have enough extra content (media handles) to support a transition of the default duration, you’re given the option to overlap media in your project to create the transition. If you choose to overlap media, Final Cut Pro uses the available media handles and then overlaps media as necessary to create the transition.

The illustration below shows a transition created without media handles. The two clips are made to overlap, and the transition is placed over the overlapping region. This is effectively a ripple edit, and the total duration of your project decreases.

![Image showing transition without media handles](image)
This same option is available for audio crossfades. See Create an audio crossfade using the Modify menu.

To learn how to set the default duration for transitions, see Set the default transition.

Add video transitions and fades in Final Cut Pro for Mac

You can choose from a large selection of video transitions (such as dissolves or wipes) to add between clips, or quickly add a fade-in or fade-out effect. You can also easily copy a transition from one edit point in your project to another.

Tip: Save time by using a keyboard shortcut to add transitions. See Quickly add a transition with a keyboard shortcut.

Add or change a transition between clips

1. In Final Cut Pro, click the Transitions button in the top-right corner of the timeline (or press Control-Command-5).

2. In the Transitions browser, select a transition.

   Move the pointer over the transition thumbnails to see an example of what the transition looks like. To filter the list of transition names that appear, type text in the search field.

   Note: If you don't see the transition you’re looking for, you can use the Filter pop-up menu at the top of the Transitions browser to check for it in other locations. See Filter Motion content stored in a library.

3. Do one of the following:
   - **Apply the transition to an edit point**: Drag the transition to the edit point.
   - **Replace an existing transition in your project**: Drag the transition on top of the existing transition.

Alternatively, you can select the edit point first, then double-click a transition in the Transitions browser to apply the transition.
Final Cut Pro creates the transition at the edit point using media handles. If the video clip has attached audio, a crossfade transition is applied to the audio.

⚠️ Tip: You can use the Cross Dissolve transition to quickly create a “fade up from black” effect at the beginning of a clip or project or a “fade to black” effect at the end. See Quick create a fade-in or fade-out effect, below.

Quickly create a fade-in or fade-out effect

You can use the Cross Dissolve transition to quickly create a “fade in from black” effect at the beginning of your project or a “fade to black” effect at the end. (Fade effects commonly appear at the beginning or end of a movie or TV show.)

Note: These instructions describe a quick way to create a fade effect, but this method doesn’t allow for fine-tuning. For more precise control over the fade, use keyframes to change the opacity over time. See Intro to video keyframing and Add video effect keyframes.

1. In Final Cut Pro, add one or more clips to the timeline.

2. Do one of the following:
   • *Create a fade-in:* Select the start point of the first clip in the timeline.
   • *Create a fade-out:* Select the end point of the last clip in the timeline.

3. Do one of the following:
   • Choose Edit > Add Cross Dissolve (or press Command-T) to add the default Cross Dissolve transition to the selection. To change the default transition, see Set the default transition.
   • Click the Transitions button in the top-right corner of the timeline (or press Control-Command-5), then drag the Cross Dissolve transition from the Transitions browser to the selection.

4. Make adjustments to the Cross Dissolve transition, as needed.
   See Adjust transitions in the timeline and Adjust transitions in the inspector and viewer.

Final Cut Pro creates the transition at the edit point using media handles. If the video clip has attached audio, a crossfade transition is applied to the audio.

Note: If you want to include connected clips in the fade effect, select them along with the original clip and make a compound clip before applying the Cross Dissolve transition.
**Copy a transition to other edit points**

After you add a transition to your project and **make adjustments to it**, you can reuse it anywhere else in your project.

1. In Final Cut Pro, select a transition in the timeline.

2. Do one of the following:
   - Choose Edit > Copy (or press Command-C), click the edge of a clip (an edit point) in the timeline, then choose Edit > Paste (or press Command-V).
   - Hold down the Option key and drag the transition to another edit point.

If you copy a transition to an edit point that already has a transition, the existing transition is overwritten.

**Note:** If you extend a clip to its maximum length in either direction, the clip edge turns red. You may need to trim (shorten) the clip to create the media handle necessary to create a transition. See **How transitions are created**.

**Quickly add a transition with a keyboard shortcut in Final Cut Pro for Mac**

You can quickly apply transitions to your clips using the Command-T keyboard shortcut. Final Cut Pro comes with the default transition set to Cross Dissolve, but you can change the default to any transition.

**Add the default transition using a keyboard shortcut**

1. In Final Cut Pro, click the Tools pop-up menu (shown below) at the top of the timeline, choose the Select tool, then click the edge of a clip (an edit point) in the timeline.

   ![Select tool](image)

   One or both clip edges are highlighted.

   ![Selected clips](image)

   You can also select one or more whole clips in the timeline, instead of just an edit point. In this case, transitions are added at each end of the selected clips.
2. Press Command-T.

The default transition is applied to the selected edit point.

Alternatively, you can choose Edit > Add [transition name]. The transition name in the menu changes depending on the current default transition setting.

Final Cut Pro creates the transition at the edit point using media handles. If the video clip has attached audio, a crossfade transition is applied to the audio.

This is the quickest way to add transitions to your projects. You can easily switch to a different default transition. See Set the default transition, below.

**Set the default transition**

Final Cut Pro comes with the default transition set to Cross Dissolve, but you can change the default to any transition.

1. In Final Cut Pro, click the Transitions button in the top-right corner of the timeline.

2. In the Transitions browser, Control-click a transition, then choose Make Default.

**Set the default duration for transitions in Final Cut Pro for Mac**

If you find you often want to change the length of your transitions to last a specific number of seconds, you can change the default duration to the duration you use the most.

**Tip:** Adjust the default duration before applying a transition to many clips at once.

1. In Final Cut Pro, choose Final Cut Pro > Settings, or press Command-Comma (,), then click Editing.

2. Use the Transition value slider to set the duration, in seconds, of all transitions you add to the timeline.

You can adjust the duration of a transition after it's in the timeline.

**Note:** Some transitions have a fixed duration and are not affected by this setting.
Delete transitions in Final Cut Pro for Mac

You can easily delete a transition, restoring the edit point to a simple cut.

1. Select one or more transitions in the Final Cut Pro timeline.
2. Press Delete.

The selected transitions are removed, and their edit points are converted to simple cuts.

You can also choose Edit > Undo to remove the transition and return the clips to their original length.

Adjust transitions in the timeline in Final Cut Pro for Mac

You can adjust a transition’s duration and move it in the timeline. You can also trim either of the clips under the transition.

*Note:* If you extend a clip to its maximum length in either direction, the clip edge turns red. You may need to trim (shorten) the clip to create the media handle necessary to create a transition. See How transitions are created.

Change the transition duration

1. Select a transition in the Final Cut Pro timeline.
2. Do one of the following:
   - Choose Modify > Change Duration (or press Control-D), type the duration (it appears below the viewer), then press Return.
   - Drag one end of the transition away from the transition’s center to lengthen it, or toward the center to shorten it.

The transition maintains its center point and both ends are trimmed equally, with the number showing how many frames have been added to or subtracted from the transition duration.
Move a transition

Moving a transition actually rolls the edit under the transition, adding content to one underlying clip while removing content from the other clip. The overall duration of the project is not affected. You can move a transition only if the clip that is being extended has sufficient media handles.

1. Select a transition in the Final Cut Pro timeline.
2. Drag the transition trim icon in the upper-center area of the transition.

The edit under the transition is rolled, with one clip being extended and the other shortened. A number appears above the trim icon showing the number of frames to the left (negative numbers) or to the right (positive numbers) you have rolled the transition.

You can also use the precision editor to roll the transition.
Trim a clip under a transition

The transition includes icons that make it easy to trim the left or right clip without affecting the transition.

1. Select a transition in the Final Cut Pro timeline.
2. Drag one of the trim icons in the upper-left or upper-right area of the transition.

Note: You may need to zoom in on the timeline to make the trim icons appear.

Dragging the trim icon in the upper left adjusts the right clip's start point, and dragging the trim icon in the upper right adjusts the left clip's end point. A number appears showing how many frames you have added to (negative numbers) or subtracted from (positive numbers) the clip's duration. Trimming the clip doesn't affect the transition's duration, but it does affect the project's duration.

You can also use the precision editor to trim the clips under the transition.
Adjust transitions in the inspector and viewer in Final Cut Pro for Mac

You can adjust a transition using the controls in the Transition inspector and viewer.

1. In the Final Cut Pro timeline, select the transition to adjust.

   This example explains how to modify the Circle transition, but you can modify any transition.

   The viewer shows the onscreen controls for the selected transition.

   In the above example, which uses the Circle transition, you can drag the white circle in the viewer to position the circle wipe's center, and the diamond-shaped handle to set the border width (in this case, its softness).

2. If the inspector is not already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

   The Transition inspector shows the other parameters available for you to adjust. In the above example, the Transition inspector includes a setting for the circle wipe's aspect ratio and edge treatment (including the border color if you choose a hard edge). Some transitions also have an image well for selecting a video frame that appears as part of the transition.
Common transition controls include:

- **Ease**: Sets the acceleration of the transition at its beginning or end, or at both points. An Ease Amount slider lets you adjust how rapidly the effect ramps up or ramps down.

- **Direction**: Sets which quadrant of the frame an animated transition (such as a wipe) begins in.

- **Edge Type**: Sets the edge hardness of wipe transitions.

- **Graphics HDR Level**: Some transitions include SDR colors or graphic elements. When applied to clips in an HDR project, these elements may look dimmer than the bright areas in the HDR clips, or colors may seem muted relative to the HDR media. You can increase the intensity or vibrancy of these elements by adjusting the Graphics HDR Level slider.

- **Audio Transition Fade In Type and Fade Out Type**: Sets the type of crossfade curve applied to audio during transitions between video clips that have an audio component. Choose one of the following:
  - **Linear**: Maintains a constant rate of change over the length of the fade.
  - **+3dB**: Fade-ins start quickly and end slowly; fade-outs start slowly and end quickly. This is the default setting and is best for maintaining a natural volume when crossfading between two clips.
  - **–3dB**: Fade-ins start slowly and end quickly; fade-outs start quickly and end slowly.
  - **S-curve**: Eases in and out of the fade with the midpoint at 0 dB.

Additionally, many transitions have parameters that you can animate using keyframes. For example, you could have the circle effect move across the video frame as the clip plays.

### Merge jump cuts with the Flow transition in Final Cut Pro for Mac

The Flow transition seamlessly merges jump cuts to remove pauses or mistakes in on-camera interviews.

1. In Final Cut Pro, open the Transitions browser, then select the Dissolves category on the left.
2. Drag the Flow transition to the edit point of a jump cut.
   
   Alternatively, you can select the edit point first, then double-click the Flow transition in the Transitions browser to apply it to the edit point.

Keep the following in mind when using the Flow transition:

- Use the Flow transition with the default duration only. Any other duration will generate unexpected results.
- The Flow transition duration is always set at 6 frames regardless of the duration set in the Editing pane of Final Cut Pro settings.
- The Flow transition is disabled (treated as a standard dissolve) when you apply it to a generator.
Adjust transitions with multiple images in Final Cut Pro for Mac

Several transitions include areas that are filled with still images from the clips on either side of the transition. The example below shows the Pan Far Right transition (one of the Bulletin Board transitions).

The areas are numbered and correlate to numbered points (handles) in the timeline.

1. Select a transition with numbered points in the Final Cut Pro timeline.

2. Position the playhead at the center of the transition so that numbered handles appear in the timeline and the corresponding numbers appear in the viewer, as shown above.

   *Note: You may need to adjust the zoom level in the timeline. To fit all the clips in the visible part of the timeline, choose View > Zoom to Fit (or press Shift–Z).*

3. Drag any of the numbered handles in the timeline to select the frame to fill the corresponding area in the viewer.

   As you drag the handle in the timeline, the corresponding area in the viewer updates to show the new image.

4. Continue until you've selected images for all of the areas.
Modify Final Cut Pro for Mac transitions in Motion

Many of the transitions in Final Cut Pro were created using Motion, an Apple app designed to work with Final Cut Pro. You can open these transitions in Motion, make modifications, and save the changes as a new transition that appears in the Transitions browser.

**Important**: To modify a transition in Motion, you must have Motion 5 installed on your computer.

1. Click the Transitions button in the top-right corner of the Final Cut Pro timeline.

2. In the Transitions browser, Control-click the transition you want to modify, then choose “Open a copy in Motion.”

Motion opens, and the transition’s project appears.

3. Modify the transition project.

   See the Motion User Guide.

4. Choose File > Save As (or press Shift-Command-S), enter a name for the new transition (referred to as a Template in Motion), assign it to a category (or create a new category), choose a theme (if needed), and click Publish.

   If you choose File > Save, the transition is saved using the same name, with “copy” appended to its end.

**Note**: If you have created or customized any Final Cut Pro effects, transitions, titles, or generators in Motion, set the storage location for your Motion content to In Library before starting any copy or move operations between libraries or storage devices. Otherwise, the Motion content is not included in those operations. See Manage Motion content. Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.
Adjust built-in effects

Intro to built-in effects in Final Cut Pro for Mac

Final Cut Pro includes several video effects that are part of each timeline clip and directly accessible from the viewer—all you need to do is select the effects and start making adjustments. You can use built-in effects to:

- Create a composited image from several clips
- Reposition or reframe a clip by zooming in on it
- Crop a clip to remove unwanted items, such as microphones or lighting equipment, that accidentally appear in the video
- Create a Ken Burns effect to add life to your still images (and video clips as well)

You can use more than one of the built-in effects at the same time. For example, you can use Transform to reduce the image's size and position, Trim to remove a portion of the video, and Distort to give the video a skewed look.

You can animate any of these effects so that they change as the clip plays. For example, you can have an image shrink and move offscreen. To configure an animation, you change settings at two or more points in the clip. When you play the clip, Final Cut Pro creates smooth animated transitions between the points.

You can save any combination of effects and their parameter settings as an effects preset, which appears in the Effects browser and functions like any clip effect. See Save video effects presets and Save audio effects presets.

Resize, move, and rotate clips in Final Cut Pro for Mac

You can resize, move, and rotate an image using the Transform built-in effect. This effect is commonly used on a clip placed over a primary storyline clip, which becomes the background of the resized clip. It’s also often used to zoom in on a clip, allowing you to reframe a shot if needed.

You can adjust the Transform effect using controls in the viewer and Video inspector. However, some controls are found only in one or the other.

1. Select a clip in the Final Cut Pro timeline.
2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To access the Transform controls, do one of the following:

- Click the pop-up menu in the lower-left corner of the viewer and choose Transform (or press Shift-T).
- Control-click in the viewer and choose Transform.

The Transform onscreen controls appear in the viewer.

4. Adjust the Transform effect using the onscreen controls:

- **Overscan button in the upper-right corner of the viewer:** Click to reveal the overscan areas (areas of a clip that extend beyond the edges of the viewer).

- **Blue handles at each corner:** Drag these to adjust the image’s size while maintaining its current aspect ratio.

- **Blue handles in the middle of each side:** Drag these to independently adjust the vertical and horizontal image size, changing the aspect ratio of the image.

  *Note:* These controls aren’t available in the Video inspector.

- **White circle in the center:** Shows the rotation anchor point. Drag anywhere inside the image to adjust the image's position.

- **Blue handle extending from the center circle:** Drag this to rotate the image.

  ☀ **Tip:** For finer precision when rotating the image, drag the rotation handle farther away from the anchor point in the center.
5. Use the Transform controls in the Video inspector as follows:
   • *Position X and Y*: Move the image left and right (X) and up and down (Y).
   • *Rotation*: Rotate the image around its anchor point.
   • *Scale*: Change the image’s size.
     
     *Note*: When you increase the video image size with the Scale parameter, some peripheral areas of the image may fall outside of the boundary of the visible program. Click the Overscan button at the top of the viewer to reveal areas outside of the viewer frame.

   [Image: Overscan off and Overscan on]

   • *Anchor X and Y*: Move the image’s center point (the point that the image rotates around).
     
     *Note*: This control isn’t available in the onscreen controls.

6. When you’re finished adjusting the effect, click Done (in the upper-right corner of the viewer).

You can animate the Transform effect and have it appear over a background. See *Work with built-in effects*.

### Adjust framing with Smart Conform in Final Cut Pro for Mac

You can use the Smart Conform feature to automatically reframe clips whose aspect ratio is different from the project aspect ratio.

Smart Conform analyzes the contents of selected clips in a project and automatically adjusts the framing for each clip based on the specific video content, such as faces or other areas of visual interest, so these important elements are not left outside the video frame.

Smart Conform is especially useful for repurposing projects created with standard widescreen or HD aspect ratios, such as those for film or TV, to make versions in different aspect ratios for social media. See *Create square or vertical versions of a project*. 
1. In Final Cut Pro, create a new project or open an existing project.

2. In the timeline, select one or more clips whose aspect ratio does not match the project aspect ratio.

   For example, you might have a horizontal or widescreen clip from an HD project that you want to use in a vertical project for a social media app or website.

3. Choose Modify > Smart Conform.

   Final Cut Pro analyzes the content of the selected clips and then intelligently reframes each clip.

   The examples below show the default “center crop” framing for a horizontal clip in a vertical project, and then how the same clip is reframed using Smart Conform.

   ![Center crop](image1)

   ![Smart Conform](image2)

   ![Final vertical project](image3)

   After the Smart Conform process is complete, you can make additional framing adjustments by changing the Position parameter for the Transform effect. See Resize, move, and rotate clips in Final Cut Pro.
Trim the edges of the video frame in Final Cut Pro for Mac

Trim controls allow you to independently trim each of the image edges, creating a window look. This effect, often used along with the Transform effect, is commonly used on a clip placed over a primary storyline clip, which becomes the background of the trimmed clip.

1. Select a clip in the Final Cut Pro timeline.
2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To access the Trim controls, do one of the following:
   • Click the pop-up menu in the lower-left corner of the viewer and choose Crop (or press Shift-C).
   • Control-click in the viewer and choose Crop.
4. Click the Trim button at the bottom of the viewer.
5. Adjust the effect using the onscreen controls:
   • Blue handles at each corner: Drag these to adjust the position of two trim window sides at the same time.
   • Blue handles in the middle of each side: Drag these to independently adjust the position of each side.
   • Anywhere inside the window: Drag anywhere inside the window to adjust its position.

You can also adjust each edge of the image individually using the Left, Right, Top, and Bottom parameters in the Crop section of the Video inspector.
6. When you’re finished adjusting the effect, click Done.

You can animate the effect and have it appear over a background. See Work with built-in effects.

**Crop clips in Final Cut Pro for Mac**

The Crop effect makes it easy to remove unwanted areas of the image. The cropped image automatically expands to fill the screen.

1. Select a clip in the Final Cut Pro timeline.
2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To access the Crop controls, do one of the following:
   - Click the pop-up menu in the lower-left corner of the viewer and choose Crop (or press Shift-C).
   - Control-click in the viewer and choose Crop.
4. Click the Crop button at the bottom of the viewer.
5. Adjust the effect using the onscreen controls:
   - *Blue handles at each corner:* Drag a corner handle to adjust the crop of that corner. The cropped image always maintains the original aspect ratio.
   - *Anywhere inside the window:* Drag anywhere inside the crop window to adjust its position.
You can also adjust each edge of the image individually using the Left, Right, Top, and Bottom parameters in the Crop section of the Video inspector.

*Note:* Although you can use these controls to change the crop window's aspect ratio, the final image still matches the original image’s aspect ratio, with additional content being cropped out so that the final image fits the original aspect ratio.

6. To apply the crop and have the cropped image fill the screen, click Done.

You can animate the effect, creating the illusion of a pan and zoom camera move (effectively, a manual Ken Burns effect). See [Work with built-in effects](#).

**Pan and zoom clips in Final Cut Pro for Mac**

The Ken Burns effect creates a pan and zoom effect using the start and end positions you define. The Ken Burns effect is actually a Crop effect with two crop settings, one at the clip start and another at its end.

You can further customize the Ken Burns effect by controlling the smoothness of the animation. The motion applied to a clip when you create a Ken Burns effect is automatically smoothed so that the movement accelerates slowly as the animation starts, and decelerates slowly as the clip comes to rest at the end of the animation. This simulates the effects of friction and inertia that occur in the real world. In visual effects software, this trick is commonly called ease out and ease in.

By default, a Ken Burns animation performs both of these smoothing operations (Ease Out and Ease In), but you can customize the effect to limit the result to just easing out, just easing in, or making a linear movement with no simulated inertia or friction.
Adjust the Ken Burns effect

1. Select a clip in the Final Cut Pro timeline.

2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.

3. To access the Ken Burns controls, do one of the following:
   - Click the pop-up menu in the lower-left corner of the viewer and choose Crop (or press Shift-C).
   - Control-click in the viewer and choose Crop.

4. Click the Ken Burns button at the bottom of the viewer.

Two rectangles appear in the viewer: a green one that defines the position and size for the start of the clip and a red one that defines the position and size for the end of the clip.

5. To choose the part of the image that appears at the start of the effect, drag the green handles to change the crop size of the image, and drag the window to set its position.

6. To choose the part of the image that appears at the end of the effect, drag the red handles to change the crop size of the image, and drag the window to set its position.

A superimposed arrow shows the direction the image travels when the clip is played.

7. To have the clip with the effect play in a loop, click the Play Loop button.

8. To exchange the start and end positions, click the Swap button.

9. Click Done.
Customize the smoothness of a Ken Burns animation

By default, a Ken Burns animation performs both smoothing operations (Ease Out and Ease In), but you can customize the effect.

1. In the Final Cut Pro timeline, select a clip with the Ken Burns effect enabled.
2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To access the Ken Burns controls, do one of the following:
   - Click the pop-up menu in the lower-left corner of the viewer and choose Crop (or press Shift-C).
   - Control-click in the viewer and choose Crop.
4. Click the Ken Burns button at the bottom of the viewer.

   Two rectangles appear in the viewer: a green one that defines the position and size for the start of the clip and a red one that defines the position and size for the end of the clip.

5. In the viewer, Control-click anywhere in the image and choose an option:
   - **Ease In and Out**: Applies the easing effect to the beginning and the end of the animation.
   - **Ease In**: Limits the easing effect to the end of the animation.
   - **Ease Out**: Limits the easing effect to the beginning of the animation.
   - **Linear**: Removes all easing effects.

⚠️ Tip: Use the Crop effect and intermediate keyframes to create a Ken Burns–style effect that follows a more complicated path.

For details on working with built-in effects, see Work with built-in effects.
Skew a clip's perspective in Final Cut Pro for Mac

You can use the Distort effect to skew or otherwise distort the image. The Distort effect allows you to create a skewed look or add a 3D perspective to the image by dragging each corner and edge of the video frame independently of the others.

*Note:* The Distort effect can change and animate the shape of the video, but it does not affect the position. To animate the video so that it moves to a different position, use the Transform effect.

1. Select a clip in the Final Cut Pro timeline.
2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To access the Distort controls, do one of the following:
   - Click the pop-up menu in the lower-left corner of the viewer and choose Distort (or press Option-D).
   - Control-click in the viewer and choose Distort.
4. Adjust the effect using the onscreen controls:
   - *Blue handles at each corner:* Drag these to adjust the position of each corner, adding a 3D perspective to the image by making parts of it appear closer to you than other parts.
   - *Blue handles in the middle of each side:* Drag these to adjust the position of each side. You can create a skewed look by dragging them in the same direction as their edge (as opposed to toward or away from the center).
   - *Anywhere inside the window:* Drag anywhere inside the window to adjust its position.

*Note:* You can also use the Distort controls in the Video inspector to individually adjust each corner.
5. When you’re finished adjusting the effect, click Done.

You can animate the effect and have it appear over a background. See Work with built-in effects.

Work with built-in effects in Final Cut Pro for Mac

Following are ways you can work with built-in effects.

Turn off or reset a built-in effect on a single clip

1. In the Final Cut Pro timeline, select the clip with the enabled built-in effect.
2. Do one of the following:
   - **Turn off the effect and retain its settings:** In the Video inspector, click the blue checkbox next to the effect used (Transform, Crop, or Distort).
     You can click the checkbox again to turn the effect back on, making it easy to compare how the clip looks with and without the effect.
   - **Return all values for the effect to their default state:** Click the Reset button.
   - **Turn off the effect in the Video Animation editor:** Open the Video Animation editor by choosing Clip > Show Video Animation (or pressing Control-V), then click the checkbox next to the effect you want to turn off.
Animate built-in effects

When you animate a built-in effect, you modify the effect's settings at two or more points in time and set keyframes at these points. When the clip plays, the video changes smoothly between the keyframes, creating an animated effect.

This applies to all built-in effects except the Ken Burns effect, which has a different workflow. See Pan and zoom clips.

1. Select a clip in the Final Cut Pro timeline.
2. Click the pop-up menu in the lower-left corner of the viewer and choose the effect you want to animate.
   
   For this example, choose Transform (or press Shift-T).

3. Position the timeline playhead at the start of the clip.
4. Adjust the effect's onscreen controls to set the start position.
   
   See Onscreen control examples.
   
   In the example shown below, the scale of the video frame was reduced by dragging a corner handle.
5. Click the Add Keyframe button in the upper part of the viewer.

6. Move the playhead to the end of the clip.
7. Adjust the effect’s controls to set the end position.

In the example shown below, the position of the video frame was moved by dragging the center circle down and to the right.

A keyframe is automatically added and appears as a white handle on the red motion path line. Additionally, for Transform effects, a line showing the image’s path appears. See Resize, move, and rotate clips.

8. To finish, click Done in the upper-right corner of the viewer.

When you play the clip, the video moves smoothly between the keyframes, creating an animated effect. You can add multiple keyframes by moving the playhead to a new position and changing the effect’s controls. See Intro to video keyframing.

Smooth position keyframes

If you animated the position of a clip using the Transform effect, you can modify the shape of the clip’s path in the viewer by setting individual keyframes to be smooth. This adds a set of Bezier handles that allow you to create intricate, complex shapes and provide more control over the way your clips move. You can remove the curves and the handles used to create them by setting a keyframe to be linear.

1. In the Final Cut Pro timeline, select the clip that has position keyframes applied.

   To learn how to add keyframes to a clip, see Animate built-in effects, above.

2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To access the Transform controls, do one of the following:
   - Click the pop-up menu in the lower-left corner of the viewer and choose Transform (or press Shift-T).
   - Control-click in the viewer and choose Transform.

4. In the viewer, Control-click any individual handle and choose an option:
   - **Convert the keyframe to a smooth keyframe**: Choose Smooth.
     Bezier handles appear, and you can drag the handles to control the curved shape of the path.
   - **Convert the keyframe to a corner point**: Choose Linear.
     Bezier handles are removed from the keyframe, and the keyframe becomes a corner point.

**Adjust the Transform effect animation path**

Transform animations have additional keyframe controls you can use to fine-tune the animation path. To show these, you first need to create a simple three-corner effect.

1. Select a clip in the Final Cut Pro timeline and put the playhead at its start.
2. Click the pop-up menu in the lower-left corner of the viewer and choose Transform (or press Shift-T), then drag the onscreen controls to reduce the image’s size and place it in the upper-left corner.
3. Click the Add Keyframe button.
4. Move the timeline playhead to the middle of the clip.
5. **Use the Transform onscreen controls** to move the image to the upper-right corner.
   
   A keyframe is automatically added, and a red line appears showing the animation’s path so far.

6. Move the timeline playhead to the end of the clip.

7. Use the Transform onscreen controls to move the image to the bottom center.
   
   A keyframe is automatically added, and the red line extends to this new point.

8. To jump between the keyframes, click the white squares along the red line.
   
   The first and last keyframes have white arrows.
   
   By default, the red line indicates a smooth path (indicated by how it curves).

9. To control the curve of the path, click the starting or middle keyframe and drag the curve handles.

10. Control-click a keyframe and choose an option:

    - **Linear**: Use for direct, noncurved paths in and out of that keyframe.
    - **Smooth**: Use for curved paths in and out of that keyframe, providing a more natural movement.
    - **Delete Point**: Use to delete that keyframe.
    - **Lock Point**: Use to prevent that keyframe from being adjusted. It changes to Unlock Point once set.
    - **Disable Point**: Use to ignore that keyframe, but keep the keyframe in place in case you want to use it later. It changes to Enable Point once set.
Composite effects over a background

Often, Transform, Trim, and Distort effects result in the image being less than full size, with the empty areas filled with black. You can replace the black with a background by placing the transformed clip over a background clip (also known as compositing).

In Final Cut Pro, do one of the following:

- **Add a clip to the timeline as a connected clip**, then add the effect to that clip.
  
  This places the clip above the primary storyline clip, which automatically becomes the effect’s background.

- If the clip is already in the primary storyline, drag it above the primary storyline, positioning it over the clip you want to be the background.

The result is a composited image.

For more information about working with connected clips, see Add storylines. For more information about compositing clips, see Intro to compositing.
Remove built-in effects in Final Cut Pro for Mac

You can remove built-in effects from clips, either individually or all at once.

Remove selected built-in effects from one or more clips

You can remove selected effects and attributes from multiple timeline clips at once.

1. Select one or more clips in the Final Cut Pro timeline.
2. Choose Edit > Remove Attributes (or press Shift-Command-X).
   
   The Remove Attributes window appears, with the clip's current effects and attributes selected.

3. Deselect the checkboxes for the effects or attributes you want to retain, and select the checkboxes for the effects or attributes you want to remove.
4. Click Remove.

   Selected built-in effects are reset to their default values. Selected clip effects are removed from the clips entirely.

Remove all effects from one or more clips

You can remove or reset all effects and attributes on multiple timeline clips at once.

1. Select one or more clips in the Final Cut Pro timeline.
2. Choose Edit > Remove Effects (or press Option-Command-X).

   All built-in effects on the selected clips are reset to their default values. All clip effects are removed from the selected clips entirely.
Add and adjust clip effects

Intro to clip effects in Final Cut Pro for Mac

In addition to the built-in effects, Final Cut Pro includes a wide variety of video effects that you can apply to your project’s video clips. Many of the effects modify the look of your video, from adding a blur or glow to severe distortions. Some effects overlay camcorder or timecode graphics. There are also effects for keying one video clip over another and for creating areas of transparency in a clip (masking).

After you have added an effect, you can adjust its settings. Some effects have few adjustments, while others provide a comprehensive set, allowing you a lot of control over how the effects look. Effects can even be animated, with their settings changing as the clip plays.

You can save any combination of effects and their settings as an effects preset, which appears in the Effects browser and functions like any clip effect. See Save video effects presets and Save audio effects presets.

You can also use effect masking controls available in most video clip effects to limit the area of the video frame that is affected by a video effect or color correction.

Additionally, many video effects can be opened and changed in Motion, allowing you to create specialized versions for use in your projects. See Modify effects in Motion.

Final Cut Pro also includes a broad range of audio effects that you can apply to your project’s audio clips. Many of the effects modify the sound of your audio, from subtle echoes to severe pitch distortions. See Add audio effects.

Add video effects in Final Cut Pro for Mac

You add video effects to clips in your project using the Effects browser.

1. Select a clip in the Final Cut Pro timeline, then click the Effects button in the top-right corner of the timeline (or press Command-5).

2. In the Effects browser, select an effect.

You can do any of the following to help make your selection:

- Filter the list of effects that appear: Type text in the Effects browser search field to search for an effect by name.
  You can also click to select individual effects categories, such as Blur or Color.

- Preview the effect: Skim the video effect thumbnail.

- Preview changing the effect’s primary control: Hold down the Option key as you skim the video effect thumbnail.

  As you skim left and right, the video thumbnail shows a still-frame preview of the effect of dragging the slider for the effect’s primary control. For example, the primary control for the Radial effect is the Amount parameter.
Note: If you don't see the effect you're looking for, you can use the Filter pop-up menu at the top of the Effects browser to check for it in other locations. See Filter Motion content stored in a library.

3. Do one of the following:
   - Drag the effect to the timeline clip you want to apply it to.
   - Double-click the effect thumbnail to apply it to the selected clip.

You can now adjust the effect.

Add the default video effect in Final Cut Pro for Mac

You can set a default video effect and quickly add it to your project clips using the Option-E keyboard shortcut or a menu command.

Final Cut Pro comes with the default video effect set to the Color Board color correction effect, but you can change the default effect to any video effect in the Effects browser, including custom video effects presets.

You can also set a default color correction effect, which appears whenever you open the Color inspector for a clip that has no color correction applied.

Add the default video effect to project clips

1. Select one or more video clips in the Final Cut Pro timeline.

2. Choose Edit > Add [effect name] (or press Option-E).
   
The name of the menu item changes depending on the current default video effect setting.

Set the default video effect

1. Click the Effects button in the top-right corner of the Final Cut Pro timeline (or press Command-5).

2. Control-click a video effect or a video effects preset, then choose Make Default Video Effect.

Set the default color correction effect

1. Choose Final Cut Pro > Settings, or press Command-Comma (,).

2. Click General.

3. Click the Color Correction pop-up menu and choose one of the following effects:
   - Color Board
   - Color Wheels
   - Color Curves
   - Hue/Saturation Curves
   - Color Adjustments
The controls for the effect you choose appear by default whenever you open the Color inspector for a clip that has no color correction applied.

**Important:** When you set the default video effect to any of the five color correction effects, the default video effect menu command (Edit > Add [effect name]) and keyboard shortcut (Option-E) always apply the default color correction effect defined in Final Cut Pro settings. If the default video effect command doesn’t apply the color correction effect you expect, make sure the effect you want to apply is chosen from the Color Correction pop-up menu in General settings.

**Adjust effects in Final Cut Pro for Mac**

Most effects have one or more parameters that you can adjust using the Video or Audio inspector, the viewer, or the Video Animation or Audio Animation editor. You can also control how the effect is applied to the clip—whether the parameter values are fixed for the duration of the clip or change over time.

**Adjust an effect in the inspector and viewer**

1. In the Final Cut Pro timeline, select the clip with the effect you want to adjust.
2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Locate the effect in the Video inspector or Audio inspector.
   - The example above shows several settings for the Censor effect. Many effects also have adjustments that appear in the viewer, known as onscreen controls.
   - **Tip:** For audio effects, you can click the Controls button (to the right of the effect’s name) to show a custom control window.
4. Select the effect, then adjust its settings as needed.
To return the effect’s values to their default settings, click the effect’s Reset button.

Controls in the inspector vary depending on the selected effect. For example, the Masks and Keying category of effects has position controls, whereas the Color Adjustments effect has controls for exposure, contrast, saturation, tint, highlights, and other image settings.

Common effect controls include:

- **Amount**: Sets the intensity of the effect.

- **Graphics HDR Level**: Some video effects include SDR colors or graphic elements. When applied to clips in an HDR project, these elements may look dimmer than the bright areas in the HDR clips, or colors may seem muted relative to the HDR media. Examples include the white type in the Timecode effect or the colors in the Comic Looks effects. You can increase the intensity or vibrancy of these elements by adjusting the Graphics HDR Level slider.

- **Mix**: Sets how much of the original image is blended with the filtered image (the original image with the video effect applied). Use this control to add back more of the original image.

**Tip**: Because the video effects that come with Final Cut Pro for Mac are based on the effects filters in the Motion app, you can learn more about them in the Motion User Guide.

**Adjust an effect in the Video Animation editor**

Many effect parameters can be adjusted in the Video Animation editor. Additionally, you can set these parameters to change over time, allowing you to change the appearance of the effect.

1. In the Final Cut Pro timeline, select the clip with the video effect you want to adjust.
2. ChooseClip > Show Video Animation (or press Control-V).

The effect appears as one of the animations in the Video Animation editor above the clip in the timeline. You can click the effect’s checkbox to turn the effect off and on. Effects that have more than one adjustable parameter also have a pop-up menu for choosing the parameter to show and adjust.
3. To show an expanded parameter, choose a specific parameter from the effect’s pop-up menu (if present), then double-click the parameter.

This applies only to effects that have a single value. An icon appears to the right of the effect if the parameter can be expanded.

4. To have the effect parameter fade in and out of the clip, drag the fade handles on either end of the effect.

You can also drag the horizontal line up and down to set the maximum value of the selected parameter (Size, in the example below). Any keyframes you add also appear.

Show the audio effects applied to a clip

1. In the Final Cut Pro timeline, select the clip with the audio effects you want to show.

2. Choose Clip > Show Audio Animation (or press Control-A).

Each audio effect applied to the clip appears as an animation in the Audio Animation editor. You can click the effect's checkbox to turn the effect off and on.
Use masks to define the shape of a video effect

Intro to effect masking in Final Cut Pro for Mac

Using the masking tools built into most clip effects in Final Cut Pro, you can isolate and control which areas of the video image are affected by clip effects, including color corrections. These isolated areas are called \textit{masks}.

There are two types of masks:

- \textit{Shape masks}: The area of a shape mask is defined by its outline, and can be a regular shape (such as a circle or rectangle) or an irregular shape that you draw. See \textit{Add a shape mask to a video effect}.

- \textit{Color masks}: The area of a color mask is defined by a specific color range, so only areas in your clip that contain colors within the color range are part of the mask. See \textit{Add a color mask to a video effect}.

You can apply a color mask and any number of shape masks to a clip effect, and you can have multiple masks interact in different ways \textit{within} an effect.

You can animate any effect mask in Final Cut Pro, just as you can animate most effect parameters.

For information about using traditional masking tools to create areas of transparency in an image, see \textit{Intro to masking}.

\textit{Note}: Clip effects in the Keying and Masks categories in the Effects browser do not have the built-in effect masking tools described in this section.
Add a shape mask to a video effect in Final Cut Pro for Mac

You can define the area of a video effect, including a color correction, using the powerful shape-masking tool.

In the example below, you can apply an effect (such as Gaussian) to everything outside or inside the mask shape that you define.

You can add multiple masks to define multiple areas, and you can also animate the shapes so that they follow a moving object, or follow an area while a camera pans.

1. Add a clip to your Final Cut Pro project, and select the clip in the timeline.
2. Position the playhead in the timeline so that your clip appears in the viewer.
3. Add an effect to the timeline clip from the Effects browser.
   
   Note: This includes the color correction effects, which you can apply from the Color category of the Effects browser or from the Color inspector. See Add color correction effects.

4. If the Video inspector isn't already open, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

5. Click the Video button at the top of the inspector.
6. In the Effects section of the Video inspector, move the pointer over the effect name and click the Apply Effect Masks button.

7. Click the pop-up menu that appears and choose Add Shape Mask.

The onscreen controls appear in the viewer, superimposed over the video image. By default, the shape mask is set to a partially feathered circle in the center of the frame. The Shape Mask parameter appears in the effect's section of the Video inspector.

8. Use the onscreen controls to adjust the mask shape.

- **Position the shape**: Drag the center.
- **Adjust the shape’s width or height**: Drag any of the four handles at the 90-degree points (top, bottom, left, or right) of the inner circle. You can hold down the Shift key while dragging to force all sides to scale proportionally.
- **Control the roundness of the shape**: Drag the handle to the left of the inner circle’s top handle.
- **Rotate the shape**: Drag the rotation handle (extending from the center).
- **Control the softness of the shape’s edge**: Drag the outer circle. Setting the outer circle close to the inner circle creates a hard edge and an abrupt visual transition to the effects you apply, and dragging the outer circle away from the inner circle creates a softer edge and a more gradual transition.
To show or hide the mask's controls, click the Shape Mask Onscreen Controls button to the right of the shape mask name in the mask list.

For more information about onscreen controls for shape masks, see Create simple shape masks.

Note: At any time, you can view the mask alpha channel by clicking View Masks (next to the effect name). The mask's alpha channel appears in the viewer. White indicates fully opaque mask areas, black indicates areas outside the mask, and levels of gray indicate transparent mask areas. See Add a color mask to a video effect and Combine multiple effect masks.

Add a color mask to a video effect in Final Cut Pro for Mac

You can create a color mask to apply a video effect, including a color correction, to a particular color in an image, or to exclude a color from the effect.

For example, you could use a color mask to mute a bright color in the background that distracts attention from a shot’s main subject.

1. Add a clip to your Final Cut Pro project, and select the clip in the timeline.
2. Position the playhead in the timeline so that your clip appears in the viewer.
3. Add an effect to the timeline clip from the Effects browser.

Note: This includes the color correction effects, which you can apply from the Color category of the Effects browser or from the Color inspector. See Add color correction effects.

4. To open the Video inspector, choose Window > Show in Workspace > Inspector (or press Command-4).

5. In the Effects section of the Video inspector, move the pointer over the effect name and click the Apply Effect Masks button.
6. Click the pop-up menu that appears and choose Add Color Mask.

The Color Mask parameter appears in the same section of the Video inspector, and the pointer changes to the eyedropper tool.

7. In the viewer, position the eyedropper on a color in the image that you want to isolate, then drag to select the color.

As you drag, two concentric circles appear. The size of the outer circle determines the range of color that is included in the color mask. As you change the outer circle size, the image becomes monochrome except for the color you’re selecting. You can drag a new selection circle as many times as you like to try for better results.

*Note:* When you stop dragging, the effect is applied to the area you selected. If you applied a color correction, you'll see the effects of the color mask as soon as you start making adjustments in the Color Board. You can then return to the Video inspector and use the eyedropper to make any adjustments to the color mask.

8. To change the range of color included in the mask, do any of the following:
   - *Add color shades:* Hold down the Shift key, position the eyedropper on a color you want to add to the mask, and drag to select the color.
   - *Subtract color shades:* Hold down the Option key, position the eyedropper on a color you want to remove from the mask, and drag to select the color.

9. To adjust the color mask edges, drag the Softness slider.

*Tip:* To view the mask alpha channel while adjusting the Softness slider, hold down the Command key.

10. Do one of the following:
   - *View the mask's alpha channel:* Click the View Masks pop-up menu and choose Black and White.

       The mask’s alpha channel appears in the viewer. White indicates fully opaque mask areas, black indicates areas outside the mask, and levels of gray indicate transparent mask areas.
   - *View the colors inside the mask:* Click the View Masks pop-up menu and choose Color.

       The colors inside the mask appear in the viewer. Gray indicates areas outside the mask.
Whether you’re viewing the mask alpha channel or the colors inside the mask, you can quickly return to the adjusted image by clicking View Masks.

Combine multiple effect masks in Final Cut Pro for Mac

When defining the area of a clip effect, including a color correction, you may find that it’s impossible to create the mask shape you need using only one mask. For example, when masking a shape with a hole in it, you need at least two masks—one set to Add to mask the overall object, and a second set to Subtract to cut out the hole.

You can set masks to interact in different ways using mask blend modes. For example, you can add mask shapes together to create a combined mask, subtract a mask shape from other masks, and intersect masks.

*Note:* You can add an unlimited number of effects to a clip, but mask blend modes interact within a single effect—not across multiple effects.

**Add, subtract, and intersect masks**

1. Select a clip in the Final Cut Pro timeline.
2. Position the playhead in the timeline so that your clip appears in the viewer.
3. **Add a video effect** to the clip from the Effects browser.
   
   You can add almost any kind of video clip effect, including the Color Correction effect. However, effects in the Keying and Masks categories in the Effects browser do not have the built-in effect masking tools described here.
4. If the Video inspector isn’t already open, do one of the following:
   
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
5. Click the Video button at the top of the inspector.

6. In the Effects section of the Video inspector, add a shape mask or a color mask to the effect.

7. To add an additional mask to the effect, move the pointer over the effect name in the Video inspector and click the Apply Effect Masks button that appears to the right of the effect name.

   The new mask appears below the effect name in the Video inspector, with the blend mode to the right. By default, new shape masks appear at the top of the list in Add mode, and new color masks appear at the bottom of the list in Intersect mode.

   Note: You can rearrange the order of the masks within a given effect. See Reorder masks, below.

8. To change how a mask interacts with other masks applied to the effect, click the pop-up menu next to the mask name and choose a blend mode:

   • Add: Applies the effect to the area inside the mask shape selection. If two or more masks are set to Add, the masks are merged.
• **Subtract:** Removes the effect from the area inside the mask shape, including areas that overlap with other masks.

![Subtract Diagram](image)

• **Intersect:** Applies the effect to any area inside the mask shape that overlaps with other masks set to either Add or Intersect.

![Intersect Diagram](image)

*Note:* At any time, you can invert all masks for a given effect. See [Invert effect masks](#).
Reorder masks

The order in which you apply shape and color masks can affect the final output. The Add, Subtract, and Intersect modes operate sequentially, starting at the top of the mask list in the Video inspector. By default, new shape masks appear at the top of the list in Add mode, and new color masks appear at the bottom of the list in Intersect mode. You can reorder masks to achieve the effect you want.

1. To apply two or more masks to an effect in Final Cut Pro, follow steps 1 through 6 in Add, subtract, and intersect masks, above.

   The masks are listed below the effect name in the Video inspector.

![Masks appear in a list below the effect name.]

2. To change the mask order, drag masks up or down in the list.

   For an example of how you might use shape masks set to the Intersect blend mode to isolate one area of a color mask, see Add shape masks to a color mask.

Invert effect masks in Final Cut Pro for Mac

In most cases, you use the built-in masking capability of a video effect, including a color correction, to limit the effect to a specific area or color. However, you can also invert your mask to exclude a specific area or color from the effect.

1. **Add a clip** to your Final Cut Pro project, and select the clip in the timeline.
2. Position the playhead in the timeline so that your clip appears in the viewer.
3. If the Video inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
4. Click the Video button at the top of the inspector.

5. Add an effect to the timeline clip from the Effects browser.

6. Apply a shape mask or a color mask to the effect.

7. To make the mask alpha channel visible, click the View Masks pop-up menu (next to the effect name) and choose Black and White.

The mask’s alpha channel appears in the viewer. White indicates fully opaque mask areas, black indicates areas outside the mask, and levels of gray indicate transparent mask areas.

Note: You can also view the color contents of the mask. See Ways to view masks.
8. In the Effects section of the Video inspector, move the pointer over the effect name, click the Apply Effect Masks button, and choose Invert Masks from the menu that appears.

All mask selections for the effect are inverted (the masked and unmasked areas are reversed).

![Inverted mask](image)

**Animate an effect shape mask in Final Cut Pro for Mac**

You can use keyframes to animate an effect shape mask so that it follows the movement of an onscreen object.

1. In Final Cut Pro, add a shape mask to a video effect.
2. In the timeline, move the playhead to the frame where you want the shape to begin moving.
3. In the viewer, position the shape mask at its starting position.
4. If the Video inspector isn’t already open, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button in the toolbar.
5. Click the Video button at the top of the inspector.
6. In the Effects section of the Video inspector, click the Keyframe button for the mask you want to animate.

A keyframe is added at the position of the playhead. To see the keyframe in the timeline, press Control-V to open the Video Animation editor. The keyframe appears in the effect's section of the Video Animation editor as a diamond at the playhead position.

7. Move the playhead to the next point in the clip where you want to define the shape mask's position, reposition the shape mask, and add the second keyframe.

8. Continue adding keyframes until you've defined the shape movement you want.

When you've added all the keyframes, you can play the clip to see the shape mask move between them. For more information about working with keyframes, see Intro to video keyframing.

Note: You can apply and animate multiple shape masks on a clip. You can view and edit individual shape masks in the Video Animation editor just as you would any other effect parameter. See Add video effect keyframes.

Change clip effect order in Final Cut Pro for Mac

You can apply multiple clip effects to a timeline clip. The order in which you apply them can affect the final output. For example, if you apply the Artifacts effect—which by default adds random white circles to the video—before the Aged Paper effect, the white circles are also aged; if you apply Artifacts after Aged Paper, the circles remain white.

You can easily change the order of the clip effects in the Video or Audio inspector, or in the Video Animation or Audio Animation editor.

Note: You can't change the order of the built-in effects.
Change video and audio clip effect order using the Video or Audio inspector

1. Select a clip in the Final Cut Pro timeline that has multiple video or audio clip effects applied, then do one of the following:
   - **View the video effects:** Open the Video inspector.
   - **View the audio effects:** Open the Audio inspector.

2. In the Video inspector or Audio inspector, drag the clip effects to change their order.

Change video and audio clip effect order using the Video Animation or Audio Animation editor

1. Select a clip in the Final Cut Pro timeline that has multiple video or audio clip effects applied, then do one of the following:
   - **View the video effects:** Choose Clip > Show Video Animation (or press Control-V).
   - **View the audio effects:** Choose Clip > Show Audio Animation (or press Control-A).

2. In the Video Animation editor or Audio Animation editor, drag the effects to change their order.
Copy effects between clips in Final Cut Pro for Mac

Final Cut Pro offers two ways to copy effects between clips:

- **Paste Attributes**: This command lets you copy selected clip attributes to another clip and provides more control over individual effects, settings, and keyframes. For example, you can copy video crop settings, audio pan settings, or keyframe adjustments.

- **Paste Effects**: This command copies all of a clip's effects to another clip and is the fastest way to copy effects and attributes.

You can also copy and paste individual keyframes from one parameter to another. See Copy and paste keyframes.

**Copy selected clip attributes to another clip**

1. Select a clip in the Final Cut Pro timeline, then choose Edit > Copy (or press Command-C).

2. Select the clip or clips to which you want to apply the attributes, then choose Edit > Paste Attributes (or press Shift-Command-V).

3. Do any of the following:
   - **Apply all video or all audio attributes from the source clip**: Select the Video Attributes or Audio Attributes checkbox.
   - **Apply individual attributes**: Select the checkboxes for the attributes you want to apply.

4. If you made any keyframe adjustments to the source clip, select one of the following in the Keyframe Timing section:
   - **Maintain**: Leaves the duration between keyframes unchanged.
   - **Stretch to Fit**: Adjusts the keyframes in time to match the duration of the destination clip.

5. Click Paste.
Copy all of a clip’s effects to another clip

1. In the Final Cut Pro timeline, select the clip you want to copy the effects from, then choose Edit > Copy (or press Command-C).
2. Select the clip or clips to which you want to apply the effects, then choose Edit > Paste Effects (or press Option-Command-V).

All the source clip’s effects and their settings are applied to the destination clip. For more control over individual attributes, follow the instructions in Copy selected clip attributes to another clip, above.

Save video effects presets in Final Cut Pro for Mac

You can save any combination of video effects and video effect parameter settings as a video effects preset, which appears in the Effects browser and functions like any other video effect. You can create an effects preset from any combination of built-in effects and clip effects. After you create an effects preset, you can share it with friends and colleagues so that the same preset (with its specific combination of effects and parameter settings) is available in their Effects browser.

Save a video effects preset

1. Apply any combination of built-in effects and clip effects to a clip in the Final Cut Pro timeline, and make any needed adjustments to the effects.
   See Add video effects.
2. Select the clip in the timeline.
3. Do one of the following:
   • Choose File > Save Video Effects Preset.
   • Open the Video inspector, then click Save Effects Preset at the bottom of the inspector.

The Save Video Effects Preset window appears, with any applied or adjusted effects selected in the Attributes list.
4. Enter a name for the new preset in the Name field.

5. Click the Category pop-up menu and choose an Effects browser category in which to store the new preset.

6. In the Attributes list, select the video effects you want to include in the preset.

7. If you made any keyframe adjustments to the source clip, select either Maintain Timing or Stretch to Fit.
   
   If you select Stretch to Fit, Final Cut Pro adjusts the keyframes in time to match the duration of any clip to which you apply the preset.

8. Click Save.

   The new video effects preset appears in the Effects browser category you chose, ready to be applied to clips in the timeline. To apply the preset to a clip, see Add video effects.

Share a video effects preset

1. In the Final Cut Pro Effects browser, Control-click the effects preset you want to share, then choose Reveal in Finder.

2. In the Finder, select the effects preset file and choose File > Compress.
   
   Note: Compressing the file prevents any change to the preset during transit.

3. Transfer the resulting .zip file to your friend or colleague using email or another convenient method.

4. On the receiving Mac, double-click the .zip file to decompress it.

5. In the Finder, hold down the Option key and choose Go > Library.

6. Drag the effects preset file to the following location in the Library folder:
   
   /Users/username/Library/Application Support/ProApps/Effects Presets/

7. If Final Cut Pro is open, quit and reopen it.

   The transferred video effects preset appears in the Effects browser, in the same category as on the original Mac.

Copy and paste keyframes in Final Cut Pro for Mac

You can copy and paste individual keyframes from one parameter to another. This allows you to move or duplicate a specific effect (or part of an effect) from one clip to another. For example, you can copy and paste an animated color correction effect or an audio filter adjustment.

You can also move or copy keyframes from one parameter to another within the same clip. For example, you can copy the center point keyframes from a kaleidoscope effect and paste them in the center point of a radial blur effect so that both effects follow identical paths.

You can even copy and paste keyframes within a single parameter, allowing you to create a repeating pattern, or to move an animation from the beginning of a clip to a point later in time.
Keyframes can be copied from any parameter, including parameters in clip effects (such as opacity, position, and audio volume), parameters in effects applied from the Effects browser (such as Gaussian Blur or Channel EQ), and even published parameters for a title. Any keyframes you can select can be cut, copied, and pasted.

Keyframes are always pasted beginning at the location of the playhead or skimmer, and a specific parameter must be selected before you choose the Paste command. If the playhead or skimmer is not currently over the selected clip, no keyframes are pasted.

Note: Pasted keyframes replace any keyframes already applied to the destination parameter within the time range of the pasted keyframes. Keyframes outside the time range being pasted are not affected. For example, if you select opacity keyframes covering a 5-second range and then paste them to a new clip’s opacity setting, keyframes within the 5 seconds beginning at the playhead or skimmer are replaced with the copied keyframes. Any keyframes before or after that range remain the same.

### Copy or move keyframes from one clip to another

1. Select the clip in the Final Cut Pro timeline containing the keyframes you want to copy.
2. To display the specific parameter you want to copy from, do one of the following:
   - *Show the Video Animation editor:* Choose Clip > Show Video Animation (or press Control-V).
   - *Show the Audio Animation editor:* Choose Clip > Show Audio Animation (or press Control-A).
3. Double-click the graph of the parameter containing the keyframes you want to copy.
   The graph expands, revealing keyframes arranged along a curve.
   Note: Some parameters allow you to select keyframes without expanding the graph.
4. Shift-click the keyframes you want to copy, or drag a selection rectangle around them.
   The selected keyframes are highlighted in yellow.
5. Do one of the following:
   - *Duplicate the keyframes:* Choose Edit > Keyframes > Copy (or press Option-Shift-C).
   - *Move the keyframes:* Choose Edit > Keyframes > Cut (or press Option-Shift-X).
   The keyframes are copied to the Clipboard.
6. Select the clip into which you want to paste the keyframes, then show the Video Animation or Audio Animation editor for that clip.
   Note: You can also copy and paste keyframes within the same clip, or within a single parameter.
7. Click the name or keyframe graph for the parameter you want to paste the keyframes to.
   When selected, the graph becomes highlighted.
8. Position the playhead on the frame where you want the new keyframes to begin.
   The keyframes are added to the selected parameter.
Copy or move keyframes from one parameter to another

1. In the Video Animation or Audio Animation editor in Final Cut Pro, select the keyframes you want to copy.
   Shift-click to select multiple keyframes, or drag a selection rectangle around the keyframes you want to select.

2. Do one of the following:
   - **Duplicate the keyframes:** Choose Edit > Keyframes > Copy (or press Option-Shift-C).
   - **Move the keyframes:** Choose Edit > Keyframes > Cut (or press Option-Shift-X).

3. Select the parameter to which you want to paste the keyframes.
   If Solo Animation is turned on, click the parameter pop-up menu and choose the graph for the parameter you want to copy or move the keyframes to. For more information about using Solo Animation, see Add video effect keyframes.

   Note: Some parameters' keyframes can be pasted only onto a similar parameter. For example, you can paste audio volume keyframes from one clip to another clip's volume animation, but you can’t paste those keyframes to a clip’s opacity animation.

4. Position the playhead on the frame where you want the pasted keyframes to begin.

5. Choose Edit > Keyframes > Paste (or press Option-Shift-V).
   The keyframes are added to the selected parameter.

Reduce video noise in Final Cut Pro for Mac

Video noise is a common problem in video clips shot in low-light conditions or with small-sensor devices such as smartphones or action cameras. Video noise is typically a result of digital gain and appears as unwanted grain or artifacts in the video image.

You can remove video noise from standard video clips and 360° clips using the Noise Reduction clip effect.
Add the Noise Reduction effect

1. Select the clip with video noise in the Final Cut Pro timeline, and position the playhead so that the clip appears in the viewer.

2. Click the Effects button in the top-right corner of the timeline (or press Command-5).

3. In the Effects browser, select the Basics category in the list of Video effects on the left, then select the Noise Reduction effect.
   
   For 360° clips, select the 360° category, then select the 360° Noise Reduction effect.
   
   Tip: To quickly find the Noise Reduction and 360° Noise Reduction effects, type “noise reduction” in the Effects browser search field.

4. Do one of the following:
   
   • Drag the effect to the timeline clip you want to apply it to.
   
   • Double-click the effect thumbnail to apply the effect to the selected clip.
   
   The first time the effect is applied, Final Cut Pro analyzes the clip for noise. This analysis must be complete before you can see the result.

   Tip: If you're applying multiple clip effects to the clip, add Noise Reduction as the first effect (so that it appears at the top of the effects list), or rearrange the order of processing by dragging the Noise Reduction effect to the top of the list. This ensures the best performance and results. See Change clip effect order.

Adjust the amount of noise reduction

1. In the Final Cut Pro timeline, select a clip with the Noise Reduction effect.

2. If the inspector isn't already shown, do one of the following:
   
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   
   • Click the Inspector button on the right side of the toolbar.

3. Do any of the following:
   
   • Adjust the amount of noise reduction: Click the Amount pop-up menu and choose the amount of noise reduction to apply.
   
   • Adjust sharpness: Click the Sharpness pop-up menu and choose the amount of sharpness to apply.
   
   You can examine the effect closely by setting the Zoom pop-up menu in the upper-right corner of the viewer to 100%. When you're finished, choose Fit from the same menu (or press Shift-Z).
Remove or turn off effects in Final Cut Pro for Mac

You can remove effects that you’ve applied to clips, or you can turn off the effects but retain their settings.

There are several ways to remove effects from clips. You can remove effects from individual clips right in the timeline or by using the Video or Audio inspector, or you can remove all effects from a clip selection. To remove selected effects and associated settings from one or more clips, you can use the Remove Attributes command, which provides more control over individual effects and settings.

For information about copying and pasting effects and attributes, see Copy effects between clips.

Remove selected attributes and effects from one or more clips

1. Select one or more clips with effects in the Final Cut Pro timeline.
2. Choose Edit > Remove Attributes (or press Shift-Command-X).

   The Remove Attributes window opens, with the clip’s current attributes, effects, and parameters selected.

3. Deselect the checkboxes for the effects, parameters, or attributes you want to retain, and select the checkboxes for the effects, parameters, or attributes you want to remove.
4. Click Remove.

   Selected clip effects are removed from the selected clips. Selected built-in effects are reset to their default values.
Turn off a clip effect
1. Select one or more clips with an effect in the Final Cut Pro timeline.
2. Do one of the following:
   • Choose Clip > Show Video Animation (or press Control-V) to view video effects, or choose Clip > Show Audio Animation (or press Control-A) to view audio effects, then deselect the effect’s checkbox.
   • Select the effect in the Video or Audio inspector, then deselect the effect’s checkbox.

The effect no longer affects the video or audio. You can select the effect’s checkbox to turn the effect back on, with its settings still intact.

Remove all effects from one or more clips
1. Select one or more clips with effects in the Final Cut Pro timeline.
2. Choose Edit > Remove Effects (or press Option-Command-X).
   All clip effects are removed from the selected clips. All built-in effects for the selected clips are reset to their default values.

Remove an effect from an individual clip
1. Select the clip with the effect in the Final Cut Pro timeline.
2. Do one of the following:
   • Choose Clip > Show Video Animation (or press Control-V) to view video effects, or choose Clip > Show Audio Animation to view audio effects, then select the effect and press Delete.
   • Select the effect in the Video or Audio inspector, then press Delete.

Modify Final Cut Pro for Mac effects in Motion
Many of the supplied video effects were created using Motion, an Apple app designed to work with Final Cut Pro. You can open any of these effects in Motion, make modifications, and save the changes as a new effect that appears in the Effects browser.

Important: To modify video effects in Motion, you must have Motion 5 installed on your computer.
1. In Final Cut Pro, click the Effects button in the top-right corner of the timeline (or press Command-5).

   ![Effects button](image)

2. In the Effects browser, Control-click the effect you want to modify, then choose “Open a copy in Motion.”
   Motion opens and the effect's project appears.
3. Modify the effect's project.
   See the Motion User Guide.

4. Choose File > Save As (or press Shift-Command-S), enter a name for this new effect
   (referred to as a Template in Motion), assign it to a category (or create a new category),
   choose a theme (if needed), and click Publish.

   If you choose File > Save, the effect is saved using the same name, with "copy"
   appended to its end.

Note: If you have created or customized any Final Cut Pro effects, transitions, titles, or
generators in Motion, set the storage location for your Motion content to In Library before
starting any copy or move operations between libraries or storage devices. Otherwise,
the Motion content is not included in those operations. See Manage Motion content.
Regardless, you must manually track and move any third-party (FxPlug) content, because it
is not managed within the Final Cut Pro library.

Add generators

Intro to generators in Final Cut Pro for Mac

Final Cut Pro includes a number of video clips called generators that you can use to add
the following elements to your project:

- **Placeholder content:** If your project is missing content that hasn't yet been shot or
delivered, you can add a placeholder clip. The placeholder generator allows you to add
a clip to the timeline with a suitable silhouette to represent the missing content. See
Add placeholders.

- **Timecode counter:** You can add a generated timecode clip to your project to
superimpose a timecode counter over part or all of the project. See Add timecode
counters.

- **Shape clip:** You can choose from a wide variety of shapes for adding graphical elements
to your project. See Add shapes.

- **General-purpose background clip:** Final Cut Pro includes a variety of still and animated
backgrounds over which you can superimpose titles or keying effects. See Add
backgrounds.

All of the generators are added to the project as clips, using their default duration. You can
change a generator’s duration and position the same way you would for any other video
clip in the timeline. You use the Generator inspector to adjust a generator’s settings.

Note: Generator clips appear in the browser when you select a generators category in the
Titles and Generators sidebar. (Generators don’t appear in the Effects browser.) If you
don’t see the generator you’re looking for in the browser, you can use the Filter pop-up
menu at the top of the browser to check for it in other locations. See Filter Motion content
stored in a library.
Add placeholders in Final Cut Pro for Mac

Generated placeholders are useful when you want to fill a gap in the project with a clip that provides a hint about the final content. You can set placeholder clips to represent a wide variety of standard shots, such as close-ups, groups, wide shots, and so on.

1. Drag the playhead in the Final Cut Pro timeline to the point where you want to add the placeholder clip.

2. Do one of the following:
   - Choose Edit > Insert Generator > Placeholder (or press Option-Command-W).
   - In the Titles and Generators sidebar, click the Generators triangle to show the generator categories, select Elements, then double-click the Placeholder thumbnail in the browser.

3. Select the placeholder clip in the timeline.

4. If the Generator inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

5. Click the Generator button at the top of the inspector.

6. In the Generator inspector, adjust the settings for the placeholder clip to match the type of shot you’re creating a placeholder for.

7. To add a text area in the viewer where you can type text that pertains to this clip, select View Notes.

If you prefer to fill a gap in the timeline with a blank clip, you can insert a gap clip. See Insert clips.
Add the default generator in Final Cut Pro for Mac

You can set a default generator and quickly add it to your project using a keyboard shortcut or a menu command.

Final Cut Pro comes with the default video generator set to Placeholder, but you can change the default to any generator.

**Add the default generator to your project**

1. In the Final Cut Pro timeline, move the playhead to the frame where you want to add the default generator.
2. Choose Edit > Insert Generator > [generator name] (or press Option-Command-W).
   
   *Note: The name of the menu item changes depending on the current default generator setting.*

The generator is inserted in the primary storyline at the skimmer or playhead position.

**Set the default generator**

1. If the Titles and Generators sidebar isn’t already shown in Final Cut Pro, do one of the following:
   - Choose Window > Go To > Titles and Generators (or press Option-Command-1).
   - Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.
2. In the sidebar, select a generators category so that the appropriate generators appear in the browser.
3. Control-click a generator in the browser and choose Make Default Generator.

Add timecode counters in Final Cut Pro for Mac

When sending your project for review, you can use the Timecode generator to superimpose timecode over it, making it easier for reviewers to precisely specify sections when providing feedback.

*Note: A related option is the Timecode effect (available in the Effects browser), which displays the clip name and source clip timecode in the viewer and in exported files.*
1. If the Titles and Generators sidebar isn’t already shown in Final Cut Pro, do one of the following:
   • Choose Window > Go To > Titles and Generators (or press Option-Command-1).
   • Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.

2. Select the Elements category in the Titles and Generators sidebar, locate the Timecode generator, and add it to the timeline as a connected clip, so that it’s over the primary storyline and any other clips or storylines.

   Usually the Timecode generator clip is placed at the start of the project, but you can place it anywhere you want it to appear and adjust its length to match the project’s length.

3. Select the Timecode generator that you added to the timeline.

4. If the Generator inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

5. Click the Generator button at the top of the inspector.

6. In the Generator inspector, adjust the settings for the Timecode generator clip.

   To return the generator to its default settings, click the Reset button.

Add shapes in Final Cut Pro for Mac

You can use the Shapes generator to add a shape—such as a star, a diamond, an arrow, or a heart—above the primary storyline. You can then animate the shape.

1. If the Titles and Generators sidebar isn’t already shown in Final Cut Pro, do one of the following:
   • Choose Window > Go To > Titles and Generators (or press Option-Command-1).
   • Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.

2. Select the Elements category in the Titles and Generators sidebar, locate the Shapes generator, and add it to the timeline as a connected clip, so that it’s over the primary storyline and any other clips or storylines that you want the shape to appear over.

   The default shape is a white circle.

3. Select the Shapes generator that you added to the timeline.

4. If the Generator inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

5. Click the Generator button at the top of the inspector.

6. In the Generator inspector, click the Shape pop-up menu and choose the shape to use, then set the shape’s fill color, outline color and width, and drop shadow.

   To return the generator to its default settings, click the Reset button ⬅️.
7. To change the shape’s size, position, and rotation, use the Transform or Distort built-in effect.

![Transform effect](image)

Using these effects also makes it possible to animate the shape. For example, you can have an arrow follow a person across a room.

8. To make the shape partially transparent, select it in the timeline and adjust its Opacity setting in the Video inspector.

To open the Video inspector, click the Video button at the top of the inspector.

---

### Add backgrounds in Final Cut Pro for Mac

Many of the generators provide a general background over which you can place built-in effects, titles, keys, and clips with an alpha channel. Some backgrounds are solid colors, and others are textures such as wood or stone. Some generators even have animated movement, providing a more interesting background.

1. Drag the playhead in the Final Cut Pro timeline to the point where you want to add the background clip.

2. If the Titles and Generators sidebar isn’t already shown, do one of the following:
   - Choose Window > Go To > Titles and Generators (or press Option-Command-1).
   - Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.

3. In the Generators browser, double-click the background thumbnail you want to use.
4. Do one of the following:
   - **Browse all generators:** Click Generators in the sidebar to display the generators in the browser.
   - **Browse a single category of generators:** Click a category below Generators in the sidebar.
     To view the generators categories, click the Generators disclosure triangle.

5. Select the background clip in the timeline.

6. If the Generator inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

7. Click the Generator button at the top of the inspector.

8. In the Generator inspector, adjust the settings for the background clip (if applicable).

---

**Adjust generators in Final Cut Pro for Mac**

Final Cut Pro provides a variety of generators, such as backgrounds, shapes, objects, and so on. Each type of generator has a unique set of controls that you can adjust.

1. In Final Cut Pro, **add a background**, shape, object, or other generator to the timeline, and select it.

2. Move the playhead over the clip (to see the effect of your changes in the viewer).
3. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

4. Click the Generator button at the top of the inspector.

5. In the Generator inspector, adjust the settings for the background, shape, or object.
   Common settings include:
   - **Color**: Sets the color of the graphic element.
   - **Center**: Sets the position of the graphic element.
   - **Graphics HDR Level**: Some generators include SDR colors or graphic elements. When applied to clips in an HDR project, these elements may look dimmer than the bright areas in the HDR clips, or colors may seem muted relative to the HDR media. You can increase the intensity or vibrancy of these elements by adjusting the Graphics HDR Level slider.
   - **Font**: Sets the font of the text in the generator.

**Modify Final Cut Pro for Mac generators in Motion**

Many of the generators were created using Motion, an Apple app designed to work with Final Cut Pro. To further customize a generator, you can open it in Motion, make modifications, and save the changes as a new file that you can access from the Titles and Generators sidebar.

**Important**: To modify generators in Motion, you must have Motion 5 installed on your computer.

1. If the Titles and Generators sidebar isn’t already shown in Final Cut Pro, do one of the following:
   - Choose Window > Go To > Titles and Generators (or press Option-Command-1).
   - Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.

2. In the Titles and Generators sidebar, click Generators, or click a generators category.
   To view the categories, click the Generators disclosure triangle.
3. In the browser, Control-click a generator thumbnail, then choose “Open a copy in Motion.”

Motion opens, and the clip’s project appears.

4. Modify the clip’s project.

See the Motion User Guide.

5. Choose File > Save As (or press Shift-Command-S), then enter a name for the new generator and click Publish.

If you choose File > Save, the generator is saved using the same name, with “copy” appended to its end.

**Note:** If you have created or customized any Final Cut Pro effects, transitions, titles, or generators in Motion, set the storage location for your Motion content to In Library before starting any copy or move operations between libraries or storage devices. Otherwise, the Motion content is not included in those operations. See Manage Motion content. Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.

**Import Live Drawing animations in Final Cut Pro for Mac**

You can import Live Drawing animations created in Final Cut Pro for iPad.

In Final Cut Pro on your iPad, you can use Live Drawing to annotate timeline clips with Apple Pencil or your finger, to create titles, doodles, and line graphics with a personal flair. Your annotations are recorded as a Live Drawing clip, and when you play back the clip, your pencil or finger strokes are animated with a “draw-on” effect.

After you import a Live Drawing clip into Final Cut Pro on your Mac, you can adjust the speed of the draw-on animation.
**Import a Live Drawing animation**

1. In Final Cut Pro for iPad, create a Live Drawing animation.
   
   See Add hand-drawn annotations to video in the Final Cut Pro User Guide for iPad.

2. Export the project containing the Live Drawing animation from Final Cut Pro for iPad, then import it into Final Cut Pro for Mac.
   
   See Import from Final Cut Pro for iPad.

   To change the speed of the draw-on animation, see Adjust the draw-on speed of a Live Drawing clip, below.

**Adjust the draw-on speed of a Live Drawing clip**

By default, Live Drawing animations are set to draw onscreen in 2 seconds. You can change the draw-on speed to slow down the animation.

1. In Final Cut Pro on your Mac, select a Live Drawing clip in the timeline.

2. If the inspector isn't already shown, do one of the following:
   
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Generator button at the top of the inspector.

4. In the Generator inspector, drag the Draw On slider (or use the value slider) to set a new draw-on time.
Use onscreen controls

Intro to onscreen controls in Final Cut Pro for Mac

Many effects, transitions, and other items use onscreen controls, superimposed over the video in the viewer, to make it easier to adjust a variety of parameters. In many cases, these onscreen controls duplicate controls in the inspectors, although in some cases the controls are unique and provide the only way to adjust a particular parameter.

The controls can be as simple as defining the center of a fisheye effect or as complex as defining the diameter, width, and position of a vignette effect.

This section focuses on the types of onscreen controls found in clip effects and transitions. Onscreen controls are also available in other areas of Final Cut Pro, including the following:

- *Built-in effects:* Onscreen controls are used extensively for all built-in effects. See Intro to built-in effects.
- *Chroma keying:* You use specialized onscreen controls when configuring a chroma keyer. See Use the Green Screen Keyer effect.
- *Color corrections:* Color corrections can contain onscreen controls used for creating color masks and shape masks. See Intro to color correction effects.

Show onscreen controls in Final Cut Pro for Mac

The onscreen controls for transitions appear when a transition is selected. The onscreen controls for clip effects appear when an effect is selected, or when the playhead is positioned over a clip or title in the timeline that has a video effect applied. You can also show or hide the onscreen controls.

*Note:* Onscreen controls are always hidden when you play clips in the timeline.

Show or hide a transition’s onscreen controls

In Final Cut Pro, do one of the following:

- *Show the transition’s onscreen controls:* Select the transition in the timeline.
- *Hide the transition’s onscreen controls:* Deselect the transition in the timeline.

Show or hide a clip effect’s onscreen controls

In Final Cut Pro, do one of the following:

- *Show the effect’s onscreen controls:* Position the playhead over a clip with the effect, or select the clip with the effect in the timeline, then select the effect in either the Video Animation editor or the Video inspector.
- *Hide the effect’s onscreen controls:* Deselect the clip with the effect in the timeline, or deselect the effect in the Video Animation editor or Video inspector.

*Note:* If a clip contains multiple effects that use onscreen controls, only the topmost effect’s onscreen controls appear when the playhead is positioned over the clip.
Onscreen control examples in Final Cut Pro for Mac

Following are a few examples of the onscreen controls you might use while working with clip effects and transitions. Many other clip effects and transitions use the same or similar controls—these examples are intended to provide general information about using the onscreen controls.

Keep the following in mind while going through these examples:

- The examples assume that you're familiar with applying clip effects to clips in the timeline.
- You can apply multiple clip effects to the same clip, but for the purpose of these examples, it’s best to either apply each clip effect to a different timeline clip or remove the clip effect before applying a different one.
- These examples also assume that you're familiar with adding transitions to edit points in the timeline.
- Most of the effects and transitions have additional adjustments in the Video inspector or Transition inspector.

Example: Apply a Censor effect

1. In Final Cut Pro, open the Effects browser and drag the Censor effect to a clip in the timeline.
2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To adjust the effect’s onscreen controls, do any of the following:
   - Position the effect: Drag the center circle.
   - Set the effect’s size: Drag the outer circle.
Example: Apply a Droplet effect

1. In Final Cut Pro, open the Effects browser and drag the Droplet effect to a clip in the timeline.
2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
3. To adjust the effect’s onscreen controls, do any of the following:
   • **Position the effect**: Drag the center circle.
   • **Set the effect’s outer limit**: Drag the outer circle.
   • **Set the effect’s inner limit**: Drag the inner circle.
   • **Set the effect’s overall size**: Drag any area in between the inner and outer circles. A shaded area appears when the pointer is in this area.
Example: Apply a Prism effect

1. In Final Cut Pro, open the Effects browser and drag the Prism effect to a clip in the timeline.

2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.

3. To adjust the direction of the effect, drag the arrow.

   Because the effect has no center setting, the circle in the center can't be dragged.
Example: Apply a Scrape effect

1. In Final Cut Pro, open the Effects browser and drag the Scrape effect to a clip in the timeline.

2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.

3. To adjust the effect's onscreen controls, do any of the following:
   - *Position the effect:* Drag the center circle.
   - *Set the effect's direction:* Drag the rotation handle.
**Example: Apply a Center transition**

1. In Final Cut Pro, open the Transitions browser and drag the Center transition to an edit point in the timeline.

2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.

3. To adjust the transition's onscreen controls, do any of the following:
   - *Position the transition*: Drag the center circle.
   - *Set the transition's direction*: Drag the arrow.
   - *Set the transition's border width*: Drag the outer handle toward or away from the center circle.
**Example: Apply a Star transition**

1. In Final Cut Pro, open the Transitions browser and drag the Star transition to an edit point in the timeline.

2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.

3. To adjust the transition's onscreen controls, do any of the following:
   - *Position the transition:* Drag the center circle.
   - *Set the number of points on the star:* Drag the longer handle.
   - *Rotate the star:* Drag the shorter handle.
Example: Apply a Zoom & Pan transition

1. In Final Cut Pro, open the Transitions browser and drag the Zoom & Pan transition to an edit point in the timeline.

2. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.

3. To adjust the transition's onscreen controls, do any of the following:
   • *Set the transition’s start point:* Drag the green circle.
   • *Set the transition’s end point:* Drag the red circle.
Animate video effects

Intro to video keyframing in Final Cut Pro for Mac

In Final Cut Pro, you can create simple changes to video over time, such as fading the video from invisible to visible at the beginning of a movie. Or you can make sophisticated and precise adjustments over time to many individual parameters of video effects, transitions, motion paths, and so on.

You use keyframes and fade handles in the Video Animation editor to change effects over time.

The word *keyframe* comes from the traditional workflow in the animation industry, where only important (key) frames of an animated sequence were drawn to sketch a character’s motion over time. After the keyframes were determined, an in-between artist drew all the frames between the keyframes.

With Final Cut Pro, you can set parameters to specific values at specific times (represented by keyframes) and Final Cut Pro acts as an automatic, real-time in-between artist, calculating all the values between your keyframes. For example, to animate a parameter, such as a rotation or scale setting, you need to create at least two keyframes in the clip. Final Cut Pro calculates the setting’s value between the keyframes, creating a smooth motion as the setting changes.

You can keyframe and animate both video and audio effects in Final Cut Pro, including individual effect parameters and clip properties. To learn about keyframing audio, see [Keyframe audio effects](#).

Add video effect keyframes in Final Cut Pro for Mac

You place keyframes at specific points in a clip to change parameter values at those points.

For example, if you want a clip in your project to fade to black, you set two opacity keyframes at two different times: one with the value of 100 (fully visible) and a second with the value of 0 (fully transparent). Final Cut Pro interpolates the values between 100 and 0, creating a smooth fade to black.

You can set keyframes in the timeline or in the Video inspector. To see keyframes in the timeline, you need to display the Video Animation editor for the clip.

Additional keyframing controls appear with the Final Cut Pro built-in effects. See [Work with built-in effects](#).

To learn about keyframing audio clips, see [Keyframe audio effects](#).
Add keyframes

1. In Final Cut Pro, do one of the following:
   - Select a clip in the timeline, then choose Clip > Show Video Animation (or press Control-V).
   - Control-click a clip in the timeline and choose Show Video Animation.

   Each effect in the Video Animation editor has a separate area for adding keyframes.

2. In either the Video Animation editor or the Effects section of the Video inspector, select the effect or effect parameter for which you want to add keyframes.

3. Do one of the following:
   - See expanded parameters in the Video Animation editor: Click the down arrow next to the effect and choose an individual parameter from the pop-up menu, or choose All to add keyframes for all parameters.
   - See expanded parameters in the Video inspector: Position the pointer over the effect and click Show.
4. Do one of the following for each effect:

- **In the Video Animation editor:** Option-click (or press Option-K) at a point on the horizontal effect control where you want to add the keyframe.

  Keyframes for the parameter you chose appear as white diamonds; keyframes for other effect parameters appear gray.

  ![Keyframe for the selected parameter](image)

  When you choose to view all parameters in the Video Animation editor, keyframes appear as white diamonds for all parameters. Double diamonds indicate that you added a keyframe for more than one parameter at that point.

  ![Double diamonds](image)

- **In the Video inspector:** Position the playhead in the timeline at the point where you want to add a keyframe, then click the Keyframe button (or press Option-K).

  ![Click the Keyframe button.](image)

  After you add a keyframe, the Keyframe button becomes solid, indicating that the playhead is currently on this keyframe.

  ![Keyframe button after a keyframe is added](image)

  When you move the playhead in the timeline, arrows appear next to the Keyframe button in the Video inspector to indicate which side of the playhead has keyframes. To go to the previous keyframe, click the left arrow. To go to the next keyframe, click the right arrow.

  ![Arrows](image)

5. Add keyframes as needed.

  ℹ️ **Tip:** After you've added one keyframe, you can add another automatically by moving the playhead in the timeline and then adjusting the effect parameter value in the Video inspector.
Add keyframes automatically across a selected area

If an effect appears in the Video Animation editor with a disclosure button, you can use either the Select or Range Selection tool to add keyframes automatically across a selected area.

1. In Final Cut Pro, do one of the following:
   - Select a clip in the timeline, then choose Clip > Show Video Animation (or press Control-V).
   - Control-click a clip and choose Show Video Animation.

2. Select an effect, then click the disclosure button to expand it in the Video Animation editor.

3. Click the Tools pop-up menu in the top-left corner of the timeline, then choose either Select or Range Selection (or press A for Select, or R for Range Selection).
4. Drag across the area in the Video Animation editor where you want to adjust the effect.

⚠️ Tip: To deselect the range, click anywhere in the timeline background.

5. Adjust the effect within the range by dragging the effect’s horizontal control up or down.

Keyframes are automatically created along the adjustment points within the range.
Adjust keyframes in the Video Animation editor

You can move keyframes left or right in the Video Animation editor.

If an effect appears with a disclosure button in the Video Animation editor, you can expand the effect view and move keyframes up or down to change the parameter value, and you can also fade video effects in or out or change the shape of the effect curve between keyframes. See Adjust effect curves.

1. Select a keyframe in the Final Cut Pro Video Animation editor.
2. Do any of the following:
   - **Change a keyframe’s position in time**: Drag a keyframe left or right.
     As you drag, the timecode value appears.

   ![Drag keyframe left or right](image)

   - **Change a keyframe’s parameter value**: Drag the keyframe up or down.
     If an effect appears with a disclosure button, click the button (or double-click the effect) to expand it.

   ![Drag keyframe up or down](image)

   - **Add another keyframe**: Option-click (or press Option-K) at a point on the effect control where you want to add the keyframe.
   - **Add a keyframe and change the effect’s parameter value at the same time**: Option-click while dragging the effect control up or down.
Adjust keyframes in the Video inspector
For many effects, you adjust the parameter value of individual keyframes using the Video inspector.

When you move the playhead in the timeline, arrows appear next to the Keyframe button in the Video inspector to indicate which side of the playhead has keyframes.

To go to the previous keyframe, click the left arrow. To go to the next keyframe, click the right arrow. Or, to use keyboard shortcuts, select the parameter in the Video Animation editor, then press Option-Semicolon (;) to go to the previous keyframe or Option-Apostrophe (‘) to go to the next keyframe.

1. If the Video inspector isn’t already shown in Final Cut Pro, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

2. Click the Video button at the top of the inspector.

3. Select a keyframe or position the playhead on a keyframe, then adjust the parameter value in the Video inspector.

4. To change the value at the next keyframe, go to the next keyframe, then adjust the value in the Video inspector.

Delete keyframes
In Final Cut Pro, do one of the following:

• Select a keyframe in the Video Animation editor, then press Option-Shift-Delete.
• Navigate to a keyframe in the Video inspector, then click the Keyframe button.
View only one effect at a time in the Video Animation editor
You can collapse the Video Animation editor to view only one effect at a time. This can be useful if you have multiple effects applied to a clip and want to preserve screen space.

1. In Final Cut Pro, choose Clip > Solo Animation (or press Control-Shift-V).
2. In the Video Animation editor, click the triangle next to the displayed effect’s name and choose an effect.

Note: When Solo Animation is turned on, you can’t delete effects from the Video Animation editor.

To turn off Solo Animation, choose Clip > Solo Animation (or press Control-Shift-V).

Hide video animation for a clip
In Final Cut Pro, do one of the following:
- Select the clip in the timeline, then choose Clip > Hide Video Animation (or press Control-V).
- Click the close button 🗔️ in the top-left corner of the Video Animation editor.
- Control-click the clip in the timeline and choose Hide Video Animation.

Modify groups of keyframes in Final Cut Pro for Mac
There are many ways you can modify keyframes to create simple or complex animations. In addition to modifying individual keyframes, you can also modify keyframe groups, effect curves (the line segments between keyframes), or the entire set of keyframes for a given parameter. You can make all of these changes with great precision.

Select and modify multiple keyframes
You can select and modify multiple keyframes in the Video Animation or Audio Animation editor, or directly in the body of a clip (for audio level keyframes).

1. In Final Cut Pro, do one of the following:
   - Shift-click more than one keyframe. All intermediate keyframes are selected. You can’t select nonadjacent keyframes.
   - Drag a selection rectangle around the keyframes you want to select.

⚠️ Tip: In the Video Animation or Audio Animation editor, you can select a range by dragging with the Select tool or the Range Selection tool. To select a range of keyframes displayed in the clip body (such as audio keyframes) you must use the Range Selection tool.
2. To modify the selected keyframes, do any of the following:
   - Move the group to a different place in time: Drag any individual keyframe horizontally.
   - Change the value of all the keyframes: Drag any individual keyframe vertically.
     Keyframe values remain relative to one another while you drag; however, if you "flatten" the curve by dragging all the way to the top or bottom of the graph, the keyframe values remain in that flattened state, with all keyframes sharing the same value.
   - Increase the relative values by 1: Press Option-Up Arrow.
   - Decrease the relative values by 1: Press Option-Down Arrow.
   - Move the keyframes earlier in time by 1 frame: Press Comma (,).
   - Move the keyframes later in time by 1 frame: Press Period (.)

   Tip: You can also modify any two keyframes simultaneously by selecting the line segment between them and then performing any of the steps above.

Adjust all keyframes on a curve

You can adjust all keyframes on a curve at once in the Video Animation or Audio Animation editor, or directly in the body of a clip (for audio level keyframes).

   - In Final Cut Pro, hold down the Command and Option keys, then drag either a keyframe or a curve up or down.

   All keyframes are adjusted by the same amount, preserving the original shape of the curve. However, if you “flatten” the curve by dragging all the way to the top or bottom of the graph, the keyframe values remain in that flattened state, with all keyframes sharing the same value.

   ![Before and After](image)

You can also copy specific keyframes between different attributes or between different clips. See Copy and paste keyframes.
Adjust effect curves in Final Cut Pro for Mac

Some effects in the Video Animation editor include fade handles, which allow you to adjust how long it takes for an effect to fade in or out. For example, you can use fade handles to adjust how long it takes for an opacity effect to fade in, how long it takes to fade up from black, or how long it takes to fade to black.

You can also move keyframes up or down to create a curve for the effect parameter and change the curve shape (interpolation) between keyframes.

Creating a fade or an effect curve smooths the transition so that the effect changes appear more natural when the clip plays.

Change an effect using fade handles

1. In the Final Cut Pro Video Animation editor, click the disclosure button for an effect to expand it.

   ![Disclosure button](image)

   *Note: If an effect doesn't have a disclosure button, it doesn't have fade handles.*

2. Drag the fade handle to the point in the clip where you want the fade to begin or end.

   ![Fade handles](image)

   Fade handles from the beginning of a clip create a fade-in, and fade handles at the end of a clip create a fade-out.
Change an effect using keyframes

1. In the Final Cut Pro Video Animation editor, click the disclosure button for an effect to expand it.

```
In the Final Cut Pro Video Animation editor, click the disclosure button for an effect to expand it.
```

**Note:** If an effect doesn't have a disclosure button, you can't move keyframes up or down.

2. Do any of the following:
   - **Add a keyframe:** Option-click (or press Option-K) at a point on the effect control where you want to add the keyframe.
     - **Tip:** To add a keyframe and change the effect's parameter value at the same time, Option-click while dragging the effect control up or down.
   - **Change the effect's parameter value at a particular keyframe:** Select a keyframe and drag it up or down.
     - **Tip:** To adjust values with greater precision, hold down the Command key while dragging the keyframe up or down.

```
Add a keyframe: Option-click (or press Option-K) at a point on the effect control where you want to add the keyframe.
Change the effect's parameter value at a particular keyframe: Select a keyframe and drag it up or down.
```

Change the curve shape (interpolation) between keyframes

1. In the Final Cut Pro Video Animation editor, click the disclosure button for an effect to expand it.

   **Note:** If an effect doesn't have a disclosure button, you can't move keyframes up or down.

2. Command-drag the line horizontally between the keyframes to create a curve.

```
Change the curve shape (interpolation) between keyframes
```

```
3. Control-click the line between keyframes and choose a curve option.

- **Linear**: Maintains a constant rate of change over the duration of the fade.
- **Ease**: Eases in and out of the fade with the midpoint set between the beginning and end values.
- **Ease In**: Starts slowly from the beginning value and then accelerates toward the end value.
- **Ease Out**: Starts quickly from the beginning value and then decelerates toward the end value.

*Note*: You can change the curve shape between keyframes for video effects only. For audio volume only, you can change the curve shape for fades created using fade handles, but not keyframes. See [Fade audio in and out](#).
Advanced editing

Use roles to manage clips and organize the timeline

Intro to roles in Final Cut Pro for Mac

*Roles* are metadata text and color labels that you assign to clips in the browser or the timeline. When you import clips (video, audio, or still images), Final Cut Pro analyzes existing clip metadata and automatically assigns one of five default color-coded roles (Video, Titles, Dialogue, Music, and Effects) to each clip. For example, if a source media file has a Music “genre” metadata tag, Final Cut Pro assigns a green Music role to the imported clip.

You can use roles to organize clips in your events and projects by function or category, control the arrangement of the timeline, and export separate video or audio files (also known as media stems) for distribution, broadcast, audio mixing, or post-production. Because roles are color-coded, you can instantly recognize clips of the same role in the browser and the timeline. You can also highlight particular roles in the timeline.
You can use roles in the following ways:

- **Organize clips with roles and subroles:** You can create subroles within a role to further organize your clips, and you can create custom roles to add to the default set. To get the maximum benefit from roles (including organizing the timeline or exporting media stems), make sure your clips have the correct role assignments early in the editing process. See View and reassign roles and Create custom roles. With iXML metadata, you can also create custom roles automatically during import.

- **Organize the timeline with roles:** With a few clicks, you can organize the timeline with “lanes,” in which all clips in the same role appear together in a separate layer of the timeline. See Organize the timeline with audio lanes. You can also display and edit audio components for entire roles and focus the timeline display on a specific role.

- **Export media stems:** A powerful benefit of roles is the ease with which you can export roles as separate files (media stems). This process is often used when delivering stems to match broadcast specifications or when handing off stems for mixing or post-production. You can export roles as media stems in a combined, multitrack QuickTime file or as separate audio or video files. See Share roles as files.

- **Create and manage captions:** Final Cut Pro features dedicated roles and subroles for adding, editing, and sharing captions (including subtitles and closed captions). See Intro to captions.

For detailed information about advanced uses of audio roles, see Audio Roles in Final Cut Pro.

**Guidelines for using roles in Final Cut Pro for Mac**

Keep the following in mind when using roles:

- Every clip component must have an assigned subrole (clips with audio and video always have one audio and one video role). Still images are assigned the Video role by default, but you can create a custom role for still images. You can also create caption roles—for example, for subtitles and closed captions—with subroles for different language versions.

  Note: A role is a category; each role contains at least one subrole. What actually happens when a role is assigned to a clip is that a subrole within the role is assigned to a component within the clip.

- Video roles can’t be assigned to audio-only clips, and audio roles can’t be assigned to video-only clips.

- Roles (specifically, subroles) can be assigned to audio or video components of a clip but can’t be assigned to a clip range, or portion of a clip.

- You can assign different roles to each instance of a standard clip. For example, if you add a clip from the browser to the timeline, copy clips between events, or copy clips within the timeline, each of these clip instances is independent of the others.

- Custom roles and subroles are specific to a library. This means that a custom role that you create for one library is not automatically available in another library. However, if you copy or move clips between libraries, any custom roles and subroles assigned to those clips are also available in the destination library.
• Changing a role within a compound clip or multicam clip affects every instance of that clip throughout the library.

• When you import clips, Final Cut Pro automatically assigns unique subroles to each audio component in a clip. You can manually assign the same subrole to multiple components in a clip, but this will cause those components to be consolidated (in the same subrole) if you place the clip inside a compound clip, multicam clip, or synced clip.

View and reassign roles in Final Cut Pro for Mac

When you import clips (video, audio, or still images), Final Cut Pro analyzes existing clip metadata and automatically assigns roles to each clip. Specifically, Final Cut Pro assigns subroles to the video and audio components in each clip.

There are many ways to view and change the default role and subrole assignments. Proper role assignment is the key to organizing the timeline with audio lanes and using roles to export media stems.

Note: You can also create and assign custom roles and subroles. See Create custom roles.

Assign audio roles in the Audio inspector

1. In the Final Cut Pro browser or timeline, select a clip containing audio.

2. If the inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

3. Click the Audio button at the top of the inspector.

Tip: Double-click the top bar of the Audio inspector to switch between half-height view and full-height view.
4. Scroll down to the Audio Configuration section.

   Note: You can drag the top edge of the Audio Configuration section to reveal all of its contents.

5. To change the role assignment for an audio component, click its Roles pop-up menu and choose a different subrole.

   ![Roles pop-up menu](image)

   For more information about audio components, see Audio channels and components.

**Assign roles using the shortcut menu**

1. Select one or more clips in the Final Cut Pro browser or timeline.

2. Control-click the selection and choose either Assign Audio Roles or Assign Video Roles, then choose a subrole from the submenu.

   A checkmark appears next to the subrole you chose.

**Assign roles using the Modify menu**

1. Select one or more clips in the Final Cut Pro browser or timeline.

2. Choose Modify > Assign Audio Roles or Modify > Assign Video Roles, then choose a subrole from the submenu.

   A checkmark appears next to the subrole you chose.
Assign roles in the browser
1. In the Final Cut Pro browser in list view, select one or more clips.
2. In the Roles column, click the assigned subrole for a clip to see a menu listing the available subroles.

If the Roles column isn’t visible in the browser, Control-click a column heading and choose Roles.
3. To change the role assignment for the selection, choose a different subrole from the menu.

Assign roles in the Info inspector
1. Select one or more clips in the Final Cut Pro browser or timeline.
2. Do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Info button at the top of the inspector.
4. In the Info inspector, click the Video Roles or Audio Roles pop-up menu to see the available subroles.

5. To change the role assignment for the selection, choose a different subrole from the Video Roles or Audio Roles pop-up menu.

**Assign roles in the timeline index**

1. To open the timeline index in Final Cut Pro, click Index in the top-left corner of the timeline (or press Shift-Command-2).
2. Click the Clips button at the top of the timeline index to open the Clips pane.
3. If the roles columns aren’t visible in the Clips pane, Control-click a column heading and choose either Video Roles or Audio Roles.
4. Select one or more clips in the Clips pane.
5. To change the role assignment for the selection, click the assigned subrole and choose a different subrole.

Note: If you change a clip’s role assignment while audio lanes are shown in the timeline, the clip moves vertically in the timeline to its new audio lane. See Organize the timeline with audio lanes.

Create custom roles in Final Cut Pro for Mac

You can create custom roles and subroles in addition to the five default roles (Video, Titles, Dialogue, Music, and Effects). For example, you might create a separate Dialogue subrole for each actor (or microphone) in your video project, so that you can quickly find and adjust all the clips with that subrole.

You can also use custom roles and subroles to create different language versions of a project, so you can export a version of the project with titles, captions, and narration in each language. For example, you could organize voiceover narration clips into a separate audio lane in the timeline by first creating a custom Voiceover role and then assigning subroles (one for each language) to your voiceover narration clips.

Note: Custom roles and subroles are specific to a library. This means that a custom role that you create for one library is not automatically available in another library. However, if you copy or move clips between libraries, any custom roles and subroles assigned to those clips are also available in the destination library.
Create custom roles

1. To open the role editor in Final Cut Pro, do one of the following:
   - Choose Modify > Edit Roles.
   - In the Roles pane of the timeline index, click Edit Roles.
   - Control-click a clip and choose either Assign Audio Roles or Assign Video Roles, then choose Edit Roles from the submenu.
   - With a clip selected in the browser or the timeline, open the Info inspector, then click either the Video Roles pop-up menu or the Audio Roles pop-up menu and choose Edit Roles.

2. Do one of the following:
   - *Create a video role:* Click the Add Video Role button at the top of the Video Roles section.
   - *Create an audio role:* Click the Add Audio Role button at the top of the Audio Roles section.

The new role appears at the bottom of the section and contains a default subrole with the same name. New roles are automatically assigned a distinct color. To change the color, see Change role colors or names.

3. Type a name for the new role.

After you create a new role, it appears in the roles list so that you can assign its subroles to any clip.
Create custom subroles

Subroles allow you to organize clips and components within a role. For example, you could create a Foley Effects subrole within the Effects role, or a Spanish Subtitles subrole within the Titles role.

1. To open the role editor in Final Cut Pro, do one of the following:
   - Choose Modify > Edit Roles.
   - Control-click a clip and choose either Assign Audio Roles or Assign Video Roles, then choose Edit Roles from the submenu.
   - In the Roles pane of the timeline index, click Edit Roles.
   - With a clip selected in the browser or the timeline, open the Info inspector, then click either the Video Roles pop-up menu or the Audio Roles pop-up menu and choose Edit Roles.

2. In the role editor, move the pointer over one of the roles and click the Add Subrole button.

The new subrole appears in the list below the role.
3. Type a name for the new subrole.

The new subrole appears below its parent role in roles lists throughout Final Cut Pro. When you assign subroles to clips in the timeline, the subroles also appear in the timeline index.

![Subroles](image)

**Change the name of a custom role or subrole**

1. In the role editor in Final Cut Pro, move the pointer over the name of a custom role or subrole.

   To show subroles, click Show to the right of the role name.

![Role Editor](image)

2. Select the name of the role or subrole, then enter the new name.

**Delete a custom role or subrole**

**Important:** Deleting a role or subrole may update existing edits, which can cause changes to your project’s audio. For example, deleting a custom subrole causes components with that subrole assignment to revert to a default subrole.

1. In Final Cut Pro, open the role editor.

2. In the role editor, move the pointer over the name of a custom role or subrole, then click the Delete button that appears to the left of the role name.

![Delete Button](image)

   To show subroles, click Show Subroles to the right of the role name.

The role or subrole is removed from the list. Any clips that had the role or subrole assigned revert to their default roles and subroles.
Merge custom subroles
You can merge a subrole with another subrole (in any role in your library). Any clips in the library that were assigned the original subrole are assigned the merged subrole instead.

1. In Final Cut Pro, open the role editor.
2. Move the pointer over the role with the subroles you want to merge, then click Show Subroles.
3. Move the pointer over one of the subroles you want to merge.
   A handle (three horizontal lines) appears at the right end of the subrole.
4. Use the handle to drag the subrole to the subrole you want to merge it with.

![Subrole merge example]

The subroles are merged into one subrole. The existing role assignments of the source subrole change to the target subrole across every clip in the library.

Move a subrole to another role
You can move a subrole from one role to another. All of the existing assignments of the subrole in the library are maintained but are updated to show the new parent role.

1. In Final Cut Pro, open the role editor.
2. Move the pointer over the role that contains the subrole you want to move, then click Show.
3. Move the pointer over the subrole you want to move.
   A handle (three horizontal lines) appears at the right end of the subrole.
4. Use the handle to drag the subrole to the role you want to move it to.

![Subrole move example]

For the most precise and powerful audio editing, you can also display all subroles for one or more roles.
Assign audio roles during import in Final Cut Pro for Mac

By default, when you import media clips (video, audio, or still images), Final Cut Pro analyzes existing clip metadata to assign one of five default roles to the video and audio components of each clip: Video, Titles, Dialogue, Music, or Effects. (Specifically, Final Cut Pro assigns a subrole of one of the default roles to each video or audio component.)

You can adjust the assignment of audio roles on import in two ways: by setting the role assignment manually or by having Final Cut Pro create custom roles automatically while importing media files with iXML metadata.

Override automatic role assignment for audio files during import

For any given import session, you can override the automatic role assignment process so that every imported audio component is assigned a role of your choosing. You can specify one of the three default audio roles or a custom role that you create. When you import with this setting enabled, Final Cut Pro assigns a unique subrole (from the role you specify) to every component in each clip.

For example, imagine that you’ve recorded several hundred natural sound files for use as Foley sound effects in your video project. By default, Final Cut Pro assigns the Dialogue role to natural sound recordings (with no additional metadata). Instead, you could assign the more appropriate Effects role to every clip in the import session.

1. To open the Import pane of Final Cut Pro settings, choose Final Cut Pro > Settings (or press Command-Comma), then click Import.

2. In the Audio Roles section, click the Assign Role pop-up menu and choose a role.

   *Note:* The Assign Role pop-up menu also appears in the Audio Roles section on the right side of the Media Import window. All default and custom audio roles appear in this pop-up menu. For information about creating custom roles and subroles, see [Create custom roles](#).

3. Import the files.

   The role you chose is assigned to the imported clips. (More precisely, components in the imported clips are assigned subroles of the role you chose.)

You can change this and any other import settings in the Media Import window or the Import pane of Final Cut Pro settings. To revert to the default setting, so that roles are assigned automatically when you import clips, click the Assign Role pop-up menu and choose Automatically.
Create custom roles automatically during import using iXML metadata

Final Cut Pro can use the iXML metadata tags in an audio channel to create custom subroles and assign them to audio components during import.

For example, during production, a sound recordist might enter “Boom mic” and “Jessie lav mic” on the recording device to identify the audio channels of a recording. During import, Final Cut Pro can use the iXML names to create subroles named “Boom mic” and “Jessie lav mic” and assign them to the corresponding audio components in the imported clips.

1. Configure your recording device so that your recordings include iXML data.
   See the documentation that came with your recording device.

2. On the device, enter the role name for each audio channel that should be assigned a role, then make your recordings.

3. To set Final Cut Pro to create roles automatically during import, choose Final Cut Pro > Settings (or press Command-Comma), click Import, then make sure the “Assign iXML track names if available” checkbox is selected in the Audio Roles section.
   Note: The “Assign iXML track names if available” checkbox also appears in the Audio Roles section on the right side of the Media Import window.

4. Import the files that include iXML metadata.
   Final Cut Pro creates subroles with the names you entered in step 2 and assigns the subroles to the corresponding components in the imported clips.

⚠️ Tip: You can use the manual override setting and the iXML method together. For example, if role override is set to a custom role named Location Sound and “Assign iXML track names if available” is selected, imported clips will be assigned the Location Sound role, and subroles will be created from the iXML track names and assigned to the corresponding audio components. All of this occurs automatically on import, and the setting is retained for future import operations.

Change role colors or names in Final Cut Pro for Mac

Roles have distinct colors that let you instantly recognize clips by role in the browser and the timeline. You can change the color of a role and, by extension, the color of the clips it’s assigned to.

You can also rename roles and subroles, within certain basic guidelines.

⚠️ Note: By default, clips with video and audio take the color of the audio role, but you can expand the clips to show video role colors separately. See Show video role colors.
Change a role’s color
1. In the Final Cut Pro role editor, move the pointer over a role, then click the Change Color button to the right of the role name.

2. Click the new color for the role.
All the clips assigned that role display the new color in the timeline and the browser.

Rename a role or a subrole
• In the Final Cut Pro role editor, select the name of a role or subrole and type a new name.

Keep the following in mind when renaming roles or subroles:
• You can rename custom roles or any subrole, but you can’t rename the default roles (Titles, Video, Dialogue, Effects, Music, and Mixed Audio). You also can’t rename a role or subrole using one of the default role names.
• Renaming a role also renames its default subroles throughout a library, but not custom subroles that you created.
• Renaming a subrole updates every clip using that subrole in the library.

Display roles and subroles in the timeline

Organize the timeline with audio lanes in Final Cut Pro for Mac
With a few clicks, you can arrange audio clips into audio lanes in the timeline, based on their role assignments. Audio lanes appear as separate, visually distinct layers in the timeline. This view organizes audio clips visually and provides reference points that make editing easier and more efficient.
Organizing the timeline in this way does not affect the content of your project or how it plays back in the viewer—it simply adjusts the timeline appearance for your editing convenience.

![Image of timeline with roles](image)

**Note:** When you display audio roles in separate lanes in the timeline, any clips that contain both audio and video are expanded to show audio and video separately. If the video portions of clips have custom roles assigned, the distinct video role colors appear in the expanded view.

1. In Final Cut Pro, open the Roles pane of the timeline index by doing one of the following:
   - Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles at the top of the timeline index.
   - Choose View > Timeline Index > Roles.
2. Do one of the following:
   - **Show an audio role in a separate lane:** In the Roles pane, click the Audio Lane button to the right of a role.
     Audio clips with that role assigned appear in a separate lane in the timeline. A text label appears at the left side of the lane in the timeline, identifying the role.

![Image of audio lane](image)

Repeat this step for each role that you want to show in a separate lane.
• **Show all audio roles in separate lanes:** Click Show Audio Lanes at the bottom of the timeline index.

Separate lanes appear in the timeline for each role, with audio clips in the lanes of their assigned roles. A text label appears at the left side of each audio lane, identifying the role.

The lanes in the timeline appear in the order you define in the timeline index. See [Reorder audio roles](#).

To help you keep track of the current timeline organization, a diamond-shaped change indicator appears in the Index button in the top-left corner of the timeline whenever you change any roles settings from their default states. These roles changes include showing roles and subroles in separate audio lanes, focusing the timeline on a specific role, and turning off roles or subroles.

*Note:* You can also customize the display of clips in the timeline by changing the clip appearance and height, and you can choose whether to view clips by name or role. See [Adjust timeline clip appearance](#).
Show audio components in audio lanes in Final Cut Pro for Mac

By default, audio clips in the timeline are represented by a single audio waveform. You can expand the audio portion of any clip to view and edit audio components down to the individual channel level.

You can also display all audio components in audio lanes, organized by roles and subroles. This view provides precise control over all the audio elements in your project. The components remain in their dedicated lanes, even when you trim overlaps. For any lane, you can switch between the audio component view and the default view with a single click.

1. To open the Roles pane of the timeline index in Final Cut Pro, do one of the following:
   • Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles at the top of the timeline index.
   • Choose View > Timeline Index > Roles.

2. In the Roles pane, click the Show Subroles button for each role whose components you want to show.

Separate audio lanes appear in the timeline for each subrole in the role or roles. Text labels appear at the left side of the audio lanes, identifying each role and subrole. In the timeline index, subroles appear in a list below the parent role.

To return to the default clip view for a role, click the role’s Show Subroles button again.

Tip: When audio components are shown in audio lanes, you can make roll edits between adjacent components. You don’t need to create a connected storyline.
Focus the timeline on an audio role in Final Cut Pro for Mac

When you need to focus on clips in a particular audio role, you can use the Focus button in the timeline index to make more space to view and work with those clips in the timeline. Clips assigned to other audio roles are minimized and appear smaller in the timeline.

For example, imagine that you’ve finished the video editing on your project and are ready to enhance the project with sound effects. You can click the Focus button in the Effects role to temporarily remove the clutter and distractions caused by clips from other roles, allowing you to zero in on the effects clips.

Focusing the timeline in this way does not affect the content of your project or how it plays back in the viewer—it simply adjusts the timeline appearance for your editing convenience.

1. To open the Roles pane of the timeline index in Final Cut Pro, do one of the following:
   - Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles at the top of the timeline index.
   - Choose View > Timeline Index > Roles.

2. In the Roles pane, click the Focus button ☰ for the audio role whose clips you want to concentrate on.

⚠️ Tip: It can be helpful to move the role you’re editing closer to the primary storyline (to more easily align and sync audio edits with video edit points). See Reorder audio roles.
Reorder audio roles in Final Cut Pro for Mac

By default, Final Cut Pro shows audio roles in the following order in the timeline: Dialogue, Music, and Effects. However, there are times when you may want to view audio roles in a different order. For example, when you've finished the video editing on your project, you might want to move a role you're editing (such as Effects) closer to the primary storyline to more easily align and sync audio edits with video edit points.

You can reorder the default roles and subroles as well as any custom ones you create.

1. To open the Roles pane of the timeline index in Final Cut Pro, do one of the following:
   - Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles.
   - Choose View > Timeline Index > Roles.
2. To reorder roles or subroles, drag them up or down in the Roles pane.
   For information about viewing subroles, see Show audio components in audio lanes.

As you drag a role or subrole in the timeline index, clips in the timeline with that role or subrole assigned move up or down to match the new order.

Show video role colors in Final Cut Pro for Mac

You can display video role colors in the timeline to see different types of footage at a glance.

By default, video clips are assigned the Video role and the Dialogue role and appear in blue. You can create custom video roles with distinct colors—for example, to identify different individuals speaking in a documentary.
To see custom video role colors in the timeline, you must expand the clips so that video and audio are shown separately.

You can also display video role colors on the outside of synced clips, auditions, multicam angles, and compound clips. If a compound clip contains multiple video roles, it displays a gray role color to indicate mixed roles within.

1. In Final Cut Pro, create one or more custom video roles.
   
   See Create custom roles.

2. Apply a custom video role to one or more timeline clips.
   
   See View and reassign roles.

3. Select the timeline clips, then do one of the following:
   
   • Show expanded audio and video.
   
   • Show expanded audio components.
   
   • In the Roles pane of the timeline index, click Show Audio Lanes.

   The clips are expanded to show video and audio separately, and the distinct colors of the custom video roles appear in the timeline.

**Turn roles on or off in Final Cut Pro for Mac**

You can turn off roles and subroles in the timeline to suspend playback for all clips with those roles assigned. For example, you could turn off all roles except Dialogue to play back only dialogue clips, and then turn on the Music role to listen to the movie soundtrack along with the dialogue.

If you turn off video, audio, or title roles and subroles, those roles are not included in output media files when you share your project. However, if you use the Export File destination or an Apple Devices destination to export a multitrack QuickTime or MXF file, you can use the Roles pane of the Share window to add disabled roles back in during the export process. See Export MXF files and Share roles as files.

Turning roles and subroles on or off does not affect settings in the browser, the timeline, or the inspectors.
1. To open the Roles pane of the timeline index in Final Cut Pro, do one of the following:
   • Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles at the top of the timeline index.
   • Choose View > Timeline Index > Roles.

2. In the Roles pane, select the checkboxes next to the roles or subroles you want to turn on, and deselect the checkboxes next to the roles or subroles you want to turn off.
   For information about viewing subroles, see Show audio components in audio lanes.

3. To preview clips by role, play back your project.
   Only clips with active roles assigned play back.
Work with audio roles in compound clips in Final Cut Pro for Mac

In Final Cut Pro, you can create several different types of clips with varying degrees of complexity. In many cases, clips can have multiple audio components, including the following clip types:

- Compound clips
- Multicam clips
- Synced clips

In Final Cut Pro 10.3, compound clips, multicam clips, and synced clips generate role components based on the audio role assignments within the clip. A role component is like a traditional audio bus—if multiple audio components share the same subrole, their audio is mixed together into a single role component.

Compound clips, multicam clips, and synced clips share some common role-related properties. The main property is that if role assignments within the clip change, the role components are updated automatically.

There are also some important differences between these three clip types:

- Compound clips have one set of role components per clip. A unique property of compound clips is that you have the option to generate role components based on either subroles or roles. When you generate role components based on subroles, a role component is created for each subrole found within the compound clip. When you generate role components based on roles, the subroles in the clip are combined into the role components of their parent roles.

- Multicam clips have one set of role components per angle. Every angle in a multicam clip creates a set of role components according to the subrole assignments contained within the angle.

- Synced clips have one set of role components for the storyline, and another set of role components for connected clips.

You can view role components for compound clips, multicam clips, and synced clips in the Audio Configuration section of the Audio inspector. You can also show expanded audio components in the timeline to work with role components there.

Manage role components in compound clips

You can use role components in compound clips to make changes to an entire role at once. For example, a typical project has clips with various Dialogue subroles assigned, some clips with Effects subroles, and perhaps a clip with a Music subrole. If you wrap the entire project in a compound clip, the resulting compound clip has role components for Dialogue, Music, and Effects. You can apply volume changes and effects to the role components to complete your mix.

You can view the roles of clips and components inside a compound clip, but you can’t assign roles to the compound clip itself.
1. Select a compound clip in the Final Cut Pro browser or timeline.

2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

3. Click the Audio button at the top of the inspector.

   💡 Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. Scroll down to the Audio Configuration section.
   Note: You can drag the top edge of the Audio Configuration section to expand it and reveal all of its contents.

   The Audio Configuration section shows the role components in the compound clip. You can’t change role assignments in this view.

5. To choose whether role components are based on roles or subroles, click the “Show Components as” pop-up menu and choose an option.
When the “View components as” pop-up menu is set to Subroles, as in the example below, each role component is based on a subrole found in the compound clip, not on a parent role.

Note: Changing this view with the pop-up menu also changes how the components are displayed in the timeline when you show expanded audio components for the compound clip.

In many ways, you can work with role components as you would with standard audio components. For example, you can:

- Skim over an individual role, or play it back using the Space bar or the J, K, and L keys. See View and listen to an audio component.

- Remove a role from a compound clip by deselecting its checkbox in the Audio Configuration section of the Audio inspector. See Enable or disable an audio component.

- Show expanded role components in the timeline, then edit them as you would a standard audio component. You can adjust volume, pan audio, add audio effects, and so on.

If you want to assign different roles to specific clips within the compound clip, you can open the compound clip for editing and then assign subroles to individual components of the constituent clips.

For more information about compound clips, see Intro to compound clips.
Manage role components in multicam clips

Every angle in a multicam clip creates a set of role components according to the subrole assignments contained within the angle. For example, if there are five audio components in angle A, but they’re all assigned to the Dialogue-1 subrole, Final Cut Pro displays a single role component named Dialogue-1 for angle A. If the role assignments of clips inside an angle change, the role components generated by that angle are updated automatically.

1. Select a multicam clip in the Final Cut Pro browser or timeline.
2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Audio button at the top of the inspector.
4. Scroll down to the Audio Configuration section.

   Note: You can drag the top edge of the Audio Configuration section to expand it and reveal all of its contents.

The Audio Configuration section shows the role components for the active angle of your multicam clip. Each role component is based on a subrole assigned to a clip in the angle. You can’t change role assignments in this view. However, you can enable or disable the audio from other angles by clicking their respective checkboxes.

As you cut and switch between angles in your multicam clip, the role components are automatically enabled or disabled to match your edits.
In many ways, you can work with role components as you would with standard audio components. For example, you can:

- Skim over an individual role, or play it back using the Space bar or the J, K, and L keys. See View and listen to an audio component.
- Remove a role from a multicam clip by deselecting its checkbox in the Audio Configuration section of the Audio inspector. See Enable or disable an audio component.
- Show expanded role components in the timeline, then edit them as you would a standard audio component. You can adjust volume, pan audio, add audio effects, and so on.

If you want to assign different roles to specific clips within the multicam clip, you can open the clip in the angle editor and then assign subroles to individual components of the constituent clips.

For more information about multicam clips, see Intro to multicam editing.

Manage role components in synced clips

When you have Final Cut Pro automatically analyze and sync audio and video clips, the resulting synced clips are specialized versions of compound clips.

Final Cut Pro creates two sets of role components for each synced clip: one based on the subrole assignments for all the clips in the primary storyline, and one based on the subrole assignments for all the connected clips. For each set of role components, the same rules apply as for compound clips or for angles in multicam clips.

1. Select a synced clip in the Final Cut Pro browser or timeline.
2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Audio button at the top of the inspector.

⚠️ Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.
4. Scroll down to the Audio Configuration section.

*Note:* You can drag the top edge of the Audio Configuration section to expand it and reveal all of its contents.

In the example below, the Audio Configuration section shows two role components representing the contents of the synced clip: Storyline (the clip in the primary storyline) and Connected (all the connected clips synced to the primary storyline). You can’t change role assignments in this view.

![Audio Configuration section](image)

In many ways, you can work with role components as you would with standard audio components. For example, you can:

- Skim over an individual role, or play it back using the Space bar or the J, K, and L keys. See [View and listen to an audio component](#).
- Remove a role from a synced clip by deselecting its checkbox in the Audio Configuration section of the Audio inspector. See [Enable or disable an audio component](#).
- Show expanded role components in the timeline, then edit them as you would a standard audio component. You can adjust volume, pan audio, add audio effects, and so on.

If you want to assign different roles to specific clips within the synced clip, you can open the synced clip for editing and then assign subroles to individual components of the constituent clips.

For more information about synced clips, see [Sync audio and video](#).
Add audio effects to clips with multiple audio components

When you apply effects to whole clips that have multiple audio components, Final Cut Pro automatically mixes the audio down to the main audio roles. The appearance of the clips may change, depending on whether the audio components have different parent roles or the same parent role.

- **Different parent roles:** Apply an audio effect to a clip containing multiple audio components that have subrole assignments from different parent roles (for example, some Dialogue subroles, some Music subroles, and some Effects subroles).

  In this case, there isn't one parent role to mix down to, so the output is assigned to a special Mixed Audio role. The clip appears gray in the timeline and the inspector.

- **Same parent role:** Apply an audio effect to a clip containing multiple audio components within the same parent role (for example, all Dialogue subroles).

  The clip is automatically mixed down to the parent audio role (Dialogue). The clip doesn't appear gray because it's not a mixed-role clip.

For detailed information about advanced uses of audio roles, see Audio Roles in Final Cut Pro.

Export roles in Final Cut Pro for Mac

When exporting your project, you can export separate files (called **media stems**) for each role. This process is often used when delivering files to match broadcast specifications or when handing off media stems for mixing or post-production.

You can export roles in a combined, multitrack QuickTime file or as separate audio or video files. During the export process you can assign mono, stereo, or surround output for your audio channels.

For more information, see Share roles as files.
Add, adjust, and share captions

Intro to captions in Final Cut Pro for Mac

Captions is a general term for timed text—visible lines of text that are synced with video and audio media. Captions are most often used for subtitles (translations of the dialogue in foreign-language movies and TV shows) or closed captions (transcriptions of a program's audio for people who are deaf or hard of hearing or for display on muted devices). Captions are also used for karaoke, scrolling news items, and teleprompters.

Government regulators, broadcasters, and streaming services often have specific requirements for subtitles and closed captions. With Final Cut Pro, you can add captions to your projects and embed them in output files—for example, when you export files for broadcast, burn DVDs, or publish your project to video-sharing websites. You can also import and export captions as separate files, independent of the associated projects and media.

How captions differ from titles

Captions have particular traits that distinguish them from titles:

- Captions are always visibly superimposed over everything else in the video frame, including titles.

- Typically, viewers can turn captions on or off while watching TV shows, movies, web videos, and other programs. In contrast, titles are always permanently “burned in to” the output media file. (However, Final Cut Pro does offer the option to burn in captions permanently.)

- Captions have industry file and formatting standards that make file transfers and interchange possible.

- In Final Cut Pro, captions are assigned format-specific caption roles, with subroles for different language versions. Titles are assigned the Titles role.
Caption formats

Final Cut Pro supports the following industry standards for captions:

- **CEA-608 (also known as EIA-608):** A caption standard for broadcasts and web video. The CEA-608 caption standard features a variety of position, formatting, color, and animation options. CEA-608 captions can be imported or exported as tracks embedded in a media file or as separate files.

- **iTT (iTunes Timed Text):** A format for delivering caption content to the iTunes Store, YouTube, and Vimeo. The iTT standard features formatting, color, and placement options, including a wider range of alphabets, making it the best choice for languages with non-Roman characters. iTT captions can be imported or exported as separate files, but they can't be embedded in an output media file the way CEA-608 captions can.

- **SRT (SubRip Text):** A subtitle format supported by Facebook, YouTube, and Vimeo. The SRT format is simple: Each caption has a number, a start and end timecode (in decimal timecode), and one or more lines of text with HTML tags. SRT captions can be imported or exported as separate files, but they can't be embedded in an output media file the way CEA-608 captions can. Unlike captions in other formats, exported SRT captions can be read and edited in a plain text editor.

Captions workflow in Final Cut Pro for Mac

You can add captions to your projects to create subtitles, closed captions, and burned-in captions. Special caption roles make it easy to deliver captions in multiple languages. The basic workflow is outlined below.
Step 1: Choose a caption format
In Final Cut Pro, choose whether to create CEA-608, iTT, or SRT captions. The format you choose depends on the intended use of your project and the target audience. Broadcasters, streaming services, and government regulators each have their own delivery specifications.

Step 2: Create a caption role
Create a caption role for the chosen format and a subrole for each language version.

Step 3: Create or import captions
Create or import an initial set of captions in one language.

Step 4: Edit caption text
Edit caption text directly in the timeline using the caption editor, or make text changes in the inspector.

Step 5: Adjust and arrange captions
Use the powerful editing tools in Final Cut Pro to adjust the timing and arrangement of captions in your projects. You can sync the captions to specific clips and points in time in your project, and set the duration of each caption.

Step 6: Format caption text
To determine how your captions look onscreen, you can format caption text in the inspector. The CEA-608 and iTT caption standards each have their own specifications for text formats, placement, color, transitions, number of lines, and number of characters. The SRT format has relatively few formal specifications. You can format SRT captions in Final Cut Pro, but you have the option to remove all formatting during export to make them universally compatible with players and devices.

Step 7: Create captions in additional languages
After you finalize an initial set of captions in one language, you can create captions in additional languages by duplicating the first set of captions. You can enter translations in the caption editor or the inspector.

You can also send the captions out for translation and then import the translated captions.

At this stage, you can also Convert captions to another format in Final Cut Pro for Mac.

Step 8: Export captions
You can export captions with your final output media file, either as a separate file or embedded directly in the video file.
Create captions in Final Cut Pro for Mac

You can create captions in Final Cut Pro—for example, to deliver your project with subtitles or closed captions.

In Final Cut Pro, captions are assigned special caption roles. To create a new set of captions, you first choose a caption format (CEA-608, iTT, or SRT), then you create a caption role specific to that format and a subrole for each language version.

Captions are always connected clips. Captions can also be connected to other connected clips.

Create caption roles and subroles

1. To open the Final Cut Pro role editor, do one of the following:
   • Choose Modify > Edit Roles.
   • In the Roles pane of the timeline index, click Edit Roles.
2. Click Captions at the top of the role editor to open the Captions pane.
3. To create a caption role, click the Caption Role button, then choose a caption format from the pop-up menu: iTT, CEA-608, or SRT.

A new caption role appears in the Caption Roles list in the format you chose. You can change the name of a role at any time by clicking it.

By default, Final Cut Pro creates a caption language subrole based on the preferred language setting in macOS System Settings. For example, if macOS is set to English, Final Cut Pro creates a subrole for the English language. To change the preferred language setting, choose Apple menu > System Settings, click General in the sidebar, then click Language & Region on the right.

4. Type a name for the caption role.
5. To add another language subrole, move the pointer over the caption role in the Captions pane, click the Language button, then choose a language from the pop-up menu.

![Image of Captions pane with Language subroles]

The new language subrole appears in the list below the role.

To delete a caption role or a language subrole, move the pointer over the role or subrole, then click the Delete button (–) to the left of the role or subrole name.

6. Click Apply.

The caption roles and subroles you created are now available to any project in the library. To create the actual captions and assign them to subroles, see Create captions, below.

Note: Choosing a language does not affect what kind of characters can be typed into the captions. Additional steps may be required for some languages. See the macOS Help topic Type in another language with input sources.

Create captions

For the most efficient workflow, make sure the dialogue and related audio in your project are “locked” (completely finished) before you create, sync, or edit the captions.

For example, if you were to add captions and then make changes to dialogue clips later, you might cause the captions to go out of sync with the audio.

1. In the Final Cut Pro timeline, position the playhead where you want a caption to appear.
2. Choose Edit > Captions > Add Caption (or press Option-C, or Control-Option-C if the caption editor is already open).

A new caption clip appears at the top of the timeline (in a dedicated caption lane), and the caption editor opens.

The caption is connected to the primary storyline at the playhead position. If a connected clip at the playhead position is selected, the caption is connected to that clip instead. See Connect a caption to a connected clip.

Important: If you move clips earlier or later in the timeline, any connected captions move with those clips. If you delete clips, any connected captions are deleted.
3. Type text for your caption in the caption editor.

For information about adjusting a caption’s text style, see Format caption text.

4. Do any of the following:
   - Create additional captions: Repeat steps 1 through 3 for each new caption.
   - Edit a caption’s text: Double-click the caption in the timeline (or select it and press Control-Shift-C), then enter your changes in the caption editor.
     
     Tip: You can also double-click a caption in the Captions pane of the timeline index to open it in the caption editor.

     If your caption doesn’t conform to the specifications of the caption format you chose (for example, if the caption is too long), the caption turns red in the timeline and in the Captions pane of the timeline index, and a warning message appears in the inspector. See the Apple Support article Learn about Final Cut Pro caption validation.

    Note: When the caption editor is open, many single-key keyboard shortcuts (such as J, K, L, I, O, and Space bar) are interpreted as text characters rather than as shortcuts. To use these shortcuts in the caption editor, add the Control key. For example, to play in reverse when the caption editor is open, press Control-J.

   - Navigate between captions: Click the arrows on either side of the caption editor (or press Command-Right Arrow or Command-Left Arrow).
   - Adjust a caption’s duration: Drag its start point or end point. See Arrange and trim caption clips in the timeline.

     You can also use powerful trimming techniques with caption clips. See Cut clips in two and Extend or shorten clips.

   - Adjust a caption’s sync with the clip it’s connected to: Drag the caption left or right in the timeline. (When you drag a caption clip, it overwrites adjacent captions.)
Import captions into Final Cut Pro for Mac

You can import CEA-608, iTT, or SRT caption files directly into your project. Each caption has text content and formatting information, as well as start and end times that Final Cut Pro uses to place the caption at the correct point in the timeline.

You can also import source media files that have embedded CEA-608 captions and then extract the captions for use in your Final Cut Pro project.

Import captions directly into a project in the timeline

1. Open an existing project in the Final Cut Pro timeline.
2. Choose File > Import > Captions.
3. In the dialog that appears, navigate to the file you want to import, and select the file.

   The file must be a valid CEA-608, iTT, or SRT caption file. CEA-608 files have the filename extension .scc, iTT files have the filename extension .itt, and SRT files have the filename extension .srt.

4. In the Import as Role section, click the pop-up menu on the left and choose a caption role, then click the pop-up menu on the right and choose a language subrole.

5. In the Insertion Time section, select one of the following:
   • Relative to Timeline: Positions captions in the timeline by adding the project’s start time to each caption’s start time.
   • Absolute: Positions captions in the timeline at each caption’s start time, regardless of the project’s start time.

6. Click Import.

   The imported captions appear in a caption lane at the top of the timeline.
Import a media file with embedded CEA-608 captions

1. In Final Cut Pro, import the media file that contains the embedded captions.

   Clips with embedded captions have a caption icon in the browser and the timeline.

2. Add the clip to the timeline, and select the clip.

3. Do one of the following:
   - Choose Edit > Captions > Extract Captions.
   - Control-click the clip and choose Extract Captions.

   The extracted captions appear in a caption lane at the top of the timeline. They are assigned a CEA-608 caption role and a language subrole based on the preferred language setting in Language & Region settings (in macOS System Settings).

You can also use this method to extract captions from compound clips and multicam clips.

Show or hide captions in Final Cut Pro for Mac

You can use the Roles pane of the timeline index to show or hide captions in the viewer and the timeline, and to change the active language subrole (the language version that appears in the viewer).

You can use the Captions pane of the timeline index to view, navigate, and search captions in your project.
Show or hide captions in the viewer

1. To open the Roles pane of the timeline index in Final Cut Pro, do one of the following:
   - Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles at the top of the timeline index.
   - Choose View > Timeline Index > Roles.

   The Roles pane appears, with a list of caption roles at the top.

   If you don’t see any caption roles, it means you haven’t yet added captions to your project. See Create captions.

2. To show captions in the viewer, select the Captions checkbox.

   You can also click the View pop-up menu in the upper-right corner of the viewer and choose Show Captions from the Captions section.

   The caption at the timeline playhead position in the active language subrole appears in the viewer, superimposed over the video image.

   **Note:** Only one language subrole can be active at a time. See Change the active language. You can show or hide captions in the timeline independently of whether captions are shown in the viewer.

To stop displaying captions in the viewer, deselect the Captions checkbox.
Show or hide captions in the timeline

1. To open the Roles pane of the timeline index in Final Cut Pro, do one of the following:
   - Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles at the top of the timeline index.
   - Choose View > Timeline Index > Roles.
   The Roles pane appears, with a list of caption roles at the top.
   If you don’t see any caption roles, it means you haven’t yet added captions to your project. See Create captions.

2. Do one of the following:
   - Show or hide all captions in the timeline: Click the Show Captions button on the right side of the main Captions bar.
   - Show or hide an individual language subrole in the timeline: Click the Show Captions button to the right of the language subrole.
   The corresponding captions appear in, or disappear from, the timeline.

   ![Caption Roles and Timeline](image)

   **Note:** The active language subrole can be displayed in the viewer even if it’s hidden in the timeline. See Show or hide captions in the viewer.
Change the active language

You can change which caption language version is displayed in the viewer by changing the active language. Only one language version appears in the viewer at a time.

1. To open the Roles pane of the timeline index in Final Cut Pro, do one of the following:
   - Click the Index button in the top-left corner of the timeline (or press Shift-Command-2), then click Roles at the top of the timeline index.
   - Choose View > Timeline Index > Roles.

   The Roles pane appears, with a list of caption roles at the top.

   If you don’t see any caption roles, it means you haven’t yet added captions to your project. See Create captions.

2. Select the checkbox to the left of the caption language subrole that you want displayed in the viewer.

   The captions appear in the viewer, and the corresponding caption clips are highlighted in the timeline.

   Note: You can display the active language subrole in the viewer even if that subrole is hidden in the timeline. See Show or hide captions in the timeline.
View, navigate, and search captions

The Captions pane of the timeline index lists the captions in the active language subrole in chronological order. (To change the active language subrole, see Change the active language.)

Note: If you don’t see the Captions pane, it means you haven’t yet added captions to your project. See Create captions.

1. To open the Final Cut Pro timeline index, click Index in the top-left corner of the timeline (or press Shift-Command-2).

2. If the Captions pane isn’t already shown, click Captions to open it.

3. Do any of the following:
   - *Navigate the captions:* Select a caption in the Captions pane to move the playhead to the beginning of that caption in the timeline.
   - *Show just the captions with errors:* Click View Errors.
     This is helpful if you’re finalizing your captions and you want to focus on correcting the remaining errors. To view all the captions again, click View All.

     For more information about caption errors, see the Apple Support article Learn about Final Cut Pro caption validation.

   - *Search all captions in the active language subrole:* Enter text in the search field.
Edit caption text in Final Cut Pro for Mac

You can edit the text of your captions directly in the timeline using the caption editor, or you can enter changes in the inspector.

1. In Final Cut Pro, do one of the following:
   - Double-click a caption in the timeline or the timeline index (or select it and press Control-Shift-C).
     The caption editor opens, showing the caption text.
   - Select a caption in the timeline and open the inspector. The text of the caption appears in the Caption Text field at the top of the inspector.

2. Make any text changes, including typing additional text, deleting text, and copying and pasting text.
   To add a new line, press Return.
   In a CEA-608 caption, you can enter up to four lines of text, with up to 32 characters per line. The four-line maximum also applies to captions with multiple fields. See Add multiple text fields to CEA-608 captions.
   In an iTT caption, you can enter up to two lines of text. The character limit is determined by several factors, including the aspect ratio and the title-safe area of the display.
   In an SRT caption, the character limit is the same as in iTT captions. The number of lines of text is limited only by the player or playback device. See the documentation for your intended player or device.
   If your caption doesn’t conform to the specifications of the caption format you chose (for example, if the caption is too long), the caption turns red in the timeline and in the Captions pane of the timeline index, and a warning message appears in the inspector. See the Apple Support article Learn about Final Cut Pro caption validation.

3. To navigate between captions, click the arrows on either side of the caption editor (or press Command-Right Arrow or Command-Left Arrow).
   Note: When the caption editor is open, many single-key keyboard shortcuts (such as J, K, L, I, O, and Space bar) are interpreted as text characters rather than as shortcuts. To use these shortcuts in the caption editor, add the Control key. For example, to play in reverse when the caption editor is open, press Control-J.
Adjust and arrange captions in Final Cut Pro for Mac

You use the powerful timeline editing tools in Final Cut Pro to adjust the timing and arrangement of captions in your projects.

Arrange and trim caption clips in the timeline

You control the timing of captions by arranging and trimming them in the timeline. In many cases, you can move and trim caption clips just as you would other types of clips.

Caption clips are always connected clips. Unlike other types of clips, caption clips can also be connected to other connected clips.

1. **Open an existing project** in the Final Cut Pro timeline.
2. Use the timeline index to show captions in the timeline and the viewer.
   
   See **Manage captions with the timeline index**.
3. Do any of the following:
   
   • **Adjust a caption’s position in the timeline**: Drag it left or right. When you drag a caption clip to adjacent captions, it overwrites the adjacent captions.
   
   You can also move caption clips by by entering a timecode value or nudging them with keyboard shortcuts. See **Arrange clips in the timeline**.
   
   • **Adjust a caption’s duration**: Trim the caption clip by dragging its start or end point.
   
   You can also use powerful trimming techniques with caption clips. See **Extend or shorten clips**.
   
   • **Roll the edit point between two caption clips**: Make a roll edit using the Trim tool.
   
   • **Cut a caption at any point**: Cut the clip using the Blade tool.

Connect a caption to a connected clip

When you create a caption, it’s connected to the primary storyline at the playhead position. Sometimes, you may want to connect the caption to another connected clip instead—for example, if the connected clip contains dialogue and you want to keep the caption in sync with the dialogue.

1. In the Final Cut Pro timeline, select the caption that you want to connect.
2. Position a connected clip so that it overlaps the caption in the timeline.
3. Option-Command-click the connected clip.

   The caption is connected to the connected clip at the frame where you clicked.
Split multiple-line captions

You can quickly split any caption with multiple lines into a series of single-line captions.

1. In the Final Cut Pro timeline, select one or more captions that have multiple lines.

2. Do one of the following:
   - Choose Edit > Captions > Split Captions (or press Control-Option-Command-C).
   - Control-click the captions you want to split, then choose Split Captions.

The selected captions are replaced with abutting single-line captions, one for each line of text in the original captions. The total duration of the new captions is equal to the duration of the original captions.
Join caption clips in the timeline
You can combine multiple captions in the timeline into one caption.

1. In the Final Cut Pro timeline, select two or more adjacent caption clips.

2. Do one of the following:
   • Choose Edit > Captions > Join Captions.
   • Control-click the captions you want to join, then choose Join Captions.

The selected caption clips are replaced with a single caption clip that contains the text from the selected captions.

Resolve caption overlaps in the timeline
In most cases, overlapping captions in the same language subrole causes an error. If you accidentally overlap captions, the overlapping caption clips turn red in the timeline, and error messages appear in the inspector and the Captions pane of the timeline index. You can fix this problem with the Resolve Overlaps command.

Note: It’s OK to overlap iTT captions that are set to Japanese and formatted to appear in different areas of the screen.
1. In the Final Cut Pro timeline, select the overlapping caption clips.

⚠️ **Tip:** To select all the captions in a language subrole, select any caption, then press Command-A. To select everything in the timeline, press Command-A again.

2. Choose Edit > Captions > Resolve Overlaps.

The clips are trimmed so that they no longer overlap.

---

**Format caption text in Final Cut Pro for Mac**

You can change the style and formatting of caption text using the inspector. The CEA-608, ITT, and SRT caption standards have varying specifications for text, placement, color, transitions, and so on.
Format the text in CEA-608 captions

1. Select one or more CEA-608 caption clips in the Final Cut Pro timeline.

2. To open the Caption inspector, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

   The Caption inspector appears, showing caption text formatting controls for the CEA-608 format.

3. If you selected a single caption and want to format just a portion of it, select the portion of the caption text that you want to format in the Text field.

4. To select an alignment style for captions with multiple lines of text, click an Alignment button.
   - You can center the text or align it to the left or right.

5. To place captions within the allowable area in the video frame, click a Placement button.
   - You can move the caption left, right, up, or down; move the caption to the left, right, top, or bottom margin; and center the caption horizontally.
6. To set the style of transitions between captions, click the Display Style pop-up menu and choose an option:
   - **Pop-On**: No transition (a simple cut between captions).
   - **Paint-On**: Starting with the topmost line of text, each line of text in the caption is revealed from left to right, one at a time.
   - **Roll-Up**: Each line of text in the caption is revealed at the bottom of the screen using the Paint-On style, and is then animated upward to make room for the next line of text.

   If you choose the Roll-Up style, a Lines pop-up menu appears. Choose how many lines of text to show at once in the Roll-Up style: 2, 3, or 4 lines.

   If a series of abutting captions are set to either the Paint-On or the Roll-Up style, their edit points in the timeline become through edits, indicating that the captions will interact. In the example below, all the captions are set to the Roll-Up style. The second caption will push the first caption up, the third caption will push the second caption up, and so on. You can make roll edits on the through edit points to precisely control when the next caption begins to appear.

7. To change caption text to the italic or underline style, click a Formatting button.
8. To change the color of caption text, click a Text Color button.
   You can select one of eight predefined colors.
9. To set the opacity of the caption text background, click a Text Background Opacity button.
   You can make the background transparent, semitransparent, or opaque.
10. To set the caption text background color, click a Text Background Color button.
    You can select one of eight predefined colors.

At the bottom of the Caption inspector, you can view information about the selected caption or captions:
   - **Timing**: Displays start and end times and duration if you selected a single caption.
   - **Validation**: Displays an error message if the selection does not conform to the specifications of the CEA-608 caption format, or displays a green checkmark if no problems are detected.

*Note*: Styling and formatting caption text can add invisible formatting tags, which may cause captions to exceed the limit of 32 characters per line.
Format the text in iTT captions

1. Select one or more iTT caption clips in the Final Cut Pro timeline.

2. To open the Caption inspector, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

The inspector appears, showing caption text formatting controls for the iTT format.

3. If you selected a single caption and want to format just a portion of it, select the portion of the caption text that you want to format in the Caption Text field.

4. To change caption text to the bold, italic, or underline style, click a Formatting button.

5. To change the color of caption text, click the Text Color color well to open the Colors window, or click the down arrow to open a pop-up color palette.

See Basic color controls and Use the pop-up color palette.
6. To place captions at the top or bottom of the video frame, click a Placement button.

For certain languages with vertical writing, the iTT format allows vertical text on the left and right margins, as well as up to four regions of text on the screen at the same time (top, bottom, left, and right).

At the bottom of the Caption inspector, you can view information about the selected caption or captions:

- **Timing**: Displays start and end times and duration if you selected a single caption.
- **Validation**: Displays an error message if the selection does not conform to the specifications of the iTT caption format, or displays a green checkmark if no problems are detected.

### Format the text in SRT captions

**Important**: Because of the absence of text formatting specifications in the SRT standard, any formatting style (such as bold, italic, or underline) that you apply to SRT captions in Final Cut Pro may not appear correctly in your intended player or playback device. For this reason, you can choose to remove all text formatting from SRT captions when you export or share them. See [Export captions](#).

1. Select one or more SRT caption clips in the Final Cut Pro timeline.
2. To open the Caption inspector, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
The inspector appears, showing caption text formatting controls for the SRT format.

3. If you selected a single caption and want to format just a portion of it, select the portion of the caption text that you want to format in the Caption Text field.

4. To change caption text to the bold, italic, or underline style, click a Formatting button.

5. To change the color of caption text, click the Text Color color well to open the Colors window, or click the down arrow to open a pop-up color palette.

   See Basic color controls and Use the pop-up color palette.

At the bottom of the Caption inspector, you can view information about the selected caption or captions:

- **Timing**: Displays start and end times and duration if you selected a single caption.
- **Validation**: Displays an error message if the selection does not conform to the specifications of the SRT caption format, or displays a green checkmark if no problems are detected.

### Save or apply the default style

1. Select one or more caption clips in the Final Cut Pro timeline.

2. To open the Caption inspector, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. In the Caption inspector, click the pop-up menu to the far right of the Display heading and choose one of the following:
   - **Save Style as Default**: Saves the current text style as the default setting.
   - **Apply Default Style**: Applies the default text style to the selected captions.
   - **Reset Default Style**: Resets the default text style to the original setting.
Add multiple text fields to CEA-608 captions

You can split a CEA-608 caption into multiple fields. For example, if two people are speaking at the same time, you can create a text field for each speaker. Each caption can have up to four fields, and you can format each field independently of the others.

CEA-608 captions are limited to four lines, but you can distribute the lines in any combination. For example, a caption could have three lines in one field and one line in a second field, or it could have four fields with one line each.

1. Select a CEA-608 caption clip in the Final Cut Pro timeline.
2. To open the Caption inspector, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the pop-up menu to the far right of the Caption Text heading, then choose Add Text Field.
4. Enter text for the second field in the additional Caption Text section that appears in the inspector.

As you type, the text appears in a new field in the viewer.
5. To position the new text field in the video frame, click a Placement button.

6. Use the text formatting controls in the Display section to adjust the look of the text in the new field.
   
   See [Format the text in CEA-608 captions](#).

7. To add additional text fields, repeat steps 3 through 6.

To remove a text field, click the pop-up menu to the far right of the Caption Text heading for that field, then choose Remove Text Field.

### Add special characters to CEA-608 captions

You can add special characters (such as the trademark symbol or the degree symbol) to CEA-608 captions.

1. Select a CEA-608 caption clip in the Final Cut Pro timeline.

2. To open the Caption inspector, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. In the Caption inspector, position the insertion point in the Text field where you want the special character to appear.

4. Click the pop-up menu to the far right of the Caption Text heading, choose Special Characters, then choose the character from the submenu.
Create multilingual captions in Final Cut Pro for Mac

The easiest way to create captions for a project in multiple languages is to duplicate a finished set of captions and then translate the captions in the duplicate set. This way, you can place the captions and set their timing once, and then reuse that initial work as many times as necessary.

1. In Final Cut Pro, complete the captions for the entire project in the first language subrole.
   For instructions, see Create captions.

2. Select all the captions that you created.
   
   Tip: To select all the captions in a language subrole, select any caption, then press Command-A. To select everything in the timeline, press Command-A again.

3. Do one of the following:
   • Choose Edit > Captions > Duplicate Captions to New Language, then choose a language from the submenu.
   • Control-click the selected captions, choose Duplicate Captions to New Language, then choose a language from the submenu.

   The new language appears as a new caption lane in the timeline.

   Note: Choosing a language does not affect what kind of characters can be typed into the captions. Additional steps may be required for some languages. See the macOS Help topic Type in another language with input sources.
4. To translate the duplicate captions, double-click a caption (or select it and press Control-Option-C), then type the translation in the caption editor.

5. Do any of the following:
   - **Navigate between captions:** Click the arrows on either side of the caption editor (or press Command-Right Arrow or Command-Left Arrow).
     
     *Note:* When the caption editor is open, many single-key keyboard shortcuts (such as J, K, L, I, O, and Space bar) are interpreted as text characters rather than as shortcuts. To use these shortcuts in the caption editor, add the Control key. For example, to play in reverse when the caption editor is open, press Control-J.
   - **Adjust a caption’s duration:** Trim it by dragging its start point or end point. See Arrange and trim caption clips in the timeline.
     
     You can also use powerful trimming techniques with caption clips. See Cut clips in two and Extend or shorten clips.
   - **Adjust a caption’s sync with the clip it’s connected to:** Drag the caption left or right in the timeline. (When you drag a caption clip, it overwrites adjacent captions.)

### Convert captions to another format in Final Cut Pro for Mac

In Final Cut Pro, you can convert captions from one caption standard to another—for example, from CEA-608 to iTT.

There are two ways to convert captions to another format in Final Cut Pro. You can use the Duplicate Captions to New Format command to create a duplicate set of captions in any format you choose, while keeping a copy of the captions in the original format. In the second method, you convert selected captions by assigning them to a new caption role in the format you want.

**WARNING:** When you convert between formats, some text or formatting may be lost. For this reason, the duplication method is recommended in most cases.
Create duplicate captions in another format

This conversion method retains a copy of the captions in the original format and is a good way to quickly add languages in a new format.

1. Select the captions that you want to convert.

   Tip: To select all the captions in a language subrole, select any caption, then press Command-A. To select everything in the timeline, press Command-A again.

2. Do one of the following:
   - Control-click the selected captions, choose Duplicate Captions to New Format, then choose the new format from the submenu.
   - Choose Edit > Captions > Duplicate Captions to New Format, then choose the new format from the submenu.

   A duplicate language subrole is created in the caption format you chose, and appears in the timeline as the active language subrole.

Convert captions to another format

This conversion method does not keep a copy of the captions in the original format. Use this method when you want to permanently convert captions to a new format (after you’ve made a backup of your project).

1. In Final Cut Pro, create a caption role and any subroles for the caption format that you want to convert to.

2. Select the captions that you want to convert.

   Tip: To select all the captions in a language subrole, select any caption, then press Command-A. To select everything in the timeline, press Command-A again.

3. Do one of the following:
   - Control-click the selected captions, choose Assign Caption Roles, then choose the caption role that you created in step 1.
   - Open the inspector, then click the pop-up menu at the top of the Caption inspector and choose the caption role that you created in step 1.
   - If you’re converting a single caption, double-click the caption, then click the pop-up menu at the top of the caption editor and choose the caption role that you created in step 1.

Note: When converting captions to another format, make sure to choose a main role, not a language subrole.

The language subrole is converted to the new format. In the example below, the German language subrole was converted from CEA-608 to iTT.
Export captions in Final Cut Pro for Mac

You can export captions as separate “sidecar” files with your finished media files, or, if your captions are in the CEA-608 format, you can embed them directly in the output media file.

You can export captions as separate files directly from the File menu.

You can also export or embed captions using Final Cut Pro share destinations that include options for exporting captions. Many share destinations also include an option to burn in captions, so they’re permanently visible.

Export captions using the File menu

1. Open the project in the Final Cut Pro timeline, then choose File > Export Captions.
2. In the Save As field, type a name for the exported caption file.
3. Navigate to a folder for the caption file.
4. In the Roles section, select the checkboxes for the language subroles you want to export as caption files.
   A separate caption file is created for each language subrole you select.
5. In the Start Time section, select one of the following:
   - Relative to Timeline: Calculate each caption's start time by subtracting the project's start time.
   - Absolute: Use each caption's actual start time, regardless of the project's start time.
6. If you're exporting SRT captions, select or deselect the Include Formatting checkbox in the SRT section to retain or remove any text formatting applied to the captions in Final Cut Pro.
   In most cases, it's recommended that you deselect this option to remove text formatting. Because of the absence of text formatting specifications in the SRT standard, any formatting style (such as bold, italic, or underline) that you apply to SRT captions in Final Cut Pro may not appear correctly in your intended player or playback device.
7. Click Export.
Export captions using share destinations

A number of Final Cut Pro share destinations include options for exporting captions. See the following topics:

- Share to Apple devices
- Export final mastering files
- Share on the web
- Export MXF files
- Create optical discs and disk images
- Share using Compressor

In addition, the Save Current Frame, Image Sequence, and HTTP Live Streaming destinations allow you to burn in captions so they’re permanently visible, but they don’t support exporting captions as separate files or embedding captions. See the following topics:

- Export still images
- Export image sequences
- Export files for HTTP Live Streaming

Group clips with compound clips

Intro to compound clips in Final Cut Pro for Mac

With Final Cut Pro, you can create compound clips, which allow you to group any combination of clips in the timeline or the browser and nest clips within other clips.

Compound clips can contain video and audio clip components, clips, and other compound clips. Effectively, each compound clip can be considered a mini project, with its own distinct project properties. Compound clips function just like other clips: you can add them to your project, trim them, retimem them, and add effects and transitions. Icons appear on compound clips in the browser and the timeline.
Compound clips have many uses. You can:

- Simplify a complicated project by creating a separate compound clip for each major section.
- Sync a video clip with one or more audio clips and then combine the clips into a compound clip, to avoid inadvertently moving them out of sync.
- Open any clip, edit its contents in the timeline, and then close it.
- Quickly create a compound clip containing the clips in an event, based on the browser sort order.
- Use a compound clip to create a section of a project with settings different from those of the main project.

The following example shows how a project in the timeline could be simplified using compound clips:
Compound clips have the following characteristics:

- You create compound clips in the browser or in the timeline.
- Every compound clip in the timeline has a “parent” compound clip in the browser.

- When you edit the contents of any compound clip, you are in fact editing the parent compound clip from the browser. Any changes you make to the compound clip are inherited by all of its child clips. For example, if you delete a title clip from the contents of a parent compound clip, the title clip is deleted from all child clips.

You can create an independent compound clip from an existing compound clip. For example, if you have a compound clip of a standard title sequence for a TV or podcast series, you can create unique (independent) instances of the compound clip for each episode without affecting other instances of the title sequence.

You can also create a snapshot of the entire project. Project snapshots are self-contained backup versions that include compound or multicam parent clips. Duplicating a project as a snapshot makes copies of the compound or multicam parent clips and embeds them in the duplicate project so that it’s not affected by changes to any other instances of the clips. See Duplicate projects and clips.

Create compound clips in Final Cut Pro for Mac

You can create a compound clip from existing clips in the timeline or the browser, or you can create a new, empty compound clip in the browser and add clips to it in the timeline. You can also break a compound clip into its component parts in the timeline, so that the items are no longer grouped.

Create a compound clip from existing clips

1. Select one or more clips in the Final Cut Pro timeline or browser.

   The selected clips can be any combination of contiguous or noncontiguous clips, compound clips, primary storyline clips, or connected clips.

2. Do one of the following:

   - Choose File > New > Compound Clip (or press Option-G).
   - Control-click the selection and choose New Compound Clip.
Note: When you add a compound clip to the timeline or create a compound clip from existing clips in the timeline, you create a direct and active relationship between a parent compound clip in the browser and the child compound clip in the timeline. If the parent clip doesn’t already exist in the browser, Final Cut Pro creates one. When you edit the contents of a compound clip (for example, by trimming or adding effects to clips within the compound clip), you are in fact editing all instances of that compound clip, including the parent compound clip in the browser.

The way clips are grouped within the compound clip depends on where you selected the clips:

- **If you selected clips in an event**: Final Cut Pro creates a new compound clip in the event (in addition to the selected clips) and places duplicates of the selected clips in the new compound clip horizontally, in the order in which you selected them. (For more information about creating a compound clip in the browser, see Create an empty compound clip, below.)
• If you selected clips in the timeline: Final Cut Pro places the selected clips in the new compound clip exactly as they are laid out in the timeline. The new compound clip inherits the frame size and frame rate of the current project.

Create independent compound clips from existing compound clips
1. Select one or more compound clips in the Final Cut Pro timeline.

Final Cut Pro creates a new parent compound clip in the browser for each referenced parent clip in your selection. This command breaks the relationship between selected compound clips in the timeline and their original parent compound clips (as well as any child clips of the original parent clips, in all projects).
Create an empty compound clip
You can create new, empty compound clips and then add clips to them. Each compound clip can be considered a mini project, with its own distinct project properties.

1. In the Libraries sidebar in Final Cut Pro, select an event to which you want to add the compound clip.
2. Choose File > New Compound Clip.
   
   In the window that appears, type a name for the compound clip in the Name field.
3. To further customize settings for your compound clip, click Use Custom Settings.
   
   Note: Final Cut Pro shows the Automatic Settings by default but retains the settings you used last, so this step may be unnecessary.
4. If you want the compound clip's timecode to start at a value other than the lowest timecode value in the selected clips (the default), type that timecode value in the Starting Timecode field.
5. To adjust video, audio, and rendering settings, click Custom.
   
   Unless you have a specific requirement for the compound clip you’re creating, it’s best to leave “Set automatically based on first video clip” and “Use default settings” selected.
6. Click OK.
   
   The new compound clip appears in the event.

Edit the contents of a standard clip in the timeline
You can edit the contents of a standard clip.

- Select a clip in the Final Cut Pro browser or timeline, then choose Clip > Open Clip.

   The timeline displays the contents of the clip. Most standard clips include a video component, an audio component, or both. You can’t edit the contents of these video and audio components.

   You can add media to the contents of this clip (by adding clips to this timeline). To close this clip, choose View > Timeline History Back.

   Note: Because editing in Final Cut Pro is nondestructive, any changes you make to the contents of standard or compound clips do not affect the corresponding source media files, which remain unchanged on your Mac or storage device. See Media files and clips.

Break apart clip items
You can break apart a compound clip or a standard clip to convert its contents to individual clips in the timeline.

- Select a compound clip or a standard clip in the Final Cut Pro timeline, then choose Clip > Break Apart Clip Items (or press Shift-Command-G).

   Final Cut Pro replaces the clip selected in the timeline with the individual items that made up the clip.

   If you selected a compound clip, its contents revert back to the original clips that made up the compound clip. However, the parent compound clip remains in the browser.

   If the selected clip is a standard clip, the contents appear as individual clips in the timeline. Most standard clips include a video component, an audio component, or both. The audio appears as a connected clip.
Edit compound clips in Final Cut Pro for Mac

You can open up compound clips and edit their component parts in a separate timeline, and you can easily navigate up and down a series of compound clip levels. You can also open and edit a compound clip from within an event.

Note: When you edit the contents of a compound clip (for example, by trimming or adding effects to clips within the compound clip), you are in fact editing all instances of that compound clip, including the parent compound clip in the browser. Any changes you make to the internal parts of the compound clip are inherited by all of its child clips, in all projects. These changes can include added or deleted clips, trimming adjustments, and video or audio effects such as color correction, clip speed retiming, and so on. For example, if you delete a title clip from a parent compound clip, the title clip is deleted from all child compound clips.

Open a compound clip for editing

In Final Cut Pro, do one of the following:

• Select a compound clip in the timeline or the browser, then choose Clip > Open Clip.
• Double-click the video portion of a compound clip in the timeline or the browser.
• Click the compound clip icon in the top-left corner of a compound clip in the timeline.

The compound clip opens in a new timeline view, with its contents ready for editing.

Note: Because editing in Final Cut Pro is nondestructive, any changes you make to the contents of standard or compound clips do not affect the corresponding source media files, which remain unchanged on your Mac or storage device. See Media files and clips.
Navigate compound clip levels using menu commands

You can navigate up or down one or more levels of a compound clip.

1. Open a compound clip in Final Cut Pro.
2. Do any of the following:
   • Move forward (down one level): Choose View > Timeline History Forward, or press Command-Right Bracket (]).
   • Move back (up one level): Choose View > Timeline History Back, or press Command-Left Bracket ([).

Navigate compound clip levels using the arrow buttons

In Final Cut Pro, do one of the following:

1. Open a compound clip in Final Cut Pro.
2. Do one of the following:
   • Click the left and right arrows at the top of the timeline.

   ![Timeline History Back and Forward](image)

   • Click and hold the right or left arrow in the top-left corner of the timeline, then choose a level.

   ![Timeline Arrow Buttons](image)

The left arrow effectively closes the current compound clip and opens its parent, with the top level being the project or event containing the compound clip. If there’s no history available to navigate, both the left and right arrows are dimmed.
Make sure all contents of a compound clip appear in your movie

When you’re editing the contents of a compound clip, Final Cut Pro indicates the boundary of the compound clip with a darker crosshatched area to the left of the start point of the clip and to the right of the end point of the clip.

If you add clips to the contents of the compound clip, any parts of any clips that extend into the dark gray area do not appear in your project.

To allow the new clip material to appear in your Final Cut Pro project, do one of the following:

- Reduce the total duration of the other clips inside the compound clip. For example, you could trim one or more clips inside the compound clip.
- Close the compound clip to navigate up one level, then extend the total duration of the parent clip (the “outside shell” of the compound clip) in the timeline.

For more information, see Intro to trimming.

Edit with multicam clips

Intro to multicam editing in Final Cut Pro for Mac

You can use Final Cut Pro to edit footage from multicamera shoots or other synced footage in real time. For example, if you shot a live concert or a wedding with four different cameras, you can sync the footage from each camera angle into a single multicam clip and cut between the angles in real time.
The angles in a multicam clip are synced by a common sync point, a frame that you can recognize (visibly or audibly) in each of the angles you’re syncing. When you add a multicam clip to the timeline, the angle that appears in the viewer when you play your project is called the active angle. While the active angle plays in the viewer, you can also view all angles playing simultaneously in the angle viewer and easily cut and switch between them.

![Diagram of Sync Point and Multicam Clip](image)

Working with multicam clips in Final Cut Pro is a flexible and fluid process. At any time, you can add angles to or remove angles from a multicam clip, and you can easily adjust the sync between angles.

You can also group unrelated footage together for real-time montage editing (such as for music videos). For example, if you’re editing a music video, you could add several angles of abstract visuals and cut to those angles at specific places in the music. You can even use photos (from a still camera) in a multicam clip. If the date and time (Content Created) information matches the contents of the other angles, the photos are automatically adjusted in duration to “fill in” the angle.

Multicam clips have the following characteristics:

- You create multicam clips in the browser only, from existing event clips.
- You edit and adjust multicam clips in the angle editor, which looks similar to the timeline.
- When you add a multicam clip to the timeline, you create a direct and active relationship between the "parent" multicam clip in the browser and the "child" multicam clip in the timeline.
• When you open any multicam clip in the angle editor (whether from the browser or the timeline) you are in fact opening the parent multicam clip from the browser. Any changes you make to a multicam clip in the angle editor are inherited by all of its child clips, in all projects. These changes include sync or trimming adjustments, clip speed retiming, video or audio effects such as color correction, and added or deleted angles. For example, if you delete an angle from a parent multicam clip, the angle is deleted from all child clips. For more information about the angle editor, see Sync and adjust camera angles.

Tip: You can create a "snapshot" backup of the entire project to protect it from accidental changes. Project snapshots are self-contained backup versions that include multicam or compound parent clips. Duplicating a project as a snapshot makes copies of the multicam or compound parent clips and embeds them in the duplicate project so that it’s not affected by changes to any other instances of the clips. See Duplicate projects and clips.

Multicam editing workflow in Final Cut Pro for Mac

The process for creating a multicam project is outlined below. The procedures are presented in rough chronological order, but you can rearrange the order to suit your workflow.

Step 1: Shoot an event with multiple cameras and record appropriate sync information

A multicamera shoot uses multiple cameras to record the same subject or event from different angles and distances.

For multicam projects, it’s a good idea to set the date, the time, and the time zone on your camcorder or recording device before you shoot footage. This provides useful information to Final Cut Pro during the automatic multicam clip creation process.

In professional multicamera shoots, each camcorder or video recorder receives the same timecode from a central timecode generator, or you can jam sync the timecode generator of each camera at the beginning of the shoot. If you’re using consumer camcorders, which can’t accept external timecode, you need to record a visible or audible cue, such as a clapboard closing or a camera flash, on all cameras. You can use this cue to sync the angles in your multicam clips.

Because you can use the sophisticated automatic audio sync feature in Final Cut Pro to help ensure multicam sync accuracy, it makes sense to record audio on every camcorder and recording device in your multicam production. (Clear audio recordings provide the best results.)

Step 2: Import media into Final Cut Pro for a multicam edit

Although importing media for multicam projects is the same as importing for any other project, there are steps you can take during importing to help streamline the multicam workflow.

Step 3: Assign camera names and multicam angles

You can use the Camera Name and Camera Angle metadata tags to automate and organize your multicam workflow. It’s recommended (but not required) to apply these tags to your event clips before you create an actual multicam clip.
Step 4: Create multicam clips

You create multicam clips from selected event clips (similar to the way you create auditions and compound clips in the browser). Whether you do it manually or have Final Cut Pro do it for you automatically, creating a multicam clip involves three fundamental steps:

- Create angles (containing one or more clips each).
- Arrange the order of clips within each angle.
- Sync the angles using a common sync point.

If you know what kind of metadata your source media has, you can create multicam clips using manual methods even faster than with the automatic methods. See Add camera names and angles and Create multicam clips.

Step 5: Cut and switch between angles in the angle viewer

After you create a multicam clip, you can watch all angles simultaneously in the angle viewer while switching or cutting to different angles in real time. You can cut and switch video and audio at the same time or independently. For example, you can use the audio from angle 1 while switching the video between angles 1 to 4.

Step 6: Sync and adjust angles in the angle editor

You can open multicam clips in the angle editor to adjust the sync and the angle order or to add or delete angles. You can also use the angle editor to make edits to the individual clips inside a multicam clip (such as trimming, making color corrections, adding transitions, and so on).

Step 7: Edit multicam clips in the timeline

You can switch multicam angles directly in the timeline or the inspector, without opening the angle viewer. Although multicam clips have some unique properties, you can edit them in the timeline in the same way you edit any other clips.

Import media for multicam edits in Final Cut Pro for Mac

When you import media for a multicam project, you can give the camcorder or file-based recording device a name. Final Cut Pro uses this Camera Name tag to sort the source clips within a multicam clip during the automatic multicam clip creation process (see Create multicam clips).

You can also add the Camera Name property after you import. See Add camera names and angles.

If you anticipate having multicam clips with numerous angles, select "Use proxy media" in Playback settings to maintain top performance during your multicam edit. You can generate the necessary proxy versions of your clips during the import process.

If you have only a few angles in your multicam edit, you can make optimized versions of your media during import using the Apple ProRes 422 codec. Or, if you prefer, you can select "Create optimized media for multicam clips" in Playback settings to generate optimized media automatically every time you create a multicam clip.
Name your camera

1. Connect your camera or recording device to your Mac.
2. In Final Cut Pro, choose File > Import > Media (or press Command-I).
3. In the Media Import window, select your camcorder or recording device in the list of devices on the left, if it’s not already selected.
4. Click it again, then enter a name.
   
   Final Cut Pro uses the name you enter as the Camera Name metadata property for all clips that you import from this device.

Note: Most modern camcorders and recording devices (including all iOS and iPadOS devices) record a Camera ID tag. Final Cut Pro imports the Camera ID metadata automatically when you import from a file-based device and can use this information to automatically build multicam angles.

Add camera names and angles in Final Cut Pro for Mac

The Camera Angle and Camera Name properties are flexible metadata tags that you can use to organize your multicam workflow.

Although you can assign metadata to clips at any time, it makes the most sense to assign the Camera Angle and Camera Name tags before you use the clips to create multicam clips. The Camera Angle tag can help you determine and track which clips appear in which angles. The Camera Name tag can be applied during import and is useful in a variety of scenarios, such as in color correction.

In Final Cut Pro, you can create multicam clips automatically or manually. If you use the automatic method for creating angles in the multicam clip, Final Cut Pro looks for metadata in the selected clips in the following order:

- Camera Angle metadata
- Camera Name metadata
- Camera ID metadata

Note: The Camera ID tag is generated by most modern camcorders and recording devices (including all iOS and iPadOS devices). The Camera ID metadata is imported automatically when you import from a file-based device.

Final Cut Pro uses the Camera Angle, Camera Name, and Camera ID metadata to place clips in the correct angle. If none of this information is found, a separate angle is created for each selected clip.

In Final Cut Pro, do one of the following:

- Select one or more clips in the browser or the timeline, open the Info inspector, then enter text in the Camera Angle field or the Camera Name field.
- In the browser in list view, enter text in the Camera Angle column or the Camera Name column for any clip.

For more information about the browser list view, see Intro to browser views.
Note: If you use the automatic method for creating angles, Final Cut Pro uses any Camera Angle tags in the selected clips to name the angles in the resulting multicam clip. If no Camera Angle tags are present, Final Cut Pro uses Camera Name, Name (clip name), or Camera ID metadata to name angles. You can rename angles in the angle editor. See Sync and adjust camera angles.

Create multicam clips in Final Cut Pro for Mac

Creating multicam clips is similar to creating auditions and compound clips in the browser. Multicam clips can be made up of diverse media sources (different formats, frame rates, and so on). There can be multiple clips in any given angle of a multicam clip.

You can have Final Cut Pro create multicam clips for you automatically, or you can create the clips manually.

If you know what kind of metadata your multicam media has, you can create multicam clips using manual methods faster than with the automatic methods. The automatic methods use sophisticated automatic audio sync technology to ensure sync accuracy (but at the expense of processing time). You can turn off automatic audio sync if it’s not needed. For example, if you’ve recorded accurate timecode in every clip, Final Cut Pro can create your multicam clip automatically without the audio sync feature.

Create a multicam clip automatically

1. In the Final Cut Pro browser, select the clips you want to include in the multicam clip.

2. Do one of the following:
   • Choose File > New > Multicam Clip.
   • Control-click the selection and choose New Multicam Clip.

3. If the multicam automatic settings aren’t shown in the window that appears, click Use Automatic Settings in the lower-left corner of the window.
   The multicam automatic settings appear.

   ![Multicam Settings Window]

   Note: The automatic settings are shown by default, but if the last multicam clip you created used custom settings, those settings are shown.

4. Type a name for the multicam clip in the Multicam Clip Name field.

5. Click the In Event pop-up menu and choose the event in which you want to create the new multicam clip.

6. If you want the multicam clip’s timecode to start at a value other than the earliest timecode value in the selected clips (the default), type a timecode value in the Starting Timecode field.
7. To sync angles automatically using audio waveform data, select “Use audio for synchronization.”

This option makes precision sync adjustments using audio waveforms in each angle. This is the same audio sync technology that you can use to automatically sync clips together into a compound clip.

Note: Some audio recordings are not suited for use with this feature. Selecting this option may result in long processing times during which Final Cut Pro is not available for editing.

8. Click OK.
Final Cut Pro creates a new multicam clip in the event you chose and places duplicates of the selected clips in the new multicam clip.

Create a multicam clip with custom settings
1. In the Final Cut Pro browser, select the clips you want to include in the multicam clip.
2. Do one of the following:
   • Choose File > New > Multicam Clip.
   • Control-click the selection and choose New Multicam Clip.
3. In the window that appears, type a name for the multicam clip in the Multicam Clip Name field.
4. Click the In Event pop-up menu and choose the event in which you want to create the new multicam clip.
5. If you want the multicam clip's timecode to start at a value other than the earliest timecode value in the selected clips (the default), type a timecode value in the Starting Timecode field.
6. To sync angles automatically using audio waveform data, select “Use audio for synchronization.”

This option makes precision sync adjustments using audio waveforms in each angle. This is the same audio sync technology that you can use to automatically sync clips together into a compound clip.

Note: Some audio recordings are not suited for use with this feature. Selecting this option may result in long processing times during which Final Cut Pro is not available for editing.

7. If the multicam custom settings aren’t shown, click Use Custom Settings.

The custom settings appear.

Note: The automatic settings are shown by default, but if the last multicam clip you created used custom settings, those settings are shown.

8. Click the Angle Assembly pop-up menu and choose how the angles in the multicam clip are created:

- **Automatic**: Final Cut Pro creates the angles automatically.
- **Camera Angle**: Final Cut Pro creates angles in the multicam clip based on the Camera Angle property of the selected clips.
- **Camera Name**: Final Cut Pro creates angles in the multicam clip based on the Camera Name property of the selected clips.
- **Clips**: Final Cut Pro creates a separate angle for each selected clip, using the Name property in each clip to name the angle.
9. Click the Angle Clip Ordering pop-up menu and choose how angles are ordered within the multicam clip:

- **Automatic**: Final Cut Pro orders the clips within each angle automatically. If there’s more than one clip per angle, Final Cut Pro inserts gap clips between the clips, as needed, to achieve the correct timing and spacing.

- **Timecode**: Final Cut Pro orders the clips within each angle using timecode recorded in the clips. If you recorded timecode in your clips, choose this option. It’s the fastest and most frame-accurate method of ordering clips.

- **Content Created**: Final Cut Pro orders the clips within each angle using the date and time information recorded by your camcorder or video recording device. The Content Created method can position clips within 1-second accuracy (because in most camcorders the smallest unit in date and time information is 1 second). If you choose this clip-ordering method, consider making your multicam clip frame-accurate by selecting "Use audio for synchronization" (described in step 6) or manually syncing your angles in the angle editor.

**Tip**: At any time, you can change the Content Created date and time of your source clips in the browser. Just select one or more clips and choose Modify > Adjust Content Created Date and Time.

10. Click the Angle Synchronization pop-up menu and choose how angles are synced in the multicam clip:

- **Automatic**: Final Cut Pro syncs the angles automatically (using one or more of the following methods).

- **Timecode**: Final Cut Pro syncs the angles based on the timecode recorded in the clips. For more information about recording timecode, see Multicam editing workflow.

  **Note**: This option is not available when the drop frame patterns in the selected clips do not match.

- **Content Created**: Final Cut Pro syncs the angles based on the date and time information recorded by your camcorder or video recording device.
• **Start of First Clip**: Final Cut Pro uses the first frame in each angle as the sync point.

![Sync point](image)

⚠️ **Tip**: The Start of First Clip method is useful if you want to use specific range selections of your source clips only. In the browser, add keywords or the favorite rating to the range selections you want to use, then filter or search for the clips. When you create your multicam clip, Final Cut Pro uses only the media showing in the filtered view.

• **First Marker on the Angle**: Final Cut Pro uses the first marker in each angle as the sync point.

![Sync point](image)

⚠️ **Tip**: With this method, you can use the first marker to define a region that can be fine-tuned with the "Use audio for synchronization" option (described above). In other words, you don’t need to place the marker exactly—just close enough so that the automatic audio sync feature can sync the angles the rest of the way.

11. If you want to change the video properties settings, click the Video pop-up menu, choose Custom, then change the settings as appropriate.

   **Note**: By default, Final Cut Pro analyzes the selected clips and configures these settings according to the most common clip properties among those clips.

12. If you want to change the rendering codec, click the Rendering pop-up menu and choose a different codec.

13. To change the rendering color space for your project, click the Color Space pop-up menu and choose a color space.

   When the Color Processing setting in the Library Properties inspector is set to Wide Gamut, you can choose either Standard - Rec. 709 or Wide Gamut - Rec. 2020. Otherwise, the rendering color space is chosen for you based on other settings, such as Video Format. For example, setting the video format to NTSC SD automatically sets the color space to Standard - Rec. 601 (NTSC).
14. If you want to change the audio channel configuration or sample rate, use the Channels pop-up menu or the Sample Rate pop-up menu, respectively.

15. Click OK.

Final Cut Pro creates a new multicam clip in the event and places duplicates of the selected clips in the new multicam clip.

Cut and switch camera angles in Final Cut Pro for Mac

After you create a multicam clip, you can watch all angles simultaneously in the angle viewer while switching or cutting to different angles in real time. This allows you to cut an entire movie as if it were live, and then fine-tune your edits in the timeline just as you would for any other project.

The angle viewer is both a display and an interactive interface for making quick cut and switch decisions as you play back your multicam clips and projects. Angles appear in banks of 2, 4, 9, or 16 angles.
Play back a multicam clip in the angle viewer

1. To open the Final Cut Pro angle viewer, do one of the following:
   - Choose View > Show in Viewer > Angles (or press Shift-Command-7).
   - Click the View pop-up menu in the top-right corner of the viewer and choose Show Angles.

If you're viewing a multicam clip in the browser, you have the option to show the event viewer next to the viewer. To show multicam angles in the event viewer, do one of the following:
   - Choose View > Show in Event Viewer > Angles.
   - Click the View pop-up menu in the top-right corner of the event viewer and choose Angles from the Show section.

2. Use the skimmer or the playhead to play back a multicam clip in the browser or the timeline.

The angle viewer appears in the upper part of the Final Cut Pro window.

Cut and switch angles in the angle viewer

You can cut and switch angles “on the fly” (while playing back your project), or you can skim to specific points in the timeline and then cut and switch. You can also use a combination of those two methods.

1. To open the Final Cut Pro angle viewer, choose View > Show in Viewer > Angles (or press Shift-Command-7).

2. Add the multicam clip you want to cut and switch to the timeline.
   
   Note: The cut and switch feature works on timeline clips only.

3. Do one of the following:
   - Position the playhead where you want playback to start, then press the Space bar to play back the multicam clip.
   - Skim the timeline to the frame where you want to cut and switch to a different angle.
4. In the angle viewer, move the pointer over the angle that you want to switch to.

As you move the pointer over the angles in the angle viewer, the pointer changes to the Blade tool, indicating that a cut (and switch) will occur when you click.

5. Do one of the following:

- **Cut and switch:** Click the angle you want to switch to. (Or press any number key to cut and switch to the corresponding angle of the current bank. For example, press 5 to cut and switch to angle 5 of the current bank.)

  In the timeline, the current multicam clip is cut at the playhead position. The section of the clip to the right of the playhead is replaced with a new instance of the clip, with the angle you clicked as the active angle. A special through edit point appears at the timeline playhead position. See Edit multicam clips.

- **Switch:** Option-click the angle you want to switch to. (Or hold down the Option key and press any number key to switch to the corresponding angle of the current bank. For example, press Option-5 to switch to angle 5 of the current bank.)

  *Note:* The pointer changes to a pointing hand icon when you hold down the Option key, indicating a switch-only edit.

  In the timeline, the multicam clip under the playhead changes to show the angle you switched to as the active angle.

  The viewer switches to the angle you selected. The active angle is highlighted in yellow, blue, or green, depending on the switch mode you’re using. See Switch video or audio separately, below.
Switch video or audio separately

By default, Final Cut Pro switches the video and audio of a multicam clip at the same time, but you can set Final Cut Pro to switch the video and audio separately.

1. To open the Final Cut Pro angle viewer, choose View > Show in Viewer > Angles (or press Shift-Command-7).

2. To change the switch mode, do one of the following:

   • *Enable video and audio switching:* Click the left switch mode button in the top-left corner of the angle viewer. This is the default setting.

   ![Click to enable video and audio switching.](image)

   • *Enable video-only switching:* Click the middle switch mode button. Only the video switches. The audio from the original angle remains active.

   ![Click to enable video-only switching.](image)

   • *Enable audio-only switching:* Click the right switch mode button. Only the audio switches. The video from the original angle remains active.

   ![Click to enable audio-only switching.](image)
3. Do one of the following:

- **Cut and switch:** Click an angle in the angle viewer.
- **Switch:** Option-click an angle in the angle viewer.

If you selected the video-only or audio-only switch mode, blue highlighting indicates the active video angle and green highlighting indicates the active audio angle.

![Diagram showing angle viewer and switch options]

**Tip:** With audio-only switching enabled, you can add audio components from inactive angles to the active angle or remove audio components from the active angle. Simply Option-Command-click an inactive angle to add its audio to the active angle, or Option-Command-click an active angle to remove its audio. See Example: Enable or disable audio components in a multicam clip.
View and navigate banks of angles

Depending on the angle viewer display setting you choose, you can show 2, 4, 9, or 16 angles at once. These sets of angles are known as *banks*. You use the bank switcher to display and navigate banks of angles in a multicam clip.

1. To open the Final Cut Pro angle viewer, choose View > Show in Viewer > Angles (or press Shift-Command-7).

2. Position the skimmer or the playhead over a multicam clip in the browser or the timeline.

The bank switcher appears as a grid of squares at the bottom of the angle viewer. Yellow, blue, or green highlighting indicates the currently active angle.
3. Click the Settings pop-up menu in the top-right corner of the angle viewer and choose the number of angles you want to display in each bank.

![Settings pop-up menu]

If the number of angles in your multicam clip exceeds the current angle viewer display setting, Final Cut Pro creates additional banks and displays them as separate grids of squares.

Here are a few examples of different angle bank combinations:

- Three banks of 4 angles each. The last angle in the third bank is the active angle, and the third bank is the currently displayed bank.
- One bank of 16 angles. The last angle is the active angle.
- One bank of 9 angles and another bank of 7 angles. The first bank is the currently displayed bank.

4. To navigate banks of angles, do any of the following:
   - *Display a bank’s angles in the angle viewer:* Click the bank switcher icon for the bank.
   - *Display the previous bank:* Press Option-Shift-Semicolon (;).
   - *Display the next bank:* Press Option-Shift-Apostrophe (’).

**Show overlays in the angle viewer**

For each angle that appears in the angle viewer, you can display video overlays showing timecode and either the clip name or the angle name.
1. To open the Final Cut Pro angle viewer, choose View > Show in Viewer > Angles (or press Shift-Command-7).

2. To choose a display option, do one of the following:
   - *Display timecode for the clips in each angle:* Click the Settings pop-up menu in the top-right corner of the angle viewer and choose Timecode. (Choose Timecode again to turn off the timecode display.)
   - *Display the names of the clips in each angle:* Click the Settings pop-up menu and choose Display Name > Clip.
   - *Display the name for each angle:* Click the Settings pop-up menu and choose Display Name > Angle.
   - *Turn off display names:* Click the Settings pop-up menu and choose Display Name > None.

**Adjust the angle viewer display**

You can adjust the size of the angle viewer and even display it as a vertical column.

In Final Cut Pro, do any of the following:
   - *Adjust the number of angles in the angle viewer:* Click the Settings pop-up menu in the top-right corner of the angle viewer, then choose either 2 Angles, 4 Angles, 9 Angles, or 16 Angles.
• Adjust the size of the angle viewer and the main viewer: Drag the boundary between them.
• *Make the angle viewer a vertical column:* Drag the boundary to the left, then drag the border between the viewer and the timeline downward to expand the viewer quadrant vertically. (This vertical column view is available only in the 2 Angles and 4 Angles views.)

![Angle Viewer Diagram](image1.png)

**Drag the boundary to the left. Drag the toolbar down.**

**Sync and adjust camera angles in Final Cut Pro for Mac**

You can open multicam clips in the angle editor to adjust the sync and the angle order, set the monitoring angle (the angle you see in the viewer when the multicam clip is playing back in the angle editor), or add or delete angles. You can also edit the individual clips inside a multicam clip (similar to how you can edit the contents of a compound clip). The many changes you can make in the angle editor include basic edits and trimming as well as effects you would normally add in the timeline, such as color corrections and transitions.

*Note:* When you open any multicam clip in the angle editor (whether from the browser or the timeline) you’re actually opening the *parent* multicam clip. Any changes you make in the angle editor are propagated to all child clips of that multicam clip, in every project. See [Create multicam clips](#).

You can’t cut and switch between angles in the angle editor. You also can’t connect clips, solo clips, use the precision editor, perform ripple deletes, or use the Detach Audio and Break Apart Clip Items commands.

⚠️ **Tip:** Before you edit multicam clips in the angle editor, duplicate them in the browser to maintain clean backup copies.
Open a multicam clip in the angle editor

- In Final Cut Pro, double-click a multicam clip in the browser.

The angle editor opens in the timeline area at the bottom of the Final Cut Pro window. Although similar to the timeline, the angle editor provides a separate interface dedicated to editing angles and clips inside multicam clips. Each angle in the multicam clip appears as a separate row in the angle editor.

Set video and audio monitoring in the angle editor

In the angle editor, you can set any one angle to be the monitoring angle. This is the angle you see in the viewer when the multicam clip is playing back in the angle editor. You can also monitor the audio of any number of angles at once.

You use the monitoring angle to sync angles in the angle editor. The monitoring angle is not the same thing as the active angle (which you see in the timeline).

Note: Setting the correct monitoring angle is important for the two sync commands described later in this section: Sync to Monitoring Angle and Sync Angle to Monitoring Angle.

1. In Final Cut Pro, double-click a multicam clip in the browser to open the angle editor.
2. To set an angle as the monitoring angle, do one of the following:
   - Click the Video Monitor button at the left side of the angle.
   - Click the pop-up menu next to the angle name and choose Set Monitoring Angle.
   - Press Shift-V while skimming the angle.
The Video Monitor button becomes highlighted, and the entire angle is highlighted in light gray. The angle plays in the viewer when you play back the multicam clip in the angle editor. Only one angle can be the video monitoring angle at a time.

3. To turn on audio monitoring for an angle, do one of the following:
   - Click the Audio Monitor button once. (To turn off audio monitoring, click the button again.)
   - Click the pop-up menu next to the angle name and choose Monitor Audio. (To turn off audio monitoring, choose Monitor Audio again.)
   - Press Shift-A while skimming the angle. (To turn off audio monitoring, press Shift-A again.)

The monitoring settings don’t affect any of your active angles. They simply change what’s playing back in the viewer while you’re working in the angle editor.

⚠️ Tip: You can use audio monitoring to double-check the sync of individual angles in a multicam clip. Open the clip in the angle editor, then turn on audio monitoring for two or more angles at a time. You’ll hear immediately if the angles are in sync or if you need to adjust them further.
Manually adjust the sync of a multicam clip

A primary function of the angle editor is to provide an easy way to correct out-of-sync angles in your multicam clips. The instructions below describe how to sync angles by locating sync points and then manually dragging the angles into alignment.

1. In Final Cut Pro, double-click a multicam clip in the browser to open the angle editor.

2. Locate a sync point in one of the out-of-sync angles by skimming the angle in the angle editor.

   As you skim, the angle is displayed in the left side of the viewer (in place of the angle viewer). The sync points could be video or audio cues (such as a clapboard closing or a door slam).

3. Locate the corresponding sync point in one or more angles that you want to sync to the original angle.

   To simplify this process, you can add markers at the sync points, to guide you visually and to provide snap points.

4. Drag the clips left or right in the rows of the angle editor so that the sync points align vertically.
If an angle contains more than one clip, you can easily select all clips in the angle so that you can move them all at once. To do this, click the pop-up menu next to the angle name and choose Select Clips in Angle.

You can then drag the clips left or right to move them all by the same amount.
Automatically adjust the sync of a multicam clip

The instructions below describe two automatic methods for syncing angles in a multicam clip.

1. In Final Cut Pro, double-click a multicam clip in the browser to open the angle editor.

2. In the out-of-sync angle, click the pop-up menu to the right of the angle name and choose one of the following:
   
   • **Sync to Monitoring Angle**: This option opens a two-up display in the viewer, showing the frame at the skimmer position on the left and the frame at the playhead position of the monitoring angle on the right. In the out-of-sync angle, skim to a frame, then click to sync the angle to the playhead position. All the clips in the angle move together to align the frame you clicked with the playhead. To close the two-up display in the viewer, click Done.

   • **Sync Angle to Monitoring Angle**: This option compares the audio waveforms in the selected angle to the waveforms in the monitoring angle, and then moves the clips in the selected angle to sync them with those in the monitoring angle. This is the same audio sync technology that you can use to automatically analyze and sync clips together into a compound clip.

   If you select clips in one or more angles before choosing this option, the command name in the pop-up menu changes to Sync Selection to Monitoring Angle. When you choose this option, Final Cut Pro moves all of the selected clips to sync them with those in the monitoring angle. If there's a selection in the monitoring angle, this option is not available.

   **WARNING**: This option does not ripple clips forward. If clips are moved to a timeline location that's already occupied by existing clips, the moved clips overwrite the existing clips.

   **Note**: Some audio recordings are not suited for use with this feature. Choosing this option may result in long processing times during which Final Cut Pro is not available for editing.
Adjust the order of angles in a multicam clip
You can adjust the order in which angles appear in the angle viewer and the angle editor.

Note: If you've already started a multicam edit on a multicam clip in the timeline, changing the angle order does not affect which angle is chosen for each cut and switch edit.

1. In Final Cut Pro, double-click a multicam clip in the browser to open the angle editor.
2. Drag the handle at the right side of an angle row to move the angle up or down in the angle order.

The angles in the angle editor and the angle viewer change to the new order.

Add, delete, or rename angles in a multicam clip
1. In Final Cut Pro, double-click a multicam clip in the browser to open the angle editor.
2. Do any of the following:
   - Delete an angle: Click the pop-up menu to the right of the angle name and choose Delete Angle.
     The angle is removed from the angle editor, the angle viewer, and all child clips of the multicam clip.
     Important: Deleting an active angle affects the edits in your projects. The deleted angle is replaced with black filler in all projects.
   - Add an angle: Click the pop-up menu to the right of the angle name and choose Add Angle.
     A new, empty angle appears in the angle editor and the angle viewer.
   - Rename an angle: At the left side of the angle editor, click the name of the angle you want to rename. When the text becomes highlighted, type the new name.
     The new name appears in the angle editor and (if overlays are turned on) in the angle viewer.

You can also copy and paste clips in the angle editor. Clips are pasted sequentially as overwrite edits, and in the monitoring angle only.

To close the angle editor and return to the timeline, choose View > Timeline History Back, or press Command-Left Bracket ([]).
Edit multicam clips in Final Cut Pro for Mac

You can switch multicam clip angles directly in the timeline or the Info inspector, without having to open the angle viewer.

Multicam clips generally function just like standard clips in the timeline. You can add video and audio effects, transitions, and markers; attach connected clips; and apply retiming effects. You can apply split edits to multicam clips and edit them in the precision editor. You can nest multicam clips in compound clips and storylines.

However, multicam clips do have some unique characteristics in the Final Cut Pro timeline:

- You can display the names of the active video angle and the active audio angle in the multicam clip.
- Cut and switch edit points appear as dotted lines. These are through edits (in which the video or audio content on either side of the edit point is continuous). In the case of multicam editing, through edits indicate that the content on either side of the edit point comes from the same multicam clip. A gray dotted line indicates that different angles from the same multicam clip are on either side of the edit point. A white dotted line indicates that the same angle is on either side of the edit point.

![Before the cut, the angle is “Kelly CU Left.”](image)

![After the cut, the angle is “Kelly Engine View.”](image)

![A through edit point appears at the playhead position. Standard edit point](image)
In the case of video-only or audio-only cuts and switches, the edit point can be mixed (with both gray and white dotted lines). For example, when you cut and switch video only, you see a gray dotted line for the video and a white dotted line for the audio.

- When you move the pointer over a multicam through edit, the pointer changes to the Trim tool, indicating that the edit will be a roll edit (because any other type of edit breaks the relationship between the clips on either side of the cut and switch edit point in the timeline).

- Many edits (such as split edits, markers, connected clips, and retiming effects) remain in place on a multicam clip in the timeline even after you switch the angle. However, the following editing operations are associated directly with the specific angle and are not retained when you switch angles:
  - Video and audio effects
  - Keyframing (including audio volume and panning)
  - Role assignments

**Switch angles in the timeline**

1. In the Final Cut Pro timeline, Control-click the multicam clip you want to switch.

2. Do one of the following:
   - **Switch the video angle**: Choose Active Video Angle, then choose the angle you want to switch to.

     - **Switch the audio angle**: Choose Active Audio Angle, then choose the angle you want to switch to.

The clip switches to the video or audio angle you chose.
Switch angles in the inspector
Switching angles in the inspector allows you to switch angles for multiple selected multicam clips at once.

1. In Final Cut Pro, select one or more multicam clips that you want to switch.
2. Open the Info inspector.
3. In the Info inspector, do one of the following:
   - **Switch the video angle**: Click the Active Video Angle pop-up menu, then choose the angle you want to switch to.
   - **Switch the audio angle**: Click the Active Audio Angle pop-up menu, then choose the angle you want to switch to.

Display the names of active angles in the timeline
You can display the names of the active video angle and the active audio angle in a multicam clip in the timeline, in the following format: V: *video angle name* | A: *audio angle name*.

1. In Final Cut Pro, click the Clip Appearance button in the top-right corner of the timeline.
2. Select the Angles checkbox.

Remove multicam through edit points
In Final Cut Pro, do any of the following:

- **Remove an individual multicam through edit**: Select it and press Delete.
- **Remove multiple through edits at once**: Select the edit points (or select the clips on both sides of the through edits), then choose Trim > Join Clips.
Multicam editing tips in Final Cut Pro for Mac

The following tips can help you streamline your Final Cut Pro multicam workflow:

- Set the date, the time, and the time zone on your camcorder or recording device before you shoot footage for your multicam project. This provides useful information to Final Cut Pro during the automatic multicam clip creation process (see Create multicam clips).

  *Note: At any time, you can change the Content Created date and time of your source clips in the browser. Just select one or more clips, then choose Modify > Adjust Content Created Date and Time.*

- Because you can use the sophisticated automatic audio sync feature in Final Cut Pro to help ensure multicam sync accuracy, it makes sense to record audio on every camcorder and recording device in your multicam production. (Clear audio recordings provide the best results.)

- Before you edit multicam clips in the angle editor, duplicate them in the browser to maintain clean backup copies.

- To double-check the sync of individual angles in a multicam clip, open the clip in the angle editor and turn on audio monitoring for two or more angles at a time. You’ll hear immediately if the angles are in sync or if you need to adjust them further.

- If performance becomes an issue while you’re working on a multicam project, do any of the following:
  
  - Set Final Cut Pro to use proxy media by choosing Proxy in the Media section of the View pop-up menu (in the top-right corner of the viewer). Proxy playback allows you to play back more angles at a time. To use proxy playback, you must have proxy versions of your media available, or you must create proxy versions. See Create optimized and proxy files.
  
  - Make sure that “Create optimized media for multicam clips” is selected in Playback settings. This option transcodes video to the Apple ProRes 422 codec format, which provides better performance during multicam editing. This option is turned on by default. If the original camera format can be edited with good performance, you can deselect this checkbox.
  
  - Make sure that the disk holding your multicam source clips is fast enough to play back all of your media at once. To check disk performance, choose Final Cut Pro > Settings, click Playback, then select “If frames drop due to disk performance, warn after playback.” To find out whether something else is causing playback issues, select “If a frame drops, stop playback and warn.”
  
  - You can include audio from multiple angles, even after you’ve finished cutting and switching your multicam program. Select the multicam clip in the timeline and, in the Audio inspector, select the checkboxes to enable the audio components for the other angles in the multicam clip. With the timeline clip still selected, choose Clip > Expand Audio Components (or press Control-Option-S) to show the components in the timeline. Then select the individual audio components in the timeline and adjust the levels as needed. See Configure audio channels, Manage role components in multicam clips, and Show expanded audio components.

- You can use photos (from a still camera) in a multicam clip. If the date and time (Content Created) information matches the contents of the other angles, the photos are automatically adjusted in duration to “fill in” the angle.
Add storylines in Final Cut Pro for Mac

Storylines are sequences of clips connected to the primary storyline (the main sequence of clips in the timeline). Storylines combine the convenience of connected clips with the precision editing capabilities of the primary storyline.

You can use storylines for the same purposes as connected clips—for example, creating cutaways, compositing titles and other graphics, and adding sound effects and music. The unique advantage of storylines is the ability to edit a sequence of connected clips within the context of the other clips in the timeline. For example, you can add cross dissolve transitions to a series of superimposed titles in a storyline and then adjust the timing of the titles to match clips in the primary storyline.

Like connected clips, storylines can contain both video and audio, or they can be video only or audio only. For more information about connected clips, see Connect clips.

You edit storylines using the same methods you use to edit the primary storyline. You can:

- **Add clips:** Drag clips to the storyline to add them, or use a standard append edit, insert edit, replace edit, or overwrite edit.
- **Add transitions, titles, effects, and generators:** Add effects to a storyline by dragging them or by using any of the standard commands and keyboard shortcuts.
  
  Note: When you apply a transition to a clip connected to the primary storyline, a storyline is automatically created for that clip.
- **Trim clips:** Use any of the standard trim edits in a storyline, including ripple edits, roll edits, slip edits, and slide edits. You can also trim or move clips within storylines by entering timecode values.
- **Create split edits:** Set separate video and audio start and end points in an individual clip to create split edits (L-cuts and J-cuts) in a storyline.
Create storylines

You can quickly create storylines from connected clips.

1. In the Final Cut Pro timeline, select two or more connected clips.

2. Choose Clip > Create Storyline (or press Command-G).

   A gray border appears around the clips, indicating a storyline.

   Note: If the original connected clips are not contiguous, Final Cut Pro inserts a gap clip to fill the space between the clips.
You can also create a storyline by holding down the G key as you drag a clip to a connected clip so that their edges touch.

**Collapse connected clips or storylines into a single storyline**

You can tidy up your timeline by collapsing a selected group of connected clips or storylines into a single connected storyline.

1. In Final Cut Pro, select the connected clips or storylines you want to combine.

At least two of the selected items must be overlapping. If none of the selected items overlap, you can choose Clip > Create Storyline (or press Command-G). See Create storylines, above.

*Note:* The selection can’t contain audio-only clips.
2. Choose Edit > Collapse to Connected Storyline (or press Shift-Command-Down Arrow). The selected items are combined into a single storyline.

Tip: You can also collapse connected clips or storylines to the primary storyline. See Move clips from and to the primary storyline without rippling the project.

Select and move storylines
You can select or move entire storylines as if they were standard clips or compound clips. Storylines have the connection properties of connected clips.

In the Final Cut Pro timeline, do any of the following:

• Select a single storyline: Click the gray border at the top of the storyline.

• Drag to select one or more storylines: Drag a selection rectangle over the storylines you want to select, making sure to drag over the gray border at the top of a storyline first (if you don’t drag over the top gray border first, you will select individual clips in the storyline instead). When a storyline is selected, the entire storyline is outlined with a yellow border.

Tip: To select entire storylines, drag in a downward motion. To select clips within the storylines, drag in an upward motion.
• *Move a storyline by dragging it:* Click the gray border at the top of the storyline, then drag the storyline left or right to connect it to a different point along the primary storyline.

• *Move a storyline with timecode values or keyboard shortcuts:* Use the same techniques you would use with standard clips.

  See [Arrange clips in the timeline](#).

**Break apart storylines**

You can convert a storyline back to its component clips. In the Final Cut Pro timeline, do one of the following:

• Select the storyline (by clicking its gray border), then choose Clip > Break Apart Clip Items (or press Shift-Command-G).

• Drag the storyline into the primary storyline.

**Use the precision editor in Final Cut Pro for Mac**

You can fine-tune the edit point between two clips in the timeline using the precision editor, which provides an expanded view of the clips on either side of the edit point as well as the unused portions of each clip. You can trim or extend the end of one clip and the beginning of the next, either separately or together. As you make changes, you can instantly see how your edits affect the cut or transition from one clip to the next.

You can also see a “two-up” display in the viewer as you trim edit points in the timeline. See [Show trimming details in the viewer](#).
1. In Final Cut Pro, click the Tools pop-up menu in the top-left corner of the timeline and choose either the Select tool or the Trim tool.

2. Double-click the edit point you want to trim in the timeline.

The precision editor appears, presenting an expanded view of your outgoing and incoming shots. The edit point is represented by a vertical line in the center of the precision editor. The outgoing clip and the clips before it appear in the top part of the storyline. The incoming clip and the clips after it appear in the bottom part.

The dimmed portions of clips to the right and left of the edit line are the unused portions of media that are available for trimming (called media handles). You can skim over these areas to view and play back the media as you decide where to trim.
3. To adjust the edit point, do any of the following:

- Move the edit line in the center of the precision editor by dragging its handle left or right.

  Moving the entire edit line performs a roll edit.

- Drag the end point of the outgoing clip or the start point of the incoming clip. This performs a ripple edit.

  Note: You can drag the edit line or individual edit points to the extent that there are media handles available. When you extend a clip to its maximum length in either direction, the clip edge turns red.
- Skim over and click the outgoing clip or the incoming clip at any point.

The clip’s edit point is adjusted to the frame you click. This is the equivalent of a ripple edit.

You can also enter a timecode value to adjust the edit point numerically. If you select either the end point of the outgoing clip or the start point of the incoming clip, a ripple edit is performed. Otherwise, a roll edit is performed.

4. To navigate to another edit point, do one of the following:
   - Go directly to an edit point: Click the other edit point.
   - Go to the next or previous edit point: Press the Up Arrow or Down Arrow key.

5. To close the precision editor, double-click the current edit point, or press the Esc (Escape) key.
Try out clips using auditions

Intro to auditions in Final Cut Pro for Mac

In Final Cut Pro, you can organize related clips into sets, called *auditions*, from which you can choose one clip to use. You can create an audition composed of different clips to try out multiple takes, or you can create an audition composed of multiple versions of the same clip to preview different effects.

An audition’s filmstrip displays the currently selected clip, called the *pick*. All other clips in the audition are referred to as *alternates*. You can open an audition to see the selected clip and the alternates.

Auditions allow you to preserve your alternative edits without affecting the other clips in the timeline. When you’re not reviewing the clips in an audition, the audition functions like an individual clip. You can trim an audition, apply transitions between auditions and other clips, and add keywords and markers.

After you’ve reviewed the clips in the audition and decided which one works best in your project, you can finalize the audition, which dissolves it and leaves the pick as an individual clip in the timeline. The pick retains the audition’s position in the timeline and all keywords and markers applied to the audition.

*Note:* Auditions appear in the browser and the timeline as clips with an audition icon in the top-left corner.
Create auditions in Final Cut Pro for Mac

You can create auditions in the browser and then add them to the timeline, or you can create auditions directly in the timeline. When you create auditions in the timeline, you can either group related clips or group multiple versions of the same clip (for example, to try out multiple effect treatments or lower-third titles).

Create auditions in the browser

1. In Final Cut Pro, select the clips you want to include in the audition.
2. Choose Clip > Audition > Create (or press Command-Y).

Create auditions in the timeline

In Final Cut Pro, do any of the following:

- **Create an audition with related clips:** Drag a clip or a group of clips from the browser onto a clip in the timeline, then choose an audition option from the menu that appears.

    Choosing Add to Audition creates an audition with the current timeline clip as the pick. Choosing Replace and Add to Audition makes the clip you’re dragging the pick.

    **Important:** If a transition is applied to the current clip in the timeline and the pick for the new audition lacks sufficient media for the transition, the transition is either shortened or removed.

- **Create an audition with a duplicate version of a clip, including applied effects:** Select a clip in the timeline, then choose Clip > Audition > Duplicate as Audition.

    An audition is created containing the selected clip and a duplicate version that includes any effects applied to the original.

- **Create an audition with a duplicate version of a clip, without applied effects:** Select a clip in the timeline, then choose Clip > Audition > Duplicate from Original (or press Shift-Command-Y).

    An audition is created containing the selected clip and a duplicate version without any applied effects.

Open an audition

After you create an audition, you can open it and review its contents.

In Final Cut Pro, do one of the following:

- Choose Clip > Audition > Open (or press Y).
- Click the audition icon.

The Audition window appears, and you can **preview your clips to choose a pick**.
Break apart an audition
You can break apart an audition to convert its contents to individual clips in the timeline. (This option is not available for auditions in the browser.)

1. Select an audition in the Final Cut Pro timeline.
2. Choose Clip > Break Apart Clip Items (or press Shift-Command-G).
   The audition selected in the timeline is replaced with the individual items that made up the audition.

You can also break apart compound clips, storylines, and standard clips. See Create compound clips and Add storylines.

Add clips to auditions in Final Cut Pro for Mac
When building auditions to try out different clips or versions of a clip with different effects, you can add and remove clips at any time. In the browser and the timeline, you can add new clips to the audition as well as duplicate clips within an audition. When an audition in the timeline contains the clips you want to try out, you can use the audition to preview the clips or effects in your project.

Add clips to an audition in the browser
In Final Cut Pro, do any of the following:

- **Add new clips to an audition in the browser:** Select the audition and the clips you want to add to it, then choose Clip > Audition > Create (or press Command-Y).

![Select a clip to add to the audition.](image1)

- **Duplicate a clip within an audition in the browser:** Click the icon in the top-left corner of the audition to open the Audition window, select the clip you want to duplicate, then click Duplicate.

![Select the clip you want to duplicate, then click Duplicate.](image2)

A new version of the selected clip appears in the Audition window.
Add clips to an audition in the timeline

In Final Cut Pro, do any of the following:

- **Add a new clip to an audition and maintain the current clip in the timeline as the pick:** Drag a clip from the browser to the audition in the timeline, then choose Add to Audition.

- **Add a new clip to an audition and make the clip you’re adding the pick:** Drag a clip from the browser to the audition in the timeline, then choose Replace and Add to Audition.

  **Important:** If a transition is applied to the current clip in the timeline and the pick for the new audition lacks sufficient media for the transition, the transition is either shortened or removed.

- **Duplicate a clip within an audition:** Click the audition icon in the top-left corner of the audition to open the Audition window, select the clip you want to duplicate, then click Duplicate (or press Shift-Command-Y).

  A new version of the selected clip appears in the Audition window.

Remove a clip from an audition

1. In Final Cut Pro, open the audition containing the clip you want to remove by clicking the icon in the top-left corner.

2. In the Audition window, select the clip you want to remove, then press Delete.

   The clip is removed from the audition.

Review clips in auditions in Final Cut Pro for Mac

You create an audition to try out the clips within it and find the one that works best for your project. Although the audition workflow may differ from project to project, the general process is the same: You create an audition that contains a set of alternative takes, effects, or text treatments, and then you choose the best clip for the edit by making it the pick. When you’re sure of your decision, you finalize the audition, which dissolves it and leaves the pick in the timeline.

Depending on your workflow, you may try out the clips within your auditions and flatten the auditions as you go, or you may leave the auditions in the timeline.

**Note:** You can use audition commands with only one selected audition at a time. For example, you can’t finalize multiple selected auditions.
Review clips within an audition in the timeline

1. In the Final Cut Pro timeline, select the audition containing the clips you want to review, then open it by choosing Clip > Audition > Open (or pressing Y).

2. In the Audition window, select the pick and press the Space bar (or press Control-Command-Y) to play it.

3. To play an alternate clip in the viewer, select a clip to the right or left of the pick (or press the Right Arrow or Left Arrow key).

⚠️ Tip: To quickly move through and play alternate clips, select a closed audition in the timeline, press the Space bar, then press Control-Left Arrow to play clips to the left of the current pick, or Control-Right Arrow to play clips to the right.
4. When you decide on the clip you want to use, make sure it’s selected, then click Done.

5. If you’re sure of your decision and want to finalize the audition, choose Clip > Audition > Finalize Audition (or press Option-Shift-Y).

   The audition is dissolved, leaving the pick in the timeline. The clip selected as the pick retains any keywords or markers assigned to the audition.

**Try out multiple effects on a clip in the timeline**

You can try out effects on a clip in the timeline by creating an audition and adding individual effects to duplicates of the same clip. This technique allows you to view each effect in relation to the clips that precede and follow the audition in the timeline.

1. In the Final Cut Pro timeline, select the clip you want to try different effects on.

2. Choose Clip > Audition > Duplicate as Audition (or press Option-Y).

3. Repeat step 2 for each effect that you want to try out.

4. To open the Audition window, click the icon in the top-left corner of the audition (or press Y).

5. To open the Effects browser, click the Effects button in the top-right corner of the timeline (or press Command-5).

6. In the Audition window, select the version of the clip you want to apply the effect to.

7. In the Effects browser, select the effect you want to try out, then drag it to the clip in the Audition window.
8. Repeat steps 6 and 7 until you've applied all the effects you want to try out.

9. To review the effects, select clips in the Audition window (you can select the clip to the right or left of the pick).

Tip: To quickly move through alternate clips, press Control-Option-Left Arrow to move your selection left, or Control-Option-Right Arrow to move your selection right.

10. When you decide on the effect you want to use, select the clip with that effect in the Audition window and click Done.

11. If you're sure of your decision and want to finalize the audition, choose Clip > Audition > Finalize Audition (or press Option-Shift-Y).

    The audition is dissolved, leaving the clip with your chosen effect in the timeline.

Tip: To have Final Cut Pro duplicate a clip in the audition and apply an effect to the duplicated clip, hold down the Control key while you drag an effect from the Effects browser to the audition in the timeline. You can also apply an effect to every clip in an audition by holding down the Option key and the Control key while you drag the effect to the audition. In both cases, you must start dragging the effect from the Effects browser and then press the keys as you add the effect to the clip.
Retime clips to create speed effects

Intro to retiming clips in Final Cut Pro for Mac

You can adjust a clip’s speed settings to create fast-motion or slow-motion effects. You can also reverse a clip, rewind a segment of a clip, apply variable speed effects (also called speed ramping) to a clip selection, and create instant replays and jump cuts. By default, Final Cut Pro maintains the audio pitch of any speed adjustment, but you can turn off this feature to accentuate the speed effect.

You can’t apply speed changes to still images, generators, titles, and themes in Final Cut Pro.

Change clip speed in Final Cut Pro for Mac

In Final Cut Pro, you can make both constant and variable speed changes to your clips while preserving the audio’s pitch.

Note: Speed settings are applied to the specific instance of the selected clip only. They are not applied to that clip’s source media file on your Mac or storage device. To create a media file with the applied speed effects, export the clip as a QuickTime movie. See Export final mastering files.

Apply a constant speed change

Applying a constant speed change to a range selection or a whole clip alters the selection's playback speed by a uniform percentage. For example, applying a speed setting of 25 percent to the selection makes the entire selection play in slow motion.

Constant speed changes usually alter the duration of a clip. By default, if a constant speed change causes the duration of a clip to become longer or shorter, all clips coming after it ripple forward or backward. If you change the speed to 50 percent, your clip becomes twice as long, and subsequent clips are moved to the right; if you change the speed to 200 percent, the clip becomes half as long, and subsequent clips ripple left. For example, if you set a 5-second clip to play back at 50 percent speed, Final Cut Pro adds frames to the clip so that the clip becomes 10 seconds long and plays back more slowly. If you increase the clip's speed to 200 percent, Final Cut Pro removes frames and the clip plays back in only 2.5 seconds.
1. In the Final Cut Pro timeline, select a range, a whole clip, or a group of clips whose speed you want to change.

2. Do one of the following:
   - *Apply a preset speed setting:* Click the Retime pop-up menu below the viewer and choose Slow or Fast, then choose a speed from the submenu.

   ![Preset Speed Setting](image1)

   - *Apply a manual speed setting:* Click the Retime pop-up menu and choose Show Retime Editor (or press Command-R) to display the retime editor above the selection in the timeline, then drag the retiming handle.

     If you drag the retiming handle to the right, the speed of the selection decreases, the duration of the selection increases, and the bar above the timeline selection turns orange.

   ![Manual Speed Setting](image2)
If you drag the retiming handle to the left, the speed of the selection increases, the duration of the selection decreases, and the bar above the timeline selection turns blue.

- **Apply a custom speed setting:** Click the Retime pop-up menu and choose Custom. In the Custom Speed window that appears, select a direction (forward or reverse), then select either Rate or Duration and enter a speed percentage or duration. If you want to allow subsequent clips in the timeline to move earlier or later as a result of the speed change, leave the Ripple checkbox selected. To prevent subsequent clips from moving, deselect the checkbox.

**Apply a constant speed change without rippling the sequence**

You can also create speed changes that don’t cause the downstream clips to ripple. In this case, if you slow down a clip (which ordinarily makes the clip longer), the clip remains at its current length but a shorter piece of the action is seen. For example, if you slow down a 5-second shot of a football being thrown and caught to 50 percent, you see the ball being thrown (slowly), but because the action now takes twice as long, the clip ends before the ball is caught.

*Note:* If there's a gap to the right of a clip that's being slowed down, the clip’s duration is lengthened to cover the gap.

When a clip is sped up, the duration of the clip is shortened and a gap fills the space between the changed clip and the remainder of the project.

1. In the Final Cut Pro timeline, select a range, a whole clip, or a group of clips whose speed you want to change.
2. Click the Retime pop-up menu below the viewer and choose Custom.
3. Select a direction (Forward or Reverse), deselect the Ripple checkbox, then type a percentage in the Rate field.

4. Press Return.

The speed effect is applied to the clip, and the rest of the project remains in place.

**Turn off Preserve Pitch for retimed clips**

By default, Final Cut Pro is set to preserve the audio pitch of a clip that has been retimed. However, if you want to accentuate the retiming adjustment’s effect by allowing the pitch to change in accordance with the retiming adjustment, you can turn this feature off.

1. In the Final Cut Pro timeline, select a range, a whole clip, or a group of clips whose speed you want to change.
2. **Apply the speed change.**
3. Click the Retime pop-up menu below the viewer and choose Preserve Pitch.

Choose Preserve Pitch again to turn it back on. A checkmark to the left of the command name indicates that Preserve Pitch is turned on.

**Create speed effects by maintaining a clip’s original frame rate**

If you’ve applied speed effects using your camera (for example, by shooting with a high frame rate), the native speed of the source media may not match the native speed of the source media for the rest of the clips in your project in the timeline. If you shoot video at a different frame rate to create a speed effect, you can use the Automatic Speed option to maintain the clip’s original frame rate.

For example, suppose you shoot a scene at 120 fps and then add the shot to a 30 fps project. If you apply Automatic Speed to that clip, every frame in the original clip plays back at the project’s frame rate of 30 fps, so the action takes longer and a slow-motion effect is created. You can use this method to create high-quality speed effects, because every frame in the original clip is played back—no frames are skipped or duplicated.
1. In the Final Cut Pro timeline, select the clip whose original frame rate you want to maintain.

2. Click the Retime pop-up menu below the viewer and choose Automatic Speed.

Smooth out a slow-motion clip with video quality presets

To smooth out the apparent motion of a clip playing back in slow motion, you can apply frame blending or optical flow analysis to the retimed clip.

Note: Final Cut Pro 10.2 or later uses an advanced optical flow algorithm that can accommodate a wide range of source footage. Any new projects created with Final Cut Pro 10.2 or later will benefit from these improvements (if they include an optical flow video quality setting). If you have projects created in earlier versions of Final Cut Pro that have optical flow settings, you can reanalyze them for improved quality by choosing Optical Flow in step 2 below.

1. In the Final Cut Pro timeline, select a range, a whole clip, or a group of clips set to play in slow motion.

2. Click the Retime pop-up menu below the viewer and choose Video Quality, then choose a setting from the submenu.

- Normal (Floor): The default setting. Final Cut Pro duplicates frames or rounds down to the nearest whole frame. For the highest-quality playback, rendering is recommended.

- Nearest Frame: Final Cut Pro rounds up or down to the nearest whole frame. This setting reduces artifacts but may cause visual stuttering. Rendering is required.

- Frame Blending: Creates in-between frames by blending individual pixels of neighboring frames. Slow-motion clips created with Frame Blending appear to play back more smoothly than those created with the Normal (Floor) or Nearest Frame setting. This setting provides better reduction of visual stuttering, but there may be some visual artifacts. Rendering is required.

- Optical Flow: A type of frame blending that uses an optical flow algorithm to create new in-between frames. Final Cut Pro analyzes the clip to determine the directional movement of pixels and then draws portions of the new frames based on the optical flow analysis. Rendering is required, and takes longer than for the other frame-sampling methods. Only the portion of the clip used in the project (the media between the clip start and end points) is analyzed.

Tip: Before using Optical Flow, try using Frame Blending and experiment with various slow-motion settings until you're satisfied with the clip speed. Then, if you see artifacts or want the very best image quality, try using Optical Flow.
Create variable speed effects in Final Cut Pro for Mac

In addition to constant speed changes, you can create variable speed effects in which the playback speed of a clip changes dynamically. For example, a clip might start in slow motion, speed up to fast motion, and then slow back down to regular speed. You create variable speed changes by identifying ranges of a clip as speed segments—sections in a clip that have different playback speeds. Each speed segment has its own constant speed setting. You can set speed segments to any speed value, forward or backward, and you can create abrupt shifts between speed segments, or gradual transitions (also called ramps).

Note: You can’t create smooth transitions between a speed segment set to a forward speed and a speed segment set to reverse speed (and vice versa).

Apply a preset variable speed change

You can apply preset variable speed effects that break your clip into multiple speed segments automatically.

1. In the Final Cut Pro timeline, select either a range within a clip or a whole clip to which you want to apply a speed ramp effect.

2. Do one of the following:
   - **Ramp the speed down**: Click the Retime pop-up menu below the viewer and choose Speed Ramp > to 0%.
   - **Ramp the speed up**: Click the Retime pop-up menu and choose Speed Ramp > from 0%.

The selection is segmented into four parts with different speed percentages, creating the ramp effect. To adjust the speed of any segment, drag its retiming handle.

You can modify the transitions between segments to control how fast each segment transitions to the next. See Add speed transitions.
Change the end frame of a speed segment
You can change the end frame of a speed segment in the timeline.

When you drag the retiming handle of a speed segment, you’re adjusting the speed of the segment, not trimming it. The Source Frame Edit button allows you to trim the end point (end frame) of a segment.

1. In the Final Cut Pro timeline, select a clip that has speed segments.
2. Click the Retime pop-up menu below the viewer and choose Show Retime Editor (or press Command-R).
3. In the retime editor in the timeline, double-click the transition between two speed segments.
4. In the Speed Transition window, click the Source Frame Edit button.
   A filmstrip icon appears over the end frame of the speed segment.
5. To change the end frame, drag the filmstrip icon left or right.

As you drag, the viewer displays the current end frame.

Create custom variable speed changes
You can manually divide a clip into segments and assign each segment its own speed setting.

1. In the Final Cut Pro timeline, position the playhead or the skimmer at the frame where you want to begin a new speed segment.
2. Click the Retime pop-up menu below the viewer and choose Blade Speed (or press Shift-B).
The retime editor appears above the clip (if it wasn't already shown), and the clip is divided into two speed segments.

3. To set the speed for the newly created segments, do one of the following:
   • Double-click the retime editor above one of the speed segments. Then, in the Custom Speed window, set a new speed by selecting either Rate or Duration and entering a speed percentage or a duration. Click anywhere outside the Custom Speed window to close it.
   • Drag the right edge of a speed segment in the retime editor.

4. To create and modify additional speed segments, repeat steps 1 to 3.

   You can modify the transitions between segments to create smooth adjustments from one speed to another. See Add speed transitions.

Add speed transitions in Final Cut Pro for Mac

When two adjacent speed segments are set to play at different speeds, you can control how smoothly the video switches between playback speeds. When there's no transition between the segments, playback shifts suddenly from one speed to another. By adding a transition between the segments, you can create a more gradual, or ramped, effect. You can also control how quickly that transition takes place.

When you apply effects that create speed segments in a clip (such as Speed Ramp, Instant Replay, and Hold), transitions are automatically added between the newly created segments. A transition appears as a shaded bar on either side of the border between speed segments.

When you create speed segments manually, you can add speed transitions individually, or you can add them to all the speed segments in a clip at once.

Note: You can’t add transitions between forward-playing segments and reverse-playing segments (or vice versa).
Add transitions between all speed segments in a clip

1. In the Final Cut Pro timeline, select a clip that has speed segments.

2. Click the Retime pop-up menu below the viewer and choose Speed Transitions, so that there’s a checkmark next to the menu item.

Transitions are added to the boundaries between speed segments.

Remove transitions from all speed segments in a clip

1. In the Final Cut Pro timeline, select a clip that has speed transitions.

2. Click the Retime pop-up menu below the viewer and choose Speed Transitions, so that the checkmark next to the menu item is removed.

Speed transitions are removed from all speed segments in the clip.
**Remove individual speed transitions**

To add transitions between some speed segments in a clip and not others, you must turn on Speed Transitions in the Retime pop-up menu and then remove the transitions you don’t want.

1. In the Final Cut Pro timeline, select a clip that has speed segments.

2. Click the Retime pop-up menu below the viewer and choose Speed Transitions, so that there’s a checkmark next to the menu item.

   ![Speed transitions are added to all speed segments in the clip.](image)

3. To remove a transition between speed segments, double-click the last frame of the outgoing speed segment in the retime editor.
4. Deselect the Speed Transition checkbox in the Speed Transition window, then click anywhere outside the window to dismiss it.

The transition is removed.

Change the duration of a speed transition
After a speed transition is applied, you can change its duration. The shorter the transition, the more quickly the speed ramps from one value to another. The longer the transition, the slower the ramp.

1. In the Final Cut Pro timeline, select a clip that has a speed transition.
2. If the retime editor isn’t shown, click the Retime pop-up menu below the viewer and choose Show Retime Editor (or press Command-R).
3. Drag the left or right edge of the transition bar in the retime editor.

Reverse or rewind clips in Final Cut Pro for Mac
In addition to changing the speed of a clip in Final Cut Pro, you can also add directional effects:

- **Reverse**: Reverses the order of frames in the clip, so that the last frame plays first.
- **Rewind**: Appends a duplicate of a range selection or clip as a segment, rewinds the duplicated segment at 1x, 2x, or 4x speed, and then plays the original clip segment again in forward motion at normal speed.
Reverse a clip

1. In the Final Cut Pro timeline, select a clip or a group of clips whose contents you want to reverse.

2. Click the Retime pop-up menu below the viewer and choose Reverse Clip.

   ![Reverse Clip Menu](image)

   The green bar with arrows pointing to the left above the selection in the timeline indicates that the clip is reversed.

3. If you want to adjust the speed of the reversed clip, drag the retiming handle.
   Dragging to the left increases the speed, and dragging to the right decreases it.

   ![Retiming Handle](image)

4. To see the effect, play back the reversed clip or selection.

Rewind a range selection or clip

1. In the Final Cut Pro timeline, select a range, a whole clip, or a group of clips whose contents you want to rewind.

2. Click the Retime pop-up menu below the viewer and choose Rewind, then choose a speed from the submenu.

   ![Rewind Menu](image)

   The selection is duplicated, added to the end of the original selection, and then reversed at the speed you chose. An additional duplicate of the timeline selection follows the reversed section and plays back in forward motion at the selection’s original speed.
3. If you want to adjust the speed of the rewound section or the section before or after the rewound section, drag the section’s retiming handle. Dragging to the left increases the speed, and dragging to the right decreases it.

4. To see the effect, play back the rewound clip or selection.

Create instant replays in Final Cut Pro for Mac

You can apply an instant replay to a range selection within a clip or to a whole clip. Final Cut Pro duplicates the range or clip, appending the duplicated frames to the end of the selection as a new segment. You can then modify the speed of the new segment to achieve the instant replay effect you’re looking for.

1. In the Final Cut Pro timeline, select a range or a whole clip whose contents you want to use to create an instant replay.

2. Click the Retime pop-up menu below the viewer, choose Instant Replay, and choose a clip speed from the submenu.

A duplicate of the range or clip is appended to the end of the selection and plays back in forward motion at the speed you chose, and an “Instant Replay” title appears in the upper-right corner of the frame. For information about adjusting the title, see Adjust titles.
3. If you want to adjust the speed of the instant replay segment, drag its retiming handle. Dragging to the left increases the speed, and dragging to the right decreases it.

4. To see the effect, play back the original selection and the instant replay segment.

**Speed up a clip with jump cuts in Final Cut Pro for Mac**

To compress time in a long clip without playing the clip at fast speed, you can create jump cuts to periodically skip over a specific number of frames. For example, if you have a 10-second shot of a person walking down a hallway, rather than playing the entire 10 seconds, you can create jump cuts every 2 seconds that skip 30 frames each, so the action happens in a fraction of the time.

1. In the Final Cut Pro timeline, select the clip that you want to speed up, then add a marker at each frame where you want a jump cut to occur.

2. Click the Retime pop-up menu below the viewer and choose Jump Cut at Markers, then choose a number of frames from the submenu.

You can skip 3, 5, 10, 20, or 30 frames.
Create hold segments in Final Cut Pro for Mac

In Final Cut Pro, you can hold on a particular frame to create a still image, temporarily stopping the action onscreen. This is called a hold segment. By default, a hold segment is added as a 2-second still frame at the location of the skimmer or playhead, but you can change the duration.

Alternatively, you can create separate freeze-frame clips in Final Cut Pro. One key difference between freeze frames and hold segments is that hold segments remain part of the original clip, and you can adjust their duration within the clip. On the other hand, freeze-frame clips are simple and quick to create, and you can move them around in your projects easily. See Create freeze frames.

Important: Adding a hold segment to a clip increases its duration.

1. In the Final Cut Pro timeline, do one of the following:
   - Click the clip with the frame you want to hold, then move the skimmer or playhead to that frame.
   - Select ranges within a clip in the timeline.
2. Click the Retime pop-up menu below the viewer and choose Hold (or press Shift-H).

If you selected a clip, a 2-second hold segment is added to the clip at the position of the skimmer or the playhead.

If you selected a range, a hold segment is created for the duration of the range. The frame used as the still frame is the first (leftmost) frame in the range.
3. If you want to adjust the duration of the hold segment, drag the segment's retiming handle.

   Dragging to the right increases the duration, and dragging to the left decreases it.

4. To see the effect of the hold segment, play back the clip in the timeline.

   Note: You can also create a still-image file from a video frame in your project or from a clip in the browser. For example, you may want to email someone a JPEG image showing a specific moment in your project. See Export still images.

Reset speed changes in Final Cut Pro for Mac

You can reset a range selection or a clip to play back at normal (100 percent) speed. Resetting the speed also removes any directional effects (reverse and rewind) and hold segments applied to the selection.

1. In the Final Cut Pro timeline, select a range, a whole clip, or a group of clips whose speed you want to reset.

2. Click the Retime pop-up menu below the viewer and choose Normal 100% (or press Shift-N).

Conform frame sizes and rates in Final Cut Pro for Mac

Final Cut Pro manages project settings automatically. This means you can work with multiple media types with differing frame sizes (also referred to as resolution) and frame rates in the same project. When you add the first video clip to your project, Final Cut Pro automatically sets the format, frame size, and frame rate for the entire project based on the properties of that first clip (or, more precisely, on the properties of the clip’s source media file).

You can modify the project’s settings at any time, and you can control, on a clip-by-clip basis, how Final Cut Pro conforms an individual clip’s frame rate and frame size to match the project settings. All of the project information in this section applies equally to compound clips, which can have their own distinct project settings.
You can add interlaced clips to progressive (non-interlaced) projects and progressive clips to interlaced projects. To add an interlaced clip to a progressive project, see the instructions below. Final Cut Pro accepts progressive clips in interlaced projects automatically.

Here are things to keep in mind when working with multiple formats and frame sizes:

- Choose video and audio project properties based on how you intend to share your final movie with your audience. For example, if you’re editing a project with mixed-format media and you intend to share it as 1080p HD, you should set your project’s video properties to 1080p HD.

- If you’re unsure of the final distribution format, the most important decision you can make before creating your project is choosing your project’s frame rate. It’s easy to change the format and the frame size of your project, but changing the frame rate can cause all the edit points in your project to shift in time.

- If you have a clip that matches the video and audio properties of the format in which you intend to share your project, add this clip to your project first. Final Cut Pro automatically creates matching project settings. This saves you from having to change your project settings later.

  Tip: If the first clip you add to a project is an audio clip or a still-image clip, Final Cut Pro prompts you to choose the video properties for your project. Cancel the edit, add a video clip whose source media file has the video properties you require for your project, and then add the audio or still-image clip to your project.

**Choose a method of conforming frame size**

You can choose how Final Cut Pro modifies the frame size of a clip to match the project’s frame size settings. For example, you can have Final Cut Pro change the frame size of the clip to fit within the longest dimension of the project's frame dimensions, fill the entire frame of the project (which usually results in cropping), or leave the clip's frame size as is.

1. Open a project in the Final Cut Pro timeline, then add a clip whose frame size (resolution) is different from the project’s frame size.

   For information about adding clips to the timeline, see Intro to adding clips.

2. Select the clip in the timeline.

3. If the inspector isn’t already shown, do one of the following:

   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
4. Click the Video button at the top of the inspector.

5. Click the Type pop-up menu in the Spatial Conform section of the Video inspector, then choose a method of conforming frame size.

   *Note:* If the clip you selected has the same frame size (resolution) as the project, the Spatial Conform section does not appear.

   - **Fit:** The default setting. Fits the clip within the project’s frame size without cropping the clip’s video. Black bars appear on the sides of the frames that don’t match the project’s frame size. In the case of a standard-definition (SD) clip in a high-definition (HD) project, Final Cut Pro scales up the SD clip to fit the HD project’s frame size. In the case of an HD clip in an SD project, Final Cut Pro scales down the HD clip to fit the SD project’s frame size.

   - **Fill:** Makes the clip’s video fill the project’s frame size. In the case of an SD clip in an HD project, Final Cut Pro scales up the SD clip to fit the HD project’s frame size. In the case of an HD clip in an SD project, Final Cut Pro scales down the HD clip to fit the SD project’s frame size. In both cases, cropping occurs along the clip’s longer dimension to allow the shorter dimension to fill the screen.

   - **None:** Leaves the clip’s frame size unchanged. If the clip’s frame size is larger than the project’s frame size, the clip appears cropped. If the clip’s frame size is smaller than the project’s frame size, black bars surround the clip.

**Choose a method of conforming frame rate**

When a clip’s frame rate differs from the project’s frame rate, Final Cut Pro employs a frame-sampling method to change the clip’s frame rate to match that of the project. You can choose which frame-sampling method Final Cut Pro uses to modify the clip’s frame rate. The method you choose depends on how important it is to eliminate visual stuttering and artifacts.

1. In Final Cut Pro, open a project in the timeline, then add a clip whose frame rate is different from the project’s frame rate.

   For information about adding clips to the timeline, see *Intro to adding clips*.

2. Select the clip in the timeline.
3. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

4. Click the Video button at the top of the inspector.

5. Click the Frame Sampling pop-up menu in the Rate Conform section of the Video inspector, then choose a method of conforming frame rate.

   Note: If the selected clip has the same frame rate as the project, the Rate Conform section doesn’t appear in the Video inspector.

   • Normal (Floor): The default setting. Final Cut Pro duplicates frames or rounds down to the nearest whole frame to match the clip's frame rate to the project's frame rate.
   • Nearest Frame: Final Cut Pro rounds up or down to the nearest whole frame to match the clip's frame rate to the project's frame rate. This setting reduces artifacts but may cause visual stuttering.
   • Frame Blending: Creates in-between frames by blending individual pixels of neighboring frames. Slow-motion clips created with Frame Blending appear to play back more smoothly than those created with the Normal (Floor) or Nearest Frame setting. This setting provides better reduction of visual stuttering, but there may be some visual artifacts. For the highest-quality playback, rendering is recommended.
   • Optical Flow: A type of frame blending that uses an optical flow algorithm to create new in-between frames. Final Cut Pro analyzes the clip to determine the directional movement of pixels and then draws portions of the new frames based on the optical flow analysis. This setting usually provides the greatest reduction in visual stuttering and artifacts. Rendering is required, and takes longer than for the other frame-sampling methods.

   Tip: Before using Optical Flow, try using Frame Blending. Then, if you see artifacts or want the very best image quality, try using Optical Flow.
Add an interlaced clip to a non-interlaced (progressive) project

Some video formats use an interlaced scanning method that divides a video frame into two fields, each consisting of alternating odd and even lines that are scanned at different times.

If you want to add an interlaced clip to a progressive project, you can have Final Cut Pro deinterlace the clip so that it plays at full resolution, free of the alternating jagged lines associated with interlaced clips in progressive projects.

1. In Final Cut Pro, do one of the following:
   • In the browser, select the interlaced clips you want to add to a progressive project.
   • In the timeline, select interlaced clips you’ve added to a progressive project.

2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

3. Click the Info button at the top of the inspector.

4. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose Settings.

5. Select the Deinterlace checkbox.

   Note: Selecting the Deinterlace setting causes the frame rate of the selected clips to double. For example, if the original interlaced clips have a frame rate of 29.97 fps, the deinterlaced clips have a frame rate of 59.94 fps. Keep this in mind when you choose the video and audio settings for your project.

   Tip: To confirm the absence of interlacing artifacts, you can press the Left Arrow and Right Arrow keys to step through the clips in the timeline one frame at a time.

6. To display full-resolution frames during playback, click the View pop-up menu in the top-right corner of the viewer and choose Better Quality.

   The clips now play back and function as progressive clips. Depending on your specific computer configuration, background rendering may be necessary.
Use XML to transfer projects in Final Cut Pro for Mac

You can import and export XML (Extensible Markup Language) files in Final Cut Pro. FCPXML is a specialized format that uses XML elements to describe the data exchanged between Final Cut Pro and third-party applications and tools. You can use XML documents (plain ASCII text files with tagged elements) to transfer the details of your libraries, events, projects, and clips between Final Cut Pro and third-party applications, devices, and media asset management tools that don’t recognize Final Cut Pro documents and files.

The XML import and export options are described in detail in the Final Cut Pro XML developer documentation. See Exchanging Content and Metadata with Final Cut Pro at the Apple Developer website.

Import XML into Final Cut Pro

You can generate XML files with other applications and then import them into Final Cut Pro. When you import an XML file, Final Cut Pro generates clips, events, projects, and a library, depending on the contents of the XML file.

1. In Final Cut Pro, choose File > Import > XML.
2. Navigate to the XML file you want to import, then click Import.

Final Cut Pro processes the XML and generates the corresponding clips, events, projects, and library, depending on the contents of the XML file.

Tip: You can also import XML files by double-clicking them in the Finder or dragging them to the Final Cut Pro app icon.

Export XML from Final Cut Pro

You can export events, projects, and libraries as XML files.

1. In Final Cut Pro, select a library, or select one or more events, projects, or clips that you want to export as XML files.

To export the project currently open in the timeline, click in the timeline to make it active.

2. Choose File > Export XML.
3. In the window that appears, enter a name for the XML file in the Save As field.
4. Navigate to a folder on your Mac or storage device where you want to store the XML file.
5. Click the Metadata View pop-up menu and choose a metadata view.

By choosing a metadata view, you determine what information is included in the XML file and how it's organized. See View and change clip metadata and Modify metadata views.

6. Select the XML version (Current or Previous) for the export.

Note: In most cases, you should choose the current version. You have the option to choose the previous version of the Final Cut Pro XML Interchange Format if you have XML processing code or a third-party application that recognizes the previous version only.

7. Click Save.
With Final Cut Pro 10.3 or later and compatible third-party applications, you can incrementally update your libraries, events, projects, and clips simply by dragging them between the applications. For example, you might drag a set of events from Final Cut Pro to your media asset management (MAM) application. Or you might drag a library from your MAM application to Final Cut Pro to update it instantly. For more information about compatible third-party applications, visit the Final Cut Pro Resources webpage.

Note: Final Cut Pro XML version 1.10 or later is required for the object tracking and Cinematic mode video features introduced in Final Cut Pro 10.6. When you export FCPXML using version 1.10 or later, Final Cut Pro uses FCPXML bundles, which have the filename extension .fcpxmld.

Edit 360-degree video

Intro to 360° video in Final Cut Pro for Mac

Using Final Cut Pro, you can import, edit, and share 360° video to provide your audience with immersive viewing experiences. 360° video (sometimes called spherical video) is footage captured by special cameras that point lenses in all directions to create a panoramic sphere of video that surrounds the viewer—as if the video were projected onto the inside of a hollow globe.

Viewers can watch 360° video in several ways. With a virtual reality (VR) headset, viewers can turn their heads to see different parts of a scene. This creates the illusion of being physically in the space. Viewers can also watch 360° video and navigate to all parts of the scene by turning or rotating an iPhone or iPad or by scrolling a rectangular window on a computer.

How 360° video is recorded and displayed

360° footage is recorded using multiple cameras or a dedicated 360° camera with multiple “fisheye” lenses, with each lens recording a different but overlapping camera angle. Before 360° footage is imported into Final Cut Pro, the different camera angles must be stitched together to create a single seamless 360° image. Some 360° cameras do this step automatically; others require that you stitch the camera angles together using special software. For 360° playback and editing in Final Cut Pro, the stitched image must be an equirectangular projection, similar to world maps that depict the globe as a two-dimensional (2D) rectangle.
The examples below show an image from a single fisheye lens, the resulting equirectangular image composed of multiple fisheye images stitched together, and a standard (also called rectilinear) image of the same scene for comparison.

Types of 360° video: Monoscopic versus stereoscopic

There are two types of 360° video: monoscopic (2D) and stereoscopic (three-dimensional, or 3D). In each case, viewers can navigate to any part of the full 360° scene.

- Monoscopic 360° video is a flat 2D rendering that can be viewed on any screen. Viewers can navigate monoscopic 360° video in any direction, but there's no real depth perception; viewing monoscopic video is like looking around with only one eye open.

- Stereoscopic 360° video is split into two views designated for the left and right eyes, creating the perception of depth that people experience in the real world when they have two eyes open. This type of video is designed to be viewed through a special headset or glasses that can project each view into the appropriate eye.
Working with 360° video in Final Cut Pro

You import 360° clips the same way you import other media, but you need to make sure that your 360° clips have the correct metadata assigned. See Import 360-degree video.

You can view and navigate 360° clips in a dedicated 360° viewer. You can also view 360° clips in a VR headset connected to your Mac. You can view and navigate the 360° image in any direction, even when the video is paused. See View and navigate 360-degree video.

To edit 360° video, you create special 360° projects. You can add standard rectilinear video clips to 360° projects, and you can also add 360° clips to rectilinear projects.

When you've finished editing, you can export your 360° clips and projects as files or share them on a variety of video-sharing and social media websites. See Share 360-degree clips and projects.

Import 360° video into Final Cut Pro for Mac

You import 360° video the same way you import any other video media, but there are a couple of important things to keep in mind:

• For proper playback and editing in Final Cut Pro, your 360° media must be formatted for equirectangular projection.
• The metadata associated with your 360° media must be set correctly. After you import 360° media, you can view or change its metadata in the browser and the Info inspector.

Check settings for imported 360° clips

1. Import the 360° video clips into Final Cut Pro.
2. Select a 360° clip in the browser.
3. Do one of the following:
   • Open the Info inspector, then make sure the 360° Projection Mode pop-up menu is set to Equirectangular.
   • Switch the browser to list view, then scroll to the right side of the browser and make sure the clip's 360° Mode column is set to Equirectangular.

If your 360° media is not equirectangular, you can assign other settings to organize your media. For example, if you have fisheye media that hasn't yet been stitched into equirectangular format, you could assign it the Back-to-Back Fisheye setting as a reminder that it still needs to be converted. See 360-degree video settings.

Note: You can tag Fisheye, Back-to-Back Fisheye, and Cubic clips to organize them, but before you can edit them in Final Cut Pro you need to convert those clips to equirectangular clips using stitching software from the camera manufacturer.
4. In the Stereoscopic Mode column in the browser (to the right of the 360° Mode column) or the Stereoscopic Mode pop-up menu in the Info inspector, choose a setting that corresponds to the type of 360° media:

- **Monoscopic:** View for a monoscopic 360° clip (no stereoscopic characteristics). For monoscopic media, make sure to choose this setting.
- **Side by Side:** View for a stereoscopic 360° clip. The images for the left and right eyes are side by side in the video frame.
- **Over/Under:** View for a stereoscopic 360° clip. The images for the left and right eyes are stacked vertically in the video frame.

For more information about stereoscopic media, see View stereoscopic 360° clips in the 360° viewer.

### 360° video settings in Final Cut Pro for Mac

You can assign 360°-related metadata tags to your 360° clips, which is useful for organizing your media and creating 360° projects. Some of these metadata tags are required for your 360° media to play back properly in the viewer and the 360° viewer.

Tagging 360° clips with the correct metadata is a fundamental part of the importing process. See Import 360-degree video.

### 360° Mode settings

The 360° Mode setting indicates the type of projection used to display the clip in the Final Cut Pro viewer and 360° viewer.

- **None:** A standard clip (no 360° characteristics).
- **Equirectangular:** A 360° clip with equirectangular projection—similar to a world map that depicts the globe as a two-dimensional (2D) rectangle.
- **Fisheye:** A clip shot with a 180° fisheye lens.
- **Back-to-Back Fisheye:** A 360° video clip shot with two 180° fisheye lenses facing in opposite directions.
- **Cubic:** A 360° projection in which the spherical view is unfolded like a cube, with six faces surrounding the viewer. Each face is flattened as a rectilinear projection with 90 x 90 degrees of view. Cube maps are stored as six separate square textures or as a single texture with all faces unfolded.

Note: You can tag Fisheye, Back-to-Back Fisheye, and Cubic clips to organize them, but before you can edit them in Final Cut Pro you need to convert those clips to equirectangular clips using stitching software from the camera manufacturer.
Stereoscopic Mode settings

The Stereoscopic Mode setting in Final Cut Pro indicates the type of stereoscopic configuration.

- **Monoscopic**: A monoscopic 360° clip (no stereoscopic characteristics).
- **Side by Side**: The images for the left and right eyes are side by side in the video frame.
- **Over/Under**: The images for the left and right eyes are stacked vertically in the video frame.

Create 360° projects in Final Cut Pro for Mac

To take full advantage of the 360° video capabilities of Final Cut Pro, you must edit 360° clips in a project whose format is set to 360° video. Final Cut Pro sets project properties based on the properties of the first clip you add to the project, so you can create a 360° project by adding a 360° clip to a new, empty project. You can also set 360° project properties manually.

**Create a 360° project with 360° clips**

1. In Final Cut Pro, select an event in the Libraries sidebar, then choose File > New > Project (or press Command-N).
   
   For more details, see Create a new project.

2. In the window that appears, make sure “Set based on first video clip properties” appears after “Video.”
   
   If you don’t see “Set based on first video clip properties,” click Use Automatic Settings.

3. Enter a name for the project, then click OK.

4. In the browser, locate one of the 360° video clips that you imported.
   
   Make sure the clip has the 360° video properties that you want in your new project. See Check settings for imported 360° clips.

5. **Add the clip** to the new (empty) timeline.

   If the clip properties match a built-in preset, Final Cut Pro sets the project properties to match the properties of the clip you added.

After you create your 360° project, you edit your 360° clips in the timeline the same way you edit standard clips. See Intro to editing.
Create a 360° project manually

1. In Final Cut Pro, select an event in the Libraries sidebar, then choose File > New > Project (or press Command-N).
2. Enter a name for the project in the window that appears.
3. Click the Video Format pop-up menu and choose 360°.
   If you don’t see the Video Format pop-up menu, click Use Custom Settings.
4. Click the Projection Type pop-up menu and choose one of the following:
   • 360° Monoscopic: Choose this option for monoscopic 360° media.
   • 360° Stereoscopic: Choose this option for stereoscopic 360° media.
5. Make any other changes to the project’s video, audio, or rendering properties.
   See Final Cut Pro project settings.
6. Click OK.
   For more details, see Create a new project.

Tip: To quickly create a 360° project from a 360° clip in the browser that has the properties you want in your project, Control-click the clip and choose New Project. Enter a name for the project, then click OK.

Final Cut Pro includes effects that are specially designed for 360° video. To find them, click the 360° category in the Titles and Generators sidebar or in the Effects browser. See Add 360-degree titles and generators and Add 360-degree video effects.

You can remove the camera mount from your stationary 360° clips. See Add the 360-degree Patch effect.

View and navigate 360° video in Final Cut Pro for Mac

In Final Cut Pro, you can view and navigate 360° clips in a dedicated 360° viewer or in a virtual reality (VR) headset connected to your Mac. You can view and navigate the 360° image in any direction, even when the video is paused.

For proper 360° playback and editing in Final Cut Pro, you must use files rendered in the equirectangular format, and they must be tagged as Equirectangular in Final Cut Pro. See Import 360-degree video.

The 360° viewer in Final Cut Pro does not currently support display of HDR media. Any HDR media in a 360° project will be clipped to SDR and may appear overexposed.

Note: Navigating within 360° video clips does not affect the orientation of any media files that you export from your 360° project. To change the orientation of output media files, see Reorient 360-degree video.
Navigate 360° video clips in the 360° viewer

1. In Final Cut Pro, do one of the following:
   - Select a 360° clip in the browser, then position the playhead in the clip.
   - Add a 360° clip to a 360° project in the timeline, then position the playhead in the clip.

   See Create 360-degree projects.

   The equirectangular image appears in the viewer.

2. Choose View > Show in Viewer > 360° (or press Option-Command-7).

   The 360° viewer appears to the left of the viewer, showing the 360° clip as a 360° projection.
3. If you wish, play back the clip.

4. To navigate within the clip, drag in any direction in the 360° viewer, or do any of the following:
   - Roll counterclockwise: Press Control-Option-Command-Left Bracket.

Adjust the field of view in the 360° viewer
As you play back or edit your 360° video clips in Final Cut Pro, you can adjust the view in the 360° viewer.

Note: You can’t adjust the view in the 360° viewer when a VR headset is connected and Mirror VR Headset is turned on.

1. In Final Cut Pro, view a 360° video clip in the 360° viewer.

2. Do any of the following:
   - Widen the field of view: Drag the Field of View slider to the left, or press Control-Option-Command-Minus Sign (−).
   - Narrow the field of view: Drag the Field of View slider to the right, or press Control-Option-Command-Plus Sign (+).
   - Reset the field of view: Click the Reset button to the right of the Field of View slider.
   - Superimpose information about the viewing angle: Click the Settings pop-up menu in the upper-right corner and choose Show Overlays.
   - Reset the angle of view to the default direction: Click the Settings pop-up menu in the upper-right corner and choose Reset Angle (or press Control-Option-Command-0).
**View stereoscopic 360° clips in the 360° viewer**

When working with stereoscopic 360° media in the 360° viewer, you can show the views for both the left and right eyes simultaneously. These special view options in the 360° viewer allow you to objectively assess the parallax and alignment of stereoscopic sources.

1. Select a stereoscopic 360° video clip in the Final Cut Pro browser.
   Be sure to **confirm the stereoscopic settings** for the clip.

2. **View the clip in the 360° viewer.**

3. Click the Settings pop-up menu at the top of the 360° viewer and choose an option from the Stereoscopic section:
   - **Left Eye:** Shows just the view for the left eye.
   - **Right Eye:** Shows just the view for the right eye.
   - **Anaglyph:** Shows a simultaneous view from both eyes. The red channel for the left eye and the blue and green channels for the right eye are composited together. You can use this view to compare parallax and alignment with or without standard red/cyan anaglyph glasses.
   - **Anaglyph Monochrome:** Shows the Anaglyph view in grayscale. This view makes it easier to see the image in stereo. Luminance from the left and right sources is composited together using the red channel for the left eye and the blue and green channels for the right eye. You can use anaglyph glasses to see the image without interference from the native colors in the source image, or use this view without glasses to compare parallax and alignment.
   - **Anaglyph Outline:** Shows edges in the image and lets you set the parallax using the Convergence control, which adjusts the apparent convergence point (the perception of distance to an element) in stereoscopic space. Edges with red on the left side indicate positive parallax (farther away than the convergence point), and red on the right indicates negative parallax (closer than the convergence point). As a bonus, you can use anaglyph glasses to preview the stereoscopic 3D effect. This is the most precise view for assessing the actual parallax in a scene.
   - **Superimpose:** Composites the views for the left and right eyes at 50 percent opacity so they are both visible simultaneously. This view is useful for spot-checking the output, but does not help identify specific left-right parallax cues. You can’t use anaglyph glasses with this view.
   - **Difference:** Compares the pixel color values of the views for the left and right eyes and produces a monochrome result. No difference results in gray output, but dissimilar pixels appear in a range from dark to bright. This view is ideal for flagging vertical disparities or inconsistencies in stitching. You can also adjust the apparent convergence point in stereoscopic space without a VR headset. You can’t use anaglyph glasses with this view.

**View 360° video clips with a VR headset**

1. Connect a VR headset to your Mac.

   Using a VR headset with Final Cut Pro requires macOS High Sierra 10.13 or later.

   **Important:** For more information about setting up your VR headset, see the Apple Support article [Use a VR headset with Final Cut Pro and Motion](https://support.apple.com/en-us/HT205201), the Final Cut Pro Technical Specifications page, and the documentation that came with your headset.
2. In Final Cut Pro, click the Settings pop-up menu in the upper-right corner of the 360° viewer and choose Output to VR Headset (or press Control-Option-Command-7).
   The 360° video appears in the VR headset display.

3. If you want the 360° viewer in Final Cut Pro to match the orientation and approximate field of view of the VR headset, click the Settings pop-up menu and choose Mirror VR Headset (or press Control-Option-Command-9).

4. To navigate the 360° video, put on the headset and look in any direction.
   The display in the headset changes as you turn your head.

5. To set a default (home) direction for the headset, point the headset in the direction that you want to set as the default, then click the Settings pop-up menu and choose Reset Orientation.
   The default direction of the headset is usually determined by headset software when the headset is initialized, but you can change the direction using the Reset Orientation command.

360º images © 2015 Jaunt, Inc.

Edit a 360-degree project

Reorient 360° video in Final Cut Pro for Mac

Every 360° video clip has a native orientation (the default direction the viewer looks). You can change the orientation of a 360° video clip by adjusting its Tilt, Pan, and Roll parameters.

Panning is a camera movement in which the field of view moves horizontally. Tilting moves the field of view up and down. Rolling rotates the view around an axis that goes through the length of the camera lens, causing the angle of the horizon to change.

![Diagram of Tilt, Pan, and Roll](image)

Note: The settings described in this topic affect the orientation of output media files you export from a project. For information about temporary playback and navigation in the 360° viewer, see View and navigate 360-degree video.
Change the 360° orientation using the Video inspector

1. In Final Cut Pro, create a 360° project.
2. Add a 360° clip to the timeline, then select the clip.
3. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
4. If the Video inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
5. Adjust the parameters in the Reorient section of the inspector:
   • Tilt (X): Rotate the view up or down (around the x-axis).
   • Pan (Y): Rotate the view left or right (around the y-axis).
   • Roll (Z): Rotate the view clockwise or counterclockwise (around the z-axis).
   • Convergence: Adjust the apparent convergence point of elements in stereoscopic space, allowing them to be perceived as closer or farther away. (The Convergence parameter appears for stereoscopic clips.)

   As you change the values in the Reorient section of the inspector, the viewer updates to reflect the changes.

Change the 360° orientation using the onscreen control

1. In Final Cut Pro, create a 360° project.
2. Add a 360° clip to the timeline, then select the clip.
3. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
4. To show the Reorient onscreen control, do one of the following:
   • Click the pop-up menu in the lower-left corner of the viewer and choose Reorient.
   • Control-click in the viewer (not the 360° viewer) and choose Reorient.
   • Click the Reorient button in the Reorient section of the Video inspector.

   When you move the pointer over the viewer, the pointer changes to the Reorient control. The Reorient button in the inspector and in the lower-left corner of the viewer turns blue to indicate that the Reorient control is active.
5. Drag in the viewer (not the 360° viewer) to adjust the orientation of the selected clip.

⚠️ Tip: To constrain the movement to one axis, hold down the Shift key as you drag.

As you drag in the viewer, the values in the Reorient section of the inspector update to reflect the changes.

Use the Horizon guidelines to realign the image

When you make orientation changes in a 360° video clip (particularly when adjusting the Tilt and Roll parameters), you might lose track of the horizon line. You can show Horizon guidelines in the viewer to help you realign, recenter, or level the image—for example, to align the horizon on the x-axis.

- In Final Cut Pro, click the View pop-up menu in the upper-right corner of the viewer, then choose Show Horizon in the Overlays section.

Note: It's possible to create cinematic camera moves in your 360° projects by using keyframes to animate changes to the orientation parameters over time (see Add video effect keyframes). However, this may not be appropriate given that 360° video is fully interactive and navigable by the viewing audience at all times. A more appropriate use of this technique might be animating a 360° clip in a rectilinear project. See Add 360-degree clips to standard projects.

360° images © 2015 Jaunt, Inc.
Add 360° video effects in Final Cut Pro for Mac

Final Cut Pro includes special 360° versions of some standard effects (such as blur, glow, and sharpen effects). You can apply these effects to 360° clips without creating seams, unwanted distortions, or other artifacts.

1. Select a 360° clip in the Final Cut Pro timeline, then click the Effects button in the top-right corner of the timeline (or press Command-5).

2. In the Effects browser, select the 360° category below Video, then double-click an effect to apply it to the selected clip.

   You can also apply an effect by dragging it directly to a clip in the timeline.

For more information about adding clip effects, see Intro to clip effects.

You can use the 360° Patch effect to cover up unwanted imagery (such as a camera or tripod) in a 360° scene. See Add the 360-degree Patch effect.

Add 360° titles and generators in Final Cut Pro for Mac

Final Cut Pro includes titles and generators that are specially designed for use in 360° projects.

360° titles are always projected correctly into the equirectangular projection, so the depth, lighting, and shading of 3D text appear as they would in a standard project. You adjust 360° titles using Reorient controls (rather than the 360° Transform controls that you use to adjust standard titles in a 360° project).
Final Cut Pro also includes special 360° generators. You can add these generators to 360° projects without creating seams, unwanted distortions, or other artifacts.

1. To open the Titles and Generators sidebar in Final Cut Pro, do one of the following:
   • Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.
   • Choose Window > Go To > Titles and Generators (or press Option-Command-1).

2. Do one of the following:
   • Select the 360° category below Titles in the sidebar, then add a 360° title to your project.
     See Add titles.
     To position 360° titles, follow the instructions for using the Reorient tools in Reorient 360-degree video.
   • Select the 360° category below Generators in the sidebar, then add a 360° generator to your project.
     See Intro to generators.

Add standard clips to 360° projects in Final Cut Pro for Mac

You can include rectilinear clips and titles in a 360° project—for example, you might want to place a logo or a title within the 360° equirectangular projection.

When you add a standard title (a title not optimized for 360° video) to a 360° project, the title looks “flat” in the viewer but appears as if it is pasted on the inside of the 360° sphere in the 360° viewer.
You can turn on the 360° Transform controls to project the title correctly into the equirectangular projection. When 360° Transform is on, the title appears on a flat plane within the 360° sphere. However, a standard 3D title projected by 360° Transform does not have the depth of a 360°-optimized 3D title. You can position it in the 360° sphere, but it always appears thin, like a piece of paper with a photograph of a 3D title on it.

1. In Final Cut Pro, do one of the following:
   - Add a standard clip: Import the rectilinear media, then add one or more rectilinear clips to your 360° project. See Intro to adding clips.
   - Add a standard title: Choose Window > Go To > Titles and Generators (or press Option-Command-1), then select any category below Titles in the sidebar (other than the 360° category) and add a title to your project. To change the text of the title, see Edit title text.

2. In the timeline, select one or more of the standard clips or titles.

3. If the Video inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

4. Click the Video button at the top of the inspector.

5. If you added a title, select the 360° Transform checkbox to turn on the 360° Transform controls.

   Note: The 360° Transform parameters are turned off by default for standard titles so that you can first edit the text in the viewer using onscreen controls. After you finish editing the title content with onscreen controls, select the title in the timeline, then select the 360° Transform checkbox in the Video inspector to enable those controls and project the title as a flat plane.
6. If the 360° Transform controls aren't shown in the Video inspector, move the pointer over 360° Transform and click Show.

7. Click the Coordinates pop-up menu and choose a method of positioning the clip or title in the equirectangular projection:
   - **Spherical**: Use this coordinate system for logos, titles, or video clips that are either stationary or orbiting around the center.
   - **Cartesian**: Use this coordinate system when you want to animate a clip or title to travel from one point in 3D space to another. For example, if you were to re-create the opening text scroll of *Star Wars*, you would create it on a single plane, then rotate it on the x-axis and fly it from behind the center out in front.

8. Depending on the coordinate system you chose, adjust the following position parameters:
   - If you chose Spherical:
     - **Latitude**: Rotate the clip plane up or down around the center.
     - **Longitude**: Rotate the clip plane left or right around the center.
     - **Distance**: Move the clip plane closer to or farther from the center.
     - **Scale**: Change the clip's size (without affecting the distance or parallax).
   - If you chose Cartesian:
     - **X Position**: Move the clip plane on the x-axis.
     - **Y Position**: Move the clip plane on the y-axis.
     - **Z Position**: Move the clip plane on the z-axis.

9. If you want the clip plane to always face the center, select the Auto-orient checkbox.

10. To set the local orientation of the clip, adjust the following parameters:
    - **X Rotation**: Rotate the clip plane on its x-axis.
    - **Y Rotation**: Rotate the clip plane on its y-axis.
    - **Z Rotation**: Rotate the clip plane on its z-axis.
    - **Convergence**: Adjust the apparent convergence point of elements in stereoscopic space, allowing them to be perceived as closer or farther away. (The Convergence parameter appears for rectilinear clips in stereoscopic projects.)
    - **Interaxial**: Adjust the stereoscopic depth of the selected clip. The effect becomes apparent when you adjust the clip's local orientation. (The Interaxial parameter appears for rectilinear clips in stereoscopic projects.)

360° images © 2015 Jaunt, Inc.
Add 360° clips to standard projects in Final Cut Pro for Mac

You can add 360° clips to a standard rectilinear project. When you export the rectilinear project, the 360° clips are converted to rectilinear clips (which are not navigable by the viewing audience). However, you can create the effect of cinematic camera moves with 360° clips by animating tilts, pans, and rolls (or create interesting “tiny planet” effects) before you export.

1. Make sure the 360° clips have the correct 360° metadata tags in the Final Cut Pro browser.
   
   See Check settings for imported 360° clips.

2. Add one or more 360° clips to a rectilinear project.
   
   See Create a new project and Intro to adding clips.

   Note: If you add a stereoscopic 360° clip to a rectilinear project, Final Cut Pro displays the video image from the left eye only.

3. Select the clip or clips in the timeline.

4. If the Video inspector isn't already shown, do one of the following:
   
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

5. Click the Video button at the top of the inspector.

6. In the Video inspector, scroll down to the Orientation section, then click the Mapping pop-up menu and choose one of the following:
   
   • Normal: Presents any portion of the 360° video, up to 175° maximum (125° for 16:9 projects), using gnomonic projection, in which straight lines appear straight.
   • Tiny Planet: Maps the entire 360° sphere onto a flat plane, creating the effect of a tiny planet. See Add the Tiny Planet effect.

7. In the Orientation section, adjust any of the following parameters:
   
   • Tilt (X): Rotate the view left or right (around the x-axis).
   • Pan (Y): Rotate the view up or down (around the y-axis).
   • Roll (Z): Rotate the view clockwise or counterclockwise (around the z-axis).
   • Field of View: Adjust the amount of the 360° scene that is shown. To widen the field of view, drag the slider to the right. To narrow the field of view, drag the slider to the left.
You can use one orientation (camera angle) for the entire duration of a 360° clip, or you can animate changes to the orientation over time to create the effect of cinematic camera moves. See Add video effect keyframes.

**Important:** Changes to the orientation settings affect the orientation of output media files.

You can edit the 360° clips in a rectilinear project the same way you edit standard clips. When you finish editing your rectilinear project, you can share the project using any share method. The output from any 360° clips included in the project is flat (just like any other standard rectilinear video).

### Add the 360° Patch effect in Final Cut Pro for Mac

You can use the 360° Patch effect to cover up (patch) a portion of a 360° clip with pixels from another location in the 360° sphere. The 360° Patch effect is typically used to hide the tripod or camera support by cloning an area of the ground near the camera. You use the source controls to specify where in the image you want to copy the patch from, and the target controls to specify where to paste the patch.

Unlike a static image, a patch created with the 360° Patch effect adjusts dynamically as the lighting changes in the scene.

**Apply the 360° Patch effect**

1. In Final Cut Pro, create a 360° project.
2. Add a 360° clip to the timeline, then select the clip.
3. Position the playhead over the clip in the timeline so that the clip's video is displayed in the viewer.
4. Open the Effects browser, select the 360° category on the left, then double-click 360° Patch to add the effect to the clip selected in the timeline.
5. If the Video inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

6. In the Video inspector, click the Patch Region pop-up menu and choose a general area of the 360° sphere to work on.
   You can choose Nadir (Bottom), Zenith (Top), Front, Back, Left, or Right.

7. Select the Setup Mode checkbox.
   The area of the image you chose in the Patch Region pop-up menu appears in the viewer, with onscreen controls for the patch source and target areas.

8. Drag the red (target) control over the area you want to patch (cover up).

9. Drag the green (source) control over the area you want to clone (copy).

10. To adjust the source radius (the size of the area you want to clone), drag the white circle around the green control.

11. In the Video inspector, adjust any of the following source parameters (which define the portion of the 360° image to copy for the patch):
   • Source Position: Adjust the source location.
   • Source Radius: Adjust the source size.
   • Source Softness: Adjust the softness of the patch edge.
   • Source Aspect: Adjust the patch shape.
   • Source Angle: Rotate the source shape.

12. To “spotlight” the source selection, dimming the rest of the image, select the Highlight Source checkbox.

13. Adjust any of the following target parameters (which define the portion of the 360° image to patch):
   • Target Position: Adjust the target location.
   • Target Opacity: Adjust the patch opacity.
   • Target Angle: Rotate the target shape.
   • Target Scale: Adjust the target size.

14. To flop the cloned image horizontally, vertically, or both horizontally and vertically, click the Target Flip Flop pop-up menu and choose an option.

15. To dismiss the onscreen controls and return to the standard view in the viewer and the 360° viewer, deselect the Setup Mode checkbox.

   The patch appears on the 360° clip. (You may need to use the 360° viewer to navigate to it.)

   Note: You can keyframe most of the parameters in the 360° Patch effect. See Add video effect keyframes.
Create a separate clip with only the 360° Patch image

By default, the 360° Patch effect is composited onto the 360° image as a permanent change in the output media file. You can isolate the patch image in a separate connected clip, which is particularly useful if you need to color correct the patch in isolation from the rest of the 360° image.

1. **Apply the 360° Patch effect** to a clip in your 360° project.

2. Duplicate the clip, then **connect the duplicate clip** above the original clip in the timeline.
   
   Tip: A quick way to do this is to Option-drag the clip to the area in the timeline just above the clip.

3. Select the connected clip.

4. If the Video inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

5. Deselect the Show Background checkbox at the bottom of the 360° Patch effect controls in the Video inspector.

   Final Cut Pro creates an alpha channel mask, isolating the patch image. You can now apply color correction and video effects to the patch image, separately from the original clip.
Add the Tiny Planet effect in Final Cut Pro for Mac

You can use the Tiny Planet mapping setting on 360° clips in a standard rectilinear project. The entire 360° sphere is converted to a stereographic projection (mapped onto a flat plane), creating the effect of a tiny planet.

In contrast, the Normal mapping setting shows a standard image (a portion of the 360° image) in the viewer in a rectilinear project, and the full equirectangular image in the viewer in a 360° project.

Note: You can apply 360° clip effects such as 360° Patch and 360° Noise Reduction to 360° clips in a rectilinear project. You can also add 360° titles and generators to rectilinear projects.

1. In Final Cut Pro, create a 360° project.
2. In the Video inspector, scroll down to the Orientation section, then click the Mapping pop-up menu and choose Tiny Planet.
3. To modify the tiny planet effect, do one of the following:
   - Adjust the parameter controls in the Orientation section of the Video inspector.
   - Click the Orientation button in the Orientation section of the inspector, then drag in the viewer to adjust the Orientation parameters. See Change the 360° orientation using the onscreen control.
     To constrain the movement to one axis, hold down the Shift key as you drag.
The following parameters are particularly useful for tiny planets:

- **Field of View**: Zoom in or out on the tiny planet.
- **Pan (Y)**: Rotate the planet.
- **Tilt (X)**: Create an inverted tiny planet.

![Tilt (X) set to 0°](image1.png) ![Tilt (X) set to 180°](image2.png)

⚠️ **Tip**: During production, have some fun and take a stroll around your tiny planet: Position your 360° camera, start recording, take two or three large steps away from the camera, then walk, ride, or skate in a concentric circle around the camera.

### Share 360° clips and projects in Final Cut Pro for Mac

When you've finished editing, you can export your 360° projects and clips as files or share them on a variety of video-sharing and social media websites. See [Share on the web](#).

Final Cut Pro includes metadata in the output media file to identify it as a particular type of 360° video.

You can also export a final file, or export XML files of events, projects, or libraries that include 360° clips and projects.

In addition to Final Cut Pro, you can use Safari on macOS High Sierra 10.13 or later, Chrome, and Firefox to play back 360° video on a Mac. You can also use many of the apps included with 360° cameras.

### 360° video tips in Final Cut Pro for Mac

The following tips can help ensure success in your Final Cut Pro 360° video workflow:

- Make sure your 360° media is compatible with Final Cut Pro.
  - Your 360° media must be formatted for equirectangular projection. See [Intro to 360-degree video](#).
  - For a list of supported cameras, see the Apple Support article [Cameras supported by Final Cut Pro](#).
- Make sure your Mac meets the recommended system requirements for 360° video. See the [Final Cut Pro Tech Specs webpage](#).
- Tag 360° clips with the correct properties as early as possible in the import process. This 360° metadata is required for proper playback and editing. See [Import 360° video](#).
• You can use a VR headset to work with 360° video in Final Cut Pro for a fully immersive editing experience. For setup instructions, see the Apple Support article Use a VR headset with Final Cut Pro and Motion.

Note: Because you can view and navigate 360° clips in a dedicated 360° viewer, a VR headset is not required to work with 360° video in Final Cut Pro.

• Make sure to provide adequate storage space for 360° video files. In general, video files from 360° cameras are about four times larger than files from comparable standard cameras. Video files from 360° cameras use the same file formats and codecs as those from standard cameras. For information about managing media in Final Cut Pro, see Intro to media management.

• In addition to Final Cut Pro, you can use Safari on macOS High Sierra 10.13 or later, Chrome, and Firefox to play back 360° video on a Mac. You can also use many of the apps included with 360° cameras.

Change the focus in Cinematic mode video

Intro to Cinematic mode video in Final Cut Pro for Mac

In Final Cut Pro, you can change the focus of video clips recorded in Cinematic mode on iPhone 13 and later. Cinematic mode creates clips with a simulated depth-of-field effect that keeps your subjects—people, pets, and more—in sharp focus while applying a pleasing blur to the background (or foreground). As you record, the camera uses machine learning to automatically detect and focus on subjects in the scene. You can also tap the screen while recording to manually focus on a subject.

These automatic and manual focus decisions are called focus points. Focus points, as well as depth-of-field data, are saved with the Cinematic mode clip.

When you import a Cinematic mode clip into Final Cut Pro, you can:

• Add focus points and switch the focus between different subjects
• Lock the focus on a moving object or a person
• Lock the focus on a point in the scene at a specific distance from the camera
• Delete manual focus points (added during recording or added in Final Cut Pro)
• Adjust or animate the depth of field, creating a rack focus effect

Note: To edit Cinematic mode video shot on an iPhone with a recent version of iOS, you may need to update to the latest version of macOS.

For information on recording in Cinematic mode, see Record video in Cinematic mode with your iPhone camera in the iPhone User Guide.
Import Cinematic mode clips into Final Cut Pro for Mac

To edit Cinematic mode video in Final Cut Pro, you must import the Cinematic mode video clips using a method that preserves the depth and focus metadata created during recording on iPhone.

Import directly into Final Cut Pro from iPhone or Photos

See the following topics:

- Import from iPhone, iPad, or iPod touch
- Import from Photos

Transfer using AirDrop, then import into Final Cut Pro

You can use AirDrop to transfer Cinematic mode video clips from your iPhone to your Mac.

1. In Photos on your iPhone, open a Cinematic mode clip, then tap the Share button.
2. Tap Options at the top of the screen, turn on All Photos Data, then tap Done.
3. Tap AirDrop, then, in the Devices list, tap the Mac you want to transfer the clip to. (Make sure the Mac you’re sharing with has AirDrop turned on.)
   
   For each Cinematic mode clip that you transfer using AirDrop, a folder containing four files appears on the receiving Mac.

4. In the folder, locate the MOV file that does not begin with “IMG_E,” then import it into Final Cut Pro.

Enable Cinematic mode video adjustments in Final Cut Pro for Mac

To view and adjust focus points in a Cinematic mode video clip, you must open the Cinematic Editor in the timeline and show the Cinematic onscreen controls in the viewer.

Step 1: Create a Cinematic mode video project

By default, iPhone records video in HDR. For the best quality, import HDR Cinematic mode clips into a wide-gamut HDR project.

1. In Final Cut Pro, do one of the following:
   
   - If you recorded Cinematic mode clips in HDR (the default): Create an HDR library and project, and set the color space to Wide Gamut HDR – Rec. 2020 HLG. See Use wide-gamut HDR color processing.
     
     If you want to use the HDR clips in an SDR project, the Color Conform effect will convert the clips to the project's color space. See Use automatic color management and Color Conform.
   
   - If you recorded Cinematic mode clips in SDR: Create a new project.

2. Import the Cinematic clips.
3. Add one or more Cinematic clips to the timeline.
Step 2: Open the Cinematic Editor in the timeline
1. In the Final Cut Pro timeline, select one or more Cinematic mode clips.
2. Do one of the following:
   - Choose Clip > Show Cinematic Editor (or press Control-Option-F).
   - Control-click the selection in the timeline and choose Show Cinematic Editor.
Two kinds of focus points appear in the Cinematic Editor (above the selected clips in the timeline):
   - **Automatic focus points**: These are created by the Camera app while recording in Cinematic mode. In the timeline, automatic focus points appear as white dots.
   - **Manual focus points**: These are created when you tap the screen (to focus on a particular item in the scene) while recording in Cinematic mode. In the timeline, manual focus points appear as yellow dots with a ring around them.

![Automatic focus point and Manual focus point](image)

*Note*: Focus points are not keyframes. They are points of automatic or manual focus created when the video was recorded.

Step 3: Show the Cinematic onscreen controls in the viewer
1. In the Final Cut Pro timeline, select one or more Cinematic mode clips.
2. Position the playhead in the timeline so that a Cinematic mode clip appears in the viewer.
3. Open the Video inspector, and make sure the Cinematic checkbox is selected.
4. To show the Cinematic onscreen controls for the selected clips, do one of the following:
   - Click the pop-up menu in the lower-left corner of the viewer and choose Cinematic (or press Control-Shift-F).
   - Control-click in the viewer and choose Cinematic.
As you drag the playhead in the timeline, different types of controls appear in the viewer around elements in the scene. These controls indicate subjects or areas of focus identified during recording on iPhone, either automatically (by the Camera app) or manually (by the person recording the video).

There are four types of controls:

<table>
<thead>
<tr>
<th>Onscreen control</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Current focus indicator" /></td>
<td>Current focus indicator</td>
<td>Yellow brackets indicate the current subject or area of focus tracked automatically by the camera.</td>
</tr>
<tr>
<td><img src="image" alt="Suggested focus indicator" /></td>
<td>Suggested focus indicator</td>
<td>White frames indicate potential subjects of focus tracked automatically by the camera. Move the pointer over the viewer to reveal additional suggested focus points. To change a suggested focus point to the current subject of focus, see Switch the focus in a Cinematic mode clip.</td>
</tr>
<tr>
<td><img src="image" alt="AF Tracking Lock" /></td>
<td>AF Tracking Lock</td>
<td>A yellow frame indicates the current subject or area of focus set manually (during recording or in Final Cut Pro). AF Tracking Lock focuses on a subject while following its movement, even when other potential subjects of focus appear in the video.</td>
</tr>
<tr>
<td><img src="image" alt="AF Lock" /></td>
<td>AF Lock</td>
<td>A small yellow square with tick marks indicates a fixed-focus point set manually (during recording or in Final Cut Pro). AF Lock focuses at a specific distance from the camera, ignoring all elements in the clip (until the next manual focus point).</td>
</tr>
</tbody>
</table>

The types of controls that appear in the viewer depend on the focus decisions made during recording (not all types of controls appear for all Cinematic mode clips).
Adjust the focus in Cinematic mode clips in Final Cut Pro for Mac

When you record video in Cinematic mode on iPhone, the Camera app automatically targets the most likely subject of focus in the scene. In the background, it also tracks focus for other potential subjects of your video clip. If another item comes into the frame, the camera may automatically switch the focus to that item. For example, if you’re focusing on one subject and that subject moves away from the center (or the camera pans) and another item comes into view, the camera may automatically focus on the second item.

After you enable Cinematic adjustments, you can switch the focus between subjects in a Cinematic mode video clip, lock the focus on a subject, or fix the focus on a point at a specific distance from the camera.

Switch the focus in a Cinematic mode clip

1. In the Final Cut Pro timeline, position the playhead on a frame in a Cinematic mode clip that contains the item you want to focus on (or select an existing focus point).

   In the viewer, yellow brackets appear around the current subject of focus. White frames indicate potential subjects of focus tracked by the camera.

2. In the viewer, click once on the suggested focus indicator (white frame) around the item you want to focus on.

   Tip: To reveal additional suggested focus points, press and hold the Option key while moving the pointer around in the viewer.

   The current focus indicator switches to the item you clicked, and the item comes into focus. A manual focus point appears at the playhead position in the clip’s Cinematic Editor in the timeline.

Note: When you set manual focus points, Final Cut Pro may remove or reposition automatic focus points.
Lock the focus on a subject in a Cinematic mode clip
When you’re editing a Cinematic mode clip in Final Cut Pro, you can lock the focus on an item to prevent the focus from switching to another item.

1. In the Final Cut Pro timeline, position the playhead on a frame in a Cinematic mode clip that contains the item you want to focus on (or select an existing focus point).
   In the viewer, yellow brackets appear around the current subject of focus. White frames indicate potential subjects of focus tracked by the camera.

2. In the viewer, click the current focus indicator (the yellow brackets) or double-click a suggested focus indicator (a white frame).
   Tip: To reveal additional suggested focus points, press and hold the Option key while moving the pointer around in the viewer.
   The control you clicked changes to the AF Tracking Lock, and a manual focus point is added to the clip's Cinematic Editor in the timeline. The focus remains locked on the subject you selected (if possible) until the end of the clip or until the next focus point (a white or yellow dot in the timeline).

To turn off AF Tracking Lock, click the center of the closed yellow frame. The control reverts to the current focus indicator.

Note: When you set manual focus points, Final Cut Pro may remove or reposition automatic focus points.

Lock the focus on a point at a specific distance from the camera
You can lock the focus in a Cinematic mode clip at a specific distance from the camera using AF Lock. AF Lock allows you to maintain the focus on a specific spot in the scene—regardless of the subject’s movement. For example, if you lock the focus on a point in the scene’s middle ground, a blurred subject in the background can move into focus in the middle ground, then become blurry again as it moves toward the foreground.
1. In the Final Cut Pro timeline, select a Cinematic mode clip and position the playhead so that the clip appears in the viewer.

2. In the viewer, do one of the following:

   • **Set a fixed-focus point from the current playhead position to the next manual focus point (or the end of the clip):** Move the pointer to a spot in the scene at the distance where you want to lock the focus, press and hold the mouse button, then release it.

   The AF Lock control, a small yellow square with tick marks, appears in the viewer, indicating the distance from the camera. A manual focus point is added to the clip’s Cinematic Editor in the timeline, and subsequent automatic focus points are overwritten.

   ![AF Lock Control](image)

   The focus is maintained at the specified distance from the camera until the next manual focus point (or the end of the clip).

   • **Set a fixed-focus point from the current playhead position to the next manual or automatic focus point (or the end of the clip):** Move the pointer to a spot in the scene at the distance where you want to lock the focus, then click once.

   A small yellow square with short tick marks appears in the viewer, and a manual focus point is added to the clip’s Cinematic Editor in the timeline.

   ![Manual Focus Point](image)

   The focus is maintained until the next manual or automatic focus point (or the end of the clip).

   **Note:** If you lock the focus on a point in the scene that falls outside of the clip’s depth-of-field range, AF Lock doesn’t bring the point into focus.

**Delete manual focus points**

You can delete any manual (yellow) focus points in a Cinematic mode clip, whether they were created during recording or added in Final Cut Pro.

1. In Final Cut Pro, open the Cinematic Editor, if it's not already shown.

2. Click a manual (yellow) focus point in the timeline, then click Delete Focus Point.

![Delete Focus Point](image)

**Note:** When you delete manual focus points, Final Cut Pro may restore or reposition automatic focus points.
Navigate between focus points
1. In the Final Cut Pro timeline, select a Cinematic mode clip and position the playhead so that the clip appears in the viewer.
2. Open the Cinematic Editor, if it’s not already shown.
3. Do any of the following:
   • Move to the next focus point: Press Option-Shift-Command-Right Arrow.
   • Move to the previous focus point: Press Option-Shift-Command-Left Arrow.
   • Select a focus point: Click an automatic or manual focus point in the Cinematic Editor in the timeline.

Adjust depth of field in Cinematic mode clips in Final Cut Pro for Mac
In addition to focusing on different subjects or areas in the scene, you can adjust and animate the depth of field in a Cinematic mode video clip. For example, you can soften or sharpen the background behind your subject.

1. In the Final Cut Pro timeline, select a Cinematic mode clip and position the playhead so that the clip appears in the viewer.
2. Open the Video inspector, and make sure the Cinematic checkbox is selected.
3. Drag the Depth of Field slider left or right.

Lower values result in a shallower depth of field. For example, if the clip is focused on a tree in the foreground and you drag the slider to the left, the background becomes more blurry (out of focus). Conversely, dragging the slider all the way to the right brings both the tree and the background into focus.

Tip: For dramatic rack focus effects, use a shallow depth of field.
You can animate the Depth of Field parameter using keyframes. See Add video effect keyframes.
Keying, masking, compositing, and tracking

Keying

Intro to keying in Final Cut Pro for Mac

Keying is creating areas of transparency based on color or lightness values in an image. Keying is commonly performed on subjects photographed against a blue or green background, but keys can be based on any color (color or chroma keying), or on a specific range of lightness values (luma keying).

Keying allows you to composite (combine) a foreground clip and a background clip into one video image. The foreground clip is processed to key out (remove) either a color or a lightness value in areas of the image, allowing the background clip to show through in those areas.

For example, you can take a video clip of a person standing in front of a green-screen background and replace the green with an interior scene, making it appear as though that person is standing in the room.

Green-screen clip

Keyed clip
This type of keying is accomplished using one of two keyer effects in Final Cut Pro:

- **Green Screen Keyer**: This general-purpose chroma-keying effect is optimized for green- or blue-screen keying but can key any range of color you choose. See Use the Green Screen Keyer effect.

- **Luma Keyer**: This effect is designed to generate mattes based on the image’s lightness—you choose to remove the white or black areas and whether the gray areas should be partially transparent. See Use the Luma Keyer effect.

In addition to using these keying effects, you may need to use a matte, a positioning effect, and color correction to ensure that the foreground video looks natural when keyed over the background. See Finalize a key and Intro to masking.

**Use the Green Screen Keyer effect in Final Cut Pro for Mac**

With the Green Screen Keyer effect, you can create a chroma key to replace a specific color in a clip with an image from another clip. For example, you can replace a green background with an image.

A challenging part of creating a good chroma key is shooting the chroma key video and, in particular, using a good, well-lit background that provides a uniform color to remove. A wide variety of specialized chroma key background options are available, from chroma key paint that includes highly reflective additives to chroma key cloth or paper sheets. It's also important to use the best camera you can and to avoid using a highly compressed video format. In the following examples, an image of a person is keyed over a scene in an empty subway station. The light stands are removed in Finalize a key.
Apply the Green Screen Keyer effect

1. In the Final Cut Pro timeline, add the foreground clip (the chroma key clip with the color you want to remove) to the primary storyline.

2. Drag the background clip (the clip you want to superimpose the chroma key clip over) so that it’s connected below the foreground clip in the primary storyline.

3. Select the foreground clip in the timeline, then click the Effects button in the top-right corner of the timeline (or press Command-5).

4. In the Effects browser, select the Green Screen Keyer effect.

5. Do one of the following:
   • Drag the effect to the timeline foreground clip you want to apply the effect to.
   • Double-click the effect thumbnail to apply the effect to the selected clip.

The Green Screen Keyer effect analyzes the video to detect a green or blue dominant color and then removes that color. If the resulting key isn’t right or you want to improve it, you can adjust it.
**Adjust the Green Screen Keyer effect**

1. In the Final Cut Pro timeline, select the foreground clip with the Green Screen Keyer effect, then open the Video inspector. Controls for modifying and improving the Green Screen Keyer effect appear.

2. If the Select tool is not the active tool, choose it from the Tools pop-up menu above the timeline (or press A).

3. To improve the key using controls in the viewer, use the Refine Key and Strength controls to do any of the following:

   - **Identify areas of the foreground clip that might still have some of the chroma key color showing:** Click the Sample Color thumbnail image in the Video inspector and draw a rectangle in the viewer over the area where the chroma key color needs to be removed.

   *Note:* By default, the Green Screen Keyer effect applies spill removal, which neutralizes any leftover tinting of the green- or blue-screen background color you’re removing. To see the original color, set the Spill Level parameter to 0%.

   To improve the key, you can drag the rectangle to adjust its position or drag its corners to change its size, and you can drag additional rectangles over any areas with the chroma key color still showing.

   ⚠️ **Tip:** Select Matte (the center button) in the View area in the Video inspector to see the matte that the chroma keyer is creating. This can make it much easier to see areas that are not keying well.
• **Refine any difficult areas, such as hair and reflections:** Click the Edges thumbnail image in the Video inspector, draw a line across the difficult area in the viewer (with one end in the area to keep and the other in the area to remove), and drag the line’s handle to adjust the edge softness.

You can use the following keyboard shortcuts to work directly in the viewer:

• **Make a Sample Color adjustment:** Draw a rectangle while holding down the Shift key.

• **Make an Edges adjustment:** Draw a line while holding down the Command key.

• **Delete a Sample Color or Edges adjustment:** Click a Sample Color rectangle or Edges line while holding down the Option key, or select the control and press the Delete key.

• **Choose a different color if the Green Screen Keyer effect chose the wrong color:** Set the Strength parameter to 0% (to override the automatic initial color sampling). Then use Sample Color to choose the color to remove. Select Composite (the left button) in the View area to see the foreground clip combined with the background clip.

• **Adjust how strongly the Green Screen Keyer matches a color in the foreground image to the default chroma key color:** Use the Strength slider to adjust the tolerance (core transparency) of the Green Screen Keyer effect’s automatic sampling. The default value is 100%. Reducing this value narrows the range of color sampled, resulting in less transparency in the keyed image. Increasing the Strength value expands the range of color sampled, resulting in more transparency in the keyed image. The Strength parameter is useful for retrieving areas of semitransparent detail such as hair, smoke, or reflections.
4. To help fine-tune the key, use the View options:

- **Composite**: Shows the final composited image, with the keyed foreground subject over the background clip. This is the default view.

- **Matte**: Shows the grayscale matte, or alpha channel, that's being generated by the keying operation. White areas are solid (the foreground video is opaque), black areas are transparent (the foreground is not seen at all), and shades of gray indicate varying levels of transparency (the background video can be seen mixed with the foreground video). Viewing the matte makes it easier to spot unwanted holes in the key or areas that aren’t transparent enough.

- **Original**: Shows the original, unkeyed foreground image.

5. To further refine the matte, use the following controls:

- **Fill Holes**: Increasing this parameter value adds solidity to regions of marginal transparency within a key. This control is useful when you’re satisfied with the edges of your key, but you have unwanted holes in the interior that you can’t eliminate using the Strength parameter without ruining your edges.

- **Edge Distance**: Lets you adjust how close to the edge of your keyed subject the effect of the Fill Holes parameter gets. Reducing this parameter value brings the filled area of the matte closer to the edge of the subject, sacrificing translucency at the edges. Increasing this parameter value pushes the filled area of the matte farther from the edge. Too much edge distance can result in unwanted translucency within parts of the subject that should be solid.

6. To suppress any of the background color that is appearing (spilling) on the foreground image, adjust the Spill Level control.

7. To reverse the keying operation, retaining the background color and removing the foreground image, select Invert.

8. To mix the keyed effect with the unkeyed effect, adjust the Mix control.

If you’re still having trouble getting a clean key, see the following instructions.
Make advanced Green Screen Keyer adjustments

The following controls are available for use in difficult keying situations or for fine-tuning specific problems:

- **Color Selection**: These controls are meant to be used after you begin creating a key using automatic sampling or the Sample Color and Edges tools. (However, you can skip those tools and create a key using Manual mode, described below.) The graphical Chroma and Luma controls provide a detailed way of refining the range of hue, saturation, and image lightness that define the keyed matte.

- **Matte Tools**: These controls are for refining the transparency matte generated by the previous sets of parameters. These parameters don't alter the range of values sampled to create the keyed matte. Instead, they alter the matte generated by the Green Screen Keyer effect's basic and advanced controls, letting you shrink, expand, soften, or invert the matte to achieve a better composite.

- **Light Wrap**: These controls are for blending color and brightness values from the background layer of your composite with the keyed foreground layer. Using these controls, you can simulate the interaction of environmental lighting with the keyed subject, making it appear as if background light wraps around the edges of a subject.

1. In the Final Cut Pro timeline, select the foreground clip with the Green Screen Keyer effect, then open the Video inspector.

   Controls for modifying and improving the Green Screen Keyer effect appear.

2. Click Color Selection to reveal the following controls:
• **Graph:** Provides two options to set how the adjustable graphs in the Chroma and Luma controls are used to fine-tune a key:

  - **Scrub Boxes:** Select to limit the Chroma and Luma controls to adjusting softness (edge transparency) in the matte you’re creating. In this mode, you can’t manually adjust tolerance (core transparency), which is determined by the Green Screen Keyer effect’s automatic sampling, plus any Sample Color rectangles you’ve added in the viewer. (To increase matte tolerance, add more Sample Color rectangles or adjust the Strength slider.)

  - **Manual:** Select to use the Chroma and Luma controls to adjust the softness (edge transparency) and tolerance (core transparency) in the matte you’re creating. Make sure the Strength slider is set to a value greater than 0% before you switch to Manual mode; otherwise the Chroma and Luma controls are disabled. When you switch to Manual mode, the Refine Key tools and Strength slider become disabled, but samples you’ve made with those controls continue to contribute to the matte.

    **Important:** When you switch to Manual mode, it’s best not to switch back to Scrub Boxes mode. For best results, begin keying an image using the Sample Color and Edges tools in Scrub Boxes mode. Switch to Manual mode afterward if you feel it’s necessary to refine your matte using the Chroma and Luma controls. However, if you switch back to Scrub Boxes mode, you may experience unexpected combinations of additionally sampled and keyframed values that might be difficult to control.

• **Chroma:** Drag the two graphs in this color wheel control to adjust the isolated range of hue and saturation that help define the keyed matte. The selected mode governs which graphs in the color wheel are adjustable. The outer graph controls the softness (edge transparency) of the matte you’re creating, and can be adjusted in either Scrub Boxes or Manual mode. The inner graph controls tolerance (core transparency), and is only adjustable when in Manual mode. Drag any side of either graph to expand or contract the graph’s border, which adds to or subtracts from the range of hue and saturation contributing to the key. In Manual mode, you can also drag inside the tolerance graph to adjust its overall position in the color wheel. To the left of the color wheel, a small graph displays the slope of chroma rolloff, the relative softness of matte edges in regions most affected by the Chroma control. Dragging the Chroma Rolloff slider (described below) modifies the shape of this slope.

    **Tip:** It’s possible to zoom in to and pan around the Chroma control to more precisely adjust the graphs. To zoom in to the Chroma control, move the pointer over the color wheel and, holding down the Z key, drag to the left to zoom out or to the right to zoom in. To pan in the Chroma control, hold down the H key and drag in the color wheel in the direction you want to move it. To reset the zoom and recenter the Chroma control, move the pointer over the Chroma control and press Shift-Z.
• **Luma**: Drag the adjustable handles in this grayscale gradient to modify the isolated range of the luma channel (the range of brightness and darkness) that also helps define the keyed matte. The upper handles (which appear only in Manual mode) adjust the tolerance (core transparency) of the luma channel’s contribution to the key. The lower handles adjust the softness (edge transparency) of the luma channel’s contribution to the key. The Graph mode governs which handles are adjustable. In Scrub Boxes mode, you can adjust only the lower softness handles, which modify the range of brightness and darkness affecting the edge transparency of the matte. In Manual mode, you can also adjust the upper tolerance handles, which modify core transparency within the luma channel of the matte. By default, the slope of the left and right sides of the Luma graph has a slight “S” curve. You can modify the shape of the curve by adjusting the Luma Rolloff slider (described below).

*Note*: The luma softness handles may extend past the outer boundaries of the Luma control. This is due to the floating-point precision of the Green Screen Keyer effect and is expected. To reveal out-of-bounds handles and then move them, drag the slope line of the Luma graph.

• **Chroma Rolloff**: Use this slider to adjust the linearity of the chroma rolloff slope (displayed in the small graph to the left of the Chroma control). Chroma rolloff modifies the softness of the matte around the edges of regions that are affected most by the Chroma control. Lowering this value makes the slope of the graph more linear, which softens the edges of the matte. Raising this value makes the slope of the graph steeper, which sharpens the edges of the matte.

• **Luma Rolloff**: Use this slider to adjust the linearity of the luma rolloff slope (the ends of the bell-shaped luma curve displayed in the Luma control). Luma rolloff modifies the softness of the matte around the edges of regions that are affected most by the Luma control. Lowering this value makes the slope between the upper and lower handles in the Luma control more linear, which increases edge softness in the matte. Raising this value makes the slope steeper, sharpening the edges of the matte and making them more abrupt.

• **Fix Video**: Select this checkbox to apply subpixel smoothing to the chroma components of the image, reducing the jagged edges that result from keying compressed media using 4:2:0, 4:1:1, or 4:2:2 chroma subsampling. Although selected by default, this checkbox can be deselected if subpixel smoothing degrades the quality of your keys.
3. Click Matte Tools to reveal the following controls:

- **Levels**: Use this grayscale gradient to alter the contrast of the keyed matte, by dragging three handles that set the black point, white point, and bias (distribution of gray values between the black point and white point). Adjusting the contrast of a matte can be useful for manipulating translucent areas of the key to make them more solid (by lowering the white point) or more translucent (by raising the black point). Dragging the Bias handle right erodes translucent regions of the key, and dragging the Bias handle left makes translucent regions of the key more solid.

- **Black, White, Bias**: Click the Levels disclosure triangle to reveal sliders for the Black, White, and Bias parameters. These sliders, which mirror the settings of the Levels handles described above, allow you to keyframe the three Levels parameters (using the Add Keyframe button to the right of each slider). Keyframing the Black, White, and Bias parameters may yield a better key, one that adapts to changing blue-screen or green-screen conditions.

- **Shrink/Expand**: Use this slider to manipulate the contrast of the matte to affect matte translucence and matte size simultaneously. Drag the slider left to make translucent regions more translucent while simultaneously shrinking the matte. Drag the slider right to make translucent regions more solid while simultaneously expanding the matte.

- **Soften**: Use this slider to blur the keyed matte, feathering the edges by a uniform amount.

- **Erode**: Drag this slider right to gradually increase transparency from the edge of the solid portion of the key inward.
4. Click Spill Suppression to reveal the following controls:

- **Spill Contrast**: Use this grayscale gradient to adjust the contrast of the color being suppressed, using the Black and White point handles (and corresponding sliders). Modifying spill contrast can reduce the gray fringing surrounding a foreground subject. The Black point handle (on the left side of the gradient control) lightens edge fringing that is too dark for a successful composite. The White point handle (on the right side of the gradient control) darkens edge fringing that is too light. Depending on how much spill is neutralized by the Spill Level slider, these controls may have a greater or lesser effect on the subject.

- **Black, White**: Click the Spill Contrast disclosure triangle to reveal sliders for the Black and White point parameters. These sliders, which mirror the settings of the Spill Contrast handles described above, allow you to keyframe the Black point and White point parameters (using the Add Keyframe button to the right of each slider).

- **Tint**: Use this slider to restore the natural color of the keyed foreground subject. Because the Spill Suppression controls eliminate blue or green spill by desaturating subtle blue or green fringing and reflection on the subject, the Tint slider lets you add hues to restore the natural color of the subject. Overdoing this parameter results in over-tinting the subject with the complementary color of the hue being suppressed—magenta if green, and orange if blue.

- **Saturation**: Use this slider to alter the range of hues introduced by the Tint slider (when the Tint slider is used at moderate levels).
5. Click Light Wrap to reveal the following controls:

![Light Wrap controls](image)

- **Amount**: Use this slider to control the overall light wrap effect, setting how far into the foreground the light wrap extends.
- **Intensity**: Use this slider to adjust gamma levels to lighten or darken the interaction of wrapped edge values with the keyed foreground subject.
- **Opacity**: Use this slider to fade the light wrap effect up or down.
- **Mode**: Use this pop-up menu to choose the compositing method that blends the sampled background values with the edges of the keyed subject. There are five modes:
  - **Normal**: Evenly blends light and dark values from the background layer with the edges of the keyed foreground layer.
  - **Lighten**: Compares overlapping pixels from the foreground and background layers, and then preserves the lighter of the two. This method is good for creating a selective light wrap effect.
  - **Screen**: Superimposes lighter portions of the background layer over wrapped areas of the keyed foreground layer. This method is good for creating an aggressive light wrap effect.
  - **Overlay**: Combines the background layer with the wrapped areas of the keyed foreground layer so overlapping dark portions become darker, light portions become lighter, and colors become intensified.
  - **Hard Light**: Similar to the Overlay composite mode, except that colors become muted.

**Animate the Green Screen Keyer effect**

To compensate for changing conditions in the foreground clip, you can make Sample Color and Edges adjustments at multiple points in the clip.

1. In the Final Cut Pro timeline, place the playhead at the start of the foreground clip with the Green Screen Keyer effect.
2. Use Sample Color and Edges (described above) to create a good chroma key.
3. Move the playhead to a point later in the clip where the lighting or background conditions change, resulting in the chroma key no longer being acceptable.
4. Use Sample Color and Edges to once again create a good chroma key.
5. To add additional adjustments at other playhead positions, repeat steps 3 and 4 as needed.
6. To move the playhead between adjustment points, use the Jump to Sample arrows.
When you play the clip, the Sample Color and Edges settings smoothly change from one sample point to the next. For even greater control, you can add keyframes for most of the other settings in the Keyer section of the Video inspector. For more information about working with keyframes, see Intro to video keyframing.

Note: Keyframes for the chroma and luma graphs in the Color Selection controls appear only in the Video inspector and not the Video Animation editor in the timeline.

Use the Luma Keyer effect in Final Cut Pro for Mac

Luma keys provide a way to composite a foreground clip over a background clip based on the luma levels in the video. This is most often useful for still images, such as a picture of a logo over a black background, or computer-generated graphics. You create a luma key with the Luma Keyer effect.

In the following examples, the speedometer image below is keyed over an outdoor car scene, creating a reflected look.

Apply the Luma Keyer effect

1. In the Final Cut Pro timeline, move the playhead to the point in the background clip (the clip you want to superimpose the luma key clip over) where you want the key to start.

2. In the browser, select the part of the foreground clip (the luma key clip) that you want to key over the background, then choose Edit > Connect to Primary Storyline (or press Q).

   For details about connecting clips in this way, see Connect clips.
3. Select the foreground clip in the timeline, then click the Effects button in the top-right corner of the timeline (or press Command-5).

4. In the Effects browser, select the Luma Keyer effect.

   Tip: Type “keyer” in the Effects browser search field to quickly find the Luma Keyer effect.

5. Do one of the following:
   • Drag the effect to the timeline foreground clip you want to apply the effect to.
   • Double-click the effect thumbnail to apply the effect to the selected clip.

The Luma Keyer effect automatically removes the black video. If the resulting key isn’t right or you want to improve it, you can adjust the luma key effect.

Adjust the Luma Keyer effect
1. In the Final Cut Pro timeline, select the clip with the Luma Keyer effect.
2. Open the Video inspector.

   The Effects section of the Video inspector shows the parameters available for adjusting the Luma Keyer effect.

3. To reverse the key and remove white instead of black areas of the foreground clip, select Invert.
4. To adjust the white and black clip values, drag the handles at either end of the gradient thumbnail image.

   By default, these handles are set to provide a key where the luma level linearly controls the transparency of the foreground—100% white is fully opaque, 0% black is completely transparent, and 25% gray retains 25% of the foreground image. Dragging the white and black controls changes the values that result in fully opaque or fully transparent foreground video.
5. To adjust the softness of the edges, adjust the Luma Rolloff control.

   Higher values make the edges harder, removing any partial transparency; lower values take advantage of any anti-aliasing or softness the edges might have.
6. To help fine-tune the key, use the View options:

- **Composite**: Shows the final composited image, with the keyed foreground subject over the background clip. This is the default view.

- **Matte**: Shows the grayscale matte, or alpha channel, that's being generated by the keying operation. White areas are solid, black areas are transparent, and shades of gray indicate varying levels of transparency. Viewing the alpha channel makes it easier to spot unwanted holes in the key or areas that aren't transparent enough.

- **Original**: Shows the original, unkeyed image.

7. To leave smoothly aliased text or graphics in the image visually intact, which can improve the edges, select Preserve RGB.

8. To mix the keyed effect with the unkeyed effect, adjust the Mix control.

If you’re still having trouble getting a clean luma key, see the following instructions.

**Make advanced Luma Keyer adjustments**

The following controls are available for use in difficult keying situations or for fine-tuning specific problems:

- **Matte Tools**: These controls refine the transparency matte generated by the previous sets of parameters. These parameters don’t alter the range of values sampled to create the keyed matte. Instead, they alter the matte generated by the Keyer effect’s basic and advanced controls, letting you shrink, expand, soften, or invert the matte to achieve a better composite.

- **Light Wrap**: These controls blend color and lightness values from the background layer of your composite with the keyed foreground layer. Using these controls, you can simulate the interaction of environmental lighting with the keyed subject, making it appear as if background light wraps around the edges of a subject.
1. In the Final Cut Pro timeline, select the clip with the Luma Keyer effect.

2. Open the Video inspector.

   The Effects section of the Video inspector shows the parameters available for adjusting the Luma Keyer effect.

3. Click Matte Tools to reveal the following controls:

   • **Fill Holes**: Increasing this parameter value adds solidity to regions of marginal transparency within a key. This control is useful when you’re satisfied with the edges of your key, but you have unwanted holes in the interior that you can’t eliminate using the Luma Rolloff parameter without ruining your edges.

   • **Edge Distance**: Lets you adjust how close to the edge of your keyed subject the effect of the Fill Holes parameter gets. Reducing this parameter value brings the filled area of the matte closer to the edge of the subject, sacrificing translucency at the edges. Raising this parameter value pushes the filled area of the matte farther from the edge, potentially introducing regions of unwanted translucency within parts of the subject that should be solid.

   • **Levels**: Use this grayscale gradient to alter the contrast of the keyed matte, by dragging three handles that set the black point, white point, and bias (distribution of gray values between the black point and white point). Adjusting the contrast of a matte can be useful for manipulating translucent areas of the key to make them more solid (by lowering the white point) or more translucent (by raising the black point). Dragging the Bias handle right erodes translucent regions of the key, and dragging the Bias handle left makes translucent regions of the key more solid.
• **Black, White, Bias:** Click the Levels disclosure triangle to reveal sliders for the Black, White, and Bias parameters. These sliders, which mirror the settings of the Levels handles described above, allow you to keyframe the three Levels parameters (using the Add Keyframe button to the right of each slider). Keyframing the Black, White, and Bias parameters may yield a better key, one that adapts to changing blue-screen or green-screen conditions.

• **Shrink/Expand:** Use this slider to manipulate the contrast of the matte to affect matte translucence and matte size simultaneously. Drag the slider left to make translucent regions more translucent while simultaneously shrinking the matte. Drag the slider right to make translucent regions more solid while simultaneously expanding the matte.

• **Soften:** Use this slider to blur the keyed matte, feathering the edges by a uniform amount.

• **Erode:** Drag this slider right to gradually increase transparency from the edge of the solid portion of the key inward.

4. Click **Light Wrap** to reveal the following controls:

   ![Light Wrap Controls](image)

   • **Amount:** Use this slider to control the overall light wrap effect, setting how far into the foreground the light wrap extends.

   • **Intensity:** Use this slider to adjust gamma levels to lighten or darken the interaction of wrapped edge values with the keyed foreground subject.

   • **Opacity:** Use this slider to fade the light wrap effect up or down.

   • **Mode:** Use this pop-up menu to choose the compositing method that blends the sampled background values with the edges of the keyed subject. There are five modes:
     
     • **Normal:** Evenly blends light and dark values from the background layer with the edges of the keyed foreground layer.

     • **Lighten:** Compares overlapping pixels from the foreground and background layers, and then preserves the lighter of the two. This method is good for creating a selective light wrap effect.

     • **Screen:** Superimposes lighter portions of the background layer over wrapped areas of the keyed foreground layer. This method is good for creating an aggressive light wrap effect.

     • **Overlay:** Combines the background layer with the wrapped areas of the keyed foreground layer so that overlapping dark portions become darker, light portions become lighter, and colors become intensified.

     • **Hard Light:** Similar to the Overlay composite mode, except that colors become muted.
Finalize a key in Final Cut Pro for Mac

Quite often your foreground image has objects that you don’t want to appear in the compositied output. These could be production items like microphone booms and light stands or the edges of the chroma key backdrop. Additionally, you might need to resize or reposition the foreground object to better fit with the background. As a final step, you can use the color corrector to adjust the foreground so that it matches the look of the background.

Final Cut Pro includes effects that you can use for these purposes.

Use a mask effect to remove unwanted parts of the foreground image

1. In the Final Cut Pro timeline, move the playhead to the point in the background clip (the clip you want to superimpose the chroma key clip over) where you want the key to start.

2. In the browser, select the part of the foreground clip (the chroma key clip) you want to key over the background, then choose Edit > Connect to Primary Storyline (or press Q).

3. Select the foreground clip.

In the above example, the light stands need to be removed.
4. Click the Effects button in the top-right corner of the timeline (or press Command-5).

5. In the Effects browser, double-click a mask effect to apply it to the selected foreground clip.
   Tip: Type “mask” in the Effects browser search field to quickly find the various mask effects. See Intro to masking.

6. Adjust the edges of the mask to crop out the objects you want to remove.

   When adjusting the mask, be sure to leave shadows and other details that can help make the key more realistic later.
7. Apply the appropriate keyer effect to the foreground clip.

The foreground is composited over the background.

Use Transform to position the foreground image

You can use the Transform effect to reposition a keyed foreground image.
1. Select the foreground clip in the Final Cut Pro timeline.

2. Click the pop-up menu in the lower-left corner of the viewer, choose Transform, and move the image to the position you want.

   You can also resize the image.

3. When you’ve finished repositioning the foreground image, click Done in the viewer.

Masking

Intro to masking in Final Cut Pro for Mac

When you draw shapes to create areas of transparency in an image, you are masking that image. Final Cut Pro has a number of powerful masking tools for creating areas of transparency in a video clip or still image.

You can use onscreen controls to precisely define the mask area. For example, if you want to isolate a clip’s foreground subject, you can create a detailed mask to cut out the background. You can also animate mask effects to create complex regions of animated transparency that change over time.
The following mask effects are available in the Masks category of the Effects browser. Add them to any clip in the timeline just as you would add any other clip effect. With the exception of Draw Mask, all of the following mask effects are considered “simple masks,” with relatively straightforward masking controls.

- **Draw Mask**: Draw a complex custom mask using control points and spline drawing methods to adjust shape and curvature. See Create complex masks and Intro to editing complex masks.
- **Graduated Mask**: Create a mask based on a gradient (from fully transparent to fully opaque).
- **Image Mask**: Create areas of transparency in a clip using a chroma channel, a luma channel, or an alpha channel from a different image.
- **Shape Mask**: Create a mask in any shape on the continuum from ellipse to rectangle. See Create simple shape masks. This is the only simple mask that can be converted to editable control points for making complex custom masks.
- **Vignette Mask**: Create a horizontal ellipse mask with graduated edges.

Final Cut Pro also features **effect masking**. Most clip effects have built-in shape masks and color masks that allow you to isolate and control which areas of the video image are affected by clip effects and color corrections. See Intro to effect masking.

*Note*: Masking blend modes (including Add, Subtract, and Intersect) for combining multiple masks are available for effect masking only.

### Create simple shape masks in Final Cut Pro for Mac

The Shape Mask effect allows you to quickly create a mask in any shape on the continuum from ellipse to rectangle.

*Note*: The Shape Mask is the only simple mask that can be converted to editable control points for making complex custom masks (changing it into a Draw Mask). See Create complex masks and Intro to editing complex masks.

1. Add the clip you want to mask to the Final Cut Pro timeline.
   *Note*: If you want to composite the clip over a background clip, you must use connected clips. See Connect clips.

2. Select the clip in the timeline, then position the playhead at a point within the clip that shows the area you want to make transparent.

3. To open the Effects browser, click the Effects button in the top-right corner of the timeline (or press Command-5).

4. In the Effects browser, select the Shape Mask effect.
   ✨ **Tip**: To quickly find the Shape Mask effect, type “shape” in the Effects browser search field.
5. To apply the mask effect to the clip selected in the timeline, do one of the following:
   • Drag the effect to the timeline clip.
   • Double-click the effect thumbnail in the Effects browser.

   The Shape Mask onscreen controls appear in the viewer, superimposed over the video image. The Shape Mask parameters appear in the Effects section of the Video inspector. By default, the Shape Mask is set to a partially feathered ellipse shape in the center of the frame.

6. Use the onscreen controls to adjust the shape mask as needed.

   • *Position the shape*: Drag the center.
   • *Adjust the shape’s width or height*: Drag any of the four handles at the 90-degree points (top, bottom, left, or right) of the inner circle. You can hold down the Shift key while dragging to force all sides to scale proportionally. Or hold down the Option key to adjust one side only.
   • *Control the curvature of the shape*: Drag the handle to the left of the inner circle’s top handle. One extreme of the curvature continuum is a perfect rectangle. The other extreme is an oval or a perfect circle.
   • *Rotate the shape*: Drag the rotation handle (extending from the center).
   • *Control the softness of the shape’s edge*: Drag the outer circle. Setting the outer circle close to the inner circle creates a hard edge and an abrupt transition to the background, and dragging the outer circle away from the inner circle creates a softer edge and a more gradual transition.
   • *Hide the mask’s controls*: Click the Shape Mask Onscreen Controls button in the Shape Mask area of the Color section of the Video inspector.

   *Note: The Shape Mask is just one of several simple mask effects. For the complete list of Effects browser mask effects, see Intro to masking.*
Use the Scene Removal Mask in Final Cut Pro for Mac

The Scene Removal Mask effect detects objects in the foreground of a video clip and automatically removes the background—without the need for a green screen. You can then replace the background with a different image or insert a title between the foreground and background.

Before you begin
For best results, before you apply the Scene Removal Mask to a video clip, make sure the clip:

- Has a static background and was captured using a stationary camera (a camera attached to a tripod, for example)
- Has a few extra frames at the beginning or end showing the background without the foreground subject present
- Was shot in a bright, evenly lit place (preferably indoors)
- Has good contrast between the subject and background (no similar colors or textures)
- Has no strong moving shadows, and maintains space between the foreground subject and background
- Has a visually simple background (without complex patterns or structures such as windows or bookshelves)
Apply the Scene Removal Mask to a clip

1. In Final Cut Pro, add the foreground clip (the clip with the background you want to remove) to the primary storyline in the timeline.

2. In the timeline, position the playhead over the clip (so that its image appears in the viewer).

   Tip: For best results, position the playhead at a point within the foreground clip that shows the maximum amount of the background to be removed.

3. Select the foreground clip in the timeline, then click the Effects button in the top-right corner of the timeline (or press Command-5).

4. In the Effects browser, select the Scene Removal Mask effect.

   Tip: Type “scene” in the Effects browser search field to quickly find the Scene Removal Mask effect.

5. Do one of the following:
   - Drag the effect to the timeline foreground clip you want to apply the effect to.
   - Double-click the effect thumbnail to apply the effect to the selected clip.

6. In the timeline, select the foreground clip with the Scene Removal Mask effect, then open the Video inspector.
   Controls for adjusting the Scene Removal Mask effect appear.

7. In the Scene Removal Mask section of the inspector, click the Reference pop-up menu and choose an option:
   - First Frame: Final Cut Pro uses the first frame of the clip to analyze and then remove the background.
   - First Frame + 1 Second: The frame 1 second after the first frame of the clip is used.
   - Last Frame – 1 Second: The frame 1 second before the last frame of the clip is used.
   - Last Frame: The last frame of the clip is used.

The original background is removed, and the foreground subject is isolated in front of a transparent background. If the clip is in the primary storyline (with no connected clips), the background appears black in the viewer.

To replace the background, see Add a new background, below.
Add a new background

When you apply the Scene Removal Mask to a clip in the primary storyline, the background appears black in the viewer. You can give the isolated foreground subject a new background by *compositing* (combining) the masked clip with a separate background clip.

1. In Final Cut Pro, apply the Scene Removal Mask to a clip in the timeline.
2. Select the clip in the timeline, then position the playhead over the clip (so that its image appears in the viewer).
3. In the browser, select the clip you want to use as the background and drag it to the timeline, connecting it at a position under the masked clip.

See Connect clips.

In the viewer, the foreground subject from the masked clip appears superimposed over the image from the background clip.

![Masked image with a new background](image)

Insert a title between the foreground and background

After you apply the Scene Removal Mask to a clip in the timeline, you can add a title to the timeline so that in the viewer, the text appears behind the foreground subject.

1. In Final Cut Pro, apply the Scene Removal Mask to a clip in the timeline, add a new background, then position the playhead over the clips (to see the result of the effect in the viewer).
2. If the Titles and Generators sidebar isn’t already shown, do one of the following:
   - Click the Titles and Generators button in the top-left corner of the Final Cut Pro window.
   - Choose Window > Go To > Titles and Generators (or press Option-Command-1).
3. Drag a title clip from the Titles and Generators sidebar to a position in the timeline between the masked foreground clip and the background clip. The title clip is attached as a connected clip.

4. Adjust the title, as needed.

Create complex masks

Intro to complex masks in Final Cut Pro for Mac

With the Draw Mask effect, you can draw complex masks using splines. Splines are vector-based curves that allow for complex, customized shapes. There are two spline drawing methods:

- Bezier splines: Bezier splines are good for drawing shapes for illustration. The controls used to manipulate Bezier splines are similar to those found in many other drawing and compositing apps. Bezier controls lend themselves to the creation of precise, detailed shapes. Tangent handles adjust the curvature of the shape on either side of the control point, defining the surface of the shape.
• **B-Splines:** You can also use B-Splines to draw shapes. Unlike Bezier splines, B-Splines are manipulated using only points—there are no tangent handles. Furthermore, the points themselves do not lie on the surface of the shape. Instead, each B-Spline control point is offset from the shape's surface, magnetically pulling that section of the shape toward itself to create a curve. By combining the influence of multiple B-Spline points, you can create different curves. B-Splines are extremely smooth—by default, there are no sharp angles in B-Spline shapes, although you can create sharper curves, if necessary. Because B-Spline controls are so simple, they’re easy to animate and manipulate.

You can also draw masks with linear control points, which are connected by straight lines. Linear control points are also known as *corner* points. You can convert control points between linear (corner) points and smooth (Bezier) points at any time.

*Note:* By default, the Draw Mask is set to draw with Bezier shapes. If you prefer to draw your mask with linear or B-Spline shapes, you can adjust this setting in the Video inspector before you get started.
Create complex masks in Final Cut Pro for Mac

You can use the powerful Draw Mask effect to create a complex custom mask using control points and spline drawing methods. You can also convert a Shape Mask to a Draw Mask, to take advantage of its sophisticated controls.

Create a complex mask with the Draw Mask effect

The instructions below explain how to create a mask using a Bezier spline, the default shape type. If you prefer to draw your mask with linear or B-Spline shapes, you can adjust this setting in the Video inspector before you get started. See Add control points.

1. Add the clip you want to mask to the Final Cut Pro timeline.
   
   Note: If you want to composite the clip over a background clip, you must use connected clips. See Connect clips.

2. Select the clip in the timeline, then position the playhead at a point within the clip that shows the area you want to make transparent.

3. To open the Effects browser, click the Effects button in the top-right corner of the timeline (or press Command-5).

4. In the Effects browser, select the Draw Mask effect.
   
   Tip: To quickly find the Draw Mask effect, type "draw mask" in the Effects browser search field.

5. To apply the mask effect to the clip selected in the timeline, do one of the following:
   - Drag the effect to the timeline clip.
   - Double-click the effect thumbnail in the Effects browser.

6. In the viewer, click to add a control point.
   
   A red dot with a white center (indicating a selected control point) appears where you clicked.
7. To add points to further define the shape, do one of the following:
   - Click to make a linear corner point.
   - Drag to make a curved Bezier point, adjusting it to the shape you want.

Press Shift while making a curved point to constrain its tangents to 45-degree angles. Press Command-Plus Sign (+) to zoom in for a closer look, and Command-Minus Sign (−) to zoom out.

8. Continue adding more control points in the viewer to create your detailed mask shape. Red lines appear in the viewer, connecting the control points.
9. To complete the initial mask shape, click the original control point. The area outside the mask shape is filled with solid black, representing the transparent area. If you added a background clip using connected clips, the background image shows through this transparent area.

10. To adjust the mask, do any of the following:
   - Visually manipulate the mask in the viewer: Drag the onscreen controls in the viewer.
   - Show or hide onscreen controls and control points in the viewer: Click the Draw Mask Onscreen Controls button in the Draw Mask section of the Video inspector.
   - Make precise numeric adjustments, including keyframing: Modify the mask settings in the Draw Mask section of the Video inspector.

Create a complex mask by converting a Shape Mask
You can refine the contours of a Shape Mask by converting it to a Draw Mask with editable control points that allow you to adjust shape and curvature.

1. Add a Shape Mask effect to a clip in the Final Cut Pro timeline. The Shape Mask onscreen controls appear in the viewer.
2. Do one of the following:
   • Click Convert to Points at the bottom of the Shape Mask section of the Video inspector.
   • Control-click the Shape Mask onscreen controls in the viewer and choose Convert to Points.

Red control points appear in the viewer, in place of the Shape Mask onscreen controls. In the Video inspector, the Shape Mask section changes to a Draw Mask section.

Note: If you animated the Radius or Curvature parameter in the original Shape Mask, a dialog appears asking you to confirm the conversion. The animation is discarded after the shape is converted.

3. To adjust the mask, do any of the following:
   • Visually manipulate the mask in the viewer: Drag the control points in the viewer.
   • Show or hide onscreen controls and control points in the viewer: Click the Draw Mask Onscreen Controls button in the Draw Mask section of the Video inspector.
   • Make precise numeric adjustments, including keyframing: Modify the mask settings in the Draw Mask section of the Video inspector.

Note: After the control points become available, you can’t convert the mask back to a simple shape mask.
Use multiple masks in Final Cut Pro for Mac

Occasionally, it may be necessary to apply multiple masks to the same image. For example, if you’re masking an image of a car, you might draw separate masks for different parts of the car: roof and windows, the lower body, and so on. It’s easier to divide the car into parts, draw separate masks for each part, and composite the masks together at the end than to draw an accurate car shape in one mask. You can apply any combination of Shape Masks and Draw Masks.

Note: Mask blend modes are available for effect masking only. Dragging multiple instances of the Draw Mask or the Shape Mask to the same clip creates the equivalent of the Intersect blend mode in the effect masking feature. In Intersect mode, only the area inside the mask shape that overlaps with other mask shapes is affected. See Combine multiple effect masks. The instructions below explain how to create the equivalent of Add mode, in which multiple mask shapes are merged.

1. Add the clip you want to mask to the Final Cut Pro timeline.
2. Duplicate the clip as a connected clip directly above the original clip.

Tip: To quickly duplicate the original clip and position it at the same time, Option-drag the clip to the area just above the primary storyline.

3. Apply a mask to the connected clip.

Tip: To get a better view of your mask as you create it, you can temporarily disable the other clip by selecting it and pressing V. To reenable the clip, press V again.

4. Apply a mask to the original clip.
   The two mask shapes are effectively merged.
5. To add any additional masks, repeat steps 2 and 3.
Edit complex masks

Intro to editing complex masks in Final Cut Pro for Mac

Complex masks are defined by Bezier splines and B-Splines, which are built with control points. Each control point in a complex mask defines some sort of corner or curve, and the actual spline that makes up the shape connects these control points together like a connect-the-dots drawing. The control points determine the shape and curvature of the spline.

You can modify a spline by dragging its control points and adjusting the tangent handles attached to each control point. You can transform multiple control points simultaneously, and you can add, delete, and lock control points.

Add mask control points in Final Cut Pro for Mac

You draw the shape of your complex mask by adding and adjusting control points. The default drawing shape type is Bezier, but you can change the shape type before creating the mask if you want to draw with a linear or B-Spline shape instead.

Set the shape type to Bezier, linear, or B-Spline

It's best to set the shape type in the Video inspector before you create your mask. Changing the type in the middle of drawing your mask may radically alter the shape.

1. Add a Draw Mask effect to a clip in the Final Cut Pro timeline, then select the clip.
2. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Video button at the top of the inspector.

4. In the Draw Mask section of the Video inspector, click the Shape Type pop-up menu and choose the type of mask shape you want to use: Linear, Bezier, or B-Spline.

**Add control points to a Draw Mask**

In the Final Cut Pro viewer, do one of the following:

- Option-click or double-click the edge of a mask.
  
  *Note:* To add control points to a B-Spline mask, Option-click or double-click the B-Spline frame's edge rather than the edge of the mask itself.

- Control-click the edge of a mask and choose Add Point.

**Delete control points from a Draw Mask**

If a mask has more control points than are necessary, you can delete points to make it easier to edit. This can be helpful if you animate the mask later on.

1. In the Final Cut Pro viewer, select the control points to delete.

2. Do one of the following:

   - Choose Edit > Delete.
   - Control-click the selected points and choose Delete Point.
   - Press Delete.

The mask shape is updated in the viewer. If you remove points from a closed mask, the mask remains closed.
Lock and disable mask control points in Final Cut Pro for Mac

There are many ways to select and deselect control points that you want to modify. You can also lock control points to prevent changes, or disable them to temporarily remove them from a mask shape.

Select control points

In the Final Cut Pro viewer, do one of the following:

• Click any control point.
• Shift-click unselected control points to add them to the selection.
• Shift-drag a selection rectangle around unselected control points in a closed mask to add them to the selection.
• Drag a selection rectangle over multiple control points in a closed mask.

Deselect control points

In the Final Cut Pro viewer, do one of the following:

• Shift-click selected points.
• Shift-drag a selection rectangle over selected points.

Select or deselect every control point on a mask

In the Final Cut Pro viewer, do one of the following:

• Select all of a mask’s control points: Choose Edit > Select All (or press Command-A).
• Deselect all of a mask’s control points: Choose Edit > Deselect All (or press Shift-Command-A).

You can also click anywhere outside the selected mask in the viewer.

Display the control point number

By default, mask control points are numerically labeled in the order in which they were created in the viewer.

• In the Final Cut Pro viewer, position the pointer over any control point in a closed mask.
  The numeric name of the control point appears—“Control Point 1,” for example.

Note: Draw Mask control points are also listed by number in the Draw Mask section of the Video inspector.
Lock control points
You can lock control points in a mask to fix them in place and prevent accidental changes.

• In the Final Cut Pro viewer, Control-click a control point and choose Lock Point.

  To unlock a locked control point, Control-click it and choose Unlock Point.

Disable control points
Disabling a control point in a Draw Mask is similar to disabling a clip in the timeline: The control point is temporarily removed from the mask but retains its position and its number in the sequence of control points. You can just as easily reenable control points.

• In the Final Cut Pro viewer, Control-click a control point and choose Disable Point.

  To enable a disabled control point, Control-click it and choose Enable Point.

Move mask control points in Final Cut Pro for Mac
You can move control points in the viewer to change the shape of your mask.

Drag selected control points

• Select control points on a mask in the Final Cut Pro viewer, then drag the points to a new position.

  As you drag selected control points, the rest of the mask stretches or curves to accommodate the change.

Note: When you drag a control point, the point’s name and coordinates are displayed at the top of the viewer.

Move a selected control point by one pixel

1. Select a control point on a mask in the Final Cut Pro viewer.

2. Do any of the following:

   • Nudge left: Press Comma (,).
   • Nudge right: Press Period (.).
   • Nudge up: Press Option-Up Arrow.
   • Nudge down: Press Option-Down Arrow.
Constrain the movement of selected control points

1. Select control points on a mask in the Final Cut Pro viewer.
2. Press Shift while you drag a selected point horizontally, vertically, or diagonally.
   The control point movement is constrained to the horizontal (90-degree), vertical (180-degree), or diagonal (45-degree or 135-degree) axis.

Move control points using the Video inspector

You can make precise adjustments to the position of any control point using controls in the Video inspector.

1. In the Final Cut Pro timeline, select the clip containing the mask you want to modify.
2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Video button at the top of the inspector.
4. In the Draw Mask section of the Video inspector, click the Control Points disclosure triangle to open the Control Points controls.
5. Make numerical adjustments to the X and Y coordinates for any control point using the value sliders.

Position, rotate, and scale a mask

1. In the Final Cut Pro timeline, select the clip containing the mask you want to modify.
2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.
3. Click the Video button at the top of the inspector.

4. In the Draw Mask section of the Video inspector, click the Transforms disclosure triangle to open the Transforms controls.

5. Adjust the Position, Rotation, and Scale parameters to precisely define the shape, size, and position of your mask.

**Move a mask edge**

You can change a mask shape by dragging its edges.

1. In the Final Cut Pro viewer, click any edge of a mask.
   The control points on either end of the line are selected.

2. Drag the line segment.

   The distance between the two points remains constant as you drag. Press Shift to constrain the movement horizontally, vertically, or diagonally.

**Edit Bezier control points in Final Cut Pro for Mac**

You can adjust Bezier control points to draw any mask shape you may need. Each point in a Bezier shape can be converted between a linear (corner) point and a smooth (Bezier) point at any time. For more information about smooth and linear points, see Intro to complex masks.

**Convert control points between corners and curves**

On a mask in the Final Cut Pro viewer, do any of the following:

- Command-click a smooth (Bezier) point to turn it into a linear (corner) point.
- Command-drag a linear (corner) point to turn it into a smooth (Bezier) point, creating adjustable tangent handles.
- Control-click selected points and choose either Linear, Smooth, or Very Smooth (for B-Splines) to change the control point type.
Adjust a Bezier curve using a control point's tangent handles

Bezier control points on a mask in the viewer have two tangent handles that you use to adjust the curvature of the shape on either side of the control point. These handles can be adjusted in various ways to create symmetrical and asymmetrical curves. By default, these tangent handles are locked to one another at an angle of 180 degrees, but you can override this restriction to adjust each tangent handle independently.

In Final Cut Pro, do any of the following:

- **Adjust the length of a tangent handle:** Drag the handle. You can adjust the length of each tangent handle independently even when the tangent handles are locked to 180 degrees.

![Adjusting Bezier Curve](image)

- **Break the relationship between opposing tangent handles:** Option-drag either tangent handle. After this relationship is broken, adjustments to one tangent handle have no effect on the other, and you can rotate both tangent handles freely.

![Breaking Bezier Curve](image)

You can also Control-click a tangent handle point and choose Break Handle.
• **Lock the angle of the tangent handles together again:** Option-drag a broken tangent handle, or Control-click a handle point and choose Link Handle. The tangent handles now maintain their relationship when moved and rotated.

• **Align the tangent handles to a 180-degree angle:** Control-click a handle point and choose Align Handles.

Press Shift while you adjust a tangent handle to constrain its movement to 45-degree angles. To simultaneously modify the handles for more than one control point, Shift-select the points (on the same spline) and then adjust the tangent handles.

**Edit B-Spline control points in Final Cut Pro for Mac**

Editing control points in B-Spline shapes is similar to editing control points in Bezier shapes. In fact, the steps for selecting, moving, adding, deleting, and locking control points are almost exactly the same. The main difference in editing the two types of shapes lies in how you manipulate and adjust curves.

The simplest, and usually fastest, way to manipulate B-Spline curves is to move B-Spline points closer to or farther from one another. When B-Spline points are moved closer to one another, a sharper curve is created. B-Spline points that are farther from one another create shallower curves.

Each B-Spline control point tugs on a section of the shape, pulling it toward itself. For this reason, you manipulate a shape’s curve by moving its control points in the direction you want to pull the shape. For example, notice how every control point creating the S curve below is offset in the direction of the curve it influences.

By default, B-Spline shapes have no corners. However, you can adjust the amount of curvature at each B-Spline control point to create sharper curves using fewer control points. (You can even create corners at a single point, if necessary.)
The easiest way to adjust B-Spline point curvature is by Command-dragging the control point. You can also switch between three preset degrees of curvature.

1. In the Final Cut Pro viewer, Command-drag selected B-Spline control points. A handle appears indicating the adjustment you're making.

   *Note:* After the handle appears, you can modify the curve without using the Command key.

2. Do any of the following:
   - *Make the curve progressively sharper:* Drag away from the point.
   - *Make the curve progressively looser:* Drag toward the point.

   ![B-Spline point curvature options](image)

   *Switch between three progressively sharper degrees of curvature:* Command-click the handle.

   Alternatively, you can Control-click a B-Spline point and choose either Very Smooth, Smooth, or Linear.

### Animate a mask in Final Cut Pro for Mac

As with many effects and titles in Final Cut Pro, you can animate simple and complex masks using keyframes.

For more information about animating effects using keyframes, see [Intro to video keyframing](#).

1. **Add a simple mask effect** or a **Draw Mask effect** to a clip in the Final Cut Pro timeline.
2. Select the clip, then position the playhead in the timeline where you want the animation to begin.
3. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
4. Click the Video button at the top of the inspector.

5. To create the starting shape of your animated mask, do one of the following:
   • Adjust the onscreen controls in the viewer.
   • Adjust the mask controls in the Video inspector.

6. To add keyframes for the starting shape of your animated mask, do one of the following in the Video inspector:
   • Add a keyframe for a single parameter: Move the pointer over the area to the right of the parameter you want to animate, then click the Keyframe button that appears.
   • Add a keyframe to every mask effect parameter: Move the pointer over the far-right side of the effect heading, click the down arrow that appears, and choose Add from the pop-up menu.

After you add a keyframe, the Keyframe button changes to yellow, indicating that the playhead is positioned on this keyframe.
7. In the timeline, move the playhead to the next point where you want to define the mask shape, and repeat steps 4 and 5.

Final Cut Pro adds a keyframe for the parameters you adjusted, and the Keyframe button changes to yellow.

When you move the playhead in the timeline, arrows appear next to the Keyframe button in the Video inspector to indicate which side of the playhead has keyframes. To go to the previous keyframe, click the left arrow. To go to the next keyframe, click the right arrow.

8. Continue adjusting the mask shape and adding keyframes as needed.

To see the effect of your animation, play the clip.

If you’re animating a Draw Mask, you can keyframe its control points numerically in the Video inspector. To reveal these parameters, click the Control Points disclosure triangle at the bottom of the Draw Mask section of the Video inspector. See Mask controls.

Mask controls in Final Cut Pro for Mac

The Shape Mask and Draw Mask controls appear in the Video inspector. You use these controls to adjust how the mask is drawn and how each mask operates upon an image. You can also fine-tune mask control point positions.
Shape Mask controls

The Shape Mask contains the following adjustable controls:

- **Radius**: A slider that changes the mask’s size.
  - **X**: A slider that adjusts the width of the mask.
  - **Y**: A slider that adjusts the height of the mask.

- **Curvature**: A slider that changes the mask shape. One extreme of the curvature continuum is a perfect rectangle. The other extreme is an oval or a perfect circle.

- **Fill Opacity**: A slider that adjusts the opacity of the image inside the mask selection.

- **Invert Mask**: A checkbox that, when selected, reverses the mask—swapping its solid and transparent areas.

- **View**: A pop-up menu that switches between the original image and the masked image (with its transparent areas).

- **Feather**: A slider that feathers (softens) the edges of the mask. Positive feathering values soften the mask from its edge outward. Negative feathering values soften the mask from its edge inward. Feathering the edge of a mask can make the masked object blend better with the background.

- **Falloff**: A slider that controls how “steep” the feathering is. Higher values result in feathering that’s pushed farther inward, so the edge of the feathering effect is more transparent. Lower values result in the “core” of the feathering effect being pushed farther outward, so the edge of the feathering effect is less transparent.

- **Transforms**: A set of controls for adjusting the position, rotation, and size of your mask effect.

  To show the controls, click the Transforms disclosure triangle.

  - **Position X and Y**: Controls that move the mask left and right (X) and up and down (Y).
  - **Rotation**: A dial control that rotates the mask around its anchor point.
  - **Scale**: A slider that changes the mask’s size as a percentage of the default mask size.

    You can also scale the mask along a single axis. To show the controls, click the Scale disclosure triangle.
    - **Scale X and Y**: Controls that scale the mask left and right (X) and up and down (Y).

- **Control Points**: When a Shape Mask is selected, the Convert To Points button is available. Click this button to convert a Shape Mask to a Draw Mask with editable control points.
**Draw Mask controls**

The Draw Mask contains the following adjustable controls:

![Draw Mask controls interface](image)

- **Shape Type**: A pop-up menu that sets the type of control points used to define the mask. For example, if you originally created a Bezier mask, you can choose B-Spline from this menu to change how the mask is drawn. Changing the shape type might dramatically change the mask's form even though its control points remain fixed at their original coordinates. There are three options:
  - **Linear**: All of a mask’s control points are joined by hard angles, and the resulting mask is a polygon. The control points of a Linear mask lie directly on its edge.
  - **Bezier**: Control points can be a mix of Bezier curves and hard angles, creating any sort of mask. The control points of a Bezier mask lie directly on its edge.
  - **B-Spline**: Control points are all B-Spline points, with different degrees of curvature. B-Spline control points lie outside the surface of the mask but are connected by the B-Spline frame.

- **Fill Opacity**: A slider that adjusts the opacity of the image inside the mask selection.

- **Invert Mask**: A checkbox that, when selected, reverses the mask—swapping its solid and transparent areas.

- **View**: A pop-up menu that switches between the original image and the masked image (with its transparent areas).

- **Feather**: A slider that feathers (softens) the edges of the mask. Positive feathering values soften the mask from its edge outward. Negative feathering values soften the mask from its edge inward. Feathering the edge of a mask can make the masked object blend better with the background.

- **Falloff**: A slider that controls how “steep” the feathering is. Higher values result in feathering that’s pushed farther inward, so the edge of the feathering effect is more transparent. Lower values result in the “core” of the feathering effect being pushed farther outward, so the edge of the feathering effect is less transparent.
• **Transforms**: A set of controls for adjusting the position, rotation, and size of your mask effect.

To show the controls, click the Transforms disclosure triangle.

- **Position X and Y**: Controls that move the mask left and right (X) and up and down (Y).
- **Rotation**: A dial control that rotates the mask around its anchor point.
- **Scale**: A slider that changes the mask's size as a percentage of the default mask size.

You can also scale the mask along a single axis. To show the controls, click the Scale disclosure triangle.

- **Scale X and Y**: Controls that scale the mask left and right (X) and up and down (Y).

• **Control Points**: When a Draw Mask is selected, click the disclosure triangle to display a list of the position parameters for the mask control points. Use the value sliders to adjust the position of control points. The left value slider represents X, and the right value slider represents Y. Move the pointer over the Control Points heading to display a single Keyframe button (at the far right) that affects all the points, letting you add keyframes, reset the mask's animation, display the animation curve in the Video Animation editor, and so on. See [Animate a mask](#) and [Intro to video keyframing](#).

---

## Compositing

### Intro to compositing in Final Cut Pro for Mac

There are times when you need to combine two clips to create an image with bits of both. **Compositing** refers to combining parts of two or more video clips into a single image.

There are a number of ways to combine video images in Final Cut Pro:

- **Transitions**: All video transitions involve combining the end of one clip with the start of a second clip, which results in a combination of the two clips appearing at the same time during the transition. See [How transitions are created](#).

- **Keying**: All keys involve compositing a foreground image over a background image. See [Intro to keying](#).
• **Alpha channels**: Many computer-generated video clips have an alpha channel—a built-in mask—that defines precisely the areas of the clip that are composited over a background clip. These require no key setup and generally just automatically work. Alpha channels are widely used for effects (such as Transform and Distort), generators (such as Shapes and Timecode), and titles.

• **Compositing**: Each video clip in the timeline has a set of Compositing settings. These settings allow you to combine clips without using the key effects.

### Use alpha channels in Final Cut Pro for Mac

Alpha channels provide an easy way to composite one image over another. You can create still images and video clips that have alpha channels using an app such as Motion, an Apple app designed to work with Final Cut Pro. Alpha channels can be thought of as having a built-in keyer—when you use the key effects, you're creating a mask that's used in the same way that a clip with an alpha channel is used for compositing.

Below is an example of a clip with an alpha channel, showing the image that fills the alpha channel.

![Example of a clip with an alpha channel](image)

Below is the alpha channel image—the white areas define the video areas that are composited over the background. Any gray areas would define parts of the image that are partially transparent.

![Alpha channel image](image)
This is what the final composite looks like over a background clip.

Use a clip with an alpha channel
1. Position the playhead in the Final Cut Pro timeline where you want to add the alpha channel clip.
2. Select the clip with the alpha channel in the browser, then choose Edit > Connect to Primary Storyline (or press Q).
3. To see the composited clips, position the playhead within the clip that was just added above the primary storyline.

The clip is composited over the primary storyline video clip, with the alpha channel controlling the opacity of its clip.

You can also use the Opacity adjustment’s fade handles to dissolve the foreground clip on and off. See Use Compositing settings.
Use Compositing settings in Final Cut Pro for Mac

The Compositing settings provide a wide variety of options for combining two images. You can make a simple adjustment to evenly combine two images, or you can choose from settings that use the video content to determine how to combine the images.

Use the Opacity adjustment

1. Position the playhead in the Final Cut Pro timeline where you want to add a clip above the primary storyline.
2. Select the clip to add in the browser, then choose Edit > Connect to Primary Storyline (or press Q).
3. To see the composited clips in the viewer, position the playhead within the clip that was just added.
   By default, the new clip completely obscures the clip in the primary storyline.
4. To make the new clip partially transparent, select it in the timeline and adjust the Opacity control in the Compositing section of the Video inspector.

The closer the Opacity setting is to 0 percent, the more transparent the clip above the primary storyline becomes. You can also use the Opacity fade handles in the Video Animation editor to have the composited clip dissolve on and off, or you can add keyframes to have the opacity value change at specified points.

Choose a blend mode

1. Position the playhead in the Final Cut Pro timeline where you want to add a clip above the primary storyline.
2. Select the clip to add in the browser, then choose Edit > Connect to Primary Storyline (or press Q).
3. To see the composited clips in the viewer, position the playhead within the clip that was just added.
   By default, the new clip completely obscures the clip in the primary storyline.
4. Click the Blend Mode pop-up menu in the Compositing section of the Video inspector, then choose an option.

There are many blend mode settings to choose from—the correct one to use depends on the video content and the look you’re aiming for. You can also use adjust the Opacity control to make the blend mode setting more subtle.
Tracking

Intro to object tracking in Final Cut Pro for Mac

In Final Cut Pro, you can record the movement of an object in a video clip and then apply that recorded movement data to another item, such as a video effect, title, logo, or image. The result is an animation in which the item follows the tracked object in the original clip. For example, you can use object tracking to:

• Track a blurry circle to a person's face to preserve someone's anonymity
• Add a glow effect to the jet engines of an airplane streaking through the sky
• Track the names of swimmers to their moving bodies as they compete in a swim meet

In Final Cut Pro, setting up object tracking is as easy as dragging a title, image, or effect to the viewer.

How does object tracking work in Final Cut Pro for Mac?

When you drag a clip (such as a title, generator, or still image) or an effect to the viewer, Final Cut Pro suggests an object or area of pixels in the background clip (known as a reference pattern) to “lock onto” as the object moves across the viewer.

Ideally, the reference pattern should be a consistent, easily identifiable detail with high contrast. This makes the pattern easier to track. When you drag the clip or effect to a suggested object, an onscreen tracker appears with controls you can use to adjust the area you want to track.

In the second step of tracking, Final Cut Pro analyzes the motion of the designated reference pattern. Final Cut Pro uses two analysis methods (algorithms) to do the calculations for object tracking:
• **Point Cloud:** The Point Cloud method samples many positions in the search region around the center point of the tracker. Some of those positions fit the designated reference pattern more closely than others; the tracker finds the position where the search region most closely matches the reference pattern (with subpixel accuracy). For every frame analyzed, the tracker assigns a correlation value by measuring how close the best match is.

In addition to searching for the reference pattern's position, the tracker identifies how the pattern transforms (scales, rotates, or distorts) from one frame to the next. Imagine you’re tracking a logo on the shirtsleeve of a person walking past the camera. If the person turns slightly as they pass the camera, the reference pattern rotates. The tracker looks for the reference pattern and any shifts in that pattern's scale or rotation.

• **Machine Learning:** Final Cut Pro uses a machine learning model trained on a data set to follow objects in a specified region of video. On systems with an Apple Neural Engine, this portion of the algorithm is accelerated.

The machine learning model draws a bounding box around any object it identifies. This method can recognize people, animals, and many common objects.

As it analyzes motion in your project, Final Cut Pro records the data, which you can then apply to any other item (such as a clip, title, image, or effect shape mask) in your project, effectively creating a *motion track*.

### Track an effect to a moving object in Final Cut Pro for Mac

In Final Cut Pro, you can track the shape mask of a video effect (such as a blur, highlight, or color effect) to a moving object in a video clip.

**Track an effect to a moving object**

1. In Final Cut Pro, position the playhead in the timeline so that the object or face that you want to track appears in the viewer.

   For the best results, make sure the object is in focus and has details with high contrast.

2. Open the Effects browser.

3. In the Effects browser, locate the effect you want to use and drag the effect to the viewer.

   As you drag the effect over the viewer, rectangles appear over objects in the video clip and oval shapes appear over faces, indicating items whose motion can be tracked.
4. When a rectangle or oval shape appears over the object or face you want to track, release the mouse or trackpad button.

An onscreen tracker appears on the object in the video. By default, the effect shape mask is pinned to the tracker, so that the effect is applied to the exact area defined by the tracker.

5. Optionally, drag the sides and the corners of the grid to further fit the tracker to the object or face you want to track.

**Tip:** Fit the grid to the target object as tightly as possible, or even consider picking just a part of the object you want to track. (If the grid includes too much information in the background, it could potentially confuse the tracker.)

6. Confirm that Tracker is selected at the top of the viewer.

7. In the upper-left corner of the viewer, click one of the following buttons:
   - **Analyze:** Final Cut Pro tracks forward from the playhead position, then tracks backward before the playhead until the entire clip has been analyzed.
   - **Left arrow:** Final Cut Pro analyzes the portion of the clip before the playhead position only.
   - **Right arrow:** Final Cut Pro analyzes the portion of the clip after the playhead position only.

   Final Cut Pro adds a shape mask to the effect that matches the bounding box of the tracker, and the tracking data from the analysis is applied to the shape mask. See How does object tracking work?

8. To view the tracking effect, position the skimmer (or the playhead) at the start of the clip in the timeline, then press the Space bar to play the clip.

   You can repeat the steps above (with the same effect or a different effect) to track other objects in the same clip.
Adjust the shape mask of a tracking effect

1. In the Final Cut Pro timeline, select a clip that has an effect tracking an object, then position the playhead so that the clip appears in the viewer.

2. If the Shape and Tracker buttons are not already shown at the top of the viewer, open the Video inspector and select the shape mask of the effect that you’re tracking to the object.

3. Click Shape at the top of the viewer, then use the onscreen controls to adjust the effect’s shape mask.

See Add a shape mask to a video effect.

If you make changes to the shape mask after the tracking analysis described in Track an effect to a moving object is complete, the changes will overwrite the existing tracking keyframe at the playhead location, which may cause an interruption in the tracking animation. To avoid this, you can do one of the following:

- Unlink (unpin) the shape mask from the tracker before adjusting the shape mask. See Offset the position of a tracking effect.
- Reset the tracking keyframes for the entire clip (or a section of the clip). See Add, rename, reset, delete, or duplicate motion tracks.
Track an image or other clip to a moving object in Final Cut Pro for Mac

You can track an image or other clip (such as a title, generator, or video clip) to a moving object in a video clip.

In the examples below, a title is tracked to moving motorcycles.

**Track an image or other clip to a moving object**
1. In Final Cut Pro, position the playhead in the timeline so that the object or face that you want to track appears in the viewer.
   
   For the best results, make sure the object is in focus and has details with high contrast.

2. In the browser, locate the image or other clip you want to use, then drag it to the viewer.
   
   As you drag the item over the viewer, rectangles appear over objects in the video clip and oval shapes appear over faces, indicating objects or regions that can be tracked.
3. When a rectangle or oval shape appears over the object or face you want to track, release the mouse or trackpad button.

An onscreen tracker appears on the object in the viewer, and the item you dragged is superimposed on the clip.

![Tracker in viewer](image)

By default, the item you dragged (a title, in this example) is offset from the tracker area. See [Offset the position of a tracking effect](#).

Additionally, the Tracking Editor appears on the clip in the timeline.

4. Optionally, drag the sides and the corners of the grid to further fit the tracker to the object or face you want to track.

5. Confirm that Tracker is selected at the top of the viewer.

6. In the upper-left corner of the viewer, click one of the following buttons:
   - **Analyze:** Final Cut Pro tracks forward from the playhead position, then tracks backward before the playhead until the entire clip has been analyzed.
   - **Left arrow:** Final Cut Pro analyzes the portion of the clip before the playhead position only.
   - **Right arrow:** Final Cut Pro analyzes the portion of the clip after the playhead position only.

Final Cut Pro applies the tracking data from the analysis to the clip. See [How does object tracking work?](#).

7. To view the tracking effect, position the skimmer (or the playhead) at the start of the clip in the timeline, then press the Space bar to play the clip.
You can track multiple moving objects in a single clip, and you can track multiple images or other clips to a single moving object. See Assign an effect or clip to an existing motion track.

**Resize, move, or rotate a tracking clip**

1. In the Final Cut Pro timeline, select a superimposed image or clip that is tracking an object, then position the playhead so that the clip appears in the viewer.

2. If the Transform and Tracker buttons are not already shown at the top of the viewer, click the pop-up menu in the lower-left corner of the viewer and choose Transform (or press Shift-T).

3. Click Transform at the top of the viewer, then use the onscreen controls to resize, move, or rotate the superimposed image.

   See *Resize, move, and rotate clips*. 
4. To adjust how tracking data is applied to the tracking clip, click the down arrow to the right of the Tracker button at the top of the viewer, then select or deselect any of the following checkboxes:

- **Position**: Apply tracking data to horizontal (x-axis) and vertical (y-axis) movement.
- **Rotation**: Apply tracking data to rotation around the clip's anchor point.
- **Scale**: Choose how the clip is scaled in relation to the tracker area:
  - **Scale All (Fit)**: Scales the clip proportionally so that the clip's longest dimension fits within the tracker area.
  - **Scale All (Fill)**: Scales the clip proportionally so that the clip's shortest dimension fills the tracker area.
  - **Scale X & Y**: Allows you to adjust the clip's horizontal and vertical dimensions independently (disproportionally).

*Note:* The Scale option is selected automatically (for a tracking image or clip) when you choose Pin to Tracker from the Behavior pop-up menu.

You can keyframe any transform effects independently of the tracking keyframes, which creates additional animation on top of the object tracking transforms. See Animate built-in effects.

### Offset the position of a tracking effect in Final Cut Pro for Mac

By default, when you track an effect to a moving object, the effect's shape mask is pinned to the tracker, so that the shape mask affects the exact area defined by the tracker. However, if the area you want the shape mask to affect is different from the area defined by the tracker, you can unpin, or offset, the effect shape from the tracker target area. This allows you to adjust the shape or position of the effect independently of the tracked object.

*Note:* By default, when you track an image or other clip to a moving object, the clip is already unpinned and positionally offset. See Track an image or other clip to a moving object.

1. In Final Cut Pro, select the clip in the timeline, then position the playhead so that the clip appears in the viewer.
2. Open the Video inspector.
3. In the Effects section of the Video inspector, select the shape mask of the effect that you're tracking to the video clip.

The onscreen tracker appears in the viewer.
4. At the top of the viewer, click the down arrow to the right of the Tracker button, then click the Behavior pop-up menu and choose Offset from Tracker.

![Image showing the Behavior pop-up menu with Offset from Tracker selected.]

The effect’s shape mask is unpinned from the motion-tracked object. In the example below, the blur effect’s shape mask is unpinned from the tracker.

![Image showing the effect’s shape mask unpinned from the tracker.]

You can now reposition or resize the effect independently of the tracker. You can also keyframe any transform effects independently of the tracking keyframes. See Animate built-in effects.
Adjust object tracking in Final Cut Pro for Mac

When you track effects or clips (such as images or titles) to moving objects in video clips, Final Cut Pro analyzes the motion of the objects in the video clips and generates object tracking data in the form of keyframes. See How does object tracking work?.

You can edit tracking keyframes for one or more motion tracks on a video clip. You can also rename, reset, delete, and duplicate motion tracks.

**Edit tracking keyframes in the timeline**

You can use the Tracking Editor in the timeline to add or remove keyframes in a motion track.

1. Do one of the following:
   - Track an effect to a moving object.
   - Track an image or other clip to a moving object.
   - Create a motion track manually.

2. If the Tracking Editor isn’t already shown, select the clip in the timeline and do one of the following:
   - Choose Clip > Show Tracking Editor (or press Option-Command-T).
   - Control-click the clip in the timeline and choose Show Tracking Editor.

   The Tracking Editor appears on the clip in the timeline.

3. In the Tracking Editor, select a region by doing one of the following:
   - **Select a region of tracking keyframes:** Click once on a light blue region.
   - **Select an empty region:** Click once on a region with no tracking keyframes.
   - **Select a range:** Drag to select the range.
   - **Select a single frame:** Double-click the frame.
4. Do one of the following:
   
   • *Generate new tracking keyframes:* Click Analyze.
   
   • *Remove keyframes:* Click Delete. This resets the motion track but doesn’t delete it.

   ![Image of Analyze and Delete buttons]

   If a clip has multiple trackers, you can choose the tracker to display in the Tracking Editor. Click the down arrow to the right of the track name, then choose a tracker from the pop-up menu.

   ![Image of tracker selection]

   You can also edit tracking keyframes in the Video inspector, which is similar to editing video effect keyframes. See *Edit tracking keyframes in the Video inspector*, below.

   When filling a gap between existing tracking keyframes, Final Cut Pro interpolates the difference between them (as it does with video animation keyframes).
Edit tracking keyframes in the Video inspector

You can edit tracking keyframes in the Video inspector, which is similar to editing video effect keyframes or editing audio effect keyframes.

1. In Final Cut Pro, track an effect or an image (or other clip) to a moving object in a video clip.
   
   See Track an effect to a moving object or Track an image or other clip to a moving object.

2. Select the clip in the timeline, then position the playhead on the clip so that the frame you want to change appears in the viewer.

3. Click Analyze to generate tracking keyframes.
   
   See Edit tracking keyframes in the timeline, above.

4. Open the Video inspector, then scroll to the tracker you want to change in the Trackers section.

5. Click the tracker name to select the tracker.

6. Do any of the following:

   • Show onscreen controls in the viewer: Click the Onscreen Controls button.

   ![Show onscreen controls](image)

   • Navigate between keyframes: Click the left arrow to move the playhead to the previous keyframe. Click the right arrow to move the playhead to the next keyframe.

   ![Navigate between keyframes](image)
• Add or remove keyframes: Click the Keyframe button.

Important: Before adding any keyframes in this way, make sure the Behavior pop-up menu in the Tracker controls is set to Pin to Tracker, so that keyframes are added to both the motion track and the item (effect shape mask, image, or other clip) tracking the object in the clip. See Offset the position of a tracking effect.

Note: When you make a change using the onscreen controls, Final Cut Pro adds a keyframe automatically.

You can also click the down arrow on the right end of the tracker and choose one of the following from the Keyframes section of the pop-up menu:

- Add: Adds a keyframe at the playhead location.
- Delete: Deletes the keyframe at the playhead location.
- Previous: Moves the playhead to the previous keyframe.
- Next: Moves the playhead to the next keyframe.

Add, rename, reset, delete, or duplicate motion tracks
1. Select the clip in the Final Cut Pro timeline.
2. Open the Video inspector, then scroll to the tracker you want to change in the Trackers section.
3. Do any of the following:
   - Add a tracker: Click the New Tracker button (+) at the top of the Trackers section.
   - Rename a tracker: Double-click the name and enter a new name.
   - Reset, delete, or duplicate a tracker: Click the down arrow on the right end of the tracker and choose one of the following:
     - Reset Tracker: Removes all keyframes from the tracker. You can also remove keyframes using the Tracking Editor. See Edit tracking keyframes in the timeline, above.
     - Delete Tracker: Deletes the tracker.
     - Duplicate Tracker: Makes a copy of the tracker and appends the word “Copy” to the name of the copy.
Change the tracking analysis method in Final Cut Pro for Mac

Final Cut Pro uses two analysis methods (algorithms) to do the calculations for object tracking. You can choose one method or use a combination of both. For more information, see How does object tracking work?

Important: When you change the analysis method for a motion track, the new method doesn’t take effect until you delete the existing keyframes for the motion track and reanalyze the clip.

1. In the Final Cut Pro timeline, select the clip whose tracking analysis method you want to change.
2. Open the Video inspector, then scroll to the tracker you want to change in the Trackers section.
3. In the inspector, click the Analysis Method pop-up menu for the tracker you want to change, then choose one of the following:
   - **Automatic:** Final Cut Pro chooses the most suitable analysis method.
   - **Combined:** Final Cut Pro uses a combination of the Machine Learning and Point Cloud methods.
   - **Machine Learning:** Choose this option for tracking common objects (such as animals, cars, faces, trees, household objects, and so on). This algorithm excels at recognizing common objects because it is trained on many and varied examples of these objects in advance. The Machine Learning method can also overcome moderate occlusion, in which the tracked object passes behind another object. For example, if a tracked object passes behind a tree for a few frames, the Machine Learning method can continue tracking the object on the other side of the tree.
     
     Note: Because Final Cut Pro uses an enhanced machine-learning model on Mac computers with Apple silicon, tracking results may differ between Mac computers with Apple silicon and Intel-based Mac computers.
   - **Point Cloud:** Choose this option when you need precise tracking of a specific set of pixels that you define using the tracker’s onscreen controls in the viewer. Point Cloud is good for tracking regions that are rigid and somewhat flat (from the camera’s point of view). If you’re using the Machine Learning method and see jitter on the motion track (the bounding rectangles around recognized objects jump from one size to another), try switching to the Point Cloud method. Its bounding rectangles are much less susceptible to quick changes.
4. In the Video inspector, click the down arrow next to the tracker and choose Reset Tracker from the pop-up menu.
   
   The existing keyframes for the motion track are removed. For more information, see Adjust object tracking.
5. With the clip selected in the timeline, do one of the following to reanalyze the clip:
   - Click Analyze in the upper-left corner of the viewer.
   - Click the Tracking Editor in the timeline, then click Analyze.
     
     If the Tracking Editor isn’t shown, choose Clip > Show Tracking Editor (or press Option-Command-T).

Final Cut Pro performs the analysis using the method you chose, and renders the new tracking keyframes for the track.
Create motion tracks manually in Final Cut Pro for Mac

In Final Cut Pro, you can manually create motion tracks and assign effects or clips to existing motion tracks.

In certain workflows, you may have to create a motion track independently of the asset (the effect or clip) that you want to assign to it. For example, you could create a motion track while waiting for the final asset to be created, or revise a tracking image (such as a logo) and then assign it to the existing motion track.

Create a motion track independent of any effect or clip

You can create motion track without having to drag an effect or a clip (such as a title, logo, generator, or still image) to the viewer.

1. In Final Cut Pro, select a clip in the timeline.
2. Position the playhead so that the clip appears in the viewer.
3. Do one of the following:
   - Open the Video inspector, scroll to the Trackers section, then click the New Tracker button (+) at the top of the Trackers section.
   - If the selected clip has an existing motion track, click the down arrow to the right of the Tracker button at the top of the viewer, then click Create New Tracker.

   The new tracker appears in the Trackers section of the inspector, and an onscreen tracker appears in the viewer.
4. Position the tracker over the object that you want to track.
   - If necessary, you can use the onscreen controls to better fit the tracker to the object.
   - Tip: To use machine learning to recognize objects or regions of potential interest for tracking, press the Option key while dragging the tracker in the viewer. As you drag, the tracker snaps to suggested images, objects, and faces in the video.
5. Click Analyze.

   Final Cut Pro analyzes motion in the clip and generates keyframes for the new motion track.

   You can connect this motion track with any effect shape mask or image (or other clip) on the same clip. See Assign an effect or clip to an existing motion track, below.
Assign an effect or clip to an existing motion track

After Final Cut Pro has analyzed a video clip and generated object tracking data for it, it's easy to reuse the tracking data with other effects or clips (such as images, titles, generators, or video clips).

You can connect any effect shape mask or clip to an existing motion track on the same clip (or on a connected clip at the same playhead location).

1. In the Final Cut Pro timeline, select a clip that has been analyzed for object tracking and has existing tracking keyframes.
2. Position the playhead so that the clip appears in the viewer.
3. Do one of the following:
   - Assign an effect shape mask: Open the Video inspector and select the shape mask in the Effects section.
   - Assign an image (or other clip): Track an image or other clip to a moving object.
   - Assign a connected clip: Select any connected clip at the same playhead location as the clip you selected in step 1, then click the pop-up menu in the lower-left corner of the viewer and choose Transform (or press Shift-T). For more information, see Resize, move, and rotate clips.

An onscreen tracker appears in the viewer.

4. At the top of the viewer, click the down arrow to the right of the Tracker button and choose a previously created motion track from the Tracker pop-up menu.

The effect shape mask or clip is assigned to the motion track you chose. You can adjust the shape or position of the item without affecting the tracking data. See Offset the position of a tracking effect.

Note: If there are multiple (connected) clips at the same playhead location, an additional pop-up menu (Tracker Source) appears in the Tracker controls. In the Tracker Source pop-up menu, choose the clip that contains the motion track you want to use.
Color correction

Intro to color correction in Final Cut Pro for Mac

In any post-production workflow, color correction is generally one of the last steps in finishing an edited program. There are a number of reasons to color correct your footage:

• Balance all the shots in a scene to match.
• Correct errors in color balance, exposure, and white-balance.
• Make sure that key elements in your program, such as skin tones, look the way they should.
• Achieve a look, such as making the scenes warmer or cooler.
• Create contrast or special effects by manipulating the colors and exposure.

Final Cut Pro color correction tools give you precise control over the look of every clip in your project, including still images, by letting you adjust each clip's color balance, shadow levels, midtone levels, highlight levels, and more.
In Final Cut Pro, you can:

- **Automatically balance colors:** With one click, neutralize any color casts and maximize image contrast. See [Intro to balancing color](#).
- **Automatically match a clip's color and look:** With two clicks, make one or more clips match the color look of any clip that you choose. See [Match color between clips](#).
- **Automatically white-balance a clip:** Use an eyedropper to define a white or neutral gray highlight in a clip and instantly remove an unwanted color cast. See [Manually white-balance clips](#).
- **Manually adjust color, saturation, and exposure:** Manually correct a clip's overall color. You can even add multiple manual color corrections to one clip. See [Intro to color correction effects](#).
- **Target specific colors or areas:** Use color or shape masks to limit a correction to a particular color range or area in the image. See [Add a color mask](#) and [Add a shape mask](#).
- **Save color correction settings and apply them to other clips:** Save a clip’s color correction settings and apply them to other clips in the project or in other projects. See [Save color correction presets](#).

Although these methods are independent of one another—you can turn any of the corrections off and on to see their effect—the order in which you use them matters. In general, you should use these tools in the order of **Balance Color** (including white-balance corrections), **Match Color**, and (if necessary) **manual color correction**.

Final Cut Pro also includes several **video scopes** you can use when manually color correcting your video. The scopes make it possible to precisely monitor the luma and chroma levels of your video clips.

### Quickly balance and match color

#### Intro to balancing color in Final Cut Pro for Mac

Final Cut Pro includes several handy color-balancing features that you can use to quickly and easily improve the look of your video clips.

#### Automatic color balance

When you balance color automatically, Final Cut Pro samples the darkest and lightest areas of the image's luma channel and adjusts the shadows and highlights in the image to neutralize any color casts. In addition, Final Cut Pro adjusts the image to maximize contrast, so that the shot occupies the widest available luma range.

The video frame used as the reference frame depends on the position of the playhead and whether the clip has been analyzed for color balance. See [Balance a clip's colors](#) and [Analyze a clip for color](#).
Manual white balance
You can set the color balance of a clip by sampling a part of the image that should be pure white. See Manually white-balance clips.

Match color
You can ensure that multiple clips have the same look. See Match color between clips.

Analyze a clip for color in Final Cut Pro for Mac
To automatically balance a clip's color, Final Cut Pro uses a single frame from the clip as a reference and calculates a correction for it that is then applied to the entire clip. Analyzing a clip for color balance allows Final Cut Pro to choose a representative frame as the clip's color balance reference frame. (You can also choose a reference frame manually by positioning the playhead or the skimmer within the clip and then balancing the clip's color.)

You can have a clip's color balance analyzed when you import it, whether importing from a camera, importing a file, or dragging a clip directly to the timeline from a Finder window. You can also analyze a clip's color balance at any time in the browser.

Analyzing a clip for color balance can take from a few seconds for shorter clips to a minute or more for longer clips. The analysis process takes longer if you also analyze for people and stabilization issues.

For information about turning the color balance correction on and off, in either the browser or the timeline, see Balance a clip's colors.

Analyze color balance during file import
1. In Final Cut Pro, choose File > Import > Media (or press Command-I).
2. In the Media Import window, select the files to import, then select “Analyze video for balance color” in the Analyze and Fix section on the right.
3. Click the Import button.

The files are imported and analyzed for color balance issues.
Analyze color balance for clips dragged to the timeline from the Finder

1. Choose Final Cut Pro > Settings, or press Command-Comma (,).
2. In the Final Cut Pro Settings window, click the Import button and select “Analyze video for balance color” in the Analyze and Fix section.

All clips that you drag directly to the timeline from the Finder are now analyzed.

Note: When you change this setting in the Settings window, the setting is also changed in all other windows that have an “Analyze video for balance color” option.

Analyze color balance for clips in the browser

When you analyze the color balance of clips in the browser, any clips that were analyzed during import are skipped.

1. Select one or more clips in the Final Cut Pro browser.
2. Do one of the following:
   - Choose Modify > Analyze and Fix.
   - Control-click one of the selected clips and choose Analyze and Fix.
3. In the window that appears, select “Analyze for balance color” in the Video section, then click OK.

Balance a clip’s colors in Final Cut Pro for Mac

Clips in Final Cut Pro have a Balance Color setting that turns automatic color balance correction on and off, whether the clip is in the browser or the timeline. The frame used as the reference frame is either a frame chosen during color balance analysis, the frame the playhead is on in the timeline, or the middle frame.

• If the clip has been color-analyzed, either during import or while in the browser: The analysis process extracts color balance information for the entire clip. Whether you add a portion of the clip or the entire clip to a project, the color-balancing feature chooses the frame within the project clip that is closest to being correctly balanced. This means that if you add multiple partial clips from the same browser clip to the project, each clip is balanced based on analysis information for its own section of media.

• If the clip has not been color-analyzed and you balance its color: You can determine the reference frame for a clip selected in the timeline by moving the playhead to that frame in the clip. If the playhead is on a different clip or you’ve selected a clip in the browser, the clip’s middle frame is used.

For more information about color analysis, see Analyze a clip for color.
**Turn a clip’s color balance correction on or off**

1. Select one or more clips in the Final Cut Pro timeline or browser.

   If you want to select the frame in the clip used as the color balance reference frame, position the playhead or skimmer on that frame.

2. Do one of the following:

   - Choose Modify > Balance Color (or press Option-Command-B).
   - Click the Enhancements pop-up menu below the viewer and choose Balance Color.
   - After you've applied a color balance correction (using one of the methods above), select or deselect the Balance Color checkbox in the Effects section of the Video inspector.

**Manually white-balance clips in Final Cut Pro for Mac**

*White-balancing* an image removes color casts and ensures that white objects in the image appear white. Whether or not the camera operator remembered to set the white balance in the camera, it’s easy to quickly correct the white balance of your video footage in Final Cut Pro.

1. Select a clip in the Final Cut Pro timeline or browser.

2. Position the playhead over the clip so that the clip’s video is displayed in the viewer.

3. To turn on the Balance Color correction, do one of the following:

   - Choose Modify > Balance Color (or press Option-Command-B).
   - Click the Enhancements pop-up menu below the viewer and choose Balance Color.

   *Note: When Balance Color is on, there's a checkmark next to the menu item.*

   The automatic color balance correction is applied to the clip.
4. If the Video inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

5. Click the pop-up menu in the Balance Color section of the Video inspector and choose White Balance.

   Choose White Balance from the pop-up menu.

   The pointer changes to an eyedropper.

6. In the viewer, click or drag over an area that should be pure white.

   White Balance eyedropper

   The entire clip's color is adjusted to turn the pixels you selected into white.

   ⚠ Tip: When using the eyedropper, don’t sample an area that's overexposed, such as a light source or a shiny highlight. Instead, select a properly exposed area of your picture that’s white, such as a well-lit white shirtsleeve or white wall.

After you apply a manual white-balance correction, you can copy the correction to other clips in your program to ensure that related clips have a consistent look. (In contrast, the more automated Balance Color correction creates a unique color correction for each clip it's applied to.) You can copy the white-balance correction to multiple clips at once using the Paste Attributes command. See Copy effects between clips.
Match color between clips in Final Cut Pro for Mac

Your project likely uses video from a wide variety of sources. The Match Color feature makes it easy to ensure that all scenes that take place in the same location have the same look.

**Match color between clips**

1. In the Final Cut Pro timeline, select one or more clips that you want to adjust.
2. Do one of the following:
   - Choose Modify > Match Color (or press Option-Command-M).
   - Click the Enhancements pop-up menu below the viewer and choose Match Color.

   The viewer changes to display the frame under the timeline playhead on the right and the frame the pointer is over on the left.

3. Skim any clip in the timeline or the browser to find a frame with the color look you want to match, then click to preview that look applied to the selected clip.

   You can click a variety of clips until you find the look you want.

   🔄 **Tip:** You may want to import a still image that has the look you want, even if it’s not related to your project, so that you can match its color.

4. To accept the current look, click Apply Match.

   The viewer returns to its normal configuration, and the selected timeline clips change to the new look.
Turn Match Color corrections on or off
You can turn off the Match Color corrections that have been applied to a clip. This is useful for viewing the difference between the original clip and the corrected clip.
1. In the Final Cut Pro timeline, select a clip with Match Color corrections applied.
2. Click the Match Color checkbox in the Effects section of the Video inspector.

Make advanced color corrections with color correction effects

Intro to color correction effects in Final Cut Pro for Mac
Final Cut Pro includes powerful manual color correction tools that you can use to accomplish a wide variety of color correction and enhancement effects. You use the tools by applying a color correction effect and then adjusting the effect’s controls in the Color inspector.

You can make manual color adjustments to the color tint, saturation, and exposure for the whole clip image using any of the following color correction effects.

Color Board effect
The unique Color Board provides controls for saturation, exposure, and color adjustments.
See Use the Color Board effect.
**Color Wheels effect**

The Color Wheels effect provides four color wheels (Global, Shadows, Midtones, and Highlights) you can use to adjust color in your video clips. You can also adjust a clip’s brightness and saturation levels using sliders on the sides of the color wheels.

See [Use the Color Wheels effect](#).

**Color Curves effect**

The Color Curves effect lets you use color curves to adjust the components of individual color channels in an image, as well as the luma channel.

See [Use the Color Curves effect](#).
Hue/Saturation Curves effect

The Hue/Saturation Curves effect provides six hue and saturation curves you can use to color correct your clips.

See Use the Hue/Saturation Curves effect.

Color Adjustments effect

The Color Adjustments effect provides controls for adjusting exposure, contrast, brightness, saturation, highlights, shadows, warmth, and tint. The Color Adjustments effect is particularly useful for adjusting HDR clips, but you can use it to adjust SDR clips as well.

See Use the Color Adjustments effect.
Manual color correction workflow in Final Cut Pro for Mac

The traditional process for color correcting a project is outlined below, in rough chronological order.

---

Step 1: Color correction starts during your shoot

The process of determining the overall look of your video begins when your scenes are lit and shot during production. To have the maximum amount of control over your clips in post-production, you need to start out with footage that has been exposed with your end goals in mind right from the beginning. Color correction in post-production is no substitute for good lighting.

Tip: In many productions, a color chip chart is placed next to the slate at the beginning of every shot. This chart can be used during post-production to provide a good neutral starting point for color correction. For example, you can use the white chip in the chart to quickly white-balance your clips. This technique is especially valuable for matching color in multicamera shoots.

Step 2: Pick a reference shot from a scene to use as the basis for color correction

If you’re color correcting a scene consisting of a single shot, your job is pretty easy. All you need to do is find the settings that work best for that one shot. Most scenes, however, cut between a variety of different shots, such as close-ups, medium shots, and wide shots. In every scene, there is usually a single wide shot that encompasses the entire scene. You can use that shot as a reference shot, and then make the colors of the other shots match those of the reference shot.
Step 3: Add a color correction effect and perform primary color correction

To make any manual color correction adjustments to a clip, you must first add one of the color correction effects available in Final Cut Pro (Color Board, Color Wheels, Color Curves, Hue/Saturation Curves, or Color Adjustments). See Add color correction effects.

Primary color correction refers to two basic steps that you take using one of the color correction effects:

- **Adjust the blacks and whites to maximize the contrast of your clip**: Essentially, you're mapping the blackest black in your clip to a value of 0 and the whitest white to a value of 100. By doing this first, you widen the range that an underexposed image covers, or bring down overly bright (or super-white) areas of overexposed video into the range considered to be broadcast-safe.

- **Adjust the balance of reds, greens, and blues in your shot**: As you make these adjustments, it's helpful to view your clip on a broadcast video monitor as well as check the clip's luma and chroma levels in the video scopes to make more informed changes. See Intro to measuring video.

Step 4: Add additional color corrections as needed

It's important to remember that you don't have to do everything with a single application of a color correction effect. For example, if you can't get the colors in both the dimly lit areas and the highlights of your clip right with a single effect, focus only on the dimly lit area. You can then adjust the highlights with a second application of a color correction effect.

For each color correction effect, you can use a color mask and an unlimited number of shape masks to isolate a region of your clip, limiting the color correction effect to just that area. This way, you can target the green grass, the highlights in the trees, and the red lipstick of an actor in the scene with three separate corrections, giving you an extremely fine level of control over your image. See Add a color mask and Add a shape mask.

Step 5: Add other effects to address specific needs

After you've finished color correcting your footage, you may find yourself with some additional issues to resolve. For example, the combination of effects you're using may cause the chroma or luma to extend into levels illegal for broadcast. In this case, you can use the Broadcast Safe effect (in the Effects browser) to bring down the offending parts of Rec. 709 clips to acceptable levels.

Step 6: Match the rest of the scene to the reference shot

After you've finished defining the look of the reference shot in a scene, you can move on to the rest of the shots. It's easy to copy the settings of the color correction effects you're using to other pieces of the same reference shot. For example, if you cut back to the reference shot five times in your scene, you can simply copy the effects from the first piece of the reference shot you corrected to all other instances in your sequence. You can also combine multiple color correction effects into a single effects preset and copy it from clip to clip. See Save color correction presets.
As you work on other shots in the scene, you'll probably repeat steps 3 through 5 for each shot. You can compare each new shot with the reference shot that you corrected, switching back and forth rapidly to compare the look of one clip with that of the other. By comparing the clips' values on the video scopes, you'll see how you need to adjust the color correction effects to make the clips' color, blacks, and whites match as closely as possible.

⚠️ Tip: You can use the Command Editor to assign a keyboard shortcut to turn color corrections on and off while making adjustments, and to assign keyboard shortcuts to many other color correction functions. See Modify keyboard shortcuts.

Add color correction effects in Final Cut Pro for Mac

The first step in adjusting a clip's color manually is adding a color correction effect to the clip. You can apply multiple color corrections to a clip to target specific issues. For example, you could apply one color correction that mutes a bright orange shirt and a second one that enhances the green in the lawn.

Add a color correction

1. In Final Cut Pro, select a clip in the timeline that you want to correct.
2. Position the playhead in the timeline so that your clip appears in the viewer.
3. If the Color inspector isn’t already shown, do one of the following:
   • Choose Window > Go To > Color Inspector (or press Command-6).
   • Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.
   • Click the Color button at the top of the inspector.
   • In the Video inspector, click the Color button to the right of a color correction to open it in the Color inspector.
4. Do one of the following:
   - Click the pop-up menu at the top of the Color inspector and choose a color correction from the Add Correction section of the menu.

   ![Color inspector menu](image)

   Choose a color correction.

   - Add a color correction effect from the Color category of the Effects browser. The color correction effects are:
     - Color Board
     - Color Wheels
     - Color Curves
     - Hue/Saturation Curves
     - Color Adjustments

   🔄 Tip: If you frequently add a particular color correction effect, you can speed up your workflow by setting it as the default color correction. Then just select a timeline clip and press Command-6 to start adjusting the effect in the Color inspector.

   The color correction effect is applied to the clip and appears in the Effects section of the Video inspector.

   ![Effects inspector](image)

   To proceed with the color correction, follow the instructions for the color correction effect you added:
   - Use the Color Board effect
   - Use the Color Wheels effect
   - Use the Color Curves effect
   - Use the Hue/Saturation Curves effect
   - Use the Color Adjustments effect
Apply multiple color corrections to a clip

1. In the Final Cut Pro timeline, select a clip that has a color correction.

2. To add an additional color correction, do one of the following:
   - Choose Window > Go To > Color Inspector (or press Command-6), then click the pop-up menu at the top of the Color inspector and choose one of the color correction effects in the Add Correction section.
   - Add another color correction effect from the Color category of the Effects browser. (The choices are Color Board, Color Wheels, Color Curves, Hue/Saturation Curves, and Color Adjustments.)

The Color inspector opens, showing the controls for the additional correction.

Additional color correction effects are named incrementally (for example, Color Wheels 2, Color Wheels 3, and so on) and appear in the pop-up menu at the top of the Color inspector. You can switch to a different correction by choosing it in the pop-up menu.

The additional color correction effect also appears in the Effects section of the Video inspector, beneath the original color correction effect. You can click the Color Inspector button 🕵️‍♂️ to the right of a correction to open the Color inspector with that correction's settings.
To make the additional color correction adjustments, see the topic for the color correction effect you added:

- **Use the Color Board effect**
- **Use the Color Wheels effect**
- **Use the Color Curves effect**
- **Use the Hue/Saturation Curves effect**
- **Use the Color Adjustments effect**

If you have applied multiple corrections to a clip, you can change their order by dragging them in the Video inspector. Rearranging the processing order can provide different results. To ensure the highest-quality results, the Balance Color and Match Color effects appear at the top of the Effects list by default.

*Note:* Applying multiple color corrections to a clip has no effect on the color masks in the additional color corrections. For example, if the first color correction removes all chroma from the clip, the second color correction can still create a color mask based on the original chroma. See Add a color mask.

**Switch to a different color correction**

1. In the Final Cut Pro timeline, select a clip that has multiple color corrections.
2. Click the pop-up menu at the top of the Color inspector, then choose a different color correction.

After you apply a color correction effect, you can copy it to another clip or group of clips. See Copy effects between clips. You can also combine multiple color correction effects into a single effects preset and then copy it to other clips. See Save color correction presets.
Remove color correction effects in Final Cut Pro for Mac

You can reset color correction effects or turn them off and on to quickly see the result of your adjustments. You can also remove color correction effects from a clip.

Reset or turn off color corrections in the Video inspector
1. In the Final Cut Pro timeline, select a clip with color corrections you want to reset or turn off.
2. In the Effects section of the Video inspector, do any of the following:
   • Turn off a color correction effect without resetting it: Deselect the checkbox for the correction.
   • Reset the entire color correction effect to its neutral state: Move the pointer over the color correction effect you want to reset, then click the pop-up menu that appears on the far right and choose Reset Parameter.

Tip: You can use the Command Editor to assign a keyboard shortcut to turn color corrections on and off while making adjustments, and to assign keyboard shortcuts to many other color correction functions. In the Command Editor, search for “Toggle color correction.” See Modify keyboard shortcuts.

Reset or turn off color corrections in the Color inspector
1. In the Final Cut Pro timeline, select a clip with color corrections you want to reset or turn off.
2. If the Color inspector isn’t already shown, do one of the following:
   • Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.
   • Choose Window > Go To > Color Inspector (or press Command-6).
   • In the Video inspector, click the Color Inspector button for the color correction effect you want to reset or turn off.
3. In the Color inspector, do any of the following:

- **Turn off a color correction effect without resetting it**: Deselect the checkbox for the correction.

  Turning the corrections off and on makes it easy to quickly see the effect of your adjustments.

- **Reset the entire color correction effect to its neutral state**: Click the pop-up menu on the far-right end of the name bar and choose Reset Parameter.

- **Reset an individual pane, wheel, curve, or other section of a color correction effect**: Click the Reset button for that section or control.

**Remove a color correction**

1. In the Final Cut Pro timeline, select the clip with the color correction you want to remove.

2. Do one of the following:

   - Select the color correction effect in the Video inspector, then press Delete.
   
   - Click the pop-up menu at the top of the Color inspector and choose the color correction effect, then click the empty gray area to the right of the correction name and press Delete.

**Use the Color Board effect in Final Cut Pro for Mac**

You can adjust a clip’s tint, saturation, and exposure with great precision using the Color Board. First you add the Color Board effect to the clip, and then you adjust its settings in the Color inspector.
To provide objective, precise information as you color correct a clip, use the video scopes and other video measurement tools (see Intro to measuring video). You can also create a custom workspace layout for color correction, or switch to the predefined Color & Effects layout (see Change the workspace layout).

Note: Because you can apply multiple color correction effects to a clip, you’re not required to follow all of the steps below, nor the order of those steps. For example, you might adjust the overall contrast with the Color Curves effect and adjust a color tint with the Color Wheels effect. Or you could achieve the same results with multiple instances of the same effect. For a summary of the color correction effects, see Intro to color correction effects.

1. In the Final Cut Pro timeline, select the clip you want to correct, then position the playhead in the clip so that the clip appears in the viewer.

2. Open the Color inspector.

   Tip: If you frequently add a particular color correction effect, you can speed up your workflow by setting it as the default color correction. Then just select a timeline clip and press Command-6 to start adjusting the effect in the Color inspector.

3. Click the pop-up menu at the top of the Color inspector, then do one of the following:
   - Add a new instance of the Color Board effect: Choose Color Board from the Add Correction section at the bottom of the menu.

For more details and methods, see Add color correction effects.

   - Correct a Color Board effect already applied to the clip: Choose the Color Board effect you want to correct from the Corrections section at the top of the menu.

Color Board controls appear in the Color inspector. The effect also appears in the Effects section of the Video inspector.
4. At the top of the Color inspector, click the button for the correction you want to make:

- **Color**: Adjusts the tint.
- **Saturation**: Adjusts the chroma level.
- **Exposure**: Adjusts the luma level.

5. Drag the controls (or select a control and press an arrow key), or enter values in the value sliders.

To make fine adjustments, hold down the Option key as you drag a control.

You can adjust the whole clip image or just the shadows, midtones, or highlights. Dragging a control up adds color to the image or increases the chroma or luma level; dragging a control down removes color or reduces the chroma or luma level. In the Color pane, you can also drag the controls left or right to choose the color to add or subtract.

To reset the values for a pane, click the Reset button in the top-right corner.

⚠️ **Tip**: If you want to color correct the next or previous clip in the timeline, press Command-Right Arrow or Command-Left Arrow to move the playhead to the next or previous clip and select it. These shortcuts select clips in the same role only, so you can quickly move between video clips and skip over clips not suited for color correction (such as music or titles).

After you apply a color correction, you can copy it to another clip or group of clips. See **Copy effects between clips**.
Use the Color Wheels effect in Final Cut Pro for Mac

You can use four color wheels (Global, Shadows, Midtones, and Highlights) to adjust color in your video clips. You can also adjust a clip's brightness and saturation levels using sliders on the sides of the color wheels. First you add the Color Wheels color correction effect to the clip, and then you adjust its settings in the Color inspector.

To provide objective, precise information as you color correct a clip, use the video scopes and other video measurement tools (see Intro to measuring video). The vectorscope shows the distribution of color in your image on a circular scale and is particularly useful for working with color wheels. The angle of distribution of red, green, and blue in the color wheels corresponds to the angles of those colors in the vectorscope. When you move the color control in the center of a color wheel, the mix of colors in the vectorscope moves the same direction.

You can create a custom workspace layout for color correction or switch to the predefined Color & Effects layout (see Change the workspace layout).
Note: Because you can apply multiple color correction effects to a clip, you’re not required to follow all of the steps below, nor the order of those steps. For example, you might adjust the overall contrast with the Color Curves effect and adjust a color tint with the Color Wheels effect. Or you could achieve the same results with multiple instances of the same effect. For a summary of the color correction effects, see Intro to color correction effects.

1. In the Final Cut Pro timeline, select the clip you want to correct, then position the playhead in the clip so that the clip appears in the viewer.

2. Open the Color inspector.
   
   Tip: If you frequently add a particular color correction effect, you can speed up your workflow by setting it as the default color correction. Then just select a timeline clip and press Command-6 to start adjusting the effect in the Color inspector.

3. Click the pop-up menu at the top of the Color inspector, then do one of the following:
   
   • Add a new instance of the Color Wheels effect: Choose Color Wheels from the Add Correction section at the bottom of the menu.

   ![Choose Color Wheels.](image)

   For more details and methods, see Add color correction effects.

   • Correct a Color Wheels effect already applied to the clip: Choose the Color Wheels effect you want to correct from the Corrections section at the top of the menu.

   Color Wheels controls appear in the Color inspector. The effect also appears in the Effects section of the Video inspector.

   ![Choose Color Wheels.](image)

   Tip: To switch the inspector between full-height view and half-height view, double-click the top bar of the inspector.

4. Click the View pop-up menu at the top of the Color inspector and choose a display option:

   • All Wheels: Displays all four color wheels at once.
     The Global color wheel adjusts the whole clip image; the other color wheels adjust only the shadows, midtones, or highlights.

   • Single Wheels: Displays one large color wheel at a time. Click a button at the top of the Color inspector to select the wheel to display.
5. To change a clip's brightness, color, or saturation, adjust the controls for a color wheel, or enter values in the value sliders below.

- **Adjust the brightness:** Drag the Brightness slider on the right side of a wheel.
- **Adjust the color value:** Drag the color control in the center of a wheel.
  
  You can also move the color control up, down, left, or right by pressing the Up Arrow, Down Arrow, Left Arrow, or Right Arrow key.
- **Adjust the saturation:** Drag the Saturation slider on the left side of a wheel.
  
  To make fine adjustments, hold down the Option key as you drag a control.

![Image of color wheel controls](image)

6. Use the controls at the bottom of the Color inspector to adjust any of the following:

- **Temperature:** Adjust the color temperature, in degrees kelvin, so that the image looks as natural as possible. *Color temperature* describes the color value of light when the image was shot (not the light’s heat value). Drag the slider to the left to increase blue tones, or to the right to increase yellow-red tones. For example, if the image was shot under tungsten conditions, set the value between 2500 and 2900 degrees kelvin to white-balance it.

- **Tint:** Fine-tune the white-balance adjustment by neutralizing a remaining green or magenta tint. Drag the Tint slider to the left to add a green tint to the image, or to the right to add a magenta tint.

- **Hue:** Use the Hue control or value slider to set a value from 0° to 360°, effectively rotating all hues in the image around the perimeter of the color wheel. A value of 0° represents the original image.

- **Mix:** Set the amount of the original image to be blended with the color-corrected image.

  To reset the values for a color wheel or a value slider, click its Reset button.

⚠️ **Tip:** If you want to color correct the next or previous clip in the timeline, press Command-Right Arrow or Command-Left Arrow to move the playhead to the next or previous clip and select it. These shortcuts select clips in the same role only, so you can quickly move between video clips and skip over clips not suited for color correction (such as music or titles).

After you apply a color correction, you can copy it to another clip or group of clips. See [Copy effects between clips](#).
Use the Color Curves effect in Final Cut Pro for Mac

You can use color curves to adjust the components of individual color channels in a clip image. You can adjust the overall luma as well as the red, green, and blue color channels. A feature unique to Final Cut Pro is that you can adjust any custom color you specify—for example, you can select any mixture of chroma and then adjust its intensity.

First you add the Color Curves color correction effect to the clip, and then you adjust its settings in the Color inspector.
A color curve is like an interactive histogram that is tilted at a 45-degree angle. The different tonal ranges of the image (the shadows, midtones, and highlights) are distributed along the curve. You can click the curve to create control points, then drag the control points up or down to increase or decrease the intensity of the color for a given tonal range.

To provide objective, precise information as you color correct a clip, use the video scopes and other video measurement tools (see Intro to measuring video).

You can create a custom workspace layout for color correction or switch to the predefined Color & Effects layout (see Change the workspace layout).

**Note:** Because you can apply multiple color correction effects to a clip, you’re not required to follow all of the steps below, nor the order of those steps. For example, you might adjust the overall contrast with the Color Curves effect and adjust a color tint with the Color Wheels effect. Or you could achieve the same results with multiple instances of the same effect. For a summary of the color correction effects, see Intro to color correction effects.

**Use the color curves to adjust the intensity of a color channel**

1. In the Final Cut Pro timeline, select the clip you want to correct, then position the playhead in the clip so that the clip appears in the viewer.

2. Open the Color inspector.

   🌟 **Tip:** If you frequently add a particular color correction effect, you can speed up your workflow by setting it as the default color correction. Then just select a timeline clip and press Command-6 to start adjusting the effect in the Color inspector.

3. Click the pop-up menu at the top of the Color inspector, then do one of the following:
   - **Add a new instance of the Color Curves effect:** Choose Color Curves from the Add Correction section at the bottom of the menu.

   Choose Color Curves.

   For more details and methods, see Add color correction effects.

   - **Correct a Color Curves effect already applied to the clip:** Choose the Color Curves effect you want to correct from the Corrections section at the top of the menu.
Color Curves controls appear in the Color inspector. The effect also appears in the Effects section of the Video inspector.

Tip: To switch the inspector between full-height view and half-height view, double-click the top bar of the inspector.

4. Click the View pop-up menu at the top of the Color inspector and choose a display option:
   - **All Curves**: Displays all four color curves at once.
     - The default color curves are Luma, Red, Green, and Blue.
   - **Single Curves**: Displays one large color curve at a time. Click a button at the top of the Color inspector to select the curve to display.

5. To set the black and white points, drag the control points on the ends of the Luma curve.

It’s a good idea to use the **waveform monitor** as you do this, to make sure you don't clip the highlights or crush the blacks more than you want to, and to make sure the image remains broadcast-safe. To show the waveform monitor, see **Display video scopes**.
6. To adjust a color channel, click a curve to set a control point, then drag it up to increase the intensity of the color or down to decrease the intensity.

To constrain the control point to vertical or horizontal movement, hold down the Shift key as you drag. To make fine adjustments, hold down the Option key as you drag.

Adjusting the image with a single control point affects most of the midtones as well as some shadows and highlights.

To select a custom color to adjust, click the eyedropper at the top of one of the color curves, then click or drag over a color in the viewer. You can also click the name of a color curve (at the top left of the curve), then click or drag in the color wheel.

Tip: To remove a color cast from a clip with manual control and precision, click the eyedropper at the top of one of the color curves, then, in the viewer, click or drag over an area of the image that's supposed to be white, such as a white sheet of paper. A vertical gray line appears on the color curve. Click to add a control point where the gray line intersects the curve, then drag the control point down until the selected color turns white. Use the waveform monitor in RGB Parade view to verify the change.
7. To narrow the tonal range for your adjustments, add more control points.

The default diagonal line for each curve indicates the original state of the image. Wherever the curve diverges from the diagonal line, the image is altered. Wherever the curve touches the diagonal line, the values of the image at that tonality are the same as in the original image. For example, to prevent any change to the shadows, you could add a control point to pin the curve to the diagonal line in the shadows area.

8. Add and move control points as needed.

To delete a control point, select it and press Delete.

9. At the bottom of the Color inspector, adjust any of the following:
   - **Preserve Luma**: Select this checkbox to maintain the overall brightness of a clip despite changes in one or more color channels.
   - **Mix**: Set the amount of the original image to be blended with the color-corrected image.

**Tip:** If you want to color correct the next or previous clip in the timeline, press Command-Right Arrow or Command-Left Arrow to move the playhead to the next or previous clip and select it. These shortcuts select clips in the same role only, so you can quickly move between video clips and skip over clips not suited for color correction (such as music or titles).

After you apply a color correction, you can copy it to another clip or group of clips. See Copy effects between clips.
Use the Hue/Saturation Curves effect in Final Cut Pro for Mac

The six hue and saturation curves provide precise control for color correcting your projects. You can adjust the hue, saturation, and brightness of any color in your project. Additionally, you can adjust the saturation for a range of brightness or a range of saturation in a clip. You can also adjust the saturation of a specific color at any point in its range of brightness.

First you add the Hue/Saturation Curves color correction effect to the clip, and then you adjust its settings in the Color inspector.

To provide objective, precise information as you color correct a clip, use the video scopes and other video measurement tools (see Intro to measuring video).

You can create a custom workspace layout for color correction or switch to the predefined Color & Effects layout (see Change the workspace layout).
Note: Because you can apply multiple color correction effects to a clip, you’re not required to follow all of the steps below, nor the order of those steps. For example, you might adjust the overall contrast with the Color Curves effect and adjust a color tint with the Color Wheels effect. Or you could achieve the same results with multiple instances of the same effect. For a summary of the color correction effects, see Intro to color correction effects.

Add and set up a Hue/Saturation Curves color correction

1. In the Final Cut Pro timeline, select the clip you want to correct, then position the playhead in the clip so that the clip appears in the viewer.

2. Open the Color inspector.
   
   Tip: If you frequently add a particular color correction effect, you can speed up your workflow by setting it as the default color correction. Then just select a timeline clip and press Command-6 to start adjusting the effect in the Color inspector.

3. Click the pop-up menu at the top of the Color inspector, then do one of the following:
   
   • Add a new instance of the Hue/Saturation Curves effect: Choose Hue/Saturation Curves from the Add Correction section at the bottom of the menu.

   ![Choose Hue/Saturation Curves.]

   For more details and methods, see Add color correction effects.

   • Correct a Hue/Saturation Curves effect already applied to the clip: Choose the Hue/Saturation Curves effect you want to correct from the Corrections section at the top of the menu.

   Hue/Saturation Curves controls appear in the Color inspector. The effect also appears in the Effects section of the Video inspector.

   ![Hue/Saturation Curves 1]

   Tip: To switch the inspector between full-height view and half-height view, double-click the top bar of the inspector.

4. Click the View pop-up menu at the top of the Color inspector and choose a display option:

   • 6 Curves: Displays all six curves at once.

   • Single Curves: Displays one large curve at a time. In Single Curves view, click a button at the top of the Color inspector to display a specific curve.

   To color correct the clip, follow the instructions below for the adjustment you want to make.
Adjust the hue, saturation, or brightness of a color

1. Follow the instructions in Add and set up a Hue/Saturation Curves color correction, above.

2. In the Color inspector, click the eyedropper for the curve that you want to use.
   - Hue vs Hue: Change a color (hue) in the image.
   - Hue vs Sat: Change the saturation of a color in the image.
   - Hue vs Luma: Adjust the brightness of a color in the image.

3. In the viewer, click or drag over the color in your clip that you want to adjust.

   Three control points appear on the curve in the Color inspector. The middle control point represents the color you selected with the eyedropper. The two outer control points constrain the selection to a narrow range of hues.

   The examples below show the Hue/Saturation Curves effect in Single Curves view. In this view, click a button at the top of the Color inspector to display a specific curve. For example, click HvH to display the Hue vs Hue curve.

   \[\text{Click the eyedropper for the curve.}\]
   \[\text{Click or drag over a color in the viewer.}\]
   \[\text{Control points appear on the curve.}\]

   \[\text{Note: You can also create control points by clicking the curve, but the eyedropper method is generally more precise.}\]
4. Drag the middle control point to adjust any of the following (depending on which curve you’re using in the Color inspector):

- **Hue vs Hue**: Change the hue in the selection. Drag the control point up or down to rotate through the various hues around the perimeter of the color wheel.

  *Note:* If you use the Hue vs Hue curve to change the hue and then use the eyedropper in any other curve in the same instance of the Hue/Saturation Curves color correction effect, the eyedropper selects the original hue—not the altered hue. To select the original hue, adjust the control points without using the eyedropper, or add a second instance of the Hue/Saturation Curves color correction effect.

- **Hue vs Sat**: Adjust the saturation of the selected color. Drag the middle control point up to increase the saturation, or down to decrease the saturation. Add or adjust control points as needed.

  In the example below, the HvS button was clicked in the Single Curves view, and the eyedropper was used to select the hue of the wall in the image.
• **Hue vs Luma:** Adjust the brightness of the selected color. Drag the middle control point up to increase the brightness, or down to decrease the brightness. Add or adjust control points as needed.

To make fine adjustments, hold down the Option key as you drag a control. Hold down the Shift key as you drag to constrain the control point to vertical or horizontal movement only.

In the example below, the HvL button was clicked in the Single Curves view, and the eyedropper was used to select the hue of the wall in the image.

5. To adjust the selected range, drag the two outer control points to the left or the right, or just delete them.

**Adjust the saturation for a range of brightness**

You can use the Luma vs Sat curve to create special looks and to make a clip broadcast-safe by reducing oversaturation.

1. Follow the instructions in *Add and set up a Hue/Saturation Curves color correction*, above.

2. In the Color inspector, click the eyedropper for the Luma vs Sat curve.

   If all six curves are shown in the inspector, you may need to scroll to see the Luma vs Sat curve. In Single Curves view, click the LvS button at the top to display the curve.

3. In the viewer, click or drag over the color in your clip whose saturation you want to adjust.
Three control points appear on the curve in the Color inspector. The middle control point represents the level of luma (brightness) you selected with the eyedropper. The two outer control points constrain the selection to a narrow range of brightness.

Note: You can also create control points by clicking the curve, but the eyedropper method is generally more precise.

4. Drag the middle control point up to increase the saturation, or down to decrease the saturation.

To make fine adjustments, hold down the Option key as you drag a control. Hold down the Shift key as you drag to constrain the control point to vertical or horizontal movement only.

5. To adjust the range of luma selected, drag the two outer control points to the left or the right, or just delete them.

6. To adjust the saturation for a different range of brightness, click the curve to add control points, and adjust them as needed.

Use the left end of the curve to adjust shadows, the middle section to adjust midtones, and the right end of the curve to adjust highlights. Drag up to increase saturation, or down to decrease saturation.
Adjust the saturation within a range of saturation

The Sat vs Sat curve allows you to create special looks by selecting and adjusting a range of saturation within the video clip’s original saturation. You can increase the saturation of areas with low saturation, or you can desaturate oversaturated areas to make them safe for broadcast. In the example below, the saturation is increased in a region of low saturation in the original image.

1. Follow the instructions in Add and set up a Hue/Saturation Curves color correction, above.
2. In the Color inspector, click the eyedropper for the Sat vs Sat curve.
   If all six curves are shown in the inspector, you may need to scroll to see the Sat vs Sat curve. In Single Curves view, click the SvS button at the top to display the curve.
3. In the viewer, click or drag over the color in your clip whose saturation you want to adjust.

Three control points appear on the curve in the Color inspector. The middle control point represents the level of saturation you selected with the eyedropper. The two outer control points constrain the selection to a narrow range of saturation.

Note: You can also create control points by clicking the curve, but the eyedropper method is generally more precise.
4. Drag the middle control point up to increase the saturation, or down to decrease the saturation.
   
   To make fine adjustments, hold down the Option key as you drag a control. Hold down the Shift key as you drag to constrain the control point to vertical or horizontal movement only.

5. To change the range of saturation selected, drag the two outer control points to the left or the right, or just delete them.

6. To adjust the saturation for a different range of saturation, click the curve to add control points, and adjust them as needed.

   Use the left end of the curve to adjust regions of low saturation, the middle section to adjust regions of medium saturation, and the right end of the curve to adjust highly saturated regions. Drag a control point up or down to increase or decrease saturation for that region of saturation.

   ![Image of curve adjustment](image)

   The viewer shows the saturation change.

   Drag the control points to adjust the saturation.

   **Adjust the saturation of a specific color at any point along its range of brightness**

   You can use the Orange vs Sat curve to adjust a specific color’s saturation at any point along its range of tonality from darkest to brightest.

   *Note:* The default color for the curve is orange (because it aligns with skin tone), but you can select any color and adjust its saturation. For more information about skin tone, seeVectorscope display options.
1. Follow the instructions in Add and set up a Hue/Saturation Curves color correction, above.

2. In the Color inspector, click the eyedropper for the Orange vs Sat curve.
   
   If all six curves are shown in the inspector, you may need to scroll to see the Orange vs Sat curve. In Single Curves view, click the Orange button at the top to display the curve.

3. In the viewer, click or drag over the color in your clip whose saturation you want to adjust.
   
   The curve color changes to the color you selected in the viewer. The name of the curve also changes to reflect the selection—for example, to “Aqua vs Sat.”

You can also change the color of a curve by clicking its name (at the top left of the curve) and then clicking or dragging in the color wheel to select a color.
4. Click the curve to add control points, then drag them up or down to increase or decrease the saturation of the selected color.

To make fine adjustments, hold down the Option key as you drag a control.

Use the left end of the curve to adjust shadows, the middle section to adjust midtones, and the right end of the curve to adjust highlights. Add or adjust control points as needed.

**Tip:** If you want to color correct the next or previous clip in the timeline, press Command-Right Arrow or Command-Left Arrow to move the playhead to the next or previous clip and select it. These shortcuts select clips in the same role only, so you can quickly move between video clips and skip over clips not suited for color correction (such as music or titles).

After you apply a color correction, you can copy it to another clip or group of clips. See Copy effects between clips.

Use the Color Adjustments effect in Final Cut Pro for Mac

The Color Adjustments effect provides controls for adjusting exposure, contrast, brightness, saturation, highlights, shadows, warmth, and tint in your video clips. It's designed to adjust color in HDR clips, but you can use it to adjust color in SDR clips as well.
1. In Final Cut Pro, select a clip in the timeline that you want to correct, then position the playhead over the clip (so that its image appears in the viewer).

2. Open the Color inspector.

   🚨 Tip: If you frequently add a particular color correction effect, you can speed up your workflow by setting it as the default color correction. Then just select a timeline clip and press Command-6 to start adjusting the effect in the Color inspector.

3. Optionally, show video scopes to check the clip’s luma and chroma levels while you’re making color adjustments.

4. Click the pop-up menu at the top of the Color inspector, then do one of the following:
   - Add a new instance of the Color Adjustments effect: Choose Color Adjustments from the Add Correction section at the bottom of the menu.

      ![Choose Color Adjustments.](image)

      For more details and methods, see Add color correction effects.

   - Correct a Color Adjustments effect already applied to the clip: Choose the Color Adjustments effect you want to correct from the Corrections section at the top of the menu.

      Controls for the Color Adjustments effect appear in the Color inspector. The effect also appears in the Effects section of the Video inspector.

5. In the Color inspector, use the Control Range pop-up menu (at the top of the Color Adjustments controls) to confirm the correct brightness (luminance) range.

   This setting allows for proper scaling of the color adjustment sliders, so that when you adjust the Shadows, Midtones, or Highlights sliders, they affect those ranges in the image. Final Cut Pro generally chooses the correct setting automatically (based on your project settings).

   Note: If automatic color management is turned off, choose the Control Range option that most closely matches the luminance range of the clip selected in the timeline. See Use automatic color management and Color Conform.
6. Use the color adjustment sliders and value sliders to adjust any of the following:

- **Exposure**: Lightens or darkens the image, with a bias toward affecting the highlights more than the other tones.
- **Contrast**: Sets the relative amount of contrast between light and dark areas.
- **Brightness**: Adjusts the overall brightness of the image.
- **Saturation**: Adjusts the color (chroma) intensity.
- **Highlights**: Adjusts the detail in the lightest areas of the image.
- **Black Point**: Adjusts the point at which black areas become completely black (no detail can be seen).
- **Shadows**: Adjusts the detail that appears in the darkest areas of the image.
- **Highlights Warmth**: Adjusts the color temperature of the lightest areas of the image. Drag the slider to the right to add warm (orange) tones to the image, or to the left to add cool (blue) tones.
- **Highlights Tint**: Fine-tunes the white-balance adjustment by neutralizing a remaining green or magenta tint. Drag the slider to the right to add a magenta tint to the image, or to the left to add a green tint.
- **Midtones Warmth**: Adjusts the color temperature for the midtone areas of the image. Drag the slider to the right to add warm (orange) tones to the image, or to the left to add cool (blue) tones.
- **Midtones Tint**: Fine-tunes the white-balance adjustment for the midtones only by neutralizing a remaining green or magenta tint. Drag the slider to the right to add a magenta tint to the image, or to the left to add a green tint.
- **Shadows Warmth**: Adjusts the color temperature in the darkest areas of the image. Drag the slider to the right to add warm (orange) tones to the image, or to the left to add cool (blue) tones.
- **Shadows Tint**: Fine-tunes the white-balance adjustment in the darkest areas of the image by neutralizing a remaining green or magenta tint. Drag the slider to the right to add a magenta tint to the image, or to the left to add a green tint.
- **Mix**: Sets the amount of the original image to be blended with the adjusted image.

⚠️ **Tip**: If you want to color correct the next or previous clip in the timeline, press Command-Right Arrow or Command-Left Arrow to move the playhead to the next or previous clip and select it. These shortcuts select clips in the same role only, so you can quickly move between video clips and skip over clips not suited for color correction (such as music or titles).

After you apply a color correction, you can copy it to another clip or group of clips. See Copy effects between clips.
Use color presets in Final Cut Pro for Mac

Apply color presets to quickly give your clips a particular look. Color presets are based on color correction effects and have the same controls as the effect they're based on. For example, Color Board presets (such as Fall Sun or Moonlight) are based on the Color Board effect. Color-grading presets (such as Green Muted Wash or Cool Shadows with Warm Highs) are based on the Color Adjustments effect. After you apply a preset, you can adjust its settings to create a custom look.

Add color presets

1. In Final Cut Pro, select a clip in the timeline that you want to apply a preset to, then position the playhead over the clip (so that its image appears in the viewer).
2. To open the Effects browser, click the Effects button in the top-right corner of the timeline (or press Command-5).
3. In the Effects browser, select a color presets category on the left (Color Board Presets or Color Grading Presets), then select a preset on the right.
   Tip: To preview a preset, skim its thumbnail in the Effects browser.
4. Do one of the following:
   • Drag the preset to the timeline clip you want to apply it to.
   • Double-click the preset thumbnail to apply it to the selected clip.

Adjust color presets

You can adjust a color preset using the controls for the effect the preset is based on. (Color Board presets are based on the Color Board effect, and color-grading presets are based on the Color Adjustments effect.)

1. In Final Cut Pro, select a clip in the timeline that has a color preset applied, then position the playhead over the clip (so that its image appears in the viewer).
2. Open the Color inspector.
   The color correction effect corresponding to the preset appears in the Color inspector.
3. Use the controls in the color correction effect to adjust the settings for the preset.
   To adjust a Color Board preset, see Use the Color Board effect.
   To adjust a color-grading preset, see Use the Color Adjustments effect.
Add color masks and shape masks

Add a color mask in Final Cut Pro for Mac

A color mask isolates a particular color in an image. You can apply a color mask to a clip to correct a specific color, or to exclude that color from corrections to the rest of the image, or both. For example, you could mute a bright color in the background that distracts attention from a clip’s main subject.

You can create two types of color masks in Final Cut Pro: a 3D color mask or an HSL color mask. With either mask type you can make an initial color selection using an eyedropper, but each mask type has its own set of controls for refining the color range in the mask.

Note: You can switch from one mask type to another, but your color selection is not retained when you switch.

1. Add a color correction to a clip in the Final Cut Pro timeline, then select the clip.
2. Position the playhead in the timeline so that the clip appears in the viewer.
3. If the Color inspector isn’t already shown, do one of the following:
   • Choose Window > Go To > Color Inspector (or press Command-6).
   • Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.
4. Click the pop-up menu at the top of the Color inspector and choose the color correction you want to mask.
5. At the top of the Color inspector, move the pointer over the effect name and click the Apply Effect Masks button.
6. Click the pop-up menu that appears and choose Add Color Mask.
    The Color Mask controls appear at the bottom of the Color inspector, and the pointer changes to an eyedropper.
7. Click the Type pop-up menu and choose one of the following:
   • 3D: Creates a color mask that lets you add or remove surrounding colors by dragging the Softness slider.
   • HSL: Creates a color mask that lets you adjust hue, saturation, and luma values independently.

For more information about each mask type, see Edit a color mask.
8. In the viewer, position the eyedropper on a color in the image that you want to isolate, then drag to select the color.

As you drag the eyedropper, a circle appears. The size of the circle determines the range of color that is included in the color mask. As you change the circle size, the image becomes monochrome except for the color you’re selecting. You can drag a new selection circle as many times as you like to try for better results.

*Note:* When you stop dragging, you see the effects of the color mask as soon as you start making adjustments in the color correction effect.

If you chose the HSL mask type you can also make the initial color selection using the HSL controls. See *Edit an HSL color mask with hue, saturation, and luma controls*.

9. Do one of the following:

- **Apply a color correction to the selected color:** Click Inside.

- **Apply a color correction to everything except the selected color:** Click Outside.

You can make corrections to both the inside and outside areas of the mask—each area effectively has its own complete set of color correction controls. For example, you could click Inside to enhance the targeted color, and then click Outside to darken everything else.

As with any other masked clip effect, you can also *invert* (flop) the masked and unmasked areas of the color mask. See *Invert effect masks*.

10. To correct the color isolated by the mask, adjust the controls of the color correction effect in the Color inspector.

    For more information about the manual color correction effects, see *Intro to color correction effects*.

To adjust the color selection in the color mask, you can *edit the mask*. To limit the area of the image affected by a color mask, you can *add one or more shape masks*.
Edit color masks in Final Cut Pro for Mac

A color mask is defined by a specific color range, so only areas in your video clip that contain colors within the range are part of the mask. The illustration below shows an example of a color range selection in a 3D color model.

In Final Cut Pro, you can adjust the range of colors included in a color mask—for example, to add or remove colors as the subject moves or the scene changes. With the eyedropper, you can quickly select a base range of colors or expand or shrink a selection.

Depending on the type of color mask you created, you can use additional controls to fine-tune the color range. If you created a 3D color mask, you can add or remove surrounding colors using the Softness slider. If you created an HSL color mask, you can adjust hue, saturation, and luma values independently.

Edit a color mask with the eyedropper

1. In Final Cut Pro, add a color mask to a clip in the timeline.
2. Position the playhead in the timeline so that the clip appears in the viewer.
3. If the Color inspector isn’t already shown, do one of the following:
   • Choose Window > Go To > Color Inspector (or press Command-6).
   • Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.
4. In the Color Mask section of the inspector, click the eyedropper to enable it (the eyedropper turns blue).
5. Do any of the following:
   - **Make a new single-color selection**: Position the eyedropper on a color you want to include in the mask, then click once.
   - **Add color shades**: Hold down the Shift key, position the eyedropper on a color you want to add to the mask, then drag to select the range of color.
   - **Subtract color shades**: Hold down the Option key, position the eyedropper on a color you want to remove from the mask, then drag to select the range of color.

**Edit a 3D color mask with the Softness slider**

1. In Final Cut Pro, add a 3D color mask to a clip in the timeline, then select the clip.
2. Position the playhead in the timeline so that the clip appears in the viewer.
3. If the Color inspector isn't already shown, do one of the following:
   - Choose Window > Go To > Color Inspector (or press Command-6).
   - Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.

4. In the Color Mask section of the inspector, make sure 3D is chosen from the Type pop-up menu.

5. Drag the Softness slider to the right to add surrounding colors to the range included in the mask, or to the left to remove colors.

⚠️ **Tip**: To view the mask contents while you make your change, press the Command key as you drag the Softness slider. See **Ways to view masks**.
Edit an HSL color mask with hue, saturation, and luma controls

1. In Final Cut Pro, add an HSL color mask to a clip in the timeline, then select the clip.

2. Position the playhead in the timeline so that the clip appears in the viewer.

3. If the Color inspector isn’t already shown, do one of the following:
   - Choose Window > Go To > Color Inspector (or press Command-6).
   - Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.

4. In the Color Mask section of the inspector, make sure HSL is chosen from the Type pop-up menu.

   The Hue, Saturation, and Luma parameter controls appear below the Type pop-up menu.

5. Do any of the following:
   - Adjust the range of a parameter: Drag the top handles of the parameter.
     🔄 Tip: To adjust ranges slowly, press the Option key while dragging a top handle.
   - Adjust the softness of a parameter’s range: Drag the bottom handles of the parameter. Adjusting the softness adds or subtracts surrounding colors.
     In the Hue parameter only, adjusting one bottom handle automatically adjusts the other.
   - Disable a parameter while adjusting the color mask: Deselect the parameter’s checkbox.
     For example, deseleting the H (Hue) checkbox selects all colors with similar saturation and luma values. Selecting only the L (Luma) checkbox selects all colors with similar luma values.
   - Adjust both ends of the parameter’s range simultaneously: Drag between the handles on any of the sliders.
     🔄 Tip: To view the mask contents while you make your change, press the Command key as you adjust a control. See Ways to view masks.
Ways to view masks in Final Cut Pro for Mac

You can display the precise area of a mask in the viewer as a black-and-white alpha channel image or as a color image, showing the actual color contents of the mask. Changing the viewing mode helps you see which areas of the image are being affected (by a color correction, for example).

1. **Add a clip** to your Final Cut Pro project, then select the clip in the timeline.

2. Do one of the following:
   - **Add an effect to the clip**, then **add a mask to the effect**.
     *Note:* Effects you can mask in this way include color corrections.
   - **Add a color mask** or a **shape mask** to the clip.

3. Position the playhead in the timeline so that the clip appears in the viewer.

4. If the Color inspector isn't already shown, do one of the following:
   - Choose **Window > Go To > Color Inspector** (or press Command-6).
   - Click the Enhancements pop-up menu below the viewer and choose **Show Color Inspector**.

5. In the inspector, click the **View Masks** button to show the mask in the viewer.
6. Do one of the following:

- **View the alpha channel in black and white**: Click the View Masks pop-up menu and choose Black and White.
  
  The mask's alpha channel appears in the viewer. White indicates fully opaque mask areas, black indicates areas outside the mask, and levels of gray indicate transparent mask areas.

- **View the visible areas of the masked image in color**: Click the View Masks pop-up menu and choose Color.
  
  The colors inside the mask appear in the viewer. Gray indicates areas outside the mask.

To turn the current mask view on or off and switch between displaying the mask and the adjusted image in the viewer, click View Masks.

### Add a shape mask in Final Cut Pro for Mac

A shape mask defines an area in the image so that you can apply color corrections either inside or outside that area. For example, you might want to emphasize an object in a shot by darkening the area around the object.
You can add multiple shape masks to define multiple areas, and you can also animate the shapes with keyframes so that they follow a moving object, or follow an area while a camera pans. For information about animating shape masks, see Animate an effect shape mask. For information about working with keyframes, see Intro to video keyframing and Add video effect keyframes.

1. Add a color correction to a clip in the Final Cut Pro timeline, then select the clip.
2. Position the playhead in the timeline so that the clip appears in the viewer.
3. If the Color inspector isn’t already shown, do one of the following:
   - Choose Window > Go To > Color Inspector (or Press Command-6).
   - Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.
4. Click the pop-up menu at the top of the Color inspector and choose the color correction you want to mask.
5. At the top of the Color inspector, move the pointer over the effect name and click the Apply Effect Masks button.
6. Click the pop-up menu that appears and choose Add Shape Mask.

The onscreen controls appear in the viewer, superimposed over the video image. By default, the shape mask is set to a partially feathered circle in the center of the frame. The Shape Mask item appears in the masks section at the bottom of the Color inspector.
7. Adjust the onscreen controls to specify which part of the video image is affected by the color correction.

- **Position the shape**: Drag the center.
- **Adjust the shape’s width or height**: Drag any of the four handles at the 90-degree points (top, bottom, left, or right) of the inner circle. You can hold down the Shift key while dragging to force all sides to scale proportionally.
- **Control the roundness of the shape**: Drag the handle to the left of the inner circle’s top handle.
- **Rotate the shape**: Drag the rotation handle (extending from the center).
- **Control the softness of the shape’s edge**: Drag the outer circle. Setting the outer circle close to the inner circle creates a hard edge and an abrupt transition to the corrections you apply, and dragging the outer circle away from the inner circle creates a softer edge and a more gradual transition.

To show or hide the mask’s controls, click the Shape Mask Onscreen Controls button to the right of the shape mask name in the mask list.

For information about viewing the mask, see **Ways to view masks**.
8. Do one of the following:

- **Apply a color correction to the shape area**: Click Inside.

- **Apply a color correction to everything except the shape area**: Click Outside.

You can make corrections to both the inside and outside areas of the mask—each area effectively has its own complete set of color correction controls. For example, you could click Inside and enhance the shape’s area, and then click Outside to change everything else.

As with any other masked clip effect, you can also invert (flop) the masked and unmasked areas of the shape mask. See Invert effect masks.

9. To correct color in the area isolated by the mask, adjust the controls of the color correction effect in the Color inspector.

   For more information about the manual color correction effects, see Intro to color correction effects.

10. To add additional shape masks to the correction, repeat steps 5 and 6 above.

    Another default shape appears in the viewer, and the original shape is dimmed. You can select and continue configuring the original shape by clicking its center.

    For information about how masks can interact, see Combine multiple effect masks.

### Add shape masks to a color mask in Final Cut Pro for Mac

Often when you create a color mask, more areas of the video are affected by it than you would like. For example, there might be a gray car on the right side of the screen that you want to color correct, and a gray car on the left that you don’t want to change. In this situation, you can add one or more shape masks to restrict the color mask to the areas defined by the shape masks.

You can set masks to interact in different ways using mask blend modes. For example, you can add mask shapes together to create a combined mask, subtract a mask shape from other masks, and intersect masks. For a complete description of ways masks can interact, see Combine multiple effect masks.

There are many ways to use multiple masks in a color correction. The example below shows how you might use a shape mask to isolate an area of a color mask: the dark gray body of one car in a line of four cars of similar color.
Example: Add shape masks to a color mask in a color correction effect

1. Add a color correction to a clip in the Final Cut Pro timeline, then select the clip.

2. Position the playhead in the timeline so that the clip appears in the viewer.

3. If the Color inspector isn’t already shown, do one of the following:
   - Choose Window > Go To > Color Inspector (or press Command-6).
   - Click the Enhancements pop-up menu below the viewer and choose Show Color Inspector.

4. Click the pop-up menu at the top of the Color inspector and choose the color correction you want to mask.

   The color correction effect appears in the Color inspector.

5. Add a color mask to the color correction.

6. To view the mask alpha channel, click the View Masks pop-up menu in the inspector and choose Black and White, then click View Masks.

   The color mask alpha channel appears in the viewer. White indicates fully opaque mask areas, black indicates areas outside the mask, and levels of gray indicate transparent mask areas.
Note: You can also view the visible areas of the masked image in color. See Ways to view masks.

7. Add a shape mask to the same color correction.

Both masks appear in a list at the bottom of the Color inspector.

By default, the shape mask appears at the top of the list, set to the Add blend mode. The color mask's blend mode is changed to Intersect. (In Intersect mode, only the area inside the mask shape that overlaps with other mask shapes is affected.)

8. Click the Shape Mask Onscreen Controls button so that the onscreen controls appear in the viewer.

9. Adjust the shape mask onscreen controls to isolate the area you want to correct (in this example, the dark gray tones of the first car).
The alpha channel in the viewer shows the isolated area only.

10. Add additional shape masks as needed to further isolate the area.

11. To correct color in the area isolated by the masks, adjust the controls of the color correction effect in the Color inspector.

   For more information about the manual color correction effects, see Intro to color correction effects.

Remove a color or shape mask in Final Cut Pro for Mac

1. In the Final Cut Pro timeline, select a clip that has a color mask or shape mask you want to remove.

2. In the Color inspector, click the mask name (so that a yellow box appears around the mask item), then press Delete.
Wide color gamut and HDR

Intro to wide color gamut and HDR in Final Cut Pro for Mac

No image device is capable of capturing and displaying the full spectrum of colors visible to the human eye. Consequently, image devices record, edit, display, or output a subset of those colors. This range of reproducible color is known as the device’s color space or color gamut. Because Final Cut Pro projects often involve media captured or created from different sources, and because color gamuts vary from device to device, Final Cut Pro employs a color-management system to reconcile those color differences. This ensures that an image looks the same on any output device, regardless of what color space it’s encoded in or how it was originally created.

Standard-gamut versus wide-gamut color

Traditional computer displays and HDTVs support a limited color space that’s based on a decades-old industry standard called Rec. 709. Rec. 709 devices (and the video content created for display on them) have standard-gamut color, the constrained color palette you see whenever you view a broadcast HDTV show, DVD, or Blu-ray disc.

A more recent generation of displays—including 4K televisions and computer displays, Apple TV 4K, and newer Mac, iOS, and iPadOS devices—can render a much wider palette of colors. These wide-gamut color devices display more vivid and lifelike hues (in addition to all the hues that standard-gamut devices can display). Accordingly, the video industry has adopted a wide-gamut color standard called Rec. 2020. Although most currently available wide-gamut devices support only a subset of the colors contained in the full Rec. 2020 specification, future imaging devices should be able to render more and more of those hues.
High dynamic range (HDR)

Additionally, some newer imaging devices can display extra levels of brightness in each color component (red, green, and blue) in a way that more closely reproduces how the human eye perceives contrast. These high-dynamic-range (HDR) displays typically process video at 10 bits per color component rather than 8 bits. The additional color data lets HDR displays render more discrete steps from the minimum to maximum brightness value in each color, creating more realistic color transitions and revealing more detail in both shadows and highlights.

Working with wide-gamut color and HDR in Final Cut Pro

Using profiles, or tags (assigned by the device upon creation) that describe the color space of the media, Final Cut Pro identifies the media's colors. If the media was not profiled by the device (or was profiled incorrectly), you can manually override the assigned color space in your Final Cut Pro project. The computer display profile then tells Final Cut Pro how to translate the colors to the display's color space. When you export from Final Cut Pro, the color-matching process algorithmically maps those colors to the output space of the project.

You can choose between two library color-processing options in Final Cut Pro:

- **Standard:** Sets the working color space to linear RGB with Rec. 709 color primaries, the color space that previous versions of Final Cut Pro have used. Rec. 709 is the current standard for HDTV projects, including HD cable, Blu-ray discs, and most streaming video today.

- **Wide Gamut HDR:** Sets the working color space to linear RGB with Rec. 2020 color primaries, a color space with a wider range of colors than Rec. 709. Rec. 2020 is useful for 4K and 8K UHDTV and HDR projects. In a Wide Gamut HDR library, the built-in camera LUT settings preserve the full dynamic range of log source media when converting to the working space.

*Note:* To view the wider range of colors in Rec. 2020, it's recommended that you use a wide-gamut HDR external monitor and video interface. See Play media on an external display. For tips on color correcting wide-gamut HDR projects with Mac displays, see Wide-gamut HDR tips.
Nearly all devices and formats support capture in the Rec. 709 color space. Some devices and formats can also capture in the DCI-P3 and Rec. 2020 color spaces, which include a much wider gamut of colors.

Generally, your working color space should match your output color space (the color space you’re required to deliver the project in). If you’re exporting to multiple output color spaces, your working color space should match the output color space with the largest gamut.

For more information, see HDR and Wide Color Gamut in Final Cut Pro.

Use wide-gamut HDR color processing in Final Cut Pro for Mac

You can choose between two basic color spaces in Final Cut Pro: Standard and Wide Gamut HDR.

To work in wide-gamut HDR, you must first configure two settings:

- The color-processing setting for an entire library: This global setting changes the way in which effects and log processing work for all projects. Set your library to Wide Gamut HDR if you’re considering exporting a wide-gamut HDR output media file.
- The color space setting for a specific project: This setting determines the color space of your render files, the color of images you see on the screen, and the color space of your exported project (the output media file). Set your project to Wide Gamut HDR if you intend to export an HDR movie when you complete the project. (This project setting is available only when the library is set to Wide Gamut HDR.)

Set the color processing for a library

Because the color-processing setting affects all projects and media in the library, it’s a good idea to create a separate library for each project or deliverable (to prevent accidental color space crossover issues). See Create a new library.

Important: The working color space setting may affect video processing and the appearance of your final rendering results. For example, when the library color-processing setting is changed from Standard to Wide Gamut HDR, some filters or compositing effects (blend modes) may change in appearance.

1. In the Libraries sidebar in Final Cut Pro, select a library.
2. To open the Library Properties inspector, do one of the following:
   - Choose File > Library Properties (or press Control-Command-J).
   - Click the Inspector button on the right side of the toolbar.

1.

![Inspector button](image-url)
3. Click Modify at the top of the Library Properties inspector.

4. Select one of the following in the window that appears:
   - **Standard**: Set the working color space to linear RGB with Rec. 709 color primaries, the color space that previous versions of Final Cut Pro have used. Rec. 709 is the current standard for HDTV projects, including HD cable, Blu-ray discs, and most streaming video today.
   - **Wide Gamut HDR**: Set the working color space to linear RGB with Rec. 2020 color primaries, a color space with a wider range of colors than Rec. 709. Rec. 2020 is useful for 4K and 8K UHDTV and HDR projects. In a Wide Gamut HDR library, the built-in camera LUT settings preserve the full dynamic range of log source media when converting to the working space. See Apply LUTs.

A third option, Wide Gamut (Deprecated), appears if you selected a wide-gamut library containing log media that was created with Final Cut Pro 10.3. The Wide Gamut (Deprecated) option ensures that wide-gamut projects created with Final Cut Pro 10.3 don't change in appearance.

**Important**: If you switch from Wide Gamut (Deprecated) to another color-processing setting, you can’t switch back—the Wide Gamut (Deprecated) setting will no longer be available.

**Set the color space for a project**
You can choose one of four color space options for your project if the library color processing is set to Wide Gamut HDR and the project video format is set to HD or larger.

When you set the project color space, the project's render files are generated in that color space, and your project is exported in that color space if the destination codec supports it. During playback, output images are converted to the project color space and then displayed onscreen according to the display device's color profile.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the project you want to modify, then select the project (or double-click it to open it in the timeline).

2. Do one of the following:
   - Choose Window > Project Properties (or press Command-J).
   - Click the Inspector button on the right side of the toolbar.
3. In the Project Properties inspector, click the Modify button in the top-right corner.

4. In the window that appears, click the Color Space pop-up menu and choose one of the following:
   - **Standard - Rec. 709**: Choose this option to set your project to use the Rec. 709 color space, the current standard for HDTV projects, including HD cable, Blu-ray discs, and most streaming video today. You can also create a project that uses the standard color space within a wide-gamut library—for example, if you have wide-gamut media but need to deliver a standard project, or if you need to deliver both standard and wide-gamut versions of a project.
   - **Wide Gamut - Rec. 2020**: Choose this legacy setting for projects created previously using the Wide Gamut - Rec. 2020 color space. If you intend to export an HDR movie, choose one of the following Wide Gamut HDR options.
   - **Wide Gamut HDR - Rec. 2020 PQ**: Choose this option if you intend to create an HDR movie with the Rec. 2020 color space and PQ transfer function (Rec. 2100 standard), using formats such as HDR10, HDR10+, Dolby Vision, or Advanced HDR. You can create an HDR10-compatible movie entirely within Final Cut Pro. See Export an HDR10 file. For other HDR formats, some additional steps are required after you export the movie file from Final Cut Pro.
   - **Wide Gamut HDR - Rec. 2020 HLG**: Choose this option if you intend to create an HDR movie with the Rec. 2020 color space and HLG transfer function (Rec. 2100 standard), using formats such as HLG or Advanced HDR. HLG, or Hybrid Log-Gamma, was developed by the BBC and NHK broadcasting networks and is compatible with older standard dynamic range (SDR) televisions and monitors. Movies created with this color space option in Final Cut Pro are compatible with HLG HDR televisions and displays.

   **Note**: If you want to set the project to a wide-gamut color space, but the menu is set to something else and dimmed, you must first set the color processing for the library.

5. Click OK.

For a detailed list of all project settings, see Final Cut Pro project settings. For information about displaying the image details of HDR clips or projects in the viewer, see Playback settings.

**Note**: You can use the video scopes and the range check overlay in Final Cut Pro to measure video levels and detect out-of-gamut colors. See Intro to measuring video and Detect out-of-gamut colors. You can also use the Broadcast Safe filter as a quick way to reduce luma and chroma levels that exceed the specification limits for either standard or wide-gamut color spaces in standard-dynamic-range (SDR) video media. To apply the Broadcast Safe filter to a clip in your project, see Add video effects.
Use automatic color management and Color Conform in Final Cut Pro for Mac

Final Cut Pro manages color space settings automatically, so you can easily edit HDR and SDR clips in the same project, or mix different types of HDR clips in a project. To manage color space settings, Final Cut Pro applies a built-in Color Conform effect to each imported clip.

By default, Color Conform is set to Automatic, so that if you add a clip to a project that has a different color space setting, the clip’s color space is automatically converted to the project’s color space. If you don’t want clips to be automatically converted to another color space when you add them to a project, you can turn off automatic color management in Final Cut Pro settings.

You can also use the Color Conform effect to manually adjust how individual clips are conformed to the project’s color space. For example, you can set the Color Conform effect on a selected clip to None (off), or to a specific conversion, such as HDR (HLG) to SDR (for HLG clips that you add to an SDR project).

You can also manually convert a clip's color space using the HDR Tools effect, which is a legacy effect included for backward compatibility with older projects. (In projects created in Final Cut Pro 10.6.3 or earlier, the Color Conform effect is set to None.)

Important: The Color Conform effect and the HDR Tools effect are additive, so you should use only one or the other on a clip.

Use Color Conform to manually convert a clip to the project’s color space

1. In Final Cut Pro, select one or more clips in the timeline.
2. To open the Video inspector, choose Window > Show in Workspace > Inspector (or press Command-4), then click the Video button at the top of the inspector.
3. In the Color Conform section of the Video inspector, click the Type pop-up menu and choose Manual, then click the Conversion Type pop-up menu and choose an option:
   - **SDR to 100% HDR (HLG):** Apply this setting to SDR (Rec. 709) clips in HDR (HLG) projects to inverse tone map a 100% SDR white level up to a 100% HLG signal level.
   - **SDR to 75% HDR (HLG):** Apply this setting to SDR (Rec. 709) clips in HDR (HLG) projects to map a 100% SDR white level to a 75% HLG signal level.
   - **SDR to HDR (PQ):** Apply this setting to SDR (Rec. 709) clips in HDR (PQ) projects to map a 100% SDR white level to a 58% (203 nits) PQ signal level. To change the target PQ signal level, adjust the Peak Brightness slider.
• HDR (HLG) to SDR: Apply this setting to HDR (HLG) clips in SDR (Rec. 709) projects to convert the clips to SDR luminance levels.

• HDR (PQ) to SDR: Apply this setting to HDR (PQ) clips in SDR (Rec. 709) projects to convert the clips to SDR luminance levels.

• HLG to PQ: Apply this setting to HDR (HLG) clips in HDR (PQ) projects to convert the clips from HLG to PQ. This setting results in PQ clips that appear on PQ displays the way HLG clips would appear on an HLG reference display, assuming all displays have the same peak luminance. This conversion uses the HLG reference OOTF in accordance with Rep. ITU-R BT.2408, with peak luminance corresponding to the level you set in the Peak Brightness slider. A value of 1000 nits is most commonly used for this conversion.

• PQ to HLG: Apply this setting to HDR (PQ) clips in HDR (HLG) projects to convert the clips from PQ to HLG. This setting results in HLG clips that appear on HLG displays the way PQ clips would appear on a PQ reference display, assuming all displays have the same peak luminance. This conversion uses the HLG inverse OOTF in accordance with Rep. ITU-R BT.2408, with peak luminance corresponding to the level you set in the Peak Brightness slider. A value of 1000 nits is most commonly used for this conversion.

• None: Turn off color conversion for the selected clips (the clips retain their native color space).

⚠️ Tip: You can also turn off color conversion for the selected clips by deselecting the checkbox next to Color Conform in the Video inspector.

### Turn off Automatic Color Conform

You can turn off automatic color management in Final Cut Pro settings. After you turn off automatic color management, clips that you import and add to the timeline are no longer converted to the project’s color space.

1. In Final Cut Pro, choose Final Cut Pro > Settings, then click General.
2. Deselect the Automatic Color Conform checkbox.

When you import a clip and add it to the timeline, Conversion Type is set to None in the Color Conform section of the Video inspector, and no conversion is applied.

### Use HDR Tools to convert or adjust HDR clips manually

The HDR Tools effect is a legacy effect included for backward compatibility with older projects and for certain manual color conversion tasks.

As described above, in Final Cut Pro 10.6.6 or later, you can use the built-in Color Conform effect to automatically manage color space settings, or to manually convert clips to another color space. In some cases, however, you might want to manually convert clips using the HDR Tools effect instead. For example, the HDR Tools effect lets you control when in the effect order the color conversion is performed.

**Important:** The Color Conform effect and the HDR Tools effect are additive, so you should use only one or the other on a clip. (In projects created in Final Cut Pro 10.6.3 or earlier, the Color Conform effect is set to None.)
You can use the HDR Tools effect to convert HDR and SDR video clips from one color space to another or to set the maximum brightness of a clip. For example, you can use the HDR Tools effect on any of the following kinds of clips:

- A clip with multiple video effects in which you want to control at what stage in the video effect processing the color conversion is performed. For example, if you want to perform the color conversion after a certain effect, you can set Color Conform to None, then position the HDR Tools effect after that effect in the effect list. See Change clip effect order.
- MOV or MXF files that were encoded directly using the HLG or PQ standard. This could be media originating from a camera or media exported from Final Cut Pro, Motion, Compressor, or another app.
- A source file that is not HLG or PQ (it could be log or RAW, for example) but has a LUT applied (either a camera LUT or a custom LUT effect), where the LUT is designed to output HLG or PQ video. See Apply LUTs.
- A compound clip that has been set to either PQ or HLG. For example, you might color correct a PQ project (a project configured for Rec. 2020 PQ), and then create a compound clip of the entire timeline and place it in an HLG project. For information about wide-gamut HDR project settings, see Use wide-gamut HDR color processing.

1. In Final Cut Pro, select a wide-gamut HDR clip in the timeline.
2. Open the Effects browser, select the Color category on the left, then double-click HDR Tools to add the effect to the clip selected in the timeline.
3. To open the Video inspector, choose Window > Show in Workspace > Inspector (or press Command-4), then click the Video button at the top of the inspector.

4. Click the Mode pop-up menu in the HDR Tools section of the inspector, then choose one of the following settings.

   Note: Some settings in the menu may require further adjustments to the image to fine-tune the look. For best results, arrange the order of the effects so that the HDR Tools effect is applied after your color correction effects. See Change clip effect order.

   - **SDR to 100% HDR (HLG):** Apply this setting to SDR (Rec. 709) clips in HDR (HLG) projects to inverse tone map a 100% SDR white level up to a 100% HLG signal level.
   - **SDR to 75% HDR (HLG):** Apply this setting to SDR (Rec. 709) clips in HDR (HLG) projects to map a 100% SDR white level to a 75% HLG signal level.
   - **SDR to HDR (PQ):** Apply this setting to SDR (Rec. 709) clips in HDR (PQ) projects to map a 100% SDR white level to a 58% (203 nits) PQ signal level. To change the target PQ signal level, adjust the Peak Brightness slider.
   - **HLG to Rec. 709 SDR:** Apply this setting to HDR (HLG) clips in SDR (Rec. 709) projects to convert the clips to SDR luminance levels.
   - **PQ to Rec. 709 SDR:** Apply this setting to HDR (PQ) clips in SDR (Rec. 709) projects to convert the clips to SDR luminance levels.
Final Cut Pro User Guide for Mac

- **HLG to PQ (Rec. 2100):** Apply this setting to HDR (HLG) clips in HDR (PQ) projects to convert the clips from HLG to PQ. This setting results in PQ clips that appear on PQ displays the way HLG clips would appear on an HLG reference display, assuming all displays have the same peak luminance. This conversion uses the HLG reference OOTF in accordance with Rep. ITU-R BT.2408, with peak luminance corresponding to the level you set in the Peak Brightness slider. A value of 1000 nits is most commonly used for this conversion.

- **PQ to HLG (Rec. 2100):** Apply this setting to HDR (PQ) clips in HDR (HLG) projects to convert the clips from PQ to HLG. This setting results in HLG clips that appear on HLG displays the way PQ clips would appear on a PQ reference display, assuming all displays have the same peak luminance. This conversion uses the HLG inverse OOTF in accordance with Rep. ITU-R BT.2408, with peak luminance corresponding to the level you set in the Peak Brightness slider. A value of 1000 nits is most commonly used for this conversion.

- **HDR to Rec. 709 SDR:** Apply this generic conversion setting to any HDR clips in SDR (Rec. 709) projects to convert the clips to SDR luminance levels. For the best results, determine whether the clips are HLG or PQ variants of HDR, then use one of the more specific conversion options above.

- **PQ Output Tone Map:** Apply this setting to reduce the brightness of HDR (PQ) clips down to the level you set in the Peak Brightness slider, and to apply a soft rolloff to the highlights so that they don’t clip abruptly. Use this setting in PQ projects only, and apply it as the last effect.

5. To set a clip’s maximum luminance on a display to a specific level, drag the Peak Brightness slider (for example, to 1000 nits).

6. To optionally set the amount of the original image to be blended with the adjusted image, drag the Mix slider.

If you want to fix incorrect or missing color space metadata on your video clips, see Change a clip’s color space metadata.

### Color correct HDR video with Pro Display XDR and Final Cut Pro for Mac

On a system with a Pro Display XDR, Final Cut Pro provides the maximum color and brightness accuracy in HDR video playback. This makes the Pro Display XDR the ideal professional reference monitor for critical work such as HDR color correction.

The **A/V Output feature** allows you to send video and audio from your Mac to an external video monitor. Follow the instructions below to set up a color correction system with at least two displays: the Pro Display XDR as the external HDR reference monitor and a display for working with the Final Cut Pro interface.

To color correct HDR video with the Pro Display XDR, you must be using Final Cut Pro 10.4.7 or later and macOS Catalina 10.15 or later.
1. In Final Cut Pro, position the playhead on an HDR clip in the timeline or browser, so that the clip appears in the viewer.

2. Connect the Pro Display XDR to the Thunderbolt port on your Mac using a Thunderbolt cable, and make sure the display is connected to power and turned on.

3. To configure the Pro Display XDR, choose Apple menu > System Settings, then click Displays.

4. In Displays settings for the Pro Display XDR, click the Color Profile pop-up menu and choose HDR Video.

   When you choose this preset, Final Cut Pro turns off tone mapping to provide the maximum color and brightness accuracy for HDR video playback on the Pro Display XDR. The color and brightness is accurate for video content measuring up to 1000 nits. For more information about tone mapping, see View HDR video.

   Note: The HDR Video preset is intended for use in a dimmed viewing environment.

5. In Displays settings, set the Pro Display XDR to be an extended display.

6. To set the Pro Display XDR as the A/V output device, choose Final Cut Pro > Settings (or press Command-Comma), click Playback, then click the A/V Output pop-up menu and choose Pro Display XDR.

7. In Final Cut Pro, choose Window > A/V Output.

   The viewer contents appear on the Pro Display XDR. Viewer features (such as onscreen controls and the title-safe and action-safe overlays) appear only in Final Cut Pro.

   Note: Video and audio are synced at the video frame (not audio sample) level.

   To turn off A/V Output, choose Window > A/V Output.

**View HDR video in the viewer in Final Cut Pro for Mac**

In Final Cut Pro 10.4.7 or later, you can choose how to view HDR video in the viewer. The available options depend on the capabilities of your display and which version of macOS you're using.

On systems with macOS Catalina 10.15 or later, you can view HDR video in the viewer with tone mapping applied, which compresses bright image content and reduces the apparent dynamic range of the video to fit the viewable range of your display.

On systems with macOS Mojave 10.14, you have the option to show details in HDR video. This “flat” view is helpful when you need to see pixel details (for example, to select an area with an eyedropper or add a Draw Mask effect).
Important: To play back the wider range of colors in an HDR project with maximum accuracy, you can use the A/V Output feature with an external reference HDR video monitor. See Play media on an external display.

View HDR video on macOS Catalina 10.15 or later
When you view HDR video on macOS Catalina 10.15 or later, the Show HDR as Tone Mapped setting is turned on by default in most cases, applying tone mapping to the HDR image in the viewer. This setting does not affect how HDR content is displayed on an external monitor using A/V Output.

Important: If the Pro Display XDR is set to HDR Video or another reference mode preset in Displays settings (in macOS System Settings), tone mapping is disabled.

1. In Final Cut Pro, position the playhead on an HDR clip in the timeline or browser, so that the clip appears in the viewer.
2. Click the View pop-up menu in the upper-right corner of the viewer, then, in the Display section, make sure that Show HDR as Tone Mapped is turned on (a checkmark appears next to it).

If you’re using a system with a Pro Display XDR, this setting is appropriate for day-to-day playback and editing with the default preset (“Apple Display P3-1600 nits”) in Displays settings. To use the Pro Display XDR for critical tasks such as color correction, see Color correct HDR video with Pro Display XDR.

View HDR video on macOS Mojave 10.14
When you view HDR video on macOS Mojave 10.14, highlights above the reference white level, typically 100 nits, appear clipped in the viewer on a Mac display. To see the image details of HDR clips or projects, use the Show HDR as Raw Values setting.

1. In Final Cut Pro, position the playhead on an HDR clip in the timeline or browser, so that the clip appears in the viewer.
2. Click the View pop-up menu in the upper-right corner of the viewer, then, in the Display section, make sure that Show HDR as Raw Values is turned on (a checkmark appears next to it).

Export HDR files in Final Cut Pro for Mac
Directly within Final Cut Pro, you can create high-dynamic-range (HDR) files suitable for certain HDR televisions and displays. Specifically, you can use Final Cut Pro to create HDR10 and HLG movie files.

- **HDR10** is most commonly used for streaming and for output on Blu-ray discs.
- **HLG** is useful for broadcast and live TV. An advantage of HLG is that you don’t need an HDR TV to view the content. You can view it on a legacy standard-dynamic-range (SDR) TV that isn’t designed to work with HLG or HDR, and the image will have acceptable quality. However, if an HDR-capable TV detects the relevant metadata in the HLG file, it will play back the file in HDR.
Export an HDR10 file

1. In the Final Cut Pro browser, select the project you want to export.

2. If the inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Set the color processing for the library to Wide Gamut HDR.

4. Set the project color space to Wide Gamut HDR - Rec. 2020 PQ.

5. With the project still selected in the browser, click the Share button at the top of the inspector.

   The Share inspector appears.

   ![Share inspector](image-url)
6. In the HDR Content Light Level Metadata section of the inspector, enter values based on the content of your program and the specifications of the target device.

   If you’re not sure of the proper values to enter, leave the fields empty.

   • **MaxCLL (Maximum Content Light Level):** Enter the level, in nits, of the brightest pixel component in the program.

     For example, if the peak brightness (maximum luminance) of the target television or display is 1000 nits, you can apply the HDR Tools effect to the entire project, with the effect configured to convert to a maximum Rec. 2020 PQ output level of 1000 nits. In this case, you would enter 1000 for MaxCLL. For more information about the HDR Tools effect, see Use HDR Tools to convert or adjust HDR clips manually.

   • **MaxFALL (Maximum Frame Average Light Level):** Enter the value, in nits, for the frame in your program with the highest average brightness level.

7. If you know the characteristics of your mastering display (the reference monitor you use for tasks such as color correction that require maximum color and brightness accuracy), enter the values in the HDR Mastering Display Metadata section.

   For example, if you’re mastering with a Sony BVM-X300 monitor, you would enter the following:

   • **Display Primaries:** Rec. 2020

   • **Display White Point:** D65

   • **Maximum Display Luminance:** 1000

   • **Minimum Display Luminance:** 0 or 0.0001

   If you’re not sure of the proper values to enter, leave the fields empty.

8. **Export the file.**

   HDR files require a 10-bit or higher codec, such as Apple ProRes.

   **Note:** Check the “Color space” field in the Settings pane of the Share window before you export to ensure that the project color space is set to Wide Gamut HDR - Rec. 2020 PQ.

### Export an HLG file

1. In the Final Cut Pro browser, select the project you want to export.

2. If the inspector isn’t already shown, do one of the following:

   • Choose Window > Show in Workspace > Inspector (or press Command-4).

   • Click the Inspector button on the right side of the toolbar.

3. **Set the color processing for the library** to Wide Gamut HDR.

4. **Set the project color space** to Wide Gamut HDR - Rec. 2020 HLG.

5. **Export the file.**

   HDR files require a 10-bit or higher codec, such as Apple ProRes.

   **Note:** Check the “Color space” field in the Settings pane of the Share window before you export to ensure that the project color space is set to Wide Gamut HDR - Rec. 2020 HLG.
Final Cut Pro does not support the creation of other HDR formats, such as HDR10+, Dolby Vision, and Advanced HDR, but you can use Final Cut Pro to export an HDR movie with the Rec. 2020 PQ standard and then use other color grading software to generate the necessary metadata for these formats.

You can, however, share your project in Dolby Vision 8.4, a format designed to optimize HDR content for Apple devices. See Share to Apple devices and this Apple Support article.

For more detailed information about color spaces and wide-gamut HDR, see HDR and Wide Color Gamut in Final Cut Pro.

Wide-gamut HDR tips in Final Cut Pro for Mac

The following tips can help you streamline your wide-gamut HDR workflow:

- On a system with a Pro Display XDR, Final Cut Pro provides the maximum color and brightness accuracy in HDR video playback. This makes the Pro Display XDR the ideal professional reference monitor for critical work such as color correction. See Color correct HDR video with Pro Display XDR.

On a system with macOS Catalina 10.15 or later, an SDR display, and Final Cut Pro 10.4.7 or later, the HDR image in the Final Cut Pro viewer is tone mapped to fit the properties of the SDR display. See View HDR video.

**Important:** When using Final Cut Pro on a system with an SDR display, you can use the A/V Output feature with an external reference HDR video monitor to accurately play back the wider range of colors in an HDR project. See Play media on an external display.

- Use the built-in Color Conform effect to manage color space settings automatically, or to manually convert a clip’s color space. You can also use the HDR Tools effect to convert between color spaces and HDR standards, or to limit the brightness of a clip to a specific level. See Use automatic color management and Color Conform.

- You can fix missing or incorrect color space metadata using the Color Space Override pop-up menu in the Info inspector. See Change a clip’s color space metadata.

- You can use guides in the waveform monitor to precisely measure and set video levels. Guides are useful as a quick annotation or reference point. To add a horizontal guide, click once anywhere in the waveform monitor. To remove the guide, drag it off the top or bottom of the waveform monitor.
• Because the library color-processing setting affects all projects and media in the library, it's a good idea to create a separate library for each project or deliverable. This prevents accidental color space crossover issues. See Create a new library.

• Dolby Vision 8.4 is a format designed to optimize HDR content for Apple devices. See Share to Apple devices and this Apple Support article.

Color correct ProRes RAW video

Intro to color correcting ProRes RAW video in Final Cut Pro for Mac

Apple ProRes RAW lets you work with the camera sensor’s RAW data in Final Cut Pro. Because ProRes RAW preserves the full dynamic range and color gamut captured by the camera, it’s an ideal format for creating and color correcting wide-gamut, high-dynamic-range (HDR) content. If you want to create standard-dynamic-range (SDR) content, such as high-definition broadcast (Rec. 709) video, the high dynamic range of a ProRes RAW source file must be restricted to a dynamic range suitable for viewing on an SDR display. This process is called tone mapping.

Most professional cameras today support recording in a log format. Using log enables a higher dynamic range of light levels (and in many cases, a wider color gamut) to be represented. Because many color correction workflows are based on working with log video, Final Cut Pro can automatically apply a log conversion setting to ProRes RAW media files during import. You can also use custom lookup table (LUT) effects on log-encoded video. For more information about LUTs and log conversion, see Apply LUTs.

There are three primary ways to color correct ProRes RAW video in Final Cut Pro:

• Use log conversion with built-in camera LUTs: Use the automatic log conversion applied by Final Cut Pro to color correct ProRes RAW video. See Use built-in camera LUTs to color correct ProRes RAW video.

• Use log conversion with custom LUT effects: Apply log conversion to ProRes RAW video, so that you can color correct it as if it were log video, and then use a custom LUT effect to convert from log to the output color space. See Use custom LUT effects to color correct ProRes RAW video.

• Color correct directly without LUTs: Turn off automatic log conversion, which lets you color correct ProRes RAW video as HDR video, whether library color processing is set to Standard or Wide Gamut HDR. See Color correct ProRes RAW video directly without LUTs.

Note: For maximum control of your ProRes RAW color correction workflow, you can use a ProRes RAW plug-in, which takes advantage of the unique properties of the cameras, sensors, and lenses that were used to produce your ProRes RAW media. See Adjust ProRes RAW camera settings and Apple ProRes RAW.
Use built-in camera LUTs to color correct ProRes RAW video in Final Cut Pro for Mac

Final Cut Pro can process ProRes RAW video automatically on import. Final Cut Pro does this by applying a RAW-to-log conversion setting and by applying a built-in camera LUT. Both settings are applied based on metadata in the video file that identifies the camera maker. If the metadata is missing (for example, if it was lost during transcoding), you can view or change either setting.

Using built-in camera LUTs with log conversion allows you to color correct ProRes RAW video as if it were SDR or HDR video, depending on your library color-processing setting. When your library is set to Standard color processing, you can color correct ProRes RAW video as if it were SDR video. With your library set to Wide Gamut HDR, you can color correct ProRes RAW video as if it were HDR video.

Confirm or change the RAW to Log setting

With the RAW to Log setting applied, ProRes RAW files behave just like conventional log video and can be edited the same way. Because ProRes RAW files contain metadata that identifies the camera manufacturer, Final Cut Pro can apply the correct log function (such as Canon Log 2, Panasonic V-Log, or Sony S-Log3) during import. You can also manually adjust the RAW to Log setting.

1. In Final Cut Pro, select one or more video clips recorded with ProRes RAW.
2. If the Info inspector isn’t already shown, choose Window > Show in Workspace > Inspector, then click the Info button at the top.
3. At the bottom of the inspector, click Modify ProRes RAW Settings.
4. In the ProRes RAW Settings window, click the RAW to Log pop-up menu and choose an option.

For more information, see Adjust ProRes RAW camera settings.

5. Click the Close button to close the ProRes RAW Settings window.

**Confirm or change the Camera LUT setting**

Because log video footage looks flat and gray, Final Cut Pro can apply a Camera LUT setting so that the image reflects the vibrancy of the original scene. A camera LUT converts the log-encoded image to an image in the intended output color space in a way that looks pleasing to the eye.

As with all video shot with log encoding, Final Cut Pro automatically applies the Camera LUT setting based on metadata in the file that identifies the camera maker. You can view or change the Camera LUT setting in the Info inspector.
1. In Final Cut Pro, select one or more video clips recorded with ProRes RAW.

2. If the Info inspector isn't already shown, choose Window > Show in Workspace > Inspector, then click the Info button at the top.

3. Click the Metadata View pop-up menu in the bottom-left corner, then choose either General, Extended, or Settings.

4. In the Camera LUT pop-up menu, confirm the current setting, or choose a different setting.

   The type of conversion performed by the built-in camera LUT depends on the library color-processing setting. When color processing is set to Standard, the log conversion applies tone mapping to reduce the original high dynamic range of the log content to a range suitable for SDR video.

   To make the full dynamic range of the original video available in the working color space, set the library color processing to Wide Gamut HDR. See Set library color processing, below.
Set library color processing

1. In Final Cut Pro, select the library in the Libraries sidebar, choose File > Library Properties, then click the Modify button at the top of the inspector.

2. In the window that appears, select one of the following:
   - **Standard**: The log conversion applies tone mapping to reduce the original high dynamic range of the log content to a range suitable for SDR video. When your library is set to Standard color processing, you can color correct ProRes RAW video as if it were SDR video.
   - **Wide Gamut HDR**: The built-in camera LUT settings do not apply tone mapping and preserve the full dynamic range of log source media when converting to the working space. With your library set to Wide Gamut HDR, you can color correct ProRes RAW video as if it were HDR video.

You can add ProRes RAW clips directly to an HDR project in the timeline—for example, a project set to Rec. 2020 PQ or Rec. 2020 HLG—and monitor them using a professional reference monitor such as the Apple Pro Display XDR. You can easily color correct the clips using the advanced color correction tools. See Intro to color correction effects and Color correct HDR video with Pro Display XDR.

*Note*: If you need to fix incorrect or missing color space metadata in your video clips, see Change a clip's color space metadata.

Use custom LUT effects to color correct ProRes RAW video in Final Cut Pro for Mac

You can use a custom LUT effect (instead of a built-in camera LUT) to color correct ProRes RAW video as though it were log video.

The LUT effect provides the conversion from log to the output color space. You can purchase and download LUT effects from a variety of sources, or you can create one yourself using inexpensive color correction software or plug-ins. You import and apply LUT effects using the Custom LUT effect in the Final Cut Pro Effects browser.
Step 1: Change the Camera LUT setting to None

1. In Final Cut Pro, select one or more video clips recorded with ProRes RAW.
2. If the Info inspector isn’t already shown, choose Window > Show in Workspace > Inspector, then click the Info button at the top.

3. Click the Metadata View pop-up menu in the bottom-left corner, then choose either General, Extended, or Settings.
4. Click the Camera LUT pop-up menu and choose None.
   
   When Camera LUT is set to None, the color correction tools (such as Color Wheels, Color Curves, and Color Adjustments) and other effects operate on the log-encoded values. No tone mapping is applied to the source, and no dynamic range is lost.

Step 2: Apply color correction and any other video effects

Make adjustments to color balance, exposure, and white balance.

In Final Cut Pro, with a ProRes RAW clip selected in the timeline, do any of the following:

- Adjust the ISO setting and color temperature: See Adjust ProRes RAW camera settings.
- Apply color correction: See Intro to color correction.
- Apply video effects: See Intro to clip effects.
Step 3: Import and apply a custom LUT effect

You use the Custom LUT effect in the Effects browser (added as the last effect in the effects list) to import and apply a 3DLUT file that provides the conversion from log to the output color space.

1. In Final Cut Pro, select the ProRes RAW clips in the timeline.
2. To open the Effects browser, choose Window > Show in Workspace > Effects.
3. Select the Color category on the left, then double-click Custom LUT to apply the effect to the selected clip.
4. If the Video inspector isn’t already shown, choose Window > Show in Workspace > Inspector, then click the Video button at the top.
5. In the Custom LUT section of the Video inspector, click the LUT pop-up menu and choose “Choose Custom LUT.”
   
   Note: If you previously imported a LUT effect, you can choose Recent and then choose from a list of recently used LUT effects.

6. In the window that appears, navigate to the LUT file you want to import, select it, then click Open.

   The LUT effect you imported appears as the selected LUT at the top of the Custom LUT section.

   ![Imported LUT effect](image)

7. Click the Input pop-up menu and choose the color space the LUT effect converts from.
8. Click the Output pop-up menu and choose the color space the LUT effect converts to.

   Note: Make sure the Custom LUT effect is the last effect in the effects list. If it isn’t, you can simply drag it to the bottom of the list.
Color correct ProRes RAW video directly without LUTs in Final Cut Pro for Mac

You can color correct ProRes RAW video as HDR video, regardless of the library color-processing setting. To do this, you turn off the RAW-to-log conversion and camera LUT settings automatically applied by Final Cut Pro. (For more information about these settings, see Use built-in camera LUTs to color correct ProRes RAW video.)

1. In Final Cut Pro, select one or more video clips recorded with ProRes RAW.
2. If the Info inspector isn’t already shown, choose Window > Show in Workspace > Inspector, then click the Info button at the top.
3. Click the Metadata View pop-up menu in the bottom-left corner, then choose either General, Extended, or Settings.
4. Click the Camera LUT pop-up menu and choose None.
5. At the bottom of the inspector, click Modify ProRes RAW Settings.
6. In the ProRes RAW Settings window, click the RAW to Log pop-up menu and choose None.

![ProRes RAW Settings window with RAW to Log set to None.](image)

For more information, see Adjust ProRes RAW camera settings.

No tone mapping is applied to the source, and the full dynamic range is available in the working space, even in libraries set to Standard color processing. Although highlights may initially appear blown out, you can correct this using color correction tools, such as Color Wheels, Color Curves, and Color Adjustments.

**Apply LUTs in Final Cut Pro for Mac**

A lookup table (LUT) is a set of data that enables a numeric transformation of pixel values to change the way an image looks.

A common use of LUTs in video post-production is *log conversion*. Many modern cameras have a *log* or *wide-dynamic-range* recording option that provides more f-stops of exposure latitude in the image. Video footage recorded with this option looks “flat” and gray, but you can apply LUTs to change the appearance of log footage to a standard broadcast specification, such as Rec. 709.

Another common use of LUTs is to stylize video clips with a particular “look.” Beyond just matching some objective model of exposure, you can subtly mix color to enhance the story you’re telling with your project. Color adjustments can alter the audience’s perception of the scene being played, changing a program’s mood.
What are camera LUTs and custom LUT effects?

Final Cut Pro supports two categories of LUTs:

- **Camera LUTs** (also known as *camera log conversion LUTs*) provide log processing for media from video cameras that have a log recording option. When you import log media, Final Cut Pro detects metadata in the media identifying the log format and automatically applies the appropriate built-in camera LUT, converting the media to the working space of the current library. If the library is set to Wide Gamut HDR, camera LUTs preserve the full dynamic range of the log media. Depending on the source camera, these built-in camera LUTs also take into account metadata such as camera exposure index, ISO setting, and white balance.

  Camera LUTs are applied at the media level (across the library) and are applied before any clip effects. In contrast, custom LUT effects (described below) are clip effects that can be applied at any position in the effect order.

  You can also import additional camera LUTs (known as *custom camera LUTs*). Custom camera LUTs can be provided by camera manufacturers or created by your director of photography, digital imaging technician (DIT), or colorist using a third-party color-grading app. You can use custom camera LUTs to correct color in your program or to apply stylized looks. See Example: Use custom camera LUTs in your workflow, below.

- **Custom LUT effects** allow you to easily create, import, or share custom looks for video clips and projects according to your creative needs. Custom LUT effects are clip effects that you apply to timeline clips from the Effects browser. You can also use custom LUT effects to apply tone mapping, allowing for a custom conversion to the project’s output color space.

Manually apply, change, or remove a camera LUT

In some cases, media files may not contain metadata that allows Final Cut Pro to apply the appropriate camera LUT automatically. For example, some cameras don’t embed this metadata, or the metadata may simply be lost if the material is transcoded. You can apply a camera LUT to one or more video clips, or switch to a different camera LUT, using the Info inspector.

*Note:* Final Cut Pro preserves the full dynamic range of the log media as long as color processing for the library is set to Wide Gamut HDR. If the library is set to either Standard or Wide Gamut (Deprecated) when you apply a camera LUT, the media is *tone mapped* (downgraded) to the narrower standard dynamic range (SDR). See Intro to wide color gamut and HDR.

1. In Final Cut Pro, select one or more video clips recorded with the log option.
2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Info button at the top of the inspector.

4. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose General, Extended, or Settings.

5. Click the Camera LUT pop-up menu and choose an option for converting the appearance of your footage:
   - **None**: Turns off log processing.
   - **Apple Log**: Uses Apple’s 3D LUT to convert Apple Log to Rec. 709.
   - **ARRI Log C**: Applies ARRI Log C linearization with a default tone mapping.
   - **ARRI Log C (3D LUT)**: Uses the 3D LUTs embedded in the media to apply a custom look.
   - **ARRI LogC4**: Uses ARRI’s ALEXA 35 LogC4 3D LUTs to convert LogC4 to Rec. 709/Rec. 2020.
   - **Blackmagic Design Film**: Applies the appropriate linearization and a tone mapping for the Blackmagic Cinema Camera and the Blackmagic Pocket Cinema Camera.
   - **Blackmagic Design Film 4K**: Applies the appropriate linearization and a tone mapping for the Blackmagic Production Camera 4K.
   - **Canon Log**: Applies the appropriate linearization and Canon’s (1D) viewing LUT for conversion to Rec. 709.
   - **Canon Log 2/Cinema Gamut**: Uses Canon's EOS C300 Mark II 3D LUTs to convert Canon Log 2 with Cinema Gamut to Wide DR gamma.
   - **Canon Log 3/Cinema Gamut**: Uses Canon’s EOS C300 Mark II 3D LUTs to convert Canon Log 3 with Cinema Gamut to Wide DR gamma.
   - **DJI D-Log**: Uses DJI’s Mavic 3 3D LUT to convert D-Log to Rec. 709.
   - **Fujifilm F-Log**: Uses Fujifilm’s X-H2S 3D LUT to convert F-Log to WDR Rec. 709.
   - **Fujifilm F-Log2**: Uses Fujifilm's X-H2S 3D LUT to convert F-Log2 to WDR Rec. 709.
   - **Nikon N-Log**: Uses Nikon’s Z 6 3D LUT to convert N-Log to Rec. 709.
   - **Panasonic V-Log**: Uses Panasonic’s Varicam 35 3D LUTs to convert V-Log to V-709/V-2020.
- **Sony S-Log2/S-Gamut**: Applies the appropriate linearization and 709(800%) MLUT tone mapping for footage shot with the S-Log2/S-Gamut setting on Sony cameras such as the F5 and F55.

- **Sony S-Log3/S-Gamut3**: Applies the appropriate linearization and 709(800%) MLUT tone mapping for footage shot with the S-Log3/S-Gamut3 setting on Sony cameras such as the F5 and F55.

- **Sony S-Log3/S-Gamut3.Cine**: Applies the appropriate linearization and 709(800%) MLUT tone mapping for footage shot with the S-Log3/S-Gamut3.Cine setting on Sony cameras such as the F5 and F55.

If you’ve imported custom camera LUTs, you can choose one from the Custom Camera section of the pop-up menu.

Final Cut Pro applies the camera LUT you chose, and alters the look of the video clip accordingly. (The camera LUT descriptions above cover conversion to SDR. For conversion to HDR, the camera LUTs apply the appropriate linearization only.) The change is applied to all instances of the clip, in all projects and events in the current library.

**Note:** Final Cut Pro properly displays Apple ProRes media captured with the ARRI ALEXA camera Log C recording option and imported with Final Cut Pro 10.0.8 or later. If Log C media was imported into an earlier version of Final Cut Pro, Log C processing is disabled by default for that media.

**Import a custom camera LUT**

1. Select a video clip in the Final Cut Pro browser or timeline.
2. In the Info inspector, click the Metadata View pop-up menu in the bottom-left corner and choose General, Extended, or Settings.

3. Click the Camera LUT pop-up menu and choose Add Custom Camera LUT.
4. In the window that appears, navigate to the LUT file you want to import, and select it.
   
   You can import 3D LUT files with the filename extensions .cube and .mga. You can select single files, multiple files, or a folder of files.
5. Click the Output Color Space pop-up menu and choose the target color space that the custom camera LUT converts to.
   
   The target color space is usually indicated in the custom camera LUT name.
6. Click Open.
The custom camera LUT you imported appears in the Custom Camera section of the Camera LUT pop-up menu. If you imported a folder of LUT files, it appears as a submenu in that section of the pop-up menu.

To remove imported custom camera LUTs from the Camera LUT pop-up menu, choose Reveal in Finder to open the Camera LUTs folder, drag the LUT files to the Trash, and reopen Final Cut Pro.

Note: If you imported a custom camera LUT and applied it to a clip, but the LUT file is missing from the Camera LUTs folder, a yellow warning button appears next to the Camera LUT pop-up menu. Click the warning button to reimport the custom camera LUT or to replace it with a different one.

**Share a custom camera LUT**

You can easily copy imported custom camera LUTs to another computer or share them with others.

1. Select a video clip in the Final Cut Pro browser or timeline.
2. In the Info inspector, click the Metadata View pop-up menu in the bottom-left corner and choose General, Extended, or Settings.
3. To open the Camera LUTs folder in the Finder, click the Camera LUT pop-up menu and choose Reveal in Finder.
   
The Camera LUTs folder is in the following location:

   `/Users/username/Library/Application Support/ProApps/Camera LUTs/`

4. In the Finder, select the LUT files you want to share, then choose File > Compress. Compressing the files prevents any change to custom layouts during transit.
5. Transfer the resulting ZIP file (with the filename extension .zip) using email or another convenient method.
6. On the receiving Mac, double-click the ZIP file to decompress it.
7. To import the LUT file, see [Import a custom camera LUT](#), above.
Note: If you copy a library that uses an imported custom camera LUT, you must copy the custom camera LUT as a separate file. If the LUT file is missing from the Camera LUTs folder, a yellow warning button appears next to the Camera LUT pop-up menu. Click the warning button to reimport the custom camera LUT.

**Example: Use custom camera LUTs in your workflow**

If implemented correctly, custom camera LUTs offer multiple benefits to productions shooting log footage.

In Final Cut Pro, you can:

- Access the full dynamic range of log media.
- Stylize footage with custom looks to suit your filmmaking needs.
- Play back without rendering. This is essential for directors and DPs to review takes immediately, on the set.
- Apply custom camera LUTs directly in the browser. This makes viewing dailies quick and easy. (In contrast, custom LUT effects must be applied to clips in the timeline.)

Below is an outline of how you might use LUTs in your production and post-production workflows.

1. Before shooting begins, the director of photography (DP) creates a custom camera LUT on the set of a production that is using cameras with a log recording option.
2. The digital imaging technician (DIT) imports the DP’s custom camera LUT.
3. As the footage is downloaded from the camera, the DIT selects the relevant shots in the browser and applies the DP’s custom camera LUT.
4. The director and DP conduct the on-set review with the custom camera LUT applied. Clips are played back directly from the browser.
   - The organizational capabilities of Final Cut Pro (such as Keyword Collections) make it easy to quickly find the best parts of each “circle take” (a take the director considers noteworthy).
   - Because camera LUTs are applied nondestructively, the DP can replace the custom camera LUT with an updated one at any time.
5. The DIT sends out dailies (generating them directly from the browser) with the custom camera LUT applied. See [Batch sharing](#).
6. During the editing and finishing phases, editors and colorists may replace the DP’s custom camera LUT—for example, they might augment the LUT by adding one or more color correction effects. See [Intro to color correction effects](#) and [Manual color correction workflow](#).

If a more stylized look is required (such as Summer, Old Timey, Sci-Fi, and so on), editors or colorists can add custom LUT effects to the same footage. See [Import and apply a custom LUT effect](#), below.

Stylized custom LUT effects are available from a variety of third-party sources.
**Import and apply a custom LUT effect**

In contrast to camera LUTs, custom LUT effects are applied by adding a clip effect to timeline clips.

1. Select a clip in the Final Cut Pro timeline.

2. Open the Effects browser, select the Color category on the left, then double-click Custom LUT to apply the effect to the selected clip.

   See *Add video effects*.

3. If the Video inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

4. Click the Video button at the top of the inspector.

5. In the Custom LUT section of the Video inspector, click the LUT pop-up menu and choose “Choose Custom LUT.”

   *Note:* If you previously imported a custom LUT, you can choose Recent and then choose from a list of recently used custom LUT effects.

6. In the window that appears, navigate to the LUT file you want to import, and select it.

   You can import 3D LUT files with the filename extensions .cube and .mga. You can select single files, multiple files, or a folder of files.

7. Click Open.

   The LUT you imported appears as the selected LUT at the top of the Custom LUT section.

   If you imported a folder of LUT files, it appears as a submenu in the LUT pop-up menu. (In this case, choose a LUT from the submenu so that it appears as the selected LUT at the top of the Custom LUT section.)
8. Click the Input pop-up menu and choose the color space the LUT converts from.

This color space was determined when the custom LUT was created.

Note: Camera LUTs and custom LUTs typically include the names of the input (source) color space and intended output (target) color space in the LUT filename. If you're not sure which color space to choose, see the LUT creator for more information.

9. Click the Output pop-up menu and choose the color space the LUT converts to.

This color space was determined when the custom LUT was created.

10. To optionally set the amount of the original image to be blended with the adjusted image, drag the Mix slider.

Final Cut Pro applies the custom LUT and the settings you chose, and alters the look of the video clip accordingly.

**Share a custom LUT effect**

You can share custom LUTs by copying the LUT files to another Mac.

1. In the Final Cut Pro timeline, select a clip that has the custom LUT effect applied.

To apply the custom LUT effect, see [Import and apply a custom LUT effect](#), above.

2. If the Video inspector isn't already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Video button at the top of the inspector.

4. To open the Custom LUTs folder in the Finder, click the LUT pop-up menu in the Custom LUT section of the inspector and choose Reveal in Finder.

The Custom LUTs folder is in the following location:

/Users/username/Library/Application Support/ProApps/Custom LUTs/

5. In the Finder, select the LUT files you want to share, then choose File > Compress.

Compressing the files prevents any change to custom layouts during transit.

6. Transfer the resulting ZIP file (with the filename extension .zip) using email or another convenient method.

7. On the receiving Mac, double-click the ZIP file to decompress it.

8. To import the custom LUT effect, see [Import and apply a custom LUT effect](#), above.

To remove imported custom LUTs from the LUT pop-up menu, follow the steps above to open the Custom LUTs folder, drag the LUT files to the Trash, then reopen Final Cut Pro.
Note: If you copy a library that uses a custom LUT effect, you must copy the LUT as a separate file. If the LUT file is missing from the Custom LUTs folder, a yellow warning button appears next to the LUT pop-up menu. Click the warning button to reimport the LUT or replace it with a different LUT.

Measure video levels

Intro to measuring video in Final Cut Pro for Mac

Broadcast facilities have limits on the maximum values of luma and chroma that are allowable for broadcast. If a video program exceeds these limits, distortion can appear in the form of colors bleeding into one another, the whites and blacks of your program washing out, or the picture signal bleeding into the audio signal and causing audible distortion. In all these cases, exceeding standard signal levels can result in unacceptable transmission quality. When you're color correcting clips in your project, you can use the Final Cut Pro video scopes and range check overlay to make sure that the luma and chroma levels of your video stay within the parameters referred to as broadcast-safe, or acceptable for broadcast.

Final Cut Pro provides the following video measurement tools:

- Waveform monitor
- Vectorscope
- Histogram
- Range check overlay

Even if your project is not intended for broadcast, using these tools is an important part of your workflow. If the monitors you’re using don’t display color accurately or you’ve been working with the same clips for a while, you can easily get used to seeing a color cast, or blacks that aren’t quite right. The video scopes provide exact measurements of the luma and chroma levels of your clips so that you can make more informed color correction decisions. You can display multiple video scopes at once and choose from among 12 different scopes layouts. See Display video scopes.
To ensure accurate information in the video scopes and range check overlay, make sure your video clips have the correct color space metadata. See Change a clip’s color space metadata.

Additionally, you can use the Broadcast Safe filter (available in the Effects browser) as a quick way to reduce luma and chroma levels that exceed the specification limits for standard and wide-gamut color spaces in standard-dynamic-range (SDR) video media. To add the Broadcast Safe filter, see Add video effects.

Display video scopes in Final Cut Pro for Mac

You can show video scopes next to the video image in the viewer and the event viewer. You can also show video scopes in the comparison viewer when you compare video frames.

Show video scopes

1. In Final Cut Pro, do one of the following:
   - Open a video scope in the viewer: Choose View > Show in Viewer > Video Scopes (or press Command-7).
   - Open a video scope in the event viewer: Choose View > Show in Event Viewer > Video Scopes.

   You can also click the View pop-up menu in the top-right corner of the viewer, event viewer, or comparison viewer and choose Video Scopes from the Show section.

2. To choose the scope to display, click the Scope button, then choose a video scope from the top section of the menu that appears.

3. Choose the display options for the scope from the bottom section of the menu.
Change video scopes display settings

You can display up to four video scopes at the same time and choose from 12 different scopes layouts, including a vertical layout in which scopes appear below the viewer. You can also adjust brightness controls, enable quantitative guides, and display monochrome scopes.

1. Open a video scope in Final Cut Pro.
2. Click the View pop-up menu above the video scopes display and choose display settings.

- Choose a video scopes layout: Click one of the 12 layout icons.
  
  Note: If you choose a layout with multiple video scopes, each scope pane appears with its own Scope button that you can use to set the display options for that scope.

- Display scopes below the video image: Choose Vertical Layout.

- Display quantitative data and guide lines: Choose Show Guides.

- Set the video scopes display to black and white: Choose Monochrome.

- Adjust the video scopes brightness level: Drag the Brightness slider at the bottom of the menu.
Below are some examples of the many possible combinations of video scopes layouts and settings.

Vectorscope, histogram, and waveform monitor in a three-up layout

Vertical layout with four video scopes

Monochrome display with guides enabled
Waveform monitor display options in Final Cut Pro for Mac

The waveform monitor shows the relative levels of luma, chroma, RGB, or luminance (HDR Rec. 2020 PQ clips and projects only) in the clip currently being examined. These values are displayed from left to right, mirroring the relative distribution of the luma and chroma levels in the image. Spikes and dips in the displayed waveforms correspond to light and dark areas in your picture. The waveforms are also tinted to match the color of items in the video.

Note: The measurement data on the y-axis of the waveform monitor may change to reflect the color space of the current selection in either the browser or the timeline. See Intro to wide color gamut and HDR.

The Scope menu in the upper-right corner of the waveform monitor provides a variety of display options:

• **RGB Parade**: Presents three side-by-side waveform displays that show your video as separate red, green, and blue components. The waveforms are tinted red, green, and blue so that you can easily identify them.
The RGB Parade view is useful for comparing the relative levels of red, green, and blue between two clips. If one clip has more blue than another, the waveform monitor displays an elevated blue waveform for the clip with more blue and a depressed blue waveform for the other clip. Negative component values signify colors that are out of gamut. For example, a blue that is out of gamut may have negative red and green components.

- **RGB Overlay**: Combines waveforms for the red, green, and blue color components in one display.

- **Red**: Shows only the red color channel.
- **Green**: Shows only the green color channel.
- **Blue**: Shows only the blue color channel.
- **Luma**: Shows only the luma component of the video. This waveform is available only for Rec. 709, Rec. 2020, and Rec. 2020 HLG clips and projects.
- **Luminance**: Shows only the luminance component of the video. This waveform is available only for Rec. 2020 PQ clips and projects.
- **Chroma**: Shows only the chroma component of the video, with the component tinted to match the video’s colors.
• **Y’CbCr Parade**: Presents three side-by-side waveform displays for the separate Y (luma), Cb (blue color difference channel), and Cr (red color difference channel) components. The waveforms are tinted white (for luma), magenta (for Cb), and yellow (for Cr) so that you can easily identify the waveform for each component.

![Y’CbCr Parade waveform display](image)

- **IRE**: Displays the video range in IRE units. This is the only measurement unit available for Chroma and Y’CbCr Parade waveforms in the Rec. 2020 PQ color space.
- **Millivolts**: Displays the video range in millivolts.
- **Nits (cd/m²)**: Displays the video range in nits (candelas per square meter). This option is available only for Rec. 2020 PQ clips and projects.

### Vectorscope display options in Final Cut Pro for Mac

The vectorscope shows the distribution of color in your image on a circular scale. The color in your video is represented by a series of connected points that fall somewhere within this scale. The angle around the scale represents the hue displayed, with targets indicating the primary colors of red, green, and blue and the secondary colors of yellow, cyan, and magenta. The distance from the center of the scale to the outer ring represents the saturation of the color being displayed. The center of the scale represents zero saturation, and the outer ring represents maximum saturation.

![Choose vectorscope display options](image)
The vectorscope shows you at a glance the hue and intensity of the various colors in your image. After you learn to identify the colors in your clips using the vectorscope, you can more easily see where two images differ and correct them so that they match as closely as possible.

The Scope menu in the upper-right corner of the vectorscope provides a variety of display options:

- **100%**: Sets the reference chroma level for the color bar targets (the squares representing each color in a standard color bar test signal) at 100 percent saturated chroma. Use this when your source media uses 100 percent color bars as its reference.
- **133%**: Sets the reference chroma level for the color bar targets at 75 percent saturated chroma. Use this when your source media uses 75 percent color bars as its reference.
- **Vector**: Uses a normal chroma hue reference, with red near the top.
- **Mark3**: Uses a 90-degree rotated chroma hue reference, with red on the right side.
- **Show/Hide Skin Tone Indicator**: Shows or hides the diagonal line that represents the human skin tone chroma phase, which is between the yellow and red color bar targets.

**Histogram display options in Final Cut Pro for Mac**

The histogram provides a statistical analysis of the image by calculating the total number of pixels of each color or luma level and creating a graph that shows the number of pixels at each percentage of luma or color. Each increment of the scale from left to right represents a percentage of luma or color, and the height of each segment of the histogram graph shows the number of pixels that correspond to that percentage.

The Scope menu in the upper-right corner of the histogram provides a variety of display options:

- **Luma**: Shows only the luma component of the video. The height of the graph at each step on the scale represents the number of pixels in the image at that percentage of luma, relative to all the other values. For example, if an image has few highlights, the histogram shows a large cluster of values in the midtones.
Using the Luma histogram view, you can quickly compare the luma of two shots so that you can adjust their shadows, midtones, and highlights to match more closely.

The shape of the graph also helps you determine the amount of contrast in an image. A low-contrast image has a concentrated clump of values nearer to the center of the graph. By comparison, a high-contrast image has a wider distribution of values across the entire width of the graph.

• **RGB Overlay:** Combines waveforms for the red, green, and blue color components in one display. If the image being examined has equal levels of two or more colors, you see the combined color:
  • Equal levels of green and blue appear as cyan.
  • Equal levels of green and red appear as yellow.
  • Equal levels of red and blue appear as magenta.
  • Equal levels of red, green, and blue appear as gray.

• **RGB Parade:** Presents three graphs that display your video as separate red, green, and blue components. The waveforms are tinted red, green, and blue so that you can easily identify them.
You can use the RGB Parade view to compare the relative distribution of each color channel across the tonal range of the image. For example, images with a red color cast have either a significantly stronger red graph or weaker green and blue graphs.

- **Red**: Shows only the red color channel.
- **Green**: Shows only the green color channel.
- **Blue**: Shows only the blue color channel.

### Detect out-of-gamut colors in Final Cut Pro for Mac

You can use the range check overlay in the viewer to quickly highlight color values in your project that exceed the acceptable limits of color space standards.

The colors highlighted by the range check overlay are determined by the color space (gamut) setting for your project. See [Intro to wide color gamut and HDR](#) and [Use wide-gamut HDR color processing](#).

- Click the View pop-up menu in the top-right corner of the Final Cut Pro viewer or event viewer, then choose an option from the Range Check section at the bottom of the menu:
  - **Luma**: Detects and indicates brightness (luma) values that may exceed broadcast-safe limits for the project’s color space setting.
  - **Saturation**: Detects and indicates color (chroma) values that may exceed broadcast-safe limits for the project’s color space setting, as well as negative or excessively high R, G, or B values.
  - **All**: Detects and indicates luma and saturation values that may exceed broadcast-safe limits for the project’s color space setting.

If out-of-gamut colors are detected in the image, those areas are indicated with a pattern in the viewer.
Color correction tools and techniques

Keyframe color corrections in Final Cut Pro for Mac

In Final Cut Pro, you can create changes to color correction settings over time. For example, you can animate brightness, hue, or saturation adjustments to correct issues caused by a lighting change or a camera movement. Or you can track moving objects with shape masks built into every color correction effect.

You place keyframes at specific points in a clip to change parameter values at those points.

You can set keyframes in color correction effects in the timeline or in the Color inspector. To see keyframes in the timeline, you need to display the Video Animation editor for the clip.

For more information about using keyframes, see Intro to video keyframing.

1. Add a color correction effect to a clip in the Final Cut Pro timeline.
2. Do one of the following:
   • Select the clip in the timeline, then choose Clip > Show Video Animation (or press Control-V).
   • Control-click a clip in the timeline and choose Show Video Animation.

Each effect in the Video Animation editor has a separate area for adding keyframes. The color correction effect you added appears in the list of effects.

3. In either the Video Animation editor or the Color inspector, select the color correction effect for which you want to add keyframes.

   Note: For some effects, you can display and keyframe individual parameters in the Video Animation editor. See Add keyframes.
4. Do one of the following:

- *In the Video Animation editor:* Option-click (or press Option-K) at a point on the horizontal effect control where you want to add the keyframe.

  Keyframes for individual parameters appear as white diamonds. Keyframes for multiple parameters appear as double diamonds. Because color correction keyframes control all parameters in a given color correction effect, they always appear as double diamonds.

- *In the Color inspector:* Position the playhead in the timeline at the point where you want to add a keyframe, then click the Keyframe button at the top of the Color inspector (or press Option-K).

  After you add a keyframe, the Keyframe button becomes solid yellow, indicating that the playhead is currently on this keyframe.

  When you move the playhead in the timeline, arrows appear next to the Keyframe button in the Color inspector to indicate which side of the playhead has keyframes. To go to the previous keyframe, click the left arrow. To go to the next keyframe, click the right arrow.

5. Add keyframes as needed.

  **Tip:** After you've added one keyframe, you can add another automatically by moving the playhead in the timeline and then adjusting the color correction effect in the Color inspector.
Add transitions between color corrections in Final Cut Pro for Mac

The most powerful and accurate way to change a color correction over time is to use keyframes to animate the changes. However, there may be times when you want to use a transition instead. For example, if you want a scene to gradually highlight the face of an actor, you could use a transition to dissolve between the original clip and a second instance of the clip that has a shape mask around the face and a color correction that darkens the image outside of the mask.

1. In Final Cut Pro, temporarily switch to the Blade tool by holding down the B key.
2. In the timeline, click a video clip at the point where you want to change between color corrections.
   The clip splits into two clips.
3. **Apply a different color correction** to each clip.
   You can also leave one clip uncorrected and apply a color correction to the other.
   The color correction could be an exaggerated tint, an exposure change, or any other noticeable adjustment.
4. Select the edit point between the two clips, then press Command-T to insert a cross dissolve.
   When you play the clip, one color correction dissolves into the other as the edit point is passed.

Save color correction presets in Final Cut Pro for Mac

You can save a clip’s color correction settings as a preset, making it easy to apply those settings to other clips in the same project or a different project.

Save a color correction preset

1. In the Final Cut Pro timeline, select a clip that has the color correction look you want to save, then open the color correction in the Color inspector.
2. Click the Save Effects Preset button in the lower-right corner of the Color inspector.
3. In the window that appears, adjust the settings for the preset:
   • **Name**: Type a name for the preset.
   • **Category**: Choose the Effects browser category your preset will appear in.
   • **Attributes**: Make sure the checkboxes for the attributes you want to include in the preset are selected.
   • **Keyframe Timing**: If your color correction preset includes keyframes, select one of the following:
     • **Maintain**: Leaves the duration between keyframes unchanged.
     • **Stretch to Fit**: Adjusts the keyframes in time to match the duration of the destination clip.
4. Click Save.
Apply a color correction preset

You apply a color correction preset as you would apply any other clip effect from the Effects browser.

1. Select a clip in the Final Cut Pro timeline, then click the Effects button in the top-right corner of the timeline (or press Command-5).

2. In the Effects browser, select the color correction preset that you saved previously.

3. Do one of the following:
   • Drag the preset to the timeline clip you want to apply it to.
   • Double-click the preset thumbnail to apply the preset to the selected clip.

The preset’s adjustments are applied to the selection. After the preset has been applied, you can modify its settings using the Color inspector.

For more information about adding clip effects, see Add video effects.

Compare color corrections in Final Cut Pro for Mac

You can show the comparison viewer next to the viewer to compare the color in any two frames of video side by side. You can also save up to 30 video frames for future comparisons. See Compare two video frames.

Turn iMovie adjustments on or off in Final Cut Pro for Mac

When editing a project in iMovie, you can adjust several video attributes, such as exposure, brightness, and saturation. If you import an iMovie project or event that has these adjustments into Final Cut Pro, the adjustments are retained and appear in the Effects area of the Video inspector.

Although you can’t modify the adjustments added in iMovie, you can choose whether they are applied to the clip.

1. In the Final Cut Pro timeline, select a clip with iMovie adjustments.

2. In the Effects section of the Video inspector, select or deselect the iMovie Color Effect checkbox.
Share your project

Intro to sharing projects in Final Cut Pro for Mac

Final Cut Pro provides a variety of preconfigured export settings, called destinations, that you can use to output your project or clip. For example, you can export a project or clip as a file, export it for viewing on Apple devices such as iPhone and iPad, add it to social media websites, or burn it to a disc. You can also save a frame from your movie or export an image sequence. Each of these options uses a different destination.

When you first open Final Cut Pro, a default set of destinations appears in the Share menu.
Details about each destination in the default set are listed in the table below.

<table>
<thead>
<tr>
<th>Destination</th>
<th>Use to</th>
</tr>
</thead>
<tbody>
<tr>
<td>DVD</td>
<td>Burn your project to a standard-definition (SD) DVD. See Create optical discs and disk images.</td>
</tr>
<tr>
<td>Export File (default)</td>
<td>Export your project as a QuickTime movie file. See Export final mastering files.</td>
</tr>
<tr>
<td>Apple Devices 720p</td>
<td>Export files for playback on most Apple devices, including iPod touch, iPhone, iPad, and Apple TV. This option creates output files with dimensions up to 720p. Of the three Apple Devices options, this option creates files with the lowest data rates and smallest file sizes.</td>
</tr>
<tr>
<td>Apple Devices 1080p</td>
<td>Export files for playback on many Apple devices, including models of iPod touch, iPhone, iPad, and Apple TV. This option creates output files with dimensions up to 1080p.</td>
</tr>
<tr>
<td>Apple Devices 4K</td>
<td>Export files for playback on recent models of iPhone, iPad, and Apple TV. This option creates output files with dimensions up to 4K. Of the three Apple Devices options, this option creates files with the highest data rates and largest file sizes.</td>
</tr>
<tr>
<td>Social Platforms</td>
<td>Prepare your projects and clips for sharing on the web. See Share on the web.</td>
</tr>
</tbody>
</table>

You can easily add destinations or replace the default set of destinations with your own customized destinations. For example, if you want to save a frame from your movie as a Photoshop file, you need to add the Save Current Frame destination to your set and specify that the destination export a Photoshop file. You create and modify destinations in the Destinations pane of Final Cut Pro settings.

You can also create a bundle of destinations to export several types of output at once. See Create share destinations.

To further customize your output, you can use Compressor, the professional transcoding app. See Share using Compressor.

Share to Apple devices in Final Cut Pro for Mac

To export your project to an Apple device such as iPhone, iPad, or iPod touch, or to play your project on a home theater system using Apple TV, you must send the project to the Apple TV app. (If you’re using macOS 10.14 or earlier, you send your project to iTunes.)

You can use the default export settings or customize the settings to suit your needs. For information about customizing settings, see Create share destinations and Change metadata for shared items.
1. In Final Cut Pro, do one of the following:
   • Select one or more projects or clips in the browser.
     Note: You can’t mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.
   • Select ranges in one or more clips in the browser.
     See Set multiple ranges in the browser.
   • Select a range in a project in the timeline.
     Note: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

3. Do one of the following:
   • Choose File > Share, then choose an Apple Devices destination from the submenu.
   • Click the Share button in the toolbar, then click an Apple Devices destination.

   The Info pane of the Share window appears, showing the video image on the left and project information on the right. To skim the video, move the pointer over the image.

   Note: If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.
4. To modify project or clip attributes, such as the title and description, enter information in the appropriate field.

See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.

Important: By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.

5. To modify the settings for the exported file, such as the format or resolution, click Settings at the top of the Share window, then make your changes.

For detailed descriptions of each setting, see Export File and Apple Devices destinations.

If you change the destination’s settings, the changes are saved as the default settings for the destination. See Intro to Destinations settings.

Note: Dolby Vision 8.4 is a format designed to optimize HDR content for Apple devices. See this Apple Support article.

6. To add the output media file to your Apple TV library, click the Action pop-up menu in the Settings pane, then choose Home Videos in the Add to TV section.

7. To review the tracks that will be included in the output media file, click Roles at the top of the Share window.

The Roles pane displays the tracks of the output media file and the roles included in each track.

8. To include captions in the export, click Roles at the top of the Share window, then do one of the following:

• Embed captions in the output video file: For each video track or file, click the blue Captions button, then click the Embed CEA-608 pop-up menu and choose a language version.

• Export captions as separate files: In the Captions section, select the caption formats you want to export, then click the Timing pop-up menu and choose an option:
  • Relative: Calculate the caption start time by subtracting the project’s start time.
  • Absolute: Use each caption’s actual start time, regardless of the project's start time.

• Burn captions in to the output video file: For each video track or file, click the blue Captions button, then click the “Burn in captions” pop-up menu and choose a language version.

For information about adding captions to your project, see Intro to captions and Create captions.
9. To see a list of devices that will play the exported file, move the pointer over the compatibility icon in the lower-right corner.

![List of devices compatible with the exported file](image)

Information about the file that will be exported, including the frame size and frame rate, appears at the bottom of the window.

10. When you’re ready to export your project, clip, or range, click Share.

   If you chose to add the output media file to your Apple TV library, the Apple TV app opens (if it wasn’t open), and the exported file appears in the Home Videos category.

   You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

   When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.

   Note: If you added chapter markers to your project, chapter marker thumbnails are placed at the appropriate location when sharing to disc (DVD and Blu-ray disc) and MV4, QuickTime, and MP4 formats (for playback using QuickTime Player and Apple devices). See Add chapter markers.
Export files

Export final mastering files in Final Cut Pro for Mac

You can use the Export File command to export your completed project as a high-quality file that can be used as the source media for the final stages of professional post-production or broadcast and distribution. You may also consider this option when you want to use the media in another app, copy the media to an external storage device for a client to review, or publish the media to a website for which there are no preconfigured destination settings in Final Cut Pro. Your project is exported as a QuickTime movie.

You can also use the Export File option to export an MXF file.

1. In Final Cut Pro, do one of the following:
   - Select one or more projects or clips in the browser.
     
     Note: You can't mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.
   - Select ranges in one or more clips in the browser.
     
     See Set multiple ranges in the browser.
   - Select a range in a project in the timeline.
     
     Note: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you're sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn't exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

3. Do one of the following:
   - Choose File > Share > Export File (or press Command-E).
   - Click the Share button in the toolbar, then click Export File.
4. In the Share window that appears, do any of the following:

   - Move the pointer over the image to skim the video.
   
     If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.
   
   - In the Info pane, view and modify project or clip attributes, such as the title and description.
     
     See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.
     
     Important: By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.
   
   - At the bottom of the window, view information about the file that will be exported, including frame size and frame rate, audio channels and sample rate, duration, output file type, and file size.
     
     For some destinations, you can also view a list of devices that will play the exported file. To view the compatible devices, move the pointer over the Compatibility icon in the lower-right corner.

5. To view or change the Export File destination settings, click Settings at the top of the Share window.

   The available settings vary based on which format you choose from the Format pop-up menu. For detailed descriptions of each setting, see Export File and Apple Devices destinations.
   
   For information about output file formats, see Supported export formats.
   
   Note: If you change the destination’s settings, the changes are saved as the default settings for the destination.

6. To export roles as separate video, title, audio, or caption tracks in the output media file, click Roles at the top of the Share window, then specify the roles to export.

   See Share roles as files.

7. Click Next, choose a location for the exported files, then click Save.
You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.

Note: If you added chapter markers to your project, chapter marker thumbnails are placed at the appropriate location when sharing to disc (DVD and Blu-ray disc) and MV4, QuickTime, and MP4 formats (for playback using QuickTime Player and Apple devices). See Add chapter markers.

Export MXF files in Final Cut Pro for Mac

MXF is an industry-standard file format for video and audio. Like QuickTime files, MXF files contain information about the media inside. This information, also called metadata, can include frame rate, frame size, creation date, and custom data added by a camera operator, an assistant, or an archivist.

When you export MXF files, you can use audio roles to configure industry-standard channel layouts.

1. In Final Cut Pro, do one of the following:
   • Select one or more projects or clips in the browser.
     Note: You can't mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.
   • Select ranges in one or more clips in the browser.
     See Set multiple ranges in the browser.
   • Select a range in a project in the timeline.
     Note: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

3. Do one of the following:
   • Choose File > Share > Export File (or press Command-E).
   • Click the Share button in the toolbar, then click Export File.
4. In the Share window that appears, do any of the following:

- Move the pointer over the image to skim the video.
  
  If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.

- In the Info pane, view and modify project or clip attributes, such as the title and description.
  
  See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.

  **Important:** By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.

- At the bottom of the window, view information about the file that will be exported, including frame size and frame rate, audio channels and sample rate, duration, output file type, and file size.
  
  For some destinations, you can also view a list of devices that will play the exported file. To view the compatible devices, move the pointer over the Compatibility icon in the lower-right corner.

5. Click Settings at the top of the Share window.

6. In the Settings pane, click the Format pop-up menu and choose MXF.
7. Click the “Video codec” pop-up menu and choose a video codec for the MXF file.

The available video codecs are determined by the resolution and frame rate of your project.

8. Click Roles at the top of the Share window.

9. In the Roles pane, click the “Roles as” pop-up menu and choose one of the following:
   • Multitrack MXF File (the default setting)
   • A custom preset
     For information about creating a custom preset, see Create and modify custom presets.

   The default Multitrack MXF File setting presents a list of tracks (including a video track, a track for each audio subrole assignment, and a caption track).

10. Do any of the following:
   • Combine roles in a track: For any track in the list, click the Add Role pop-up menu (on the right) to add roles or subroles for the track.
   • Remove roles from a track: For any role, click the Remove button (on the right).
   • Choose an audio channel format for a track: For any audio track in the list, click the Channels pop-up menu and choose the channel format (Mono, Stereo, or Surround). See Configure audio channels.
   • Add an audio track to the export file: Click the Add Audio Track button, then choose a role or subrole and an audio channel format from the pop-up menus that appear.
   • Remove a track from the export file: Click the Remove button (with an X) to the right of the track name.
   • Burn captions in to the output video file: For each video track or file, click the blue Captions button, then click the “Burn in captions” pop-up menu and choose a language version.
• **Add captions to the export:** In the Captions section, select the caption formats you want to export, then click the Timing pop-up menu and choose an option:
  - **Relative:** Calculate the caption start time by subtracting the project's start time.
  - **Absolute:** Use each caption's actual start time, regardless of the project's start time.

Final Cut Pro will create a separate “sidecar” caption file for each language subrole in the selected caption formats and place the files in the same folder as the exported MXF file.

For information about adding captions to your project, see *Intro to captions* and *Create captions*.

• **Save a preset:** Click the “Roles as” pop-up menu and choose Save As in the Presets section.

11. Click Next, choose a location for the exported files, then click Save.

You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See *View the status of shared items*.

For more information about creating MXF files, see *Create a multi-channel MXF file with Final Cut Pro*. 
Export still images in Final Cut Pro for Mac

You can save a still-image file of any video frame in your project or in any clip in the browser.

1. In the Final Cut Pro timeline or browser, position the playhead on the video frame you want to export as a still image.

2. Do one of the following:
   - Choose File > Share > Save Current Frame.
   - Click the Share button in the toolbar, then click Save Current Frame.

   **Important:** The Save Current Frame destination doesn’t appear by default. To add it to your set of destinations and to the Share menu, choose File > Share > Add Destination, then double-click the Save Current Frame destination. See Create share destinations and Intro to Destinations settings.

3. In the Share window that appears, do any of the following:
   - Move the pointer over the image to skim the video.
     If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.
   - In the Info pane, view and modify the still-image attributes, such as the title and description.
     See Change metadata for shared items. All of the attributes associated with the project or clip are included in the still-image output file.
     **Important:** By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.
   - At the bottom of the window, view information about the file that will be exported, including frame size and output file type.
4. Click Settings to confirm the export settings or make any necessary adjustments:
   • **Export**: Choose an output file type for the still image you’re exporting.
   • **Scale image to preserve aspect ratio**: Leave this checkbox selected unless your project uses a non-square pixel format (such as 1440 x 1080) and you want to use the exported still image in another video project with the same non-square pixel properties.
   • **Burn in captions**: If you added captions to your project, you can choose a caption language to burn in to the output media file.
     
     **Note**: Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

5. Click Next.

6. Enter a name and choose a location for the exported file, then click Save.

**Note**: The Save Current Frame destination creates a still-image file. If you want to create a freeze frame or hold effect in your project, see Create freeze frames or Create hold segments.

You can monitor the progress of the transcoding in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.

---

**Export image sequences in Final Cut Pro for Mac**

You can export your project’s visuals as an image sequence—a set of sequentially numbered still-image files that are compatible with many professional finishing, compositing, and grading apps.

1. In Final Cut Pro, do one of the following:
   • Select one or more projects or clips in the browser.
     
     **Note**: You can’t mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.
   • Select ranges in one or more clips in the browser.
     See Set multiple ranges in the browser.
   • **Select a range** in a project in the timeline.
     
     **Note**: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.
2. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

3. Do one of the following:
   - Choose File > Share > Export Image Sequence.
   - Click the Share button in the toolbar, then click Export Image Sequence.

   **Important:** The Export Image Sequence destination doesn’t appear by default. To add it to your set of destinations and to the Share menu, choose File > Share > Add Destination, then double-click the Image Sequence destination. See Create share destinations and Intro to Destinations settings.

4. In the Share window that appears, do any of the following:
   - Move the pointer over the image to skim the video.
     If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.
   - In the Info pane, view and modify project or clip attributes, such as the title and description.
     See Change metadata for shared items.
   - At the bottom of the window, view information about the files that will be exported, including frame size, frame rate, and output file type.
5. Click Settings to confirm the export settings or make any necessary adjustments:
   • *Export:* Choose an output file type for the image sequence you’re exporting.
   • *Scale image to preserve aspect ratio:* Leave this checkbox selected unless your project uses a non-square pixel format (such as 1440 x 1080) and you want to use the exported image sequence in another video project with the same non-square pixel properties.
   • *Burn in captions:* If you added captions to your project, you can choose a caption language to burn in to the output media file.
     
     *Note:* Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

6. Click Next.

7. If you selected a single range, enter a name for the image sequence you’re sharing.

8. Choose a location for the exported files, then click Save.

   The image sequence files are saved in a folder with the name you entered.

You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.

**Export files for HTTP Live Streaming in Final Cut Pro for Mac**

If you want to post a movie on a streaming website, you can export an HTTP Live Streaming playlist that’s linked to a group of movie segments (such as MPEG-4 files) compressed using different settings. When hosted using the related server software, the playlist dynamically chooses the best version for a user’s device and internet connection speed.

1. In Final Cut Pro, do one of the following:
   • Select one or more projects or clips in the browser.
     
     *Note:* You can’t mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.
   • Select ranges in one or more clips in the browser.
     See Set multiple ranges in the browser.
   • **Select a range** in a project in the timeline.
     
     *Note:* To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.
3. Do one of the following:
   - Choose File > Share > Export for HTTP Live Streaming.
   - Click the Share button in the toolbar, then click Export for HTTP Live Streaming.

**Important:** The HTTP Live Streaming destination doesn’t appear by default. To add it to your set of destinations and to the Share menu, choose File > Share > Add Destination, then double-click the HTTP Live Streaming destination. See Create share destinations and Intro to Destinations settings.

4. In the Share window that appears, do any of the following:
   - Move the pointer over the image to skim the video. If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.
   - In the Info pane, view and modify project or clip attributes, such as the title and description.
     See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.
     **Important:** By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.
   - At the bottom of the window, view information about the files that will be exported, such as frame size and frame rate, audio channels and sample rate, duration, output file type, and file size.
5. Click Settings.

6. Select one or more network types on which the movie will be streamed (Cellular or Broadband).

7. To speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing, select “Allow export segmentation.”

   See Speed up exports with simultaneous processing.

8. If you added captions to your project, optionally click the “Burn in captions” pop-up menu and choose a language version.

   Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

9. Click Next.

10. If you selected a single project, clip, or range, enter a name for the file you’re sharing.

11. Choose a location for the exported files, then click Save.

   Your selection is transcoded, and the exported segments are saved in folders. An index.html file and a readme.html file containing information on how to post your project to your website are included in the export. See your server administrator.

   You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

   When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.

### Share roles as files in Final Cut Pro for Mac

You can share a project’s roles, exporting each media role as a separate media stem. For example, you can export a project’s dialogue, music, and sound effects as separate media files by assigning roles to the dialogue, music, and sound effects, and then exporting the roles.

If your project contains captions, you can choose which language version (subrole) to export. You can embed captions in the output video file or export them as separate files. See Export captions.

If you want to export the same roles from another project or clip later, you can save your settings as a preset.
Share roles as separate files
You can export media roles as a combined, multitrack QuickTime or MXF file, or as separate audio or video files. You can also choose mono, stereo, or surround output for your audio channels.

1. In Final Cut Pro, do one of the following:
   • Select one or more projects or clips in the browser.
     *Note:* You can’t mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.
   • Select ranges in one or more clips in the browser.
     See Set multiple ranges in the browser.
   • Select a range in a project in the timeline.
     *Note:* To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. Do one of the following:
   • Choose File > Share > Export File.
   • Click the Share button in the toolbar, then click Export File.

   ![Share settings](image)

   *Note:* You can also choose another destination you created based on the Export File destination.

3. Click Settings at the top of the Share window, then specify the following settings (available settings depend on your source media):
   • **Format:** Choose a mastering format (Video and Audio, Video Only, or Audio Only). For information about exporting MXF files, see Export MXF files.
   • **Video codec:** The source codec is listed by default. Depending on your source media, you can choose another codec.
   • **Resolution:** The resolution (based on the source footage) is provided. Depending on your source media, you can choose another resolution.
   • **Color space:** The color space (based on the project setting) is provided. See Modify a project’s settings and Use wide-gamut HDR color processing.
   • **Audio file format:** The source format is listed by default. Depending on your source media, you can choose another audio format.
   • **Include chapter markers:** Select the checkbox to include chapter markers with the exported file (or files).
   • **Allow export segmentation:** Speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing. See Speed up exports with simultaneous processing.
   • **Open with:** Choose what you want to happen after the export is complete. See Export File and Apple Devices destinations.
4. Click Roles at the top of the Share window.

5. In the Roles pane, click the “Roles as” pop-up menu and choose how you want the roles exported.

   Note: The options available in this pop-up menu change based on your choices in the Format and “Audio file format” pop-up menus in the Settings pane.

   • QuickTime Movie: Exports all of the roles in the project as a single QuickTime movie.
     If you choose this option, skip step 7.
   • Multitrack QuickTime Movie: Exports the roles you specify as a single QuickTime movie.
   • Separate Files: Exports each of the video and audio roles you specify as a separate file.
   • Video Only as Separate Files: Exports each of the video roles you specify as a separate file.
   • Audio Only as Separate Files: Exports each of the audio roles you specify as a separate file.

6. To add captions to the export files, do any of the following:

   • Embed captions in the output video file: For each video track or file, click the blue Captions button, then click the Embed CEA-608 pop-up menu and choose a language version.
   • Burn captions in to the output video file: For each video track or file, click the blue Captions button, then click the “Burn in captions” pop-up menu and choose a language version.
   • Export captions as separate files: In the Captions section, select the caption formats you want to export, then click the Timing pop-up menu and choose an option:
     • Relative: Calculate the caption start time by subtracting the project’s start time.
     • Absolute: Use each caption’s actual start time, regardless of the project’s start time.

   For information about adding captions to your project, see Intro to captions and Create captions.

7. If you chose any format other than QuickTime Movie in step 5, do any of the following:

   • Add a track or file to the export: Click a purple Add Track or Add File button on the right, then choose a role or subrole.
   • Combine roles in an output track or file: For any track or file in the list, click the purple Add Role pop-up menu (on the right) to add roles or subroles.
   • Remove roles from a track or file: For any role, click the white Remove button (on the right).
   • Choose an audio channel format for a track: For any audio track or file in the list, click the Channels pop-up menu and choose the channel format (Mono, Stereo, or Surround). See Configure audio channels.
   • Remove a track or file from the export: Click the white Remove button (with an X) to the right of the track or file name.
   • Save a preset: Click the “Roles as” pop-up menu and choose Save As in the Presets section.
8. Click Next.

9. If you selected a single project, clip, or range, enter a name for the file you're sharing.

10. Choose a location for the exported files, then click Save.

You can monitor the progress of the transcoding in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.
Create and modify custom presets
If you’ve created a customized list of roles to share, you can save it as a preset.

1. In Final Cut Pro, configure your share options using the instructions in Share roles as separate files, above.

2. In the “Roles as” pop-up menu, do any of the following:
   - Save a new preset: Choose Save As, type a name for the preset, then click Save.
   - Save changes to an existing preset: Select the preset and make your changes, then choose Save.
   - Save a modified preset as a new preset: Select the preset and make your changes, then choose Save As, type a name for the preset, and click Save.
   - Rename a preset: Select the preset, then choose Rename, type a new name for the preset, and click Save.

Custom presets that you create appear in the “Roles as” pop-up menu.

Custom presets are stored in /Users/username/Library/Application Support/ProApps/Export Presets/. To access them quickly, click the “Roles as” pop-up menu and choose Reveal User Presets in Finder.

Delete custom presets
You can delete custom presets that you no longer need.

1. Select a project or clip in Final Cut Pro, then click the Share button in the toolbar and choose Export File.

2. In the Share window, click the Settings button.

3. Click the “Roles as” pop-up menu and choose the custom preset that you want to delete.

   After you choose a preset, a checkmark appears next to its name.

4. Click the “Roles as” pop-up menu and choose Delete.

Export formats supported in Final Cut Pro for Mac
You can export to a number of formats natively using the Master File share destination. You can export to additional formats using settings in Compressor.

Note: Depending on your project settings, some of the export formats listed below may not be available.
Export File destination

All of the Export File destination formats below are available for the MOV container format (for supported source resolutions and frame rates). All of the formats below are also available for the MXF container format (with the exception of H.264, HDV, and Uncompressed 10-bit 4:2:2).

You can export to the following using the Export File share destination:

- Apple ProRes (all versions)
- AVC-Intra Class 50/100/200
- DV (including DVCAM, DVCPro, and DVCPRO50)
- DVCPro HD
- H.264
- HDV
- MPEG IMX (D-10)
- MXF
- Uncompressed 10-bit 4:2:2
- Uncompressed 8-bit 4:2:2
- XDCAM HD/EX/HD422

For more information, see Export final mastering files and Export MXF files.

Compressor setting

You can export to the following using a Compressor setting:

- AAC
- AIF
- AVC-Intra (MXF)
- CAF
- Dolby Digital (AC3 and EC3)
- FLAC
- H.264 for Blu-ray streams
- Image sequences
- MP3
- MPEG-2
- MPEG-4
- QuickTime formats
- Third-party plug-ins
- WAV

For more information, see Share using Compressor.
Share on the web in Final Cut Pro for Mac

In Final Cut Pro, you can use the Social Platforms share option to save a project or clip as a file that is ready for posting on video-sharing websites.

1. In Final Cut Pro, do one of the following:
   - Select one or more projects or clips in the browser.
     
     Note: You can't mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.
   - Select ranges in one or more clips in the browser.
     
     See Set multiple ranges in the browser.
   - Select a range in a project in the timeline.
     
     Note: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

3. Do one of the following:
   - Choose File > Share > Social Platforms.
   - Click the Share button in the toolbar, then click Social Platforms.

4. In the Share window that appears, do any of the following:
• Move the pointer over the image to skim the video.

If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.

• In the Info pane, view and modify project or clip attributes, such as the title and description.

See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.

Important: By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.

• At the bottom of the window, view information about the file that will be exported, including frame size and frame rate, audio channels and sample rate, duration, output file type, and file size.

5. Click Settings to confirm the settings and make any necessary adjustments.

See Social Platforms destination in Final Cut Pro for Mac.

6. Click Next.

7. Enter a name for the output media file, navigate to a location on your Mac or storage device where you want to save the file, and click Save.

Your project is transcoded to a MOV file with H.264 video and AAC audio, suitable for posting on video-sharing websites such as YouTube and Facebook.

8. Upload the file to the social platform using the corresponding website or app. (You must first set up an account with the video-sharing service you plan to use.)

You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.

Create optical discs and disk images in Final Cut Pro for Mac

You can burn a project, a clip, or a range selection to a standard-definition (SD) DVD or to a Blu-ray-compatible disc.

There are two ways to create a Blu-ray-compatible disc:

• Use an external optical drive that supports burning Blu-ray discs.

• Use a standard DVD burner and standard red laser media to create an AVCHD disc with high-definition (HD) video content and menus. You can play AVCHD discs in Blu-ray players if they’re compatible with AVCHD discs.

You can also create a disk image (.img) file that you can copy to an external storage device. You can send the disk image to a disc replication facility or burn it to DVD or Blu-ray disc media at a later time using Disk Utility.
Markers are added to the file on the disc at 5-minute intervals, making it possible to use the DVD or Blu-ray player’s remote to skip forward or backward 5 minutes each time you press the Next Chapter or Previous Chapter button.

*Note:* If Compressor is installed on your computer, you can use the Send to Compressor command to open the project in Compressor. See [Send your projects or clips to Compressor](https://(finalcutpromac). See [Send your projects or clips to Compressor](finalcutpromac) and the [Compressor User Guide](finalcutpromac).

**Burn an SD DVD or create an SD disk image file**

1. In Final Cut Pro, do one of the following:
   - Select a project or a clip in the browser.
   - **Select a range** in a project in the timeline or in a clip in the browser.

   *Note:* To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see [Control playback quality](finalcutpromac).

3. Do one of the following:
   - Choose File > Share > DVD.
   - Click the Share button in the toolbar, then click DVD.

4. In the Share window that appears, do any of the following:
• Move the pointer over the image to skim the video.

If you’re batch sharing (exporting multiple items), the image is replaced by a list of
the items you’re exporting.

• In the Info pane, view and modify project or clip attributes, such as the title and
description.

See Change metadata for shared items. All of the attributes associated with the
project or clip are included in the output file.

Important: By default, the title field lists the project or clip name. Changing the title
does not change the project or clip name, which is the name used for the exported
file.

• At the bottom of the window, view information about the file that will be exported,
including frame size and frame rate, audio channels and sample rate, duration,
output file type, and file size.

5. Click Settings, then choose your preferred DVD settings:

• Output Device: To burn a disc, choose an optical drive. To create a disk image (.img)
file that you can copy to an external storage device or burn to DVD media later,
choose Hard Drive.

• Layers: Choose whether to burn a single-layer or dual-layer disc.
  • Automatic: Automatically detects the type of disc you can use.
  • Single-layer: Identifies the disc as a single-layer disc. You can use this option to
  force a double-layer disc to be treated as a single-layer disc.
  • Double-layer: Identifies the disc as a double-layer disc. You can use this option to
  force the disk image to be formatted for a double-layer disc when you choose
  Hard Drive as your output device.

Important: Choosing “Double-layer” when using a single-layer disc can result in an
error during burning, depending on the project’s length.

• Build type: Choose File to save a disk image (.dmg) file, or Folder to save a set of
  files in a folder.

• Disc template: Choose an available template.

• Title: Enter the program title in the Title field. By default, the title is the project name
  in Final Cut Pro.

• Volume name: Enter the filename for the disc.

• Color space: This field can’t be edited. The values (Standard - Rec. 709 or Wide
  Gamut - Rec. 2020) are determined by the color space settings for your project. See
  Use wide-gamut HDR color processing.

• When disc loads: Specify the DVD player’s action when the disc is inserted. Choose
  Show Menu to have a main menu appear, or choose Play Movie to begin playing the
  movie immediately.

• Markers: Select the checkbox to include chapter marker text as subtitles on the
  output disc. Users can navigate between the chapter markers by pressing the Next
  Chapter or Previous Chapter button on the DVD or Blu-ray player. See Add chapter
  markers.

• Loop: Select the checkbox to add a loop movie button to the DVD menu.
• **Background, Logo image, Title image:** To add a background, logo, or title to menus, click the Add button, then select a graphic. To select a different graphic, click the Remove button (with an X), then click Add again.

• **Preview:** View a representation of the menu.

• **Include captions:** If you added CEA-608 captions to your project, you can choose the language version to include on the DVD. See Intro to captions.

• **Burn in captions:** If you added captions to your project, you can choose a caption language to burn in to the output media file.

  *Note:* Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

6. Do one of the following:

   • *If you’re burning to a disc (instead of creating a disk image):* Click the Eject button to the right of the Output Device pop-up menu, then insert a blank disc into your disc-burning device and click Burn.

   • *If you’re creating a disk image file:* Click Next, then enter a name for the file, choose a location to save it, and click Save. (By default, Final Cut Pro burns disk images as single-layer media, adjusting the bit rate accordingly.)

**Burn a Blu-ray or AVCHD disc, or create a disk image Blu-ray file**

1. In Final Cut Pro, do one of the following:

   • Select a project or a clip in the browser.

   • **Select a range** in a project in the timeline or in a clip in the browser.

     *Note:* To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

3. Do one of the following:

   • Choose File > Share > Blu-ray / AVCHD.

   • Click the Share button in the toolbar, then click Blu-ray / AVCHD.

**Important:** The Blu-ray / AVCHD destination doesn’t appear by default. To add it to your set of destinations and to the Share menu, choose File > Share > Add Destination, then double-click the Blu-ray / AVCHD destination. See Create share destinations and Intro to Destinations settings.
4. In the Share window that appears, do any of the following:

- Move the pointer over the image to skim the video.
  
  If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.

- In the Info pane, view and modify project or clip attributes, such as the title and description.
  
  See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.

  **Important:** By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.

- At the bottom of the window, view information about the file that will be exported, including frame size and frame rate, audio channels and sample rate, duration, output file type, and file size.

5. Click Settings, then choose your preferred Blu-ray / AVCHD settings:

- **Output Device:** To burn a disc, choose an optical drive. To create a disk image (.img) file that you can copy to an external storage device or burn to optical media later, choose Hard Drive.

- **Layers:** Choose whether to burn a single-layer or dual-layer disc.
  
  - **Automatic:** Automatically detects the type of disc you can use.
  
  - **Single-layer:** Identifies the disc as a single-layer disc. You can use this option to force a double-layer disc to be treated as a single-layer disc.
  
  - **Double-layer:** Identifies the disc as a double-layer disc. You can use this option to force the disk image to be formatted for a double-layer disc when you choose Hard Drive as your output device.

  **Important:** Choosing “Double-layer” when using a single-layer disc can result in an error during burning, depending on the project’s length.

- **Build type:** Choose File to save a disk image (.dmg) file, or Folder to save a set of files in a folder.

- **Disc template:** Choose an available template.
• **Title:** Enter the program title in the Title field. By default, the title is the project name in Final Cut Pro.

• **Volume name:** Enter the filename for the disc.

• **Color space:** This field can't be edited. The values (Standard - Rec. 709 or Wide Gamut - Rec. 2020) are determined by the color space settings for your project. See [Use wide-gamut HDR color processing](#).

• **When disc loads:** Specify the Blu-ray player's action when the disc is inserted. Choose Show Menu to have a main menu appear, or choose Play Movie to begin playing the movie immediately.

• **Markers:** Select the checkbox to include chapter marker text as subtitles on the output disc. Users can navigate between the chapter markers by pressing the Next Chapter or Previous Chapter button on the Blu-ray player. See [Add chapter markers](#).

• **Loop:** Select the checkbox to add a loop movie button to the Blu-ray menu.

• **Background, Logo image, Title image:** To add a background, logo, or title to menus, click the Add button, then select a graphic. To select a different graphic, click the Remove button (with an X), then click Add again.

• **Preview:** View a representation of the menu.

• **Burn in captions:** If you added captions to your project, you can choose a caption language to burn in to the output media file.

  **Note:** Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

6. Do one of the following:

   • **If you're burning to a disc (instead of creating a disk image):** Click the Eject button to the right of the Output Device pop-up menu, then insert a blank disc into your disc-burning device and click Burn.

   • **If you're creating a disk image file:** Click Next, then enter a name for the file, choose a location to save it, and click Save. (By default, Final Cut Pro burns disk images as single-layer media, adjusting the bit rate accordingly.)

  **Note:** Blu-ray and AVCHD menus are best suited for displays set to show 1080 lines of vertical resolution.

You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See [View the status of shared items](#).

**Note:** If you added chapter markers to your project, chapter marker thumbnails are placed at the appropriate location when sharing to disc (DVD and Blu-ray disc) and MV4, QuickTime, and MP4 formats (for playback using QuickTime Player and Apple devices). See [Add chapter markers](#).
Share in email in Final Cut Pro for Mac

You can create an email message in the macOS Mail app and include your movie as an attachment.

1. In Final Cut Pro, do one of the following:
   - Select a project or a clip in the browser.
   - Select a range in a project in the timeline or in a clip in the browser.
     Note: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. If you're sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.
   This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

3. Do one of the following:
   - Choose File > Share > Email.
   - Click the Share button in the toolbar, then click Email.

   **Important:** The Email destination doesn’t appear by default. To add it to your set of destinations and to the Share menu, choose File > Share > Add Destination, then double-click the Email destination. See Create share destinations and Intro to Destinations settings.

4. In the Share window that appears, do any of the following:
• Move the pointer over the image to skim the video.

If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.

• In the Info pane, view and modify project or clip attributes, such as the title and description.

See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.

Important: By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.

• At the bottom of the window, view information about the file that will be exported, including frame size and frame rate, audio channels and sample rate, duration, output file type, and file size.

5. Click Settings to confirm the settings and make any necessary adjustments.

See Email destination.

Important: Many email services limit the file size for attachments. If the message exceeds the maximum size allowed by your email provider, the message size in the macOS Mail app appears in red, along with the allowed limit (if the Mail app can retrieve that information from the email provider).

6. Click Share.

After transcoding is complete, the Mail app opens, and an email is created with the Subject field filled in and the movie attached.

You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See View the status of shared items.

Batch sharing in Final Cut Pro for Mac

You can export multiple projects, clips, or clip ranges at once, referred to as batch sharing. You select the projects, clips, or ranges in the browser and then share to specific destinations.

Note: You can’t mix projects and clips in a batch share. Your selection must contain only projects or only clips. Batch sharing is not available for all destinations.
If the selected projects, clips, or clip ranges have identical settings (including roles settings, project settings, captions, frame rate, frame size, and so on), the share process is almost the same as when you share single items. For example, you can adjust the resolution and compression settings in the Settings pane of the Share window just as if you were sharing a single project, clip, or range.

If the selected projects, clips, or ranges have mixed settings, you may need to change the settings in the individual projects before sharing the batch.

**Mixed roles**

If you selected projects with differing roles settings (for example, one of the projects has additional roles, or the projects have the same roles but some roles are disabled in some of the projects), you can’t add or remove roles in the Roles pane of the Share window. You must first adjust the roles in the individual projects using the Roles pane of the timeline index, and then share the batch. See *Turn roles on or off*.

**Mixed project settings**

If you selected projects with differing project settings (such as different frame rates or frame sizes), you can't adjust those settings in the Settings pane of the Share window. You must first adjust the project settings in the individual projects, and then share the batch. See *Modify a project’s settings*.

**Mixed caption settings**

If you selected multiple projects with differing caption settings (for example, different caption formats, different active languages, or captions that are enabled and disabled), you have several options for exporting captions.

- You can export CEA-608, iTT, or SRT captions in any selected project as separate “sidecar” files with your finished media files. Final Cut Pro creates a folder for each project to hold the exported caption files.
- If you selected projects with different active caption languages, you can use a pop-up menu to choose a language to include (or burn in). You can also have Final Cut Pro use the currently active caption language.

  **Important:** To change the active language, you must first adjust the caption settings in the individual projects using the Roles pane of the timeline index, and then share the batch. See *Change the active language*.

- If you selected projects with CEA-608 captions, you can choose a language to embed or have Final Cut Pro embed the currently active CEA-608 caption language.

  **Note:** Embedded captions are not the same as burned-in captions.

**Other ways to use batch sharing**

You can use batch sharing with the Send to Compressor command to send your projects or clips to Compressor, which lets you customize your output using the options available in Compressor. See *Send your projects or clips to Compressor*.

You can also use batch sharing in combination with destination bundles to easily export projects, clips, or ranges to multiple types of output, all in a single step. See *Create a bundle of destinations*. 
Share from Final Cut Pro for Mac using Compressor

The destinations available in Final Cut Pro provide many options for exporting projects and clips. If you need more options, you can create highly customized export settings using Compressor, the professional transcoding app designed to work directly with Final Cut Pro. For example, you can use the Compressor frame resizing and retiming controls to make high-quality frame size and frame rate adjustments in your output files.

Important: To export using Compressor, you must have a compatible version of Compressor installed. Compressor must be purchased separately.

There are three ways you can use Final Cut Pro and Compressor together:

• Use the Compressor Settings destination in Final Cut Pro to apply Compressor settings (either the Apple-supplied setting or custom settings you create). Exporting a project in this way lets you transcode your project using Compressor settings without opening your project in Compressor. You can also create several types of output in a single step using a destination bundle (see Create a bundle of destinations).

• Use the Send to Compressor command to send your projects or clips to Compressor, which allows you to customize your output using the options available in Compressor.

• Use the Send iTMS Package to Compressor command to assemble an iTunes Store package in Compressor. If you plan to sell a movie in the iTunes Store, you must deliver the movie file plus a set of related files and information. Compressor makes it easy to assemble these items into a single iTunes Store package, which is the format required for submission to the iTunes Store.

Share using the Compressor Settings destination

Using this method, you add destinations in the Share menu that are based on Compressor settings.

1. In Final Cut Pro, create a new destination using the Compressor Settings destination.

2. Do one of the following:

   • Select one or more projects or clips in the browser.
     
     Note: You can’t mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.

   • Select ranges in one or more clips in the browser.
     
     See Set multiple ranges in the browser.

   • Select a range in a project in the timeline.
     
     Note: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.
3. If you’re sharing a project that is set to use proxy media for playback, open it in the timeline, then click the View pop-up menu in the top-right corner of the viewer and choose Optimized/Original.

This ensures the highest quality in the exported file. When you choose this setting, Final Cut Pro uses optimized media to create the shared file. If optimized media doesn’t exist, the original media is used. For more information about optimized and proxy media, see Control playback quality.

4. Do one of the following:
   - Choose File > Share, then choose the destination you created in step 1 from the submenu.
   - Click the Share button in the toolbar, then click the destination you created in step 1.

5. In the Share window that appears, do any of the following:
   - Move the pointer over the image to skim the video.
     If you’re batch sharing (exporting multiple items), the image is replaced by a list of the items you’re exporting.
   - In the Info pane, view and modify project or clip attributes, such as the title and description.
     See Change metadata for shared items. All of the attributes associated with the project or clip are included in the output file.
     Important: By default, the title field lists the project or clip name. Changing the title does not change the project or clip name, which is the name used for the exported file.
   - Click Settings to confirm the export settings and make any necessary adjustments.
     See Compressor Settings destination.
   - Click Next.
   - If you selected a single project, clip, or range, enter a name for the file you’re sharing.
   - Choose a location for the exported files, then click Save.
**Send your projects or clips to Compressor**

1. In Final Cut Pro, do one of the following:
   - Select one or more projects or clips in the browser.
     
     *Note: You can't mix projects and clips in a batch share. Your selection must contain only projects or only clips. See Batch sharing.*
   - Select ranges in one or more clips in the browser.
     
     See Set multiple ranges in the browser.
   - Select a range in a project in the timeline.
     
     *Note: To share just a portion of a project, you must make a range selection. A clip selection is not sufficient. You can use the I and O keys to set the range start and end points.

2. Choose File > Send to Compressor.

   *Note: The Send to Compressor command is dimmed if Compressor is not installed on the same computer as Final Cut Pro.

   If your project contains captions, you’re asked to choose a language version (subrole).

   Compressor opens with a new batch that contains one or more jobs corresponding to the items you selected in step 1.

3. Configure the job by clicking Add Outputs and following the instructions, then click Start Batch.

   *Note: If you want to add or replace caption language subroles in a Compressor batch, you can export caption files using the File menu and then add them to the job in Compressor.*

**Send an iTunes Store package to Compressor**

If Compressor is installed on the same Mac, you can send all the video, audio, and caption roles in your current Final Cut Pro project to Compressor as an iTunes Store package.

For comprehensive information on iTunes Store packages, see the Compressor User Guide and Create an iTunes Store Package with Compressor.

1. In Final Cut Pro, select a project or clip in the browser, or open a project in the timeline.

2. Choose File > Send iTMS Package to Compressor.

   If your project contains more than one CEA-608 language, a pop-up menu appears allowing you to choose the CEA-608 language you want to send to Compressor. (You can send only one CEA-608 file to Compressor.)

   If your project contains iTT captions, a list of iTT language subroles in your project appears. Select one of the following settings for each iTT language subrole in the list:

   - **Translation (Full):** Outputs a full translation of all words spoken in the film using the language assigned to that subrole. During playback, viewers can turn these subtitles on or off.
   - **Forced:** Use when a person in the video speaks a language different from the main language of the video—for example, for a French-speaker in an otherwise English-language film. Forced subtitles can't be turned off because they're necessary to understand the content of the video.
• *Deaf and Hard of Hearing (SDH)*: Use for a full translation of all the words spoken in the video, as well as song lyrics and sound effects (*owl hooting*, *scream in distance*, and so on). During playback, viewers can turn SDH subtitles on or off.

Compressor opens with a new batch that contains the new iTunes Store package, including the iTT captions you configured. If you had CEA-608 captions in your project, they appear in the iTunes Store package as closed captions.

To configure the iTunes Store package, follow the instructions in the **Compressor User Guide**.

*Note*: You can set Compressor to use the computer’s graphics processing engine (GPU) to display or transcode a Final Cut Pro project sent to Compressor for processing. For more information about configuring jobs and settings in Compressor, see the **Compressor User Guide**.

You can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded.

When transcoding is complete, a notification appears. You can view and locate shared projects in the Share inspector. See **View the status of shared items**.

---

### Create share destinations in Final Cut Pro for Mac

In the Destinations pane of the Final Cut Pro Settings window, you can modify existing destinations, add new destinations, delete destinations, and create destination bundles, which allow you to export multiple types of output at once. You can also revert to the default set of destinations that were available when you first opened Final Cut Pro.

![Destinations pane of Final Cut Pro Settings window](image)

For information about sharing projects and clips from Final Cut Pro, see **Intro to sharing projects**.
Create a new destination

1. In Final Cut Pro, do one of the following:
   - Choose File > Share > Add Destination.
   - Choose Final Cut Pro > Settings, click Destinations at the top of the window, then select Add Destination in the Destinations list on the left.
   - Select a clip or project, click the Share button in the toolbar (shown below), then click Add Destination.

2. In the Destinations pane of the Final Cut Pro Settings window, do one of the following:
   - Drag a destination from the area on the right to the Destinations list on the left (or double-click a destination on the right).
   - Control-click a destination in the Destinations list, then choose Duplicate.

The new destination appears selected in the list on the left, and the settings for the destination appear on the right.
3. Specify settings for the new destination.

For descriptions of the controls in each destination, see Intro to Destinations settings.

Here are some tips for setting up various types of destinations:

- **If you chose a web destination:** Enter your user name and password in the window that appears, then click OK. Depending on the destination you're setting up, you may need to verify your account or your device. To do so, follow the onscreen instructions.

  In some cases, you can select a "Remember this password in my keychain" checkbox, so that you don’t have to enter your user name and password every time you share to the destination.

- **If you chose the Compressor Settings destination:** Select a Compressor setting in the window that appears, then click OK. The settings that are displayed include the Compressor settings that come with Final Cut Pro as well as any settings you added.

  **Important:** You can use the Compressor Settings destination only if you have Compressor installed or someone gives you a Compressor setting.

You can make changes to the destination at any time. For example, you can type a new name or use the controls on the right to change the destination settings. As you customize the destination, your changes are saved automatically.
Modify existing destinations

Note: You can modify an existing destination's settings while you're sharing a project or clip. For information about sharing projects and clips from Final Cut Pro, see Intro to sharing projects.

1. Choose Final Cut Pro > Settings, then click Destinations at the top of the window. The Destinations pane appears, with a list of destinations on the left.

2. Do any of the following:
   - Change a destination’s settings: Select a destination, then modify the destination’s settings on the right.
   - Restore a destination to its original settings: Control-click a destination in the Destinations list, then choose Revert to Original Settings. The destination's settings are restored to their original values.
   - Rename a destination: Double-click a destination in the list on the left, then type a new name.
   - Change the order of destinations in the list: Drag a destination to a different location in the list.

   For descriptions of the controls in each destination, see Intro to Destinations settings.

As you modify destinations, your changes are saved automatically.
Create a bundle of destinations

Bundles make it easy to create several types of output in a single step. A bundle holds a set of destinations. When you share a project or clip using the bundle, a file is output for each destination in the bundle.

1. Choose Final Cut Pro > Settings, then click Destinations at the top of the window.
2. Select Add Destination in the Destinations list, then double-click the Bundle destination (or drag it from the area on the right to the Destinations list on the left).
   
   An empty bundle appears in the Destinations list.
3. To add destinations to the bundle, drag existing destinations into it from the Destinations list, or select Add Destination and drag destinations from the area on the right into the bundle.

   Tip: To quickly make a bundle from destinations in the Destinations list, select one or more destinations in the Destinations list, then Control-click in the Destinations list and choose New Bundle from Selection.

Delete a destination

1. Choose Final Cut Pro > Settings, then click Destinations at the top of the window.
2. Do one of the following:
   
   • Control-click a destination in the Destinations list, then choose Delete.
   
   • Select a destination in the Destinations list, then press Delete.
   
   • Select a destination in the Destinations list, then click the Remove button (–) below the list.

Assign a default destination

After you set the default destination, you can quickly share to that destination by pressing Command-E. If a clip in the browser is selected, the clip is shared; if the timeline is active, the project is shared. By default, this keyboard shortcut is assigned to the Export File destination. To use the Command-E keyboard shortcut to share to another destination (or destination bundle), you can make that destination or bundle the default.

1. Choose Final Cut Pro > Settings, then click Destinations at the top of the window.
2. Control-click the destination or bundle you want to make the default, then choose Make Default.

   The name of the new default destination is appended with “(default).”
Revert to the set of destinations that came with Final Cut Pro

1. Choose Final Cut Pro > Settings, then click Destinations at the top of the window.
2. Control-click in the Destinations list, then choose Restore Default Destinations.

Any custom destinations are deleted, and the default set of destinations appears. For a list of the default destinations, see Intro to sharing projects.

Share destinations between Final Cut Pro users

1. Choose Final Cut Pro > Settings, then click Destinations at the top of the window.
2. Do any of the following:
   - Export destinations from your copy of Final Cut Pro: Drag one or more destinations from the Destinations list to a location in the Finder.
     The destination file is appended with the filename extension .fcpxdest.
   - Import destinations into your copy of Final Cut Pro: Drag a destination file from a location in the Finder to the Destinations list.
     The destination you added appears in the Destinations list, the Share submenu of the File menu, and the menu that appears when you click the Share button in the toolbar.
Change metadata for shared items in Final Cut Pro for Mac

In Final Cut Pro, you can customize the metadata—also called attributes— included with exported files. You can view and modify metadata for a shared project or clip in the Attributes section of the Share inspector.

Change metadata to be shared with a project or clip

1. In Final Cut Pro, select a project or clip.

2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Share button at the top of the inspector.

4. In the Share inspector, type new text in an attribute field.
   If you type a word or phrase that has been defined as an attribute, the attribute (a word or phrase in a blue bubble) appears after you finish typing.
Choose the fields that appear in the Share inspector

1. In Final Cut Pro, select a project or clip.

2. Open the Share inspector.

   The Share inspector contains a pop-up menu you can use to customize attribute fields.

3. Using the Attributes pop-up menu, do any of the following:
   - Add an attribute field: Choose the field name (so that there’s a checkmark next to it).

      Fields with a checkmark are shown in the Share inspector, and the contents of those fields are exported with your project or clip as metadata.

      • Remove an attribute field: Choose the field name (so that there’s no checkmark next to it).

      • Show only the Final Cut Pro default attribute fields: Choose Show Default Fields.

      Choosing this option displays only the Title, Description, Creator, and Tags fields.

      Important: The default fields can’t be removed.

      • Save the selected attribute fields as your default set: Choose Save as Default.

      • Display your default set of attribute fields: Choose Update to Default.
Select the attributes that appear in a Share inspector field

You can set the attributes that appear automatically in an attribute field.

1. In Final Cut Pro, select a project or clip.
2. Open the Share inspector, then click the Attributes pop-up menu and choose Edit Share Fields.
3. In the Edit Share Fields window, select an attribute field from the list on the left.

   The attributes assigned to the selected field appear in the Format field.

4. To edit the selected attribute field, do any of the following:
   - Add an attribute: Drag an attribute (a word or phrase in a blue bubble) from the middle of the window to the Format field. You can also type the attribute name in the field.
   - Add text: Type a word or phrase in the Format field.
   - Create a custom name attribute: Enter a word or phrase in the Custom Name field at the bottom of the window, then drag the Custom Name attribute to the Format field.

   Tip: Because the custom name attribute appears in the Format field as “Custom Name,” you can use it for long phrases or sentences and still easily view the other attributes and text in the Format field.

   - Remove an attribute or text: Select the attribute or text, then press Delete.

As you add and remove attributes, the example (below the Format field) shows your changes.

5. When you're finished, click OK.
View the status of shared items in Final Cut Pro for Mac

When you share a project, you can monitor the progress of the transcode in the Background Tasks window, and you can continue to work in Final Cut Pro while the file is transcoded. When transcoding is complete, a notification appears.

You can view the share history of a project and locate shared projects using the Share inspector. If you share your project or clip using the Export File destination (or any custom destinations you create based on the Export File destination), you can locate the shared file in the Finder.

Open the Share inspector

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the shared project or clip you want to inspect.
2. In the browser, select the shared project or clip.
3. If the inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button on the right side of the toolbar.

---

View the exported files in the Finder.

Click to open the shared item's pop-up menu.
4. Click the Share button at the top of the inspector.

A summary of the project's or clip's information appears at the top of the inspector, metadata (or attributes) included with the shared project or clip appears in the middle, and information about where the project or clip has been shared appears at the bottom.

Click the shared item's pop-up menu to access more options.

**Locate a shared project or clip in the Finder**

1. In Final Cut Pro, select the shared project or clip.
2. Open the Share inspector, then click the shared item's pop-up menu and choose Reveal in Finder.

   *Note: Not all shared items generate an output file that you can reveal in the Finder.*

For more information about shared files, see [Locate source media files](#).

For information about removing a previously shared project or clip from a video-sharing website, see the documentation for the website.
Speed up exports with simultaneous processing in Final Cut Pro for Mac

You can speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing. This is called *export segmentation*.

When your project is approximately 3 minutes or longer, the “Allow export segmentation” option becomes available in the Share window and is selected by default. You can monitor the progress of simultaneous processing in the Background Tasks window.

Simultaneous processing is available for most share destinations, including the following:

- Apple Devices
- Export File
- Social Platforms
- Email
- HTTP Live Streaming
- Compressor Settings

Simultaneous processing requires macOS Sonoma or later and a Mac with Apple M1 Max, M1 Ultra, M2 Max, M2 Ultra, or M3 Max. HEVC HLG Dolby Vision 8.4 is not supported.
Manage media, libraries, and archives

Intro to media management in Final Cut Pro for Mac

Final Cut Pro provides you with flexible and powerful tools to manage your media files.

The first time you open Final Cut Pro, it automatically creates a library file in the Movies folder. You can import media into the library file or have Final Cut Pro access media files in other locations. The Final Cut Pro library database tracks your edit decisions, the associated metadata, and all your events, projects, and clips (as well as any optimized or rendered media files). The library database also keeps track of all your source media files (video files, audio files, or still-image files), whether they are stored in the Final Cut Pro library file or in other locations. As your library grows, you can rename, copy, move, and delete your clips, events, and projects as necessary.

You can use multiple libraries and events to organize media and projects to suit your workflow. For example, copying or moving events is useful if you want to work on a project using another Mac that has Final Cut Pro installed, or if you want to free up storage space. Use other media management tools such as the Consolidate command for backups and managing shared storage.
The following are some common media management tasks:

- Transcoding your source media files to optimized or proxy formats that are high quality and easy to work with. See Create optimized and proxy files.
- Backing up your work. See Back up projects and libraries.
- Consolidating source media files in one location. See Consolidate projects and libraries.
- Locating source media files. See Locate source media files.
- Relinking clips to media files. See Relink clips to media files.
- Managing multiple libraries, including copying and moving items between libraries. See Intro to managing libraries.
- Creating camera archives to save the contents of your camera or camcorder as readily available backups on any computer. See Create camera archives.

Importing media from cameras, external storage devices, or other devices is also generally considered a form of media management. See Intro to importing media.

Manage your media files

View a clip's information in Final Cut Pro for Mac

The Info inspector provides a summary of a clip's information. Here you can view status information about a clip's source media file, including the file's location, available media representations for the file, the event the clip is located in, and the event the clip references.
1. Select a clip in the Final Cut Pro browser or timeline.

2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.

3. Click the Info button at the top of the inspector.

Tip: Double-click the top bar of the inspector to switch between half-height view and full-height view.

4. In the Info inspector, scroll down to view the file information.

For information about using optimized or proxy media for playback, see Control playback quality. For more general information about optimized and proxy media, see Create optimized and proxy files.
Override a clip’s metadata in Final Cut Pro for Mac

You can use the Info inspector to override information (called metadata) about a clip or group of clips selected in either the browser or the timeline. You can adjust color space information, anamorphic playback, and field order.

For more information about managing metadata, including metadata views and naming presets, see Intro to metadata.

Change a clip’s color space metadata

The color space metadata for a video clip is sometimes missing or incorrect, especially when you use media that was created by third-party software. When this happens, the Color Profile field in the Info inspector is empty or shows unexpected values, which can result in the inaccurate display or color processing of the media.

You can use the Color Space Override setting to correct the color space metadata so that Final Cut Pro processes and displays the selected clip correctly. It’s best to do this before attempting any color correction.

Note: The steps below change a clip’s metadata only. If you want to adjust a timeline clip’s luminance levels, see Use Color Conform to manually convert a clip to the project’s color space.

1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose Extended.
4. Locate the Color Profile field, and check to see whether the metadata is missing or incorrect.
   
   The metadata tag consists of three numbers, which refer to standard color spaces. Here are the correct codes for the standard formats:
   
   • 1-1-1: Rec. 709 (HD)
   • 9-16-9: Rec. 2020 PQ
   • 9-18-9: Rec. 2020 HLG
   • 9-1-9: Rec. 2020 SDR
   • 5-1-6: PAL SD
   • 6-1-6: NTSC SD
5. If the code is missing or incorrect, click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose Settings.
6. Click the Color Space Override pop-up menu and choose the correct (original) color space for the selected clip.

For more information about color spaces, see Intro to wide color gamut and HDR.
**Adjust anamorphic footage**

Some video camcorders and recording devices shoot at a widescreen 16:9 aspect ratio but record the data using a 4:3 aspect ratio. Sometimes the metadata tag specifying 16:9 playback in the video file is missing or set incorrectly. In Final Cut Pro, you can set this tag so that the video plays correctly with a widescreen 16:9 aspect ratio.

*Note:* This option is available only for the following formats: standard definition (SD) and ARRI ALEXA 2K 4:3 (2048 x 1536).

1. In the Final Cut Pro browser or timeline, select the SD clips whose anamorphic setting you want to adjust.
2. Open the Info inspector.
3. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose Settings.
4. Click the Anamorphic Override pop-up menu and choose Widescreen.

**Change a clip's field order**

Modern video cameras and codecs support two kinds of video frame rates: *progressive*, in which video is recorded and stored as a series of whole frames, and *interlaced*, in which each frame is made up of two half-frames called *fields*. In the interlaced system, each field contains half the frame lines; one field contains lines 1, 3, 5, 7, 9 and so on, and the other field contains lines 2, 4, 6, 8, 10, and so on. When the video is played back, the TV displays the fields in an alternating pattern, which creates an effective illusion of smooth movement.

A clip’s *field order* determines the temporal order of fields within a frame. Missing or incorrect field order metadata can result in awkward field movement and improper motion effects rendering (in a left-to-right wipe, for example). You can correct this order with the Field Dominance Override pop-up menu.

1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose Settings.
4. Click the Field Dominance Override pop-up menu and choose one of the following:

- **Progressive**: The video is displayed in complete frames with all lines sampled at the same instant in time.
- **Upper First**: The video is interlaced and displayed as two separate interleaved fields. The field containing the top line is sampled at an earlier instant in time than the field containing the bottom line. This field order is commonly used for high-definition (HD) video and standard-definition (SD) PAL video.
- **Lower First**: The video is interlaced and displayed as two separate interleaved fields. The field containing the bottom line is sampled at an earlier instant in time than the field containing the top line. This field order is commonly used for SD NTSC video.

Locate source media files in Final Cut Pro for Mac

You can locate the original source media file or proxy file (on your Mac or storage device) for any clip in your library.

1. In the Libraries sidebar in Final Cut Pro, select the event that contains the clip.
2. Select the clip in the browser.
3. Do one of the following:
   - **Locate the original source media file**: Choose File > Reveal in Finder (or press Shift-Command-R).
   - **Locate the proxy file**: Choose File > Reveal Proxy Media in Finder.

   A Finder window opens, with the file selected.

You can also quickly find the source event clip for any clip in the timeline. See Find a project clip’s source clip.

Relink clips to media files in Final Cut Pro for Mac

In Final Cut Pro, clips represent your media, but they are not the media files themselves (see Media files and clips). Final Cut Pro keeps track of the links between clips and media files automatically.

However, there are times when you need to manually relink clips to media files:

- **When files are altered or re-created outside of your copy of Final Cut Pro**: For example, if you send files out for color correction, you may need to relink the clips in your event to the color-corrected versions of the files when you receive them.
- **When media files are missing**: If you move or rename externally linked files in the Finder, or if you move an event or a project to a different location, you need to relink the event or project clips (which appear as red frames with yellow alert triangles) to the files.
In either case, manually relinking connects the clips in Final Cut Pro to the correct files on your Mac or storage device.

You can relink either original source media files or proxy files. The relinked files must include all the media in the referenced clips and must be the same media type (for example, video or audio), have the same frame rate, and have similar audio channels.

**Note:** You can't undo the Relink Files command.

1. In Final Cut Pro, do one of the following:
   - In the browser or the timeline, select the clips you want to relink.
   - In the browser, select the projects containing the clips you want to relink.
   - In the Libraries sidebar, select an event or an entire library containing the clips you want to relink.

2. Do one of the following:
   - **Relink original source media files:** Choose File > Relink Files > Original Media.
   - **Relink proxy files:** Choose File > Relink Files > Proxy Media.

   The Relink Files window appears. By default, this window shows **missing clips or events** only.

3. If you want to show all items in the selection, select All.

4. Do one of the following:
   - **Locate all the matching files:** Click Locate All.
   - **Locate some of the matching files:** Select items in the list and click Locate Selected.
5. In the window that appears, navigate to one of the files you want to link to, or to the folder that contains it.

Text at the bottom of the window indicates how many potential matches to items in your original list were found (based on the filenames only).

Note: Final Cut Pro identifies matches based on proximity in the directory structure and related filenames. For example, if your original files were in two adjacent folders, Final Cut Pro looks in folders adjacent to the folder containing the file you chose and relinks all matching files in the relative path. If your original files were named “File1,” “File2,” “File3,” and so on, and you chose to relink to a file named “File1_A,” Final Cut Pro looks for files named “File2_A,” “File3_A,” and so on to relink the remaining items in your list.

6. Click Choose.

Final Cut Pro analyzes the files to confirm that all attributes (in addition to the filename) match items in the original selection. Analysis results are shown below the Original Files list (for example, “3 of 3 files matched”).
7. Click the disclosure triangle next to the analysis results to show a list, with old files on the left and new, matching files on the right.

If a file was matched incorrectly, select it in the list and press Delete. The item is placed back in the original list at the top of the Relink Files window.

Items with no matches remain in the original list above. To continue to locate matches, select items in the original list and repeat steps 4 through 6.

8. To link the event clips to the new media files, click Relink Files.

All matched clips (including those in other projects or events) are updated to link to the new media files. Metadata in the relinked clips remains unchanged.

Note: Red “Missing Proxy File” alert icons in the browser, viewer, or timeline may indicate an unrelated issue. You may need to switch the playback media mode or generate proxy media. See Control playback quality or Create optimized and proxy files.

Consolidate projects and libraries in Final Cut Pro for Mac

In the course of creating a project, you might use media files from a variety of locations, including your local computer and external storage devices. If the media being used in a project, event, or library is located in multiple folders or on multiple storage devices, you can consolidate all the media in one location, on one storage device. This process facilitates archiving and makes it easier for others to access the media (using shared storage, for example).

The Consolidate command places the files in the current library storage location. You view and set storage locations for media, Motion content, cache files, and library backup files using the Library Properties inspector.

The Consolidate command follows these rules:

- When you consolidate files out of a library to an external folder, the files are moved.
- When you consolidate files into a library from an external folder, or from an external folder to another external folder, the files are copied.

These rules prevent broken links from other libraries.

Note: If the media is already external, and no other libraries are using it, you can manually delete the original media after consolidating to save storage space.
Consolidate media files for a library, event, project, or clip

1. In the Libraries sidebar in Final Cut Pro, do one of the following:
   - Select a library.
   - Select one or more events.
   - Select an event, then select one or more projects in the browser.
   - Select an event, then select one or more clips in the browser.
3. In the window that appears, select one or more media types (original, optimized, or proxy) and confirm the library to consolidate the files into.
4. Click OK.
   
   If you chose to include optimized or proxy media, and the optimized or proxy media isn't available, you're given the option to generate the media.

   Final Cut Pro copies the media types you selected to the current library storage location, generating optimized or proxy media in that location if needed. To view or change library storage locations, see Set storage locations.

   If a message appears stating that there is nothing to consolidate, it means that all of your media files are already consolidated at one location, on one storage device.

Consolidate the Motion content for a library

By default, when you create or customize any Final Cut Pro effects, transitions, titles, or generators in Motion, that Motion content is stored in the Motion Templates folder located in your Movies folder. You can also store that Motion content inside a library—for example, to move a project or library to another Mac, or to back up and archive your work. You use the Library Properties inspector to manage storage locations for Motion content files and consolidate them (either to the Motion Templates folder or to the library).

**Important:** The Consolidate command described below works only on effects, transitions, titles, or generators that have been added to projects or events in the selected library. Other Motion content is not affected.

1. In the Libraries sidebar in Final Cut Pro, select a library.
2. Choose File > Consolidate Motion Content.
   
   You can also press Command-4 to open the Library Properties inspector, then click Consolidate in the Motion Content section.
3. In the window that appears, confirm the storage location (either the library file or the Motion Templates folder) to consolidate the files into.
   
   If a message appears stating that there’s nothing to consolidate, it means that all of your media files are already consolidated at one location, on one storage device.
4. Click OK.
   
   The Motion content files that are in use in the library are copied into the current Motion content storage location for the library (either the library file or the Motion Templates folder). To view or change library storage locations, see Set storage locations.
Note: If you have created or customized any Final Cut Pro effects, transitions, titles, or generators in Motion, set the storage location for your Motion content to In Library before starting any copy or move operations between libraries or storage devices. Otherwise, the Motion content is not included in those operations. See Manage Motion content. Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.

Back up projects and libraries in Final Cut Pro for Mac

Backing up your work and your media consistently is an essential part of your workflow. Some people back up daily or weekly; others back up when a project is complete. To protect your media, it's recommended that you back up to a storage device or partition different from the one where you store the media files used with Final Cut Pro.

Final Cut Pro provides both automatic and manual tools that let you:

- Back up projects, events, and libraries manually. See Transfer a library to another Mac and Copy or move items between libraries.
- Enable automatic backups of the database portion of Final Cut Pro libraries. See Restore a library and Set storage locations.
- Back up projects by duplicating them as snapshots. See Duplicate projects and clips.
- Collect the source media files for a library, an event, or a project in one location. You can also collect Motion content for a library in the library file or the Motion Templates folder. See Consolidate projects and libraries.

Note: If you have created or customized any Final Cut Pro effects, transitions, titles, or generators in Motion, set the storage location for your Motion content to In Library before starting any copy or move operations between libraries or storage devices. Otherwise, the Motion content is not included in those operations. See Manage Motion content. Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.

Create optimized and proxy files in Final Cut Pro for Mac

Final Cut Pro can play back many media formats. For a complete list, see Supported media formats. Final Cut Pro also provides options for transcoding your media (converting it to a different format or changing its settings) to make it suitable for editing.

- **Create optimized media**: This option transcodes video to the Apple ProRes 422 format, which provides better performance during editing, faster render times, and better color quality for compositing. If the original camera format can be edited with good performance, this option is dimmed.

- **Create proxy media**: This option creates video proxy files. Video is transcoded to either the Apple ProRes 422 Proxy or H.264 format. You can create proxy media in a variety of frame sizes from 12.5 percent to 100 percent of the original. Proxy files increase editing performance and take up considerably less storage space than optimized files.

Note: For better import and playback performance, Final Cut Pro automatically transcodes all MP3 audio files to MOV audio files. When transcoding files, Final Cut Pro always retains the original media for future use.
You can create optimized and proxy media during the import process or in the browser, after the media has been imported. You can also create a proxy file for a clip using the Info inspector. After transcoding is complete, the optimized and proxy files are stored in your Final Cut Pro library or in an external location you define. See Set storage locations.

**Create optimized and proxy files during import**

During import, Final Cut Pro either creates an alias file that points to the media file in its original location, or creates a copy of the original media file. After the files are imported, transcoding, optimization, and analysis are performed in the background.

1. In Final Cut Pro, do one of the following:
   - *Import a file from a compatible file-based recording or storage device, or from your Mac:* Connect your device to your Mac, turn on the device, and choose File > Import > Media (or press Command-I), then navigate to and select the media you want to import.
   - *Import a file from a tape-based camcorder:* Connect your device to your Mac, turn on the device and set it to VTR or VCR mode, then choose File > Import > Media.
   - *Import from an archive:* Choose File > Import > Media, select a camera archive from the list on the left, click Open Archive, then navigate to the files you want to import.

   See Intro to importing media.

2. Use the settings on the right side of the Media Import window to choose how you want to organize the imported media in your library:
   - *Add the imported media to an existing event:* Select “Add to existing event,” then click the pop-up menu and choose the event.
   - *Create a new event:* Select “Create new event in,” use the pop-up menu to choose the library in which you want to create the event, then type a name (for example, “Chris and Kim Wedding”) in the text field.

   To learn more about events, see Intro to libraries. If you want to import media into a new library, you must create the new library before importing your media.

3. In the Files section, choose a storage option:
   - *Copy the files to the current library:* To duplicate the files and place the copies in the current library storage location, select “Copy to library.” You can set storage locations for each of your libraries. See Set storage locations.
   - *Link to the files at their current location:* Select “Leave files in place.”

   **Note:** If you select this option, Final Cut Pro creates symbolic links (also called symlinks), which are special files that point to the media files. If you later copy or move clips between events, only the symbolic links are copied or moved (not the source media files). To replace the symbolic links with the actual source media files, select the events and choose File > Consolidate Event Files.
4. Do any of the following:
   • *Create optimized files:* Select the “Create optimized media” checkbox.
   • *Create proxy files:* Select the “Create proxy media” checkbox, then select the proxy format and frame size. For details about the settings, see the “Transcode” section in Import settings.

   **Note:** If the original camera format can be edited with good performance, the “Create optimized media” option is dimmed. If optimized and proxy media are already available, the “Create optimized media” and “Create proxy media” options are dimmed.

   The files are transcoded in the background, after the import process is complete.

5. Click Import Selected or Import All (the Import button changes its name based on your clip selection).

   The import may take a while, depending on the options you selected. You can see the status of all the background processes currently running in the Background Tasks window.

### Create optimized and proxy files after import

1. Do one of the following:
   • Control-click one or more clips in the Final Cut Pro browser or events in the Libraries sidebar, then choose Transcode Media from the shortcut menu.
   • Select one or more clips or projects in the browser, then choose File > Transcode Media.

2. In the window that appears, do any of the following:
   • *Create optimized files:* Select the “Create optimized media” checkbox.
   • *Create proxy files:* Select the “Create proxy media” checkbox, then select the proxy format and frame size. For details about the settings, see the “Transcode” section in Import settings.

   **Note:** If the original camera format can be edited with good performance, the “Create optimized media” option is dimmed. If optimized and proxy media are already available, the “Create optimized media” and “Create proxy media” options are dimmed.

3. Click OK.

   The transcoding process may take a while, depending on the options you selected. You can see the status of all the background processes currently running in the Background Tasks window.

   **Tip:** MP3 audio files from projects created with versions of Final Cut Pro earlier than 10.0.0.4 can be manually transcoded to WAV audio files using this process.
Create optimized and proxy files when importing by dragging

Media you drag from the Finder into an event or the timeline is automatically organized, transcoded, and analyzed based on the import settings you specify in Final Cut Pro settings.

1. To specify import settings, choose Final Cut Pro > Settings, click Import, and select the import settings you want to apply to your media.
   
   See Import settings.

2. To import one or more files, select a file (or Command-click multiple files) in the Finder, then drag the selection to the timeline or to an event in the Libraries sidebar.

Generate a proxy file from the Info inspector

You can use the Info inspector to create a proxy file for a clip or to see whether a proxy file exists for a clip. If the file you’re viewing in the Info inspector doesn’t have a proxy file, you see a red triangle.

1. Select a clip in the Final Cut Pro browser.

2. If the inspector isn’t already shown, do one of the following:
   
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   
   • Click the Inspector button on the right side of the toolbar.

3. Click the Info button at the top of the inspector.
4. Scroll down to the bottom section of the Info inspector, then click Transcode Media.

5. In the window that appears, do any of the following:
   - **Create optimized files**: Select the “Create optimized media” checkbox.
   - **Create proxy files**: Select the “Create proxy media” checkbox, then select the proxy format and frame size. For details about the settings, see the “Transcode” section in Import settings.

   *Note*: If the original camera format can be edited with good performance, the “Create optimized media” option is dimmed. If optimized and proxy media are already available, the “Create optimized media” and “Create proxy media” options are dimmed.

6. Click OK.

   The transcoding process may take a while, depending on the options you selected. You can see the status of all the background processes currently running in the Background Tasks window.

   ❗️ **Tip**: MP3 audio files from projects created with versions of Final Cut Pro earlier than 10.0.4 can be manually transcoded to WAV audio files using this process.

   The proxy file is created, and a green circle appears next to the proxy item in the Available Media Representations section, indicating that the proxy file for the clip is available.
Delete optimized or proxy files

You can delete optimized or proxy media files at any time, no matter where they’re stored. Original media files are not deleted, so you can always regenerate optimized and proxy files from the original media.

1. In Final Cut Pro, do one of the following:
   - *Delete optimized or proxy files for one or more clips:* In the browser or the timeline, select one or more clips.
   - *Delete optimized or proxy files for one or more projects:* In the browser, select one or more projects.
   - *Delete optimized or proxy files for one or more events:* In the Libraries sidebar, select one or more events in the same library.
   - *Delete optimized or proxy files for a library:* Select a library in the Libraries sidebar.


3. In the window that appears, select any of the following:
   - Delete Optimized Media
   - Delete Proxy Media

4. Click OK.

   The selected files are deleted from your storage device.

*Note:* Unlike other media management commands in Final Cut Pro, the Delete Generated Library Files and Delete Generated Clip Files commands affect external media as well as managed media (in the library).

To control whether Final Cut Pro displays optimized, proxy, or original media in the viewer, and whether video playback is optimized for quality or performance, choose the corresponding options from the View pop-up menu in the upper-right corner of the viewer. See Control playback quality.

*Important:* If you use proxy media for playback, make sure to switch back to optimized/original media before sharing your project. This ensures the highest quality in the exported file. See Intro to sharing projects.

Create a proxy-only project in Final Cut Pro for Mac

You can create proxy-only versions of your projects, events, and libraries for portability and performance. The proxy-only versions contain only proxy media files, along with file types that don’t support proxy media, such as audio, video with an alpha channel, and still images.

Proxy-only projects are useful for offline editing. Video proxy files use considerably less storage space, often enough to allow you to work on a portable computer instead of a desktop computer with significantly more memory and processing power.

The following instructions are for making a proxy-only version of a project, but they apply equally to making proxy-only events and proxy-only libraries.
Create a proxy-only project for offline editing

1. In the Libraries sidebar in Final Cut Pro, select the event that contains your project.

2. In the browser, select the project, then choose File > Copy [item] to Library > New Library.
   
   Note: To make a proxy-only version of an event or a library, select it in the Libraries sidebar.

3. Enter a name for the new library, choose a location for it, and click Save.

4. In the window that appears, select Media in the Include section, then select the “Proxy media” checkbox.

5. In the Media Destination section, click Modify Settings and choose a storage location for the new library, then click OK.

   Important: If a window appears with the option to generate proxy media for clips in the project, click Transcode.

   Final Cut Pro copies the item you selected and its proxy media to the new library’s storage location (or generates the proxy media at that location). The new library appears in the Libraries sidebar.

   Note: File types that don’t support proxy media (audio, video with an alpha channel, and still images) are copied to the new library’s storage location in their original format.

6. Open the project in the new library.

7. Click the View pop-up menu in the upper-right corner of the viewer, and choose either Proxy Only or Proxy Preferred in the Media Playback section.

   Missing File alert icons may appear in the browser, timeline, and viewer if Media Playback is set to Optimized/Original. See Control playback quality.

For more information about setting the library storage location, see Set storage locations.

Relink a proxy-only project to original or optimized media

You can return a proxy-only project to the original library and reunite it with its original or optimized media.

1. In the Final Cut Pro browser, rename the proxy-only project (to distinguish it from the original project), then drag it to an event in the original library.

   See Copy or move items between libraries.

2. In the window that appears, select “Project without media” in the Include section.

   Note: If you added new media to the project and want the new media to be copied to the original library, select Media in the Include section, then select the “Original media” checkbox.

   A copy of the project appears in the event, automatically connected to the relevant original or optimized media.
Manage render files in Final Cut Pro for Mac

By default, rendering happens in the background in Final Cut Pro, but you can also manually start rendering for a project or a portion of a project.

Render files are stored in your Final Cut Pro library or in an external location you define. See Set storage locations.

Over time, render files can accumulate and take up storage space. Unused render files can also accumulate when you do any of the following:

- Make changes to a project timeline
- Update Final Cut Pro, macOS, or third-party plug-ins
- Move a library between computers with different versions of macOS

If you want to free up storage space, you can delete unused render files in selected events. You can also delete all render files for projects, events, or libraries. Original media files are not deleted, so you can always regenerate render files from the original media.

Note: The Delete Generated Files commands delete render, optimized, and proxy files only. See Create optimized and proxy files.

Render all or part of a project

In Final Cut Pro, do one of the following:

- Render a portion of your project: In the timeline, select the clip or clips that you want to render, then choose Modify > Render Selection (or press Control-R).
  
  Note: The selection must be a clip selection, not a range selection. See Select one or more clips and Select a range.

- Render all portions of your project that need rendering: Choose Modify > Render All (or press Control-Shift-R).

Final Cut Pro renders the portions of the project that you defined and removes the corresponding dotted render indicator. You can view the progress of rendering in the Background Tasks window.

Delete clip render files

1. Select one or more clips in the Final Cut Pro browser.
2. Choose File > Delete Generated Clip Files.
3. In the window that appears, select Delete Render Files and click OK.

Delete project render files

1. Select one or more projects in the Final Cut Pro browser.
2. Choose File > Delete Generated Project Files.
3. In the window that appears, select Delete Render Files and click OK.
Delete event render files
1. In the Libraries sidebar in Final Cut Pro, select one or more events in the same library.
2. Choose File > Delete Generated Event Files.
3. In the window that appears, select Delete Render Files.
4. Select whether to delete unused render files or all render files, then click OK.

*Note:* If you choose to delete all render files in an event, any project render files in that event are also deleted.

Delete render files from a library
1. In the Libraries sidebar in Final Cut Pro, select a library.
2. Choose File > Delete Generated Library Files.
3. In the window that appears, select Delete Render Files.
4. Select whether to delete unused render files or all render files, then click OK.

View background tasks in Final Cut Pro for Mac
Many Final Cut Pro tasks take place in the background:
- Importing
- Transcoding
- Analyzing and optimizing video and audio
- Rendering
- Sharing
- Transferring remote media
- Backing up libraries

Final Cut Pro manages background tasks automatically, so you don’t need to do anything to start or pause them. If you want to see the progress of any of the background processes, you can open the Background Tasks window, which shows the tasks being performed and the percentage of completion.

*Important:* If you actively use Final Cut Pro while background tasks are running, the background tasks are paused. The tasks resume when you stop using Final Cut Pro.

View tasks that are running in the background
1. In Final Cut Pro, do one of the following:
   - Choose Window > Background Tasks (or press Command-9).
   - In the toolbar, click the Background Tasks button.
2. To view the active tasks in a section, click its disclosure triangle.

![Background Tasks](image)

### Pause or resume a background task
- In the Background Tasks window in Final Cut Pro, click the Pause button ⏸️ or Resume button ⏯️.

### Cancel a background task
- In the Background Tasks window in Final Cut Pro, click the Cancel button ✗.

## Manage libraries

### Intro to managing libraries in Final Cut Pro for Mac
You can work with multiple libraries in Final Cut Pro, opening and closing them as needed. You can easily copy events and projects between libraries, which makes it simple and quick to move media, metadata, and creative work to another system so that you can edit on a portable computer, collaborate with other editors, or archive your projects and media.

![Managing Libraries](image)

Select an event in the Libraries sidebar.

Show or hide the Libraries sidebar.

Click the disclosure triangle for a library to show or hide its events.

The browser displays clips and projects in the selected event.

For each library, you can set storage locations for media files, cache files, and library backups. See Set storage locations.
Create a new library in Final Cut Pro for Mac

You can create new, empty libraries, or you can create libraries from existing events.

1. If the Final Cut Pro Libraries sidebar isn’t already shown, do one of the following:
   - Click the Libraries button in the top-left corner of the Final Cut Pro window.
   - Choose Window > Go To > Libraries (or press Command-1).

2. Do one of the following:
   - Create an empty library: Choose File > New > Library, navigate to a location on your Mac or storage device where you want to save the library, enter a name, and click Save.
     Note: You can’t store your Final Cut Pro library on a storage device that’s used for Time Machine backups.
   - Create a library from existing events: Select one or more events in an existing library, then choose File > Copy Events to Library > New Library, navigate to a location on your Mac or storage device where you want to save the library, enter a name, and click Save.
     The new library appears in the Libraries sidebar.
     Note: With Final Cut Pro 10.4 or later, you can save a library to a SAN (such as an Xsan storage volume) or an NFS or SMB file system volume and use it as if it were on a local storage device. A network SMB volume must originate from either a macOS server or a Linux server that has Samba 4.3.4 or later and is configured with modules for Apple compatibility. See the Apple Support article Use shared storage with Final Cut Pro.
     If you’re opening a library that uses media on shared storage, be sure to connect the shared storage before opening the library.

Open and close libraries in Final Cut Pro for Mac

You can open and close libraries in the Libraries sidebar as needed, so that you never have too many libraries open at once.

Make sure to close a library before disconnecting an external storage device the library is stored on.

1. If the Final Cut Pro Libraries sidebar isn’t already shown, do one of the following:
   - Click the Libraries button in the top-left corner of the Final Cut Pro window.
   - Choose Window > Go To > Libraries (or press Command-1).
2. Do any of the following:
   - **Open an existing library:** Choose File > Open Library, then choose a library from the submenu. You can also double-click a library file in the Finder.
     If you’re opening a library that uses media on shared storage, be sure to connect the shared storage before opening the library.
   - **Close a library:** Select the library in the Libraries sidebar, then choose File > Close Library.

⚠️ **Tip:** To open specific libraries when you open Final Cut Pro, Option-click the Final Cut Pro app icon in the Dock, then select one or more libraries in the list and click Choose. To select more than one library, Command-click the libraries in the list.

---

### Copy or move items between libraries in Final Cut Pro for Mac

You can copy or move clips, projects, or entire events between libraries in the same storage location or between libraries in different storage locations. You can also copy the contents of one library to another library.

Copying or moving items between libraries lets you:

- Use multiple libraries on the same storage device to organize a large number of active projects and media assets.
- Work on your project and media files on a different Mac that has Final Cut Pro installed.
- Back up your project and its media files to a storage device, a network volume, or other storage media.
- Allow multiple users to access your media in an external folder on shared storage.
- Free up space on your Mac or storage device.

When you *copy* an item from one library to another, the corresponding files are duplicated on the storage device that contains the receiving library. When you *move* an item from one library to another, the corresponding files are moved from the library file in the first storage location to the library file in the second location.

*Note:* If you have created or customized any Final Cut Pro effects, transitions, titles, or generators in Motion, set the storage location for your Motion content to In Library before starting any copy or move operations between libraries or storage devices. Otherwise, the Motion content is not included in those operations. See Manage Motion content.

Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.

---

### Copy items to another library

You can copy clips, projects, events, or the contents of a library to another library.

1. In the Libraries sidebar in Final Cut Pro, do one of the following:
   - Select the event you want to copy.
   - Select the event that contains the clips or projects you want to copy.
   - Select the library you want to copy.

2. If you’re copying clips or projects, select them in the browser.

*Note:* You can’t select clips and projects at the same time.
3. Do one of the following:

- **If the library you want to copy to is present in the Libraries sidebar:** Drag the items to the library. If you’re copying an event, drag it to the library icon 📘. If you’re copying clips and projects, drag them to a specific event icon.

- **If the library you want to copy to is not present in the Libraries sidebar:** Do one of the following:
  - Choose File > Open Library and choose the library from the submenu, then follow the instructions above.
  - Choose File > Copy [item] to Library and choose the library from the submenu, or choose New Library to create a new library and set a location for it.

4. In the window that appears, select options for copying the items, then click OK.

   If you chose to include optimized or proxy media, and the optimized or proxy media isn’t available, you’re given the option to generate the media.

   Final Cut Pro copies the item you selected and the corresponding media to the destination library’s storage location, generating optimized or proxy media at that location if needed.

---

### Move items between libraries

You can move clips, projects, or events between libraries.

1. In the Libraries sidebar in Final Cut Pro, select the event you want to move, or select the event that contains the clips or projects you want to move.

2. If you’re moving clips or projects, select them in the browser.
   
   _Note:_ You can’t select clips and projects at the same time.

3. Do one of the following:

   - **If the library you want to move the items to is present in the Libraries sidebar:**
     Command-drag the items to the library by first starting to drag and then holding down the Command key as you drag. If you’re copying an event, drag it to the library icon 📘. If you’re copying clips and projects, drag them to a specific event icon.

   - **If the library you want to move the items to is not present in the Libraries sidebar:** Do one of the following:
     - Choose File > Open Library and choose the library from the submenu, then follow the instructions above.
     - Choose File > Move [item] to Library and choose the library from the submenu, or choose New Library to create a new library and set a location for it.

4. In the window that appears, select the options you want for moving the items, then click OK.

   **Important:** When you import media into Final Cut Pro, you can select the “Leave files in place” option to link to the files in their current location rather than copy them into the library. In that case, Final Cut Pro creates *symbolic links* (also called *symlinks*), which are special files that point to the media files. When you copy or move clips between events, only the symbolic links are copied or moved (not the source media files). To replace the symbolic links with the actual source media files, select the events and choose File > Consolidate Event Files.
Transfer a Final Cut Pro for Mac library to another Mac

You can copy a Final Cut Pro library to an external storage device to save space or to edit your project on another Mac.

Note: You can’t store your Final Cut Pro library on a storage device that’s used for Time Machine backups.

1. Connect an external storage device to your Mac.
2. In the Libraries sidebar in Final Cut Pro, select the library you want to copy.
3. To open the Library Properties inspector, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button in the toolbar.

4. In the Media section, make sure the media storage location is set to In Library, then click Consolidate.
   See Set storage locations.

5. If your project contains effects, transitions, titles, and generators that were created or customized in Motion, make sure the Motion Content storage location is set to In Library, then click Consolidate.
   Note: As an alternative, you could manually back up and copy the Motion Templates folder located in your Movies folder. Regardless, you must manually track and move any third-party (FxPlug) content, because it’s not managed within the Final Cut Pro library.

6. Quit Final Cut Pro.
   **Important:** Always make sure that Final Cut Pro is not open when you copy or move libraries in the Finder.

7. In the Finder, drag the library file to the icon for the connected external storage device.
   If you can’t find the library file in the Finder, open Final Cut Pro, select the library in the Libraries sidebar, then choose File > Reveal in Finder (or press Shift-Command-R).
   The library is copied to the external storage device.

8. When copying is complete, eject the external storage device and disconnect it from your Mac.

9. Connect the external storage device to the new (destination) Mac.

10. Drag the library file to the folder on the new Mac where you want to store the file.

11. To open the library, double-click its icon.
Set storage locations in Final Cut Pro for Mac

You can set storage locations for each of your libraries. You view and define storage locations for media, Motion content, cache files, and library backup files using the Library Properties inspector. You can store these files within the library or in external folders. You can also consolidate (collect all files as managed media) inside the library for easy transport or archiving. See What are libraries? for more information about managed and external media.

View and set library storage locations

1. In the Libraries sidebar in Final Cut Pro, select a library.
2. If the Library Properties inspector isn’t already shown, do one of the following:
   - Choose File > Library Properties (or press Control-Command-J).
   - Click the Inspector button in the toolbar.

   The inspector shows the storage locations for the selected library.

   The Storage Used for Media and Motion Content section (near the bottom of the inspector) shows a list of storage devices for the existing media and custom Motion content in the selected library, including the total amount of original, optimized, and proxy media stored on each device. (This is media that was previously imported or generated for the selected library.)

3. Click Modify Settings.

   A window appears with pop-up menus that you can use to set storage locations. By default, media and cache files are stored within the library, Motion content is stored in the Motion Templates folder located in your Movies folder, and backups of the library database are stored in your Movies folder.

4. Use the pop-up menus to set storage locations for the library:
   - **Media**: Choose the storage location for imported files, proxy and optimized files, and consolidated files. To store files outside the library, choose “Choose,” navigate to a storage location, then click Choose.
   - **Motion Content**: Choose the storage location for effects, transitions, titles, and generators created or customized in Motion. See Manage Motion content.
   - **Cache**: Choose the storage location for render files, analysis files, thumbnail images, and audio waveform files. To store files outside the library, choose “Choose,” navigate to a storage location, then click Choose.
   - **Backups**: Choose the storage location for library backups. To store backups outside the Movies folder, choose “Choose,” navigate to a storage location, then click Choose. If you don’t want Final Cut Pro to back up your library, choose Do Not Save.

   Note: By default, Final Cut Pro makes automatic library backups at regular intervals. Backups include the database portion of libraries only, not the media files. Backups are saved with the time and date in the filename. To open a backup from a specific time and date and add it to the Libraries sidebar in Final Cut Pro, choose File > Open Library > From Backup. See Restore a library.
5. When you’re finished setting storage locations, click OK.

Your new storage locations are used for future source media file imports, Motion content, cache files, and library backups.

**Important:** Existing source media and backup files remain in their original locations. If you changed the cache storage location, you’re asked if you want to move your existing active render files to the new location.

### Consolidate media and Motion content files for a library

1. In the Libraries sidebar in Final Cut Pro, select a library.

2. If the Library Properties inspector isn’t already shown, do one of the following:
   - Choose File > Library Properties (or press Control-Command-J).
   - Click the Inspector button in the toolbar.

3. In the Media section of the Library Properties inspector, click Consolidate.

4. If you want to include optimized and proxy media, select the checkboxes in the window that appears, then click OK.

   Final Cut Pro copies the media into the selected library file, or into the external storage location. To view or change library storage locations, see [View and set library storage locations](#), above.

   For more information about consolidating media files, see [Consolidate projects and libraries](#).

5. If your project contains effects, transitions, titles, or generators that were created or customized in Motion, make sure the Motion Content section of the Library Properties inspector is set to either In Library or “In Motion Templates folder,” then click Consolidate.

   Final Cut Pro copies the media into the selected library file, or into the Motion Templates folder. To view or change library storage locations, see [View and set library storage locations](#), above.

   **Note:** You must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.
Manage Motion content in Final Cut Pro for Mac

By default, when you create or customize any Final Cut Pro effects, transitions, titles, or generators in Motion, that content is stored in the Motion Templates folder located in your Movies folder. You can also store Motion content inside a library—for example, to move a project or library to another Mac, or to back up and archive your work. You may also want to store Motion content in the library if you’re working on a project with others and using shared storage.

If you have custom Motion content and you’re copying or moving clips, projects, or events to another library, storage device, or Mac, set the storage location for your Motion content to the library before doing so. Otherwise, the Motion content is not moved or copied with the other items, and you must manually back up and move the Motion Templates folder. Regardless, you must manually track and move any third-party (FxPlug) content, because it is not managed within the Final Cut Pro library.

**Set the Motion content storage location before copying or moving items to another library**

1. In the Libraries sidebar in Final Cut Pro, select the destination library (the library you want to copy to).

2. If the Library Properties inspector isn’t already shown, do one of the following:
   - Choose File > Library Properties (or press Control-Command-J).
   - Click the Inspector button in the toolbar.

3. Click Modify Settings at the top of the Library Properties inspector.
   A window appears with pop-up menus that you can use to set storage locations.

4. Click the Motion Content pop-up menu and choose In Library.

5. Click OK.

The destination library is now ready to receive the Motion content.

For information about copying or moving clips, projects, or events to another library, see *Copy items to another library* and *Move items between libraries*. 
Set the Motion content storage location before copying or moving a library
1. In the Libraries sidebar in Final Cut Pro, select the library you want to copy or move.
2. If the Library Properties inspector isn’t already shown, do one of the following:
   • Choose File > Library Properties (or press Control-Command-J).
   • Click the Inspector button in the toolbar.
3. Click Modify Settings at the top of the LibraryProperties inspector.
   A window appears with pop-up menus that you can use to set storage locations.
4. Click the Motion Content pop-up menu and choose In Library.
5. Click OK.
6. In the Motion Content section of the Library Properties inspector, click Consolidate.
   Note: It’s recommended that you also set the media storage location and click
   Consolidate in the Media section. See Set storage locations.
The Motion content is now stored in the library file and is ready to be copied or moved.
For information about copying or moving entire libraries, see Copy a project to
another Mac.

Filter Motion content stored in a library
If you add custom Motion content—effects, transitions, titles, or generators—to your
project and store it in the library, the items may not appear in the Final Cut Pro media
browsers (the browser, the Effects browser, and the Transitions browser). By default, the
media browsers are set to show the effects, transitions, titles, and generators that came
with Final Cut Pro, and any custom Motion content that is stored in the Motion Templates
folder located in your Movies folder. However, you can use the Filter pop-up menu to show
Motion content stored in a particular library.
1. In Final Cut Pro, do one of the following:

   - **Filter titles and generators:** To show titles and generators in the browser, click the Titles and Generators button in the top-left corner of the Final Cut Pro window, or choose Window > Go To > Titles and Generators (or press Option-Command-1).

   - **Filter effects:** To open the Effects browser, click the Effects button in the top-right corner of the timeline (or press Command-5).

   - **Filter transitions:** To open the Transitions browser, click the Transitions button in the top-right corner of the timeline (or press Control-Command-5).

2. Click the Filter pop-up menu at the top of the media browser for the type of Motion content you want to view, then choose an option:

   - **Installed [items]:** View content that came with Final Cut Pro, and any Motion content that is stored in the Motion Templates folder located in your Movies folder. This is the default setting.

   - **[Library name]:** Choose any open library to view the custom Motion content stored in that library.
Create camera archives in Final Cut Pro for Mac

You can make a camera archive (backup copy) of the contents of your camera or camcorder. (You can’t make an archive from a live video signal, such as the signal produced by an iSight camera.)

Because you can import media into Final Cut Pro from an archive, archiving the media on your device can be useful if you want to:

- Quickly empty the contents of your camera or camcorder so that you can record more media right away, rather than wait for it to be imported into Final Cut Pro.
- Import the archived media on multiple computers without having to keep it on the camcorder
- Keep a browsable, “near-line” archive of media from a camera without having to import the media into Final Cut Pro

For information about importing media into Final Cut Pro from a camera archive, see Import from an archive or disk image.

Archive the media on your file-based camera or camcorder

1. If you want to save the archive to an external storage device, connect it to your Mac.
2. Connect the camera or camcorder to your Mac using the cable that came with the device, and turn on the device.

   See Memory cards and cables.

   If you’re using a camcorder, set it to PC Connect mode. The name of this transfer mode may be different on your device. Your camcorder may automatically go into “connect” mode if you turn it on in playback mode while it’s connected to your Mac. See the documentation that came with your camcorder.

   Note: Connecting a DVD camcorder to your Mac can cause the DVD Player app to open. If that happens, simply close DVD Player.
3. In Final Cut Pro, do one of the following:
   - Choose File > Import > Media (or press Command-I).
   - Click the Import Media button on the left side of the toolbar.

   ![Import Media button in Final Cut Pro toolbar]
4. Select your device in the list of cameras on the left side of the Media Import window.

5. Click the Create Archive button at the bottom-left corner of the window.

6. In the “Create Camera Archive as” field, type a name for the archive.

7. Click the Destination pop-up menu and choose a location to save the archive, then click OK.

   Note: It’s a good idea to save your archive to a disk or partition different from the one where you store the media files used with Final Cut Pro.

The camera archive is stored at the location you chose. You can mount the archive as if it were a file-based camcorder and browse the archive’s contents, or you can import the media on the camera archive into Final Cut Pro.

**Archive the media on your tape-based camera or camcorder**

1. If you want to save the archive to an external storage device, connect it to your Mac.

2. Connect the camera or camcorder to your Mac using the cable that came with the device, and turn on the device.

   See Memory cards and cables.

   If you’re using a camcorder, set it to PC Connect mode. The name of this transfer mode may be different on your device. Your camcorder may automatically go into “connect” mode if you turn it on in playback mode while it’s connected to your Mac. See the documentation that came with your camcorder.
3. In Final Cut Pro, do one of the following:
   - Choose File > Import > Media (or press Command-I).
   - Click the Import Media button on the left side of the toolbar.

4. Select your device in the list of cameras on the left side of the Media Import window.

5. Click the Create Archive button at the bottom-left corner of the window.

6. In the “Create Camera Archive as” field, type a name for the archive.

7. Click the Destination pop-up menu and choose a location to save the archive, then click OK.

   **Note:** To protect your media, it’s a good idea to save your archive to a disk or partition different from the one where you store the media files used with Final Cut Pro.

   Final Cut Pro begins archiving from the current location on the tape. Archiving continues until one of the following occurs:
   - The end of the tape is reached.
   - You stop the archiving process by clicking Stop Import or Close (to close the Media Import window).

   The camera archive is stored at the location you chose. You can mount the archive as if it were a file-based camcorder and browse the archive’s contents, or you can import the media on the camera archive into Final Cut Pro.
Move or copy a camera archive
1. In the Finder, select the camera archive that you want to move or copy.
2. Do one of the following:
   - Move the camera archive on your local disk: Drag the camera archive to a new location.
   - Copy the camera archive on your local disk: Hold down the Option key and drag the camera archive to a new location on your local disk.
   - Copy the camera archive to an external storage device: Drag the camera archive to a location on the external storage device.

Delete a camera archive
Camera archives are very small relative to other media files, and often don’t warrant being deleted. However, you can delete a camera archive at any time.
1. Control-click the camera archive in the Finder, then choose Move to Trash.
2. Control-click the Trash icon in the Dock, then choose Empty Trash.
   Important: Emptying the Trash permanently deletes the camera archive.

Common media management issues

Alert icons in Final Cut Pro for Mac
When you see red frames and a yellow alert triangle in the timeline or an event, it means that part of your project or event is missing. There are many reasons that clips, events, media files, and effects can be missing—for example, moving projects, events, and files between computers or actively managing your media using the Finder.

Final Cut Pro events and clips

<table>
<thead>
<tr>
<th>Icon</th>
<th>Alert</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Missing Clip Icon" /></td>
<td>Missing Clip</td>
<td>A clip used in a Final Cut Pro project or event is not available. You may see this alert if you moved the clip to the Trash, moved a clip (or an event), moved a project to a different location, or consolidated a different project’s media.</td>
</tr>
<tr>
<td><img src="image" alt="Missing Camera Icon" /></td>
<td>Missing Camera</td>
<td>A camera that contains files used in Final Cut Pro is not connected to your system. To avoid getting this alert, create a copy of the media when you import it. See Organize files during import.</td>
</tr>
</tbody>
</table>
## Media files

<table>
<thead>
<tr>
<th>Icon</th>
<th>Alert</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Missing File" /></td>
<td>Missing File</td>
<td>A file is not available in the Finder. You may see this alert if you moved or renamed a file in the Finder, moved an event or a project to a different location, or consolidated a different project's media.</td>
</tr>
<tr>
<td><img src="image" alt="Modified File" /></td>
<td>Modified File</td>
<td>A media file has been changed by an app other than Final Cut Pro.</td>
</tr>
<tr>
<td><img src="image" alt="Missing Proxy File" /></td>
<td>Missing Proxy File</td>
<td>A proxy file created by Final Cut Pro is not in its expected location in the Finder. See Create optimized and proxy files.</td>
</tr>
<tr>
<td><img src="image" alt="Missing Remote Media" /></td>
<td>Missing Remote Media</td>
<td>Some remote media was not downloaded completely. There may be connection issues with the local or remote network, permissions may have expired, or files may no longer exist on the server.</td>
</tr>
<tr>
<td><img src="image" alt="Downloading Remote Media" /></td>
<td>Downloading Remote Media</td>
<td>Some remote media is being downloaded.</td>
</tr>
<tr>
<td><img src="image" alt="Missing Plug-In" /></td>
<td>Missing Plug-In</td>
<td>A plug-in is missing. Some media file formats require that you download and install an additional software plug-in. You may see this alert if the plug-in is not installed correctly.</td>
</tr>
</tbody>
</table>
### Final Cut Pro effects

<table>
<thead>
<tr>
<th>Icon</th>
<th>Alert</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Missing Effect Icon" /></td>
<td>Missing Effect</td>
<td>An effect in Final Cut Pro is missing.</td>
</tr>
<tr>
<td><img src="image" alt="Missing Generator Icon" /></td>
<td>Missing Generator</td>
<td>A generator in Final Cut Pro is missing.</td>
</tr>
<tr>
<td><img src="image" alt="Missing Title Icon" /></td>
<td>Missing Title</td>
<td>A title in Final Cut Pro is missing.</td>
</tr>
<tr>
<td><img src="image" alt="Missing Transition Icon" /></td>
<td>Missing Transition</td>
<td>A transition in Final Cut Pro is missing.</td>
</tr>
<tr>
<td><img src="image" alt="Missing LUT Icon" /></td>
<td>Missing LUT</td>
<td>A LUT in Final Cut Pro is missing. See Apply LUTs.</td>
</tr>
</tbody>
</table>

### Solutions to media management issues in Final Cut Pro for Mac

This section describes common media management issues and solutions.

**If you can’t relink clips to media files transcoded in Compressor**

If media files that you transcoded in Compressor are not automatically matched and relinked in Final Cut Pro, it may be because of how the files were named.

For example, if you use Compressor to batch transcode proxy files from a set of source media files, the setting name is appended to the end of the filename as a suffix. You can change the filename that Compressor assigns at any time. See “Set a custom location's filename format” in Work with locations in Compressor.

During the relinking process, Final Cut Pro looks for matches between the source filename and the output filename. The source and output filenames can have nonmatching suffixes as long as each suffix is preceded by an underscore (_) or hyphen (-). Using other characters or symbols before a suffix will prevent automatic matching to the original clips in your Final Cut Pro library.
**Note:** You can still manually relink clips to compatible files with any filename, by selecting a clip in the Relink Files window, clicking Locate Selected, and navigating to the files one at a time. See [Relink clips to media files](#).

To ensure automatic matching and relinking, follow these filenaming guidelines:

- Use the underscore (_) or hyphen (-) character before a filename suffix.
- Don’t precede a filename suffix with other characters such as the plus sign (+), slash (/), or backslash (\).

For examples, see the table below.

<table>
<thead>
<tr>
<th>Source filename</th>
<th>Output filename</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>A.mov</td>
<td>A+suffix.mov</td>
<td>Will not match because of the plus sign (+).</td>
</tr>
<tr>
<td>A_B.mov</td>
<td>A_suffix.mov</td>
<td>Will match, because “_B” is a valid suffix.</td>
</tr>
<tr>
<td>A-B.mov</td>
<td>A_B.mov</td>
<td>Will match, because both “-B” and “_B” are valid suffixes.</td>
</tr>
<tr>
<td>A_B.mov</td>
<td>A_B_suffix.mov</td>
<td>Will match, because Final Cut Pro compares the output filename without the suffix against the source filename.</td>
</tr>
<tr>
<td>A_B_C.mov</td>
<td>A_B_C_suffix.mov</td>
<td>Will match, because Final Cut Pro compares the output filename without the suffix against the source filename.</td>
</tr>
</tbody>
</table>

**Note:** When two or more matching files exist in a folder, Final Cut Pro does not automatically relink to either one of them.

**If you see an alert indicating that a file is missing**

You may see a Missing File alert if you move or rename a file in the Finder.

1. In the Finder, change the filename back to the filename used in the Final Cut Pro browser.
2. Quit and reopen Final Cut Pro.
   The file is relinked to the clip when Final Cut Pro opens.
If a clip was not imported correctly

If you canceled an import and didn’t import an entire clip, the clip has a camera icon on its bottom-left corner.

- Follow the instructions in Reimport a clip.

If your DSLR camera isn’t recognized by Final Cut Pro

- Follow the instructions in Import from digital still cameras.
Work smarter

Final Cut Pro settings

Intro to settings in Final Cut Pro for Mac

In Final Cut Pro, you can modify settings to specify how your source media is imported into the app, how your clips play back, and how you edit your clips in the timeline.

For details about settings, see the following topics:

- General settings
- Editing settings
- Playback settings
- Import settings
- Intro to Destinations settings
Change settings in Final Cut Pro for Mac

A setting modifies how a particular Final Cut Pro feature behaves. Most settings can be turned on or off at any time. The following topics describe Final Cut Pro settings in detail.

Open Final Cut Pro settings

- Choose Final Cut Pro > Settings (or press Command-Comma), then click a button at the top of the window to open a settings pane.

Note: On systems with macOS Monterey or earlier, “Settings” appears as “Preferences” in the Final Cut Pro menu.

Copy Final Cut Pro settings between computers

You can copy Final Cut Pro settings to another Mac that has Final Cut Pro installed so that the settings are the same on both computers.

1. Find the Final Cut Pro settings file in the following location:
   `/Users/username/Library/Preferences/com.apple.FinalCut.plist`
2. Copy the settings file to the same location on the other Mac.
   If necessary, overwrite any existing version of the file at that location.

Reset Final Cut Pro settings

You can reset Final Cut Pro settings to their original values.

- Press Option-Command while opening Final Cut Pro.

  Final Cut Pro resets the settings and adds a file named `VideoAppDiagnostics-FinalCut` to the desktop, containing a record of your previous settings.

General settings in Final Cut Pro for Mac

General settings are basic settings in Final Cut Pro.

![General settings in Final Cut Pro for Mac](image)
Time Display

• **Time Display:** Use this pop-up menu to choose the time mode for Final Cut Pro. Changes to this setting affect the timecode display below the viewer (for the position of the skimmer or the playhead), as well as trimming and navigation operations in Final Cut Pro. You have the following options:
  • Timecode display
  • Timecode display including subframes
  • Duration in frames
  • Duration in seconds

Dialog warnings

• **Reset All:** Click this button to reset all warning dialogs that you dismissed by selecting the “Do not remind me again” checkbox.

Audio Units

• **Validate on Next Launch:** If you encounter issues with third-party Audio Units effects, click this button to have Final Cut Pro validate all installed third-party Audio Units effects the next time you open the app. Final Cut Pro performs a series of tests to verify that each Audio Units effect is operating correctly, and notifies you of any Audio Units effects that fail. Validation is performed automatically the first time Final Cut Pro is opened and whenever Audio Units effects are installed or reinstalled, so you don’t normally need to click this button.

Inspector Units

• **Inspector Units:** Use this pop-up menu to choose how values are displayed in inspector controls for the Transform, Crop, and Distort effects.
  • **Pixels:** Choose this setting to display values as pixels.
  • **Percentages:** Choose this setting to display values as percentages.

Color Correction

• **Color Correction:** Use this pop-up menu to choose the default color correction effect. The controls for the default color correction effect appear when you open the Color inspector. You can choose the following color correction effects:
  • Color Board
  • Color Wheels
  • Color Curves
  • Hue/Saturation Curves
  • Color Adjustments

HDR

*Automatic Color Conform:* Select this checkbox to set the Color Conform effect to Auto when importing a clip. Or deselect the checkbox to set the Color Conform effect to None when importing a clip. See **Use automatic color management and Color Conform.**
Editing settings in Final Cut Pro for Mac

Editing settings affect editing behaviors in Final Cut Pro.

![Editing settings interface](image)

### Timeline
- **Show detailed trimming feedback**: Select this checkbox to show the “two-up” display in the viewer for more accurate feedback on an edit point involving two adjacent clips. For example, for a simple ripple or roll edit, this display shows the end point of the left clip and the start point of the right clip.
- **Position playhead after edit operation**: Select this checkbox to have the playhead automatically positioned in the timeline at the end of your last edit. For example, if you insert a clip between two clips in the timeline, the playhead is automatically positioned between the inserted clip and the clip that follows it.

### Audio
- **Show reference waveforms**: Select this checkbox to change the background appearance of the audio portion of a clip to show reference waveforms. A reference waveform shows the maximum visual resolution possible for the actual audio waveform. By factoring out loudness, reference waveforms let you see the shape of the sound more clearly. When the actual waveform changes shape (for example, it’s diminished when a clip’s volume level is low), you can continue to see its reference waveform in full for easy reference when editing.

### Durations
- **Audio Fade**: Use this value slider to set the default duration, in seconds, for audio fades created using the Apply Fades command (choose Modify > Adjust Audio Fades > Apply Fades).
- **Crossfade**: Use this value slider to set the default duration, in seconds, for audio crossfades.
- **Still Image**: Use this value slider to set the default editing duration, in seconds, for still-image and freeze-frame clips.
- **Transition**: Use this value slider to set the default duration, in seconds, for video transitions.
Playback settings in Final Cut Pro for Mac

Playback settings affect playback and rendering performance in Final Cut Pro.

![Playback settings in Final Cut Pro for Mac](image)

**Note:** For information about controlling playback quality and performance, including switching between original or optimized media and proxy media, see Control playback quality.

**Rendering**

- *Background render*: Select this checkbox to turn on Final Cut Pro rendering operations when the system is idle.
- *Start after x seconds*: Use this value slider to set the amount of time your system is idle, in seconds, before Final Cut Pro begins background rendering.

**Render/Share GPU**

- *Render/Share GPU*: Use this pop-up menu to choose which graphics processing unit (GPU) to use in Final Cut Pro when rendering or sharing. This choice affects only rendering and sharing; real-time effects use the default GPU.
Playback

- **Scroll timeline continuously during playback**: Select this checkbox to set the timeline to scroll during playback, so that the timeline always shows the section of the project playing in the viewer.

- **Create optimized media for multicam clips**: Select this checkbox to automatically transcode multicam clip video to the Apple ProRes 422 codec, which provides better performance during editing and faster render times.

- **If a frame drops, stop playback and warn**: Select this checkbox to have Final Cut Pro warn you when frames are dropped during playback.

- **If frames drop due to disk performance, warn after playback**: Select this checkbox to have Final Cut Pro warn you if frames were dropped because of disk performance.

- **If frames drop on VR headset, warn after playback**: Select this checkbox to have Final Cut Pro warn you if frames were dropped on a connected VR headset display.

Pre-Roll Duration

- **Pre-Roll Duration**: Use this value slider to set the amount of time to play before an audition or before the skimmer or playhead position when using the Play Around command.

Post-Roll Duration

- **Post-Roll Duration**: Use this value slider to set the amount of time to play after an audition or after the skimmer or playhead position when using the Play Around command.

Player Background

- **Player Background**: Use this pop-up menu to choose a background for the viewer. The color you choose will be visible in the case of partially or completely transparent clips, or clips that don’t fill the frame completely.

A/V Output

- **A/V Output**: Use this pop-up menu to choose an external audio/video device or monitor for output. See Play media on an external display.

- **Show HDR as Tone Mapped**: Select this checkbox to compress bright image content and reduce the apparent dynamic range of the video to fit the viewable range of the external video display. This checkbox is available only for external displays connected using an HDMI or Thunderbolt 3 cable on systems with macOS 10.15 or later. This option is disabled if a connected Pro Display XDR is set to a reference mode preset, such as HDR Video, in Displays settings (in macOS System Settings).
Import settings in Final Cut Pro for Mac

When you import media into Final Cut Pro using the Media Import window, you can customize your import settings each time you import files. However, if you drag media directly into Final Cut Pro from the Finder, Final Cut Pro uses the import settings you selected in the Import pane of the Final Cut Pro Settings window.

Files

Choose a storage location for the media files:

- **Copy to library storage location**: This option duplicates the media files and places the copies in the current library storage location. You can set storage locations for each of your libraries. See [Set storage locations](#).

- **Leave files in place**: If you import files with this option selected, Final Cut Pro creates symbolic links (also called symlinks), which are special files that point to the media files without copying them. When you move, copy, or back up events and projects that use these files, only the symbolic links are copied or moved, not the source media files. If, after you move or copy your project or event, you want to replace the symbolic links with the actual source media files, select the events and choose File > Consolidate Event Files. See [Media files and clips](#).
Keywords

- **From Finder tags:** Creates a Keyword Collection for each Finder tag assigned to the files you’re importing. If the files you’re importing have tags, select this option to keep the tag organization that exists in the Finder. For more information about Finder tags, see macOS Help (available from the Help menu when the Finder is active).

  *Note:* For REDCODE RAW files only, Keyword Collections are based on tags assigned to the enclosing folder.

- **From folders:** Creates a Keyword Collection for each folder in the files you’re importing. Select this option to preserve the file organization that exists in the Finder. (Although Keyword Collections don’t appear in a hierarchy in the Libraries sidebar, every file in a folder is assigned a keyword for each folder it’s in, whether it’s one, two, or more levels deep in that folder.)

Analyze Video

- **Balance color:** Analyzes video clips and detects color cast and contrast issues. Color is automatically balanced when you drag the clip to the timeline. You can fix color balance for a clip in an event by turning on Balance in the Color section of the Video inspector. You can turn off the automatic color adjustments at any time to display the colors that were originally recorded.

- **Find people:** Analyzes clips with video for the presence of people and shot types. After analysis, any of the following keywords are added to the clip: One Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot. The “Consolidate find people results” checkbox simplifies and summarizes all of the “find people” analysis keywords. See Video analysis options. If you’re analyzing to find people, it’s recommended that you also select the Create Smart Collection checkbox.

- **Create Smart Collection:** Creates Smart Collections for each keyword applied when video clips are analyzed for image stabilization problems or the presence of people. The Smart Collections appear in a folder inside the event.
Transcode

• **Create optimized media**: This option transcodes video to the Apple ProRes 422 codec, which provides better performance during editing, faster render times, and better color quality for compositing. If the original camera format can be edited with good performance, this option is dimmed.

• **Create proxy media**: This option transcodes video to high-quality files useful for offline editing. Video proxy files can use considerably less storage space, often enough to allow you to work on a portable computer instead of a desktop computer with significantly more memory and processing power.

  • **Codec**: This option allows you to select a codec for your proxy media: Apple ProRes 422 Proxy or H.264.
    - **ProRes Proxy**: Creates higher-quality Apple ProRes 422 Proxy files. This option is required for HDR and ProRes RAW source media.
    - **H.264**: Creates smaller proxy file sizes. This option is appropriate for SDR projects and source media.
  
  • **Frame Size**: This pop-up menu allows you to choose a frame size for the transcoded media (either as a percentage of the original or as maximum pixel dimensions).
    - To specify a percentage of the source media frame size, you can choose Same as Source (100%), 50%, 25%, or 12.5%.
    - To specify maximum pixel dimensions, you can choose 3840 x 2160, 1920 x 1080, or 960 x 540. Final Cut Pro maintains the source media aspect ratio without exceeding these dimensions.

See [Create optimized and proxy files](#).

*Note*: To control whether Final Cut Pro displays optimized, proxy, or original media in the viewer, and whether video playback is optimized for quality or performance, choose the corresponding options from the View pop-up menu in the upper-right corner of the viewer. See [Control playback quality](#).

Analyze Audio

• **Fix audio problems**: Analyzes audio and automatically corrects it for hum, noise, and loudness. You can turn off automatic audio corrections at any time; after you do so, the audio plays as originally recorded.

• **Separate mono and group stereo audio**: Analyzes audio channels and groups them as dual mono or stereo, depending on the results of the analysis.

• **Remove silent channels**: Audio channels are analyzed, and silent channels are removed.

  *Note*: You can retrieve the original audio configuration after import. See [Configure audio channels](#).
Assign Audio Role

- **Assign Audio Role:** This pop-up menu allows you to override the automatic role assignment process during import so that every imported clip is assigned to a role of your choosing. You can specify one of the three default audio roles or a custom role that you create yourself. See *Override automatic role assignment for audio files during import*. If the “Assign iXML track names if available” checkbox is selected, Final Cut Pro detects iXML metadata tags in an audio channel and creates and assigns roles to the corresponding audio components in the imported clips, based on the iXML names. See *Create custom roles automatically during import using iXML metadata*.

Destinations settings

**Intro to Destinations settings in Final Cut Pro for Mac**

You modify share destinations in the Destinations pane of the Final Cut Pro Settings window. The destinations in the Destinations list (on the left side of the Destinations pane) also appear in the Share submenu of the File menu and in the menu that appears when you click the Share button in the toolbar.

When you first open Final Cut Pro, a default set of destinations appears in the Destinations list, but you can add other destinations and customize destinations. To see the destinations you can add, select Add Destination in the Destinations list. When you select a destination in the Destinations list, its settings appear on the right.

![Destinations settings](image)

The settings available for each destination are described in the following topics. For information about adding and modifying destinations, see *Create share destinations*. 
DVD and Blu-ray / AVCHD destinations in Final Cut Pro for Mac

Use these destinations to burn your project or clip to a standard-definition (SD) DVD, a Blu-ray-compatible disc, or an AVCHD-compatible disc. You can also create a disk image (.img) file that you can copy to an external drive or burn to a disc later.

Note: The Blu-ray / AVCHD destination does not appear by default. To add it to the Destinations list, see Create share destinations.

The DVD and Blu-ray / AVCHD destinations include the following settings:

- **Output Device**: Displays your system's suitable output devices, including optical drives and the computer's internal disk.
  
  You can use your computer’s internal disk to create a disk image (.img) file that you can copy to an external drive or burn to DVD media later.

- **Layers**: Displays the available layers on the destination media.
  
  - **Automatic**: Automatically detects the type of disc you can use.
  
  - **Single-layer**: Identifies the disc as a single-layer disc. You can use this option to force a double-layer disc to be treated as a single-layer disc.
  
  - **Double-layer**: Identifies the disc as a double-layer disc. You can use this option to force the disk image to be formatted for a double-layer disc when you choose Hard Drive as your output device.
    
    **Important**: Depending on the project’s length, choosing Double-layer when using a single-layer disc may result in an error while burning the disc.

- **Build type**: The DVD destination builds a VIDEO_TS folder; the Blu-ray / AVCHD destination builds a BDMV folder. These folders contain files correctly formatted for the type of disc selected. Use this pop-up menu to choose how you want to save that data:
  
  - **Disc**: Available when Output Device is set to a compatible device, burns the folder to a disc.
  
  - **File**: Available when Output Device is set to Hard Drive, embeds the folder into a disk image file that is formatted correctly to be burned to a disc later.
  
  - **Folder**: Available when Output Device is set to Hard Drive, leaves the folder as is; the media can then be played or later burned to a disc.

- **Disc template**: Displays the available disc templates.

- **Title**: Type the disc title in the text field. This title will be displayed on the disc menus.

- **Volume name**: Type the name that will appear when the disc is mounted on a computer. Only uppercase characters and certain punctuation marks are permitted in the name. Volume names are typically limited to 30 characters.

- **Color Space**: Indicates the color space of the output media file.

- **When disc loads**: Displays the automatic action taken when you play the disc.
  
  - **Show Menu**: Displays the main menu.
  
  - **Play Movie**: Begins playing the movie immediately.

- **Markers**: Not available for Blu-ray when using an AVCHD output device. Select the checkbox to include chapter marker text as subtitles on the output disc. Users can navigate between the chapter markers by pressing the Next Chapter or Previous Chapter button on the DVD or Blu-ray player. See Add chapter markers.
• **Loop:** Select this checkbox to add a Loop Movie button to the disc main menu. This gives users the option to play the movie in a continuous loop.

• **Background:** Click the Add button to select a graphic for the disc's background. This image will be used instead of the template background.

• **Logo image:** Click the Add button to select a logo graphic that will be displayed in the upper-right corner of the disc menus. This image will appear on top of the menu background.

• **Title image:** Click the Add button to select a title graphic that will be displayed in the center of the main menu of the disc. This image will appear on top of the menu background.

• **Preview:** Shows a thumbnail preview of the main menu.

• **Include captions:** If you added CEA-608 captions to your project, you can choose a language version to include on the DVD. See Intro to captions.

• **Burn in captions:** If you added captions to your project, you can choose a caption language to burn in to the output media file.

  *Note:* Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

**Email destination in Final Cut Pro for Mac**

Use this destination to email your project or clip using Mail, Apple’s email app. The Email destination automatically creates an email message that includes the exported file.

*Note:* The Email destination does not appear by default. To add it to the Destinations list, see Create share destinations.

The Email destination includes the following settings:

• **Resolution:** Choose a resolution.

• **Compression:** Choose “Multi-pass (Better)” to maximize the quality. Choose “Single-pass (Faster)” to speed up the encoding.

• **Embed CEA-608:** If you added captions to your project, you can choose a CEA-608 language version to embed in the output media file.

• **Burn in captions:** If you added captions to your project, you can choose a caption language to burn in to the output media file.

  *Note:* Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

• **Allow export segmentation:** Speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing. See Speed up exports with simultaneous processing.
Social Platforms destination in Final Cut Pro for Mac

Use this destination to save a project or clip as a file that is ready for posting on video-sharing websites.

The Social Platforms destination (previously the YouTube & Facebook destination) includes the following settings:

- **Resolution**: Choose the default resolution for the destination. If the destination is used with a project or clip that has a lower resolution than the resolution you chose, the resolution changes to match that of the project or clip.
- **Compression**: Choose “Multi-pass (Better)” to maximize the quality. Choose “Single-pass (Faster)” to speed up the encoding.
- **Export captions**: If you added captions to your project, you can choose a language version to include with the video, either as embedded captions or as a separate sidecar file. See Intro to captions.
- **Burn in captions**: If you added captions to your project, you can choose a language version to burn in to the output media file.
  
  *Note*: Burned-in captions are permanently visible in the output file and are not the same as embedded captions.
- **Allow export segmentation**: Speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing. See Speed up exports with simultaneous processing.

Still-image destinations in Final Cut Pro for Mac

Use these destinations to save a still image of any video frame in your project or to save a set of sequentially numbered still-image files.

*Note*: The Save Current Frame and Image Sequence destinations do not appear by default. To add either of them to the Destinations list, see Create share destinations.

The Save Current Frame and Image Sequence destinations include the following settings:

- **Export**: Choose a file type for the exported file.
- **Scale image to preserve aspect ratio**: Select this checkbox to scale the output file to use square pixels and maintain the original aspect ratio (which results in an increase or decrease in the number of horizontal and vertical pixels).
  
  The checkbox affects only projects with formats that use non-square pixels, such as NTSC and PAL formats. If the checkbox is not selected (the default setting), the output file uses the same pixel aspect ratio and has the same number of horizontal and vertical pixels as the original video.
- **Burn in captions**: If you added captions to your project, you can choose a caption language to burn in to the output media file.
  
  *Note*: Burned-in captions are permanently visible in the output file and are not the same as embedded captions.
Export File and Apple Devices destinations in Final Cut Pro for Mac

Use these destinations to export files for Apple devices, computers, and web hosting. You can export your project or clip as a movie file with video and audio, as a video file (with no audio), or as an audio file (with no video).

You can customize these destinations by choosing one of several resolutions, depending on the intended playback device. You can also export one or more of the roles used in your project as one or more files, also known as media stems. If your project includes captions, you can export language versions (subroles) as embedded captions or as separate caption files.

The Export File and Apple Devices destinations include the following settings:

- **Format**: Lists mastering formats (Video and Audio, Video Only, Audio Only) and publishing formats, including Apple Devices (such as iPhone and iPad), Computer (for playback on Mac and PC), and Web Hosting (such as YouTube or Vimeo). Your choice of format determines the options in the pop-up menus below.
  
  **Important**: When sharing a project or clip, you can change the resolution only for publishing formats.

- **Video Codec**: Choose a codec to use for the exported file. (Available choices are based on the source clip or project media format.)

- **Resolution**: Choose the default resolution for the destination. If the destination is used with a project or clip that has a lower resolution than the resolution you chose, the resolution changes to match that of the project or clip. See Modify a project’s settings.

- **Color Space**: The color space for the destination is determined by the project settings and the destination video codec. See Modify a project’s settings.

- **Audio Format**: If you chose Audio Only from the Format pop-up menu, choose an audio format for the exported file. If you chose another option from the Format pop-up menu, this item lists the audio format that will be used for the exported file.

- **Allow export segmentation**: Speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing. See Speed up exports with simultaneous processing.

- **Include chapter markers**: Select the checkbox to include chapter markers that were added to the project in the output file. Users can navigate between the chapter markers by clicking the Next Chapter or Previous Chapter button in QuickTime Player and other apps.
• **Action:** Choose what should happen when the export is complete. You can choose to open the exported file in an app or add it to your media library.

• **Save only:** Choose this option if you don’t want to automatically open the exported file.

• **Open with QuickTime Player (or another app):** Choose this option to open the exported file in the default app associated with the file. You can set or change the default app in the Finder. See macOS Help, available from the Help menu when the Finder is active.

• **Open with Compressor:** Choose this option to open the exported file in Compressor. The exported file will appear as the source in a new batch, making it easy to continue to process the project’s movie. For example, you can create the compressed versions needed for distribution, without involving Final Cut Pro.

  **Note:** This option is available only if Compressor is installed on the same computer as Final Cut Pro.

• **Other:** Choose this option to specify another app to open the exported file. Select the app in the window that appears, then click Open.

• **Home Videos:** Choose this option in the “Add to TV” section to add the exported file to the Home Videos category in the Apple TV app. (If you’re using macOS 10.14 or earlier, this section is labeled “Add to iTunes.”)

### Compressor Settings destination in Final Cut Pro for Mac

Use this destination to export a project or clip using settings from Compressor, the professional transcoding app designed to work directly with Final Cut Pro.

**Note:** The Compressor Settings destination does not appear by default. To add it to the Destinations list, see Create share destinations.

Exporting a project with a Compressor setting provides many of the benefits of Compressor without requiring you to open your project in Compressor. You can use Compressor to create multiple output files in one share operation, or create custom settings that modify your output file (for example, to add a watermark to the video). If you have Compressor installed on your system, you can use any of your Compressor settings with Final Cut Pro.

If you don’t have Compressor installed on your system and you receive a Compressor setting from someone else, put the setting in this location so that Final Cut Pro and Compressor can access it:

/Users/username/Library/Application Support/Compressor/Settings/

You may need to create the Compressor and Settings folders using the Finder.

⚠️ **Tip:** In Mac OS X 10.7 and later, the Library folder within your home folder is hidden by default. To access it in the Finder, hold down Option and choose Go > Library. See macOS Help, available from the Help menu when the Finder is active.
HTTP Live Streaming destination in Final Cut Pro for Mac

Use this destination to send audio and video to iPhone, iPad, iPod touch, and Mac using a web server.

*Note:* The HTTP Live Streaming destination does not appear by default. To add it to the Destinations list, see Create share destinations.

Because HTTP Live Streaming dynamically adjusts movie playback quality to match the available speed of wired or wireless networks, it’s a great way to deliver streaming media to your iOS-based app or HTML5-based website. For detailed information about implementing HTTP Live Streaming, visit the Apple Developer HTTP Live Streaming website.

The HTTP Live Streaming destination includes the following settings:

- **Versions to export:** Select each type of network connection you want to support for streaming. You can export files for use with devices that use cellular or broadband data connections.

- **Allow export segmentation:** Speed up H.264 and HEVC exports by sending segments of your video to available media engines for simultaneous processing. See Speed up exports with simultaneous processing.

- **Burn in captions:** If you added captions to your project, you can choose a caption language to burn in to the output media file.

  *Note:* Burned-in captions are permanently visible in the output file and are not the same as embedded captions.

Bundle destination in Final Cut Pro for Mac

You can group sets of destinations together in a bundle to create several types of output in a single step. When you share a project or clip using the bundle, a file for each destination in the bundle is output automatically. To learn how to create a bundle, see Create share destinations.

Keyboard shortcuts and gestures

Intro to shortcuts and gestures in Final Cut Pro for Mac

Final Cut Pro provides several ways to increase your efficiency while you put together your project:

- **Standard keyboard shortcuts:** Many common tasks, such as opening a specific window or adding a clip from the browser to the timeline, can be accomplished very quickly by pressing one or more keys. See Keyboard shortcuts.

- **Multi-Touch gestures:** If you have a Multi-Touch trackpad or mouse, you can take advantage of Multi-Touch gestures to quickly perform many tasks while creating your project. See Multi-Touch trackpad gestures.
• **Touch Bar:** If your MacBook Pro has a Touch Bar, you can use familiar gestures like swipe and tap to quickly perform tasks such as scrubbing the timeline, applying an audio fade, selecting tools, or editing text. The contents of the Touch Bar are dynamic—the controls change depending on your current selection within Final Cut Pro and other apps. Related buttons and sliders appear together in groups in the bar. See Touch Bar shortcuts.

• **Custom keyboard shortcuts:** You can add to the standard keyboard shortcuts by creating your own custom keyboard shortcuts for features that you use frequently, such as Color Board controls. Or if you’re more familiar with keyboard shortcuts from another app, you can use the Command Editor to substitute those keyboard shortcuts in place of the default set in Final Cut Pro. See View keyboard shortcuts.

### Keyboard shortcuts in Final Cut Pro for Mac

You can use keyboard shortcuts to quickly accomplish many tasks in Final Cut Pro. To use a keyboard shortcut, press all the keys in the shortcut at the same time. Shortcuts for common commands are listed in the table below. For information about viewing, creating, and managing shortcuts, see Intro to the Command Editor.

**Application**

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Final Cut Pro</td>
<td>Hide Application</td>
<td>Command-H</td>
</tr>
<tr>
<td>Hide all applications except Final Cut Pro</td>
<td>Hide Other Applications</td>
<td>Option-Command-H</td>
</tr>
<tr>
<td>Open the Command Editor</td>
<td>Keyboard Customization</td>
<td>Option-Command-K</td>
</tr>
<tr>
<td>Minimize Final Cut Pro</td>
<td>Minimize</td>
<td>Command-M</td>
</tr>
<tr>
<td>Open an existing library or a new library</td>
<td>Open Library</td>
<td>Command-O</td>
</tr>
<tr>
<td>Quit Final Cut Pro</td>
<td>Quit</td>
<td>Command-Q</td>
</tr>
<tr>
<td>Redo the last command</td>
<td>Redo Change</td>
<td>Shift-Command-Z</td>
</tr>
<tr>
<td>Open the Final Cut Pro Settings window</td>
<td>Settings</td>
<td>Command-Comma (,)</td>
</tr>
<tr>
<td>Undo the last command</td>
<td>Undo Change</td>
<td>Command-Z</td>
</tr>
</tbody>
</table>
## Editing

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the audio volume across all selected clips to a specific dB value</td>
<td>Adjust Volume Absolute</td>
<td>Control-Option-L</td>
</tr>
<tr>
<td>Adjust the audio volume across all selected clips by the same dB value</td>
<td>Adjust Volume Relative</td>
<td>Control-L</td>
</tr>
<tr>
<td>Add the selection to the end of the storyline</td>
<td>Append to Storyline</td>
<td>E</td>
</tr>
<tr>
<td>Add the selected clip to the audition</td>
<td>Audition: Add to Audition</td>
<td>Control-Shift-Y</td>
</tr>
<tr>
<td>Create an audition with a timeline clip and a duplicate version of the clip, including applied effects</td>
<td>Audition: Duplicate as Audition</td>
<td>Option-Y</td>
</tr>
<tr>
<td>Duplicate the selected audition clip without applied effects</td>
<td>Audition: Duplicate from Original</td>
<td>Shift-Command-Y</td>
</tr>
<tr>
<td>Create an audition and replace the timeline clip with the current selection</td>
<td>Audition: Replace and Add to Audition</td>
<td>Shift-Y</td>
</tr>
<tr>
<td>Cut the primary storyline clip (or the selection) at the skimmer or playhead location</td>
<td>Blade</td>
<td>Command-B</td>
</tr>
<tr>
<td>Cut all clips at the skimmer or playhead location</td>
<td>Blade All</td>
<td>Shift-Command-B</td>
</tr>
<tr>
<td>Break the selected item into its component parts</td>
<td>Break Apart Clip Items</td>
<td>Shift-Command-G</td>
</tr>
<tr>
<td>Change the duration of the selection</td>
<td>Change Duration</td>
<td>Control-D</td>
</tr>
<tr>
<td>Collapse the selected group of connected clips or storylines into a connected storyline</td>
<td>Collapse to Connected Storyline</td>
<td>Shift-Command-Down Arrow</td>
</tr>
<tr>
<td>Connect the default lower third to the primary storyline</td>
<td>Connect Default Lower Third</td>
<td>Control-Shift-T</td>
</tr>
<tr>
<td>Connect the default title to the primary storyline</td>
<td>Connect Default Title</td>
<td>Control-T</td>
</tr>
<tr>
<td>Connect the selection to the primary storyline</td>
<td>Connect to Primary Storyline</td>
<td>Q</td>
</tr>
<tr>
<td>Connect the selection to the primary storyline, aligning the selection's end point with the skimmer or playhead</td>
<td>Connect to Primary Storyline - Backtimed</td>
<td>Shift-Q</td>
</tr>
<tr>
<td>Copy the selection</td>
<td>Copy</td>
<td>Command-C</td>
</tr>
<tr>
<td>Create an audition from the selection</td>
<td>Create Audition</td>
<td>Command-Y</td>
</tr>
<tr>
<td>Create a storyline from a selection of connected clips that don’t overlap</td>
<td>Create Storyline</td>
<td>Command-G</td>
</tr>
<tr>
<td>Cut the selection</td>
<td>Cut</td>
<td>Command-X</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>----------------------------------------------------------</td>
<td>--------------------------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 1 of the current bank</td>
<td>Cut and Switch to Viewer Angle 1</td>
<td>1</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 2 of the current bank</td>
<td>Cut and Switch to Viewer Angle 2</td>
<td>2</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 3 of the current bank</td>
<td>Cut and Switch to Viewer Angle 3</td>
<td>3</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 4 of the current bank</td>
<td>Cut and Switch to Viewer Angle 4</td>
<td>4</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 5 of the current bank</td>
<td>Cut and Switch to Viewer Angle 5</td>
<td>5</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 6 of the current bank</td>
<td>Cut and Switch to Viewer Angle 6</td>
<td>6</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 7 of the current bank</td>
<td>Cut and Switch to Viewer Angle 7</td>
<td>7</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 8 of the current bank</td>
<td>Cut and Switch to Viewer Angle 8</td>
<td>8</td>
</tr>
<tr>
<td>Cut and switch the multicam clip to angle 9 of the current bank</td>
<td>Cut and Switch to Viewer Angle 9</td>
<td>9</td>
</tr>
<tr>
<td>Delete the timeline selection, reject the browser selection, or remove a through edit</td>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Delete the selection and attach the connected clip or clips to the resulting gap clip</td>
<td>Delete Selection Only</td>
<td>Option-Command-Delete</td>
</tr>
<tr>
<td>Deselect all selected items</td>
<td>Deselect All</td>
<td>Shift-Command-A</td>
</tr>
<tr>
<td>Duplicate the browser selection</td>
<td>Duplicate</td>
<td>Command-D</td>
</tr>
<tr>
<td>Enable or disable playback for the selection</td>
<td>Enable/Disable Clip</td>
<td>V</td>
</tr>
<tr>
<td>View audio and video separately for selected clips</td>
<td>Expand Audio</td>
<td>Control-S</td>
</tr>
<tr>
<td>Expand or collapse audio components for the selection in the timeline</td>
<td>Expand/Collapse Audio Components</td>
<td>Control-Option-S</td>
</tr>
<tr>
<td>Extend the selected edit point to the skimmer or playhead position</td>
<td>Extend Edit</td>
<td>Shift-X</td>
</tr>
<tr>
<td>In the browser list view, add the next item to the selection</td>
<td>Extend Selection Down</td>
<td>Shift-Down Arrow</td>
</tr>
<tr>
<td>In the timeline, add the next item to the selection</td>
<td>Extend Selection to Next Clip</td>
<td>Control-Command-Right-Arrow</td>
</tr>
<tr>
<td>In the browser list view, add the previous item to the selection</td>
<td>Extend Selection Up</td>
<td>Shift-Up Arrow</td>
</tr>
<tr>
<td>Dissolve the audition and replace it with the audition pick</td>
<td>Finalize Audition</td>
<td>Option-Shift-Y</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>----------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Insert the selection at the skimmer or playhead position</td>
<td>Insert</td>
<td>W</td>
</tr>
<tr>
<td>Insert a freeze frame at the playhead or skimmer location in the timeline, or connect a freeze frame from the skimmer or playhead location in the event to the playhead location in the timeline</td>
<td>Insert/Connect Freeze Frame</td>
<td>Option-F</td>
</tr>
<tr>
<td>Insert a gap clip at the skimmer or playhead position</td>
<td>Insert Gap</td>
<td>Option-W</td>
</tr>
<tr>
<td>Insert the default generator at the skimmer or playhead position</td>
<td>Insert Default Generator</td>
<td>Option-Command-W</td>
</tr>
<tr>
<td>Lift the selection from the storyline and connect it to the resulting gap clips</td>
<td>Lift from Storyline</td>
<td>Option-Command-Up Arrow</td>
</tr>
<tr>
<td>Lower the audio volume by 1 dB</td>
<td>Lower Volume 1 dB</td>
<td>Control-Hyphen (-)</td>
</tr>
<tr>
<td>Move the playhead by entering a timecode value</td>
<td>Move Playhead Position</td>
<td>Control-P</td>
</tr>
<tr>
<td>Create a new compound clip (if there's no selection, create an empty compound clip)</td>
<td>New Compound Clip</td>
<td>Option-G</td>
</tr>
<tr>
<td>Nudge the selected audio edit point left by one subframe, creating a split edit</td>
<td>Nudge Audio Subframe Left</td>
<td>Option-Comma (,)</td>
</tr>
<tr>
<td>Nudge the selected audio edit point left by 10 subframes, creating a split edit</td>
<td>Nudge Audio Subframe Left Many</td>
<td>Option-Shift-Comma (,)</td>
</tr>
<tr>
<td>Nudge the selected audio edit point right by one subframe, creating a split edit</td>
<td>Nudge Audio Subframe Right</td>
<td>Option-Period (.)</td>
</tr>
<tr>
<td>Nudge the selected audio edit point right by 10 subframes, creating a split edit</td>
<td>Nudge Audio Subframe Right Many</td>
<td>Option-Shift-Period (.)</td>
</tr>
<tr>
<td>Nudge down the value of the selected keyframe in the animation editor</td>
<td>Nudge Down</td>
<td>Option-Down Arrow</td>
</tr>
<tr>
<td>Nudge the selection one unit to the left</td>
<td>Nudge Left</td>
<td>Comma (,)</td>
</tr>
<tr>
<td>Nudge the selection 10 units to the left</td>
<td>Nudge Left Many</td>
<td>Shift-Comma (,)</td>
</tr>
<tr>
<td>Nudge the selection one unit to the right</td>
<td>Nudge Right</td>
<td>Period (.)</td>
</tr>
<tr>
<td>Nudge the selection 10 units to the right</td>
<td>Nudge Right Many</td>
<td>Shift-Period (,)</td>
</tr>
<tr>
<td>Nudge up the value of the selected keyframe in the animation editor</td>
<td>Nudge Up</td>
<td>Option-Up Arrow</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>------------------------------------------------------</td>
<td>-------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Open the selected audition</td>
<td>Open Audition</td>
<td>Y</td>
</tr>
<tr>
<td>Temporarily override clip connections for the selection</td>
<td>Override Connections</td>
<td>Grave Accent (’)</td>
</tr>
<tr>
<td>Overwrite at the skimmer or playhead position</td>
<td>Overwrite</td>
<td>D</td>
</tr>
<tr>
<td>Overwrite from the skimmer or playhead position back</td>
<td>Overwrite - Backtimed</td>
<td>Shift-D</td>
</tr>
<tr>
<td>Overwrite at the skimmer or playhead position in the primary storyline (with the selected connected clip)</td>
<td>Overwrite to Primary Storyline</td>
<td>Option-Command-Down Arrow</td>
</tr>
<tr>
<td>Paste the selection and connect it to the primary storyline</td>
<td>Paste as Connected</td>
<td>Option-V</td>
</tr>
<tr>
<td>Insert the Clipboard contents at the skimmer or playhead position</td>
<td>Paste Insert at Playhead</td>
<td>Command-V</td>
</tr>
<tr>
<td>Switch to the previous angle in the multicam clip</td>
<td>Previous Angle</td>
<td>Control-Shift-Left Arrow</td>
</tr>
<tr>
<td>Switch to the previous audio angle in the multicam clip</td>
<td>Previous Audio Angle</td>
<td>Option-Shift-Left Arrow</td>
</tr>
<tr>
<td>Select the previous clip in the Audition window, making it the audition pick</td>
<td>Previous Pick</td>
<td>Control-Left Arrow</td>
</tr>
<tr>
<td>Switch to the previous video angle in the multicam clip</td>
<td>Previous Video Angle</td>
<td>Shift-Command-Left Arrow</td>
</tr>
<tr>
<td>Raise the audio volume by 1 dB</td>
<td>Raise Volume 1 dB</td>
<td>Control-Equal Sign (=)</td>
</tr>
<tr>
<td>Replace the selected clip in the timeline with the browser selection</td>
<td>Replace</td>
<td>Shift-R</td>
</tr>
<tr>
<td>Replace the selected clip in the timeline with the browser selection, starting from its start point</td>
<td>Replace from Start</td>
<td>Option-R</td>
</tr>
<tr>
<td>Replace the selected timeline clip with a gap clip</td>
<td>Replace with Gap</td>
<td>Shift-Delete</td>
</tr>
<tr>
<td>Select all clips</td>
<td>Select All</td>
<td>Command-A</td>
</tr>
<tr>
<td>Select the clip under the pointer in the timeline</td>
<td>Select Clip</td>
<td>C</td>
</tr>
<tr>
<td>Select the clip above the current timeline selection at the skimmer or playhead location</td>
<td>Select Clip Above</td>
<td>Command-Up Arrow</td>
</tr>
<tr>
<td>Select the clip below the current timeline selection at the skimmer or playhead location</td>
<td>Select Clip Below</td>
<td>Command-Down Arrow</td>
</tr>
<tr>
<td>For audio/video clips in expanded view, select the left edge of the audio edit point</td>
<td>Select Left Audio Edge</td>
<td>Shift-Left Bracket ([)</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>----------------------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Select the left edge of the edit point</td>
<td>Select Left Edge</td>
<td>Left Bracket (])</td>
</tr>
<tr>
<td>For audio/video clips in expanded view, select the left and right edges of the audio edit point</td>
<td>Select Left and Right Audio Edit Edges</td>
<td>Shift-Backslash (])</td>
</tr>
<tr>
<td>Select the left and right edges of the edit point</td>
<td>Select Left and Right Edit Edges</td>
<td>Backslash (])</td>
</tr>
<tr>
<td>For audio/video clips in expanded view, select the left and right edges of the video edit point</td>
<td>Select Left and Right Video Edit Edges</td>
<td>Control-Backslash (])</td>
</tr>
<tr>
<td>For audio/video clips in expanded view, select the left edge of the video edit point</td>
<td>Select Left Video Edge</td>
<td>Control-Left Bracket (])</td>
</tr>
<tr>
<td>Switch to the next angle in the multicam clip</td>
<td>Select Next Angle</td>
<td>Control-Shift-Right Arrow</td>
</tr>
<tr>
<td>Switch to the next audio angle in the multicam clip</td>
<td>Select Next Audio Angle</td>
<td>Option-Shift-Right Arrow</td>
</tr>
<tr>
<td>Move the playhead and the selection to the next topmost timeline clip in the same role</td>
<td>Select Next Clip</td>
<td>Command-Right Arrow</td>
</tr>
<tr>
<td>Select the next clip in the Audition window, making it the audition pick</td>
<td>Select Next Pick</td>
<td>Control-Right Arrow</td>
</tr>
<tr>
<td>Switch to the next video angle in the multicam clip</td>
<td>Select Next Video Angle</td>
<td>Shift-Command-Right Arrow</td>
</tr>
<tr>
<td>Move the playhead and the selection to the previous topmost timeline clip in the same role</td>
<td>Select Previous Clip</td>
<td>Command-Left Arrow</td>
</tr>
<tr>
<td>For audio/video clips in expanded view, select the right edge of the audio edit point</td>
<td>Select Right Audio Edge</td>
<td>Shift-Right Bracket (])</td>
</tr>
<tr>
<td>Select the right edge of the edit point</td>
<td>Select Right Edge</td>
<td>Right Bracket (])</td>
</tr>
<tr>
<td>For audio/video clips in expanded view, select the right edge of the video edit point</td>
<td>Select Right Video Edge</td>
<td>Control-Right Bracket (])</td>
</tr>
<tr>
<td>Set an additional range selection end point at the playhead or skimmer location</td>
<td>Set Additional Selection End</td>
<td>Shift-Command-O</td>
</tr>
<tr>
<td>Set an additional range selection start point at the playhead or skimmer location</td>
<td>Set Additional Selection Start</td>
<td>Shift-Command-I</td>
</tr>
<tr>
<td>When an edit point is selected, show or hide the precision editor</td>
<td>Show/Hide Precision Editor</td>
<td>Control-E</td>
</tr>
<tr>
<td>Turn snapping on or off</td>
<td>Snapping</td>
<td>N</td>
</tr>
<tr>
<td>Solo the selected items in the timeline</td>
<td>Solo</td>
<td>Option-S</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>------------------------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>Turn on audio/video mode to add the video and audio portion of your selection to the timeline</td>
<td>Source Media: Audio &amp; Video</td>
<td>Shift-1</td>
</tr>
<tr>
<td>Turn on audio-only mode to add the audio portion of your selection to the timeline</td>
<td>Source Media: Audio Only</td>
<td>Shift-3</td>
</tr>
<tr>
<td>Turn on video-only mode to add the video portion of your selection to the timeline</td>
<td>Source Media: Video Only</td>
<td>Shift-2</td>
</tr>
<tr>
<td>Replace the selected captions with abutting single-line captions, one for each line of text in the original captions.</td>
<td>Split Caption</td>
<td>Control-Option-Command-C</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 1 of the current bank</td>
<td>Switch to Viewer Angle 1</td>
<td>Option-1</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 2 of the current bank</td>
<td>Switch to Viewer Angle 2</td>
<td>Option-2</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 3 of the current bank</td>
<td>Switch to Viewer Angle 3</td>
<td>Option-3</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 4 of the current bank</td>
<td>Switch to Viewer Angle 4</td>
<td>Option-4</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 5 of the current bank</td>
<td>Switch to Viewer Angle 5</td>
<td>Option-5</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 6 of the current bank</td>
<td>Switch to Viewer Angle 6</td>
<td>Option-6</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 7 of the current bank</td>
<td>Switch to Viewer Angle 7</td>
<td>Option-7</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 8 of the current bank</td>
<td>Switch to Viewer Angle 8</td>
<td>Option-8</td>
</tr>
<tr>
<td>Switch the multicam clip to angle 9 of the current bank</td>
<td>Switch to Viewer Angle 9</td>
<td>Option-9</td>
</tr>
<tr>
<td>Turn on or turn off the ability to build storylines when dragging clips in the timeline</td>
<td>Toggle Storyline Mode</td>
<td>G</td>
</tr>
<tr>
<td>Trim the end of the selected or topmost clip to the skimmer or playhead position</td>
<td>Trim End</td>
<td>Option-Right Bracket ()</td>
</tr>
<tr>
<td>Trim the clip start point to the skimmer or playhead position</td>
<td>Trim Start</td>
<td>Option-Left Bracket ()</td>
</tr>
<tr>
<td>Trim clip start and end points to the range selection</td>
<td>Trim to Selection</td>
<td>Option-Backslash ()</td>
</tr>
</tbody>
</table>
## Effects

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect a basic lower-third title to the primary storyline</td>
<td>Add Basic Lower Third</td>
<td>Control-Shift-T</td>
</tr>
<tr>
<td>Connect a basic title to the primary storyline</td>
<td>Add Basic Title</td>
<td>Control-T</td>
</tr>
<tr>
<td>Add the default audio effect to the selection</td>
<td>Add Default Audio Effect</td>
<td>Option-Command-E</td>
</tr>
<tr>
<td>Add the default transition to the selection</td>
<td>Add Default Transition</td>
<td>Command-T</td>
</tr>
<tr>
<td>Apply a crossfade to the audio edit point between the selected clips</td>
<td>Crossfade</td>
<td>Option-T</td>
</tr>
<tr>
<td>Add the default video effect to the selection</td>
<td>Add Default Video Effect</td>
<td>Option-E</td>
</tr>
<tr>
<td>Reset the controls in the current Color Board pane</td>
<td>Color Board: Reset Current Board Controls</td>
<td>Option-Delete</td>
</tr>
<tr>
<td>Switch to the Color pane in the Color Board</td>
<td>Color Board: Switch to the Color Pane</td>
<td>Control-Command-C</td>
</tr>
<tr>
<td>Switch to the Exposure pane in the Color Board</td>
<td>Color Board: Switch to the Exposure Pane</td>
<td>Control-Command-E</td>
</tr>
<tr>
<td>Switch to the Saturation pane in the Color Board</td>
<td>Color Board: Switch to the Saturation Pane</td>
<td>Control-Command-S</td>
</tr>
<tr>
<td>Copy the selected effects and their settings</td>
<td>Copy Effects</td>
<td>Option-Command-C</td>
</tr>
<tr>
<td>Copy the selected keyframes and their settings</td>
<td>Copy Keyframes</td>
<td>Option-Shift-C</td>
</tr>
<tr>
<td>Cut the selected keyframes and their settings</td>
<td>Cut Keyframes</td>
<td>Option-Shift-X</td>
</tr>
<tr>
<td>Turn Balance Color corrections on or off</td>
<td>Enable/Disable Balance Color</td>
<td>Option-Command-B</td>
</tr>
<tr>
<td>Match the sound between clips</td>
<td>Match Audio</td>
<td>Shift-Command-M</td>
</tr>
<tr>
<td>Match color between clips</td>
<td>Match Color</td>
<td>Option-Command-M</td>
</tr>
<tr>
<td>Navigate to the next text item</td>
<td>Next Text</td>
<td>Option-Tab</td>
</tr>
<tr>
<td>Paste selected attributes and their settings to the selection</td>
<td>Paste Attributes</td>
<td>Shift-Command-V</td>
</tr>
<tr>
<td>Paste effects and their settings to the selection</td>
<td>Paste Effects</td>
<td>Option-Command-V</td>
</tr>
<tr>
<td>Paste keyframes and their settings to the selection</td>
<td>Paste Keyframes</td>
<td>Option-Shift-V</td>
</tr>
<tr>
<td>Navigate to the previous text item</td>
<td>Previous Text</td>
<td>Option-Shift-Tab</td>
</tr>
<tr>
<td>Remove selected attributes from the selection</td>
<td>Remove Attributes</td>
<td>Shift-Command-X</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>-----------------------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Remove all effects from the selection</td>
<td>Remove Effects</td>
<td>Option-Command-X</td>
</tr>
<tr>
<td>Show or hide the retime editor</td>
<td>Retime Editor</td>
<td>Command-R</td>
</tr>
<tr>
<td>Set the selection to play at normal (100 percent) speed</td>
<td>Retime: Create Normal Speed Segment</td>
<td>Shift-N</td>
</tr>
<tr>
<td>Create a 2-second hold segment</td>
<td>Retime: Hold</td>
<td>Shift-H</td>
</tr>
<tr>
<td>Reset the selection to play forward at normal (100 percent) speed</td>
<td>Retime: Reset</td>
<td>Option-Command-R</td>
</tr>
<tr>
<td>Show one effect at a time in the Video Animation editor</td>
<td>Solo Animation</td>
<td>Control-Shift-V</td>
</tr>
<tr>
<td>Delete the timeline selection, reject the browser selection, or remove a through edit</td>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Show or hide the Filter window (in the browser) or the timeline index (in the timeline)</td>
<td>Find</td>
<td>Command-F</td>
</tr>
<tr>
<td>Make the event viewer active</td>
<td>Go to Event Viewer</td>
<td>Option-Command-3</td>
</tr>
<tr>
<td>Import media from a device, a camera, or an archive</td>
<td>Import Media</td>
<td>Command-I</td>
</tr>
<tr>
<td>Open the Library Properties inspector for the current library</td>
<td>Library Properties</td>
<td>Control-Command-J</td>
</tr>
<tr>
<td>Move the selection to the Finder Trash</td>
<td>Move to Trash</td>
<td>Command-Delete</td>
</tr>
<tr>
<td>Create a new project</td>
<td>New Project</td>
<td>Command-N</td>
</tr>
<tr>
<td>Open the Properties inspector for the current project</td>
<td>Project Properties</td>
<td>Command-J</td>
</tr>
<tr>
<td>Start all rendering tasks for the current project</td>
<td>Render All</td>
<td>Control-Shift-R</td>
</tr>
<tr>
<td>Start rendering tasks for the selection</td>
<td>Render Selection</td>
<td>Control-R</td>
</tr>
<tr>
<td>Reveal the selected event clip's source media file in the Finder</td>
<td>Reveal in Finder</td>
<td>Shift-Command-R</td>
</tr>
</tbody>
</table>

**General**
# Marking

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a caption to the active language subrole at the playhead location</td>
<td>Add Caption</td>
<td>Option-C (or Control-Option-C if the caption editor is open)</td>
</tr>
<tr>
<td>Add a marker at the location of the skimmer or playhead</td>
<td>Add Marker</td>
<td>M</td>
</tr>
<tr>
<td>Change the browser filter settings to show all clips</td>
<td>All Clips</td>
<td>Control-C</td>
</tr>
<tr>
<td>Add a marker and edit the marker’s text</td>
<td>Add Marker and Modify</td>
<td>Option-M</td>
</tr>
<tr>
<td>Apply keyword 1 to the selection</td>
<td>Apply Keyword Tag 1</td>
<td>Control-1</td>
</tr>
<tr>
<td>Apply keyword 2 to the selection</td>
<td>Apply Keyword Tag 2</td>
<td>Control-2</td>
</tr>
<tr>
<td>Apply keyword 3 to the selection</td>
<td>Apply Keyword Tag 3</td>
<td>Control-3</td>
</tr>
<tr>
<td>Apply keyword 4 to the selection</td>
<td>Apply Keyword Tag 4</td>
<td>Control-4</td>
</tr>
<tr>
<td>Apply keyword 5 to the selection</td>
<td>Apply Keyword Tag 5</td>
<td>Control-5</td>
</tr>
<tr>
<td>Apply keyword 6 to the selection</td>
<td>Apply Keyword Tag 6</td>
<td>Control-6</td>
</tr>
<tr>
<td>Apply keyword 7 to the selection</td>
<td>Apply Keyword Tag 7</td>
<td>Control-7</td>
</tr>
<tr>
<td>Apply keyword 8 to the selection</td>
<td>Apply Keyword Tag 8</td>
<td>Control-8</td>
</tr>
<tr>
<td>Apply keyword 9 to the selection</td>
<td>Apply Keyword Tag 9</td>
<td>Control-9</td>
</tr>
<tr>
<td>Clear the range selection</td>
<td>Clear Selected Ranges</td>
<td>Option-X</td>
</tr>
<tr>
<td>Clear the range’s end point</td>
<td>Clear Range End</td>
<td>Option-O</td>
</tr>
<tr>
<td>Clear the range’s start point</td>
<td>Clear Range Start</td>
<td>Option-I</td>
</tr>
<tr>
<td>Delete the selected marker</td>
<td>Delete Marker</td>
<td>Control-M</td>
</tr>
<tr>
<td>Delete all of the markers in the selection</td>
<td>Delete Markers in Selection</td>
<td>Control-Shift-M</td>
</tr>
<tr>
<td>Deselect all selected items</td>
<td>Deselect All</td>
<td>Shift-Command-A</td>
</tr>
<tr>
<td>Open the selected caption in the caption editor</td>
<td>Edit Caption</td>
<td>Control-Shift-C</td>
</tr>
<tr>
<td>Rate the browser selection as favorite</td>
<td>Favorite</td>
<td>F</td>
</tr>
<tr>
<td>Change the browser filter settings to show favorites</td>
<td>Favorites</td>
<td>Control-F</td>
</tr>
<tr>
<td>Change the browser filter settings to hide rejected clips</td>
<td>Hide Rejected</td>
<td>Control-H</td>
</tr>
<tr>
<td>Create a new Keyword Collection</td>
<td>New Keyword Collection</td>
<td>Shift-Command-K</td>
</tr>
<tr>
<td>Create a new Smart Collection</td>
<td>New Smart Collection</td>
<td>Option-Command-N</td>
</tr>
<tr>
<td>Make the Range Selection tool active</td>
<td>Range Selection Tool</td>
<td>R</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>----------------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>Mark the current selection in the browser as rejected</td>
<td>Reject</td>
<td>Delete</td>
</tr>
<tr>
<td>Note: The Delete key removes selected items if the timeline is active instead of the browser.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change the browser filter settings to show rejected clips</td>
<td>Rejected</td>
<td>Control-Delete</td>
</tr>
<tr>
<td>Remove all keywords from the browser selection</td>
<td>Remove All Keywords From Selection</td>
<td>Control-0</td>
</tr>
<tr>
<td>Apply Dialogue subroles to the selected clip's components</td>
<td>Roles: Apply Dialogue Role</td>
<td>Control-Option-D</td>
</tr>
<tr>
<td>Apply Effects subroles to the selected clip's components</td>
<td>Roles: Apply Effects Role</td>
<td>Control-Option-E</td>
</tr>
<tr>
<td>Apply Music subroles to the selected clip's components</td>
<td>Roles: Apply Music Role</td>
<td>Control-Option-M</td>
</tr>
<tr>
<td>Apply the Titles role to the selected clip</td>
<td>Roles: Apply Titles Role</td>
<td>Control-Option-T</td>
</tr>
<tr>
<td>Apply the Video role to the selected clip</td>
<td>Roles: Apply Video Role</td>
<td>Control-Option-V</td>
</tr>
<tr>
<td>Select all clips</td>
<td>Select All</td>
<td>Command-A</td>
</tr>
<tr>
<td>Set the range selection to match the boundaries of the clip below the skimmer or playhead</td>
<td>Select Clip Range</td>
<td>X</td>
</tr>
<tr>
<td>Set an additional range selection end point at the playhead or skimmer location</td>
<td>Set Additional Range End</td>
<td>Shift-Command-O</td>
</tr>
<tr>
<td>Set an additional range selection start point at the playhead or skimmer location</td>
<td>Set Additional Range Start</td>
<td>Shift-Command-I</td>
</tr>
<tr>
<td>Set the end point for the range</td>
<td>Set Range End</td>
<td>O</td>
</tr>
<tr>
<td>Set the end point for the range while editing a text field</td>
<td>Set Range End</td>
<td>Control-O</td>
</tr>
<tr>
<td>Set the start point for the range</td>
<td>Set Range Start</td>
<td>I</td>
</tr>
<tr>
<td>Set the start point for the range while editing a text field</td>
<td>Set Range Start</td>
<td>Control-I</td>
</tr>
<tr>
<td>Remove ratings from the selection</td>
<td>Unrate</td>
<td>U</td>
</tr>
</tbody>
</table>
## Organization

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new event</td>
<td>New Event</td>
<td>Option-N</td>
</tr>
<tr>
<td>Create a new folder</td>
<td>New Folder</td>
<td>Shift-Command-N</td>
</tr>
<tr>
<td>Reveal the selected clip in the browser</td>
<td>Reveal in Browser</td>
<td>Shift-F</td>
</tr>
<tr>
<td>Reveal the open project in the browser</td>
<td>Reveal Project in Browser</td>
<td>Option-Shift-Command-F</td>
</tr>
<tr>
<td>Sync the selected event clips</td>
<td>Synchronize Clips</td>
<td>Option-Command-G</td>
</tr>
</tbody>
</table>

## Playback and navigation

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn audio skimming on or off</td>
<td>Audio Skimming</td>
<td>Shift-S</td>
</tr>
<tr>
<td>Play the pick in context in the timeline</td>
<td>Audition: Preview</td>
<td>Control-Command-Y</td>
</tr>
<tr>
<td>Turn clip skimming on or off</td>
<td>Clip Skimming</td>
<td>Option-Command-S</td>
</tr>
<tr>
<td>Turn on audio-only mode for multicam cutting and switching</td>
<td>Cut/Switch Multicam Audio Only</td>
<td>Option-Shift-3</td>
</tr>
<tr>
<td>Turn on audio/video mode for multicam cutting and switching</td>
<td>Cut/Switch Multicam Audio and Video</td>
<td>Option-Shift-1</td>
</tr>
<tr>
<td>Turn on video-only mode for multicam cutting and switching</td>
<td>Cut/Switch Multicam Video Only</td>
<td>Option-Shift-2</td>
</tr>
<tr>
<td>Go to the next item (in the browser) or the next edit point (in the timeline)</td>
<td>Down</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>While editing a text field, go to the next item (in the browser) or the next edit point (in the timeline)</td>
<td>Down</td>
<td>Control-Down Arrow</td>
</tr>
<tr>
<td>Move the playhead to the next timeline clip containing the same duplicate range and select the clip</td>
<td>Duplicate Range: Go to Next Related Clip</td>
<td>Option-Command-Right Arrow</td>
</tr>
<tr>
<td>Move the playhead to the previous timeline clip containing the same duplicate range and select the clip</td>
<td>Duplicate Range: Go to Previous Related Clip</td>
<td>Option-Command-Left Arrow</td>
</tr>
<tr>
<td>Move the playhead back 10 frames</td>
<td>Go Back 10 Frames</td>
<td>Shift-Left Arrow</td>
</tr>
<tr>
<td>Move the playhead forward 10 frames</td>
<td>Go Forward 10 Frames</td>
<td>Shift-Right Arrow</td>
</tr>
<tr>
<td>Move the playhead to the beginning of the timeline or the first clip in the browser</td>
<td>Go to Beginning</td>
<td>Home key (or Fn-Left Arrow)</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------------------------------</td>
</tr>
<tr>
<td>Move the playhead to the end of the timeline or to the last clip in the browser</td>
<td>Go to End</td>
<td>End key (or Fn-Right Arrow)</td>
</tr>
<tr>
<td>Display the next bank of angles in the current multicam clip</td>
<td>Go to Next Bank</td>
<td>Option-Shift-Apostrophe ('')</td>
</tr>
<tr>
<td>Move the playhead to the next edit point in the timeline</td>
<td>Go to Next Edit</td>
<td>Apostrophe (’)</td>
</tr>
<tr>
<td>Move the playhead to the next field in an interlaced clip</td>
<td>Go to Next Field</td>
<td>Option-Right Arrow</td>
</tr>
<tr>
<td>Move the playhead to the next focus point</td>
<td>Go to Next Focus Point</td>
<td>Option-Shift-Command-Right Arrow</td>
</tr>
<tr>
<td>Move the playhead to the next frame</td>
<td>Go to Next Frame</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Move the playhead to the next audio subframe</td>
<td>Go to Next Subframe</td>
<td>Option-Right Arrow</td>
</tr>
<tr>
<td>Display the previous bank of angles in the current multicam clip</td>
<td>Go to Previous Bank</td>
<td>Option-Shift-Semicolon (;)</td>
</tr>
<tr>
<td>Move the playhead to the previous edit point in the timeline</td>
<td>Go to Previous Edit</td>
<td>Semicolon (;)</td>
</tr>
<tr>
<td>Move the playhead to the previous field in an interlaced clip</td>
<td>Go to Previous Field</td>
<td>Option-Left Arrow</td>
</tr>
<tr>
<td>Move the playhead to the previous focus point</td>
<td>Go to Previous Focus Point</td>
<td>Option-Shift-Command-Left Arrow</td>
</tr>
<tr>
<td>Move the playhead to the previous frame</td>
<td>Go to Previous Frame</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Move the playhead to the previous audio subframe</td>
<td>Go to Previous Subframe</td>
<td>Option-Left Arrow</td>
</tr>
<tr>
<td>Move the playhead to the end of the range selection</td>
<td>Go to Range End</td>
<td>Shift-O</td>
</tr>
<tr>
<td>Move the playhead to the beginning of the range selection</td>
<td>Go to Range Start</td>
<td>Shift-I</td>
</tr>
<tr>
<td>Roll the 360° viewer clockwise</td>
<td>Look Clockwise</td>
<td>Control-Option-Command-Right Bracket</td>
</tr>
<tr>
<td>Roll the 360° viewer counterclockwise</td>
<td>Look Counterclockwise</td>
<td>Control-Option-Command-Left Bracket</td>
</tr>
<tr>
<td>Tilt the 360° viewer down</td>
<td>Look Down</td>
<td>Control-Option-Command-Down Arrow</td>
</tr>
<tr>
<td>Pan the 360° viewer to the left</td>
<td>Look Left</td>
<td>Control-Option-Command-Left Arrow</td>
</tr>
<tr>
<td>Pan the 360° viewer to the right</td>
<td>Look Right</td>
<td>Control-Option-Command-Right Arrow</td>
</tr>
<tr>
<td>Pan the 360° viewer up</td>
<td>Look Up</td>
<td>Control-Option-Command-Up Arrow</td>
</tr>
<tr>
<td>Turn looped playback on or off</td>
<td>Loop Playback</td>
<td>Command-L</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------</td>
<td>------------------------------------</td>
</tr>
<tr>
<td>Mirror the display of the connected VR headset in the 360° viewer</td>
<td>Mirror VR Headset</td>
<td>Control-Option-Command-9</td>
</tr>
<tr>
<td>Turn on or turn off audio monitoring for the angle being skimmed</td>
<td>Monitor Audio</td>
<td>Shift-A</td>
</tr>
<tr>
<td>Enter a negative timecode value to move the playhead back, move a</td>
<td>Negative Timecode Entry</td>
<td>Hyphen (-)</td>
</tr>
<tr>
<td>clip earlier, or trim a range or clip, depending on your selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Go to the next item (in the browser) or the next edit point (in the</td>
<td>Next Clip</td>
<td>Control-Command-Right Arrow</td>
</tr>
<tr>
<td>timeline)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Move the playhead to the next marker</td>
<td>Next Marker</td>
<td>Control-Apostrophe (')</td>
</tr>
<tr>
<td>Send 360° video to the connected VR headset</td>
<td>Output to VR Headset</td>
<td>Control-Option-Command-7</td>
</tr>
<tr>
<td>Play around the playback position</td>
<td>Play Around</td>
<td>Shift-Question Mark (?)</td>
</tr>
<tr>
<td>Play forward (press L multiple times to increase the playback speed)</td>
<td>Play Forward</td>
<td>L</td>
</tr>
<tr>
<td>Play from the playback position</td>
<td>Play from Playhead</td>
<td>Option-Space bar</td>
</tr>
<tr>
<td>Play full screen from the skimmer or playhead position</td>
<td>Play Full Screen</td>
<td>Shift-Command-F</td>
</tr>
<tr>
<td>Play in reverse (press J multiple times to increase the reverse</td>
<td>Play Reverse</td>
<td>J</td>
</tr>
<tr>
<td>playback speed)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Play in reverse while editing a text field (press J multiple times</td>
<td>Play Reverse</td>
<td>Control-J</td>
</tr>
<tr>
<td>to increase the reverse playback speed)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Play in reverse</td>
<td>Play Reverse</td>
<td>Shift-Space bar</td>
</tr>
<tr>
<td>Play the selection</td>
<td>Play Selection</td>
<td>Slash (/)</td>
</tr>
<tr>
<td>Play from the playhead to the end of the selection</td>
<td>Play to End</td>
<td>Control-Shift-O</td>
</tr>
<tr>
<td>Start or pause playback</td>
<td>Play/Pause</td>
<td>Space bar</td>
</tr>
<tr>
<td>Start or pause playback while editing a text field</td>
<td>Play/Pause</td>
<td>Control-Space bar</td>
</tr>
<tr>
<td>Enter a positive timecode value to move the playhead forward, move a</td>
<td>Positive Timecode Entry</td>
<td>Equal Sign (=)</td>
</tr>
<tr>
<td>clip later, or trim a range or clip, depending on your selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Go to the previous item (in the browser) or the previous edit point</td>
<td>Previous Clip</td>
<td>Control-Command-Left Arrow</td>
</tr>
<tr>
<td>(in the timeline)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Move the playhead to the previous marker</td>
<td>Previous Marker</td>
<td>Control-Semicolon (;)</td>
</tr>
</tbody>
</table>
### Action Command Shortcut

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the angle being skimmed as the monitoring angle</td>
<td>Set Monitoring Angle</td>
<td>Shift-V</td>
</tr>
<tr>
<td>Turn skimming on or off</td>
<td>Skimming</td>
<td>S</td>
</tr>
<tr>
<td>Start or stop recording audio from the Record Voiceover window</td>
<td>Start/Stop Voiceover Recording</td>
<td>Option-Shift-A</td>
</tr>
<tr>
<td>Stop playback</td>
<td>Stop</td>
<td>K</td>
</tr>
<tr>
<td>Stop playback while editing a text field</td>
<td>Stop</td>
<td>Control-K</td>
</tr>
<tr>
<td>Go back one level in the timeline history</td>
<td>Timeline History Back</td>
<td>Command-Left Bracket ([])</td>
</tr>
<tr>
<td>Go forward one level in the timeline history</td>
<td>Timeline History Forward</td>
<td>Command-Right Bracket (])</td>
</tr>
<tr>
<td>Go to the previous item (in the browser) or the previous edit point</td>
<td>Up</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>While editing a text field, go to the previous item (in the browser)</td>
<td>Up</td>
<td>Control-Up Arrow</td>
</tr>
</tbody>
</table>

### Share and tools

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Share the selected project or clip using the default destination</td>
<td>Share to Default Destination</td>
<td>Command-E</td>
</tr>
<tr>
<td>Make the Select tool active</td>
<td>Select (Arrow) Tool</td>
<td>A</td>
</tr>
<tr>
<td>Make the Blade tool active</td>
<td>Blade Tool</td>
<td>B</td>
</tr>
<tr>
<td>Make the Cinematic tool active and display onscreen controls for the selected clip or the topmost clip under the playhead</td>
<td>Cinematic Tool</td>
<td>Control-Shift-F</td>
</tr>
<tr>
<td>Make the Crop tool active and display onscreen controls for the selected clip or the topmost clip under the playhead</td>
<td>Crop Tool</td>
<td>Shift-C</td>
</tr>
<tr>
<td>Make the Distort tool active and display onscreen controls for the selected clip or the topmost clip under the playhead</td>
<td>Distort Tool</td>
<td>Option-D</td>
</tr>
<tr>
<td>Make the Hand tool active</td>
<td>Hand Tool</td>
<td>H</td>
</tr>
<tr>
<td>Make the Position tool active</td>
<td>Position Tool</td>
<td>P</td>
</tr>
<tr>
<td>Make the Transform tool active and display onscreen controls for the selected clip or the topmost clip under the playhead</td>
<td>Transform Tool</td>
<td>Shift-T</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>----------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Make the Trim tool active</td>
<td>Trim Tool</td>
<td>T</td>
</tr>
<tr>
<td>Make the Zoom tool active</td>
<td>Zoom Tool</td>
<td>Z</td>
</tr>
</tbody>
</table>

**View**

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide the Cinematic Editor for the selected timeline clips</td>
<td>Show/Hide Cinematic Editor</td>
<td>Control-Option-F</td>
</tr>
<tr>
<td>Depending on the clip name setting, display timeline clips with clip</td>
<td>Clip Appearance: Clip Labels Only</td>
<td>Control-Option-6</td>
</tr>
<tr>
<td>names, role names, or active angle names only</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Decrease the size of audio waveforms for timeline clips</td>
<td>Clip Appearance: Decrease Waveform Size</td>
<td>Control-Option-Down Arrow</td>
</tr>
<tr>
<td>Display timeline clips with large filmstrips only</td>
<td>Clip Appearance: Filmstrips Only</td>
<td>Control-Option-5</td>
</tr>
<tr>
<td>Increase the size of audio waveforms for timeline clips</td>
<td>Clip Appearance: Increase Waveform Size</td>
<td>Control-Option-Up Arrow</td>
</tr>
<tr>
<td>Display timeline clips with small audio waveforms and large filmstrips</td>
<td>Clip Appearance: Large Filmstrips</td>
<td>Control-Option-4</td>
</tr>
<tr>
<td>Display timeline clips with large audio waveforms and small filmstrips</td>
<td>Clip Appearance: Large Waveforms</td>
<td>Control-Option-2</td>
</tr>
<tr>
<td>Display timeline clips with audio waveforms and video filmstrips of</td>
<td>Clip Appearance: Waveforms and Filmstrips</td>
<td>Control-Option-3</td>
</tr>
<tr>
<td>equal size</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Display timeline clips with large audio waveforms only</td>
<td>Clip Appearance: Waveforms Only</td>
<td>Control-Option-1</td>
</tr>
<tr>
<td>Decrease the browser clip height</td>
<td>Decrease Clip Height</td>
<td>Shift-Command-Hyphen (-)</td>
</tr>
<tr>
<td>Increase the browser clip height</td>
<td>Increase Clip Height</td>
<td>Shift-Command-Equal Sign (=)</td>
</tr>
<tr>
<td>Show fewer filmstrip frames in browser clips</td>
<td>Show Fewer Filmstrip Frames</td>
<td>Shift-Command-Comma (,)</td>
</tr>
<tr>
<td>Show or hide the Audio Animation editor for the selected clips or</td>
<td>Show/Hide Audio Animation</td>
<td>Control-A</td>
</tr>
<tr>
<td>components</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show or hide clip information when skimming in the browser</td>
<td>Show/Hide Skimmer Info</td>
<td>Control-Y</td>
</tr>
<tr>
<td>Show or hide the Video Animation editor for the selected timeline</td>
<td>Show/Hide Video Animation</td>
<td>Control-V</td>
</tr>
<tr>
<td>clips</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show more filmstrip frames in browser clips</td>
<td>Show More Filmstrip Frames</td>
<td>Shift-Command-Period (.)</td>
</tr>
<tr>
<td>Show one frame per filmstrip</td>
<td>Show One Frame per Filmstrip</td>
<td>Option-Shift-Command-Comma (,)</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>-----------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Switch the browser between filmstrip view and list view</td>
<td>Toggle Filmstrip/List View</td>
<td>Option-Command-2</td>
</tr>
<tr>
<td>Show or hide clip names in the browser</td>
<td>View Clip Names</td>
<td>Option-Shift-N</td>
</tr>
<tr>
<td>Zoom in to the browser, viewer, or timeline</td>
<td>Zoom In</td>
<td>Command-Plus Sign (+)</td>
</tr>
<tr>
<td>Zoom out of the browser, viewer, or timeline</td>
<td>Zoom Out</td>
<td>Command-Minus Sign (-)</td>
</tr>
<tr>
<td>Zoom the contents to fit the size of the browser, viewer, or timeline</td>
<td>Zoom to Fit</td>
<td>Shift-Z</td>
</tr>
<tr>
<td>Turn zooming in to audio samples on or off</td>
<td>Zoom to Samples</td>
<td>Control-Z</td>
</tr>
</tbody>
</table>

**Windows**

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch to the Anaglyph view in the 360° viewer (stereoscopic only)</td>
<td>Anaglyph</td>
<td>Control-Option-Command-3</td>
</tr>
<tr>
<td>Switch to the Anaglyph Monochrome view in the 360° viewer (stereoscopic only)</td>
<td>Anaglyph Monochrome</td>
<td>Control-Option-Command-4</td>
</tr>
<tr>
<td>Switch to the Anaglyph Outline view in the 360° viewer (stereoscopic only)</td>
<td>Anaglyph Outline</td>
<td>Control-Option-Command-5</td>
</tr>
<tr>
<td>Show or hide the Background Tasks window</td>
<td>Background Tasks</td>
<td>Command-9</td>
</tr>
<tr>
<td>Switch to the Difference view in the 360° viewer (stereoscopic only)</td>
<td>Difference</td>
<td>Control-Option-Command-6</td>
</tr>
<tr>
<td>Make the Audio Enhancements inspector active</td>
<td>Go to Audio Enhancements</td>
<td>Command-8</td>
</tr>
<tr>
<td>Make the browser active</td>
<td>Go to Browser</td>
<td>Command-1</td>
</tr>
<tr>
<td>Make the Color Board active</td>
<td>Go to Color Board</td>
<td>Command-6</td>
</tr>
<tr>
<td>Make the current inspector active</td>
<td>Go to Inspector</td>
<td>Option-Command-4</td>
</tr>
<tr>
<td>Make the timeline active</td>
<td>Go to Timeline</td>
<td>Command-2</td>
</tr>
<tr>
<td>Make the viewer active</td>
<td>Go to Viewer</td>
<td>Command-3</td>
</tr>
<tr>
<td>Switch to the Left Eye view in the 360° viewer (stereoscopic only)</td>
<td>Left</td>
<td>Control-Option-Command-1</td>
</tr>
<tr>
<td>Go to the next pane in the inspector or the Color Board</td>
<td>Next Tab</td>
<td>Control-Tab</td>
</tr>
<tr>
<td>Go to the previous pane in the inspector or the Color Board</td>
<td>Previous Tab</td>
<td>Control-Shift-Tab</td>
</tr>
<tr>
<td>Action</td>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Show or hide the Record Voiceover window</td>
<td>Record Voiceover</td>
<td>Option-Command-8</td>
</tr>
<tr>
<td>Switch to the Right Eye view in the 360° viewer (stereoscopic only)</td>
<td>Right</td>
<td>Control-Option-Command-2</td>
</tr>
<tr>
<td>Show the vectorscope in the viewer</td>
<td>Show Vectorscope</td>
<td>Control-Command-V</td>
</tr>
<tr>
<td>Show the waveform monitor in the viewer</td>
<td>Show Video Waveform</td>
<td>Control-Command-W</td>
</tr>
<tr>
<td>Show or hide the angle viewer</td>
<td>Show/Hide Angles</td>
<td>Shift-Command-7</td>
</tr>
<tr>
<td>Show or hide the audio meters</td>
<td>Show/Hide Audio Meters</td>
<td>Shift-Command-8</td>
</tr>
<tr>
<td>Show or hide the browser</td>
<td>Show/Hide Browser</td>
<td>Control-Command-1</td>
</tr>
<tr>
<td>Show or hide the comparison viewer</td>
<td>Show/Hide Comparison Viewer</td>
<td>Control-Command-6</td>
</tr>
<tr>
<td>Show or hide the Effects browser</td>
<td>Show/Hide Effects Browser</td>
<td>Command-5</td>
</tr>
<tr>
<td>Show or hide the Transitions browser</td>
<td>Show/Hide Transitions Browser</td>
<td>Control-Command-5</td>
</tr>
<tr>
<td>Show or hide the event viewer</td>
<td>Show/Hide Event Viewer</td>
<td>Control-Command-3</td>
</tr>
<tr>
<td>Show or hide the inspector</td>
<td>Show/Hide Inspector</td>
<td>Command-4</td>
</tr>
<tr>
<td>Show or hide the keyword editor</td>
<td>Show/Hide Keyword Editor</td>
<td>Command-K</td>
</tr>
<tr>
<td>Show or hide the Libraries sidebar</td>
<td>Show/Hide Libraries</td>
<td>Command-1</td>
</tr>
<tr>
<td>Show or hide the Photos, Videos, and Audio sidebar</td>
<td>Show/Hide Photos, Videos, and Audio</td>
<td>Shift-Command-1</td>
</tr>
<tr>
<td>Show or hide the sidebar</td>
<td>Show/Hide Sidebar</td>
<td>Command-Grave Accent (‘)</td>
</tr>
<tr>
<td>Show or hide the 360° viewer</td>
<td>Show/Hide 360° Viewer</td>
<td>Option-Command-7</td>
</tr>
<tr>
<td>Show or hide the timeline</td>
<td>Show/Hide Timeline</td>
<td>Control-Command-2</td>
</tr>
<tr>
<td>Show or hide the timeline index for the open project</td>
<td>Show/Hide Timeline Index</td>
<td>Shift-Command-2</td>
</tr>
<tr>
<td>Show or hide the Titles and Generators sidebar</td>
<td>Show/Hide Titles and Generators</td>
<td>Option-Command-1</td>
</tr>
<tr>
<td>Show or hide the video scopes in the viewer</td>
<td>Show/Hide Video Scopes</td>
<td>Command-7</td>
</tr>
<tr>
<td>Switch to the Superimpose view in the 360° viewer (stereoscopic only)</td>
<td>Superimpose</td>
<td>Control-Option-Command-Grave Accent (‘)</td>
</tr>
<tr>
<td>Switch between the half-height view and full-height view in the inspector</td>
<td>Toggle Inspector Height</td>
<td>Control-Command-4</td>
</tr>
</tbody>
</table>
# Multi-Touch trackpad gestures in Final Cut Pro for Mac

If your Mac has a Multi-Touch trackpad, you can use the Multi-Touch gestures listed in the table below when working with Final Cut Pro.

For more information about Multi-Touch gestures, choose Apple menu > System Settings, then click Trackpad in the sidebar. (You may need to scroll down.)

<table>
<thead>
<tr>
<th>Gesture</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Pinch" /></td>
<td><strong>Pinch (two-finger):</strong> Pinch closed with two fingers to zoom out of the timeline or window. Pinch open to zoom in to the timeline or window.</td>
</tr>
<tr>
<td><img src="image" alt="Double-tap" /></td>
<td><strong>Double-tap (two-finger):</strong> Double-tap with two fingers to zoom the timeline so that all the clips fill the visible part of the timeline.</td>
</tr>
<tr>
<td><img src="image" alt="Swipe" /></td>
<td><strong>Swipe (two-finger):</strong> Swipe with two fingers to scroll left, right, up, or down in the timeline.</td>
</tr>
<tr>
<td><img src="image" alt="Click" /></td>
<td><strong>Click (two-finger):</strong> Click once to open the shortcut menu.</td>
</tr>
<tr>
<td><img src="image" alt="Drag" /></td>
<td><strong>Drag (three-finger):</strong> Drag a selection rectangle over the timeline or event clips you want to select, or drag to move selected clips.</td>
</tr>
<tr>
<td><img src="image" alt="Swipe" /></td>
<td><strong>Swipe (three-finger):</strong> Swipe left or right to move the playhead to the previous or next edit point. Swipe up or down to move the playhead to the beginning or end of the timeline.</td>
</tr>
</tbody>
</table>

*Note:* To enable this gesture, choose Apple menu > System Settings, then click Trackpad in the sidebar. (You may need to scroll down.) Click More Gestures on the right, then click the “Swipe between pages” pop-up menu and choose Swipe with Three Fingers. Enabling this gesture automatically disables the “Drag (three-finger)” gesture described above.
Touch Bar shortcuts in Final Cut Pro for Mac

If your MacBook Pro has a Touch Bar, you can use familiar gestures like swipe and tap to quickly perform tasks such as scrubbing the timeline, applying an audio fade, selecting tools, or editing text. With the exception of the Control Strip (on the right side of the Touch Bar) and the Esc button (on the left), the contents of the Touch Bar are dynamic—the controls change depending on your current selection within Final Cut Pro and other apps. Related buttons and sliders appear together in groups in the bar.

For more information about the Control Strip and Esc button, see MacBook Pro Essentials. To learn more about the Touch Bar, see the Apple Support article Use the Touch Bar on Mac.

Browser with no selection

These controls appear in the Touch Bar when the browser is active but no clips are selected.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Import]</td>
<td>Import</td>
<td>Import media from a device, camera, or archive.</td>
</tr>
<tr>
<td>![New Event]</td>
<td>New Event</td>
<td>Create a new event.</td>
</tr>
<tr>
<td>![New Project]</td>
<td>New Project</td>
<td>Create a new project.</td>
</tr>
</tbody>
</table>
Browser with a selection

These controls appear in the Touch Bar when the browser is active and something in the browser is selected. You can use these controls to manage and sort your media in the browser.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Info Inspector" /></td>
<td>Info Inspector</td>
<td>Open the Info inspector for the selected item.</td>
</tr>
<tr>
<td><img src="image" alt="Audio Controls" /></td>
<td>Audio Controls</td>
<td>Display a set of audio controls in the Touch Bar. See Audio controls below.</td>
</tr>
<tr>
<td><img src="image" alt="Move to Start" /></td>
<td>Move to Start</td>
<td>Move the skimmer or playhead to the start of the selection or clip.</td>
</tr>
<tr>
<td><img src="image" alt="Move to End" /></td>
<td>Move to End</td>
<td>Move the skimmer or playhead to the end of the selection or clip.</td>
</tr>
<tr>
<td><img src="image" alt="Clear Selection" /></td>
<td>Clear Selection</td>
<td>Clear the range selection.</td>
</tr>
<tr>
<td><img src="image" alt="List View" /></td>
<td>List View</td>
<td>Switch the browser from filmstrip view to list view. See Intro to browser views.</td>
</tr>
<tr>
<td><img src="image" alt="Filmstrip View" /></td>
<td>Filmstrip View</td>
<td>Switch the browser from list view to filmstrip view. See Intro to browser views.</td>
</tr>
</tbody>
</table>

Typing suggestions

When you type a name for a new event or project, the Touch Bar displays typing suggestions based on your recent activity and information from your apps. (Typing suggestions are not available in all languages.) Tap a word to choose it, or accept a highlighted suggestion by entering a space or punctuation.
## Timeline editing

These controls appear in the Touch Bar when the timeline is active. Use these trimming, playback, and navigation controls to streamline your editing workflow.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Editing Tools" /></td>
<td>Editing Tools</td>
<td>Display a set of editing tools in the Touch Bar. The button shows the active tool. See Editing tools, below.</td>
</tr>
<tr>
<td><img src="image" alt="Audio Controls" /></td>
<td>Audio Controls</td>
<td>Display a set of audio controls in the Touch Bar. See Audio controls, below.</td>
</tr>
<tr>
<td><img src="image" alt="Override Clip Connections" /></td>
<td>Override Clip Connections</td>
<td>Temporarily override clip connections for the selection. See Edit clips in the primary storyline without affecting connected clips.</td>
</tr>
<tr>
<td><img src="image" alt="Trim to Playhead" /></td>
<td>Trim to Playhead</td>
<td>Trim the edit point closest to the playhead. See Cut the start or end of a clip at the playhead.</td>
</tr>
<tr>
<td><img src="image" alt="Trim Start" /></td>
<td>Trim Start</td>
<td>Trim the clip start point to the skimmer or playhead position. See Cut the start or end of a clip at the playhead.</td>
</tr>
<tr>
<td><img src="image" alt="Trim End" /></td>
<td>Trim End</td>
<td>Trim the clip end point to the skimmer or playhead position. See Cut the start or end of a clip at the playhead.</td>
</tr>
<tr>
<td><img src="image" alt="Play Around" /></td>
<td>Play Around</td>
<td>Play around the playhead position. See Play back video and audio clips.</td>
</tr>
</tbody>
</table>
Editing tools

The timeline editing tools appear in the Touch Bar when you tap the Editing Tools button. The default editing tool is the Select tool. You can tap any tool to make it the active tool. When you choose a tool, the pointer changes to the icon for that tool.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Close]</td>
<td>Close</td>
<td>Close the editing tools.</td>
</tr>
<tr>
<td>![Select tool]</td>
<td>Select tool</td>
<td>Select items in the timeline. See Select clips.</td>
</tr>
<tr>
<td>![Trim tool]</td>
<td>Trim tool</td>
<td>Trim clips in the timeline using ripple, roll, slip, and slide edits. See Intro to trimming.</td>
</tr>
<tr>
<td>![Position tool]</td>
<td>Position tool</td>
<td>Place clips in the timeline. See Overwrite clips using the Position tool.</td>
</tr>
<tr>
<td>![Range Selection tool]</td>
<td>Range Selection tool</td>
<td>Select a range within a clip or across multiple clips. See Select ranges.</td>
</tr>
<tr>
<td>![Blade tool]</td>
<td>Blade tool</td>
<td>Cut clips in the timeline. See Cut clips in two.</td>
</tr>
<tr>
<td>![Zoom tool]</td>
<td>Zoom tool</td>
<td>Zoom in and out of the timeline. See Zoom in to and out of the timeline using the Zoom tool.</td>
</tr>
<tr>
<td>![Hand tool]</td>
<td>Hand tool</td>
<td>Scroll the timeline. See Manually scroll a zoomed-in timeline.</td>
</tr>
</tbody>
</table>
Audio controls

The audio controls appear when you tap the Audio Controls button ( ) in the Touch Bar.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Close" /></td>
<td>Close</td>
<td>Close the audio controls.</td>
</tr>
<tr>
<td><img src="image" alt="Silence" /></td>
<td>Silence</td>
<td>Silence the selected clip, range, or audio component. See Silence clips or ranges.</td>
</tr>
<tr>
<td><img src="image" alt="Audio Fade In" /></td>
<td>Audio Fade In</td>
<td>Apply an audio fade-in to selected clips or audio components (available for timeline selections only). See Apply fades using the Modify menu.</td>
</tr>
<tr>
<td><img src="image" alt="Decrease Volume" /></td>
<td>Decrease Volume</td>
<td>Decrease the volume for the selected clip, range, or audio component. See Adjust volume.</td>
</tr>
<tr>
<td><img src="image" alt="Volume slider" /></td>
<td>Volume slider</td>
<td>Adjust the volume for the selected clip, range, or audio component (available for single-item selections only). See Adjust volume.</td>
</tr>
<tr>
<td><img src="image" alt="Increase Volume" /></td>
<td>Increase Volume</td>
<td>Increase the volume for the selected clip, range, or audio component. See Adjust volume.</td>
</tr>
<tr>
<td><img src="image" alt="Audio Fade Out" /></td>
<td>Audio Fade Out</td>
<td>Apply an audio fade-out to the selected clip, range, or audio component (available for timeline selections only). See Apply fades using the Modify menu.</td>
</tr>
</tbody>
</table>
Timeline navigation

When you tap the Timeline Navigation button, the Timeline Navigation slider appears in the Touch Bar. Use the slider to control what portion of your project is visible in the timeline. Drag the start or end handle, or drag the center of the slider to move the start and end points at the same time.

To close the Timeline Navigation slider and return to the timeline editing controls, tap the close button.

Note: When Final Cut Pro is in full-screen view, a timeline appears in the Touch Bar, which you can navigate by tapping or dragging.

Text editing

These controls appear in the Touch Bar when you select a title in the viewer. Use these controls to format and edit your titles.

Note: The Done button does not appear in the Touch Bar on all MacBook Pro models.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![A]</td>
<td>Text Appearance</td>
<td>Display a set of text alignment, style, and appearance controls in the Touch Bar. See Text alignment and appearance, below.</td>
</tr>
<tr>
<td>![A]</td>
<td>Text Size</td>
<td>Display the Text Size slider. See Text size, below.</td>
</tr>
<tr>
<td>![A]</td>
<td>Text Kerning</td>
<td>Display the Text Kerning slider. See Text kerning, below.</td>
</tr>
<tr>
<td>![3D]</td>
<td>3D Text</td>
<td>Enable or disable 3D text. See Convert text to 3D text.</td>
</tr>
<tr>
<td>![ ]</td>
<td>Text Color</td>
<td>Display the text color controls, including controls for adjusting hue, brightness, and saturation (available for 2D text only). See Text color, below.</td>
</tr>
</tbody>
</table>
Text alignment and appearance

These controls appear in the Touch Bar when you tap the Text Appearance button in the text editing controls.

Use these controls to adjust the alignment, style, and appearance of text selected in the viewer.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Close" /></td>
<td>Close</td>
<td>Close the text appearance controls.</td>
</tr>
<tr>
<td><img src="image" alt="Align Text Left" /></td>
<td>Align Text Left</td>
<td>Align the selected text to the left.</td>
</tr>
<tr>
<td><img src="image" alt="Align Text Center" /></td>
<td>Align Text Center</td>
<td>Center the selected text.</td>
</tr>
<tr>
<td><img src="image" alt="Align Text Right" /></td>
<td>Align Text Right</td>
<td>Align the selected text to the right.</td>
</tr>
<tr>
<td><img src="image" alt="Bold Text" /></td>
<td>Bold Text</td>
<td>Make the selected text bold (if available for the selected font).</td>
</tr>
<tr>
<td><img src="image" alt="Italic Text" /></td>
<td>Italic Text</td>
<td>Italicize the selected text (if available for the selected font).</td>
</tr>
<tr>
<td><img src="image" alt="Text Face" /></td>
<td>Text Face</td>
<td>Turn the Face parameter settings on or off (available for 2D text only). See Change a title's text style.</td>
</tr>
<tr>
<td><img src="image" alt="Text Outline" /></td>
<td>Text Outline</td>
<td>Turn the Outline parameter settings on or off (available for 2D text only). See Change a title's text style.</td>
</tr>
<tr>
<td><img src="image" alt="Text Glow" /></td>
<td>Text Glow</td>
<td>Turn the Glow parameter settings on or off (available for 2D text only). See Change a title's text style.</td>
</tr>
<tr>
<td><img src="image" alt="Text Drop Shadow" /></td>
<td>Text Drop Shadow</td>
<td>Turn the Drop Shadow parameter settings on or off (available for 2D text only). See Change a title's text style.</td>
</tr>
</tbody>
</table>

Text size

When you tap the Text Size button in the text editing controls, the Text Size slider appears in the Touch Bar. Drag the slider to change the size of text selected in the viewer.

To close the Text Size slider and return to the text editing controls, tap the close button.
Text kerning

When you tap the Text Kerning button in the text editing controls, the Text Kerning slider appears in the Touch Bar. Drag the slider to adjust the space between text characters.

Note: For the slider to be available, the insertion point (a blinking bar) must be positioned between text characters in the viewer.

To close the Text Kerning slider and return to the text editing controls, tap the close button.

Text color

When you tap the Text Color button in the text editing controls, the text color controls appear in the Touch Bar. Either the color swatches or the hue controls appear, depending on which controls were open last.

To switch between the color swatches and the hue controls, tap the Hue/Color Swatch button on the right end of the Touch Bar.

To change the color of text, select it in the viewer, then tap a color swatch, or drag the Hue slider.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✗</td>
<td>Close</td>
<td>Close the text color controls.</td>
</tr>
<tr>
<td></td>
<td>Active Color</td>
<td>Displays the active color (hue), based on your current color settings.</td>
</tr>
<tr>
<td></td>
<td>Hue/Color Swatch</td>
<td>Switch between displaying color swatches and hue controls.</td>
</tr>
<tr>
<td></td>
<td>Brightness</td>
<td>Display the Brightness control. Tap or drag to change the brightness of the text selected in the viewer.</td>
</tr>
<tr>
<td></td>
<td>Saturation</td>
<td>Display the Saturation control. Tap or drag to change the saturation of the text selected in the viewer.</td>
</tr>
</tbody>
</table>
Customize keyboard shortcuts

Intro to the Command Editor in Final Cut Pro for Mac

You can use the Command Editor to view and modify existing shortcuts, create new shortcuts, and save multiple sets of keyboard shortcuts that you can export for others to use. You can also import a set of shortcuts that someone else created. And if you’re more familiar with keyboard shortcuts from other apps, you can use the Command Editor to substitute those shortcuts in place of the default set in Final Cut Pro.

View keyboard shortcuts in Final Cut Pro for Mac

Final Cut Pro provides a wide variety of menu commands and keyboard shortcuts that let you control almost every aspect of your project, from playback to displaying windows and inspectors to working with tools.

The Command Editor provides a set of Final Cut Pro keyboard shortcuts in English, Japanese, French, and German. The language that is shown is determined by your computer’s operating system. To learn how to change the language used by Final Cut Pro, see macOS Help, available from the Help menu when the Finder is active.
View standard keyboard shortcuts


   The Command Editor appears.

2. To find keyboard shortcuts in the Command Editor, do any of the following:
   
   - Click one or more keys on the virtual keyboard (or click one of the four modifier key buttons at the top of the Command Editor).

   The command groups, or categories, associated with the selected key or keys appear in the bottom-left corner of the window, and a list of all the keyboard shortcuts associated with the key or keys appears in the bottom-right corner of the window.

   Click a key to see the command groups associated with the key.
When you press any modifier key on your keyboard, or click any modifier key button to select it, the key colors update. Key colors correspond with command groups; for example, editing commands, such as Overwrite (D), are blue. The clickable list of command groups in the bottom-left corner of the Command Editor contains a color key for reference.

- Enter a command name, description keywords, or a key name in the search field at the top-right corner of the window.

The commands that match the search term appear in the command list at the bottom of the window.

Tip: To show the keys that correspond with the items in the command list, click the Keyboard Highlight button to the left of the search field.

Click any command in the list to view a description in the detail area on the right.

- Click a command group to quickly filter the command list to display only the commands and keyboard shortcuts in that group.

Click any command in the list to view a description in the detail area on the right.
View shortcuts from a different command set

If your system has multiple command sets, you can easily switch between them. See Export or import keyboard shortcuts.

In Final Cut Pro, do one of the following:

• Choose Final Cut Pro > Commands, then choose a command set from the submenu.
  The Command Editor window appears, showing the command set you chose.

• If you’ve already opened the Command Editor, click the pop-up menu in the top-left corner of the window and choose a command set.

Modify keyboard shortcuts in Final Cut Pro for Mac

You can quickly and easily customize keyboard shortcuts in the Command Editor. If you want to add a few custom commands to the default set in Final Cut Pro, you can duplicate the default set and assign keyboard shortcuts to some of the unassigned commands. You can also create a new set that contains only your commands.

Duplicate a command set


2. If the command set you want to duplicate isn’t shown, click the pop-up menu in the top-left corner of the Command Editor choose a different command set.

3. Click the pop-up menu in the top-left corner of the Command Editor and choose Duplicate.

4. In the window that appears, type a name for the command set, then click OK.
  The duplicate set is added to the Commands submenu of the Final Cut Pro menu and to the pop-up menu in the Command Editor.
Modify a command set
You can add keyboard shortcuts to a command set or reassign keyboard shortcuts.

2. If the command set you want to modify isn’t shown, click the pop-up menu in the top-left corner of the Command Editor and choose a different command set.
3. Select the command you want to assign a new keyboard shortcut to by doing one of the following:
   • Type a command name in the search field in the top-right corner of the Command Editor.
   • Browse the command list to find the command you want.
4. Press the combination of keys you want to use for the command (for example, Option-Shift-T, or any other keys).
   Note: The keys on the Command Editor keyboard that are shaded with diagonal lines are reserved for system use and can’t be assigned.
   If the key combination is not already assigned to a command, the Command Editor keyboard updates to show the new key assignment. A gray dot appears on the newly assigned key (or keys), and a color is applied if the command belongs to a color-coded command group.
   If the key combination is already assigned to a command, Final Cut Pro displays the current setting, and you’re asked to confirm the change.
5. To save your changes to the command set, click the Save button in the lower-right corner of the Command Editor.
   If you close the Command Editor with unsaved changes, you’re prompted to save your changes.

Delete a command set
2. If the command set you want to delete isn’t shown, click the pop-up menu in the top-left corner of the Command Editor and choose a different command set.
3. Click the pop-up menu in the top-left corner of the Command Editor and choose Delete.
4. In the window that appears, click Delete.
   The command set is removed.
Export or import keyboard shortcuts in Final Cut Pro for Mac

After you save a command set, you may want to export it to create a backup or to share the new set with another user. Exported command sets are saved in a file that can be imported back into Final Cut Pro at a later time.

Export a set of custom keyboard shortcuts

2. If the command set you want to export isn’t shown, click the pop-up menu in the top-left corner of the Command Editor and choose a different command set.
3. Do one of the following:
   • Choose Final Cut Pro > Commands > Export.
   • Click the pop-up menu in the top-left corner of the Command Editor and choose Export.
4. Type a name for the exported command set in the Save As field, navigate to the location where you want to save the exported set, and click Save.

   The file is saved in the location you chose, with the filename extension .commandset.

Import a command set

1. In Final Cut Pro, do one of the following:
   • Choose Final Cut Pro > Commands > Import.
   • Open the Command Editor by choosing Final Cut Pro > Commands > Customize, then click the pop-up menu in the upper-left corner of the Command Editor and choose Import.
2. In the window that appears, navigate to the location where you’ve stored a command set file, select it, and click Open.

   If you’re already using a command set with the same name, you’re asked to rename the command set.

   The new command set is added to the Commands submenu of the Final Cut Pro menu and to the pop-up menu in the Command Editor.
Customize the Final Cut Pro interface

Arrange the main window in Final Cut Pro for Mac

The main areas of the Final Cut Pro window include the browser, viewer, timeline, sidebar, and inspector. You can show, hide, and resize these areas to suit both your working style and the task at hand, even across multiple displays.

Final Cut Pro also comes with a set of predefined workspace layouts, and you can create and save your own custom workspace layouts. See Change the workspace layout.

Resize areas of the Final Cut Pro window

- Drag the border between two areas of the Final Cut Pro window.
  As you drag, one area gets larger, and the other gets smaller.

When both the browser and viewer are shown, the bottom of the browser and viewer acts as a single border—resizing one resizes the other as well.
Show or hide the browser, the timeline, or the inspector

In Final Cut Pro, do any of the following:

- **Show or hide the browser:** Click the Browser button in the toolbar (or press Control-Command-1).

  ![Browser button in toolbar](image)

  The image below shows the Final Cut Pro window with the browser hidden and just the viewer and the timeline showing:

  ![Viewer and timeline showing](image)

- **Show or hide the timeline:** Click the Timeline button in the toolbar (or press Control-Command-2).

  ![Timeline button in toolbar](image)

  *Note:* You can’t hide both the browser and the timeline at the same time.

- **Show or hide the inspector:** Click the Inspector button in the toolbar (or press Command-4).

  ![Inspector button in toolbar](image)

  💡 **Tip:** To switch the inspector between full-height view and half-height view, double-click the top bar of the inspector. You can also choose View > Toggle Inspector Height (or press Control-Command-4).
Show or hide the sidebar

The sidebar appears to the left of the browser and contains three panes for selecting different types of media: the Libraries sidebar, the Photos, Videos, and Audio sidebar, and the Titles and Generators sidebar. When you select an item in the sidebar (such as an event containing clips, or a category of sound effects or 3D titles), the item's contents are displayed in the browser. You can show or hide any of the sidebars.

In Final Cut Pro, do any of the following:

- **Show the Libraries sidebar:** Click the Libraries button in the top-left corner of the Final Cut Pro window, or choose Window > Go To > Libraries (or press Command-1).
- **Show the Photos, Videos, and Audio sidebar:** Click the Photos, Videos, and Audio button in the top-left corner, or choose Window > Go To > Photos, Videos, and Audio (or press Shift-Command-1).
- **Show the Titles and Generators sidebar:** Click the Titles and Generators button in the top-left corner, or choose Window > Go To > Titles and Generators (or press Option-Command-1).
- **Show or hide the sidebar:** Choose Window > Show in Workspace > Sidebar, or press Command-Grave Accent (`). You can also hide the sidebar by clicking the button for the sidebar that's currently shown (the button is highlighted).
Use a second display with Final Cut Pro for Mac

When you connect a second display to your Mac, controls appear that allow you to move the viewer, browser, or timeline to the second display.

To view playback on an external video monitor, see Play media on an external display and Color correct HDR video with Pro Display XDR.

1. Make sure that the second display is connected to your Mac and turned on.

   The Secondary Display button and pop-up menu appear in the toolbar at the top of the Final Cut Pro window.

2. To choose which area of the Final Cut Pro window you want to move to the second display, do one of the following:
   - Click the Secondary Display pop-up menu and choose Timeline, Viewer, or Browser.
   - Choose Window > Show in Secondary Display > [item].
The area you chose moves to the second display, and the other areas of the Final Cut Pro window are adjusted on the primary display.

To move all areas back to the primary display, click the Secondary Display button.
Change the workspace layout in Final Cut Pro for Mac

Final Cut Pro comes with a set of predefined workspace layouts that determine the size and location of the main areas of the Final Cut Pro window, including the browser, the viewer, the inspector, and the timeline.

If none of the existing workspace layouts meet your needs, you can create and save additional layouts. After you save a custom workspace layout, you can easily share it with others. When you create custom layouts, you can include additional areas, such as the timeline index, the event viewer, the comparison viewer, and the audio meters.

Choose a workspace layout

- In Final Cut Pro, choose Window > Workspaces, then choose a layout from the submenu.

Save custom workspace layouts

1. In Final Cut Pro, arrange the areas of the main window the way you want them.
   
   See Arrange the main window.

2. Choose Window > Workspaces > “Save Workspace as.”

3. Enter a name for the new layout, then click Save.
   
   The new layout is added to the Workspaces submenu.

⚠️ Tip: To save a change to an existing custom layout, make the change, then choose Window > Workspaces > Update [name] Workspace.
Share custom workspace layouts
You can easily copy custom workspace layouts to another computer or share them with friends and colleagues.

1. In Final Cut Pro, save a custom workspace layout.
   See Save custom workspace layouts, above.
2. Choose Window > Workspaces > Open Workspace Folder in Finder.
   The Workspaces folder, with all the custom layouts you created, opens in the Finder.
3. In the Finder, select the custom layout files you want to share, then choose File > Compress.
   Note: Compressing the files prevents any change to custom layouts during transit.
4. Transfer the resulting ZIP file (with the filename extension .zip) to your friend or colleague using email or another convenient method.
5. On the receiving Mac, double-click the ZIP file to decompress it.
6. In the Finder, hold down the Option key and choose Go > Library.
7. Drag the custom layout files to the following location in the Library folder:
   /Users/username/Library/Application Support/Final Cut Pro/Workspaces/

Use workflow extensions in Final Cut Pro for Mac
You can use extensions to access features of third-party apps from within Final Cut Pro. For example, you can access stock footage, media management, and review-and-approve apps without ever leaving Final Cut Pro.

1. To install an extension for Final Cut Pro, follow the instructions that came with the extension app.
2. Open Final Cut Pro.
3. Click the Extensions button on the left side of the Final Cut Pro toolbar.
   Note: The Extensions button appears only when extensions are installed.

   ![Extensions button](image)

   The extension window or a menu of installed extensions appears.

   See the documentation that came with extension app for instructions on how to use it. For example, you might drag items from the extension window to an event in the Libraries sidebar or to a project in the timeline.
4. To close the extension window, click the Extensions button.

To uninstall an extension, remove it from the Applications folder and reopen Final Cut Pro.
Work with metadata

Intro to metadata in Final Cut Pro for Mac

You can view and change the information associated with a clip, referred to as a clip's metadata. Metadata includes information about a clip's source media files as well as information you add to a clip, such as notes.

In Final Cut Pro, you work with three types of metadata:

- **Exchangeable Image File (EXIF) data**: Information recorded by the camera and stored in the media at the time it was shot, such as camera make and model, file size, color profile, and bits per sample.

- **International Press Telecommunications Council (IPTC) data**: Standardized data used by media organizations to embed keywords, captions, copyright notices, and other information in the media files themselves.

- **Final Cut Pro metadata**: Data you apply to clips within Final Cut Pro, such as clip name, ratings, and keywords.

You can create your own combinations of metadata, called metadata views, to display with your clips. You can either create new metadata views or modify the ones that come with Final Cut Pro. See Modify metadata views.

View and change clip metadata in Final Cut Pro for Mac

You can use the Info inspector to view and change the metadata for a clip or group of clips selected in the browser or timeline.

The Share inspector also displays metadata that is exported with a shared clip or project. See Change metadata for shared items.
View a clip’s metadata

1. Select one or more clips in the Final Cut Pro browser or timeline.
2. If the inspector isn’t already shown, do one of the following:
   - Choose Window > Show in Workspace > Inspector (or press Command-4).
   - Click the Inspector button on the right side of the toolbar.
3. Click the Info button at the top of the inspector.

Metadata for the selected clip or group of clips is displayed in fields in the Info inspector.

Switch metadata views in the Info inspector

You can change the metadata fields shown in the Info inspector.

1. Select one or more clips in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose a metadata view.

Note: If you create custom metadata views, they also appear in the pop-up menu.
Change a clip’s metadata
1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector, then choose a metadata view that contains fields for the metadata you want to change.
4. Do one of the following:
   • Click in a text field to make it active, then enter the text you want to include.
     Note: If you can't click in a text field, it means the field can't be edited. Some EXIF metadata fields, for example, can't be edited.
   • Click the pop-up menu for the metadata you want to change, then choose an option.
   ! Tip: You can also change the Content Created date and time of your source clips in the browser. Just select one or more clips, then choose Modify > Adjust Content Created Date and Time.

Rearrange the fields in a metadata view
1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. Drag the metadata labels into a different order.

Modify metadata views in Final Cut Pro for Mac
You can create new metadata views or modify the ones that come with Final Cut Pro.

Create a new metadata view
1. Select one or more clips in the Final Cut Pro browser or timeline.
2. If the inspector isn't already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button in the toolbar.
3. Click the Info button at the top of the inspector.
4. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose Edit Metadata View.
5. In the Metadata Views window that appears, click the Action pop-up menu in the bottom-left corner and choose New Metadata View.
6. Enter a name for the new metadata view, then press Return.
7. To limit the number of properties to a specific group, such as EXIF or video properties, click the Properties pop-up menu at the top of the window and choose a property group.

8. To add a property to the metadata view, select the checkbox to the left of the property.

9. When you're satisfied with the metadata fields assigned to the metadata view, click OK. The new metadata view is added to the Metadata View pop-up menu in the Info inspector.

Modify an existing metadata view

You can change the combination of metadata that appears in a metadata view. You can rename metadata fields, add or remove metadata fields, create custom metadata fields, and rearrange the order in which the metadata fields are displayed.

1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. In the Info inspector, click the Metadata View pop-up menu in the bottom-left corner and choose Edit Metadata View.
4. In the Metadata Views window, select the metadata view you want to change, then do any of the following:
   - *Rename the metadata view:* Double-click the metadata view name in the column on the left, enter a new name, then press Return.
   - *Remove properties (metadata fields) from the metadata view:* In the Property column, deselect checkmarks to the left of the properties you want to remove.
   - *Add properties (metadata fields) to the metadata view:* In the Property column, select the checkboxes to the left of the properties you want to add.
   - *Add a custom property (metadata field) to the metadata view:* Click the Action pop-up menu in the bottom-left corner, choose Add Custom Metadata Field, enter a name and description for the new property, then click OK.
5. When you're satisfied with the metadata fields assigned to the selected metadata view, click OK.
Duplicate a metadata view
If you want to create a new metadata view that contains most of the metadata fields in an existing metadata view, you can save time by duplicating the existing metadata view and then modifying it.

1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. In the Info inspector, click the Metadata View pop-up menu in the bottom-left corner, choose the metadata view you want to duplicate, then click the Metadata View pop-up menu again and choose Save Metadata View As.
4. In the window that appears, enter a name for the new metadata view and click OK.
The new metadata view appears in the Metadata View pop-up menu in the Info inspector. You can modify the new metadata view as needed.

Delete a metadata view
1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. In the Info inspector, click the Metadata View pop-up menu in the bottom-left corner and choose Edit Metadata View.
4. In the Metadata Views window, select the metadata view you want to delete in the column on the left, then click the Action pop-up menu in the bottom-left corner and choose Delete Metadata View.
The metadata view is removed from the left column of the Metadata Views window and from the Metadata View pop-up menu in the Info inspector.

Note: Deleting a metadata view does not delete metadata applied to a clip or its source media.

Batch rename clips in Final Cut Pro for Mac
When you import media into Final Cut Pro, the clips often contain meaningless names, such as those assigned by the camera. Although you can rename clips individually, you can also rename a selection of clips as a batch in the browser, after the media has been imported. Final Cut Pro provides customizable naming presets that make renaming large numbers of clips efficient and easy.

Batch rename clips using a naming preset
1. In the Final Cut Pro browser, select the clips you want to rename.
2. If the inspector isn’t already shown, do one of the following:
   • Choose Window > Show in Workspace > Inspector (or press Command-4).
   • Click the Inspector button in the toolbar.
3. Click the Info button at the top of the inspector.

4. In the Info inspector, click the Apply Custom Name pop-up menu and choose a naming preset.

The clips selected in the browser are renamed.

**Create a new naming preset**

If the naming presets that come with Final Cut Pro don’t meet your needs, you can create a new naming preset and customize it.

⚠️ Tip: The easiest way to create a new naming preset is to duplicate an existing one. See **Duplicate an existing naming preset**, below.

1. In the Final Cut Pro browser, select the clips you want to rename.
2. Open the Info inspector.
3. Click the Apply Custom Name pop-up menu and choose New.
4. In the Naming Presets window, double-click Untitled, type a name for the new preset, then press Return.

The new naming preset appears in the Apply Custom Name submenu of the Action pop-up menu.

**Duplicate an existing naming preset**

The simplest way to create a new naming preset is to duplicate an existing preset—one that contains most of the name format options you want to include—and modify it.

1. In the Final Cut Pro browser, select the clips you want to rename.
2. Open the Info inspector.
3. Click the Apply Custom Name pop-up menu and choose Edit.
4. In the Naming Presets window, Control-click the preset you want to duplicate, then choose Duplicate.

The duplicate naming preset appears below the original preset.

5. Enter a name for the duplicate preset, then press Return.

You can now modify the preset to suit your needs.
Modify an existing naming preset
1. In the Final Cut Pro browser, select the clips you want to rename.
2. Open the Info inspector.
3. Click the Apply Custom Name pop-up menu and choose Edit.
4. In the Naming Presets window, add naming tokens—metadata elements you can use to create a naming preset—by dragging them from the Clip Info, Date/Time, Format, and Camera areas to the Format field.

To remove a naming token, select it in the Format field and press Delete.
5. Rearrange the tokens in the Format field by dragging them into new positions.
6. If you like, add text characters, such as underscores (_) and spaces, between naming tokens in the Format field.
7. When you’re satisfied with the naming preset’s new format, click OK.

Remove a naming preset
1. Select a clip in the Final Cut Pro browser or timeline.
2. Open the Info inspector.
3. Click the Apply Custom Name pop-up menu and choose Edit.
4. In the Naming Presets window, select the naming preset you want to remove, then click the Remove Presets button (with a minus sign).

The naming preset is removed from the Naming Presets window.
Use color and gradient controls

Intro to color and gradient controls in Final Cut Pro for Mac

The color and gradient controls appear in an inspector when you have the option to apply a custom color or gradient to a selected item, such as a title or generator in your project.

Use color controls to set the color of objects such as shapes, text, and gradients. Use the gradient editor to change gradient parameters, such as color, opacity, direction, and so on.

Color controls

Basic color controls in Final Cut Pro for Mac

Before you expand the color controls, you see the following:

- **Color well**: A small color swatch that, when clicked, opens the macOS Colors window. See [Pick a color in the Colors window](#). You can also click the downward arrow or Control-click the color well to open the pop-up color palette. See [Use the pop-up color palette](#).

- **Disclosure triangle**: A control that, when clicked, reveals individual Red, Green, Blue, and, when applicable, Opacity sliders. See [Use expanded color controls](#).

Use the pop-up color palette in Final Cut Pro

Use the pop-up color palette to select a color from the spectrum of hues, saturation, and lightness. You can also select a grayscale value.
1. In Final Cut Pro, Control-click a color well, or click the adjacent downward arrow.

2. In the pop-up color palette, do one of the following:
   
   - Select a color from the spectrum of hues, saturation, and lightness: Click in the top area.
   - Select a grayscale value: Click in the bottom gradient.

   As you move the pointer over either area, the pointer becomes an eyedropper, the column on the right displays the RGB and HSL values for the sampled colors, and two swatches above the RGB information display the current and sampled colors. As you sample in the spectrum, the selected object is updated in the viewer.

**Use the Colors window in Final Cut Pro for Mac**

You can use the macOS Colors window in Final Cut Pro, giving you access to the familiar color pickers such as the Spectrum palette or the Pencils palette.

The Colors window has four sections: the icons at the top select picker interfaces; the large color swatch shows the current color; the middle section shows the active picker; and the row of boxes can be used to save swatches.

**Show the Colors window**

- Click a color well in Final Cut Pro.

**Pick a color in the Colors window**

Do one of the following:

- Click a color in the color picker area.
- Click the eyedropper, then click anywhere on the computer screen to choose a color.

The color you click in the Colors window loads into the well, and the selected item changes color.
Save a color to the saved swatch area in the Colors window
1. Select a color in the picker or by using the eyedropper.
2. Drag the color from the large swatch to a white square at the bottom of the Colors window.
   Colors saved in this area remain accessible across applications and restarts.

Use expanded color controls in Final Cut Pro for Mac
Sometimes you need precise numerical control over colors. You might also need to match two colors exactly or adjust a color channel independently.

Every set of color controls has a disclosure triangle, which, when clicked, reveals sliders for the Red, Green, and Blue color channels. You can choose or fine-tune a color by adjusting these sliders. Among other uses, these controls are handy when you need to keyframe each color channel differently.

Gradient controls
Intro to the gradient editor in Final Cut Pro for Mac
Many titles and generators that can be filled with a color can also be filled with a gradient. Like color controls, gradient controls are a group of settings that can be expanded for more precise control.
Change gradient colors in Final Cut Pro for Mac

You can use the gradient controls to create gradients in titles and generators.

Change the colors in a gradient

1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. To change the color of a color tag in the gradient editor, do one of the following:
   • Double-click a color tag.
   • Click a color tag, then adjust the Red, Green, and Blue color channel sliders.
   • Click the down arrow next to the color well to display the pop-up color palette. When you move the pointer over the color palette, the pointer becomes an eyedropper. Click in the top area to select a color, or click in the bottom gradient to set the tag to a grayscale value.
Change the opacity in a gradient
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, click an opacity tag.

   The Opacity slider becomes available.

4. Use the Opacity slider or adjacent value slider to change the level of transparency.

   The gradient reflects the new opacity values.

   The lower the percentage of opacity, the greater the transparency.

Add or remove a color tag
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, position the pointer in the lower gradient bar where you want to add the new color, then click.

   A new color tag is added to the gradient.

Add an opacity tag to a gradient
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, position the pointer in the opacity bar (the top bar) where you want to add the tag, then click.

   A new opacity tag is added to the gradient.

   Until the value is adjusted, the gradient opacity is 100%.
Remove a color or opacity tag from the gradient
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, drag the tag away from the gradient bar.

Reverse gradient direction in Final Cut Pro for Mac
You can reverse the direction of gradients in titles and generators, or evenly distribute the gradient color and opacity tags.

Reverse the gradient color or opacity direction
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, click the reverse tags icon next to the opacity or color bar.

Evenly distribute the gradient color or opacity tags
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, click the distribute tags icon next to the opacity or color bar.

Change the direction of a gradient
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, use the Start and End value sliders to change the direction of the gradient.
Move and copy gradient tags in Final Cut Pro for Mac

You can manipulate tags in the gradient editor to create custom gradients in titles and generators.

Move the position of a color or opacity tag
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, click the color or opacity tag you want to move.
4. Do one of the following:
   • Drag the color or opacity tag left or right.
   • Use the Location slider (or adjacent value slider) to modify the position of the selected tag. A value of 100% is the rightmost position of the gradient, and a value of 0% is the leftmost position of the gradient.

Duplicate a color or opacity tag
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, Option-drag the tag to a new position.

Change the transition midpoint between adjacent color or opacity tags
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, drag the small triangle between adjacent color tags or opacity tags to change the point where one tag’s effect ends and the next tag’s effect begins.

The closer the middle control is to a tag, the sharper the color or opacity transition.

Note: The middle control does not appear for color or opacity tags set to Linear or Constant.

Change the color or opacity tag interpolation
1. In Final Cut Pro, select a title or generator, then open the inspector.
2. Click the Gradient disclosure triangle to show the gradient editor.
3. In the gradient editor, Control-click a tag and choose either Constant, Linear, or Continuous.
Basic gradient controls in Final Cut Pro for Mac

Before you expand the gradient controls, you see the following in the inspector in Final Cut Pro:

- **Gradient preview bar**: A horizontal bar that displays the currently selected gradient
- **Disclosure triangle**: A control that, when clicked, expands to show the gradient editor

Gradient editor controls in Final Cut Pro for Mac

In Final Cut Pro, use the advanced gradient controls to make precise adjustments to gradients applied to selected items (such as titles and generators).

To customize or modify a gradient, click the disclosure triangle in the Gradient row of the inspector to reveal the advanced gradient controls:

- **Graphical controls**: Three horizontal bars that let you set and preview the opacity, color, and spread of a gradient.

  The narrow, white top bar (the *opacity bar*) controls opacity and transparency in the gradient. Adjust the spread of opacity across the gradient by dragging one of the small box-shaped *opacity tags* horizontally along the bar. Click in the opacity bar to add opacity tags, creating a gradient with varying levels of transparency. Delete an opacity tag by dragging it away from the color bar. Change the value of an opacity tag by selecting it and dragging the Opacity slider (described below).

  Opacity tags have a value range of 0% (completely transparent) to 100% (completely opaque). Adjust the transition between two opacity tags by dragging the *middle control*—a small triangle between adjacent tags, available when Interpolation is set to Continuous (described below). By default, the opacity of a gradient applied to text is 100%.

  The wide middle bar shows a preview of the current gradient.
The narrow bottom bar (the *gradient bar*) controls color in the gradient. Adjust the spread of color across the gradient by dragging one of the small box-shaped **color tags** horizontally along the bar. Click in the gradient bar to add more color tags. Delete a color tag by dragging it away from the gradient bar. Change the value of a color tag by selecting it and choosing a color from the color well below, or by double-clicking the tag and choosing a color from the Colors window. Adjust the transition between color tags by dragging the **middle control**—a small triangle between adjacent tags, available when Interpolation is set to Continuous (described below).

Selecting a color tag activates the Color and Location controls (described below). Selecting an opacity tag activates the Opacity slider (described below). Selecting a middle control activates the Middle slider (described below).

- **Color:** A color well and eyedropper that sets the hue of a selected color tag in the gradient bar. For more information about color wells, see Basic color controls.

- **Opacity:** A slider that sets the transparency of a selected opacity tag in the opacity bar. Values range from 0% (completely transparent) to 100% (completely opaque).

- **Interpolation:** A pop-up menu that sets the interpolation of a selected color tag or opacity tag. There are three options:
  - **Linear:** Creates a uniform distribution of opacity or color between the tags.
  - **Continuous:** Sets an adjustable rate of change between adjacent opacity or color tags. Adjust the rate of change by dragging a middle control in the opacity bar or gradient bar, or by dragging the Middle slider (described below).
  - **Constant:** Creates a constant color distribution from the color or opacity tag, moving from left to right in the gradient. For example, if the left color tag is set to Constant, the area of the gradient between that tag and the next one to the right is a single, solid color.

- **Location:** A slider that adjusts the location of a selected opacity tag or color tag.

- **Type:** A pop-up menu that lets you choose a linear or radial gradient.
• **Start**: Value sliders that set the start position of the gradient in the selected object. This parameter affects the gradient as a whole—colors and opacity. Clicking the disclosure triangle stacks the X and Y value sliders vertically instead of horizontally.
  - **X**: Controls the X start position of the gradient.
  - **Y**: Controls the Y start position of the gradient.

• **End**: Value sliders that set the end position of the gradient in the selected object. This parameter affects the gradient as a whole—colors and opacity. Clicking the disclosure triangle stacks the X and Y value sliders vertically instead of horizontally.
  - **X**: Controls the X end position of the gradient.
  - **Y**: Controls the Y end position of the gradient.

*Note*: The Start and End parameters do not appear in standard text gradients.

• **Angle**: When the Type pop-up menu is set to Linear, this dial specifies the direction of a linear gradient. This parameter appears only for standard text gradients.

The Angle parameter, available for text gradients, defines the direction of a linear gradient.
Final Cut Pro includes free supplemental content and advanced video formats for use in your projects. You can download them after you install Final Cut Pro.

The Final Cut Pro supplemental content includes:

- Over 1300 royalty-free sound effects you can access from the Photos, Videos, and Audio sidebar in Final Cut Pro
- Additional preset effects for the Space Designer plug-in
  
  For information about using the Space Designer plug-in included with Final Cut Pro, see Final Cut Pro Logic Effects for Mac.

Pro Video Formats enables Final Cut Pro, Motion, and Compressor to work with a variety of professional video formats, including Apple ProRes codecs and MXF files.

1. Install Final Cut Pro from the Mac App Store.
   
   Shortly afterward, the additional content becomes available for download.

2. Choose Final Cut Pro > Download Additional Content.
   
   Software Update settings open, showing Final Cut Pro Supplemental Content and Pro Video Formats as available updates.

3. Do one of the following:

   - **Install all updates available for your Mac**: Click Update Now.
   - **Install selected updates**: Click “More info” to see a list of updates, select the checkboxes for the updates you want, then click Install Now.

If you’re not sure whether Pro Video Formats has been installed, see Verify installation of Pro Video Formats.

For information about permitted use of the content, see the Final Cut Pro Software License Agreement.
Glossary

4:3  The aspect ratio for standard-definition (SD) broadcast video. The ratio of the width to the height of the visible area of the video frame is 4:3, or 1.33. See also standard-definition (SD).

16:9  A widescreen aspect ratio for video. The ratio of the width to the height of the visible area of the video frame is 16:9, or 1.78. The 16:9 aspect ratio is used for high-definition (HD) video. See also high-definition (HD).

AAC (Advanced Audio Coding)  Also called MPEG-4 Audio. A standard way of compressing and encoding digital audio. AAC-encoded files rival the quality of audio CDs and generally sound as good as or better than MP3 files encoded at the same or even a higher bit rate.

AC3 (Audio Codec 3, Advanced Codec 3, Acoustic Coder 3)  A Dolby Digital compressed audio format often used for encoding surround sound.

AIFF (Audio Interchange File Format)  A cross-platform audio file format developed by Apple. Like WAV files, AIFF files contain “chunks” of information, such as the Sound Data Chunk, which contains the actual sample data, and the Common Chunk, which contains sample rate and bit depth information.

alpha channel  An image channel in addition to the R, G, and B (red, green, and blue) color channels that is used to store transparency information for compositing. Alpha channels are often 8-bit, but some applications support 16-bit alpha channels. In Final Cut Pro, black represents 100 percent transparency, and white represents 100 percent opacity. Only certain formats support alpha channels. Examples are Targa, TIFF, PNG, PSD, Apple ProRes 4444, and the QuickTime Animation codec. See also compositing, RGB.

angle editor  You can open multicam clips in the angle editor to adjust the sync and the angle order, or to add or delete angles. You can also use the angle editor to make edits to the individual clips inside a multicam clip (such as trimming, making color corrections, adding transitions, and so on). See also multicam clip.

angle viewer  A viewer used to watch all angles of a multicam clip simultaneously while switching or cutting to different angles in real time. You can cut and switch video and audio at the same time or independently. For example, you can use the audio from angle 1 while switching the video between angles 1 to 4. See also multicam clip.

animation editors  See Audio Animation editor, Video Animation editor.
**Apple ProRes**  Apple codecs that provide an unparalleled combination of multistream, real-time editing performance, impressive image quality, and reduced storage rates. Apple ProRes codecs take full advantage of multicore processing and feature fast, reduced-resolution decoding modes. All Apple ProRes codecs support any frame size (including SD, HD, 2K, 4K, and 6K) at full resolution. The data rates vary based on codec type, image content, frame size, and frame rate. See also frame rate, resolution.

**Apple ProRes 4444 XQ**  The highest-quality version of Apple ProRes for 4:4:4:4 image sources (including alpha channels), with a very high data rate to preserve the detail in high-dynamic-range imagery generated by the highest-quality digital image sensors. Apple ProRes 4444 XQ preserves dynamic ranges several times greater than the dynamic range of Rec. 709 imagery—even against the rigors of extreme visual effects processing, in which tone-scale blacks or highlights are stretched significantly. Like standard Apple ProRes 4444, this codec supports up to 12 bits per image channel and up to 16 bits for the alpha channel. Apple ProRes 4444 XQ features a target data rate of approximately 500 Mbps for 4:4:4 sources at 1920 x 1080 and 29.97 fps.

**Apple ProRes 4444**  An extremely high-quality version of Apple ProRes for 4:4:4:4 image sources (including alpha channels). This codec features full-resolution, mastering-quality 4:4:4:4 RGBA color and visual fidelity that is perceptually indistinguishable from the original material. Apple ProRes 4444 is a high-quality solution for storing and exchanging motion graphics and composites, with excellent multigeneration performance and a mathematically lossless alpha channel up to 16 bits. This codec features a remarkably low data rate compared to uncompressed 4:4:4 HD, with a target data rate of approximately 330 Mbps for 4:4:4 sources at 1920 x 1080 and 29.97 fps. It also offers direct encoding of, and decoding to, both RGB and Y'CbCr pixel formats.

**Apple ProRes 422 HQ**  A higher-data-rate version of Apple ProRes 422 that preserves visual quality at the same high level as Apple ProRes 4444, but for 4:2:2 image sources. With widespread adoption across the video post-production industry, Apple ProRes 422 HQ offers visually lossless preservation of the highest-quality professional HD video that a single-link HD-SDI signal can carry. This codec supports full-width, 4:2:2 video sources at 10-bit pixel depths, while remaining visually lossless through many generations of decoding and reencoding. The target data rate of Apple ProRes 422 HQ is approximately 220 Mbps at 1920 x 1080 and 29.97 fps.

**Apple ProRes 422**  A high-quality compressed codec offering nearly all the benefits of Apple ProRes 422 HQ, but at 66 percent of the data rate for even better multistream, real-time editing performance. The target data rate of Apple ProRes 422 is approximately 147 Mbps at 1920 x 1080 and 29.97 fps.

**Apple ProRes 422 LT**  A more highly compressed codec than Apple ProRes 422, with roughly 70 percent of the data rate and 30 percent smaller file sizes. This codec is perfect for environments where storage capacity and data rate are at a premium. The target data rate of Apple ProRes 422 LT is approximately 102 Mbps at 1920 x 1080 and 29.97 fps.

**Apple ProRes 422 Proxy**  An even more highly compressed codec than Apple ProRes 422 LT, intended for use in offline workflows that require low data rates but full-resolution video. The target data rate of Apple ProRes 422 Proxy is approximately 45 Mbps at 1920 x 1080 and 29.97 fps.
**Apple ProRes RAW** The Apple ProRes RAW and Apple ProRes RAW HQ codecs preserve all of the camera sensor’s pristine raw data to deliver extraordinarily high-quality images. ProRes RAW brings to RAW video the same great performance, quality, and ease of use that ProRes has brought to conventional video, in a format ideal for HDR content creation. Being able to use the raw image sensor data directly in Final Cut Pro during post-production gives you more control over the processing of the image, including demosaicing, linear-to-log conversions, and custom LUTs.

**aspect ratio** A film or video frame’s width-to-height ratio on any viewing screen. Standard-definition (SD) video (used for regular television screens) has an aspect ratio of 4:3. High-definition (HD) video has an aspect ratio of 16:9.

**Audio Animation editor** You can show the Audio Animation editor for clips in the timeline to adjust effect parameters, create fade-ins or fade-outs, or change effects over time using keyframes. See also **keyframe**, **Video Animation editor**.

**audio components** Audio files can contain a single audio channel or multiple audio channels. Final Cut Pro automatically groups audio channels into **audio components** according to how the channels are configured for the clip. In Final Cut Pro, you can expand the audio portion of clips to view and edit audio components down to the individual channel level.

**audio sample rate** The number of times an audio signal is measured, or **sampled**, per second. A higher sample rate produces higher-quality audio and larger file sizes, and a lower sample rate produces lower-quality audio and smaller file sizes.

**Audio Units** The standard real-time audio effect format for audio applications used with macOS.

**audio waveforms** Visual representations of the actual sound. An audio waveform’s amplitude and length change according to the underlying sound’s volume and duration. A short, loud sound such as a drum beat has a sharp, peaked waveform, whereas low-level crowd noise has a lower, more uniform waveform. These properties make it easier to find specific edit points when trimming clips or keyframing effects.

**audition** In Final Cut Pro, you can organize related clips into sets, called **auditions**, from which you can choose one clip to use. You can create an audition composed of different clips to try out multiple takes, or you can create an audition composed of multiple versions of the same clip to preview different effects. Auditions appear in the browser and timeline as clips with an audition icon in the top-left corner.

**automatic audio sync** The “Use audio for synchronization” option in the multicam clip creation process makes precision sync adjustments using audio waveforms in the angles of a multicam clip. This is the same audio sync technology that you can use to automatically analyze and sync clips together into a compound clip. See also **compound clip**, **multicam clip**.

**AVCHD** A high-definition (HD) video format that uses Advanced Video Coding (AVC) compression (also known as **MPEG-4 part 10** or **H.264**). Many Blu-ray players can play red laser discs with AVCHD format content, making this a common way to distribute short HD video projects using a standard red laser disc.

**Background Tasks window** A window in Final Cut Pro that shows the progress of importing, transcoding, analysis, rendering, sharing, and other tasks performed in the background.
batch  Compressor uses a batch to contain one or more source media files that you want to convert, or transcode, to another format. Each source media file creates its own job. This means that a batch can contain multiple jobs, with each job based on its own source media file. Each job also has at least one setting that defines the format of the transcoded file. See also source media files.

batch share  A feature in Final Cut Pro that allows you to share multiple projects, clips, or ranges in a single export.

Bezier curve  A parametric curve used to create smooth movement for keyframes and animated objects and to create precise, detailed mask shapes. Bezier curves contain two kinds of points: smooth points with handles that can be manipulated to curve the adjacent line segment, and corner points that have no handles and therefore have straight (or linear) adjacent line segments.

bit rate  The number of bits that are processed or transmitted per unit of time. The higher the bit rate, the better the quality. However, higher bit rates require larger file sizes.

Blade tool  The editing tool that allows you to cut clips in the timeline. You can select the Blade tool by pressing the B key.

blue laser media  Blu-ray burners and players use a blue laser when working with Blu-ray media. The blue laser has a shorter wavelength than the red laser used for DVDs, making it possible to store more data on a disc. See also red laser media.

blue or green screening  See chroma key.

broadcast-safe  Broadcast facilities have limits on the maximum values of luma and chroma that are allowable for broadcast. If a video exceeds these limits, distortion can appear, resulting in unacceptable transmission quality. You can use the Final Cut Pro video scopes to make sure that the luma and chroma levels you set stay within acceptable limits. See also chroma, luma.

B-roll  A term used to describe alternative footage shot to intercut with the primary shots used in a program. B-roll is frequently used for cutaway shots. See also cutaway shot.

browser  The browser displays clips, projects, photos, titles, or generators for the item selected in the sidebar (such as an event containing clips, or a category of sound effects or 3D titles). You select items in the browser to work with them. You can sort or group items in the browser by creation date, name, and duration. You can also view your clips as filmstrips or in a list. See also sidebar.

burn in  To make a visible and permanent change to an output media file. For example, titles are burned in. In contrast, captions can be included in the output media file without being permanently visible in the video image.

BWF (Broadcast Wave Format)  An extension of the WAV file format that includes additional metadata such as timecode and production information.

CAF (Core Audio Format)  Apple’s Core Audio Format (CAF) is a flexible file format for storing and manipulating digital audio data. It is fully supported by Core Audio APIs on Mac OS X 10.4 or later and on Mac OS X 10.3 with QuickTime 7 or later. CAF provides high performance and flexibility, and is scalable to future ultra-high-resolution audio recording, editing, and playback.

camera LUT  See LUT (lookup table).
CEA-608 Also known as EIA-608. A caption standard for broadcasts and web video. The CEA-608 caption standard features a variety of position, formatting, color, and animation options. CEA-608 captions can be imported or exported as separate files or as tracks embedded in a media file. CEA-608 caption files have the filename extension .scc.

chroma The color information contained in a video signal, consisting of hue, which represents the color itself, and saturation, which represents the intensity of the color.

chroma key A special effects technique that allows you to derive an alpha channel or matte from the blue or green background of a video clip in order to make it transparent (so that it can be composited against other clips). Blue- or green-screen technology is what makes weather forecasters appear to be standing against an animated map, when in reality they’re standing in front of a blue or green wall. Also known as blue or green screening. See also alpha channel.

chromaticity The exact values a display uses to represent each of the three primary colors. Different displays use different primary values. Because all colors represented by a particular display are a mix of the three primary colors, if the three primary points vary from display to display, the entire gamut of color shifts.

Cinematic Editor An interface for viewing and adjusting focus points in Cinematic mode video clips in the Final Cut Pro timeline. The Cinematic Editor shows automatic focus points as white dots and manual focus points as yellow dots with a ring around them.

clip The term used to describe a video or audio asset, especially after it has been imported into Final Cut Pro. Clips appear in the browser and the timeline. Clips in Final Cut Pro point to (link to) source media files stored on your Mac or a connected storage device. When you modify a clip, you’re not modifying the media file, just the clip’s information in Final Cut Pro. This is known as nondestructive editing.

clipping Distortion occurring during the playback or recording of digital audio because of a signal that exceeds the maximum sample value of 0 dBFS.

clip selection A selection of whole clips in the browser or the timeline. In contrast to a range selection, a clip selection is limited to clip boundaries. You can’t adjust a clip selection to include portions of clips. However, you can add or remove whole clips.

codec Short for compressor/decompressor, or encode/decode. A software component used to translate video or audio from its current form to the digital compressed form in which it is stored on a computer or storage device. DV, Photo JPEG, and Apple ProRes are common QuickTime video codecs.

color balance Refers to the mix of red, green, and blue in a clip. In Final Cut Pro, you can adjust the color balance of the highlights (bright areas), midtones, or shadows (dark areas) of your clip.

color bars A standard color test signal displayed as columns, often accompanied by a reference audio tone. Color bars are used to adjust the video signal of the incoming source to maintain proper color from import through output.

Color Board The Color Board allows you to manually adjust a clip’s color properties. It contains separate panes for adding or subtracting a color tint, controlling the intensity of the color, and controlling the brightness of the video. In addition to an overall control, each pane has individual controls for the highlight, midtone, and shadow areas of the image.

color cast An unwanted color tint in the image, usually caused by lighting issues.
color correction  A process in which the color of clips used in an edited program is evened out so that all shots in a given scene match. Color correction is generally one of the last steps in finishing an edited program. The color correction tools in Final Cut Pro give you precise control over the look of every clip in your project by allowing you to adjust the color balance, black levels, midtones, and white levels of individual clips.

color difference  In video formats that store color information in the Y’CbCr color space, color channels are derived by subtracting Y (luma) from the R (red) and B (blue) signals and are sometimes referred to generally as B-Y and R-Y. See also Y’CbCr.

Color inspector  You use the Color inspector to perform manual color corrections using the five color correction effects: Color Board, Color Wheels, Color Curves, Hue/Saturation Curves, and Color Adjustments.

compositing  A process in which two or more images are combined into a single frame. This term can also describe the process of creating various video effects.

compound clip  You can use compound clips to group any combination of clips in the timeline or the browser and nest clips within other clips. You can open any compound clip, edit its contents in the timeline, and then close it. Compound clips can contain video and audio clip components, clips, and other compound clips. Effectively, each compound clip can be considered a mini project, with its own distinct project settings. Compound clips function just like other clips: You can add them to your project, trim them, retime them, and add effects and transitions.

compression  The process by which video, graphics, and audio files are reduced in size. “Lossy” compression refers to a process of reducing video file sizes through the removal of redundant or less noticeable image data. Lossless compression reduces file sizes by mathematically consolidating redundant image data without discarding it.

connected clip  Connected clips are attached to clips in the primary storyline in the timeline. They’re useful for cutaway shots, superimposed or composited images, and sound effects. Connected clips remain attached and synced until you explicitly move or remove them. A sequence of connected clips is a storyline. See also cutaway shot.

contrast  The difference between the lightest and darkest values in an image. High-contrast images have a large range of values from the darkest shadow to the lightest highlight. Low-contrast images have a more narrow range of values, resulting in a “flatter” look.

corner point  A point with no curves applied in a Bezier path. Adjacent line segments are linear. See also Bezier curve.

cross dissolve  A common type of video transition, in which the first shot fades out while the second shot simultaneously fades in. During the cross dissolve, the two shots are superimposed as they fade.

crossfade  A common type of audio transition, in which the first shot’s audio fades down while the second shot’s audio simultaneously fades up. During the crossfade, audio from both shots is heard.

custom LUT effect  See LUT (lookup table).

cut  An edit in which one clip immediately follows another, with no transition effect. This is the simplest type of edit.
**cutaway shot**  A shot that is related to the current subject and occurs in the same time frame (for example, an interviewer’s reaction to what’s being said in an interview). Often, a cutaway shot is used to eliminate an unwanted visual section of another shot. The audio usually remains continuous during the cutaway, helping to make the edit less noticeable.

**data rate**  The speed at which data can be transferred, often described in megabytes per second (MB/sec.) or megabits per second (Mbps). The higher a video file’s data rate, the higher quality it is, but the more system resources (processor speed, storage space, and performance) it requires. Some codecs allow you to specify a maximum data rate for a movie during capture.

**decibel (dB)**  Unit of measurement for sound levels; a logarithmic scale used to describe the loudness of sound as perceived by the human ear. (1 dB corresponds approximately to the smallest volume change that the average human ear can perceive.) For digital audio, dBFS is the standard decibel unit of sound level measurement.

**depth of field**  The distance between the closest and farthest elements in a scene that appear “sharp” (in focus).

**destination**  A set of preconfigured export settings that you can use to share a project or clip from Final Cut Pro. Destinations make it easy to export your movie for viewing on Apple devices such as iPad and iPhone, add your movie to video-sharing websites, or burn your movie to a disc. Final Cut Pro comes with a variety of destinations, and you can also modify destinations and create new destinations. You add and modify destinations in the Destinations pane of Final Cut Pro settings.

**Disk Utility**  An Apple app that performs disk-related tasks in macOS. It’s located in the Utilities folder inside the Applications folder.

**downmixing**  The process used to combine multiple audio channels into a single stereo (or dual mono) pair. Also referred to as mixing down.

**downstream**  Refers to clips to the right of the current clip in the timeline. When you perform actions that ripple the project, downstream clips are affected; upstream clips are not. See also ripple edit, upstream.

**drop frame timecode**  NTSC timecode that skips ahead in time by two frame numbers each minute, except every tenth minute, so that the timecode agrees with the actual elapsed clock time. (Timecode numbers are skipped, but actual video frames are not skipped.) This skipping corrects for NTSC’s actual frame rate of 29.97 fps, which causes non-drop frame timecode to lag behind actual elapsed time by 3 seconds and 18 frames per hour. To avoid confusion, drop frame timecode should be avoided in film-based productions. See also non-drop frame timecode.

**drop shadow**  An effect that creates an artificial shadow behind an image. Typically used with graphics and text.

**DV**  A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1 compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). DV supports two tracks of audio with 16-bit, 48 kHz audio sampling, or four tracks of audio with 12-bit, 32 kHz audio sampling.

**DVCAM**  A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1 compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). DVCAM supports two tracks of audio with 16-bit, 48 kHz audio sampling, or four tracks of audio with 12-bit, 32 kHz audio sampling.
DVCPRO  A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1 compressed component video signal using 4:1:1 color sampling (PAL uses 4:2:0). DVCPRO supports two tracks of audio with 16-bit, 48 kHz audio sampling.

DVCPRO50  A standard-definition (SD) digital videotape recorder format that records an 8-bit, 3.3:1 compressed component video signal with 4:2:2 color sampling. DVCPRO50 supports four tracks of audio with 16-bit, 48 kHz audio sampling.

DVCPRO HD  A high-definition (HD) video format that records an 8-bit, compressed component video signal with 4:2:2 color sampling. Both 720p and 1080i are supported. DVCPRO HD includes up to eight tracks of audio with 16-bit, 48 kHz audio sampling. The total data rate is 115 Mbps.

DVD  A disc that is the size of a CD but that uses higher-density storage methods to significantly increase its capacity. Although usually used for video distribution, DVD-ROM discs can also be used to store computer data.

dynamic range  The difference, in decibels, between the loudest and softest parts of a recording.

ease in  An effect in which an object in motion decelerates slowly until it comes to a stop, rather than ending its movement abruptly. This simulates the effect of friction in the real world and generally creates a more natural, organic-looking effect than a linear movement would.

ease out  An effect in which an object in motion accelerates from its starting position slowly rather than beginning its movement at full speed. This simulates the effect of inertia and friction in the real world and generally creates a more natural, organic-looking effect than a linear movement would.

editing tools  A group of seven tools you can use when working in the timeline: Select tool, Trim tool, Position tool, Range Selection tool, Blade tool, Zoom tool, and Hand tool. When you choose a tool, the pointer changes to the icon for that tool.

edit point  Edit points define the part of a clip you want to use in an edited project. Edit points include start points, which specify the beginning of a section of a clip or project, and end points, which specify the end of a section of a clip or project. An edit point is also a point in the timeline where the end point of one clip meets the start point of the next clip. This edit point can be selected for various operations.

Effects browser  A media browser in Final Cut Pro that contains video and audio clip effects.

embedded captions  CEA-608 captions that are included in the output media file. Viewers can turn embedded captions on or off while watching TV shows, movies, web videos, and other programs. In contrast, titles and burned-in captions are always permanently visible in the output media file.

equalization  An equalizer (commonly abbreviated as EQ) shapes the sound of incoming audio by changing the level of specific frequency bands. Equalization is one of the most commonly used audio processes, both for music projects and in video post-production work. You can use EQ to subtly or significantly shape the sound of an audio file, instrument, or project by adjusting specific frequencies or frequency ranges.

equirectangular projection  A display of 360° video that shows all parts of a three-dimensional sphere flattened in a video frame, similar to world maps that depict the globe as a two-dimensional rectangle.
**event** When you import video, audio, and still images, or record directly into Final Cut Pro, the source media files (your raw footage) are stored in events. An event is similar to a folder that can hold dozens, hundreds, or even thousands of video clips, audio clips, and still images, as well as projects. Each event in the library refers to media on your Mac or a storage device, and a database file keeps track of where everything is.

**event viewer** A separate video display that appears next to the main viewer and is used to play clips from the browser only.

**exposure** The amount of light in video or film images. Exposure affects the overall brightness of the image as well as its perceived contrast.

**fade** A common type of transition in both video and audio. For video, a fade-out begins with a shot at full intensity and reduces until it is gone. A fade-in begins with a shot at no intensity and increases to full intensity. These are the common "fade to black" and "fade up (from black)" transitions. Audio fade-ins begin with silence and increase to full volume, and fade-outs begin at full volume and decrease to silence.

**filmstrip** Your video clips appear as filmstrips in the timeline (where you build projects) and in the browser (where your source clips are displayed). A single video filmstrip might represent several seconds of video encompassing hundreds of video frames (individual images). Audio-only clips appear as audio waveforms, showing the change in the audio volume over time.

**FireWire** The trademarked Apple name for the IEEE 1394 standard. A fast and versatile interface used to connect DV camcorders to computers. FireWire is well suited to applications that move large amounts of data, and it can also be used to connect external storage devices, scanners, and other kinds of computer peripherals. See also Thunderbolt.

**Foley effects** Custom sound effects that are heavily synced to picture, such as footsteps on different surfaces, clothes rustling, fight sounds, and the handling of various noisy objects. Final Cut Pro includes a number of built-in Foley and other sound effects that you can insert as connected audio clips. See also connected clip.

**frame** A single still image. Film and video are made up of a series of these images. Although a film frame is a single photographic image, an interlaced video frame contains two fields. See also interlaced video, non-interlaced video.

**frame blending** Duplicating frames to create slow motion can result in a strobing, jittery effect. To minimize this, you can turn on Frame Blending in the Retime pop-up menu below the viewer. Frame blending creates new in-between frames, each a composite of two neighboring frames.

**frame rate** The number of images photographed per second for a video clip.

**frame size** See resolution.

**frequency** The number of times a sound or signal vibrates each second, measured in cycles per second, or hertz (Hz). Audio recordings are made up of a vast collection of waveforms, using many different frequencies of sound. Each frequency in a recording is associated with an audio pitch. For example, the note generated by each key of a piano has a specific frequency. See also pitch.

**gain** The amount an audio or video signal is boosted. In video, this increases the white level; in audio, this increases the volume.
**gamma** A curve that describes the intensity of an image. Gamma is a nonlinear function often confused with brightness or contrast. Gamma adjustment is often used to compensate for differences between Mac and Windows video graphics cards and displays.

**gamut** The *gamut* of a particular display device represents the total range of colors that can be displayed on that device. Some types of displays are capable of displaying a greater range of colors than others. Furthermore, different video and film standards specify different color gamuts; colors that may be easily represented by one imaging medium are out of bounds for another.

**gap clip** A blank clip (containing blank video and silent audio) that you can adjust to any duration. (The film industry term for this is *slug.*) Gap clip color is determined by the current background color in Final Cut Pro. You can adjust the background color using the Player Background pop-up menu in the Playback pane of Final Cut Pro settings.

**generators** Clips that are synthesized by Final Cut Pro. Generators can be used as different kinds of backgrounds, titles, and elements for visual design.

**Hand tool** The editing tool that allows you to scroll in the timeline. You can select the Hand tool by pressing the H key.

**H.264** H.264/MPEG-4 Part 10 or AVC (Advanced Video Coding) is a video compression standard in widespread use for recording, distribution, and internet streaming of high-definition (HD) video.

**HDCAM** A high-definition (HD) digital videotape recorder format that records an 8-bit, 7:1:1 DCT-compressed component video signal with 3:1:1 color sampling. HDCAM supports four tracks of audio and is recorded using 1/2-inch tape.

**HDV** A format for recording high-definition (HD) video on DV tape. HDV uses MPEG-2 video compression with 8-bit samples and 4:2:0 chroma subsampling. HDV has a video bit rate of 18.3 Mbps for 720p (1280 x 720) and a bit rate of 25 Mbps for 1080i (1440 x 1080).

**HEIF (High Efficiency Image File Format)** A container format for storing still images and image sequences, defined by MPEG-H Part 12 (ISO/IEC 23008-12). HEIF was developed by the Moving Picture Experts Group (MPEG) and can store images encoded using the HEVC (High Efficiency Video Coding) compression standard.

**HEVC (High Efficiency Video Coding)** A video compression standard; also known as *H.265* and MPEG-H Part 2.

**high-definition (HD)** Refers to video with a higher resolution than standard-definition (SD) NTSC or PAL video. The most common HD resolutions are 1280 x 720 (720p) and 1920 x 1080 (1080i or 1080p). See also NTSC format, PAL format, standard-definition (SD), ultra-high-definition (UHD).

**high dynamic range (HDR)** High-dynamic-range (HDR) images have a greater range of luminance (extra levels of brightness) than do standard-dynamic-range (SDR) images. HDR can represent luminances as high as 10,000 nits (candelas per square meter) with a dynamic range of 14 stops or more, creating more realistic color transitions and revealing more detail in both shadows and highlights.

**histogram** A video scope in Final Cut Pro that provides a statistical analysis of the image by graphing the number of pixels at each percentage of luma or color. It’s useful for comparing two clips in order to match their brightness values more closely. See also luma.
HLG (Hybrid Log-Gamma)  One of the two supported systems in the ITU-R Rec. 2100 standard for high-dynamic-range (HDR) video. The HLG transfer function relates image signal values to scene-relative light levels and is compatible with standard-dynamic-range (SDR) displays without the need for metadata. HLG was developed by the BBC and NHK broadcasting networks.

**hue**  An attribute of color perception, also known as color phase. Red, blue, yellow, and green are all hues.

**import** The process of bringing media files of various types into events in Final Cut Pro. You can import files from connected camcorders and other devices, other apps, or connected storage devices. See also event, source media files.

**IMX** A standard-definition (SD), all-I-frame MPEG-2 format stored on tape, XDCAM optical disc, or storage device. Some IMX decks can play back and convert formats such as Digital Betacam, Betacam SX, and Betacam SP to IMX. The data rate of IMX can be set to 30, 40, or 50 Mbps.

**incoming clip** The clip to which a transition segues. For example, if clip A dissolves to clip B, clip B is the incoming clip. See also outgoing clip.

**Info inspector** A Final Cut Pro inspector that displays information (called metadata) about a clip or group of clips selected in either the browser or the timeline. You can display different combinations of metadata with your clips, such as codecs, media start and end times, reel, scene, take, EXIF information, and IPTC information. You can also use the Info inspector to change the metadata for a selected clip or group of clips, and you can create custom sets of metadata for display using the Metadata Views window, accessed from the Info inspector. You also use the Info inspector to display and access project settings. See also inspectors.

**In point**  See edit point.

**insert edit** A type of edit that places the source clip so that all clips after the insertion point are moved forward (or rippled) in the timeline to make room for the clip being added. No clips are removed from your project. An insert edit makes the project longer by the duration of the inserted clip.

**inspectors** Final Cut Pro provides a number of inspectors you can use to view and change the attributes of selected items. For example, you can adjust video effects in the Video inspector. Other inspectors include the Audio, Info, Transition, Title, Text, Generator, Library Properties, and Share inspectors. The inspectors appear in the top-right corner of the Final Cut Pro window.

**interlaced video** A scanning method that divides a video frame into two fields, each consisting of alternating odd and even lines that are scanned at different times.

**IRE** An analog video signal unit of measurement for luma, established by the Institute of Radio Engineers. See also luma.

**iTT (iTunes Timed Text)** A format for delivering caption content to the iTunes Store. The iTT caption standard features formatting, color, and placement options, including a wider range of alphabets, making it the best choice for languages with non-Roman characters. iTT captions can be imported or exported as separate files. iTT caption files have the filename extension .itt.

**J-cut**  See split edit.
job Each media file added to a batch in Compressor is a job. Each job has one media file and one or more settings that define the type of file to render. See also batch, source media files.

JPEG A popular image file format that lets you create highly compressed graphics files. The amount of compression used can vary. Less compression results in a higher-quality image.

keyframe A control that denotes the value of a video or audio effect parameter at a particular point in the project. When two keyframes with different values are set in Final Cut Pro, a transition from one value to another is calculated, resulting in a dynamic change to that parameter. The word keyframe comes from the traditional workflow in the animation industry, where only important (key) frames of an animated sequence were drawn to sketch a character’s motion over time. After the keyframes were determined, an in-between artist drew all the frames between the keyframes.

keying See chroma key, luma key.

Keyword Collection When you apply a keyword to a clip, a Keyword Collection is automatically created in the event in the library. When you select the Keyword Collection, each clip tagged with that keyword is displayed in the browser. See also event, keywords.

keywords Keywords add descriptive information to a clip or clip range. You can use keywords to organize, sort, and classify media. You can add keywords to a clip manually, and Final Cut Pro can also add keywords automatically during import or clip analysis. See also Keyword Collection.

L-cut See split edit.

Libraries sidebar The pane in the Final Cut Pro sidebar that lists the libraries and events that contain your imported media (video, audio, and still images) and your projects. When you select an event or a library in the Libraries sidebar, its media appears as clips in the browser, and its projects appear as thumbnails. The Libraries sidebar is also the home for Final Cut Pro Keyword Collections and Smart Collections, which provide a powerful way to organize your media using keywords and persistent search filters. See also event, Keyword Collection, Smart Collection.

linear editing Before digital video editing, programs were edited together by copying shots from the original source tapes to a program tape, one by one. Because the assembly was linear, any changes in duration made to an earlier point of the tape required reassembling the movie from that point forward. See also nonlinear editing.

log (logarithmic) recording A method of encoding video that preserves shadow and highlight details. A log recording takes the dynamic range (exposure range) of the source image and maps it across a logarithmic curve. This allows you to flexibly manipulate the shadows and highlights in post-production. A log recording looks flat, desaturated, and lacking in contrast. But when you apply a LUT or make manual color corrections, the video reflects the natural vibrancy and contrast of the original scene. See also LUT (lookup table).

looping A playback mode in which clips and projects go back to the beginning whenever the playhead reaches the end of the media. You can turn looping on or off from the View menu or by pressing Command-L.
**lower third** A television industry term for a graphic placed in the lower area of the screen, usually to convey details about subjects or products. A common use of lower thirds is to identify individuals on the screen with their names and job titles.

**luma** A value describing the brightness of a video image. A luma channel is a grayscale image showing the range of brightness across the whole clip.

**luma key** An effect used to key out pixels of a certain luma value (or a range of luma values), creating a matte based on the brightest or darkest area of an image. Keying out luma values works best when your clip has a large discrepancy in exposure between the areas that you want to key out and the foreground images you want to preserve—for example, a white title on a black background. See also chroma key, matte.

**luminance** An objective measurement of light corresponding to intensity weighted by the spectral sensitivity of human vision. Luminance is measured in candelas per square meter (cd/m²), often referred to as nits.

**LUT (lookup table)** A set of data that enables a numeric transformation of pixel values to change the way an image looks. Final Cut Pro works with two types of LUTs: camera LUTs and custom LUT effects. Camera LUTs (also known as camera log conversion LUTs) built into Final Cut Pro provide log processing for media from video cameras that have a log recording option. When you import media, Final Cut Pro detects metadata in the media identifying the log format and automatically applies the appropriate camera LUT. In contrast, custom LUT effects are clip effects that can be applied to timeline clips at any position in the effect order. You can purchase or create LUT effects and use them to stylize footage with custom looks. See also log (logarithmic) recording.

**markers** Markers flag a specific location in a clip with editing notes or other descriptive information. You can also use markers for task management. Markers are classified as standard markers (blue), chapter markers (orange), to-do items (red), or completed to-do items (green).

**mask** An image or a clip used to define areas of transparency in another clip. Similar to an alpha channel. You can create masks based on a color you choose or a shape you create. See also alpha channel.

**mastering** The process of creating a high-quality final copy of a completed project, which serves as the source media for the final stages of professional post-production or broadcast and distribution.

**matte** Sometimes referred to as a holdout matte. An effect that uses information in one layer of video to affect another layer. Mattes are useful when you want to use one clip to selectively hide or reveal part of another; for example, you could use a round spotlight shape to reveal parts of a video layer. Matte effects can be used by themselves to mask out areas of a clip or to create alpha channel information for a clip—for example, to make a transparent border around the clip that can be composited against other layers. See also alpha channel, compositing.

**media** A generic term for elements such as movies, sounds, and pictures.

**media handle** Additional media available before the start point or after the end point of a clip in the timeline.
media representation  In Final Cut Pro, a type of media file corresponding to a video clip. Final Cut Pro allows for three types of media representations—original source video files, optimized copies transcoded to the Apple ProRes 422 format, and proxy copies transcoded to the Apple ProRes 422 Proxy or H.264 format. You can choose to edit with optimized or proxy media to increase playback performance. See also optimized files, proxy files, source media files.

media stems  Audio or video files that are usually exported separately for audio mixing or post-production, or to match specifications when delivering files to broadcast networks. For example, you may need to deliver a multitrack QuickTime file along with separate dialogue, music, and effects stems.

mixing  The process of adjusting the audio levels of all audio clips in an edited program, including the production audio, music, sound effects, voiceovers, and additional background ambience, to turn all of these sounds into a harmonious whole.

monochrome  An image presented in shades of a single color, most often as the shades of gray in a black-and-white image.

monoscopic  A 360° video file that uses a single projection. This is a flat (two-dimensional) rendering that can be viewed on any screen. You can navigate monoscopic 360° video in any direction, but there's no real depth perception; viewing monoscopic video is like looking around with only one eye open.

MP3  Refers to the MPEG-1 or MPEG-2 Audio Layer 3 compression standard and file format. Like AAC, MP3 uses perceptual audio coding and psychoacoustic compression to remove superfluous information that the human ear doesn't hear.

MPEG (Moving Picture Experts Group)  A group of compression standards for video and audio, which includes MPEG-1, MPEG-2, and MPEG-4.

multicam clip  A set of clips grouped together and synced by a common sync point. You can use multicam clips to edit footage from multicamera shoots or other synced footage in real time. While the active angle plays in the viewer, you can also view all angles playing simultaneously in the angle viewer and easily cut and switch between them.

MXF  An industry-standard file format for video and audio. Like QuickTime files, MXF files contain information about the media inside. This information, also called metadata, can include frame rate, frame size, creation date, and custom data created by a camera operator, assistant, or archivist. See also frame rate, resolution.

nested sequence  See compound clip.

NLE  Short for nonlinear editor. See also nonlinear editing.

nondestructive editing  No matter how you edit clips in Final Cut Pro, the underlying media is never touched. This is known as nondestructive editing, because none of the changes and effects you apply to your footage affect the original source media files. Clips represent your media, but they are not the media files themselves. The clips in a project simply point to (link to) the source media files on your Mac or storage device. When you modify a clip, you're not modifying the media file, just the clip's information in the project. Trimmed or deleted pieces of clips are removed from your project only, not from the clips in your library or from the source media files on your Mac or storage device.
**non-drop frame timecode**  Timecode in which frames are numbered sequentially and no timecode numbers are dropped from the count. In the case of NTSC video, the video frame rate is actually 29.97 fps, and non-drop frame timecode is off by 3 seconds and 18 frames per hour in comparison to actual elapsed time. See also drop frame timecode, NTSC format.

**non-interlaced video**  The standard representation of images on a computer. Also referred to as progressive scan. The monitor displays the image by drawing lines, one after another, from top to bottom.

**nonlinear editing**  A video editing method that allows you to change the edits within a program without having to re-create the entire program. When you use a nonlinear editing application to edit a program, all footage used is stored on a computer or storage device rather than on tape. This allows random access to all video, audio, and images as you edit. See also linear editing.

**NTSC format**  The video standard defined by the National Television Standards Committee, the organization that originally defined North American broadcast standards. Analog NTSC video has 525 interlaced lines per frame, a frame rate of 29.97 fps, and a limited color gamut. Digital NTSC video has a frame size of 720 x 486 pixels (720 x 480 for DV and DVD), and a frame rate of 29.97 fps. See also PAL format.

**offline editing**  A post-production process in which raw footage is copied and edited without affecting the original camera media (film, tape, or file-based media). After a program has been completed in the offline edit (typically using proxy media at a lower resolution), an online edit is performed to re-create the edit using the original media.

**opacity**  The level of a clip’s transparency.

**optimized files**  You can use Final Cut Pro to transcode your original media to create optimized files in the Apple ProRes 422 format, which provides better performance during editing, faster render times, and better color quality for compositing. See also Apple ProRes 422, media representation.

**outgoing clip**  The clip a transition segues from. For example, if clip A dissolves to clip B, clip A is the outgoing clip. See also incoming clip.

**Out point**  See edit point.

**overwrite edit**  In an overwrite edit, one or more source clips overwrite any clips in the primary storyline or a selected storyline, starting at a range selection start point or at the skimmer or playhead position. No clip items are rippled forward, so the duration of your project remains the same. Overwriting is purely duration-based and works on range selections only, irrespective of clip boundaries. See also range, storylines.

**PAL format**  Acronym for Phase Alternating Line, a 25 fps (625 lines per frame) interlaced video format used by many European countries. Digital PAL video has a frame size of 720 x 576. See also NTSC format.

**parallax**  The difference between the horizontal positions of the two cameras, or eyes, in stereoscopic 360° media. See also stereoscopic.

**Photos, Videos, and Audio sidebar**  A pane in the Final Cut Pro sidebar that provides access to your photo, video, and audio collections. When you select an item in the sidebar (such as an album in Photos or a category of sound effects), the item’s contents are displayed in the browser. The media libraries that appear depend on which apps and version of macOS you’re using.
**pitch** Sounds are perceived as high or low depending on their frequency, or the number of times per second a sound wave cycles from positive to negative and back to positive. The word that musicians most commonly use for frequency is *pitch*. The higher the frequency, the higher the pitch. Modifying the speed of a clip affects the pitch of the audio. Slow motion creates low pitch, and fast motion creates high pitch.

**pixel** One dot in a video or still image. The more pixels in an image, the higher the resolution. See also *resolution*.

**playhead** A gray vertical line that marks the current position in a project in the timeline or a clip in the browser. You can move the playhead by dragging it or clicking another area of the timeline or browser. You use the playhead to *scrub*, or move through your project and play it back from different locations. The playhead is fixed in place unless you move it or click elsewhere. See also *skimmer*.

**Position tool** The editing tool that allows you to place items in the timeline. You can select the Position tool by pressing the P key.

**post-production** The phase of film or video editing in which all of the production elements are organized, assembled, and output.

**PQ (Perceptual Quantizer)** A high-dynamic-range (HDR) transfer function that relates image signal values to absolute light levels produced by a display. PQ is standardized in SMPTE ST 2084 and is one of the two supported transfer functions in the ITU-R Rec. 2100 standard for HDR video. PQ is used in formats such as HDR10, HDR10+, and Dolby Vision.

**project** A project provides a record of your editing decisions and the media you use. You build your project by adding clips and editing them in the timeline. A project is also defined by its video, audio, and rendering properties. In most cases, Final Cut Pro manages project settings automatically based on the properties of the first clip you add to a project.

**project properties** A project's video, audio, and rendering properties. In most cases, Final Cut Pro manages a project's properties automatically based on the properties of the first clip you add to a project. If you must modify the project properties, choose video and audio project properties based on how you intend to share your final movie with your audience.

**proxy files** You can use Final Cut Pro to transcode your original media to create proxy files, which are smaller files with a lower data rate. Proxy files can be used for offline editing or for editing when using a slower computer. Final Cut Pro creates video proxy files using either the Apple ProRes 422 Proxy or H.264 format. You can create proxy media in a variety of frame sizes from 12.5 percent to 100 percent of the original. See also *Apple ProRes 422 Proxy, H.264, media representation*.

**QuickTime** Cross-platform multimedia technology from Apple. Widely used for production, post-production, and distribution of video, audio, and interactive programs.

**rack focus** A commonly used technique in film and television that involves shifting the focus between the foreground, middle ground, and background elements of a shot.

**range** Instead of selecting whole clips, you can select a range within any clip in the timeline or the browser. You can trim range selections, mark them with ratings and keywords, and modify them in other ways. You can adjust the range start and end points by dragging either side of the selection. In the timeline, you can also select a range that spans multiple clips. In the browser, you can set multiple ranges within one or more clips, and you can select and deselect ranges after you set them.
Range Selection tool  The editing tool that allows you to select a range in the timeline. You can select the Range Selection tool by pressing the R key.

Rec. 2020  Short for *Rec. ITU-R Recommendation BT.2020*, a color space standard with a very large gamut (range of color).

Rec. 709  Short for *ITU-R Recommendation BT.709*, the standard broadcast format for high-definition (HD) television.

rectilinear  A standard video file, as opposed to a spherical 360° video file that has equirectangular projection (showing all parts of a three-dimensional sphere flattened in a video frame, similar to world maps that depict the globe as a two-dimensional rectangle).

red laser media  Traditional DVD burners and players use a red laser when working with DVD media. Blu-ray burners and players use a blue laser when working with Blu-ray media. The blue laser has a shorter wavelength, making it possible to store more data on a disc. See also blue laser media.

render  To process video and audio with any applied effects or transitions, and store the result on your Mac or storage device as a render file. These render files are stored with your Final Cut Pro event and project files. When you publish or export a project, it’s also rendered to create the output files.

replace edit  In a replace edit, a source selection replaces a clip in your project in the timeline. In contrast to overwrite edits, replacing works on whole timeline clips only and can change the duration of your project.

resolution  Also referred to as *frame size*. Refers to the number of pixels in an image. Resolution is expressed in terms of the width and height of the image in pixels (for example, 640 x 360 pixels). Higher-resolution images contain more detail but also create larger files that take longer to download. Your electronic devices (computer, iPhone, iPad, iPod, and so on) also have screen resolution. Ideally, you should match the image resolution of your media to the resolution of your playback device.

reverb  Reverberation, or *reverb*, refers to the reflection pattern created by sound waves bouncing off the surfaces—walls, ceilings, windows, and so on—of any space, or off objects within a space, gradually dying out until they’re inaudible. Final Cut Pro includes a variety of audio effects that add reverb to the sound of a clip.

RF64  An extension to the WAV file format that allows for files larger than 4 GB.

RGB  Abbreviation for *Red, Green, Blue*. A color space commonly used on computers, in which each color is described by the strength of its red, green, and blue components. This color space directly translates to the red, green, and blue phosphors used in computer displays. The RGB color space has a very large gamut, meaning it can reproduce a very wide range of colors. This range is typically larger than the range that can be reproduced for broadcast.

ripple edit  The default type of trim in Final Cut Pro is a *ripple edit* (also called a *ripple trim*), which adjusts a clip’s start point or end point without leaving a gap in the timeline. The change in the clip’s duration ripples outward, moving all subsequent clips earlier or later in the timeline. Similarly, if you delete a clip from the timeline, subsequent clips ripple earlier to close the gap. Ripple edits affect the trimmed clip, the position of all subsequent clips in the timeline, and the total duration of your project.
**roles** Metadata text and color labels that you assign to clips in the browser or the timeline. Roles provide a flexible and powerful way to manage your editing workflow. You can use roles in Final Cut Pro to organize clips in your events and projects, control the appearance of the timeline, and export separate video or audio files (also known as *media stems*) for broadcast delivery, audio mixing, or post-production. Roles have distinct colors that let you instantly recognize clips with a particular role in the browser and the timeline.

**roll edit** An edit that affects two clips that share an edit point. For example, if clip A cuts to clip B, a roll edit simultaneously adjusts the end point of clip A and the start point of clip B by the same amount. The overall duration of the project stays the same.

**rough edit** The first editing pass. The rough cut is an early version of a movie that pulls together its basic elements. Often, a rough edit is performed prior to adding transitions, titles, and other effects.

**saturation** A measurement of the intensity of color in the video signal.

**scene** A series of shots that take place at the same time and in the same location. A series of scenes make up a program.

**Select tool** The default arrow-shaped pointer that allows you to select items in the timeline. For example, you use it to select a clip or edit point. You can select the Select tool by pressing the A key.

**sequence** See *project*, *timeline*.

**shortcut menu** A menu you access by holding down the Control key and clicking an item on the screen, or by pressing the right mouse button. Sometimes called a *contextual menu*.

**shot** A segment of continuously recorded video. A shot is the smallest unit of a program.

**sidebar** The sidebar appears to the left of the browser and contains three panes for selecting different types of media: the Libraries sidebar, the Photos, Videos, and Audio sidebar, and the Titles and Generators sidebar. When you select an item in a sidebar pane (such as an event containing clips, or a category of sound effects or 3D titles), its contents are displayed in the browser. You can show or hide any of the sidebars.

**skimmer** A red vertical line that appears as you move the pointer over clips in the browser and timeline to preview them. You use the skimmer to *skim*, or freely move over clips to play them back at the position and speed of the pointer. You can skim clips without affecting the playhead position. If you have snapping turned on, the skimmer turns orange when it snaps to a position. See also *playhead*, *snapping*.

**slate** A shot at the beginning of a scene that identifies the scene with basic production information such as the take, date, and scene number. A clapper provides an audiovisual cue for syncing when video and audio are recorded separately.

**slide edit** An edit in which an entire clip is moved, along with the edit points on its left and right. The duration of the clip being moved stays the same, but the clips to the left and right of it change in length to accommodate the new position of the clip. The overall duration of the project and of these three clips remains the same.

**slip edit** An edit in which the location of both the start and end points of a project clip are changed at the same time, without changing the position or duration of the clip. This is referred to as *slipping*, because you slip the clip's start and end points inside the available footage. The portion of the clip seen in the project changes, but its position in the timeline stays the same.
**Smart Collection**  When you search for clips in an event using the Filter window, you can save your results by creating a new Smart Collection that gathers clips matching the search criteria. Whenever a new clip that matches the Smart Collection’s search criteria is brought into the event, the new clip is automatically added to the Smart Collection. Clips that appear in Smart Collections are not duplicates. Smart Collections filter clips in an event to help you focus on the clips you need to use for a specific task. See also event.

**snapping**  When snapping is turned on in Final Cut Pro, items you move in the timeline (including the playhead, the skimmer, and selected clips) appear to jump, or “snap,” directly to certain points in the timeline. This can help you quickly line up edits with other items in the project. Snapping affects the functions of many of the editing tools in Final Cut Pro, including the Select tool, the Trim tool, the Position tool, the Range Selection tool, and the Blade tool. You can disable snapping when frame-by-frame precision editing is required.

**sound effects**  Specific audio material, such as the sound of a door closing or a dog barking, from effects libraries or from clips you recorded. Sound effects can be used to replace sounds in the location audio of a program, or to add sound that wasn’t originally recorded. Over 1300 royalty-free sound effects are included with Final Cut Pro as a separate download.

**source media files**  The original files (video, audio, and still images or graphics) that you import into Final Cut Pro. A clip you use in Final Cut Pro points to the location where the source media file is stored (either on your Mac, a storage device, or a camcorder, camera, or device). Changes made to clips within Final Cut Pro do not affect the source media files.

**special effects**  Visual effects applied to clips and projects, such as motion, compositing, keying, and retiming effects.

**spill suppression**  A color correction operation that neutralizes any green or blue fringing or light bounce that’s tinting the subject being keyed. Spill suppression works by applying the complementary (opposite) color of the color that’s being made transparent.

**split edit**  Final Cut Pro allows you to set separate video and audio start and end points in an individual clip. These edits, known as split edits, are a common technique in most dialogue scenes in films and television shows. You can use split edits to introduce the sound of a new shot or scene before cutting to the video of that shot or scene. Conversely, you can use a split edit to extend the audio of a shot over a subsequent shot.

**SRT (SubRip Text)**  A subtitle format supported by Facebook, YouTube, and Vimeo. The SRT format is simple: Each caption has a number, a start and end timecode (in decimal timecode), and one or more lines of text. SRT captions can be imported or exported as separate files. Unlike captions in other formats, exported SRT captions can be read and edited in a plain text editor. SRT caption files have the filename extension .srt.

**standard-definition (SD)**  Refers to the original NTSC and PAL video frame sizes. NTSC uses 480 or 486 active lines per frame, and PAL uses 576 active lines. See also high-definition (HD).

**standard dynamic range (SDR)**  The conventional technique for processing luminance (brightness) and color values in images, developed in the mid-1900s, with a nominal maximum brightness of 100 nits (candels per square meter) and a dynamic range of 6 to 10 stops. Some newer imaging devices can display high-dynamic-range (HDR) images, representing a much wider range of brightness levels.
**stereo** Short for *stereophonic*, which describes audio that contains two different channels. Audio level changes are automatically made to both channels at the same time.

**stereoscopic** A 360° video file that is split into two views designated for the left and right eyes. This type of video is designed to be viewed through a special headset or glasses that can project each of the two views into the appropriate eye. Stereoscopic video simulates the depth perception (in three dimensions) that people experience in the real world when they have two eyes open.

**storylines** All instances of the timeline contain a primary storyline, which is the main sequence of clips you build to create your movie. Storylines are sequences of clips connected to the primary storyline. You can use storylines for the same purposes as connected clips (such as creating cutaways, compositing titles and other graphics, and adding sound effects and music). See also *compositing*, *cutaway shot*.

**straight cut** A cut in which both the video and audio clip items are cut at the same time.

**subframe** A subframe has 1/80 the duration of a video frame and is thus a more precise unit of reference when editing audio at the sample level.

**sync (synchronization)** The relationship between the image of a sound being made in a video clip (for example, a person talking) and the corresponding sound in an audio clip. Maintaining audio sync is critical when editing dialogue. In Final Cut Pro, connected clips and compound clips help maintain sync in your program. See also *compound clip*, *connected clip*.

**Thunderbolt** I/O technology that supports high-resolution displays and high-performance data devices through a single, compact port.

**three-point editing** An editing technique in which three out of four edit points are set in a source selection and a project. When the edit is performed, the fourth edit point is calculated automatically in Final Cut Pro. See also *edit point*.

**through edit** An edit point in which the video or audio content on either side of the edit is continuous. See also *edit point*.

**TIFF (Tagged Image File Format)** A widely used bitmapped graphics file format, developed by Aldus and Microsoft, that handles monochrome, grayscale 8- and 24-bit color. TIFF supports alpha channels. See also *alpha channel*.

**timecode** A signal recorded with your video that uniquely identifies each frame. By default, timecode appears in Final Cut Pro in the format hours: minutes: seconds: frames. Timecode supports a variety of functions in Final Cut Pro, including timeline playback, syncing video and audio clip items, navigating through projects in the timeline, and moving and trimming clips.

**timeline** The bottom portion of the Final Cut Pro window contains the timeline, where you create your movie project by adding and arranging clips and making all your edits.

**timeline index** You can view a text-based, chronological list of the clips, keywords, and markers in a project using the timeline index. When you select an item in the timeline index, the playhead jumps to that item in the timeline. You can also use the Roles pane of the timeline index to organize clips in the timeline by role. See also *keywords*, *markers*, *roles*.

**tint** A color shade added to an image, usually to create an effect. For example, adding a sepia tone creates the effect of old photos or film footage.
Titles and Generators sidebar A pane in the Final Cut Pro sidebar that provides access to all the title effects and video generators included with Final Cut Pro. When you select an item in the sidebar (such as a category of 3D titles), the item's contents are displayed in the browser.

toolbar The bar at the top of the Final Cut Pro window with buttons and tools for common tasks such as showing or hiding the main areas of Final Cut Pro and sharing your project.

Tracking Editor You can show the Tracking Editor for clips in the timeline to add or remove keyframes in a motion track.

transcode To convert a media file to a different format (such as DV, H.264, or MPEG-2) or change its properties (such as video frame size and frame rate, data rate, and audio sample rate). Compressor, an Apple app designed to work with Final Cut Pro, makes transcoding media files a fast and easy process.

transitions Effects that are applied to edit points to smooth out the change from one clip to the next. In Final Cut Pro, you can choose from a variety of video transitions, such as a dissolves or wipes, or you can add an audio crossfade between audio clips.

Transitions browser A media browser in Final Cut Pro that provides access to all the video transitions included with Final Cut Pro.

trim After you've assembled your clips in rough chronological order in the timeline, you begin to fine-tune the cut points (or edit points) between clips. Any time you make a clip in a project longer or shorter, you're trimming that clip. In Final Cut Pro, you can use a variety of techniques to trim timeline clips and edit points, including ripple edits, roll edits, slip edits, and slide edits.

Trim tool The editing tool that allows you to trim items in the timeline. You can select the Trim tool by pressing the T key.

ultra-high-definition (UHD) Refers to video with a minimum resolution of 3840 x 2160 pixels. See also high-definition (HD).

uncompressed 8- and 10-bit 4:2:2 Video formats that can be used to store 8-bit or 10-bit 4:2:2 Y’CbCr video without employing data compression. Bypassing compression reduces the computer’s processing load but increases the data rate considerably. A large-capacity RAID storage system is typically required to work effectively with uncompressed video. In many cases, Apple ProRes is a better choice. The data rate of uncompressed 4:2:2 video varies according to frame size and frame rate. As an example, at a frame size of 1920 x 1080 and a frame rate of 29.97 fps, the data rate is 1.0 Gbps for uncompressed 8-bit 4:2:2 video and 1.3 Gbps for uncompressed 10-bit 4:2:2 video.

upstream Refers to clips that are to the left of the current clip in the timeline. When you perform actions that ripple the project, upstream clips are not affected. See also downstream, ripple edit.

value slider A type of numerical slider control that appears as a number, often to the right of a basic slider. There are two ways to adjust a value slider: by dragging over the number to decrease or increase the parameter value, or by double-clicking the number and entering a new value.

variable speed Speed that varies dynamically, in forward or reverse motion, in a single clip.
VCR Abbreviation for videocassette recorder. Generally refers to consumer equipment used for recording video from various sources. Sometimes referred to as a VTR. See also VTR.

Vectorscope A video scope in Final Cut Pro that shows the distribution of color in your image on a circular scale. The vectorscope is useful for comparing the hue and intensity of colors between two clips for the purposes of color correction. See also hue.

Video Animation editor You can show the Video Animation editor for clips in the timeline to adjust effect parameters, create fade-ins or fade-outs, or change effects over time using keyframes. See also Audio Animation editor, keyframe.

Viewer When you play clips selected in the browser and the timeline, they appear in the viewer.

VTR Abbreviation for videotape recorder. Generally refers to professional equipment used for recording video from various sources.

Watermark A visible graphic or text overlay applied to an image or video clip to indicate that it’s protected by a copyright. Watermarks are used to discourage the use of images or video clips without the copyright holder’s explicit permission.

WAVE (or WAV) An audio file format most commonly used for storing uncompressed linear pulse code modulation (LPCM) audio data.

Waveform monitor A video scope in Final Cut Pro that displays the relative levels of luma and chroma in the clip currently being examined. Spikes and dips in the displayed waveforms correspond to light or dark areas in your picture. See also chroma, luma.

White-balance To make adjustments to a video signal being recorded in order to reproduce white as true white. For example, if the white in a shot is too yellow because of incandescent lighting, white-balancing adds enough blue to make the white appear neutral.

Widescreen Any movie presentation that has an aspect ratio wider than 4:3. In movie theaters, 1.85 is considered standard and 2.40 is considered widescreen. For video, 4:3 is considered standard and 16:9 (which is almost the same aspect ratio as 1.85) is considered widescreen. See also 4:3, 16:9.

Wipe A common type of video transition. In a wipe, the screen splits, moving from one side of the image to the other to gradually reveal the next shot. A wipe is more obvious (and customizable) than a fade or cross dissolve. See also cross dissolve, fade.

XDCAM A Sony optical disc format for recording DVCAM and IMX video within MXF container files. See also DVCAM, IMX, MXF.

XDCAM EX A member of the Sony XDCAM product family that uses MPEG-2 video compression with 4:2:0 chroma sampling. In contrast to XDCAM HD, XDCAM EX supports 720p and records full HD resolution (either 1920 x 1080 or 1280 x 720). Its maximum bit rate is 35 Mbps. Instead of optical discs, XDCAM EX camcorders use solid-state memory cards known as SxS cards. See also chroma, HDV.

XDCAM HD422 A member of the Sony XDCAM product family featuring 4:2:2 chroma sampling and a video bit rate of 50 Mbps. Like XDCAM EX, XDCAM HD422 uses MPEG-2 video compression at full HD resolution (either 1920 x 1080 or 1280 x 720). See also chroma, HDV.
Y'CbCr  The color space in which many digital video formats store data. Three components are stored for each pixel—one for luma (Y) and two for color information (Cb for the blue difference signal and Cr for the red difference signal). Also referred to as YUV. See also luma, pixel.

Zoom tool  The editing tool that allows you to zoom in to or out of the timeline. You can select the Zoom tool by pressing the Z key.