Using Score Sets to Create Scores and Parts

You can use score sets to determine which instrument tracks should be included in the score display. Each project can contain as many score sets as required. Score sets allow you to:

The Relationship Between Score Sets and Display Modes

A score set is only shown as defined if an appropriate display mode is chosen. Content Link and Content Catch only allow the display of one MIDI region at a time, making them unsuitable for work with score sets. It’s usually best to deselect Link, once the desired score set is fully displayed. If only one MIDI region is displayed, double-click below the staff, which displays the full score; then deselect Link.

Tip: It is possible to work with several open Score Editor windows, each showing different display levels or different score sets.

Choosing a Score Set

You choose a score set in the Inspector’s Score Set pop-up menu.

Figure. Score Set menu in the Inspector.

Click the menu to show all available score sets. New projects only show the All Instruments score set, which displays all instruments, depending on the display level.

Getting to Know the Score Set Window

You can create and edit score sets in the Score Set window.

To open the Score Set window
Do one of the following:
  • Choose the Open Score Set window command in the Score Set menu (or use the Open Score Set Window key command, default assignment:  Control-Option-Command-I).

  • Choose Layout > Score Sets in the Score Editor.

Note: If you open the Score Set window when the default All Instruments score set is chosen, a warning indicates that the All Instruments score set cannot be edited.

Figure. Score Set window.
Name of Score Set

You can edit the name of a score set by double-clicking the name in the left column of the Score Set window, which opens a text entry field.

Insert Mark

The narrow column to the left allows you to set an insert mark (>) with a mouse click, or make multiple selection marks by dragging vertically.


This column is used to determine which instruments are included in the score set, and their (vertical) order of appearance in the score. Track instrument icons are also displayed in this column, at the highest zoom level.

Figure Instrument column in the Score Set window.
Full Name

Click any line in this column to open an entry field that contains the default “@(reference).” If you don’t change this, the name of the track’s instrument is used as the name for the instrument in the score. As the track’s instrument name is often identical to the corresponding synthesizer patch (Solo Strings High, for example), you’ll probably want to assign another name here. This name is automatically displayed in the score as the full name:  “Violin 1,” for example. Display parameters for instrument names are set in the Numbers & Names pane of the Score project settings. (See Numbers & Names Settings.)

Short Name

You can also define an abbreviated name for each instrument, which is used if Short Names is chosen in the 1st Staff and Other Staffs pop-up menus of the Numbers & Names pane, in the Score project settings.

Figure. Instrument Names section of Numbers and Names pane.
Brackets and Bar Lines

You can define which staffs in the score set are connected by brackets or bar lines (either at the beginning of each staff, or throughout), in the last four columns. Any of these connections can be set by dragging vertically in the column, until you see the appropriate display.

Figure. Bracket line in the Score Set window.

Brackets and bar lines can also be interrupted between staffs, allowing you to form groups of connected instruments in a score. If you want to delete a line or bracket, grab the corresponding symbol at its end point (bottom), and drag it upward, until it disappears. You can use the same method to shorten lines.

Bar line connections can also be edited directly in the score. Click the upper end of a bar line to connect it to the next (higher) staff. Repeating the procedure disconnects the bar lines.

Creating and Deleting Score Sets

When you open a Score Editor window while several regions are selected in the Arrange area, Logic Pro automatically creates and displays a score set that only contains the instruments of the selected regions.

You can also use one of the following methods to create a score set manually.

To create an empty score set
  • Choose New > New Empty Set in the Score Set window.

    You can insert instruments into the empty score set, one by one.

To create a copy of the currently selected score set
  • Choose New > Duplicate Set in the Score Set window.

To create a score set for all selected instruments
  1. Select at least one MIDI region for all instrument tracks you want to include in the score set.

  2. Choose Layout > Create Score Set from Selection (or use the corresponding key command) in the Score Editor.

Logic Pro creates and displays a new score set, which consists of all instruments used by the currently selected MIDI regions.

Score sets created this way are automatically named after the instruments they contain.

To create a score set that contains all instrument tracks used in the Arrange window
  • In the Score Set window, choose New > New Complete Set.

    Tip: If several instruments or staffs use the same MIDI sound for playback (with the same MIDI channel on the same MIDI instrument), and you want to display these staffs with different instrument names in the score, you need to create a separate track instrument for each staff, in the Arrange area.

All score sets are saved with the project file.

To delete a score set
  • Select the score set in the Score Set window, then choose New > Delete Set.

Editing Score Sets

Once you have created a score set, you can change the assignment of instrument entries, add instruments, or change their order.

To assign another instrument to an existing score set entry
  • Click-hold the name of the instrument you want to replace in the Instrument column, then choose an instrument from the pop-up menu.

To add an instrument to the middle of the list
  • Set the insert mark to the desired position, then choose New > Add Instrument Entry.

A new instrument entry is added at the insert mark.

To add an instrument at the bottom of the list
  • Double-click below the instrument list.

A new instrument entry is added at the bottom of the list.

You can use the usual Cut, Copy, and Paste commands to reorder the instrument entries in a score set. If pasted, they are placed at the insert mark position, which must be set beforehand.

Scaling Score Sets

You can scale any score set to a size between 50 and 200 percent of its original size.

To scale a score set
  • Select the score set in the Score Set window, then set the Scale parameter to a new value.

Figure. Scale parameter in the Score Set window.

The Scale parameter affects:

  • All staffs

  • The distance between the staffs

  • All symbols associated with staffs (all notes, rests, and other symbols)

  • All local text, including lyrics

  • Slur and Tie thickness

The Scale parameter does not affect global text objects (header text, text inserted outside the margins) and text such as page numbers.

Scaling doesn’t take place on instrument parts that were created by Option-clicking the Score Set pop-up menu and choosing the instrument from the pop-up menu (as described below; see Filtering Single Instruments from the Score). As such, you can use the same staff styles for full scores and parts:  in extracted parts, the staffs appear at their original size; in the full score, their size is defined by the Scale parameter.

Note: The All Instruments set cannot be edited (and therefore, cannot be scaled), so you need to create a dedicated score set for the full score, in most cases.

Creating Separate Layouts for Full Score and Parts

You can set separate layout parameters for the full score and parts in the Global pane of the Score project settings. The Format parameter in the Score Set window determines which layout parameters a score set uses.

To create separate layout parameters for the full score and parts
  1. Open the Global Score project settings by choosing File > Project Settings > Score (or using the Open Score Project Settings key command), then click the Global tab.

    Figure. Global pane in the Score project settings.

    The Global pane offers separate page layout parameters for score and parts.

  2. Set the separate score and part layout parameters.

To determine the layout parameters used by a score set
  • In the Score Set window, choose a setting from the Format pop-up menu.

    Figure. Format menu in the Score Set window.

For the default All Instruments set, the score settings are always used, except when a single MIDI region is displayed. In this situation, the part settings are used.

Filtering Single Instruments from the Score

You can quickly extract a single instrument from the score, by choosing it from the pop-up menu that appears when you Option-click the Score Set pop-up menu.

This way, you don’t need to create a score set for every instrument in order to produce parts. You should note, however, that only the track instrument names are used as instrument names in the score. So, if you use this method for printout of your parts, you see the real instrument names of the Arrange window track instruments.

Importing Score Sets from Other Projects

You can import score sets from other projects.

To import score sets from other projects
  1. Do one of the following:

    • Choose File > Project Settings > Import Project Settings (or use the corresponding key command).

    • Click the Settings button in the Arrange toolbar, then choose Import Settings.

    • Click the Browser tab in the Media area.

  2. Navigate to, and select, the required project file.

  3. Click the Import button.

    Note: If accessing the settings from the Browser tab, you also need to click the Import Settings button, which appears after you click the Import button.

  4. In the Import Settings window, select the Score Sets checkbox (and deselect all other settings that you don’t want to import).

  5. Click the Import button.

All score sets are imported from another project into the current project.