General Batch Information

This section provides general information about submitting, saving, and opening batches.

Submitting a Batch

Once you have configured the jobs and their targets within a batch, you are ready to submit the batch for processing.

To submit a batch
  1. Make sure the batch to be submitted is selected in the Batch window.

  2. Do one of the following:

    • Choose File > Submit.

    • Click the Batch window’s Submit button.

    The submit dialog appears.

    Figure. The submit dialog.
  3. Check the Name field to confirm the batch name.

    You can change this name to something more meaningful about this batch. This is the name that is used for this submission in both Share Monitor and the History window.

  4. Use the Cluster pop-up menu to do one of the following: Use the Cluster pop-up menu to choose which computer or cluster will process the batch.

    • Choose This Computer: Compressor will not involve any other computers in completing the batch unless you select This Computer Plus, which creates an ad hoc cluster including This Computer and any available service nodes.

      See About This Computer Plus and Unmanaged Services for more information.

    • Choose a cluster: Compressor submits the batch to the cluster for processing (This Computer Plus is not available).

    You may need to authenticate yourself depending on the choice you make. See Apple Qmaster and Distributed Processing for more details.

  5. Use the Priority pop-up menu to choose priority level for the batch.

  6. Click Submit or press Enter to submit the batch for processing.

    The History window shows the batch progress. See About the History Window for more information.

    Note: The History window automatically opens if it is not already open.

You can also monitor the transcoding progress with Share Monitor by clicking its icon in the Batch window. For more information on Share Monitor, see the Share Monitor User Manual, available from the Share Monitor Help menu.

You can set Compressor preferences to automatically open Share Monitor. See Setting Compressor Preferences for more details.

Note: When submitting larger batches (for example, nine source media files with three settings assigned to each), there is about a 10-second delay after submitting the batch when nothing happens. Be patient. Compressor is preparing the large batch before it can be properly submitted for processing. If you are transcoding a large batch, you should turn off the screen saver application on your computer. This will improve the speed of your transcode because resources are not being diverted to the screen saver.

Once the batch has been submitted, a yellow triangle with an exclamation point appears in the batch.

Figure. Warning triangle and corresponding explanation window.

These warning symbols are used by Compressor whenever an issue exists with a batch. You can place the pointer over the symbol to see a tooltip defining why it is there, or you can click the symbol to open a dialog about it.

In the above case, since the batch has been submitted, this warning is to let you know that a file with that name now exists at that destination, and that if you submit again, that file will be overwritten.

You can bypass the submit dialog when submitting a batch. The submitted batch automatically uses the settings from the previously submitted batch.

To submit a batch using previous settings
Do one of the following:
  • Choose File > Submit with Previous Settings.

  • Click the “Submit with Previous Settings” item in the Batch window toolbar (if present).

See About the Batch Window for more information about using the Batch window.

Test Transcode Tip

Before committing to a long transcoding session, do a quick test with a small section of the source media file. If there is a problem (such as an incorrect setting or a reference file that can’t find the files it is referencing), you can make the correction without losing a lot of time. Such tests also allow you to preview Encoder pane and Frame Controls results that are not visible in the Preview window. For a quick way to select a small section of the source media file, see Transcoding a Portion of the Clip with the Preview Window.

Make sure the test section is specific to the type of settings you applied. For example, pick a high motion section if you’re doing frame rate or field order conversions with Frame Controls.

About the History Window

The History window provides quick access to all previously submitted batches, allowing you to conveniently resubmit batches by dragging them to the Batch window and view submission details about when particular job batches were submitted from your computer.

Figure. The History window.

The History window organizes its contents by the submission date. You can change the order in which the contents are sorted by clicking the Reverse Sort Order button along the bottom of the History window. You can also clear the contents of the History window by clicking the Clear button or remove selected items by selecting them and pressing the Delete key.

The History window can also show you the progress of a batch currently being transcoded.

Figure. History window showing disclosure triangle, progess bar, Cancel button, and Pause/Resume button.

Note: If it is closed, the History window automatically opens when you submit a batch.

Once the transcode finishes, the History window adds a button to make finding the encoded files easy.

Figure. "Reveal in Finder" button in the History window.

Resubmitting a Batch

All batch submission information is stored in the History window. This information includes the details about all of the batch’s jobs and targets, including which source media files were assigned to them. You can use this information to resubmit a batch simply by dragging a particular entry from the History window back to the Batch window.

To resubmit a batch submission from the History window
  1. Use the disclosure triangles to locate the batch submission to resubmit.

    Note: This is where giving the submission a recognizable name can help.

  2. Drag the submission from the History window to the Batch window.

    When you drag a batch from the History window to the Batch window, Compressor creates a new untitled tab in the Batch window for that batch. The batch appears in the new tab with all its original details (source media files, targets, assigned settings, destinations, output format, and batch name). You can now make any changes to the batch and resubmit it.

Saving and Opening a Batch File

There may be times when you configure a batch but are not able to submit it right away. In those cases, you may find it useful to save the batch settings for later reference.

To save a batch file
  1. Choose File > Save As (or press Command-Shift-S).

    A dialog opens to name the file and choose its destination.

  2. Enter a name for the file if you do not want to use the default name.

  3. Choose the destination for the file.

  4. Click Save.

    Batch filenames have a .compressor extension added to them.

Note: The .compressor extension appears in the Batch window tabs if Finder preferences are set to show all file extensions.

To open a batch file within Compressor
  1. Choose File > Open (or press Command-O).

    A dialog opens to select the batch file to open.

  2. Locate and select the batch file to open.

  3. Click Open.

You can also open a batch file by double-clicking it in the Finder, or by dragging the batch file to the Compressor application icon.

Note: An error message appears if Compressor cannot locate any of the source files listed in the batch file, and only those sources it finds will appear.

Transcoding Different Clips from One Source Media File

If you have a large source media file and you want to transcode only a few different sections of it, you can do this in one batch submission.

To transcode different clips from one source media file
  1. Open the Batch window.

  2. Import the source media file into a batch as many times as the number of clips you want to make.

    A new job is created each time you import the source media file.

  3. Add settings to each job.

    A unique identifier is applied to the output filename, so that you can easily identify each clip after it is transcoded.

    Figure. Unique identifiers applied to the output filenames.
  4. Do one of the following to open the Preview window:

    • Choose Window > Preview (or press Command-2).

    • Click the Preview button in the Batch window.

    The Preview window opens.

  5. Use the Batch Item selection buttons or pop-up menu to navigate to each media file you want to transcode.

  6. Drag the In and Out points to the first relevant section of the media file, and repeat for the next media file by dragging its In and Out points to the next relevant section of the media file.

    You can also use the I (In) and O (Out) keys to move the markers to the current location of the playhead.

    Figure. In and Out points in the Preview window.
  7. Return to the Batch window and click Submit.

See About the Preview Window for more information.