Quick and Easy Compressor Workflow: Manual Method

The following workflow shows you an easy way to manually build and process a batch in Compressor.

Stage 1: Adding Source Media Files

To use Compressor, you must first add source media files to the Batch window.

To open Compressor and add source media files to the Batch window
  1. Double-click the Compressor icon in the Applications folder.

    Compressor opens with the Batch Template Chooser and an empty untitled batch with a placeholder job.

    Figure. Default Compressor window layout, including the Template Chooser and an empty untitled batch window.
  2. Since this workflow is focused on the manual method rather than the batch template method, click Cancel in the Batch Template Chooser to close it.

    To prevent the Batch Template Chooser from opening in the future, select “Don’t show this dialog again,” or, in Compressor preferences, select Use Blank Template.

    For information about the batch template method, see Quick and Easy Compressor Workflow: Batch Template Method.

    The figure below shows the remaining windows in the Compressor interface.

    Figure. Default Compressor window layout, without the Template Chooser, and an empty untitled batch window.

    Note: To see the Compressor interface configured similarly to what is shown above, choose a Standard layout from the Layouts submenu of the Window menu.

  3. Drag one or more source files from the Finder or the desktop to an empty area in the Batch window (in this example, just below the empty job).

    Note: If you drag multiple files to the empty job, only the last file is added to this job and all other files are ignored.

    Figure. Compressor Batch window, with source files being dragged to it.

    New jobs are created for each source file you dragged to the batch.

    Figure. New job in Batch window.

    See About the Batch Window for more information about the controls in the Batch window.

Stage 2: Assigning Settings and Destinations

You need to assign at least one setting to each source media file job before you can submit the batch for processing, but you can also add multiple settings to the same job to transcode multiple versions of the media file. Each setting-destination pair is known in Compressor as a target.

To assign a setting and a destination to a job
  1. Choose a setting for your source media file jobs in any of the following ways.

    • To assign different settings to different jobs: Drag settings from the Settings tab to individual jobs in the Batch window.
      Figure. Settings being dragged from the Settings tab to a job in the Batch window.
    • To assign a single setting to multiple selected jobs: Select the jobs (source media files) in the Batch window and choose Target > New Target With Setting. This opens a settings selection dialog over the Batch window.
      Figure. Multiple settings selected in the Settings tab and multiple jobs selected in the Batch window.

      Choose one or more settings, using the disclosure triangles to reveal individual settings, and click Add. The chosen settings are assigned to all the selected jobs.

      Figure. The settings assigned to the selected jobs in the Batch window.

      You can also choose Edit > Select All to select all the jobs before applying the settings. See Creating, Previewing, and Modifying Settings for more information on settings, and Finalizing Jobs and Submitting Batches for more information about working with jobs and targets.

      The next step is to set the destination. By default, the destination is set to Source, which writes the output files to the same folder as the source files originated from. You can change the destination for organization purposes or to take advantage of larger and faster hard disks.

      Note: You can choose a default destination from the Compressor Preferences window. See Setting Compressor Preferences for more information.

      You can set the destination for each individual target or for a selected group of targets.

  2. Choose a destination for your job’s targets in one of the following ways.

    • Do nothing: Accept the default destination Source (the same folder as the source media files originated from) specified in the Destination column.
    • Use the target’s shortcut menu to change one setting at a time: Control-click the target you want to change and then choose any of the preexisting destinations available to you from the Destination submenu.
      Figure. Destination submenu in the target shortcut menu.

    You can also choose Other from the shortcut menu to open a dialog to choose any location available to your computer as the destination.

    Note: Choosing Other allows you to choose any location currently accessible from your desktop, including a mounted open volume. However, this volume must remain open until the batch has been transcoded.

    You can select multiple targets and change all their destinations at once using the same method. You can also use the Destination submenu of the target’s shortcut menu to choose a destination, or drag a destination from the Destinations tab to the target.

    See Creating and Changing Destinations for more information on destinations.

  3. You can name the batch, and save it, by choosing File > Save.

Stage 3: Submitting the Batch

Once each media file has at least one setting and destination associated with it, it becomes a job, and your batch is ready to be submitted.

To submit a batch for processing
  • Click Submit.

A dialog appears where you can name this submission, choose whether to use distributed processing, and set the priority of this submission. In most cases you can leave the settings as they are and just click Submit.

Figure. Submit dialog.

For more details about this Submit dialog, see Submitting a Batch.

After you submit a batch, you can open Share Monitor so you can monitor the transcoding progress of your batch. You can also set Share Monitor to automatically open in the Compressor Preferences window.

Note: You can always open Share Monitor by double-clicking the Share Monitor icon in the Dock or by clicking its icon in the Batch window.

Figure. Share Monitor window.

You can also monitor the encoding progress in the History window.

Figure. History window.

See Finalizing Jobs and Submitting Batches for more information on jobs and batches.